Telerik.WebAii.Controls.Html Namespace

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
Telerik.WebAii.Controls.Html Namespace
Send Feedback
Contains the WebAii RadControls for ASP.NET AJAX.

Classes

Class | Description
CalendarConstants | The calendar string constants.
CalendarFastNavigationPopup | Represents the RadCalendar for ASP.NET AJAX fast navigation popup control wrapper.
ColorPickerConstants | String constatns of the colorpicker(Css classes, Id prefix, etc).
ColorPickerIcon | The icon of the RadColorpicker.
ColorPickerPalette | The palette of the RadColorPicker.
ComboBoxConstants | Represents the RadComboBox constants class.
CommonHelper | Represents a common helper class.
DataPagerConstants | The ListView string constants.
EditorCommand | RadEditor for the ASP.NET AJAX: EditorCommand wrapper.
EditorConstants | String constatns of the editor(Css classes, Id prefix, etc).
EditorDropDown | RadEditor for the ASP.NET AJAX: EditorDropDown wrapper.
EditorDropDownBody | RadEditor for the ASP.NET AJAX: EditorDropDownBody wrapper.
EditorModeCommand | RadEditor for the ASP.NET AJAX: EditorModeCommand wrapper.
EditorSpinBox | RadEditor for the ASP.NET AJAX: EditorSpinBox wrapper.
EditorSplitButton | RadEditor for the ASP.NET AJAX: EditorSplitButton wrapper.
GridConstants | The Grid constants used in the verifications and action messages.
GridDataCell | Represents the RadGrid for ASP.NET AJAX data cell control wrapper.
GridDataItem | Represents the RadGrid for ASP.NET AJAX data item control wrapper.
GridEditForm | Represents the RadGrid for ASP.NET AJAX edit form control wrapper.
GridFilterItem | Represents the RadGrid for ASP.NET AJAX filter item control wrapper.
GridFooterCell | Represents the RadGrid for ASP.NET AJAX footer cell control wrapper.
GridGroupHeader | Represents the RadGrid for ASP.NET AJAX group header control wrapper.
GridGroupPanel | Represents the RadGrid for ASP.NET AJAX group panel control wrapper.
GridGroupPanelItem | Represents the RadGrid for ASP.NET AJAX group panel item control wrapper.
GridHelper | A helper class for the RadGrid wrapper.
GridPager | Represents the RadGrid for ASP.NET AJAX pager control wrapper.
GridTableHeader | Represents the RadGrid for ASP.NET AJAX table header control wrapper.
GridTableView | Represents the RadGrid for ASP.NET AJAX TableView control wrapper.
InputConstants | The RadInput constants used across the source classes.
ListBoxConstants | Represents the ListBoxConstants class.
ListViewConstants | The ListView string constants.
MenuConstants | Represents the menu constants class.
PanelBarConstants | Represents the PanelBar constants class.
RadCalendar | Represents the RadCalendar for ASP.NET AJAX control wrapper.
RadColorPicker | RadColorPicker control.
RadComboBox | Represents the RadComboBox class.
RadComboBoxItem | Represents the RadComboBoxItem class.
RadControlAssert | Represents the base class for assertion of RadControls wrappers.
RadDataPager | Represents RadDataPager for Asp.Net Ajax control wrapper.
RadDateInput | Represents the RadDateInput for ASP.NET AJAX control wrapper.
RadDatePicker | Represents the RadDatePicker for ASP.NET AJAX control wrapper.
RadDateTimePicker | Represents the RadDateTimePicker for ASP.NET AJAX control wrapper.
RadEditor | A simple control wrapper for the RadEditor for the ASP.NET AJAX.
RadGrid | Represents the RadGrid for ASP.NET AJAX control wrapper.
RadInput | Represents the RadCalendar for ASP.NET AJAX control wrapper.
RadInputManager | Represents the RadInputManager for ASP.NET AJAX control wrapper.
RadInputManagerTextBox | Represents the TextBox extended with RadInputManager for ASP.NET AJAX control wrapper.
RadListBox | Represents the RadListBox class.
RadListBoxItem | Represents the RadListBoxItem class.
RadListView | Represents RadListView for Asp.Net Ajax control wrapper.
RadMaskedTextBox | Represents the RadMaskedTextBox for ASP.NET AJAX control wrapper.
RadMenu | Represents the RadMenu class.
RadMenuItem | Represents the RadMenuItem class.
RadNumericTextBox | Represents the RadNumericTextBox for ASP.NET AJAX control wrapper.
RadPane | The RadPane of the RadSplitter.
RadPanelBar | Represents the RadPanelBar class.
RadPanelBarItem | Represents the RadPanelBarItem class.
RadPicker | Represents the RadDate/DateTime/TimePicker for ASP.NET AJAX control wrapper.
RadRotator | RadRotator control.
RadScheduler | A simple control wrapper for the scheduler Control.
RadSlider | RadSlider control.
RadSlidingPane | The sliding pane of Radsplitter.
RadSlidingZone | RadSlidingZone of the RadSplitter.
RadSpellDialog | The content of Radspell dialog window.
RadSplitBar | The splitbar of the RadSplitter.
RadSplitter | RadSplitter control.
RadTab | Represents the RadTab class.
RadTabStrip | Represents the RadTabStrip class.
RadTextBox | The HtmlControl wrapper for RadTextBox.
RadTimePicker | Represents the RadTimePicker for ASP.NET AJAX control wrapper.
RadTimeView | Represents the RadDateTimePicker/RadTimePicker for ASP.NET AJAX TimeView control wrapper.
RadToolBar | Represents the RadToolBar class.
RadToolBarButton | Represents the RadToolBarButton class.
RadToolBarDropDownButton | Represents the RadToolBarDropDownButton class.
RadToolBarItem | Represents the RadToolBarItem class.
RadToolBarSplitButton | Represents the RadToolBar SplitButton control wrapper.
RadToolTip | RadToolTip control.
RadTreeNode | Represents the RadTreeNode class.
RadTreeView | Represents the RadTreeView class.
RadUpload | Represents the RadUpload class.
RadWindow | RadWindow control.
RotatorConstants | String constatns of the rotator(Css classes, Id prefix, etc).
SchedulerAppointment | Class that represents the scheduler appointment object.
SchedulerConstants | Represents the scheduler constants class.
SchedulerTimeSlot | Represents the SchedulerTimeSlot class.
SelectedDateCollection | Represents a custom collection of DateTime objects, serving as return type of RadCalendar wrapper properties and methods.
SliderConstants | String constatns of the slider(Css classes, Id prefix, etc).
SpellConstants | String constatns of the radspell(Css classes, Id prefix, etc).
SplitterConstants | String constatns of the splitter(Css classes, Id prefix, etc).
TabStripConstants | The TabStrip constants class.
ToolBarConstants | Class that represents toolbar constants.
ToolTipConstants | String constatns of the tooltip(Css classes, Id prefix, etc).
TreeViewConstants | Represents the treeview constants class.
UploadConstants | Represents the upload constants class.
WindowConstants | String constatns of the window(Css classes, Id prefix, etc).

Enumerations

Enumeration | Description
CalendarPresentationType | Enumerates the PresentationType settings of the calendar.
EditorActionType | Editor action type enumeration.
EditorMode | Editor mode enumeration.
EditorSpinBoxActionType | Action type enumeration of the editor spinbox.
EditorSplitButtonActionType | Action types enumeration of the editor splitbutton.
EditorToolBarMode | Editor toolbar mode enumeration.
GridAdvancedPagerActionType | Enumerates the Grid advanced pager action type.
GridColumnSortOrderType | Enumerates the Grid column sort order type.
GridCommandItemLocation | Enumerates the Grid command item lcation -- either 'top' or 'bottom' command item.
GridCommandItemType | Enumerates the Grid command item type. The standard 'AddNew' and 'Refresh' are supported.
GridEditFormActionType | Enumerates the Grid edit form action type.
GridEditModeType | Enumerates the Grid edit mode type.
GridGroupExpandCollapseActionType | Enumerates the Grid group expand/collapse action type.
ListBoxButtonPosition | Type of listbox button position.
MenuOrientationType | Type of menu orientation type.
PredefinedLayoutType | Enumerates the predefined layouts of the ListView.
RadInputControlType | Control type of the Input.
RadPickerControlType | Enumerates the different picker types.
RotatorScrollDirection | Rotator scroll direction enumeration.
RotatorScrollType | Rotator scroll type enumeration.
RotatorType | The type of approach, that changes the icons of rotaror.
SchedulerViewNavigationType | Type of scheduler view navigarion.
SliderDirection | Slider direction.
SliderOrientation | Slider orientation enumeration.
SlidingPaneActionType | Action type enumeration of the splitter sliding pane.
SplitBarActionType | Action type enumeration of the splitbar.
SplitBarCollapseDirection | The direction of the splitbar collapsing.
SplitterOrientation | Splitter orientation enumeration.
SplitterPaneType | Splitter pane type: Previous(Left or Upper) or Next(Right or Down).
SplitterSlideDirection | Splitter slide direction enumeration.
TabStripOrientationType | Type of scheduler view navigarion.
ToolBarButtonType | The ToolBar button type.
ToolBarOrientationType | ToolBar orientation.
ToolTipHideMode | Tooltip hide mode enumeration.
ToolTipRelativeToMode | Tooltip RelativeTo mode enumeration.
ToolTipShowMode | Tooltip show mode enumeration.


CalendarConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants Class
Members See Also Send Feedback
The calendar string constants.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class CalendarConstants
Visual Basic (Declaration)
Public NotInheritable Class CalendarConstants
Visual C++
public ref class CalendarConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.CalendarConstants

See Also

CalendarConstants Members
Telerik.WebAii.Controls.Html Namespace


CalendarConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants Members
CalendarConstants Class Fields See Also Send Feedback

The CalendarConstants type exposes the following members.

Fields

Name | Description
CalendarKey | The Calendar key.
ColumnHeaderCellId | The ID of the ColumnHeader cell.
CssDatePopupButton | The CSS class of the calendar popup button.
CssDisabled | The disabled CSS class.
CssFastNavigationPopup | The CSS class of the fast navigation popup div element.
CssFastNextButton | The CSS class of the fast next button.
CssFastPreviousButton | The CSS class of the fast previous button.
CssNextButton | The CSS class of the next button.
CssOutOfRange | The out of range CSS class.
CssPreviousButton | The CSS class of the previous button.
CssRadCalendar | The CSS class of the RadCalendar table.
CssTimePopupButton | The CSS class of the TimeView popup button.
CssTitleBar | The CSS class of the title bar.
CssTitleCell | The CSS class of the title cell.
CssViewSelector | The CSS class of the calendar's ViewSelector.
DatePickerKey | The RadDatePicker key.
DateTimePickerKey | The RadDateTimePicker key.
FastNavigationCancelButtonId | The Id of the fast navigation 'Cancel' button.
FastNavigationKey | The Fast Navigation key.
FastNavigationNextButtonId | The Id of the fast navigation 'Next' button.
FastNavigationOkButtonId | The Id of the fast navigation 'Ok' button.
FastNavigationPreviousButtonId | The Id of the fast navigation 'Previous' button.
FastNavigationTodayButtonId | The Id of the fast navigation 'Today' button.
FastNextButtonId | The ID of the fast next button.
FastPreviousButtonId | The ID of the fast previous button.
NextButtonId | The ID of the next button.
PickerKey | The Picker key.
PreviousButtonId | The ID of the previous button.
RowHeaderCellId | The ID of the RowHeader cell.
TimePickerKey | The RadTimePicker key.
TimeViewKey | The TimeView key.

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants Fields
CalendarConstants Class See Also Send Feedback

The CalendarConstants type exposes the following members.

Fields

Name | Description
CalendarKey | The Calendar key.
ColumnHeaderCellId | The ID of the ColumnHeader cell.
CssDatePopupButton | The CSS class of the calendar popup button.
CssDisabled | The disabled CSS class.
CssFastNavigationPopup | The CSS class of the fast navigation popup div element.
CssFastNextButton | The CSS class of the fast next button.
CssFastPreviousButton | The CSS class of the fast previous button.
CssNextButton | The CSS class of the next button.
CssOutOfRange | The out of range CSS class.
CssPreviousButton | The CSS class of the previous button.
CssRadCalendar | The CSS class of the RadCalendar table.
CssTimePopupButton | The CSS class of the TimeView popup button.
CssTitleBar | The CSS class of the title bar.
CssTitleCell | The CSS class of the title cell.
CssViewSelector | The CSS class of the calendar's ViewSelector.
DatePickerKey | The RadDatePicker key.
DateTimePickerKey | The RadDateTimePicker key.
FastNavigationCancelButtonId | The Id of the fast navigation 'Cancel' button.
FastNavigationKey | The Fast Navigation key.
FastNavigationNextButtonId | The Id of the fast navigation 'Next' button.
FastNavigationOkButtonId | The Id of the fast navigation 'Ok' button.
FastNavigationPreviousButtonId | The Id of the fast navigation 'Previous' button.
FastNavigationTodayButtonId | The Id of the fast navigation 'Today' button.
FastNextButtonId | The ID of the fast next button.
FastPreviousButtonId | The ID of the fast previous button.
NextButtonId | The ID of the next button.
PickerKey | The Picker key.
PreviousButtonId | The ID of the previous button.
RowHeaderCellId | The ID of the RowHeader cell.
TimePickerKey | The RadTimePicker key.
TimeViewKey | The TimeView key.

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CalendarKey Field
CalendarConstants Class See Also Send Feedback
The Calendar key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CalendarKey
Visual Basic (Declaration)
Public Const CalendarKey As String
Visual C++
public:
literal String^ CalendarKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderCellId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.ColumnHeaderCellId Field
CalendarConstants Class See Also Send Feedback
The ID of the ColumnHeader cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColumnHeaderCellId
Visual Basic (Declaration)
Public Const ColumnHeaderCellId As String
Visual C++
public:
literal String^ ColumnHeaderCellId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDatePopupButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssDatePopupButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the calendar popup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssDatePopupButton
Visual Basic (Declaration)
Public Const CssDatePopupButton As String
Visual C++
public:
literal String^ CssDatePopupButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDisabled Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssDisabled Field
CalendarConstants Class See Also Send Feedback
The disabled CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssDisabled
Visual Basic (Declaration)
Public Const CssDisabled As String
Visual C++
public:
literal String^ CssDisabled

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFastNavigationPopup Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssFastNavigationPopup Field
CalendarConstants Class See Also Send Feedback
The CSS class of the fast navigation popup div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssFastNavigationPopup
Visual Basic (Declaration)
Public Const CssFastNavigationPopup As String
Visual C++
public:
literal String^ CssFastNavigationPopup

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFastNextButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssFastNextButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the fast next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssFastNextButton
Visual Basic (Declaration)
Public Const CssFastNextButton As String
Visual C++
public:
literal String^ CssFastNextButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFastPreviousButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssFastPreviousButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the fast previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssFastPreviousButton
Visual Basic (Declaration)
Public Const CssFastPreviousButton As String
Visual C++
public:
literal String^ CssFastPreviousButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNextButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssNextButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNextButton
Visual Basic (Declaration)
Public Const CssNextButton As String
Visual C++
public:
literal String^ CssNextButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssOutOfRange Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssOutOfRange Field
CalendarConstants Class See Also Send Feedback
The out of range CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssOutOfRange
Visual Basic (Declaration)
Public Const CssOutOfRange As String
Visual C++
public:
literal String^ CssOutOfRange

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPreviousButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssPreviousButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPreviousButton
Visual Basic (Declaration)
Public Const CssPreviousButton As String
Visual C++
public:
literal String^ CssPreviousButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadCalendar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssRadCalendar Field
CalendarConstants Class See Also Send Feedback
The CSS class of the RadCalendar table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadCalendar
Visual Basic (Declaration)
Public Const CssRadCalendar As String
Visual C++
public:
literal String^ CssRadCalendar

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTimePopupButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssTimePopupButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the TimeView popup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTimePopupButton
Visual Basic (Declaration)
Public Const CssTimePopupButton As String
Visual C++
public:
literal String^ CssTimePopupButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTitleBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssTitleBar Field
CalendarConstants Class See Also Send Feedback
The CSS class of the title bar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTitleBar
Visual Basic (Declaration)
Public Const CssTitleBar As String
Visual C++
public:
literal String^ CssTitleBar

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTitleCell Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssTitleCell Field
CalendarConstants Class See Also Send Feedback
The CSS class of the title cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTitleCell
Visual Basic (Declaration)
Public Const CssTitleCell As String
Visual C++
public:
literal String^ CssTitleCell

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssViewSelector Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.CssViewSelector Field
CalendarConstants Class See Also Send Feedback
The CSS class of the calendar's ViewSelector.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssViewSelector
Visual Basic (Declaration)
Public Const CssViewSelector As String
Visual C++
public:
literal String^ CssViewSelector

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


DatePickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.DatePickerKey Field
CalendarConstants Class See Also Send Feedback
The RadDatePicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DatePickerKey
Visual Basic (Declaration)
Public Const DatePickerKey As String
Visual C++
public:
literal String^ DatePickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


DateTimePickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.DateTimePickerKey Field
CalendarConstants Class See Also Send Feedback
The RadDateTimePicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DateTimePickerKey
Visual Basic (Declaration)
Public Const DateTimePickerKey As String
Visual C++
public:
literal String^ DateTimePickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationCancelButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNavigationCancelButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Cancel' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNavigationCancelButtonId
Visual Basic (Declaration)
Public Const FastNavigationCancelButtonId As String
Visual C++
public:
literal String^ FastNavigationCancelButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNavigationKey Field
CalendarConstants Class See Also Send Feedback
The Fast Navigation key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNavigationKey
Visual Basic (Declaration)
Public Const FastNavigationKey As String
Visual C++
public:
literal String^ FastNavigationKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationNextButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNavigationNextButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Next' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNavigationNextButtonId
Visual Basic (Declaration)
Public Const FastNavigationNextButtonId As String
Visual C++
public:
literal String^ FastNavigationNextButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationOkButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNavigationOkButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Ok' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNavigationOkButtonId
Visual Basic (Declaration)
Public Const FastNavigationOkButtonId As String
Visual C++
public:
literal String^ FastNavigationOkButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationPreviousButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNavigationPreviousButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Previous' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNavigationPreviousButtonId
Visual Basic (Declaration)
Public Const FastNavigationPreviousButtonId As String
Visual C++
public:
literal String^ FastNavigationPreviousButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationTodayButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNavigationTodayButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Today' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNavigationTodayButtonId
Visual Basic (Declaration)
Public Const FastNavigationTodayButtonId As String
Visual C++
public:
literal String^ FastNavigationTodayButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNextButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastNextButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the fast next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastNextButtonId
Visual Basic (Declaration)
Public Const FastNextButtonId As String
Visual C++
public:
literal String^ FastNextButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastPreviousButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.FastPreviousButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the fast previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FastPreviousButtonId
Visual Basic (Declaration)
Public Const FastPreviousButtonId As String
Visual C++
public:
literal String^ FastPreviousButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


NextButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.NextButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string NextButtonId
Visual Basic (Declaration)
Public Const NextButtonId As String
Visual C++
public:
literal String^ NextButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


PickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.PickerKey Field
CalendarConstants Class See Also Send Feedback
The Picker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PickerKey
Visual Basic (Declaration)
Public Const PickerKey As String
Visual C++
public:
literal String^ PickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


PreviousButtonId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.PreviousButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PreviousButtonId
Visual Basic (Declaration)
Public Const PreviousButtonId As String
Visual C++
public:
literal String^ PreviousButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderCellId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.RowHeaderCellId Field
CalendarConstants Class See Also Send Feedback
The ID of the RowHeader cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RowHeaderCellId
Visual Basic (Declaration)
Public Const RowHeaderCellId As String
Visual C++
public:
literal String^ RowHeaderCellId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


TimePickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.TimePickerKey Field
CalendarConstants Class See Also Send Feedback
The RadTimePicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimePickerKey
Visual Basic (Declaration)
Public Const TimePickerKey As String
Visual C++
public:
literal String^ TimePickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


TimeViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarConstants..::.TimeViewKey Field
CalendarConstants Class See Also Send Feedback
The TimeView key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeViewKey
Visual Basic (Declaration)
Public Const TimeViewKey As String
Visual C++
public:
literal String^ TimeViewKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Class
Members See Also Send Feedback
Represents the RadCalendar for ASP.NET AJAX fast navigation popup control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class CalendarFastNavigationPopup : HtmlContainerControl
Visual Basic (Declaration)
Public Class CalendarFastNavigationPopup _
    Inherits HtmlContainerControl
Visual C++
public ref class CalendarFastNavigationPopup : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.CalendarFastNavigationPopup

See Also

CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Members
CalendarFastNavigationPopup Class Constructors Methods Properties See Also Send Feedback

The CalendarFastNavigationPopup type exposes the following members.

Constructors

Name | Description
CalendarFastNavigationPopup | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ClickCancel | Clicks on the Cancel button.
ClickOk | Clicks on the Ok button.
ClickToday | Clicks on the Today button.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
NextYears | Navigates to next years.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
PreviousYears | Navigates to previous years.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectMonth | Selects a month.
SelectYear | Selects an year.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the navigation popup. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FirstYear | Gets the firt year which the popup is displaying.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsFastNavigationOpen | Gets the visibility of the popup.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
LastYear | Gets the last year which the popup is displaying.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedMonth | Gets the selected month string of the popup.
SelectedYear | Gets the selected year of the popup.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Constructor
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
CalendarFastNavigationPopup()()() | Initializes a new instance of the CalendarFastNavigationPopup class.
CalendarFastNavigationPopup(Element) | Initializes a new instance of the CalendarFastNavigationPopup class. Create the control.

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Constructor
CalendarFastNavigationPopup Class See Also Send Feedback
Initializes a new instance of the CalendarFastNavigationPopup class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarFastNavigationPopup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarFastNavigationPopup()

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Overload
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Constructor (Element)
CalendarFastNavigationPopup Class See Also Send Feedback
Initializes a new instance of the CalendarFastNavigationPopup class. Create the control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarFastNavigationPopup(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
CalendarFastNavigationPopup(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.CalendarFastNavigationPopup.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Overload
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Methods
CalendarFastNavigationPopup Class See Also Send Feedback

The CalendarFastNavigationPopup type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ClickCancel | Clicks on the Cancel button.
ClickOk | Clicks on the Ok button.
ClickToday | Clicks on the Today button.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
NextYears | Navigates to next years.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
PreviousYears | Navigates to previous years.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectMonth | Selects a month.
SelectYear | Selects an year.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.AssignElement Method
CalendarFastNavigationPopup Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.CallMethod Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.Capture Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.Click Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


ClickCancel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.ClickCancel Method
CalendarFastNavigationPopup Class See Also Send Feedback
Clicks on the Cancel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClickCancel()
Visual Basic (Declaration)
Public Sub ClickCancel
Visual C++
public:
void ClickCancel()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ClickOk Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.ClickOk Method
CalendarFastNavigationPopup Class See Also Send Feedback
Clicks on the Ok button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClickOk()
Visual Basic (Declaration)
Public Sub ClickOk
Visual C++
public:
void ClickOk()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ClickToday Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.ClickToday Method
CalendarFastNavigationPopup Class See Also Send Feedback
Clicks on the Today button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClickToday()
Visual Basic (Declaration)
Public Sub ClickToday
Visual C++
public:
void ClickToday()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.DragTo Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.GetValue Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.InvokeEvent Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.MouseClick Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.MouseHover Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


NextYears Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.NextYears Method
CalendarFastNavigationPopup Class See Also Send Feedback
Navigates to next years.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NextYears()
Visual Basic (Declaration)
Public Sub NextYears
Visual C++
public:
void NextYears()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


PreviousYears Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.PreviousYears Method
CalendarFastNavigationPopup Class See Also Send Feedback
Navigates to previous years.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void PreviousYears()
Visual Basic (Declaration)
Public Sub PreviousYears
Visual C++
public:
void PreviousYears()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.ScrollToVisible Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


SelectMonth Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.SelectMonth Method
CalendarFastNavigationPopup Class See Also Send Feedback
Selects a month.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectMonth(
    string month
)
Visual Basic (Declaration)
Public Sub SelectMonth ( _
    month As String _
)
Visual C++
public:
void SelectMonth(
    String^ month
)

Parameters

month
Type: System..::.String
The month string.

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


SelectYear Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.SelectYear Method
CalendarFastNavigationPopup Class See Also Send Feedback
Selects an year.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectYear(
    string year
)
Visual Basic (Declaration)
Public Sub SelectYear ( _
    year As String _
)
Visual C++
public:
void SelectYear(
    String^ year
)

Parameters

year
Type: System..::.String
The year string.

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.SetValue Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup Properties
CalendarFastNavigationPopup Class See Also Send Feedback

The CalendarFastNavigationPopup type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the navigation popup. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FirstYear | Gets the firt year which the popup is displaying.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsFastNavigationOpen | Gets the visibility of the popup.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
LastYear | Gets the last year which the popup is displaying.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedMonth | Gets the selected month string of the popup.
SelectedYear | Gets the selected year of the popup.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.ClientSideLocator Property
CalendarFastNavigationPopup Class See Also Send Feedback
The client-side locator of the navigation popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


FirstYear Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.FirstYear Property
CalendarFastNavigationPopup Class See Also Send Feedback
Gets the firt year which the popup is displaying.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int FirstYear { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstYear As Integer
Visual C++
public:
property int FirstYear {
    int get ();
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


IsFastNavigationOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.IsFastNavigationOpen Property
CalendarFastNavigationPopup Class See Also Send Feedback
Gets the visibility of the popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFastNavigationOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFastNavigationOpen As Boolean
Visual C++
public:
property bool IsFastNavigationOpen {
    bool get ();
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


LastYear Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.LastYear Property
CalendarFastNavigationPopup Class See Also Send Feedback
Gets the last year which the popup is displaying.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int LastYear { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastYear As Integer
Visual C++
public:
property int LastYear {
    int get ();
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.LocatorExpression Property
CalendarFastNavigationPopup Class See Also Send Feedback
Get the item locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


SelectedMonth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.SelectedMonth Property
CalendarFastNavigationPopup Class See Also Send Feedback
Gets the selected month string of the popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedMonth { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedMonth As String
Visual C++
public:
property String^ SelectedMonth {
    String^ get ();
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


SelectedYear Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarFastNavigationPopup..::.SelectedYear Property
CalendarFastNavigationPopup Class See Also Send Feedback
Gets the selected year of the popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectedYear { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedYear As Integer
Visual C++
public:
property int SelectedYear {
    int get ();
}

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


CalendarPresentationType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPresentationType Enumeration
See Also Send Feedback
Enumerates the PresentationType settings of the calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum CalendarPresentationType
Visual Basic (Declaration)
Public Enumeration CalendarPresentationType
Visual C++
public enum class CalendarPresentationType

Members

Member name | Description
Preview | Preview presentation type.
Interactive | Interactive presentation type.

See Also

Telerik.WebAii.Controls.Html Namespace


ColorPickerConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants Class
Members See Also Send Feedback
String constatns of the colorpicker(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ColorPickerConstants
Visual Basic (Declaration)
Public NotInheritable Class ColorPickerConstants
Visual C++
public ref class ColorPickerConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.ColorPickerConstants

See Also

ColorPickerConstants Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants Members
ColorPickerConstants Class Fields See Also Send Feedback

The ColorPickerConstants type exposes the following members.

Fields

Name | Description
CssColorBox | The CSS class identifying the ColorPicker's colorbox element.
CssColorPicker | The CSS class identifying the ColorPicker control.
CssColorPickerIcon | The CSS class identifying the ColorPickerIcon control.
CssColorPickerPalette | The CSS class identifying the ColorPickerPalette control.
CssEmptyColor | The CSS class identifying the ColorPicker's "No color" element.
CssSelectedColor | The CSS class identifying the ColorPicker's selected color element.
IconKey | The key identifying the ColorPicker Icon.
PaletteKey | The key identifying the ColorPicker Palette.

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants Fields
ColorPickerConstants Class See Also Send Feedback

The ColorPickerConstants type exposes the following members.

Fields

Name | Description
CssColorBox | The CSS class identifying the ColorPicker's colorbox element.
CssColorPicker | The CSS class identifying the ColorPicker control.
CssColorPickerIcon | The CSS class identifying the ColorPickerIcon control.
CssColorPickerPalette | The CSS class identifying the ColorPickerPalette control.
CssEmptyColor | The CSS class identifying the ColorPicker's "No color" element.
CssSelectedColor | The CSS class identifying the ColorPicker's selected color element.
IconKey | The key identifying the ColorPicker Icon.
PaletteKey | The key identifying the ColorPicker Palette.

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.CssColorBox Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker's colorbox element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssColorBox
Visual Basic (Declaration)
Public Const CssColorBox As String
Visual C++
public:
literal String^ CssColorBox

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorPicker Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.CssColorPicker Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssColorPicker
Visual Basic (Declaration)
Public Const CssColorPicker As String
Visual C++
public:
literal String^ CssColorPicker

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorPickerIcon Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.CssColorPickerIcon Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPickerIcon control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssColorPickerIcon
Visual Basic (Declaration)
Public Const CssColorPickerIcon As String
Visual C++
public:
literal String^ CssColorPickerIcon

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorPickerPalette Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.CssColorPickerPalette Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPickerPalette control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssColorPickerPalette
Visual Basic (Declaration)
Public Const CssColorPickerPalette As String
Visual C++
public:
literal String^ CssColorPickerPalette

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEmptyColor Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.CssEmptyColor Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker's "No color" element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEmptyColor
Visual Basic (Declaration)
Public Const CssEmptyColor As String
Visual C++
public:
literal String^ CssEmptyColor

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectedColor Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.CssSelectedColor Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker's selected color element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSelectedColor
Visual Basic (Declaration)
Public Const CssSelectedColor As String
Visual C++
public:
literal String^ CssSelectedColor

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


IconKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.IconKey Field
ColorPickerConstants Class See Also Send Feedback
The key identifying the ColorPicker Icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IconKey
Visual Basic (Declaration)
Public Const IconKey As String
Visual C++
public:
literal String^ IconKey

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


PaletteKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerConstants..::.PaletteKey Field
ColorPickerConstants Class See Also Send Feedback
The key identifying the ColorPicker Palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaletteKey
Visual Basic (Declaration)
Public Const PaletteKey As String
Visual C++
public:
literal String^ PaletteKey

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Class
Members See Also Send Feedback
The icon of the RadColorpicker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ColorPickerIcon : HtmlContainerControl
Visual Basic (Declaration)
Public Class ColorPickerIcon _
    Inherits HtmlContainerControl
Visual C++
public ref class ColorPickerIcon : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.ColorPickerIcon

See Also

ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Members
ColorPickerIcon Class Constructors Methods Properties See Also Send Feedback

The ColorPickerIcon type exposes the following members.

Constructors

Name | Description
ColorPickerIcon | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HidePalette | Hides the ColorPicker palette.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowPalette | Shows the ColorPicker palette.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaletteDisplayed | Determines whether the palette is displayed.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Constructor
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
ColorPickerIcon()()() | Initializes a new instance of the ColorPickerIcon class.
ColorPickerIcon(Element) | Initializes a new instance of the ColorPickerIcon class.

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Constructor
ColorPickerIcon Class See Also Send Feedback
Initializes a new instance of the ColorPickerIcon class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ColorPickerIcon()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorPickerIcon()

See Also

ColorPickerIcon Class
ColorPickerIcon Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Constructor (Element)
ColorPickerIcon Class See Also Send Feedback
Initializes a new instance of the ColorPickerIcon class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ColorPickerIcon(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
ColorPickerIcon(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
RadColorPicker icon element.

See Also

ColorPickerIcon Class
ColorPickerIcon Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Methods
ColorPickerIcon Class See Also Send Feedback

The ColorPickerIcon type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HidePalette | Hides the ColorPicker palette.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowPalette | Shows the ColorPicker palette.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.AssignElement Method
ColorPickerIcon Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.CallMethod Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.Capture Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.Click Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.DragTo Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.GetValue Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


HidePalette Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.HidePalette Method
ColorPickerIcon Class See Also Send Feedback
Hides the ColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HidePalette()
Visual Basic (Declaration)
Public Sub HidePalette
Visual C++
public:
void HidePalette()

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.InvokeEvent Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.MouseClick Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.MouseHover Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.ScrollToVisible Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.SetValue Method
ColorPickerIcon Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ShowPalette Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.ShowPalette Method
ColorPickerIcon Class See Also Send Feedback
Shows the ColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowPalette()
Visual Basic (Declaration)
Public Sub ShowPalette
Visual C++
public:
void ShowPalette()

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon Properties
ColorPickerIcon Class See Also Send Feedback

The ColorPickerIcon type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaletteDisplayed | Determines whether the palette is displayed.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.LocatorExpression Property
ColorPickerIcon Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


PaletteDisplayed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerIcon..::.PaletteDisplayed Property
ColorPickerIcon Class See Also Send Feedback
Determines whether the palette is displayed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool PaletteDisplayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaletteDisplayed As Boolean
Visual C++
public:
property bool PaletteDisplayed {
    bool get ();
}

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Class
Members See Also Send Feedback
The palette of the RadColorPicker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ColorPickerPalette : HtmlContainerControl
Visual Basic (Declaration)
Public Class ColorPickerPalette _
    Inherits HtmlContainerControl
Visual C++
public ref class ColorPickerPalette : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.ColorPickerPalette

See Also

ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Members
ColorPickerPalette Class Constructors Methods Properties See Also Send Feedback

The ColorPickerPalette type exposes the following members.

Constructors

Name | Description
ColorPickerPalette | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPicker palette. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedColor | Gets/Sets the selected color of the RadColorPicker palette.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Constructor
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
ColorPickerPalette()()() | Initializes a new instance of the ColorPickerPalette class.
ColorPickerPalette(Element) | Initializes a new instance of the ColorPickerPalette class.

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Constructor
ColorPickerPalette Class See Also Send Feedback
Initializes a new instance of the ColorPickerPalette class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ColorPickerPalette()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorPickerPalette()

See Also

ColorPickerPalette Class
ColorPickerPalette Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Constructor (Element)
ColorPickerPalette Class See Also Send Feedback
Initializes a new instance of the ColorPickerPalette class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ColorPickerPalette(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
ColorPickerPalette(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.ColorPickerPalette.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

ColorPickerPalette Class
ColorPickerPalette Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Methods
ColorPickerPalette Class See Also Send Feedback

The ColorPickerPalette type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.AssignElement Method
ColorPickerPalette Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.CallMethod Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.Capture Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.Click Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.DragTo Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.GetValue Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.InvokeEvent Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.MouseClick Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.MouseHover Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.ScrollToVisible Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.SetValue Method
ColorPickerPalette Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette Properties
ColorPickerPalette Class See Also Send Feedback

The ColorPickerPalette type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPicker palette. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedColor | Gets/Sets the selected color of the RadColorPicker palette.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.LocatorExpression Property
ColorPickerPalette Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


SelectedColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerPalette..::.SelectedColor Property
ColorPickerPalette Class See Also Send Feedback
Gets/Sets the selected color of the RadColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedColor { get; set; }
Visual Basic (Declaration)
Public Property SelectedColor As String
Visual C++
public:
property String^ SelectedColor {
    String^ get ();
    void set (String^ value);
}

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants Class
Members See Also Send Feedback
Represents the RadComboBox constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ComboBoxConstants
Visual Basic (Declaration)
Public NotInheritable Class ComboBoxConstants
Visual C++
public ref class ComboBoxConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.ComboBoxConstants

See Also

ComboBoxConstants Members
Telerik.WebAii.Controls.Html Namespace


ComboBoxConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants Members
ComboBoxConstants Class Fields See Also Send Feedback

The ComboBoxConstants type exposes the following members.

Fields

Name | Description
ComboBox | The ComboBox key used across the source classes.
ComboBoxItemKey | The ComboBoxItem key used across the source classes.
CssComboBox | The CSS class identifying the ComboBox control.
CssComboBoxItem | The CSS class identifying the ComboBox item.
IdComboArrow | The ID part identifying the drop down arrow of the ComboBox control.
IdComboInput | The ID part identifying the input element of the ComboBox control.

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants Fields
ComboBoxConstants Class See Also Send Feedback

The ComboBoxConstants type exposes the following members.

Fields

Name | Description
ComboBox | The ComboBox key used across the source classes.
ComboBoxItemKey | The ComboBoxItem key used across the source classes.
CssComboBox | The CSS class identifying the ComboBox control.
CssComboBoxItem | The CSS class identifying the ComboBox item.
IdComboArrow | The ID part identifying the drop down arrow of the ComboBox control.
IdComboInput | The ID part identifying the input element of the ComboBox control.

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ComboBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants..::.ComboBox Field
ComboBoxConstants Class See Also Send Feedback
The ComboBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ComboBox
Visual Basic (Declaration)
Public Const ComboBox As String
Visual C++
public:
literal String^ ComboBox

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants..::.ComboBoxItemKey Field
ComboBoxConstants Class See Also Send Feedback
The ComboBoxItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ComboBoxItemKey
Visual Basic (Declaration)
Public Const ComboBoxItemKey As String
Visual C++
public:
literal String^ ComboBoxItemKey

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssComboBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants..::.CssComboBox Field
ComboBoxConstants Class See Also Send Feedback
The CSS class identifying the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssComboBox
Visual Basic (Declaration)
Public Const CssComboBox As String
Visual C++
public:
literal String^ CssComboBox

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssComboBoxItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants..::.CssComboBoxItem Field
ComboBoxConstants Class See Also Send Feedback
The CSS class identifying the ComboBox item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssComboBoxItem
Visual Basic (Declaration)
Public Const CssComboBoxItem As String
Visual C++
public:
literal String^ CssComboBoxItem

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


IdComboArrow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants..::.IdComboArrow Field
ComboBoxConstants Class See Also Send Feedback
The ID part identifying the drop down arrow of the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdComboArrow
Visual Basic (Declaration)
Public Const IdComboArrow As String
Visual C++
public:
literal String^ IdComboArrow

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


IdComboInput Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxConstants..::.IdComboInput Field
ComboBoxConstants Class See Also Send Feedback
The ID part identifying the input element of the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdComboInput
Visual Basic (Declaration)
Public Const IdComboInput As String
Visual C++
public:
literal String^ IdComboInput

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CommonHelper Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper Class
Members See Also Send Feedback
Represents a common helper class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class CommonHelper
Visual Basic (Declaration)
Public NotInheritable Class CommonHelper
Visual C++
public ref class CommonHelper abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.CommonHelper

See Also

CommonHelper Members
Telerik.WebAii.Controls.Html Namespace


CommonHelper Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper Members
CommonHelper Class Methods See Also Send Feedback

The CommonHelper type exposes the following members.

Methods

Name | Description
GenArray | A helper method to generate an array of integers with given count.
GetControl | Get the HtmlControl type of the given element.
GetControlType | Get the control type of the given element.
GetInputControl | Get the HtmlInputControl type of the given element.
GetInputControlType | Get the input control type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


CommonHelper Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper Methods
CommonHelper Class See Also Send Feedback

The CommonHelper type exposes the following members.

Methods

Name | Description
GenArray | A helper method to generate an array of integers with given count.
GetControl | Get the HtmlControl type of the given element.
GetControlType | Get the control type of the given element.
GetInputControl | Get the HtmlInputControl type of the given element.
GetInputControlType | Get the input control type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GenArray Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper..::.GenArray Method
CommonHelper Class See Also Send Feedback
A helper method to generate an array of integers with given count.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static int[] GenArray(
    int count
)
Visual Basic (Declaration)
Public Shared Function GenArray ( _
    count As Integer _
) As Integer()
Visual C++
public:
static array<int>^ GenArray(
    int count
)

Parameters

count
Type: System..::.Int32
The count of the array elements.

Return Value

An array of integers with given count.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetControl Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper..::.GetControl Method
CommonHelper Class See Also Send Feedback
Get the HtmlControl type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static HtmlControl GetControl(
    Element element
)
Visual Basic (Declaration)
Public Shared Function GetControl ( _
    element As Element _
) As HtmlControl
Visual C++
public:
static HtmlControl^ GetControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element to get the control type of.

Return Value

The HtmlControl type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetControlType Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper..::.GetControlType Method
CommonHelper Class See Also Send Feedback
Get the control type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static Type GetControlType(
    Element element
)
Visual Basic (Declaration)
Public Shared Function GetControlType ( _
    element As Element _
) As Type
Visual C++
public:
static Type^ GetControlType(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element to get the control type of.

Return Value

The control type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetInputControl Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper..::.GetInputControl Method
CommonHelper Class See Also Send Feedback
Get the HtmlInputControl type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static HtmlInputControl GetInputControl(
    Element element
)
Visual Basic (Declaration)
Public Shared Function GetInputControl ( _
    element As Element _
) As HtmlInputControl
Visual C++
public:
static HtmlInputControl^ GetInputControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element to get the control type of.

Return Value

The HtmlInputControl type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetInputControlType Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CommonHelper..::.GetInputControlType Method
CommonHelper Class See Also Send Feedback
Get the input control type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static Type GetInputControlType(
    Element element
)
Visual Basic (Declaration)
Public Shared Function GetInputControlType ( _
    element As Element _
) As Type
Visual C++
public:
static Type^ GetInputControlType(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element to get the input control type of.

Return Value

The input control type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


DataPagerConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants Class
Members See Also Send Feedback
The ListView string constants.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class DataPagerConstants
Visual Basic (Declaration)
Public NotInheritable Class DataPagerConstants
Visual C++
public ref class DataPagerConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.DataPagerConstants

See Also

DataPagerConstants Members
Telerik.WebAii.Controls.Html Namespace


DataPagerConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants Members
DataPagerConstants Class Fields See Also Send Feedback

The DataPagerConstants type exposes the following members.

Fields

Name | Description
CssCurrentPage | The CSS class of the DataPager's currently selected page.
CssFirstButton | The CSS class of the DataPager's 'first page' button.
CssLastButton | The CSS class of the DataPager's 'last page' button.
CssNextButton | The CSS class of the DataPager's next page button.
CssNumberPartDiv | The CSS class of the div wrapping the numbers in the pager.
CssPageButton | The CSS class of the DataPager's 'Go' button.
CssPreviousButton | The CSS class of the DataPager's previous button.
CssRadDataPager | The CSS class of the DataPager div wrapper.
DataPagerKey | The DataPager key.
PagerTextBoxId | The ID of the numeric textbox in the pager.
PageSizeComboBoxId | The ID of the page size combo box.

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


DataPagerConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants Fields
DataPagerConstants Class See Also Send Feedback

The DataPagerConstants type exposes the following members.

Fields

Name | Description
CssCurrentPage | The CSS class of the DataPager's currently selected page.
CssFirstButton | The CSS class of the DataPager's 'first page' button.
CssLastButton | The CSS class of the DataPager's 'last page' button.
CssNextButton | The CSS class of the DataPager's next page button.
CssNumberPartDiv | The CSS class of the div wrapping the numbers in the pager.
CssPageButton | The CSS class of the DataPager's 'Go' button.
CssPreviousButton | The CSS class of the DataPager's previous button.
CssRadDataPager | The CSS class of the DataPager div wrapper.
DataPagerKey | The DataPager key.
PagerTextBoxId | The ID of the numeric textbox in the pager.
PageSizeComboBoxId | The ID of the page size combo box.

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCurrentPage Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssCurrentPage Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's currently selected page.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCurrentPage
Visual Basic (Declaration)
Public Const CssCurrentPage As String
Visual C++
public:
literal String^ CssCurrentPage

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFirstButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssFirstButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's 'first page' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssFirstButton
Visual Basic (Declaration)
Public Const CssFirstButton As String
Visual C++
public:
literal String^ CssFirstButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLastButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssLastButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's 'last page' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssLastButton
Visual Basic (Declaration)
Public Const CssLastButton As String
Visual C++
public:
literal String^ CssLastButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNextButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssNextButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's next page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNextButton
Visual Basic (Declaration)
Public Const CssNextButton As String
Visual C++
public:
literal String^ CssNextButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNumberPartDiv Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssNumberPartDiv Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the div wrapping the numbers in the pager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNumberPartDiv
Visual Basic (Declaration)
Public Const CssNumberPartDiv As String
Visual C++
public:
literal String^ CssNumberPartDiv

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssPageButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's 'Go' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPageButton
Visual Basic (Declaration)
Public Const CssPageButton As String
Visual C++
public:
literal String^ CssPageButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPreviousButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssPreviousButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPreviousButton
Visual Basic (Declaration)
Public Const CssPreviousButton As String
Visual C++
public:
literal String^ CssPreviousButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadDataPager Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.CssRadDataPager Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager div wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadDataPager
Visual Basic (Declaration)
Public Const CssRadDataPager As String
Visual C++
public:
literal String^ CssRadDataPager

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


DataPagerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.DataPagerKey Field
DataPagerConstants Class See Also Send Feedback
The DataPager key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DataPagerKey
Visual Basic (Declaration)
Public Const DataPagerKey As String
Visual C++
public:
literal String^ DataPagerKey

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


PagerTextBoxId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.PagerTextBoxId Field
DataPagerConstants Class See Also Send Feedback
The ID of the numeric textbox in the pager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PagerTextBoxId
Visual Basic (Declaration)
Public Const PagerTextBoxId As String
Visual C++
public:
literal String^ PagerTextBoxId

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


PageSizeComboBoxId Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DataPagerConstants..::.PageSizeComboBoxId Field
DataPagerConstants Class See Also Send Feedback
The ID of the page size combo box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PageSizeComboBoxId
Visual Basic (Declaration)
Public Const PageSizeComboBoxId As String
Visual C++
public:
literal String^ PageSizeComboBoxId

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorActionType Enumeration
See Also Send Feedback
Editor action type enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum EditorActionType
Visual Basic (Declaration)
Public Enumeration EditorActionType
Visual C++
public enum class EditorActionType

Members

Member name | Description
SetHtml | Set Html to current RadEditor.
ChangeMode | Change current RadEditor mode.
OnFocus | Focus the editor.

See Also

Telerik.WebAii.Controls.Html Namespace


EditorCommand Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Class
Members See Also Send Feedback
RadEditor for the ASP.NET AJAX: EditorCommand wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class EditorCommand : HtmlAnchor
Visual Basic (Declaration)
Public Class EditorCommand _
    Inherits HtmlAnchor
Visual C++
public ref class EditorCommand : public HtmlAnchor

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlAnchor
Telerik.WebAii.Controls.Html..::.EditorCommand

See Also

EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorCommand Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Members
EditorCommand Class Constructors Methods Properties See Also Send Feedback

The EditorCommand type exposes the following members.

Constructors

Name | Description
EditorCommand | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlAnchor..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadEditor command. (Overrides HtmlControl..::.ClientSideLocator.)
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EditorId | Gets ID of the parent editor.
Enabled | Determines whether RadEditorCommand is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsNonDefaultToolBarMode | Determines whether the editor is in default toolbar mode or not.
IsOn | Determines whether RadEditorCommand is on.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorCommand. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Gets the name of a link. (Inherited from HtmlAnchor.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Text | Gets RadEditorCommand text(tooltip).
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorCommand Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Constructor
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
EditorCommand()()() | Initializes a new instance of the EditorCommand class.
EditorCommand(Element) | Initializes a new instance of the EditorCommand class.

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorCommand Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Constructor
EditorCommand Class See Also Send Feedback
Initializes a new instance of the EditorCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorCommand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditorCommand()

See Also

EditorCommand Class
EditorCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorCommand Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Constructor (Element)
EditorCommand Class See Also Send Feedback
Initializes a new instance of the EditorCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorCommand(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorCommand(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorCommand.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorCommand Class
EditorCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorCommand Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Methods
EditorCommand Class See Also Send Feedback

The EditorCommand type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlAnchor..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.AssignElement Method
EditorCommand Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.CallMethod Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.Capture Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.Click Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.DragTo Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.GetValue Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.InvokeEvent Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.MouseClick Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.MouseHover Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.ScrollToVisible Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.SetValue Method
EditorCommand Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorCommand Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand Properties
EditorCommand Class See Also Send Feedback

The EditorCommand type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadEditor command. (Overrides HtmlControl..::.ClientSideLocator.)
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EditorId | Gets ID of the parent editor.
Enabled | Determines whether RadEditorCommand is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsNonDefaultToolBarMode | Determines whether the editor is in default toolbar mode or not.
IsOn | Determines whether RadEditorCommand is on.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorCommand. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Gets the name of a link. (Inherited from HtmlAnchor.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Text | Gets RadEditorCommand text(tooltip).
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.ClientSideLocator Property
EditorCommand Class See Also Send Feedback
Gets the client-side code that defines the RadEditor command.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


CommandName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.CommandName Property
EditorCommand Class See Also Send Feedback
The Command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CommandName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommandName As String
Visual C++
public:
property String^ CommandName {
    String^ get ();
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.EditorId Property
EditorCommand Class See Also Send Feedback
Gets ID of the parent editor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EditorId { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditorId As String
Visual C++
public:
property String^ EditorId {
    String^ get ();
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.Enabled Property
EditorCommand Class See Also Send Feedback
Determines whether RadEditorCommand is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


IsNonDefaultToolBarMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.IsNonDefaultToolBarMode Property
EditorCommand Class See Also Send Feedback
Determines whether the editor is in default toolbar mode or not.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsNonDefaultToolBarMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNonDefaultToolBarMode As Boolean
Visual C++
public:
property bool IsNonDefaultToolBarMode {
    bool get ();
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


IsOn Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.IsOn Property
EditorCommand Class See Also Send Feedback
Determines whether RadEditorCommand is on.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsOn { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOn As Boolean
Visual C++
public:
property bool IsOn {
    bool get ();
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.LocatorExpression Property
EditorCommand Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a EditorCommand.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorCommand..::.Text Property
EditorCommand Class See Also Send Feedback
Gets RadEditorCommand text(tooltip).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants Class
Members See Also Send Feedback
String constatns of the editor(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class EditorConstants
Visual Basic (Declaration)
Public NotInheritable Class EditorConstants
Visual C++
public ref class EditorConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.EditorConstants

See Also

EditorConstants Members
Telerik.WebAii.Controls.Html Namespace


EditorConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants Members
EditorConstants Class Fields See Also Send Feedback

The EditorConstants type exposes the following members.

Fields

Name | Description
CssEditor | The CSS class identifying the RadEditor control.
CssEditorCommandExclude | The CSS class, excluding splitbuttons, identifying the RadEditorCommand control.
CssEditorCommandInclude | The CSS class identifying the RadEditorCommand control.
CssEditorDropDown | The CSS class identifying the RadEditorDropDown control.
CssEditorDropDownBody | The CSS class identifying the DropDownBody control.
CssEditorModeCommand | The CSS class identifying the RadEditorModeCommand control.
CssEditorSpinBox | The CSS class identifying the RadEditorSpinBox control.
CssEditorSpinBoxDecrease | The CSS class identifying decreasing handler of the RadEditorSpinBox.
CssEditorSpinBoxIncrease | The CSS class identifying increasing handler of the RadEditorSpinBox.
CssEditorSpinBoxTextBox | The CSS class identifying the textbox of the RadEditorSpinBox.
CssModeCommandSelected | The CSS class, that will be added, when the RadEditorModeCommand is selected.
CssSplitButton | The CSS class identifying the RadEditorSplitButton control.
CssSplitButtonHandler | The CSS class identifying showing handler of RadEditorCommand control.
CssTableHelperCell | The CSS class identifying the table cell of the Table helper.
CssToolDisabled | The CSS class, that will be added, when the tool is disabled.
CssToolSelected | The CSS class, that will be added, when the tool is selected.
EditorCommandsUsingSelectedText | The string, identify a group of editor commands, that uses selected text.
KeyEditor | The Editor key used accross the verifications and action messages.
KeyEditorCommand | The Editor Command key used accross the verifications and action messages.
KeyEditorDropDown | The Editor DropDown key used accross the verifications and action messages.
KeyEditorDropDownBody | The Editor DropDownBody key used accross the verifications and action messages.
KeyEditorModeCommand | The Editor Mode key used accross the verifications and action messages.
KeyEditorSpinBox | The Editor SpinBox key used accross the verifications and action messages.
KeyEditorSplitButton | The Editor Split Button key used accross the verifications and action messages.
ToolBarIdPostfix | The string postfix of the toolbar ID, when toolbar mode of editor is not default.
ToolBarIdPrefix | The string prefix of the toolbar ID, when toolbar mode of editor is not default.

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants Fields
EditorConstants Class See Also Send Feedback

The EditorConstants type exposes the following members.

Fields

Name | Description
CssEditor | The CSS class identifying the RadEditor control.
CssEditorCommandExclude | The CSS class, excluding splitbuttons, identifying the RadEditorCommand control.
CssEditorCommandInclude | The CSS class identifying the RadEditorCommand control.
CssEditorDropDown | The CSS class identifying the RadEditorDropDown control.
CssEditorDropDownBody | The CSS class identifying the DropDownBody control.
CssEditorModeCommand | The CSS class identifying the RadEditorModeCommand control.
CssEditorSpinBox | The CSS class identifying the RadEditorSpinBox control.
CssEditorSpinBoxDecrease | The CSS class identifying decreasing handler of the RadEditorSpinBox.
CssEditorSpinBoxIncrease | The CSS class identifying increasing handler of the RadEditorSpinBox.
CssEditorSpinBoxTextBox | The CSS class identifying the textbox of the RadEditorSpinBox.
CssModeCommandSelected | The CSS class, that will be added, when the RadEditorModeCommand is selected.
CssSplitButton | The CSS class identifying the RadEditorSplitButton control.
CssSplitButtonHandler | The CSS class identifying showing handler of RadEditorCommand control.
CssTableHelperCell | The CSS class identifying the table cell of the Table helper.
CssToolDisabled | The CSS class, that will be added, when the tool is disabled.
CssToolSelected | The CSS class, that will be added, when the tool is selected.
EditorCommandsUsingSelectedText | The string, identify a group of editor commands, that uses selected text.
KeyEditor | The Editor key used accross the verifications and action messages.
KeyEditorCommand | The Editor Command key used accross the verifications and action messages.
KeyEditorDropDown | The Editor DropDown key used accross the verifications and action messages.
KeyEditorDropDownBody | The Editor DropDownBody key used accross the verifications and action messages.
KeyEditorModeCommand | The Editor Mode key used accross the verifications and action messages.
KeyEditorSpinBox | The Editor SpinBox key used accross the verifications and action messages.
KeyEditorSplitButton | The Editor Split Button key used accross the verifications and action messages.
ToolBarIdPostfix | The string postfix of the toolbar ID, when toolbar mode of editor is not default.
ToolBarIdPrefix | The string prefix of the toolbar ID, when toolbar mode of editor is not default.

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditor Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditor Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditor control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditor
Visual Basic (Declaration)
Public Const CssEditor As String
Visual C++
public:
literal String^ CssEditor

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorCommandExclude Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorCommandExclude Field
EditorConstants Class See Also Send Feedback
The CSS class, excluding splitbuttons, identifying the RadEditorCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorCommandExclude
Visual Basic (Declaration)
Public Const CssEditorCommandExclude As String
Visual C++
public:
literal String^ CssEditorCommandExclude

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorCommandInclude Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorCommandInclude Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorCommandInclude
Visual Basic (Declaration)
Public Const CssEditorCommandInclude As String
Visual C++
public:
literal String^ CssEditorCommandInclude

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorDropDown Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorDropDown Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorDropDown control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorDropDown
Visual Basic (Declaration)
Public Const CssEditorDropDown As String
Visual C++
public:
literal String^ CssEditorDropDown

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorDropDownBody Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorDropDownBody Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the DropDownBody control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorDropDownBody
Visual Basic (Declaration)
Public Const CssEditorDropDownBody As String
Visual C++
public:
literal String^ CssEditorDropDownBody

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorModeCommand Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorModeCommand Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorModeCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorModeCommand
Visual Basic (Declaration)
Public Const CssEditorModeCommand As String
Visual C++
public:
literal String^ CssEditorModeCommand

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorSpinBox Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorSpinBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorSpinBox
Visual Basic (Declaration)
Public Const CssEditorSpinBox As String
Visual C++
public:
literal String^ CssEditorSpinBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBoxDecrease Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorSpinBoxDecrease Field
EditorConstants Class See Also Send Feedback
The CSS class identifying decreasing handler of the RadEditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorSpinBoxDecrease
Visual Basic (Declaration)
Public Const CssEditorSpinBoxDecrease As String
Visual C++
public:
literal String^ CssEditorSpinBoxDecrease

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBoxIncrease Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorSpinBoxIncrease Field
EditorConstants Class See Also Send Feedback
The CSS class identifying increasing handler of the RadEditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorSpinBoxIncrease
Visual Basic (Declaration)
Public Const CssEditorSpinBoxIncrease As String
Visual C++
public:
literal String^ CssEditorSpinBoxIncrease

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBoxTextBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssEditorSpinBoxTextBox Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the textbox of the RadEditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssEditorSpinBoxTextBox
Visual Basic (Declaration)
Public Const CssEditorSpinBoxTextBox As String
Visual C++
public:
literal String^ CssEditorSpinBoxTextBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssModeCommandSelected Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssModeCommandSelected Field
EditorConstants Class See Also Send Feedback
The CSS class, that will be added, when the RadEditorModeCommand is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssModeCommandSelected
Visual Basic (Declaration)
Public Const CssModeCommandSelected As String
Visual C++
public:
literal String^ CssModeCommandSelected

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssSplitButton Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorSplitButton control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSplitButton
Visual Basic (Declaration)
Public Const CssSplitButton As String
Visual C++
public:
literal String^ CssSplitButton

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitButtonHandler Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssSplitButtonHandler Field
EditorConstants Class See Also Send Feedback
The CSS class identifying showing handler of RadEditorCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSplitButtonHandler
Visual Basic (Declaration)
Public Const CssSplitButtonHandler As String
Visual C++
public:
literal String^ CssSplitButtonHandler

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTableHelperCell Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssTableHelperCell Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the table cell of the Table helper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTableHelperCell
Visual Basic (Declaration)
Public Const CssTableHelperCell As String
Visual C++
public:
literal String^ CssTableHelperCell

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolDisabled Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssToolDisabled Field
EditorConstants Class See Also Send Feedback
The CSS class, that will be added, when the tool is disabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolDisabled
Visual Basic (Declaration)
Public Const CssToolDisabled As String
Visual C++
public:
literal String^ CssToolDisabled

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolSelected Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.CssToolSelected Field
EditorConstants Class See Also Send Feedback
The CSS class, that will be added, when the tool is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolSelected
Visual Basic (Declaration)
Public Const CssToolSelected As String
Visual C++
public:
literal String^ CssToolSelected

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorCommandsUsingSelectedText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.EditorCommandsUsingSelectedText Field
EditorConstants Class See Also Send Feedback
The string, identify a group of editor commands, that uses selected text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string EditorCommandsUsingSelectedText
Visual Basic (Declaration)
Public Const EditorCommandsUsingSelectedText As String
Visual C++
public:
literal String^ EditorCommandsUsingSelectedText

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditor Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditor Field
EditorConstants Class See Also Send Feedback
The Editor key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditor
Visual Basic (Declaration)
Public Const KeyEditor As String
Visual C++
public:
literal String^ KeyEditor

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorCommand Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditorCommand Field
EditorConstants Class See Also Send Feedback
The Editor Command key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditorCommand
Visual Basic (Declaration)
Public Const KeyEditorCommand As String
Visual C++
public:
literal String^ KeyEditorCommand

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorDropDown Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditorDropDown Field
EditorConstants Class See Also Send Feedback
The Editor DropDown key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditorDropDown
Visual Basic (Declaration)
Public Const KeyEditorDropDown As String
Visual C++
public:
literal String^ KeyEditorDropDown

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorDropDownBody Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditorDropDownBody Field
EditorConstants Class See Also Send Feedback
The Editor DropDownBody key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditorDropDownBody
Visual Basic (Declaration)
Public Const KeyEditorDropDownBody As String
Visual C++
public:
literal String^ KeyEditorDropDownBody

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorModeCommand Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditorModeCommand Field
EditorConstants Class See Also Send Feedback
The Editor Mode key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditorModeCommand
Visual Basic (Declaration)
Public Const KeyEditorModeCommand As String
Visual C++
public:
literal String^ KeyEditorModeCommand

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorSpinBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditorSpinBox Field
EditorConstants Class See Also Send Feedback
The Editor SpinBox key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditorSpinBox
Visual Basic (Declaration)
Public Const KeyEditorSpinBox As String
Visual C++
public:
literal String^ KeyEditorSpinBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorSplitButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.KeyEditorSplitButton Field
EditorConstants Class See Also Send Feedback
The Editor Split Button key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyEditorSplitButton
Visual Basic (Declaration)
Public Const KeyEditorSplitButton As String
Visual C++
public:
literal String^ KeyEditorSplitButton

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarIdPostfix Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.ToolBarIdPostfix Field
EditorConstants Class See Also Send Feedback
The string postfix of the toolbar ID, when toolbar mode of editor is not default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBarIdPostfix
Visual Basic (Declaration)
Public Const ToolBarIdPostfix As String
Visual C++
public:
literal String^ ToolBarIdPostfix

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarIdPrefix Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorConstants..::.ToolBarIdPrefix Field
EditorConstants Class See Also Send Feedback
The string prefix of the toolbar ID, when toolbar mode of editor is not default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBarIdPrefix
Visual Basic (Declaration)
Public Const ToolBarIdPrefix As String
Visual C++
public:
literal String^ ToolBarIdPrefix

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Class
Members See Also Send Feedback
RadEditor for the ASP.NET AJAX: EditorDropDown wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class EditorDropDown : HtmlAnchor
Visual Basic (Declaration)
Public Class EditorDropDown _
    Inherits HtmlAnchor
Visual C++
public ref class EditorDropDown : public HtmlAnchor

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlAnchor
Telerik.WebAii.Controls.Html..::.EditorDropDown

See Also

EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Members
EditorDropDown Class Constructors Methods Properties See Also Send Feedback

The EditorDropDown type exposes the following members.

Constructors

Name | Description
EditorDropDown | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlAnchor..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hides the drop down.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectItem | Selects Item.
SetValue | Overloaded.
Show | Shows the drop down.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadEditor dropdown. (Overrides HtmlControl..::.ClientSideLocator.)
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownValue | Gets/Sets the value of the drop down.
EditorId | Gets the parent Editor Id.
Enabled | Determines or set whether RadEditorDropDown is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsExpanded | Determines whether RadEditorDropDown is expanded.
IsOn | Determines whether RadEditorDropDown is on.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemCount | Gets the item count of the drop down.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorDropDown. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Gets the name of a link. (Inherited from HtmlAnchor.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets/Sets selected index of drop down.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Gets where to open a link. (Inherited from HtmlAnchor.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Constructor
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
EditorDropDown()()() | Initializes a new instance of the EditorDropDown class.
EditorDropDown(Element) | Initializes a new instance of the EditorDropDown class.

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Constructor
EditorDropDown Class See Also Send Feedback
Initializes a new instance of the EditorDropDown class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorDropDown()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditorDropDown()

See Also

EditorDropDown Class
EditorDropDown Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Constructor (Element)
EditorDropDown Class See Also Send Feedback
Initializes a new instance of the EditorDropDown class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorDropDown(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorDropDown(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorDropDown.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorDropDown Class
EditorDropDown Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Methods
EditorDropDown Class See Also Send Feedback

The EditorDropDown type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlAnchor..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hides the drop down.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectItem | Selects Item.
SetValue | Overloaded.
Show | Shows the drop down.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.AssignElement Method
EditorDropDown Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.CallMethod Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.Capture Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.Click Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.ControlAssert Method
EditorDropDown Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.DragTo Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.GetValue Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.Hide Method
EditorDropDown Class See Also Send Feedback
Hides the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.InvokeEvent Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.MouseClick Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.MouseHover Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.ScrollToVisible Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


SelectItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.SelectItem Method
EditorDropDown Class See Also Send Feedback
Selects Item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int index
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    index As Integer _
)
Visual C++
public:
void SelectItem(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorDropDown.SelectItem(System.Int32)"]

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.SetValue Method
EditorDropDown Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.Show Method
EditorDropDown Class See Also Send Feedback
Shows the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown Properties
EditorDropDown Class See Also Send Feedback

The EditorDropDown type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadEditor dropdown. (Overrides HtmlControl..::.ClientSideLocator.)
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownValue | Gets/Sets the value of the drop down.
EditorId | Gets the parent Editor Id.
Enabled | Determines or set whether RadEditorDropDown is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsExpanded | Determines whether RadEditorDropDown is expanded.
IsOn | Determines whether RadEditorDropDown is on.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemCount | Gets the item count of the drop down.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorDropDown. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Gets the name of a link. (Inherited from HtmlAnchor.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets/Sets selected index of drop down.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Gets where to open a link. (Inherited from HtmlAnchor.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.ClientSideLocator Property
EditorDropDown Class See Also Send Feedback
Gets the client-side code that defines the RadEditor dropdown.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


CommandName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.CommandName Property
EditorDropDown Class See Also Send Feedback
The Command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CommandName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommandName As String
Visual C++
public:
property String^ CommandName {
    String^ get ();
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


DropDownValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.DropDownValue Property
EditorDropDown Class See Also Send Feedback
Gets/Sets the value of the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DropDownValue { get; set; }
Visual Basic (Declaration)
Public Property DropDownValue As String
Visual C++
public:
property String^ DropDownValue {
    String^ get ();
    void set (String^ value);
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.EditorId Property
EditorDropDown Class See Also Send Feedback
Gets the parent Editor Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EditorId { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditorId As String
Visual C++
public:
property String^ EditorId {
    String^ get ();
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.Enabled Property
EditorDropDown Class See Also Send Feedback
Determines or set whether RadEditorDropDown is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.IsExpanded Property
EditorDropDown Class See Also Send Feedback
Determines whether RadEditorDropDown is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


IsOn Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.IsOn Property
EditorDropDown Class See Also Send Feedback
Determines whether RadEditorDropDown is on.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsOn { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOn As Boolean
Visual C++
public:
property bool IsOn {
    bool get ();
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


ItemCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.ItemCount Property
EditorDropDown Class See Also Send Feedback
Gets the item count of the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
Visual C++
public:
property int ItemCount {
    int get ();
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.LocatorExpression Property
EditorDropDown Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a EditorDropDown.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


SelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDown..::.SelectedIndex Property
EditorDropDown Class See Also Send Feedback
Gets/Sets selected index of drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Class
Members See Also Send Feedback
RadEditor for the ASP.NET AJAX: EditorDropDownBody wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class EditorDropDownBody : HtmlDiv
Visual Basic (Declaration)
Public Class EditorDropDownBody _
    Inherits HtmlDiv
Visual C++
public ref class EditorDropDownBody : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.EditorDropDownBody

See Also

EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Members
EditorDropDownBody Class Constructors Methods Properties See Also Send Feedback

The EditorDropDownBody type exposes the following members.

Constructors

Name | Description
EditorDropDownBody | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the HtmlFindExpression that defines the pattern for a EditorDropDownBody. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Constructor
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
EditorDropDownBody()()() | Initializes a new instance of the EditorDropDownBody class.
EditorDropDownBody(Element) | Initializes a new instance of the EditorDropDownBody class.

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Constructor
EditorDropDownBody Class See Also Send Feedback
Initializes a new instance of the EditorDropDownBody class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorDropDownBody()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditorDropDownBody()

See Also

EditorDropDownBody Class
EditorDropDownBody Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Constructor (Element)
EditorDropDownBody Class See Also Send Feedback
Initializes a new instance of the EditorDropDownBody class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorDropDownBody(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorDropDownBody(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorDropDownBody.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorDropDownBody Class
EditorDropDownBody Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Methods
EditorDropDownBody Class See Also Send Feedback

The EditorDropDownBody type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.AssignElement Method
EditorDropDownBody Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.CallMethod Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.Capture Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.Click Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.ControlAssert Method
EditorDropDownBody Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.DragTo Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.GetValue Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.InvokeEvent Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.MouseClick Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.MouseHover Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.ScrollToVisible Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.SetValue Method
EditorDropDownBody Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody Properties
EditorDropDownBody Class See Also Send Feedback

The EditorDropDownBody type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the HtmlFindExpression that defines the pattern for a EditorDropDownBody. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorDropDownBody..::.LocatorExpression Property
EditorDropDownBody Class See Also Send Feedback
Get the HtmlFindExpression that defines the pattern for a EditorDropDownBody.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


EditorMode Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorMode Enumeration
See Also Send Feedback
Editor mode enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum EditorMode
Visual Basic (Declaration)
Public Enumeration EditorMode
Visual C++
public enum class EditorMode

Members

Member name | Description
Design | Correspondes to DesignMode.
Html | Correspondes to HtmlMode.
Preview | Correspondes to PreviewMode.

See Also

Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Class
Members See Also Send Feedback
RadEditor for the ASP.NET AJAX: EditorModeCommand wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class EditorModeCommand : HtmlContainerControl
Visual Basic (Declaration)
Public Class EditorModeCommand _
    Inherits HtmlContainerControl
Visual C++
public ref class EditorModeCommand : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.EditorModeCommand

See Also

EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Members
EditorModeCommand Class Constructors Methods Properties See Also Send Feedback

The EditorModeCommand type exposes the following members.

Constructors

Name | Description
EditorModeCommand | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorModeCommand. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Determines whether this command is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Constructor
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
EditorModeCommand()()() | Initializes a new instance of the EditorModeCommand class.
EditorModeCommand(Element) | Initializes a new instance of the EditorModeCommand class.

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Constructor
EditorModeCommand Class See Also Send Feedback
Initializes a new instance of the EditorModeCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorModeCommand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditorModeCommand()

See Also

EditorModeCommand Class
EditorModeCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Constructor (Element)
EditorModeCommand Class See Also Send Feedback
Initializes a new instance of the EditorModeCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorModeCommand(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorModeCommand(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorModeCommand.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorModeCommand Class
EditorModeCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Methods
EditorModeCommand Class See Also Send Feedback

The EditorModeCommand type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.AssignElement Method
EditorModeCommand Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.CallMethod Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.Capture Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.Click Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.DragTo Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.GetValue Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.InvokeEvent Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.MouseClick Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.MouseHover Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.ScrollToVisible Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.SetValue Method
EditorModeCommand Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand Properties
EditorModeCommand Class See Also Send Feedback

The EditorModeCommand type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorModeCommand. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Determines whether this command is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


CommandName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.CommandName Property
EditorModeCommand Class See Also Send Feedback
The Command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CommandName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommandName As String
Visual C++
public:
property String^ CommandName {
    String^ get ();
}

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.LocatorExpression Property
EditorModeCommand Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a EditorModeCommand.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorModeCommand..::.Selected Property
EditorModeCommand Class See Also Send Feedback
Determines whether this command is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
}

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Class
Members See Also Send Feedback
RadEditor for the ASP.NET AJAX: EditorSpinBox wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class EditorSpinBox : HtmlContainerControl
Visual Basic (Declaration)
Public Class EditorSpinBox _
    Inherits HtmlContainerControl
Visual C++
public ref class EditorSpinBox : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.EditorSpinBox

See Also

EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Members
EditorSpinBox Class Constructors Methods Properties See Also Send Feedback

The EditorSpinBox type exposes the following members.

Constructors

Name | Description
EditorSpinBox | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSpinBox. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SpinBoxValue | Gets/Sets SpinBox value.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Constructor
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
EditorSpinBox()()() | Initializes a new instance of the EditorSpinBox class.
EditorSpinBox(Element) | Initializes a new instance of the EditorSpinBox class.

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Constructor
EditorSpinBox Class See Also Send Feedback
Initializes a new instance of the EditorSpinBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorSpinBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditorSpinBox()

See Also

EditorSpinBox Class
EditorSpinBox Overload
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Constructor (Element)
EditorSpinBox Class See Also Send Feedback
Initializes a new instance of the EditorSpinBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorSpinBox(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorSpinBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorSpinBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorSpinBox Class
EditorSpinBox Overload
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Methods
EditorSpinBox Class See Also Send Feedback

The EditorSpinBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.AssignElement Method
EditorSpinBox Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.CallMethod Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.Capture Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.Click Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.DragTo Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.GetValue Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.InvokeEvent Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.MouseClick Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.MouseHover Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.ScrollToVisible Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.SetValue Method
EditorSpinBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox Properties
EditorSpinBox Class See Also Send Feedback

The EditorSpinBox type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSpinBox. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SpinBoxValue | Gets/Sets SpinBox value.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.LocatorExpression Property
EditorSpinBox Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a EditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


SpinBoxValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBox..::.SpinBoxValue Property
EditorSpinBox Class See Also Send Feedback
Gets/Sets SpinBox value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SpinBoxValue { get; set; }
Visual Basic (Declaration)
Public Property SpinBoxValue As String
Visual C++
public:
property String^ SpinBoxValue {
    String^ get ();
    void set (String^ value);
}

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


EditorSpinBoxActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSpinBoxActionType Enumeration
See Also Send Feedback
Action type enumeration of the editor spinbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum EditorSpinBoxActionType
Visual Basic (Declaration)
Public Enumeration EditorSpinBoxActionType
Visual C++
public enum class EditorSpinBoxActionType

Members

Member name | Description
Increase | Correspondes to increase the value in the SpinBox.
Decrease | Correspondes to decrease the value in the SpinBox.

See Also

Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Class
Members See Also Send Feedback
RadEditor for the ASP.NET AJAX: EditorSplitButton wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class EditorSplitButton : HtmlAnchor
Visual Basic (Declaration)
Public Class EditorSplitButton _
    Inherits HtmlAnchor
Visual C++
public ref class EditorSplitButton : public HtmlAnchor

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlAnchor
Telerik.WebAii.Controls.Html..::.EditorSplitButton

See Also

EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Members
EditorSplitButton Class Constructors Methods Properties See Also Send Feedback

The EditorSplitButton type exposes the following members.

Constructors

Name | Description
EditorSplitButton | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlAnchor..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the split button.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectItem | Selects item.
SelectItemOfTableHelper | Selects item of table helper.
SetValue | Overloaded.
Show | Show the split button.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadEditor splitbutton. (Overrides HtmlControl..::.ClientSideLocator.)
Color | Gets/Sets the color of the tool(if it has).
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EditorId | Gets the parent Editor ID.
Enabled | Determines or set whether RadEditorSplitButton is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsExpanded | Determines whether RadEditorSplitButton is expanded.
IsOn | Determines whether RadEditorSplitButton is on.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemCount | Gets the number of items.
ItemsPerRow | Gets the number of items per row.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSplitButton. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Gets the name of a link. (Inherited from HtmlAnchor.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets/Sets selected index of slit button.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TableHelperClicked | Determines whether the table helper is clicked.
TableHelperSelectedIndex | Gets/Sets the table helper active index.
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Gets where to open a link. (Inherited from HtmlAnchor.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Constructor
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
EditorSplitButton()()() | Initializes a new instance of the EditorSplitButton class.
EditorSplitButton(Element) | Initializes a new instance of the EditorSplitButton class.

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Constructor
EditorSplitButton Class See Also Send Feedback
Initializes a new instance of the EditorSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorSplitButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditorSplitButton()

See Also

EditorSplitButton Class
EditorSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Constructor (Element)
EditorSplitButton Class See Also Send Feedback
Initializes a new instance of the EditorSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorSplitButton(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorSplitButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorSplitButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorSplitButton Class
EditorSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Methods
EditorSplitButton Class See Also Send Feedback

The EditorSplitButton type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlAnchor..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the split button.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectItem | Selects item.
SelectItemOfTableHelper | Selects item of table helper.
SetValue | Overloaded.
Show | Show the split button.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.AssignElement Method
EditorSplitButton Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.CallMethod Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.Capture Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.Click Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.ControlAssert Method
EditorSplitButton Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.DragTo Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.GetValue Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.Hide Method
EditorSplitButton Class See Also Send Feedback
Hide the split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.InvokeEvent Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.MouseClick Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.MouseHover Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.ScrollToVisible Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


SelectItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.SelectItem Method
EditorSplitButton Class See Also Send Feedback
Selects item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int index
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    index As Integer _
)
Visual C++
public:
void SelectItem(
    int index
)

Parameters

index
Type: System..::.Int32
The index of item.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


SelectItemOfTableHelper Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.SelectItemOfTableHelper Method
EditorSplitButton Class See Also Send Feedback
Selects item of table helper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItemOfTableHelper(
    int index
)
Visual Basic (Declaration)
Public Sub SelectItemOfTableHelper ( _
    index As Integer _
)
Visual C++
public:
void SelectItemOfTableHelper(
    int index
)

Parameters

index
Type: System..::.Int32
The index of item.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.SetValue Method
EditorSplitButton Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.Show Method
EditorSplitButton Class See Also Send Feedback
Show the split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton Properties
EditorSplitButton Class See Also Send Feedback

The EditorSplitButton type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadEditor splitbutton. (Overrides HtmlControl..::.ClientSideLocator.)
Color | Gets/Sets the color of the tool(if it has).
CommandName | The Command name.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EditorId | Gets the parent Editor ID.
Enabled | Determines or set whether RadEditorSplitButton is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsExpanded | Determines whether RadEditorSplitButton is expanded.
IsOn | Determines whether RadEditorSplitButton is on.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemCount | Gets the number of items.
ItemsPerRow | Gets the number of items per row.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSplitButton. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Gets the name of a link. (Inherited from HtmlAnchor.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets/Sets selected index of slit button.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TableHelperClicked | Determines whether the table helper is clicked.
TableHelperSelectedIndex | Gets/Sets the table helper active index.
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Gets where to open a link. (Inherited from HtmlAnchor.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.ClientSideLocator Property
EditorSplitButton Class See Also Send Feedback
Gets the client-side code that defines the RadEditor splitbutton.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.Color Property
EditorSplitButton Class See Also Send Feedback
Gets/Sets the color of the tool(if it has).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Color { get; set; }
Visual Basic (Declaration)
Public Property Color As String
Visual C++
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


CommandName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.CommandName Property
EditorSplitButton Class See Also Send Feedback
The Command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CommandName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommandName As String
Visual C++
public:
property String^ CommandName {
    String^ get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


EditorId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.EditorId Property
EditorSplitButton Class See Also Send Feedback
Gets the parent Editor ID.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EditorId { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditorId As String
Visual C++
public:
property String^ EditorId {
    String^ get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.Enabled Property
EditorSplitButton Class See Also Send Feedback
Determines or set whether RadEditorSplitButton is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.IsExpanded Property
EditorSplitButton Class See Also Send Feedback
Determines whether RadEditorSplitButton is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


IsOn Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.IsOn Property
EditorSplitButton Class See Also Send Feedback
Determines whether RadEditorSplitButton is on.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsOn { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOn As Boolean
Visual C++
public:
property bool IsOn {
    bool get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


ItemCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.ItemCount Property
EditorSplitButton Class See Also Send Feedback
Gets the number of items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
Visual C++
public:
property int ItemCount {
    int get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


ItemsPerRow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.ItemsPerRow Property
EditorSplitButton Class See Also Send Feedback
Gets the number of items per row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemsPerRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemsPerRow As Integer
Visual C++
public:
property int ItemsPerRow {
    int get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.LocatorExpression Property
EditorSplitButton Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a EditorSplitButton.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


SelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.SelectedIndex Property
EditorSplitButton Class See Also Send Feedback
Gets/Sets selected index of slit button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


TableHelperClicked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.TableHelperClicked Property
EditorSplitButton Class See Also Send Feedback
Determines whether the table helper is clicked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool TableHelperClicked { get; }
Visual Basic (Declaration)
Public ReadOnly Property TableHelperClicked As Boolean
Visual C++
public:
property bool TableHelperClicked {
    bool get ();
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


TableHelperSelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButton..::.TableHelperSelectedIndex Property
EditorSplitButton Class See Also Send Feedback
Gets/Sets the table helper active index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int TableHelperSelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property TableHelperSelectedIndex As Integer
Visual C++
public:
property int TableHelperSelectedIndex {
    int get ();
    void set (int value);
}

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


EditorSplitButtonActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorSplitButtonActionType Enumeration
See Also Send Feedback
Action types enumeration of the editor splitbutton.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum EditorSplitButtonActionType
Visual Basic (Declaration)
Public Enumeration EditorSplitButtonActionType
Visual C++
public enum class EditorSplitButtonActionType

Members

Member name | Description
Click | Correspondes to click over a command or split button.
Show | Correspondes to show drop down or split button items.
Hide | Correspondes to hide drop down or split button items.
SelectItem | Correspondes to select drop down or split button item.

See Also

Telerik.WebAii.Controls.Html Namespace


EditorToolBarMode Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
EditorToolBarMode Enumeration
See Also Send Feedback
Editor toolbar mode enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum EditorToolBarMode
Visual Basic (Declaration)
Public Enumeration EditorToolBarMode
Visual C++
public enum class EditorToolBarMode

Members

Member name | Description
Default | The toolbar is static and positioned over the content area.
PageTop | In this mode, when a particular editor gets the focus its toolbar will appear docked at the top of the page.
ShowOnFocus | The toolbar will appear right above the editor when it gets focus.
Floating | The toolbar will pop up in a window and will allow the user to move it over the page.

See Also

Telerik.WebAii.Controls.Html Namespace


GridAdvancedPagerActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridAdvancedPagerActionType Enumeration
See Also Send Feedback
Enumerates the Grid advanced pager action type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridAdvancedPagerActionType
Visual Basic (Declaration)
Public Enumeration GridAdvancedPagerActionType
Visual C++
public enum class GridAdvancedPagerActionType

Members

Member name | Description
GoToPage | Go-to-page action type in Grid Advanced-Mode Pager.
ChangePageSize | Change-page-size action type in Grid Advanced-Mode Pager.

See Also

Telerik.WebAii.Controls.Html Namespace


GridColumnSortOrderType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridColumnSortOrderType Enumeration
See Also Send Feedback
Enumerates the Grid column sort order type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridColumnSortOrderType
Visual Basic (Declaration)
Public Enumeration GridColumnSortOrderType
Visual C++
public enum class GridColumnSortOrderType

Members

Member name | Description
None | Column is not sorted.
Ascending | Column is sorted in 'Ascending' order.
Descending | Column is sorted in 'Descending' order.

See Also

Telerik.WebAii.Controls.Html Namespace


GridCommandItemLocation Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridCommandItemLocation Enumeration
See Also Send Feedback
Enumerates the Grid command item lcation -- either 'top' or 'bottom' command item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridCommandItemLocation
Visual Basic (Declaration)
Public Enumeration GridCommandItemLocation
Visual C++
public enum class GridCommandItemLocation

Members

Member name | Description
Top | The 'Top' command item.
Bottom | The 'Bottom' command item.

See Also

Telerik.WebAii.Controls.Html Namespace


GridCommandItemType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridCommandItemType Enumeration
See Also Send Feedback
Enumerates the Grid command item type. The standard 'AddNew' and 'Refresh' are supported.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridCommandItemType
Visual Basic (Declaration)
Public Enumeration GridCommandItemType
Visual C++
public enum class GridCommandItemType

Members

Member name | Description
AddNew | The 'AddNew' command type.
Refresh | The 'Refresh' command type.

See Also

Telerik.WebAii.Controls.Html Namespace


GridConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants Class
Members See Also Send Feedback
The Grid constants used in the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class GridConstants
Visual Basic (Declaration)
Public NotInheritable Class GridConstants
Visual C++
public ref class GridConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.GridConstants

See Also

GridConstants Members
Telerik.WebAii.Controls.Html Namespace


GridConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants Members
GridConstants Class Fields See Also Send Feedback

The GridConstants type exposes the following members.

Fields

Name | Description
ColumnKey | The Grid table column key used accross the verifications and action messages.
CssAdvancedPart | CSS class of the Grid pager navigation buttons part div.
CssArrayPart | CSS class of the Grid pager navigation buttons part div.
CssCollapse | CSS class of the Grid "collapse" input button.
CssCommandAdd | CSS class of the Grid Command item 'add new' button.
CssCommandRefresh | CSS class of the Grid Command item 'refresh' button.
CssDetailTable | The unique CSS class of the detail table.
CssExpand | CSS class of the Grid "expand" input button.
CssExpandCol | CSS class of the Grid hierarchy expand/collapse column.
CssFilter | CSS class of the Grid filtering input button.
CssGrid | The unique CSS class of the Grid div element.
CssGridAltRow | CSS class of the Grid alternating row item.
CssGridCommandRow | CSS class of the Grid Command item.
CssGridEditForm | CSS class of the Grid edit form item.
CssGridEditRow | CSS class of the Grid edited row item.
CssGridFilterRow | CSS class of the Grid filter item.
CssGridFooter | CSS class of the Grid footer item.
CssGridHeader | CSS class of the Grid header item.
CssGridPager | CSS class of the Grid pager item.
CssGridRow | CSS class of the Grid row item.
CssGroupCol | CSS class of the Grid group separator column.
CssGroupHeader | CSS class of the Grid group header item.
CssGroupPanelItem | CSS class of the Grid grouping panel item.
CssInfoPart | CSS class of the Grid pager info part div.
CssMasterTable | The unique CSS class of the master table.
CssNumberPart | CSS class of the Grid pager number part div.
CssPageFirst | CSS class of the Grid pager "first page" button.
CssPageLast | CSS class of the Grid pager "last page" button.
CssPageNext | CSS class of the Grid pager "next page" button.
CssPagePrevious | CSS class of the Grid pager "previous page" button.
CssPagerCell | CSS class of the Grid pager cell.
CssResizeCol | CSS class of built-in resize column.
CssSort | CSS class of the Grid sorting input button.
CssSortAscending | CSS class of the Grid sorting input button - 'Asc' order.
CssSortDescending | CSS class of the Grid sorting input button - 'Desc' order.
CssUngroupButton | Css class of the Ungroup button.
CssWrap | CSS class of the Grid pager wrap div.
DataCellKey | The Grid data cell key used accross the verifications and action messages.
DataItemKey | The Grid Data Item key used accross the verifications and action messages.
FilterKey | The Grid filter item key used accross the verifications and action messages.
FooterKey | The Grid Footer key used accross the verifications and action messages.
GridKey | The Grid key used accross the verifications and action messages.
GroupItemKey | The Grid group item key used accross the verifications and action messages.
GroupKey | The Grid group item key used accross the verifications and action messages.
GroupPanelKey | The Grid group panel key used accross the verifications and action messages.
HeaderKey | The Grid Data header key used accross the verifications and action messages.
IdCancelButton | Id of the auto generated edit form "Cancel" button.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdCommandItemAddNew | Id of the CommandItem "Insert" button.
IdCommandItemRefresh | Id of the CommandItem "Rebind" button.
IdDeleteButton | Id of the auto generated "Delete" button.
IdDeleteColumn | The GridButtonColumn with Command "Delete" image button ID ending part.
IdEditButton | Id of the auto generated "Edit" button.
IdFilteringContextMenu | The unique part of the Grid context menu control Id.
IdGoToPage | Id of the "go to page" Advanced Pager button.
IdGridData | Id of the Grid Data div in scrolling mode.
IdGroupPanel | Id of the Grid group panel.
IdHierarchyButton | The ID of the hierarchy image button.
IdInsertButton | Id of the auto generated insert form "Insert" button.
IdMasterTable | The Id ending part of the Grid master table.
IdSelectCheckBox | Id of the ClientSelectCheckBox column check boxes.
IdUpdateButton | Id of the auto generated edit form "Update" button.
PagerKey | The Grid Pager key used accross the verifications and action messages.
TableKey | The Grid table key used accross the verifications and action messages.

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GridConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants Fields
GridConstants Class See Also Send Feedback

The GridConstants type exposes the following members.

Fields

Name | Description
ColumnKey | The Grid table column key used accross the verifications and action messages.
CssAdvancedPart | CSS class of the Grid pager navigation buttons part div.
CssArrayPart | CSS class of the Grid pager navigation buttons part div.
CssCollapse | CSS class of the Grid "collapse" input button.
CssCommandAdd | CSS class of the Grid Command item 'add new' button.
CssCommandRefresh | CSS class of the Grid Command item 'refresh' button.
CssDetailTable | The unique CSS class of the detail table.
CssExpand | CSS class of the Grid "expand" input button.
CssExpandCol | CSS class of the Grid hierarchy expand/collapse column.
CssFilter | CSS class of the Grid filtering input button.
CssGrid | The unique CSS class of the Grid div element.
CssGridAltRow | CSS class of the Grid alternating row item.
CssGridCommandRow | CSS class of the Grid Command item.
CssGridEditForm | CSS class of the Grid edit form item.
CssGridEditRow | CSS class of the Grid edited row item.
CssGridFilterRow | CSS class of the Grid filter item.
CssGridFooter | CSS class of the Grid footer item.
CssGridHeader | CSS class of the Grid header item.
CssGridPager | CSS class of the Grid pager item.
CssGridRow | CSS class of the Grid row item.
CssGroupCol | CSS class of the Grid group separator column.
CssGroupHeader | CSS class of the Grid group header item.
CssGroupPanelItem | CSS class of the Grid grouping panel item.
CssInfoPart | CSS class of the Grid pager info part div.
CssMasterTable | The unique CSS class of the master table.
CssNumberPart | CSS class of the Grid pager number part div.
CssPageFirst | CSS class of the Grid pager "first page" button.
CssPageLast | CSS class of the Grid pager "last page" button.
CssPageNext | CSS class of the Grid pager "next page" button.
CssPagePrevious | CSS class of the Grid pager "previous page" button.
CssPagerCell | CSS class of the Grid pager cell.
CssResizeCol | CSS class of built-in resize column.
CssSort | CSS class of the Grid sorting input button.
CssSortAscending | CSS class of the Grid sorting input button - 'Asc' order.
CssSortDescending | CSS class of the Grid sorting input button - 'Desc' order.
CssUngroupButton | Css class of the Ungroup button.
CssWrap | CSS class of the Grid pager wrap div.
DataCellKey | The Grid data cell key used accross the verifications and action messages.
DataItemKey | The Grid Data Item key used accross the verifications and action messages.
FilterKey | The Grid filter item key used accross the verifications and action messages.
FooterKey | The Grid Footer key used accross the verifications and action messages.
GridKey | The Grid key used accross the verifications and action messages.
GroupItemKey | The Grid group item key used accross the verifications and action messages.
GroupKey | The Grid group item key used accross the verifications and action messages.
GroupPanelKey | The Grid group panel key used accross the verifications and action messages.
HeaderKey | The Grid Data header key used accross the verifications and action messages.
IdCancelButton | Id of the auto generated edit form "Cancel" button.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdCommandItemAddNew | Id of the CommandItem "Insert" button.
IdCommandItemRefresh | Id of the CommandItem "Rebind" button.
IdDeleteButton | Id of the auto generated "Delete" button.
IdDeleteColumn | The GridButtonColumn with Command "Delete" image button ID ending part.
IdEditButton | Id of the auto generated "Edit" button.
IdFilteringContextMenu | The unique part of the Grid context menu control Id.
IdGoToPage | Id of the "go to page" Advanced Pager button.
IdGridData | Id of the Grid Data div in scrolling mode.
IdGroupPanel | Id of the Grid group panel.
IdHierarchyButton | The ID of the hierarchy image button.
IdInsertButton | Id of the auto generated insert form "Insert" button.
IdMasterTable | The Id ending part of the Grid master table.
IdSelectCheckBox | Id of the ClientSelectCheckBox column check boxes.
IdUpdateButton | Id of the auto generated edit form "Update" button.
PagerKey | The Grid Pager key used accross the verifications and action messages.
TableKey | The Grid table key used accross the verifications and action messages.

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.ColumnKey Field
GridConstants Class See Also Send Feedback
The Grid table column key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColumnKey
Visual Basic (Declaration)
Public Const ColumnKey As String
Visual C++
public:
literal String^ ColumnKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedPart Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssAdvancedPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager navigation buttons part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAdvancedPart
Visual Basic (Declaration)
Public Const CssAdvancedPart As String
Visual C++
public:
literal String^ CssAdvancedPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssArrayPart Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssArrayPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager navigation buttons part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssArrayPart
Visual Basic (Declaration)
Public Const CssArrayPart As String
Visual C++
public:
literal String^ CssArrayPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapse Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssCollapse Field
GridConstants Class See Also Send Feedback
CSS class of the Grid "collapse" input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCollapse
Visual Basic (Declaration)
Public Const CssCollapse As String
Visual C++
public:
literal String^ CssCollapse

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCommandAdd Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssCommandAdd Field
GridConstants Class See Also Send Feedback
CSS class of the Grid Command item 'add new' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCommandAdd
Visual Basic (Declaration)
Public Const CssCommandAdd As String
Visual C++
public:
literal String^ CssCommandAdd

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCommandRefresh Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssCommandRefresh Field
GridConstants Class See Also Send Feedback
CSS class of the Grid Command item 'refresh' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCommandRefresh
Visual Basic (Declaration)
Public Const CssCommandRefresh As String
Visual C++
public:
literal String^ CssCommandRefresh

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDetailTable Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssDetailTable Field
GridConstants Class See Also Send Feedback
The unique CSS class of the detail table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssDetailTable
Visual Basic (Declaration)
Public Const CssDetailTable As String
Visual C++
public:
literal String^ CssDetailTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpand Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssExpand Field
GridConstants Class See Also Send Feedback
CSS class of the Grid "expand" input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssExpand
Visual Basic (Declaration)
Public Const CssExpand As String
Visual C++
public:
literal String^ CssExpand

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpandCol Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssExpandCol Field
GridConstants Class See Also Send Feedback
CSS class of the Grid hierarchy expand/collapse column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssExpandCol
Visual Basic (Declaration)
Public Const CssExpandCol As String
Visual C++
public:
literal String^ CssExpandCol

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilter Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssFilter Field
GridConstants Class See Also Send Feedback
CSS class of the Grid filtering input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssFilter
Visual Basic (Declaration)
Public Const CssFilter As String
Visual C++
public:
literal String^ CssFilter

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGrid Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGrid Field
GridConstants Class See Also Send Feedback
The unique CSS class of the Grid div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGrid
Visual Basic (Declaration)
Public Const CssGrid As String
Visual C++
public:
literal String^ CssGrid

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridAltRow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridAltRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid alternating row item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridAltRow
Visual Basic (Declaration)
Public Const CssGridAltRow As String
Visual C++
public:
literal String^ CssGridAltRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridCommandRow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridCommandRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid Command item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridCommandRow
Visual Basic (Declaration)
Public Const CssGridCommandRow As String
Visual C++
public:
literal String^ CssGridCommandRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridEditForm Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridEditForm Field
GridConstants Class See Also Send Feedback
CSS class of the Grid edit form item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridEditForm
Visual Basic (Declaration)
Public Const CssGridEditForm As String
Visual C++
public:
literal String^ CssGridEditForm

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridEditRow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridEditRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid edited row item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridEditRow
Visual Basic (Declaration)
Public Const CssGridEditRow As String
Visual C++
public:
literal String^ CssGridEditRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridFilterRow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridFilterRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid filter item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridFilterRow
Visual Basic (Declaration)
Public Const CssGridFilterRow As String
Visual C++
public:
literal String^ CssGridFilterRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridFooter Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridFooter Field
GridConstants Class See Also Send Feedback
CSS class of the Grid footer item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridFooter
Visual Basic (Declaration)
Public Const CssGridFooter As String
Visual C++
public:
literal String^ CssGridFooter

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridHeader Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridHeader Field
GridConstants Class See Also Send Feedback
CSS class of the Grid header item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridHeader
Visual Basic (Declaration)
Public Const CssGridHeader As String
Visual C++
public:
literal String^ CssGridHeader

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridPager Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridPager Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridPager
Visual Basic (Declaration)
Public Const CssGridPager As String
Visual C++
public:
literal String^ CssGridPager

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridRow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGridRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid row item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGridRow
Visual Basic (Declaration)
Public Const CssGridRow As String
Visual C++
public:
literal String^ CssGridRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGroupCol Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGroupCol Field
GridConstants Class See Also Send Feedback
CSS class of the Grid group separator column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGroupCol
Visual Basic (Declaration)
Public Const CssGroupCol As String
Visual C++
public:
literal String^ CssGroupCol

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGroupHeader Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGroupHeader Field
GridConstants Class See Also Send Feedback
CSS class of the Grid group header item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGroupHeader
Visual Basic (Declaration)
Public Const CssGroupHeader As String
Visual C++
public:
literal String^ CssGroupHeader

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGroupPanelItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssGroupPanelItem Field
GridConstants Class See Also Send Feedback
CSS class of the Grid grouping panel item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssGroupPanelItem
Visual Basic (Declaration)
Public Const CssGroupPanelItem As String
Visual C++
public:
literal String^ CssGroupPanelItem

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInfoPart Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssInfoPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager info part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssInfoPart
Visual Basic (Declaration)
Public Const CssInfoPart As String
Visual C++
public:
literal String^ CssInfoPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMasterTable Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssMasterTable Field
GridConstants Class See Also Send Feedback
The unique CSS class of the master table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMasterTable
Visual Basic (Declaration)
Public Const CssMasterTable As String
Visual C++
public:
literal String^ CssMasterTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNumberPart Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssNumberPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager number part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNumberPart
Visual Basic (Declaration)
Public Const CssNumberPart As String
Visual C++
public:
literal String^ CssNumberPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageFirst Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssPageFirst Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "first page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPageFirst
Visual Basic (Declaration)
Public Const CssPageFirst As String
Visual C++
public:
literal String^ CssPageFirst

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageLast Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssPageLast Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "last page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPageLast
Visual Basic (Declaration)
Public Const CssPageLast As String
Visual C++
public:
literal String^ CssPageLast

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageNext Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssPageNext Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "next page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPageNext
Visual Basic (Declaration)
Public Const CssPageNext As String
Visual C++
public:
literal String^ CssPageNext

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagePrevious Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssPagePrevious Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "previous page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPagePrevious
Visual Basic (Declaration)
Public Const CssPagePrevious As String
Visual C++
public:
literal String^ CssPagePrevious

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagerCell Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssPagerCell Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPagerCell
Visual Basic (Declaration)
Public Const CssPagerCell As String
Visual C++
public:
literal String^ CssPagerCell

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeCol Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssResizeCol Field
GridConstants Class See Also Send Feedback
CSS class of built-in resize column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssResizeCol
Visual Basic (Declaration)
Public Const CssResizeCol As String
Visual C++
public:
literal String^ CssResizeCol

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSort Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssSort Field
GridConstants Class See Also Send Feedback
CSS class of the Grid sorting input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSort
Visual Basic (Declaration)
Public Const CssSort As String
Visual C++
public:
literal String^ CssSort

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortAscending Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssSortAscending Field
GridConstants Class See Also Send Feedback
CSS class of the Grid sorting input button - 'Asc' order.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSortAscending
Visual Basic (Declaration)
Public Const CssSortAscending As String
Visual C++
public:
literal String^ CssSortAscending

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortDescending Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssSortDescending Field
GridConstants Class See Also Send Feedback
CSS class of the Grid sorting input button - 'Desc' order.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSortDescending
Visual Basic (Declaration)
Public Const CssSortDescending As String
Visual C++
public:
literal String^ CssSortDescending

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssUngroupButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssUngroupButton Field
GridConstants Class See Also Send Feedback
Css class of the Ungroup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssUngroupButton
Visual Basic (Declaration)
Public Const CssUngroupButton As String
Visual C++
public:
literal String^ CssUngroupButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssWrap Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.CssWrap Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager wrap div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssWrap
Visual Basic (Declaration)
Public Const CssWrap As String
Visual C++
public:
literal String^ CssWrap

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


DataCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.DataCellKey Field
GridConstants Class See Also Send Feedback
The Grid data cell key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DataCellKey
Visual Basic (Declaration)
Public Const DataCellKey As String
Visual C++
public:
literal String^ DataCellKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


DataItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.DataItemKey Field
GridConstants Class See Also Send Feedback
The Grid Data Item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DataItemKey
Visual Basic (Declaration)
Public Const DataItemKey As String
Visual C++
public:
literal String^ DataItemKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.FilterKey Field
GridConstants Class See Also Send Feedback
The Grid filter item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FilterKey
Visual Basic (Declaration)
Public Const FilterKey As String
Visual C++
public:
literal String^ FilterKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


FooterKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.FooterKey Field
GridConstants Class See Also Send Feedback
The Grid Footer key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FooterKey
Visual Basic (Declaration)
Public Const FooterKey As String
Visual C++
public:
literal String^ FooterKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GridKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.GridKey Field
GridConstants Class See Also Send Feedback
The Grid key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridKey
Visual Basic (Declaration)
Public Const GridKey As String
Visual C++
public:
literal String^ GridKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GroupItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.GroupItemKey Field
GridConstants Class See Also Send Feedback
The Grid group item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GroupItemKey
Visual Basic (Declaration)
Public Const GroupItemKey As String
Visual C++
public:
literal String^ GroupItemKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GroupKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.GroupKey Field
GridConstants Class See Also Send Feedback
The Grid group item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GroupKey
Visual Basic (Declaration)
Public Const GroupKey As String
Visual C++
public:
literal String^ GroupKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GroupPanelKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.GroupPanelKey Field
GridConstants Class See Also Send Feedback
The Grid group panel key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GroupPanelKey
Visual Basic (Declaration)
Public Const GroupPanelKey As String
Visual C++
public:
literal String^ GroupPanelKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


HeaderKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.HeaderKey Field
GridConstants Class See Also Send Feedback
The Grid Data header key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HeaderKey
Visual Basic (Declaration)
Public Const HeaderKey As String
Visual C++
public:
literal String^ HeaderKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCancelButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdCancelButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated edit form "Cancel" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdCancelButton
Visual Basic (Declaration)
Public Const IdCancelButton As String
Visual C++
public:
literal String^ IdCancelButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdChangePageSize Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdChangePageSize Field
GridConstants Class See Also Send Feedback
Id of the "change page size" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdChangePageSize
Visual Basic (Declaration)
Public Const IdChangePageSize As String
Visual C++
public:
literal String^ IdChangePageSize

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemAddNew Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdCommandItemAddNew Field
GridConstants Class See Also Send Feedback
Id of the CommandItem "Insert" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdCommandItemAddNew
Visual Basic (Declaration)
Public Const IdCommandItemAddNew As String
Visual C++
public:
literal String^ IdCommandItemAddNew

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemRefresh Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdCommandItemRefresh Field
GridConstants Class See Also Send Feedback
Id of the CommandItem "Rebind" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdCommandItemRefresh
Visual Basic (Declaration)
Public Const IdCommandItemRefresh As String
Visual C++
public:
literal String^ IdCommandItemRefresh

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdDeleteButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdDeleteButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated "Delete" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdDeleteButton
Visual Basic (Declaration)
Public Const IdDeleteButton As String
Visual C++
public:
literal String^ IdDeleteButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdDeleteColumn Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdDeleteColumn Field
GridConstants Class See Also Send Feedback
The GridButtonColumn with Command "Delete" image button ID ending part.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdDeleteColumn
Visual Basic (Declaration)
Public Const IdDeleteColumn As String
Visual C++
public:
literal String^ IdDeleteColumn

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdEditButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdEditButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated "Edit" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdEditButton
Visual Basic (Declaration)
Public Const IdEditButton As String
Visual C++
public:
literal String^ IdEditButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdFilteringContextMenu Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdFilteringContextMenu Field
GridConstants Class See Also Send Feedback
The unique part of the Grid context menu control Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdFilteringContextMenu
Visual Basic (Declaration)
Public Const IdFilteringContextMenu As String
Visual C++
public:
literal String^ IdFilteringContextMenu

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGoToPage Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdGoToPage Field
GridConstants Class See Also Send Feedback
Id of the "go to page" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdGoToPage
Visual Basic (Declaration)
Public Const IdGoToPage As String
Visual C++
public:
literal String^ IdGoToPage

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGridData Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdGridData Field
GridConstants Class See Also Send Feedback
Id of the Grid Data div in scrolling mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdGridData
Visual Basic (Declaration)
Public Const IdGridData As String
Visual C++
public:
literal String^ IdGridData

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGroupPanel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdGroupPanel Field
GridConstants Class See Also Send Feedback
Id of the Grid group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdGroupPanel
Visual Basic (Declaration)
Public Const IdGroupPanel As String
Visual C++
public:
literal String^ IdGroupPanel

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdHierarchyButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdHierarchyButton Field
GridConstants Class See Also Send Feedback
The ID of the hierarchy image button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdHierarchyButton
Visual Basic (Declaration)
Public Const IdHierarchyButton As String
Visual C++
public:
literal String^ IdHierarchyButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdInsertButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdInsertButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated insert form "Insert" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdInsertButton
Visual Basic (Declaration)
Public Const IdInsertButton As String
Visual C++
public:
literal String^ IdInsertButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdMasterTable Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdMasterTable Field
GridConstants Class See Also Send Feedback
The Id ending part of the Grid master table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdMasterTable
Visual Basic (Declaration)
Public Const IdMasterTable As String
Visual C++
public:
literal String^ IdMasterTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSelectCheckBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdSelectCheckBox Field
GridConstants Class See Also Send Feedback
Id of the ClientSelectCheckBox column check boxes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSelectCheckBox
Visual Basic (Declaration)
Public Const IdSelectCheckBox As String
Visual C++
public:
literal String^ IdSelectCheckBox

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdUpdateButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.IdUpdateButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated edit form "Update" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdUpdateButton
Visual Basic (Declaration)
Public Const IdUpdateButton As String
Visual C++
public:
literal String^ IdUpdateButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


PagerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.PagerKey Field
GridConstants Class See Also Send Feedback
The Grid Pager key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PagerKey
Visual Basic (Declaration)
Public Const PagerKey As String
Visual C++
public:
literal String^ PagerKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


TableKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridConstants..::.TableKey Field
GridConstants Class See Also Send Feedback
The Grid table key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TableKey
Visual Basic (Declaration)
Public Const TableKey As String
Visual C++
public:
literal String^ TableKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GridDataCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX data cell control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridDataCell : HtmlTableCell
Visual Basic (Declaration)
Public Class GridDataCell _
    Inherits HtmlTableCell
Visual C++
public ref class GridDataCell : public HtmlTableCell

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableCell
Telerik.WebAii.Controls.Html..::.GridDataCell

See Also

GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


GridDataCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Members
GridDataCell Class Constructors Methods Properties See Also Send Feedback

The GridDataCell type exposes the following members.

Constructors

Name | Description
GridDataCell | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Cancel | Performs 'cancel editing' action when in edit mode.
Capture | Overloaded.
Click | Overloaded.
ClientSelectCheckBoxClick | Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.
ControlAssert | Returns RadControlAssert instance initialized for this control.
DeleteButtonClick | Built-in 'Delete' button click to delete the item. Throws InvalidOperationException if the delete button cannot be located.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
EditButtonClick | Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandCollapseButtonClick | Expand/collapse button click to expand/collapse the item in Grid hierarchy mode. Throws InvalidOperationException in case of a plain Grid.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Update | Performs 'update item' action when in edit mode.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CanDeleteItem | Get whether a built-in 'delete' item button is available in this cell so the parent item can be deleted.
CanEditItem | Get whether a built-in 'edit' item button is available in this cell so the parent item can be edited.
CanExpandCollapseItem | Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
CellText | The text of this Grid data cell.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator IFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ParentItemIndex | The parent data item index.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GridDataCell Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Constructor
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
GridDataCell()()() | Initializes a new instance of the GridDataCell class.
GridDataCell(Element) | Initializes a new instance of the GridDataCell class.

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


GridDataCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Constructor
GridDataCell Class See Also Send Feedback
Initializes a new instance of the GridDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridDataCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridDataCell()

See Also

GridDataCell Class
GridDataCell Overload
Telerik.WebAii.Controls.Html Namespace


GridDataCell Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Constructor (Element)
GridDataCell Class See Also Send Feedback
Initializes a new instance of the GridDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridDataCell(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridDataCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridDataCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridDataCell Class
GridDataCell Overload
Telerik.WebAii.Controls.Html Namespace


GridDataCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Methods
GridDataCell Class See Also Send Feedback

The GridDataCell type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Cancel | Performs 'cancel editing' action when in edit mode.
Capture | Overloaded.
Click | Overloaded.
ClientSelectCheckBoxClick | Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.
ControlAssert | Returns RadControlAssert instance initialized for this control.
DeleteButtonClick | Built-in 'Delete' button click to delete the item. Throws InvalidOperationException if the delete button cannot be located.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
EditButtonClick | Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandCollapseButtonClick | Expand/collapse button click to expand/collapse the item in Grid hierarchy mode. Throws InvalidOperationException in case of a plain Grid.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Update | Performs 'update item' action when in edit mode.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.AssignElement Method
GridDataCell Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.CallMethod Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Cancel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.Cancel Method
GridDataCell Class See Also Send Feedback
Performs 'cancel editing' action when in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.Capture Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.Click Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


ClientSelectCheckBoxClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.ClientSelectCheckBoxClick Method
GridDataCell Class See Also Send Feedback
Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClientSelectCheckBoxClick()
Visual Basic (Declaration)
Public Sub ClientSelectCheckBoxClick
Visual C++
public:
void ClientSelectCheckBoxClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.ControlAssert Method
GridDataCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


DeleteButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.DeleteButtonClick Method
GridDataCell Class See Also Send Feedback
Built-in 'Delete' button click to delete the item. Throws InvalidOperationException if the delete button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DeleteButtonClick()
Visual Basic (Declaration)
Public Sub DeleteButtonClick
Visual C++
public:
void DeleteButtonClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.DragTo Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


EditButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.EditButtonClick Method
GridDataCell Class See Also Send Feedback
Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void EditButtonClick()
Visual Basic (Declaration)
Public Sub EditButtonClick
Visual C++
public:
void EditButtonClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


ExpandCollapseButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.ExpandCollapseButtonClick Method
GridDataCell Class See Also Send Feedback
Expand/collapse button click to expand/collapse the item in Grid hierarchy mode. Throws InvalidOperationException in case of a plain Grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ExpandCollapseButtonClick()
Visual Basic (Declaration)
Public Sub ExpandCollapseButtonClick
Visual C++
public:
void ExpandCollapseButtonClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.GetValue Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.InvokeEvent Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.MouseClick Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.MouseHover Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.ScrollToVisible Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.SetValue Method
GridDataCell Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Update Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.Update Method
GridDataCell Class See Also Send Feedback
Performs 'update item' action when in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Update()
Visual Basic (Declaration)
Public Sub Update
Visual C++
public:
void Update()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GridDataCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell Properties
GridDataCell Class See Also Send Feedback

The GridDataCell type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CanDeleteItem | Get whether a built-in 'delete' item button is available in this cell so the parent item can be deleted.
CanEditItem | Get whether a built-in 'edit' item button is available in this cell so the parent item can be edited.
CanExpandCollapseItem | Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
CellText | The text of this Grid data cell.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator IFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ParentItemIndex | The parent data item index.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CanDeleteItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.CanDeleteItem Property
GridDataCell Class See Also Send Feedback
Get whether a built-in 'delete' item button is available in this cell so the parent item can be deleted.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanDeleteItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanDeleteItem As Boolean
Visual C++
public:
property bool CanDeleteItem {
    bool get ();
}

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CanEditItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.CanEditItem Property
GridDataCell Class See Also Send Feedback
Get whether a built-in 'edit' item button is available in this cell so the parent item can be edited.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanEditItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanEditItem As Boolean
Visual C++
public:
property bool CanEditItem {
    bool get ();
}

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CanExpandCollapseItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.CanExpandCollapseItem Property
GridDataCell Class See Also Send Feedback
Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanExpandCollapseItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanExpandCollapseItem As Boolean
Visual C++
public:
property bool CanExpandCollapseItem {
    bool get ();
}

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CellText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.CellText Property
GridDataCell Class See Also Send Feedback
The text of this Grid data cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CellText { get; }
Visual Basic (Declaration)
Public ReadOnly Property CellText As String
Visual C++
public:
property String^ CellText {
    String^ get ();
}

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.LocatorExpression Property
GridDataCell Class See Also Send Feedback
Get the locator IFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


ParentItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataCell..::.ParentItemIndex Property
GridDataCell Class See Also Send Feedback
The parent data item index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ParentItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentItemIndex As Integer
Visual C++
public:
property int ParentItemIndex {
    int get ();
}

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GridDataItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX data item control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridDataItem : HtmlTableRow
Visual Basic (Declaration)
Public Class GridDataItem _
    Inherits HtmlTableRow
Visual C++
public ref class GridDataItem : public HtmlTableRow

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableRow
Telerik.WebAii.Controls.Html..::.GridDataItem

See Also

GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


GridDataItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Members
GridDataItem Class Constructors Methods Properties See Also Send Feedback

The GridDataItem type exposes the following members.

Constructors

Name | Description
GridDataItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapses the current item in case of hierarchy and the item is expanded. Throws InvalidOperationException otherwise.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the current item in case of hierarchy and the item is collapsed. Throws InvalidOperationException otherwise.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetRowIndex | Gets the row index of a row.
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CanDelete | Get whether the item can be deleted, e.g. whether the Grid parent table contains built-in delete column.
CanEdit | Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.
CanExpand | Get whether the item can be expanded, e.g. whether the Grid is in hierarchy mode.
CanSelect | Get whether the item can be selected, e.g. whether the Grid has ClientSettings.Selecting.AllowRowSelect set to 'true'.
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the control client-side locator, determining which base script initializes the data item object on the client. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DataCells | Get the list of item's data cells direct children (note the RadGrid hierarchy mode).
Edited | Get whether this item has edit form opened.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Get whether the data item is expanded so that a detail table is displayed. Use this property when 'CanExpand' returns 'true'.
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
ItemId | The data item Id client-side value.
ItemIndex | The data item index.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator IFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get whether the item is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the data item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GridDataItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Constructor
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
GridDataItem()()() | Initializes a new instance of the GridDataItem class.
GridDataItem(Element) | Initializes a new instance of the GridDataItem class.

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


GridDataItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Constructor
GridDataItem Class See Also Send Feedback
Initializes a new instance of the GridDataItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridDataItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridDataItem()

See Also

GridDataItem Class
GridDataItem Overload
Telerik.WebAii.Controls.Html Namespace


GridDataItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Constructor (Element)
GridDataItem Class See Also Send Feedback
Initializes a new instance of the GridDataItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridDataItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridDataItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridDataItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridDataItem Class
GridDataItem Overload
Telerik.WebAii.Controls.Html Namespace


GridDataItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Methods
GridDataItem Class See Also Send Feedback

The GridDataItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapses the current item in case of hierarchy and the item is expanded. Throws InvalidOperationException otherwise.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the current item in case of hierarchy and the item is collapsed. Throws InvalidOperationException otherwise.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetRowIndex | Gets the row index of a row.
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.AssignElement Method
GridDataItem Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.CallMethod Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Capture Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Click Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Collapse Method
GridDataItem Class See Also Send Feedback
Collapses the current item in case of hierarchy and the item is expanded. Throws InvalidOperationException otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.ControlAssert Method
GridDataItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.DragTo Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Expand Method
GridDataItem Class See Also Send Feedback
Expands the current item in case of hierarchy and the item is collapsed. Throws InvalidOperationException otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetRowIndex Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.GetRowIndex Method
GridDataItem Class See Also Send Feedback
Gets the row index of a row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static int GetRowIndex(
    string id
)
Visual Basic (Declaration)
Public Shared Function GetRowIndex ( _
    id As String _
) As Integer
Visual C++
public:
static int GetRowIndex(
    String^ id
)

Parameters

id
Type: System..::.String
The Id of the row.

Return Value

The index of the row.

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.GetValue Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.InvokeEvent Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.MouseClick Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.MouseHover Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.ScrollToVisible Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.SetValue Method
GridDataItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


GridDataItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem Properties
GridDataItem Class See Also Send Feedback

The GridDataItem type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CanDelete | Get whether the item can be deleted, e.g. whether the Grid parent table contains built-in delete column.
CanEdit | Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.
CanExpand | Get whether the item can be expanded, e.g. whether the Grid is in hierarchy mode.
CanSelect | Get whether the item can be selected, e.g. whether the Grid has ClientSettings.Selecting.AllowRowSelect set to 'true'.
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the control client-side locator, determining which base script initializes the data item object on the client. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DataCells | Get the list of item's data cells direct children (note the RadGrid hierarchy mode).
Edited | Get whether this item has edit form opened.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Get whether the data item is expanded so that a detail table is displayed. Use this property when 'CanExpand' returns 'true'.
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
ItemId | The data item Id client-side value.
ItemIndex | The data item index.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator IFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get whether the item is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the data item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


CanDelete Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.CanDelete Property
GridDataItem Class See Also Send Feedback
Get whether the item can be deleted, e.g. whether the Grid parent table contains built-in delete column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanDelete { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanDelete As Boolean
Visual C++
public:
property bool CanDelete {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


CanEdit Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.CanEdit Property
GridDataItem Class See Also Send Feedback
Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanEdit { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanEdit As Boolean
Visual C++
public:
property bool CanEdit {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


CanExpand Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.CanExpand Property
GridDataItem Class See Also Send Feedback
Get whether the item can be expanded, e.g. whether the Grid is in hierarchy mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanExpand { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanExpand As Boolean
Visual C++
public:
property bool CanExpand {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


CanSelect Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.CanSelect Property
GridDataItem Class See Also Send Feedback
Get whether the item can be selected, e.g. whether the Grid has ClientSettings.Selecting.AllowRowSelect set to 'true'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanSelect { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
Visual C++
public:
property bool CanSelect {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.ClientSideLocator Property
GridDataItem Class See Also Send Feedback
Get the control client-side locator, determining which base script initializes the data item object on the client.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


DataCells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.DataCells Property
GridDataItem Class See Also Send Feedback
Get the list of item's data cells direct children (note the RadGrid hierarchy mode).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridDataCell> DataCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataCells As IList(Of GridDataCell)
Visual C++
public:
property IList<GridDataCell^>^ DataCells {
    IList<GridDataCell^>^ get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


Edited Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Edited Property
GridDataItem Class See Also Send Feedback
Get whether this item has edit form opened.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Edited { get; }
Visual Basic (Declaration)
Public ReadOnly Property Edited As Boolean
Visual C++
public:
property bool Edited {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


Expanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Expanded Property
GridDataItem Class See Also Send Feedback
Get whether the data item is expanded so that a detail table is displayed. Use this property when 'CanExpand' returns 'true'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Expanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expanded As Boolean
Visual C++
public:
property bool Expanded {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


ItemId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.ItemId Property
GridDataItem Class See Also Send Feedback
The data item Id client-side value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.ItemIndex Property
GridDataItem Class See Also Send Feedback
The data item index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.LocatorExpression Property
GridDataItem Class See Also Send Feedback
Get the item locator IFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Selected Property
GridDataItem Class See Also Send Feedback
Get whether the item is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridDataItem..::.Visible Property
GridDataItem Class See Also Send Feedback
Get whether the data item is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GridEditForm Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX edit form control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridEditForm : HtmlDiv
Visual Basic (Declaration)
Public Class GridEditForm _
    Inherits HtmlDiv
Visual C++
public ref class GridEditForm : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.GridEditForm

See Also

GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


GridEditForm Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Members
GridEditForm Class Constructors Methods Properties See Also Send Feedback

The GridEditForm type exposes the following members.

Constructors

Name | Description
GridEditForm | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Cancel | Performs 'cancel editing/inserting' action for the edit form.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Insert | Performs 'insert item' action for the edit form.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Update | Performs 'update item' action for the edit form.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


GridEditForm Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Constructor
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
GridEditForm()()() | Initializes a new instance of the GridEditForm class.
GridEditForm(Element) | Initializes a new instance of the GridEditForm class.

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


GridEditForm Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Constructor
GridEditForm Class See Also Send Feedback
Initializes a new instance of the GridEditForm class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridEditForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridEditForm()

See Also

GridEditForm Class
GridEditForm Overload
Telerik.WebAii.Controls.Html Namespace


GridEditForm Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Constructor (Element)
GridEditForm Class See Also Send Feedback
Initializes a new instance of the GridEditForm class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridEditForm(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridEditForm(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridEditForm.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridEditForm Class
GridEditForm Overload
Telerik.WebAii.Controls.Html Namespace


GridEditForm Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Methods
GridEditForm Class See Also Send Feedback

The GridEditForm type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Cancel | Performs 'cancel editing/inserting' action for the edit form.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Insert | Performs 'insert item' action for the edit form.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Update | Performs 'update item' action for the edit form.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.AssignElement Method
GridEditForm Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.CallMethod Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Cancel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.Cancel Method
GridEditForm Class See Also Send Feedback
Performs 'cancel editing/inserting' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.Capture Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.Click Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.DragTo Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.GetValue Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Insert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.Insert Method
GridEditForm Class See Also Send Feedback
Performs 'insert item' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Insert()
Visual Basic (Declaration)
Public Sub Insert
Visual C++
public:
void Insert()

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.InvokeEvent Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.MouseClick Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.MouseHover Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.ScrollToVisible Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.SetValue Method
GridEditForm Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Update Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.Update Method
GridEditForm Class See Also Send Feedback
Performs 'update item' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Update()
Visual Basic (Declaration)
Public Sub Update
Visual C++
public:
void Update()

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


GridEditForm Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm Properties
GridEditForm Class See Also Send Feedback

The GridEditForm type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditForm..::.LocatorExpression Property
GridEditForm Class See Also Send Feedback
Get the item locator HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


GridEditFormActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditFormActionType Enumeration
See Also Send Feedback
Enumerates the Grid edit form action type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridEditFormActionType
Visual Basic (Declaration)
Public Enumeration GridEditFormActionType
Visual C++
public enum class GridEditFormActionType

Members

Member name | Description
Insert | The 'Insert' command type.
Update | The 'Update' command type.
Cancel | The 'Cancel' command type.

See Also

Telerik.WebAii.Controls.Html Namespace


GridEditModeType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridEditModeType Enumeration
See Also Send Feedback
Enumerates the Grid edit mode type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridEditModeType
Visual Basic (Declaration)
Public Enumeration GridEditModeType
Visual C++
public enum class GridEditModeType

Members

Member name | Description
InForms | In-forms (edit form) edit mode.
InLine | In-line edit mode.

See Also

Telerik.WebAii.Controls.Html Namespace


GridFilterItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX filter item control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridFilterItem : HtmlTableRow
Visual Basic (Declaration)
Public Class GridFilterItem _
    Inherits HtmlTableRow
Visual C++
public ref class GridFilterItem : public HtmlTableRow

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableRow
Telerik.WebAii.Controls.Html..::.GridFilterItem

See Also

GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Members
GridFilterItem Class Constructors Methods Properties See Also Send Feedback

The GridFilterItem type exposes the following members.

Constructors

Name | Description
GridFilterItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FilterMenuPopup | Click to popup the column filter menu.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Constructor
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
GridFilterItem()()() | Initializes a new instance of the GridFilterItem class.
GridFilterItem(Element) | Initializes a new instance of the GridFilterItem class.

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Constructor
GridFilterItem Class See Also Send Feedback
Initializes a new instance of the GridFilterItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridFilterItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridFilterItem()

See Also

GridFilterItem Class
GridFilterItem Overload
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Constructor (Element)
GridFilterItem Class See Also Send Feedback
Initializes a new instance of the GridFilterItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridFilterItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridFilterItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridFilterItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridFilterItem Class
GridFilterItem Overload
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Methods
GridFilterItem Class See Also Send Feedback

The GridFilterItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FilterMenuPopup | Click to popup the column filter menu.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.AssignElement Method
GridFilterItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.CallMethod Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.Capture Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.Click Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.DragTo Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


FilterMenuPopup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.FilterMenuPopup Method
GridFilterItem Class See Also Send Feedback
Click to popup the column filter menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FilterMenuPopup(
    string columnName
)
Visual Basic (Declaration)
Public Sub FilterMenuPopup ( _
    columnName As String _
)
Visual C++
public:
void FilterMenuPopup(
    String^ columnName
)

Parameters

columnName
Type: System..::.String

[Missing <param name="columnName"/> documentation for "M:Telerik.WebAii.Controls.Html.GridFilterItem.FilterMenuPopup(System.String)"]

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.GetValue Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.InvokeEvent Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.MouseClick Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.MouseHover Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.ScrollToVisible Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.SetValue Method
GridFilterItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem Properties
GridFilterItem Class See Also Send Feedback

The GridFilterItem type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFilterItem..::.LocatorExpression Property
GridFilterItem Class See Also Send Feedback
Get the item locator HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX footer cell control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridFooterCell : HtmlTableCell
Visual Basic (Declaration)
Public Class GridFooterCell _
    Inherits HtmlTableCell
Visual C++
public ref class GridFooterCell : public HtmlTableCell

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableCell
Telerik.WebAii.Controls.Html..::.GridFooterCell

See Also

GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Members
GridFooterCell Class Constructors Methods Properties See Also Send Feedback

The GridFooterCell type exposes the following members.

Constructors

Name | Description
GridFooterCell | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
CellText | The text of this Grid footer cell.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Constructor
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
GridFooterCell()()() | Initializes a new instance of the GridFooterCell class.
GridFooterCell(Element) | Initializes a new instance of the GridFooterCell class.

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Constructor
GridFooterCell Class See Also Send Feedback
Initializes a new instance of the GridFooterCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridFooterCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridFooterCell()

See Also

GridFooterCell Class
GridFooterCell Overload
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Constructor (Element)
GridFooterCell Class See Also Send Feedback
Initializes a new instance of the GridFooterCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridFooterCell(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridFooterCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridFooterCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridFooterCell Class
GridFooterCell Overload
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Methods
GridFooterCell Class See Also Send Feedback

The GridFooterCell type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.AssignElement Method
GridFooterCell Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.CallMethod Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.Capture Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.Click Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.ControlAssert Method
GridFooterCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.DragTo Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.GetValue Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.InvokeEvent Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.MouseClick Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.MouseHover Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.ScrollToVisible Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.SetValue Method
GridFooterCell Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell Properties
GridFooterCell Class See Also Send Feedback

The GridFooterCell type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
CellText | The text of this Grid footer cell.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


CellText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.CellText Property
GridFooterCell Class See Also Send Feedback
The text of this Grid footer cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CellText { get; }
Visual Basic (Declaration)
Public ReadOnly Property CellText As String
Visual C++
public:
property String^ CellText {
    String^ get ();
}

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridFooterCell..::.LocatorExpression Property
GridFooterCell Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


GridGroupExpandCollapseActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupExpandCollapseActionType Enumeration
See Also Send Feedback
Enumerates the Grid group expand/collapse action type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum GridGroupExpandCollapseActionType
Visual Basic (Declaration)
Public Enumeration GridGroupExpandCollapseActionType
Visual C++
public enum class GridGroupExpandCollapseActionType

Members

Member name | Description
Expand | The 'Expand' action type.
Collapse | The 'Collapse' action type.

See Also

Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX group header control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridGroupHeader : HtmlTableRow
Visual Basic (Declaration)
Public Class GridGroupHeader _
    Inherits HtmlTableRow
Visual C++
public ref class GridGroupHeader : public HtmlTableRow

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableRow
Telerik.WebAii.Controls.Html..::.GridGroupHeader

See Also

GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Members
GridGroupHeader Class Constructors Methods Properties See Also Send Feedback

The GridGroupHeader type exposes the following members.

Constructors

Name | Description
GridGroupHeader | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Initiates a 'collapse' action if this group is expanded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Initiates an 'expand' action if this group is collapsed.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Get whether the group is expanded.
Find | Find property (Inherited from HtmlControl.)
HeaderText | The header text of the group.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the LocatorExpression HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Constructor
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
GridGroupHeader()()() | Initializes a new instance of the GridGroupHeader class.
GridGroupHeader(Element) | Initializes a new instance of the GridGroupHeader class.

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Constructor
GridGroupHeader Class See Also Send Feedback
Initializes a new instance of the GridGroupHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridGroupHeader()

See Also

GridGroupHeader Class
GridGroupHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Constructor (Element)
GridGroupHeader Class See Also Send Feedback
Initializes a new instance of the GridGroupHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupHeader(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridGroupHeader(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridGroupHeader.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridGroupHeader Class
GridGroupHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Methods
GridGroupHeader Class See Also Send Feedback

The GridGroupHeader type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Initiates a 'collapse' action if this group is expanded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Initiates an 'expand' action if this group is collapsed.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.AssignElement Method
GridGroupHeader Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.CallMethod Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.Capture Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.Click Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.Collapse Method
GridGroupHeader Class See Also Send Feedback
Initiates a 'collapse' action if this group is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.ControlAssert Method
GridGroupHeader Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.DragTo Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.Expand Method
GridGroupHeader Class See Also Send Feedback
Initiates an 'expand' action if this group is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.GetValue Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.InvokeEvent Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.MouseClick Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.MouseHover Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.ScrollToVisible Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.SetValue Method
GridGroupHeader Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader Properties
GridGroupHeader Class See Also Send Feedback

The GridGroupHeader type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Get whether the group is expanded.
Find | Find property (Inherited from HtmlControl.)
HeaderText | The header text of the group.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the LocatorExpression HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


Expanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.Expanded Property
GridGroupHeader Class See Also Send Feedback
Get whether the group is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Expanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expanded As Boolean
Visual C++
public:
property bool Expanded {
    bool get ();
}

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.HeaderText Property
GridGroupHeader Class See Also Send Feedback
The header text of the group.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupHeader..::.LocatorExpression Property
GridGroupHeader Class See Also Send Feedback
Get the LocatorExpression HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX group panel control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridGroupPanel : HtmlDiv
Visual Basic (Declaration)
Public Class GridGroupPanel _
    Inherits HtmlDiv
Visual C++
public ref class GridGroupPanel : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.GridGroupPanel

See Also

GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Members
GridGroupPanel Class Constructors Methods Properties See Also Send Feedback

The GridGroupPanel type exposes the following members.

Constructors

Name | Description
GridGroupPanel | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToUngroup | Performs DragTo action to ungroup the data by the given field if such group field exists in the group panel. Throws ArgumentException otherwise.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Sort | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
GroupFieldNames | Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
GroupItems | Obsolete. Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of group panel items.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Constructor
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
GridGroupPanel()()() | Initializes a new instance of the GridGroupPanel class.
GridGroupPanel(Element) | Initializes a new instance of the GridGroupPanel class.

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Constructor
GridGroupPanel Class See Also Send Feedback
Initializes a new instance of the GridGroupPanel class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridGroupPanel()

See Also

GridGroupPanel Class
GridGroupPanel Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Constructor (Element)
GridGroupPanel Class See Also Send Feedback
Initializes a new instance of the GridGroupPanel class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupPanel(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridGroupPanel(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridGroupPanel.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridGroupPanel Class
GridGroupPanel Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Methods
GridGroupPanel Class See Also Send Feedback

The GridGroupPanel type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToUngroup | Performs DragTo action to ungroup the data by the given field if such group field exists in the group panel. Throws ArgumentException otherwise.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Sort | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.AssignElement Method
GridGroupPanel Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.CallMethod Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.Capture Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.Click Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.DragTo Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


DragToUngroup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.DragToUngroup Method
GridGroupPanel Class See Also Send Feedback
Performs DragTo action to ungroup the data by the given field if such group field exists in the group panel. Throws ArgumentException otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToUngroup(
    string name
)
Visual Basic (Declaration)
Public Sub DragToUngroup ( _
    name As String _
)
Visual C++
public:
void DragToUngroup(
    String^ name
)

Parameters

name
Type: System..::.String
The group name field to ungroup by.

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.GetValue Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.InvokeEvent Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.MouseClick Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.MouseHover Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.ScrollToVisible Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.SetValue Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.Sort Method
GridGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Sort(Int32) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such index does not exist in the group panel.
Sort(String) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such name does not exist in the group panel.

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Sort Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.Sort Method (Int32)
GridGroupPanel Class See Also Send Feedback
Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such index does not exist in the group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Sort(
    int index
)
Visual Basic (Declaration)
Public Sub Sort ( _
    index As Integer _
)
Visual C++
public:
void Sort(
    int index
)

Parameters

index
Type: System..::.Int32
The group panel item index.

See Also

GridGroupPanel Class
Sort Overload
Telerik.WebAii.Controls.Html Namespace


Sort Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.Sort Method (String)
GridGroupPanel Class See Also Send Feedback
Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such name does not exist in the group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Sort(
    string name
)
Visual Basic (Declaration)
Public Sub Sort ( _
    name As String _
)
Visual C++
public:
void Sort(
    String^ name
)

Parameters

name
Type: System..::.String
The group name field to sort by.

See Also

GridGroupPanel Class
Sort Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel Properties
GridGroupPanel Class See Also Send Feedback

The GridGroupPanel type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
GroupFieldNames | Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
GroupItems | Obsolete. Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of group panel items.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GroupFieldNames Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.GroupFieldNames Property
GridGroupPanel Class See Also Send Feedback
Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string GroupFieldNames { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupFieldNames As String
Visual C++
public:
property String^ GroupFieldNames {
    String^ get ();
}

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GroupItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.GroupItems Property
GridGroupPanel Class See Also Send Feedback
Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
[ObsoleteAttribute("Use the GroupFieldNames property")]
public string GroupItems { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use the GroupFieldNames property")> _
Public ReadOnly Property GroupItems As String
Visual C++
[ObsoleteAttribute(L"Use the GroupFieldNames property")]
public:
property String^ GroupItems {
    String^ get ();
}

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.Items Property
GridGroupPanel Class See Also Send Feedback
Get the list of group panel items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridGroupPanelItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of GridGroupPanelItem)
Visual C++
public:
property IList<GridGroupPanelItem^>^ Items {
    IList<GridGroupPanelItem^>^ get ();
}

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanel..::.LocatorExpression Property
GridGroupPanel Class See Also Send Feedback
Get the item locator HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX group panel item control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridGroupPanelItem : HtmlTableCell
Visual Basic (Declaration)
Public Class GridGroupPanelItem _
    Inherits HtmlTableCell
Visual C++
public ref class GridGroupPanelItem : public HtmlTableCell

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableCell
Telerik.WebAii.Controls.Html..::.GridGroupPanelItem

See Also

GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Members
GridGroupPanelItem Class Constructors Methods Properties See Also Send Feedback

The GridGroupPanelItem type exposes the following members.

Constructors

Name | Description
GridGroupPanelItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Sort | Clicks on the sort button.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Ungroup | Clicks on the ungroup button.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | The index of the GroupPanelItem.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Get the field name of the group panel item.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Constructor
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
GridGroupPanelItem()()() | Initializes a new instance of the GridGroupPanelItem class.
GridGroupPanelItem(Element) | Initializes a new instance of the GridGroupPanelItem class.

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Constructor
GridGroupPanelItem Class See Also Send Feedback
Initializes a new instance of the GridGroupPanelItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupPanelItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridGroupPanelItem()

See Also

GridGroupPanelItem Class
GridGroupPanelItem Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Constructor (Element)
GridGroupPanelItem Class See Also Send Feedback
Initializes a new instance of the GridGroupPanelItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupPanelItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridGroupPanelItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridGroupPanelItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridGroupPanelItem Class
GridGroupPanelItem Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Methods
GridGroupPanelItem Class See Also Send Feedback

The GridGroupPanelItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Sort | Clicks on the sort button.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Ungroup | Clicks on the ungroup button.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.AssignElement Method
GridGroupPanelItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.CallMethod Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.Capture Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.Click Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.DragTo Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.GetValue Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.InvokeEvent Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.MouseClick Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.MouseHover Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.ScrollToVisible Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.SetValue Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.Sort Method
GridGroupPanelItem Class See Also Send Feedback
Clicks on the sort button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort
Visual C++
public:
void Sort()

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


Ungroup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.Ungroup Method
GridGroupPanelItem Class See Also Send Feedback
Clicks on the ungroup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Ungroup()
Visual Basic (Declaration)
Public Sub Ungroup
Visual C++
public:
void Ungroup()

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem Properties
GridGroupPanelItem Class See Also Send Feedback

The GridGroupPanelItem type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | The index of the GroupPanelItem.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | Get the field name of the group panel item.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.Index Property
GridGroupPanelItem Class See Also Send Feedback
The index of the GroupPanelItem.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.LocatorExpression Property
GridGroupPanelItem Class See Also Send Feedback
Get the item locator HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


Name Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridGroupPanelItem..::.Name Property
GridGroupPanelItem Class See Also Send Feedback
Get the field name of the group panel item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


GridHelper Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridHelper Class
Members See Also Send Feedback
A helper class for the RadGrid wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class GridHelper
Visual Basic (Declaration)
Public NotInheritable Class GridHelper
Visual C++
public ref class GridHelper abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.GridHelper

See Also

GridHelper Members
Telerik.WebAii.Controls.Html Namespace


GridHelper Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridHelper Members
GridHelper Class Methods See Also Send Feedback

The GridHelper type exposes the following members.

Methods

Name | Description
IsExpandCollapseButton | Returns whether the button element is expand/collapse.

See Also

GridHelper Class
Telerik.WebAii.Controls.Html Namespace


GridHelper Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridHelper Methods
GridHelper Class See Also Send Feedback

The GridHelper type exposes the following members.

Methods

Name | Description
IsExpandCollapseButton | Returns whether the button element is expand/collapse.

See Also

GridHelper Class
Telerik.WebAii.Controls.Html Namespace


IsExpandCollapseButton Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridHelper..::.IsExpandCollapseButton Method
GridHelper Class See Also Send Feedback
Returns whether the button element is expand/collapse.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static bool IsExpandCollapseButton(
    Element element,
    out GridGroupExpandCollapseActionType actionType
)
Visual Basic (Declaration)
Public Shared Function IsExpandCollapseButton ( _
    element As Element, _
    <OutAttribute> ByRef actionType As GridGroupExpandCollapseActionType _
) As Boolean
Visual C++
public:
static bool IsExpandCollapseButton(
    Element^ element,
    [OutAttribute] GridGroupExpandCollapseActionType% actionType
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The current element.
actionType
Type: Telerik.WebAii.Controls.Html..::.GridGroupExpandCollapseActionType %
The Grid expand/collapse action type.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.GridHelper.IsExpandCollapseButton(ArtOfTest.WebAii.ObjectModel.Element,Telerik.WebAii.Controls.Html.GridGroupExpandCollapseActionType@)"]

See Also

GridHelper Class
Telerik.WebAii.Controls.Html Namespace


GridPager Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX pager control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridPager : HtmlTableRow
Visual Basic (Declaration)
Public Class GridPager _
    Inherits HtmlTableRow
Visual C++
public ref class GridPager : public HtmlTableRow

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableRow
Telerik.WebAii.Controls.Html..::.GridPager

See Also

GridPager Members
Telerik.WebAii.Controls.Html Namespace


GridPager Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Members
GridPager Class Constructors Methods Properties See Also Send Feedback

The GridPager type exposes the following members.

Constructors

Name | Description
GridPager | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
GoToPage | The Advanced Pager 'GoToPage' action.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentPageIndex | The current page index of the loaded page in the table.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InfoText | Get the pager info text when available, returns null otherwise.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Mode | Get the pager mode.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | The page count of the table.
PageSize | The page size of the table.
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


GridPager Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Constructor
GridPager Class See Also Send Feedback

Overload List

Name | Description
GridPager()()() | Initializes a new instance of the GridPager class.
GridPager(Element) | Initializes a new instance of the GridPager class.

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GridPager Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Constructor
GridPager Class See Also Send Feedback
Initializes a new instance of the GridPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridPager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridPager()

See Also

GridPager Class
GridPager Overload
Telerik.WebAii.Controls.Html Namespace


GridPager Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Constructor (Element)
GridPager Class See Also Send Feedback
Initializes a new instance of the GridPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridPager(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridPager Class
GridPager Overload
Telerik.WebAii.Controls.Html Namespace


GridPager Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Methods
GridPager Class See Also Send Feedback

The GridPager type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
GoToPage | The Advanced Pager 'GoToPage' action.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.AssignElement Method
GridPager Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.CallMethod Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.Capture Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


ChangePageSize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.ChangePageSize Method
GridPager Class See Also Send Feedback
The Advanced Pager 'ChangePageSize' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangePageSize()
Visual Basic (Declaration)
Public Sub ChangePageSize
Visual C++
public:
void ChangePageSize()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.Click Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.ControlAssert Method
GridPager Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.DragTo Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.GetValue Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GoToPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.GoToPage Method
GridPager Class See Also Send Feedback
The Advanced Pager 'GoToPage' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GoToPage()
Visual Basic (Declaration)
Public Sub GoToPage
Visual C++
public:
void GoToPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.InvokeEvent Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


LoadFirstPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadFirstPage Method
GridPager Class See Also Send Feedback
Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadFirstPage()
Visual Basic (Declaration)
Public Sub LoadFirstPage
Visual C++
public:
void LoadFirstPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadLastPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadLastPage Method
GridPager Class See Also Send Feedback
Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadLastPage()
Visual Basic (Declaration)
Public Sub LoadLastPage
Visual C++
public:
void LoadLastPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadNextPage Method
GridPager Class See Also Send Feedback
Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadNextPage()
Visual Basic (Declaration)
Public Sub LoadNextPage
Visual C++
public:
void LoadNextPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPages Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadNextPages Method
GridPager Class See Also Send Feedback
Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadNextPages()
Visual Basic (Declaration)
Public Sub LoadNextPages
Visual C++
public:
void LoadNextPages()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadPage Method
GridPager Class See Also Send Feedback
Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadPage(
    int pageNumber
)
Visual Basic (Declaration)
Public Sub LoadPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::.Int32
The number of the page to be loaded.

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadPreviousPage Method
GridPager Class See Also Send Feedback
Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadPreviousPage()
Visual Basic (Declaration)
Public Sub LoadPreviousPage
Visual C++
public:
void LoadPreviousPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPages Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LoadPreviousPages Method
GridPager Class See Also Send Feedback
Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadPreviousPages()
Visual Basic (Declaration)
Public Sub LoadPreviousPages
Visual C++
public:
void LoadPreviousPages()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.MouseClick Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.MouseHover Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.ScrollToVisible Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.SetValue Method
GridPager Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GridPager Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager Properties
GridPager Class See Also Send Feedback

The GridPager type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentPageIndex | The current page index of the loaded page in the table.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InfoText | Get the pager info text when available, returns null otherwise.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Mode | Get the pager mode.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | The page count of the table.
PageSize | The page size of the table.
RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of this table row. (Inherited from HtmlTableRow.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


CurrentPageIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.CurrentPageIndex Property
GridPager Class See Also Send Feedback
The current page index of the loaded page in the table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int CurrentPageIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentPageIndex As Integer
Visual C++
public:
property int CurrentPageIndex {
    int get ();
}

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


InfoText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.InfoText Property
GridPager Class See Also Send Feedback
Get the pager info text when available, returns null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string InfoText { get; }
Visual Basic (Declaration)
Public ReadOnly Property InfoText As String
Visual C++
public:
property String^ InfoText {
    String^ get ();
}

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.LocatorExpression Property
GridPager Class See Also Send Feedback
Get the item locator HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


Mode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.Mode Property
GridPager Class See Also Send Feedback
Get the pager mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Mode { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mode As String
Visual C++
public:
property String^ Mode {
    String^ get ();
}

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


PageCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.PageCount Property
GridPager Class See Also Send Feedback
The page count of the table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


PageSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridPager..::.PageSize Property
GridPager Class See Also Send Feedback
The page size of the table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As Integer
Visual C++
public:
property int PageSize {
    int get ();
}

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX table header control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridTableHeader : HtmlTableCell
Visual Basic (Declaration)
Public Class GridTableHeader _
    Inherits HtmlTableCell
Visual C++
public ref class GridTableHeader : public HtmlTableCell

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableCell
Telerik.WebAii.Controls.Html..::.GridTableHeader

See Also

GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Members
GridTableHeader Class Constructors Methods Properties See Also Send Feedback

The GridTableHeader type exposes the following members.

Constructors

Name | Description
GridTableHeader | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ClientSelectCheckBoxClick | Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToGroup | Drag the current header cell/column into the RadGrid Grouping Panel to group the data by the corresponging field.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Reorder | Overloaded.
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowContextMenu | Shows the header context menu.
Sort | Initiates a 'sort' action of the column.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the TableHeader control. (Overrides HtmlControl..::.ClientSideLocator.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
ColumnIndex | The index of the column.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Reorderable | Get whether the column is reorderable.
Resizable | Get whether the columns is resizable.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SortOrder | The sort order of this column.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
UniqueName | The unique name of this column.
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Visible | Get whether the column is visible on the client.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Constructor
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
GridTableHeader()()() | Initializes a new instance of the GridTableHeader class.
GridTableHeader(Element) | Initializes a new instance of the GridTableHeader class.

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Constructor
GridTableHeader Class See Also Send Feedback
Initializes a new instance of the GridTableHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTableHeader()

See Also

GridTableHeader Class
GridTableHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Constructor (Element)
GridTableHeader Class See Also Send Feedback
Initializes a new instance of the GridTableHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableHeader(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridTableHeader(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableHeader.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridTableHeader Class
GridTableHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Methods
GridTableHeader Class See Also Send Feedback

The GridTableHeader type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ClientSelectCheckBoxClick | Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToGroup | Drag the current header cell/column into the RadGrid Grouping Panel to group the data by the corresponging field.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Reorder | Overloaded.
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowContextMenu | Shows the header context menu.
Sort | Initiates a 'sort' action of the column.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.AssignElement Method
GridTableHeader Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.CallMethod Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Capture Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Click Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


ClientSelectCheckBoxClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.ClientSelectCheckBoxClick Method
GridTableHeader Class See Also Send Feedback
Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClientSelectCheckBoxClick()
Visual Basic (Declaration)
Public Sub ClientSelectCheckBoxClick
Visual C++
public:
void ClientSelectCheckBoxClick()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.ControlAssert Method
GridTableHeader Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.DragTo Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


DragToGroup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.DragToGroup Method
GridTableHeader Class See Also Send Feedback
Drag the current header cell/column into the RadGrid Grouping Panel to group the data by the corresponging field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToGroup()
Visual Basic (Declaration)
Public Sub DragToGroup
Visual C++
public:
void DragToGroup()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.GetValue Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.InvokeEvent Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.MouseClick Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.MouseHover Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Reorder Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
Reorder(HtmlControl) | Simulates drag and drop of the current table header to reorder it with the target one.
Reorder(String) | Simulates drag and drop of the current table header to reorder it with the target one.

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method (HtmlControl)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Reorder Method (HtmlControl)
GridTableHeader Class See Also Send Feedback
Simulates drag and drop of the current table header to reorder it with the target one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Reorder(
    HtmlControl targetHeader
)
Visual Basic (Declaration)
Public Sub Reorder ( _
    targetHeader As HtmlControl _
)
Visual C++
public:
void Reorder(
    HtmlControl^ targetHeader
)

Parameters

targetHeader
Type: ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
The target table header to reorder with.

Remarks

The column reordering in RadGrid may interfere with the column resizing feature. This method might not be working if the column resizing is enabled as well.

See Also

GridTableHeader Class
Reorder Overload
Telerik.WebAii.Controls.Html Namespace


Reorder Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Reorder Method (String)
GridTableHeader Class See Also Send Feedback
Simulates drag and drop of the current table header to reorder it with the target one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Reorder(
    string headerName
)
Visual Basic (Declaration)
Public Sub Reorder ( _
    headerName As String _
)
Visual C++
public:
void Reorder(
    String^ headerName
)

Parameters

headerName
Type: System..::.String
The name of the target table header to reorder with.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown in case of invalid column unique name.

See Also

GridTableHeader Class
Reorder Overload
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.ScrollToVisible Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.SetValue Method
GridTableHeader Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


ShowContextMenu Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.ShowContextMenu Method
GridTableHeader Class See Also Send Feedback
Shows the header context menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowContextMenu()
Visual Basic (Declaration)
Public Sub ShowContextMenu
Visual C++
public:
void ShowContextMenu()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Sort Method
GridTableHeader Class See Also Send Feedback
Initiates a 'sort' action of the column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort
Visual C++
public:
void Sort()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader Properties
GridTableHeader Class See Also Send Feedback

The GridTableHeader type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the TableHeader control. (Overrides HtmlControl..::.ClientSideLocator.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
ColumnIndex | The index of the column.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Reorderable | Get whether the column is reorderable.
Resizable | Get whether the columns is resizable.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SortOrder | The sort order of this column.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
UniqueName | The unique name of this column.
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Visible | Get whether the column is visible on the client.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.ClientSideLocator Property
GridTableHeader Class See Also Send Feedback
The client-side locator of the TableHeader control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


ColumnIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.ColumnIndex Property
GridTableHeader Class See Also Send Feedback
The index of the column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ColumnIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual C++
public:
property int ColumnIndex {
    int get ();
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.LocatorExpression Property
GridTableHeader Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


Reorderable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Reorderable Property
GridTableHeader Class See Also Send Feedback
Get whether the column is reorderable.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Reorderable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reorderable As Boolean
Visual C++
public:
property bool Reorderable {
    bool get ();
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


Resizable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Resizable Property
GridTableHeader Class See Also Send Feedback
Get whether the columns is resizable.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Resizable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resizable As Boolean
Visual C++
public:
property bool Resizable {
    bool get ();
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


SortOrder Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.SortOrder Property
GridTableHeader Class See Also Send Feedback
The sort order of this column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridColumnSortOrderType SortOrder { get; }
Visual Basic (Declaration)
Public ReadOnly Property SortOrder As GridColumnSortOrderType
Visual C++
public:
property GridColumnSortOrderType SortOrder {
    GridColumnSortOrderType get ();
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


UniqueName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.UniqueName Property
GridTableHeader Class See Also Send Feedback
The unique name of this column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string UniqueName { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueName As String
Visual C++
public:
property String^ UniqueName {
    String^ get ();
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableHeader..::.Visible Property
GridTableHeader Class See Also Send Feedback
Get whether the column is visible on the client.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GridTableView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX TableView control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridTableView : HtmlTable
Visual Basic (Declaration)
Public Class GridTableView _
    Inherits HtmlTable
Visual C++
public ref class GridTableView : public HtmlTable

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTable
Telerik.WebAii.Controls.Html..::.GridTableView

See Also

GridTableView Members
Telerik.WebAii.Controls.Html Namespace


GridTableView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Members
GridTableView Class Constructors Methods Properties See Also Send Feedback

The GridTableView type exposes the following members.

Constructors

Name | Description
GridTableView | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTable..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
CancelAll | Initiates "cancel" action for all the table items in edit mode.
CancelInsert | Initiates "cancel" action for the table insert item.
Capture | Overloaded.
ClearSelectedItems | Clears the selection of all items.
Click | Overloaded.
CommandItemAction | Initiates a default command item template action -- either 'AddNew' or 'Refresh'.
ControlAssert | Returns RadControlAssert instance initialize for this control.
DeleteSelectedItems | Deletes all the selected items on the client.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragDrop | Performs DragDrop of a Grid Item (draggedItemIndex) to another (targetItemIndex).
DragTo | Overloaded.
DragToSelect | Performs DragTo from the DataItem with 'start' index to the one with 'end' index selecting the items.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
EditAllItems | Initiates "edit" action for all the table items.
EditSelectedItems | Initiates "edit" action for all the selected items.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItems | Get the list of the data items matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetColumns | Get the columns of the Grid.
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HideFilterItem | Hides the filtering item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InsertItem | Initiates an "insert item" action client-side.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllItems | Selects all the table items.
SelectItem | Select an item in the grid.
SelectItems | Select a set of items in the grid.
SetValue | Overloaded.
ShowFilterItem | Shows the filter item on the client.
ShowInsertItem | Shows the insert item client-side.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UpdateEditedItems | Initiates an "update" action for all the table items in edit mode.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllowMultiColumnSorting | Get whether the mult-column sorting is enabled.
AllowRowSelection | Get whether the row selection is enabled.
AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Border | Gets the width of the table border. (Inherited from HtmlTable.)
CanInsertItem | Get whether the standard table command item is enabled either in the header or the footer.
Caption | Gets the caption of a table. (Inherited from HtmlTable.)
CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the table HTML control. (Overrides HtmlControl..::.ClientSideLocator.)
ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentPageIndex | The current page index of the loaded page in this table.
DataItems | Get the list of the children data items of this table.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
Groups | Get the list of the groups for this table.
HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsFilterItemVisible | Get whether the filtering is enabled for the table.
IsItemInserted | Get whether the insert mode form is opened in this table.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Gets requested row by index. (Inherited from HtmlTable.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | The name of the TableView.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | The page count of this table.
PageSize | The page size of the table.
Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedItems | Get the list of selected items in case selection is enabled, null otherwise.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VirtualItemCount | Get the virtual item count of the table.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GridTableView Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Constructor
GridTableView Class See Also Send Feedback

Overload List

Name | Description
GridTableView()()() | Initializes a new instance of the GridTableView class.
GridTableView(Element) | Initializes a new instance of the GridTableView class.

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


GridTableView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Constructor
GridTableView Class See Also Send Feedback
Initializes a new instance of the GridTableView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTableView()

See Also

GridTableView Class
GridTableView Overload
Telerik.WebAii.Controls.Html Namespace


GridTableView Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Constructor (Element)
GridTableView Class See Also Send Feedback
Initializes a new instance of the GridTableView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableView(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridTableView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridTableView Class
GridTableView Overload
Telerik.WebAii.Controls.Html Namespace


GridTableView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Methods
GridTableView Class See Also Send Feedback

The GridTableView type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlTable..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
CancelAll | Initiates "cancel" action for all the table items in edit mode.
CancelInsert | Initiates "cancel" action for the table insert item.
Capture | Overloaded.
ClearSelectedItems | Clears the selection of all items.
Click | Overloaded.
CommandItemAction | Initiates a default command item template action -- either 'AddNew' or 'Refresh'.
ControlAssert | Returns RadControlAssert instance initialize for this control.
DeleteSelectedItems | Deletes all the selected items on the client.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragDrop | Performs DragDrop of a Grid Item (draggedItemIndex) to another (targetItemIndex).
DragTo | Overloaded.
DragToSelect | Performs DragTo from the DataItem with 'start' index to the one with 'end' index selecting the items.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
EditAllItems | Initiates "edit" action for all the table items.
EditSelectedItems | Initiates "edit" action for all the selected items.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItems | Get the list of the data items matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetColumns | Get the columns of the Grid.
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HideFilterItem | Hides the filtering item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InsertItem | Initiates an "insert item" action client-side.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllItems | Selects all the table items.
SelectItem | Select an item in the grid.
SelectItems | Select a set of items in the grid.
SetValue | Overloaded.
ShowFilterItem | Shows the filter item on the client.
ShowInsertItem | Shows the insert item client-side.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UpdateEditedItems | Initiates an "update" action for all the table items in edit mode.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.AssignElement Method
GridTableView Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.CallMethod Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


CancelAll Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.CancelAll Method
GridTableView Class See Also Send Feedback
Initiates "cancel" action for all the table items in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CancelAll()
Visual Basic (Declaration)
Public Sub CancelAll
Visual C++
public:
void CancelAll()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


CancelInsert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.CancelInsert Method
GridTableView Class See Also Send Feedback
Initiates "cancel" action for the table insert item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CancelInsert()
Visual Basic (Declaration)
Public Sub CancelInsert
Visual C++
public:
void CancelInsert()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.Capture Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ClearSelectedItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.ClearSelectedItems Method
GridTableView Class See Also Send Feedback
Clears the selection of all items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClearSelectedItems()
Visual Basic (Declaration)
Public Sub ClearSelectedItems
Visual C++
public:
void ClearSelectedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.Click Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


CommandItemAction Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.CommandItemAction Method
GridTableView Class See Also Send Feedback
Initiates a default command item template action -- either 'AddNew' or 'Refresh'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CommandItemAction(
    GridCommandItemType commandItemType,
    GridCommandItemLocation location
)
Visual Basic (Declaration)
Public Sub CommandItemAction ( _
    commandItemType As GridCommandItemType, _
    location As GridCommandItemLocation _
)
Visual C++
public:
void CommandItemAction(
    GridCommandItemType commandItemType,
    GridCommandItemLocation location
)

Parameters

commandItemType
Type: Telerik.WebAii.Controls.Html..::.GridCommandItemType
The command item type.
location
Type: Telerik.WebAii.Controls.Html..::.GridCommandItemLocation
The position of the CommandItem in the Grid.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.ControlAssert Method
GridTableView Class See Also Send Feedback
Returns RadControlAssert instance initialize for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialize for this control.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DeleteSelectedItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.DeleteSelectedItems Method
GridTableView Class See Also Send Feedback
Deletes all the selected items on the client.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DeleteSelectedItems()
Visual Basic (Declaration)
Public Sub DeleteSelectedItems
Visual C++
public:
void DeleteSelectedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DragDrop Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.DragDrop Method
GridTableView Class See Also Send Feedback
Performs DragDrop of a Grid Item (draggedItemIndex) to another (targetItemIndex).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragDrop(
    int draggedItemIndex,
    int targetItemIndex
)
Visual Basic (Declaration)
Public Sub DragDrop ( _
    draggedItemIndex As Integer, _
    targetItemIndex As Integer _
)
Visual C++
public:
void DragDrop(
    int draggedItemIndex,
    int targetItemIndex
)

Parameters

draggedItemIndex
Type: System..::.Int32

[Missing <param name="draggedItemIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableView.DragDrop(System.Int32,System.Int32)"]

targetItemIndex
Type: System..::.Int32

[Missing <param name="targetItemIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableView.DragDrop(System.Int32,System.Int32)"]

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.DragTo Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


DragToSelect Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.DragToSelect Method
GridTableView Class See Also Send Feedback
Performs DragTo from the DataItem with 'start' index to the one with 'end' index selecting the items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToSelect(
    int startIndex,
    int endIndex
)
Visual Basic (Declaration)
Public Sub DragToSelect ( _
    startIndex As Integer, _
    endIndex As Integer _
)
Visual C++
public:
void DragToSelect(
    int startIndex,
    int endIndex
)

Parameters

startIndex
Type: System..::.Int32
The index of the data item to start dragging from.
endIndex
Type: System..::.Int32
The index of the data item to end drag-to-select.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


EditAllItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.EditAllItems Method
GridTableView Class See Also Send Feedback
Initiates "edit" action for all the table items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void EditAllItems()
Visual Basic (Declaration)
Public Sub EditAllItems
Visual C++
public:
void EditAllItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


EditSelectedItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.EditSelectedItems Method
GridTableView Class See Also Send Feedback
Initiates "edit" action for all the selected items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void EditSelectedItems()
Visual Basic (Declaration)
Public Sub EditSelectedItems
Visual C++
public:
void EditSelectedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.FindItems Method
GridTableView Class See Also Send Feedback
Get the list of the data items matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridDataItem> FindItems(
    Predicate<GridDataItem> predicate
)
Visual Basic (Declaration)
Public Function FindItems ( _
    predicate As Predicate(Of GridDataItem) _
) As IList(Of GridDataItem)
Visual C++
public:
IList<GridDataItem^>^ FindItems(
    Predicate<GridDataItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( GridDataItem >)>)
The predicate to search for.

Return Value

The list of the data items matching the given predicate.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GetColumns Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.GetColumns Method
GridTableView Class See Also Send Feedback
Get the columns of the Grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GetColumns()
Visual Basic (Declaration)
Public Sub GetColumns
Visual C++
public:
void GetColumns()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.GetValue Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


HideFilterItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.HideFilterItem Method
GridTableView Class See Also Send Feedback
Hides the filtering item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HideFilterItem()
Visual Basic (Declaration)
Public Sub HideFilterItem
Visual C++
public:
void HideFilterItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


InsertItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.InsertItem Method
GridTableView Class See Also Send Feedback
Initiates an "insert item" action client-side.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InsertItem()
Visual Basic (Declaration)
Public Sub InsertItem
Visual C++
public:
void InsertItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.InvokeEvent Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.MouseClick Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.MouseHover Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.ScrollToVisible Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


SelectAllItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.SelectAllItems Method
GridTableView Class See Also Send Feedback
Selects all the table items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectAllItems()
Visual Basic (Declaration)
Public Sub SelectAllItems
Visual C++
public:
void SelectAllItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SelectItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.SelectItem Method
GridTableView Class See Also Send Feedback
Select an item in the grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SelectItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.SelectItems Method
GridTableView Class See Also Send Feedback
Select a set of items in the grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItems(
    params int[] itemIndexes
)
Visual Basic (Declaration)
Public Sub SelectItems ( _
    ParamArray itemIndexes As Integer() _
)
Visual C++
public:
void SelectItems(
    ... array<int>^ itemIndexes
)

Parameters

itemIndexes
Type: array< System..::.Int32 >[]()[]
The array of item indexes.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.SetValue Method
GridTableView Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ShowFilterItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.ShowFilterItem Method
GridTableView Class See Also Send Feedback
Shows the filter item on the client.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowFilterItem()
Visual Basic (Declaration)
Public Sub ShowFilterItem
Visual C++
public:
void ShowFilterItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


ShowInsertItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.ShowInsertItem Method
GridTableView Class See Also Send Feedback
Shows the insert item client-side.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowInsertItem()
Visual Basic (Declaration)
Public Sub ShowInsertItem
Visual C++
public:
void ShowInsertItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


UpdateEditedItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.UpdateEditedItems Method
GridTableView Class See Also Send Feedback
Initiates an "update" action for all the table items in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UpdateEditedItems()
Visual Basic (Declaration)
Public Sub UpdateEditedItems
Visual C++
public:
void UpdateEditedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GridTableView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView Properties
GridTableView Class See Also Send Feedback

The GridTableView type exposes the following members.

Properties

Name | Description
AllowMultiColumnSorting | Get whether the mult-column sorting is enabled.
AllowRowSelection | Get whether the row selection is enabled.
AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Border | Gets the width of the table border. (Inherited from HtmlTable.)
CanInsertItem | Get whether the standard table command item is enabled either in the header or the footer.
Caption | Gets the caption of a table. (Inherited from HtmlTable.)
CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the table HTML control. (Overrides HtmlControl..::.ClientSideLocator.)
ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentPageIndex | The current page index of the loaded page in this table.
DataItems | Get the list of the children data items of this table.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
Groups | Get the list of the groups for this table.
HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsFilterItemVisible | Get whether the filtering is enabled for the table.
IsItemInserted | Get whether the insert mode form is opened in this table.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Gets requested row by index. (Inherited from HtmlTable.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Name | The name of the TableView.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | The page count of this table.
PageSize | The page size of the table.
Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedItems | Get the list of selected items in case selection is enabled, null otherwise.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VirtualItemCount | Get the virtual item count of the table.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


AllowMultiColumnSorting Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.AllowMultiColumnSorting Property
GridTableView Class See Also Send Feedback
Get whether the mult-column sorting is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowMultiColumnSorting { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowMultiColumnSorting As Boolean
Visual C++
public:
property bool AllowMultiColumnSorting {
    bool get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


AllowRowSelection Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.AllowRowSelection Property
GridTableView Class See Also Send Feedback
Get whether the row selection is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowRowSelection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowRowSelection As Boolean
Visual C++
public:
property bool AllowRowSelection {
    bool get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


CanInsertItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.CanInsertItem Property
GridTableView Class See Also Send Feedback
Get whether the standard table command item is enabled either in the header or the footer.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanInsertItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanInsertItem As Boolean
Visual C++
public:
property bool CanInsertItem {
    bool get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.ClientSideLocator Property
GridTableView Class See Also Send Feedback
The client-side locator of the table HTML control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


CurrentPageIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.CurrentPageIndex Property
GridTableView Class See Also Send Feedback
The current page index of the loaded page in this table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int CurrentPageIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentPageIndex As Integer
Visual C++
public:
property int CurrentPageIndex {
    int get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DataItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.DataItems Property
GridTableView Class See Also Send Feedback
Get the list of the children data items of this table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridDataItem> DataItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataItems As IList(Of GridDataItem)
Visual C++
public:
property IList<GridDataItem^>^ DataItems {
    IList<GridDataItem^>^ get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


Groups Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.Groups Property
GridTableView Class See Also Send Feedback
Get the list of the groups for this table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridGroupHeader> Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As IList(Of GridGroupHeader)
Visual C++
public:
property IList<GridGroupHeader^>^ Groups {
    IList<GridGroupHeader^>^ get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


IsFilterItemVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.IsFilterItemVisible Property
GridTableView Class See Also Send Feedback
Get whether the filtering is enabled for the table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFilterItemVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFilterItemVisible As Boolean
Visual C++
public:
property bool IsFilterItemVisible {
    bool get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


IsItemInserted Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.IsItemInserted Property
GridTableView Class See Also Send Feedback
Get whether the insert mode form is opened in this table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsItemInserted { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsItemInserted As Boolean
Visual C++
public:
property bool IsItemInserted {
    bool get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.LocatorExpression Property
GridTableView Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


Name Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.Name Property
GridTableView Class See Also Send Feedback
The name of the TableView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


PageCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.PageCount Property
GridTableView Class See Also Send Feedback
The page count of this table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


PageSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.PageSize Property
GridTableView Class See Also Send Feedback
The page size of the table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As Integer
Visual C++
public:
property int PageSize {
    int get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SelectedItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.SelectedItems Property
GridTableView Class See Also Send Feedback
Get the list of selected items in case selection is enabled, null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridDataItem> SelectedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItems As IList(Of GridDataItem)
Visual C++
public:
property IList<GridDataItem^>^ SelectedItems {
    IList<GridDataItem^>^ get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


VirtualItemCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridTableView..::.VirtualItemCount Property
GridTableView Class See Also Send Feedback
Get the virtual item count of the table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int VirtualItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property VirtualItemCount As Integer
Visual C++
public:
property int VirtualItemCount {
    int get ();
}

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


InputConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants Class
Members See Also Send Feedback
The RadInput constants used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class InputConstants
Visual Basic (Declaration)
Public NotInheritable Class InputConstants
Visual C++
public ref class InputConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.InputConstants

See Also

InputConstants Members
Telerik.WebAii.Controls.Html Namespace


InputConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants Members
InputConstants Class Fields See Also Send Feedback

The InputConstants type exposes the following members.

Fields

Name | Description
CssButtonCell | TextBox table cell button CSS class.
CssRadInput | The base CSS class of the RadInput wrapper elements.
CssRadInputManager | The Css class of the TextBoxes extended by RadInputManager.
CssSpinButtonCell | NumericTextBox spin buttons table cell CSS class.
CssSpinDown | NumericTextBox spin 'Down' button CSS class.
CssSpinUp | NumericTextBox spin 'Up' button CSS class.
DateInputKey | The DateInput key used across the source classes.
IdTextBoxButton | The TextBox 'Go' button Id.
IdTextBoxLabel | The TextBox built-in label Id.
InputKey | The 'RadInput' key used across the source classes.
NumericTextBoxKey | The NumericTextBox key used across the source classes.
TextBoxKey | The RadTextBox key used across the source classes.

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


InputConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants Fields
InputConstants Class See Also Send Feedback

The InputConstants type exposes the following members.

Fields

Name | Description
CssButtonCell | TextBox table cell button CSS class.
CssRadInput | The base CSS class of the RadInput wrapper elements.
CssRadInputManager | The Css class of the TextBoxes extended by RadInputManager.
CssSpinButtonCell | NumericTextBox spin buttons table cell CSS class.
CssSpinDown | NumericTextBox spin 'Down' button CSS class.
CssSpinUp | NumericTextBox spin 'Up' button CSS class.
DateInputKey | The DateInput key used across the source classes.
IdTextBoxButton | The TextBox 'Go' button Id.
IdTextBoxLabel | The TextBox built-in label Id.
InputKey | The 'RadInput' key used across the source classes.
NumericTextBoxKey | The NumericTextBox key used across the source classes.
TextBoxKey | The RadTextBox key used across the source classes.

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssButtonCell Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.CssButtonCell Field
InputConstants Class See Also Send Feedback
TextBox table cell button CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssButtonCell
Visual Basic (Declaration)
Public Const CssButtonCell As String
Visual C++
public:
literal String^ CssButtonCell

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadInput Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.CssRadInput Field
InputConstants Class See Also Send Feedback
The base CSS class of the RadInput wrapper elements.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadInput
Visual Basic (Declaration)
Public Const CssRadInput As String
Visual C++
public:
literal String^ CssRadInput

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadInputManager Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.CssRadInputManager Field
InputConstants Class See Also Send Feedback
The Css class of the TextBoxes extended by RadInputManager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadInputManager
Visual Basic (Declaration)
Public Const CssRadInputManager As String
Visual C++
public:
literal String^ CssRadInputManager

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSpinButtonCell Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.CssSpinButtonCell Field
InputConstants Class See Also Send Feedback
NumericTextBox spin buttons table cell CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSpinButtonCell
Visual Basic (Declaration)
Public Const CssSpinButtonCell As String
Visual C++
public:
literal String^ CssSpinButtonCell

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSpinDown Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.CssSpinDown Field
InputConstants Class See Also Send Feedback
NumericTextBox spin 'Down' button CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSpinDown
Visual Basic (Declaration)
Public Const CssSpinDown As String
Visual C++
public:
literal String^ CssSpinDown

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSpinUp Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.CssSpinUp Field
InputConstants Class See Also Send Feedback
NumericTextBox spin 'Up' button CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSpinUp
Visual Basic (Declaration)
Public Const CssSpinUp As String
Visual C++
public:
literal String^ CssSpinUp

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


DateInputKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.DateInputKey Field
InputConstants Class See Also Send Feedback
The DateInput key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DateInputKey
Visual Basic (Declaration)
Public Const DateInputKey As String
Visual C++
public:
literal String^ DateInputKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


IdTextBoxButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.IdTextBoxButton Field
InputConstants Class See Also Send Feedback
The TextBox 'Go' button Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdTextBoxButton
Visual Basic (Declaration)
Public Const IdTextBoxButton As String
Visual C++
public:
literal String^ IdTextBoxButton

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


IdTextBoxLabel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.IdTextBoxLabel Field
InputConstants Class See Also Send Feedback
The TextBox built-in label Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdTextBoxLabel
Visual Basic (Declaration)
Public Const IdTextBoxLabel As String
Visual C++
public:
literal String^ IdTextBoxLabel

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


InputKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.InputKey Field
InputConstants Class See Also Send Feedback
The 'RadInput' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string InputKey
Visual Basic (Declaration)
Public Const InputKey As String
Visual C++
public:
literal String^ InputKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


NumericTextBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.NumericTextBoxKey Field
InputConstants Class See Also Send Feedback
The NumericTextBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string NumericTextBoxKey
Visual Basic (Declaration)
Public Const NumericTextBoxKey As String
Visual C++
public:
literal String^ NumericTextBoxKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


TextBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
InputConstants..::.TextBoxKey Field
InputConstants Class See Also Send Feedback
The RadTextBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TextBoxKey
Visual Basic (Declaration)
Public Const TextBoxKey As String
Visual C++
public:
literal String^ TextBoxKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxButtonPosition Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxButtonPosition Enumeration
See Also Send Feedback
Type of listbox button position.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ListBoxButtonPosition
Visual Basic (Declaration)
Public Enumeration ListBoxButtonPosition
Visual C++
public enum class ListBoxButtonPosition

Members

Member name | Description
Top | Button position top.
Bottom | Button position bottom.
Left | Button position left.
Right | Button position right.
NotSet | Button position not set.

See Also

Telerik.WebAii.Controls.Html Namespace


ListBoxConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants Class
Members See Also Send Feedback
Represents the ListBoxConstants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ListBoxConstants
Visual Basic (Declaration)
Public NotInheritable Class ListBoxConstants
Visual C++
public ref class ListBoxConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.ListBoxConstants

See Also

ListBoxConstants Members
Telerik.WebAii.Controls.Html Namespace


ListBoxConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants Members
ListBoxConstants Class Fields See Also Send Feedback

The ListBoxConstants type exposes the following members.

Fields

Name | Description
CssListBox | The CSS class identifying the ListBox control.
CssListBoxButtonText | The CSS class identifying the ListBox button text.
CssListBoxItem | The CSS class identifying the ListBox item.
CssListBoxItemCheckBox | The CSS class identifying the ListBox item checkbox.
CssListBoxItemImage | The CSS class identifying the ListBox item image element.
CssListBoxItemText | The CSS class identifying the ListBox item span element.
CssListBoxLinkButtonDelete | The CSS class identifying the ListBox link button "Delete".
CssListBoxLinkButtonMoveDown | The CSS class identifying the ListBox link button "MoveDown".
CssListBoxLinkButtonMoveUp | The CSS class identifying the ListBox link button "MoveUp".
CssListBoxLinkButtonTransferAllFrom | The CSS class identifying the ListBox link button "TransferAllFrom".
CssListBoxLinkButtonTransferAllTo | The CSS class identifying the ListBox link button "TransferAllTo".
CssListBoxLinkButtonTransferFrom | The CSS class identifying the ListBox link button "TransferFrom".
CssListBoxLinkButtonTransferTo | The CSS class identifying the ListBox link button "TransferTo".
ListBoxItemKey | The ListBoxItem key used across the source classes.
ListBoxKey | The ListBox key used across the source classes.

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants Fields
ListBoxConstants Class See Also Send Feedback

The ListBoxConstants type exposes the following members.

Fields

Name | Description
CssListBox | The CSS class identifying the ListBox control.
CssListBoxButtonText | The CSS class identifying the ListBox button text.
CssListBoxItem | The CSS class identifying the ListBox item.
CssListBoxItemCheckBox | The CSS class identifying the ListBox item checkbox.
CssListBoxItemImage | The CSS class identifying the ListBox item image element.
CssListBoxItemText | The CSS class identifying the ListBox item span element.
CssListBoxLinkButtonDelete | The CSS class identifying the ListBox link button "Delete".
CssListBoxLinkButtonMoveDown | The CSS class identifying the ListBox link button "MoveDown".
CssListBoxLinkButtonMoveUp | The CSS class identifying the ListBox link button "MoveUp".
CssListBoxLinkButtonTransferAllFrom | The CSS class identifying the ListBox link button "TransferAllFrom".
CssListBoxLinkButtonTransferAllTo | The CSS class identifying the ListBox link button "TransferAllTo".
CssListBoxLinkButtonTransferFrom | The CSS class identifying the ListBox link button "TransferFrom".
CssListBoxLinkButtonTransferTo | The CSS class identifying the ListBox link button "TransferTo".
ListBoxItemKey | The ListBoxItem key used across the source classes.
ListBoxKey | The ListBox key used across the source classes.

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBox Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBox
Visual Basic (Declaration)
Public Const CssListBox As String
Visual C++
public:
literal String^ CssListBox

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxButtonText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxButtonText Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox button text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxButtonText
Visual Basic (Declaration)
Public Const CssListBoxButtonText As String
Visual C++
public:
literal String^ CssListBoxButtonText

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxItem Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxItem
Visual Basic (Declaration)
Public Const CssListBoxItem As String
Visual C++
public:
literal String^ CssListBoxItem

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItemCheckBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxItemCheckBox Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxItemCheckBox
Visual Basic (Declaration)
Public Const CssListBoxItemCheckBox As String
Visual C++
public:
literal String^ CssListBoxItemCheckBox

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItemImage Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxItemImage Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item image element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxItemImage
Visual Basic (Declaration)
Public Const CssListBoxItemImage As String
Visual C++
public:
literal String^ CssListBoxItemImage

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItemText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxItemText Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxItemText
Visual Basic (Declaration)
Public Const CssListBoxItemText As String
Visual C++
public:
literal String^ CssListBoxItemText

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonDelete Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonDelete Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "Delete".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonDelete
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonDelete As String
Visual C++
public:
literal String^ CssListBoxLinkButtonDelete

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonMoveDown Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonMoveDown Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "MoveDown".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonMoveDown
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonMoveDown As String
Visual C++
public:
literal String^ CssListBoxLinkButtonMoveDown

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonMoveUp Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonMoveUp Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "MoveUp".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonMoveUp
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonMoveUp As String
Visual C++
public:
literal String^ CssListBoxLinkButtonMoveUp

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferAllFrom Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonTransferAllFrom Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferAllFrom".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonTransferAllFrom
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonTransferAllFrom As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferAllFrom

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferAllTo Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonTransferAllTo Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferAllTo".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonTransferAllTo
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonTransferAllTo As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferAllTo

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferFrom Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonTransferFrom Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferFrom".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonTransferFrom
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonTransferFrom As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferFrom

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferTo Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.CssListBoxLinkButtonTransferTo Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferTo".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssListBoxLinkButtonTransferTo
Visual Basic (Declaration)
Public Const CssListBoxLinkButtonTransferTo As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferTo

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.ListBoxItemKey Field
ListBoxConstants Class See Also Send Feedback
The ListBoxItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ListBoxItemKey
Visual Basic (Declaration)
Public Const ListBoxItemKey As String
Visual C++
public:
literal String^ ListBoxItemKey

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListBoxConstants..::.ListBoxKey Field
ListBoxConstants Class See Also Send Feedback
The ListBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ListBoxKey
Visual Basic (Declaration)
Public Const ListBoxKey As String
Visual C++
public:
literal String^ ListBoxKey

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListViewConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListViewConstants Class
Members See Also Send Feedback
The ListView string constants.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ListViewConstants
Visual Basic (Declaration)
Public NotInheritable Class ListViewConstants
Visual C++
public ref class ListViewConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.ListViewConstants

See Also

ListViewConstants Members
Telerik.WebAii.Controls.Html Namespace


ListViewConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListViewConstants Members
ListViewConstants Class Fields See Also Send Feedback

The ListViewConstants type exposes the following members.

Fields

Name | Description
CssRadListView | The Css class of the ListView div wrapper.
ListViewKey | The ListView key.

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


ListViewConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListViewConstants Fields
ListViewConstants Class See Also Send Feedback

The ListViewConstants type exposes the following members.

Fields

Name | Description
CssRadListView | The Css class of the ListView div wrapper.
ListViewKey | The ListView key.

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadListView Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListViewConstants..::.CssRadListView Field
ListViewConstants Class See Also Send Feedback
The Css class of the ListView div wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadListView
Visual Basic (Declaration)
Public Const CssRadListView As String
Visual C++
public:
literal String^ CssRadListView

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


ListViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ListViewConstants..::.ListViewKey Field
ListViewConstants Class See Also Send Feedback
The ListView key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ListViewKey
Visual Basic (Declaration)
Public Const ListViewKey As String
Visual C++
public:
literal String^ ListViewKey

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants Class
Members See Also Send Feedback
Represents the menu constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class MenuConstants
Visual Basic (Declaration)
Public NotInheritable Class MenuConstants
Visual C++
public ref class MenuConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.MenuConstants

See Also

MenuConstants Members
Telerik.WebAii.Controls.Html Namespace


MenuConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants Members
MenuConstants Class Fields See Also Send Feedback

The MenuConstants type exposes the following members.

Fields

Name | Description
CssContextMenu | The unique part of RadContextMenu CSS class.
CssMenu | The unique part of RadMenu CSS class.
CssMenuItem | CSS class of the menu item.
CssMenuLink | CSS class of the menu item link.
CssMenuText | CSS class of the menu item span element containing the item text.
MenuItemKey | The MenuItem key used accross the classes.
MenuKey | The Menu key used accross the classes.

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants Fields
MenuConstants Class See Also Send Feedback

The MenuConstants type exposes the following members.

Fields

Name | Description
CssContextMenu | The unique part of RadContextMenu CSS class.
CssMenu | The unique part of RadMenu CSS class.
CssMenuItem | CSS class of the menu item.
CssMenuLink | CSS class of the menu item link.
CssMenuText | CSS class of the menu item span element containing the item text.
MenuItemKey | The MenuItem key used accross the classes.
MenuKey | The Menu key used accross the classes.

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssContextMenu Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.CssContextMenu Field
MenuConstants Class See Also Send Feedback
The unique part of RadContextMenu CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssContextMenu
Visual Basic (Declaration)
Public Const CssContextMenu As String
Visual C++
public:
literal String^ CssContextMenu

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenu Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.CssMenu Field
MenuConstants Class See Also Send Feedback
The unique part of RadMenu CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMenu
Visual Basic (Declaration)
Public Const CssMenu As String
Visual C++
public:
literal String^ CssMenu

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.CssMenuItem Field
MenuConstants Class See Also Send Feedback
CSS class of the menu item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMenuItem
Visual Basic (Declaration)
Public Const CssMenuItem As String
Visual C++
public:
literal String^ CssMenuItem

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuLink Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.CssMenuLink Field
MenuConstants Class See Also Send Feedback
CSS class of the menu item link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMenuLink
Visual Basic (Declaration)
Public Const CssMenuLink As String
Visual C++
public:
literal String^ CssMenuLink

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.CssMenuText Field
MenuConstants Class See Also Send Feedback
CSS class of the menu item span element containing the item text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMenuText
Visual Basic (Declaration)
Public Const CssMenuText As String
Visual C++
public:
literal String^ CssMenuText

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.MenuItemKey Field
MenuConstants Class See Also Send Feedback
The MenuItem key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MenuItemKey
Visual Basic (Declaration)
Public Const MenuItemKey As String
Visual C++
public:
literal String^ MenuItemKey

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuConstants..::.MenuKey Field
MenuConstants Class See Also Send Feedback
The Menu key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MenuKey
Visual Basic (Declaration)
Public Const MenuKey As String
Visual C++
public:
literal String^ MenuKey

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuOrientationType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MenuOrientationType Enumeration
See Also Send Feedback
Type of menu orientation type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum MenuOrientationType
Visual Basic (Declaration)
Public Enumeration MenuOrientationType
Visual C++
public enum class MenuOrientationType

Members

Member name | Description
Horizontal | Horizontal orientation.
Vertical | Vertical orientation.

See Also

Telerik.WebAii.Controls.Html Namespace


PanelBarConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants Class
Members See Also Send Feedback
Represents the PanelBar constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class PanelBarConstants
Visual Basic (Declaration)
Public NotInheritable Class PanelBarConstants
Visual C++
public ref class PanelBarConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.PanelBarConstants

See Also

PanelBarConstants Members
Telerik.WebAii.Controls.Html Namespace


PanelBarConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants Members
PanelBarConstants Class Fields See Also Send Feedback

The PanelBarConstants type exposes the following members.

Fields

Name | Description
CssPanelBar | The CSS class identifying the PanelBar control.
CssPanelBarItem | The CSS class identifying the PanelBar item.
CssPanelBarItemLink | The CSS class identifying the PanelBar item link.
CssPanelBarItemText | The CSS class identifying the PanelBar item text span element.
PanelBarItemKey | The PanelBarItem key used across the source classes.
PanelBarKey | The PanelBar key used across the source classes.

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants Fields
PanelBarConstants Class See Also Send Feedback

The PanelBarConstants type exposes the following members.

Fields

Name | Description
CssPanelBar | The CSS class identifying the PanelBar control.
CssPanelBarItem | The CSS class identifying the PanelBar item.
CssPanelBarItemLink | The CSS class identifying the PanelBar item link.
CssPanelBarItemText | The CSS class identifying the PanelBar item text span element.
PanelBarItemKey | The PanelBarItem key used across the source classes.
PanelBarKey | The PanelBar key used across the source classes.

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants..::.CssPanelBar Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPanelBar
Visual Basic (Declaration)
Public Const CssPanelBar As String
Visual C++
public:
literal String^ CssPanelBar

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants..::.CssPanelBarItem Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPanelBarItem
Visual Basic (Declaration)
Public Const CssPanelBarItem As String
Visual C++
public:
literal String^ CssPanelBarItem

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItemLink Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants..::.CssPanelBarItemLink Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPanelBarItemLink
Visual Basic (Declaration)
Public Const CssPanelBarItemLink As String
Visual C++
public:
literal String^ CssPanelBarItemLink

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItemText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants..::.CssPanelBarItemText Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item text span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPanelBarItemText
Visual Basic (Declaration)
Public Const CssPanelBarItemText As String
Visual C++
public:
literal String^ CssPanelBarItemText

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants..::.PanelBarItemKey Field
PanelBarConstants Class See Also Send Feedback
The PanelBarItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PanelBarItemKey
Visual Basic (Declaration)
Public Const PanelBarItemKey As String
Visual C++
public:
literal String^ PanelBarItemKey

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarConstants..::.PanelBarKey Field
PanelBarConstants Class See Also Send Feedback
The PanelBar key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PanelBarKey
Visual Basic (Declaration)
Public Const PanelBarKey As String
Visual C++
public:
literal String^ PanelBarKey

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PredefinedLayoutType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PredefinedLayoutType Enumeration
See Also Send Feedback
Enumerates the predefined layouts of the ListView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum PredefinedLayoutType
Visual Basic (Declaration)
Public Enumeration PredefinedLayoutType
Visual C++
public enum class PredefinedLayoutType

Members

Member name | Description
Grid | Grid layout.
UnorderedList | UnOrderedList layout.
OrderedList | OrderedList layout.
Flow | Flow layout.
SingleRow | SingleRow layout.
Custom | Custom layout.

See Also

Telerik.WebAii.Controls.Html Namespace


RadCalendar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Class
Members See Also Send Feedback
Represents the RadCalendar for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadCalendar : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadCalendar _
    Inherits HtmlContainerControl
Visual C++
public ref class RadCalendar : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadCalendar

See Also

RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


RadCalendar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Members
RadCalendar Class Constructors Methods Properties See Also Send Feedback

The RadCalendar type exposes the following members.

Constructors

Name | Description
RadCalendar | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ColumnHeaderClick | Clicks on the header of a column.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FastNext | Clicks the FastNextMonth navigation link.
FastPrevious | Clicks the FastPreviousMonth navigation link.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Next | Clicks the NextMonth navigation link.
OpenFastNavigation | Opens the FastNavigation Popup.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Previous | Clicks the PreviousMonth navigation link.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
RowHeaderClick | Clicks on the header of a row.
ScrollToVisible | Overloaded.
SelectDate | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)
ViewSelectorClick | Clicks on the ViewSelector.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Check whether autopostback is enabled.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Get the culture which is used by the calendar.
EnableMonthYearFastNavigation | Whether the FastNavigation is enabled.
EnableMultiSelect | Check whether multi date selection is enabled.
EnableViewSelector | Returns the value of the EnableViewSelector property.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
FastNavigationStep | Get the step for fast navigation.
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Get the focused date.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MultiMonthCount | The number of the displayed months in multi-month view.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PopupVisible | Whether the popup is visible.
PresentationType | Get the calendar presentation type.
RangeMaxDate | Get RangeMaxDate.
RangeMinDate | Get RangeMinDate.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDates | Get Calendar selected dates.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TitleText | The title text of the Calendar.
UseColumnHeadersAsSelectors | Whether the column headers can be used to select the dates in the respective column.
UseRowHeadersAsSelectors | Whether the row headers can be used to select the dates in the respective row.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RadCalendar Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Constructor
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
RadCalendar()()() | Initializes a new instance of the RadCalendar class.
RadCalendar(Element) | Initializes a new instance of the RadCalendar class.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


RadCalendar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Constructor
RadCalendar Class See Also Send Feedback
Initializes a new instance of the RadCalendar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCalendar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCalendar()

See Also

RadCalendar Class
RadCalendar Overload
Telerik.WebAii.Controls.Html Namespace


RadCalendar Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Constructor (Element)
RadCalendar Class See Also Send Feedback
Initializes a new instance of the RadCalendar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCalendar(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadCalendar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadCalendar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadCalendar Class
RadCalendar Overload
Telerik.WebAii.Controls.Html Namespace


RadCalendar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Methods
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ColumnHeaderClick | Clicks on the header of a column.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FastNext | Clicks the FastNextMonth navigation link.
FastPrevious | Clicks the FastPreviousMonth navigation link.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Next | Clicks the NextMonth navigation link.
OpenFastNavigation | Opens the FastNavigation Popup.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Previous | Clicks the PreviousMonth navigation link.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
RowHeaderClick | Clicks on the header of a row.
ScrollToVisible | Overloaded.
SelectDate | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)
ViewSelectorClick | Clicks on the ViewSelector.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.AssignElement Method
RadCalendar Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.CallMethod Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Capture Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Click Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ColumnHeaderClick Method
RadCalendar Class See Also Send Feedback
Clicks on the header of a column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ColumnHeaderClick(
    string dayOfWeek
)
Visual Basic (Declaration)
Public Sub ColumnHeaderClick ( _
    dayOfWeek As String _
)
Visual C++
public:
void ColumnHeaderClick(
    String^ dayOfWeek
)

Parameters

dayOfWeek
Type: System..::.String
The day of week.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ControlAssert Method
RadCalendar Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.DragTo Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


FastNext Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.FastNext Method
RadCalendar Class See Also Send Feedback
Clicks the FastNextMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FastNext()
Visual Basic (Declaration)
Public Sub FastNext
Visual C++
public:
void FastNext()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


FastPrevious Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.FastPrevious Method
RadCalendar Class See Also Send Feedback
Clicks the FastPreviousMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FastPrevious()
Visual Basic (Declaration)
Public Sub FastPrevious
Visual C++
public:
void FastPrevious()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.GetValue Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.InvokeEvent Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.MouseClick Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.MouseHover Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


Next Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Next Method
RadCalendar Class See Also Send Feedback
Clicks the NextMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Next()
Visual Basic (Declaration)
Public Sub Next
Visual C++
public:
void Next()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


OpenFastNavigation Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.OpenFastNavigation Method
RadCalendar Class See Also Send Feedback
Opens the FastNavigation Popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenFastNavigation()
Visual Basic (Declaration)
Public Sub OpenFastNavigation
Visual C++
public:
void OpenFastNavigation()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


Previous Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Previous Method
RadCalendar Class See Also Send Feedback
Clicks the PreviousMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Previous()
Visual Basic (Declaration)
Public Sub Previous
Visual C++
public:
void Previous()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.RowHeaderClick Method
RadCalendar Class See Also Send Feedback
Clicks on the header of a row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void RowHeaderClick(
    int weekNumber
)
Visual Basic (Declaration)
Public Sub RowHeaderClick ( _
    weekNumber As Integer _
)
Visual C++
public:
void RowHeaderClick(
    int weekNumber
)

Parameters

weekNumber
Type: System..::.Int32

[Missing <param name="weekNumber"/> documentation for "M:Telerik.WebAii.Controls.Html.RadCalendar.RowHeaderClick(System.Int32)"]

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ScrollToVisible Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


SelectDate Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDate Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SelectDate(DateTime) | Select a date in the Calendar.
SelectDate(String) | Select a date in the Calendar.
SelectDate(DateTime, String) | Select a date in the Calendar.
SelectDate(String, String) | Select a date in the Calendar.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (DateTime)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDate Method (DateTime)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDate(
    DateTime selectedDate
)
Visual Basic (Declaration)
Public Sub SelectDate ( _
    selectedDate As DateTime _
)
Visual C++
public:
void SelectDate(
    DateTime selectedDate
)

Parameters

selectedDate
Type: System..::.DateTime
The date to be selected.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDate Method (String)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDate(
    string dateTimeValue
)
Visual Basic (Declaration)
Public Sub SelectDate ( _
    dateTimeValue As String _
)
Visual C++
public:
void SelectDate(
    String^ dateTimeValue
)

Parameters

dateTimeValue
Type: System..::.String
The date to be selected.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (DateTime, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDate Method (DateTime, String)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDate(
    DateTime selectedDate,
    string currentCalendarCulture
)
Visual Basic (Declaration)
Public Sub SelectDate ( _
    selectedDate As DateTime, _
    currentCalendarCulture As String _
)
Visual C++
public:
void SelectDate(
    DateTime selectedDate,
    String^ currentCalendarCulture
)

Parameters

selectedDate
Type: System..::.DateTime
The date to be selected.
currentCalendarCulture
Type: System..::.String
Thu current culture.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (String, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDate Method (String, String)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDate(
    string dateTimeValue,
    string currentCalendarCulture
)
Visual Basic (Declaration)
Public Sub SelectDate ( _
    dateTimeValue As String, _
    currentCalendarCulture As String _
)
Visual C++
public:
void SelectDate(
    String^ dateTimeValue,
    String^ currentCalendarCulture
)

Parameters

dateTimeValue
Type: System..::.String
The date to be selected.
currentCalendarCulture
Type: System..::.String
The current culture.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SetValue Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


ViewSelectorClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ViewSelectorClick Method
RadCalendar Class See Also Send Feedback
Clicks on the ViewSelector.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ViewSelectorClick()
Visual Basic (Declaration)
Public Sub ViewSelectorClick
Visual C++
public:
void ViewSelectorClick()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RadCalendar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Properties
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Check whether autopostback is enabled.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Get the culture which is used by the calendar.
EnableMonthYearFastNavigation | Whether the FastNavigation is enabled.
EnableMultiSelect | Check whether multi date selection is enabled.
EnableViewSelector | Returns the value of the EnableViewSelector property.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
FastNavigationStep | Get the step for fast navigation.
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Get the focused date.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MultiMonthCount | The number of the displayed months in multi-month view.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PopupVisible | Whether the popup is visible.
PresentationType | Get the calendar presentation type.
RangeMaxDate | Get RangeMaxDate.
RangeMinDate | Get RangeMinDate.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDates | Get Calendar selected dates.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TitleText | The title text of the Calendar.
UseColumnHeadersAsSelectors | Whether the column headers can be used to select the dates in the respective column.
UseRowHeadersAsSelectors | Whether the row headers can be used to select the dates in the respective row.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


AutoPostBack Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.AutoPostBack Property
RadCalendar Class See Also Send Feedback
Check whether autopostback is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AutoPostBack { get; set; }
Visual Basic (Declaration)
Public Property AutoPostBack As Boolean
Visual C++
public:
property bool AutoPostBack {
    bool get ();
    void set (bool value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ClientSideLocator Property
RadCalendar Class See Also Send Feedback
The client-side locator of the RadCalendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


Culture Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Culture Property
RadCalendar Class See Also Send Feedback
Get the culture which is used by the calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Culture { get; }
Visual Basic (Declaration)
Public ReadOnly Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


EnableMonthYearFastNavigation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.EnableMonthYearFastNavigation Property
RadCalendar Class See Also Send Feedback
Whether the FastNavigation is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableMonthYearFastNavigation { get; set; }
Visual Basic (Declaration)
Public Property EnableMonthYearFastNavigation As Boolean
Visual C++
public:
property bool EnableMonthYearFastNavigation {
    bool get ();
    void set (bool value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


EnableMultiSelect Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.EnableMultiSelect Property
RadCalendar Class See Also Send Feedback
Check whether multi date selection is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableMultiSelect { get; set; }
Visual Basic (Declaration)
Public Property EnableMultiSelect As Boolean
Visual C++
public:
property bool EnableMultiSelect {
    bool get ();
    void set (bool value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


EnableViewSelector Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.EnableViewSelector Property
RadCalendar Class See Also Send Feedback
Returns the value of the EnableViewSelector property.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableViewSelector { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnableViewSelector As Boolean
Visual C++
public:
property bool EnableViewSelector {
    bool get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationStep Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.FastNavigationStep Property
RadCalendar Class See Also Send Feedback
Get the step for fast navigation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int FastNavigationStep { get; set; }
Visual Basic (Declaration)
Public Property FastNavigationStep As Integer
Visual C++
public:
property int FastNavigationStep {
    int get ();
    void set (int value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


FocusedDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.FocusedDate Property
RadCalendar Class See Also Send Feedback
Get the focused date.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime FocusedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FocusedDate As DateTime
Visual C++
public:
property DateTime FocusedDate {
    DateTime get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.LocatorExpression Property
RadCalendar Class See Also Send Feedback
Get the item locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


MultiMonthCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.MultiMonthCount Property
RadCalendar Class See Also Send Feedback
The number of the displayed months in multi-month view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MultiMonthCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property MultiMonthCount As Integer
Visual C++
public:
property int MultiMonthCount {
    int get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


PopupVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.PopupVisible Property
RadCalendar Class See Also Send Feedback
Whether the popup is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool PopupVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupVisible As Boolean
Visual C++
public:
property bool PopupVisible {
    bool get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


PresentationType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.PresentationType Property
RadCalendar Class See Also Send Feedback
Get the calendar presentation type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarPresentationType PresentationType { get; set; }
Visual Basic (Declaration)
Public Property PresentationType As CalendarPresentationType
Visual C++
public:
property CalendarPresentationType PresentationType {
    CalendarPresentationType get ();
    void set (CalendarPresentationType value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RangeMaxDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.RangeMaxDate Property
RadCalendar Class See Also Send Feedback
Get RangeMaxDate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime RangeMaxDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property RangeMaxDate As DateTime
Visual C++
public:
property DateTime RangeMaxDate {
    DateTime get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RangeMinDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.RangeMinDate Property
RadCalendar Class See Also Send Feedback
Get RangeMinDate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime RangeMinDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property RangeMinDate As DateTime
Visual C++
public:
property DateTime RangeMinDate {
    DateTime get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


SelectedDates Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectedDates Property
RadCalendar Class See Also Send Feedback
Get Calendar selected dates.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SelectedDateCollection SelectedDates { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDates As SelectedDateCollection
Visual C++
public:
property SelectedDateCollection^ SelectedDates {
    SelectedDateCollection^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


TitleText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.TitleText Property
RadCalendar Class See Also Send Feedback
The title text of the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TitleText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleText As String
Visual C++
public:
property String^ TitleText {
    String^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


UseColumnHeadersAsSelectors Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.UseColumnHeadersAsSelectors Property
RadCalendar Class See Also Send Feedback
Whether the column headers can be used to select the dates in the respective column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool UseColumnHeadersAsSelectors { get; set; }
Visual Basic (Declaration)
Public Property UseColumnHeadersAsSelectors As Boolean
Visual C++
public:
property bool UseColumnHeadersAsSelectors {
    bool get ();
    void set (bool value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


UseRowHeadersAsSelectors Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.UseRowHeadersAsSelectors Property
RadCalendar Class See Also Send Feedback
Whether the row headers can be used to select the dates in the respective row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool UseRowHeadersAsSelectors { get; set; }
Visual Basic (Declaration)
Public Property UseRowHeadersAsSelectors As Boolean
Visual C++
public:
property bool UseRowHeadersAsSelectors {
    bool get ();
    void set (bool value);
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Class
Members See Also Send Feedback
RadColorPicker control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadColorPicker : HtmlDiv
Visual Basic (Declaration)
Public Class RadColorPicker _
    Inherits HtmlDiv
Visual C++
public ref class RadColorPicker : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadColorPicker

See Also

RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Members
RadColorPicker Class Constructors Methods Properties See Also Send Feedback

The RadColorPicker type exposes the following members.

Constructors

Name | Description
RadColorPicker | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HidePalette | Hides the ColorPicker palette.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowPalette | Shows the ColorPicker palette.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client-side script that identifies the control. (Overrides HtmlControl..::.ClientSideLocator.)
Columns | Gets ColorPicker columns.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Determines or set whether the ColorPicker is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaletteDisplayed | Determines whether the palette is displayed.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedColor | Gets/sets currently selected color.
ShowIcon | Determines whether the ColorPickcer is shown as an icon.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Constructor
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
RadColorPicker()()() | Initializes a new instance of the RadColorPicker class.
RadColorPicker(Element) | Initializes a new instance of the RadColorPicker class.

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Constructor
RadColorPicker Class See Also Send Feedback
Initializes a new instance of the RadColorPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPicker()

See Also

RadColorPicker Class
RadColorPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Constructor (Element)
RadColorPicker Class See Also Send Feedback
Initializes a new instance of the RadColorPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorPicker(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadColorPicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
RadColorPicker wrapper div.

See Also

RadColorPicker Class
RadColorPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Methods
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HidePalette | Hides the ColorPicker palette.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowPalette | Shows the ColorPicker palette.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.AssignElement Method
RadColorPicker Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.CallMethod Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Capture Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Click Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.ControlAssert Method
RadColorPicker Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.DragTo Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.GetValue Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


HidePalette Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.HidePalette Method
RadColorPicker Class See Also Send Feedback
Hides the ColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HidePalette()
Visual Basic (Declaration)
Public Sub HidePalette
Visual C++
public:
void HidePalette()

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.InvokeEvent Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.MouseClick Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.MouseHover Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.ScrollToVisible Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.SetValue Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


ShowPalette Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.ShowPalette Method
RadColorPicker Class See Also Send Feedback
Shows the ColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowPalette()
Visual Basic (Declaration)
Public Sub ShowPalette
Visual C++
public:
void ShowPalette()

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Properties
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client-side script that identifies the control. (Overrides HtmlControl..::.ClientSideLocator.)
Columns | Gets ColorPicker columns.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Determines or set whether the ColorPicker is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaletteDisplayed | Determines whether the palette is displayed.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedColor | Gets/sets currently selected color.
ShowIcon | Determines whether the ColorPickcer is shown as an icon.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.ClientSideLocator Property
RadColorPicker Class See Also Send Feedback
Client-side script that identifies the control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


Columns Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Columns Property
RadColorPicker Class See Also Send Feedback
Gets ColorPicker columns.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual C++
public:
property int Columns {
    int get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Enabled Property
RadColorPicker Class See Also Send Feedback
Determines or set whether the ColorPicker is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.LocatorExpression Property
RadColorPicker Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


PaletteDisplayed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.PaletteDisplayed Property
RadColorPicker Class See Also Send Feedback
Determines whether the palette is displayed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool PaletteDisplayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaletteDisplayed As Boolean
Visual C++
public:
property bool PaletteDisplayed {
    bool get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


SelectedColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.SelectedColor Property
RadColorPicker Class See Also Send Feedback
Gets/sets currently selected color.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedColor { get; set; }
Visual Basic (Declaration)
Public Property SelectedColor As String
Visual C++
public:
property String^ SelectedColor {
    String^ get ();
    void set (String^ value);
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


ShowIcon Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.ShowIcon Property
RadColorPicker Class See Also Send Feedback
Determines whether the ColorPickcer is shown as an icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShowIcon { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowIcon As Boolean
Visual C++
public:
property bool ShowIcon {
    bool get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


RadComboBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Class
Members See Also Send Feedback
Represents the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadComboBox : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadComboBox _
    Inherits HtmlContainerControl
Visual C++
public ref class RadComboBox : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadComboBox

See Also

RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


RadComboBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Members
RadComboBox Class Constructors Methods Properties See Also Send Feedback

The RadComboBox type exposes the following members.

Constructors

Name | Description
RadComboBox | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadComboBox control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ClearItems | Clears all items of the combobox.
ClearSelection | Clears the selection.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Disable | Disables the combo box.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the combo box.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HideDropDown | Hide the drop down of RadComboBox.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetText | Set the given text of the ComboBox. Swows the drop down as well.
SetValue | Overloaded.
ShowDropDown | Show the drop down of RadComboBox.
ToggleDropDown | Toggle the drop down of RadComboBox.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
ComboBoxValue | Gets or set the ComboBox value.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownVisible | Gets whether the drop down is visible.
ElementOffsetWidth | Get the offset width of the combobox element.
EmptyMessage | Gets or set the empty message text of the RadComboBox.
Enabled | Get whether combobox is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
FilterEnabled | Get whether combobox filtering is enabled.
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of items.
LastWord | Gets the word after the last separator in the text of the combobox. If a separator is not set, returns the text itself.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets the selected index of the RadComboBox. Returns '-1' if there is no selected item.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Gets or set the text of the RadComboBox.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VisibleItems | Get the list of the visible items.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


RadComboBox Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Constructor
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
RadComboBox()()() | Initializes a new instance of the RadComboBox class.
RadComboBox(Element) | Initializes a new instance of the RadComboBox class.

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


RadComboBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Constructor
RadComboBox Class See Also Send Feedback
Initializes a new instance of the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadComboBox()

See Also

RadComboBox Class
RadComboBox Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBox Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Constructor (Element)
RadComboBox Class See Also Send Feedback
Initializes a new instance of the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBox(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadComboBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBox Class
RadComboBox Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Methods
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadComboBox control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ClearItems | Clears all items of the combobox.
ClearSelection | Clears the selection.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Disable | Disables the combo box.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the combo box.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HideDropDown | Hide the drop down of RadComboBox.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetText | Set the given text of the ComboBox. Swows the drop down as well.
SetValue | Overloaded.
ShowDropDown | Show the drop down of RadComboBox.
ToggleDropDown | Toggle the drop down of RadComboBox.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.AssignElement Method
RadComboBox Class See Also Send Feedback
Assign the DOM element to be the RadComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.CallMethod Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Capture Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ClearItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ClearItems Method
RadComboBox Class See Also Send Feedback
Clears all items of the combobox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClearItems()
Visual Basic (Declaration)
Public Sub ClearItems
Visual C++
public:
void ClearItems()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ClearSelection Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ClearSelection Method
RadComboBox Class See Also Send Feedback
Clears the selection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClearSelection()
Visual Basic (Declaration)
Public Sub ClearSelection
Visual C++
public:
void ClearSelection()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Click Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ControlAssert Method
RadComboBox Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Disable Method
RadComboBox Class See Also Send Feedback
Disables the combo box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.DragTo Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Enable Method
RadComboBox Class See Also Send Feedback
Enables the combo box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.FindItem Method
RadComboBox Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBoxItem FindItem(
    Predicate<RadComboBoxItem> predicate
)
Visual Basic (Declaration)
Public Function FindItem ( _
    predicate As Predicate(Of RadComboBoxItem) _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItem(
    Predicate<RadComboBoxItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadComboBoxItem >)>)
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.FindItemByText Method
RadComboBox Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBoxItem FindItemByText(
    string itemText
)
Visual Basic (Declaration)
Public Function FindItemByText ( _
    itemText As String _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::.String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByText(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.FindItemByValue Method
RadComboBox Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBoxItem FindItemByValue(
    string itemValue
)
Visual Basic (Declaration)
Public Function FindItemByValue ( _
    itemValue As String _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::.String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByValue(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.GetValue Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


HideDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.HideDropDown Method
RadComboBox Class See Also Send Feedback
Hide the drop down of RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HideDropDown()
Visual Basic (Declaration)
Public Sub HideDropDown
Visual C++
public:
void HideDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.InvokeEvent Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.MouseClick Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.MouseHover Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ScrollToVisible Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


SetText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SetText Method
RadComboBox Class See Also Send Feedback
Set the given text of the ComboBox. Swows the drop down as well.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SetText(
    string text
)
Visual Basic (Declaration)
Public Sub SetText ( _
    text As String _
)
Visual C++
public:
void SetText(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.SetText(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SetValue Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ShowDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ShowDropDown Method
RadComboBox Class See Also Send Feedback
Show the drop down of RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowDropDown()
Visual Basic (Declaration)
Public Sub ShowDropDown
Visual C++
public:
void ShowDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ToggleDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ToggleDropDown Method
RadComboBox Class See Also Send Feedback
Toggle the drop down of RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleDropDown()
Visual Basic (Declaration)
Public Sub ToggleDropDown
Visual C++
public:
void ToggleDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


RadComboBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Properties
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
ComboBoxValue | Gets or set the ComboBox value.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownVisible | Gets whether the drop down is visible.
ElementOffsetWidth | Get the offset width of the combobox element.
EmptyMessage | Gets or set the empty message text of the RadComboBox.
Enabled | Get whether combobox is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
FilterEnabled | Get whether combobox filtering is enabled.
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of items.
LastWord | Gets the word after the last separator in the text of the combobox. If a separator is not set, returns the text itself.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets the selected index of the RadComboBox. Returns '-1' if there is no selected item.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Gets or set the text of the RadComboBox.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VisibleItems | Get the list of the visible items.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ClientSideLocator Property
RadComboBox Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ComboBoxValue Property
RadComboBox Class See Also Send Feedback
Gets or set the ComboBox value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ComboBoxValue { get; set; }
Visual Basic (Declaration)
Public Property ComboBoxValue As String
Visual C++
public:
property String^ ComboBoxValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


DropDownVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.DropDownVisible Property
RadComboBox Class See Also Send Feedback
Gets whether the drop down is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool DropDownVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownVisible As Boolean
Visual C++
public:
property bool DropDownVisible {
    bool get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ElementOffsetWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ElementOffsetWidth Property
RadComboBox Class See Also Send Feedback
Get the offset width of the combobox element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ElementOffsetWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElementOffsetWidth As Integer
Visual C++
public:
property int ElementOffsetWidth {
    int get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


EmptyMessage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.EmptyMessage Property
RadComboBox Class See Also Send Feedback
Gets or set the empty message text of the RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EmptyMessage { get; set; }
Visual Basic (Declaration)
Public Property EmptyMessage As String
Visual C++
public:
property String^ EmptyMessage {
    String^ get ();
    void set (String^ value);
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Enabled Property
RadComboBox Class See Also Send Feedback
Get whether combobox is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FilterEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.FilterEnabled Property
RadComboBox Class See Also Send Feedback
Get whether combobox filtering is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool FilterEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilterEnabled As Boolean
Visual C++
public:
property bool FilterEnabled {
    bool get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Items Property
RadComboBox Class See Also Send Feedback
Get the list of items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadComboBoxItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadComboBoxItem)
Visual C++
public:
property IList<RadComboBoxItem^>^ Items {
    IList<RadComboBoxItem^>^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


LastWord Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.LastWord Property
RadComboBox Class See Also Send Feedback
Gets the word after the last separator in the text of the combobox. If a separator is not set, returns the text itself.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LastWord { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastWord As String
Visual C++
public:
property String^ LastWord {
    String^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.LocatorExpression Property
RadComboBox Class See Also Send Feedback
Get the FindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


SelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SelectedIndex Property
RadComboBox Class See Also Send Feedback
Gets the selected index of the RadComboBox. Returns '-1' if there is no selected item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectedIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Text Property
RadComboBox Class See Also Send Feedback
Gets or set the text of the RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


VisibleItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.VisibleItems Property
RadComboBox Class See Also Send Feedback
Get the list of the visible items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadComboBoxItem> VisibleItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibleItems As IList(Of RadComboBoxItem)
Visual C++
public:
property IList<RadComboBoxItem^>^ VisibleItems {
    IList<RadComboBoxItem^>^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Class
Members See Also Send Feedback
Represents the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadComboBoxItem : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadComboBoxItem _
    Inherits HtmlContainerControl
Visual C++
public ref class RadComboBoxItem : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadComboBoxItem

See Also

RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Members
RadComboBoxItem Class Constructors Methods Properties See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Constructors

Name | Description
RadComboBoxItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | This method executes when traverse trough page elements. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the item.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hides the item.
Highlight | Highlights the item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the item. Hides the combo drop down.
SetValue | Overloaded.
Show | Shows the item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UNHighlight | Unhighlights the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the combo item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Highlighted | Get whether the combo item is highlighted.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the combo item index.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemValue | Get or set the value for this item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Check if the item is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text for this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the combo item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Constructor
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
RadComboBoxItem()()() | Initializes a new instance of the RadComboBoxItem class.
RadComboBoxItem(Element) | Initializes a new instance of the RadComboBoxItem class.

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Constructor
RadComboBoxItem Class See Also Send Feedback
Initializes a new instance of the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBoxItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadComboBoxItem()

See Also

RadComboBoxItem Class
RadComboBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Constructor (Element)
RadComboBoxItem Class See Also Send Feedback
Initializes a new instance of the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBoxItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadComboBoxItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBoxItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBoxItem Class
RadComboBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Methods
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | This method executes when traverse trough page elements. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the item.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hides the item.
Highlight | Highlights the item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the item. Hides the combo drop down.
SetValue | Overloaded.
Show | Shows the item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UNHighlight | Unhighlights the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.AssignElement Method
RadComboBoxItem Class See Also Send Feedback
This method executes when traverse trough page elements.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBoxItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.CallMethod Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Capture Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Click Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.ControlAssert Method
RadComboBoxItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Disable Method
RadComboBoxItem Class See Also Send Feedback
Disables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.DragTo Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Enable Method
RadComboBoxItem Class See Also Send Feedback
Enables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.GetValue Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Hide Method
RadComboBoxItem Class See Also Send Feedback
Hides the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Highlight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Highlight Method
RadComboBoxItem Class See Also Send Feedback
Highlights the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Highlight()
Visual Basic (Declaration)
Public Sub Highlight
Visual C++
public:
void Highlight()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.InvokeEvent Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.MouseClick Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.MouseHover Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.ScrollToVisible Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Select Method
RadComboBoxItem Class See Also Send Feedback
Select the item. Hides the combo drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.SetValue Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Show Method
RadComboBoxItem Class See Also Send Feedback
Shows the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


UNHighlight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.UNHighlight Method
RadComboBoxItem Class See Also Send Feedback
Unhighlights the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UNHighlight()
Visual Basic (Declaration)
Public Sub UNHighlight
Visual C++
public:
void UNHighlight()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Properties
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the combo item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Highlighted | Get whether the combo item is highlighted.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the combo item index.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemValue | Get or set the value for this item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Check if the item is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text for this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the combo item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.ClientSideLocator Property
RadComboBoxItem Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Enabled Property
RadComboBoxItem Class See Also Send Feedback
Get whether the combo item is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Highlighted Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Highlighted Property
RadComboBoxItem Class See Also Send Feedback
Get whether the combo item is highlighted.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Highlighted { get; }
Visual Basic (Declaration)
Public ReadOnly Property Highlighted As Boolean
Visual C++
public:
property bool Highlighted {
    bool get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Index Property
RadComboBoxItem Class See Also Send Feedback
Get the combo item index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


ItemValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.ItemValue Property
RadComboBoxItem Class See Also Send Feedback
Get or set the value for this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemValue { get; set; }
Visual Basic (Declaration)
Public Property ItemValue As String
Visual C++
public:
property String^ ItemValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.LocatorExpression Property
RadComboBoxItem Class See Also Send Feedback
Get the FindParam that defines the pattern for a treeview node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Selected Property
RadComboBoxItem Class See Also Send Feedback
Check if the item is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Text Property
RadComboBoxItem Class See Also Send Feedback
Get or set the text for this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Visible Property
RadComboBoxItem Class See Also Send Feedback
Get whether the combo item is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Class
Members See Also Send Feedback
Represents the base class for assertion of RadControls wrappers.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadControlAssert : BaseControlAssert<HtmlControl>
Visual Basic (Declaration)
Public Class RadControlAssert _
    Inherits BaseControlAssert(Of HtmlControl)
Visual C++
public ref class RadControlAssert : public BaseControlAssert<HtmlControl^>

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.BaseControlAssert<(Of <(HtmlControl>)>)
Telerik.WebAii.Controls.Html..::.RadControlAssert

See Also

RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Members
RadControlAssert Class Constructors Methods Properties See Also Send Feedback

The RadControlAssert type exposes the following members.

Constructors

Name | Description
RadControlAssert | Overloaded.

Methods

Name | Description
Assert | Overloaded.
AssertNumber | Overloaded.
AssertString | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NumberValue | Assert a number.
StringValue | Assert a string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Constructor
RadControlAssert Class See Also Send Feedback

Overload List

Name | Description
RadControlAssert()()() | Initializes a new instance of the RadControlAssert class.
RadControlAssert(HtmlControl) | Initializes a new instance of the RadControlAssert class.

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Constructor
RadControlAssert Class See Also Send Feedback
Initializes a new instance of the RadControlAssert class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadControlAssert()

See Also

RadControlAssert Class
RadControlAssert Overload
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Constructor (HtmlControl)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Constructor (HtmlControl)
RadControlAssert Class See Also Send Feedback
Initializes a new instance of the RadControlAssert class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert(
    HtmlControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As HtmlControl _
)
Visual C++
public:
RadControlAssert(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
The target control to assert against.

See Also

RadControlAssert Class
RadControlAssert Overload
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Methods
RadControlAssert Class See Also Send Feedback

The RadControlAssert type exposes the following members.

Methods

Name | Description
Assert | Overloaded.
AssertNumber | Overloaded.
AssertString | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NumberValue | Assert a number.
StringValue | Assert a string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


Assert Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert..::.Assert Method
RadControlAssert Class See Also Send Feedback

Overload List

Name | Description
Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)
Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


AssertNumber Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert..::.AssertNumber Method
RadControlAssert Class See Also Send Feedback

Overload List

Name | Description
AssertNumber(Int32, Int32, NumberCompareType) | Obsolete. Common assert for a number (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)
AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


AssertString Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert..::.AssertString Method
RadControlAssert Class See Also Send Feedback

Overload List

Name | Description
AssertString(String, String, StringCompareType) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)
AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


NumberValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert..::.NumberValue Method
RadControlAssert Class See Also Send Feedback
Assert a number.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool NumberValue(
    string controlPropertyName,
    int expected,
    NumberCompareType compareType
)
Visual Basic (Declaration)
Public Function NumberValue ( _
    controlPropertyName As String, _
    expected As Integer, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
bool NumberValue(
    String^ controlPropertyName,
    int expected,
    NumberCompareType compareType
)

Parameters

controlPropertyName
Type: System..::.String
The property name to get value of.
expected
Type: System..::.Int32
The expected string.
compareType
Type: ArtOfTest.Common..::.NumberCompareType
The compare type.

Return Value

True/false whether the comparison works. Returns false if the property value is not of integer type.

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


StringValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert..::.StringValue Method
RadControlAssert Class See Also Send Feedback
Assert a string.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StringValue(
    string controlPropertyName,
    string expected,
    StringCompareType compareType
)
Visual Basic (Declaration)
Public Function StringValue ( _
    controlPropertyName As String, _
    expected As String, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool StringValue(
    String^ controlPropertyName,
    String^ expected,
    StringCompareType compareType
)

Parameters

controlPropertyName
Type: System..::.String
The property name to get value of.
expected
Type: System..::.String
The expected string.
compareType
Type: ArtOfTest.Common..::.StringCompareType
The compare type.

Return Value

True/false whether the comparison works.

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlAssert Properties
RadControlAssert Class See Also Send Feedback

The RadControlAssert type exposes the following members.

Properties

Name | Description
Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(HtmlControl>)>).)

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


RadDataPager Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Class
Members See Also Send Feedback
Represents RadDataPager for Asp.Net Ajax control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDataPager : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadDataPager _
    Inherits HtmlContainerControl
Visual C++
public ref class RadDataPager : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadDataPager

See Also

RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


RadDataPager Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Members
RadDataPager Class Constructors Methods Properties See Also Send Feedback

The RadDataPager type exposes the following members.

Constructors

Name | Description
RadDataPager | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FirstPage | Clicks the first page button.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
LastPage | Clicks the last page button.
LoadPage | Clicks a number from the numeric pages.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
NextPage | Clicks the next page button.
Page | Clicks the 'Go' button to perform paging.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
PreviousPage | Clicks the previous page button.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of the DataPager.
ClientSideLocator | The client-side locator of the RadDataPager. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentPageIndex | Get or set the current page index of the DataPager.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | Get the page count of the DataPager.
PagerNumericTextBox | The numeric textbox in the pager.
PageSize | Get or set the page size of the DataPager.
PageSizeCombo | The page size ComboBox.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TotalRowCount | The row count.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


RadDataPager Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Constructor
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
RadDataPager()()() | Initializes a new instance of the RadDataPager class.
RadDataPager(Element) | Initializes a new instance of the RadDataPager class.

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


RadDataPager Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Constructor
RadDataPager Class See Also Send Feedback
Initializes a new instance of the RadDataPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDataPager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDataPager()

See Also

RadDataPager Class
RadDataPager Overload
Telerik.WebAii.Controls.Html Namespace


RadDataPager Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Constructor (Element)
RadDataPager Class See Also Send Feedback
Initializes a new instance of the RadDataPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDataPager(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDataPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDataPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDataPager Class
RadDataPager Overload
Telerik.WebAii.Controls.Html Namespace


RadDataPager Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Methods
RadDataPager Class See Also Send Feedback

The RadDataPager type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FirstPage | Clicks the first page button.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
LastPage | Clicks the last page button.
LoadPage | Clicks a number from the numeric pages.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
NextPage | Clicks the next page button.
Page | Clicks the 'Go' button to perform paging.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
PreviousPage | Clicks the previous page button.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.AssignElement Method
RadDataPager Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.CallMethod Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.Capture Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.Click Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.ControlAssert Method
RadDataPager Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.DragTo Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


FirstPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.FirstPage Method
RadDataPager Class See Also Send Feedback
Clicks the first page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FirstPage()
Visual Basic (Declaration)
Public Sub FirstPage
Visual C++
public:
void FirstPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.GetValue Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.InvokeEvent Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


LastPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.LastPage Method
RadDataPager Class See Also Send Feedback
Clicks the last page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LastPage()
Visual Basic (Declaration)
Public Sub LastPage
Visual C++
public:
void LastPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.LoadPage Method
RadDataPager Class See Also Send Feedback
Clicks a number from the numeric pages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadPage(
    int pageNumber
)
Visual Basic (Declaration)
Public Sub LoadPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::.Int32
The numer to click on.

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.MouseClick Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.MouseHover Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


NextPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.NextPage Method
RadDataPager Class See Also Send Feedback
Clicks the next page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NextPage()
Visual Basic (Declaration)
Public Sub NextPage
Visual C++
public:
void NextPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


Page Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.Page Method
RadDataPager Class See Also Send Feedback
Clicks the 'Go' button to perform paging.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Page()
Visual Basic (Declaration)
Public Sub Page
Visual C++
public:
void Page()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PreviousPage Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.PreviousPage Method
RadDataPager Class See Also Send Feedback
Clicks the previous page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void PreviousPage()
Visual Basic (Declaration)
Public Sub PreviousPage
Visual C++
public:
void PreviousPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.ScrollToVisible Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.SetValue Method
RadDataPager Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


RadDataPager Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager Properties
RadDataPager Class See Also Send Feedback

The RadDataPager type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of the DataPager.
ClientSideLocator | The client-side locator of the RadDataPager. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentPageIndex | Get or set the current page index of the DataPager.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | Get the page count of the DataPager.
PagerNumericTextBox | The numeric textbox in the pager.
PageSize | Get or set the page size of the DataPager.
PageSizeCombo | The page size ComboBox.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TotalRowCount | The row count.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.ClientId Property
RadDataPager Class See Also Send Feedback
The client id of the DataPager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.ClientSideLocator Property
RadDataPager Class See Also Send Feedback
The client-side locator of the RadDataPager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


CurrentPageIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.CurrentPageIndex Property
RadDataPager Class See Also Send Feedback
Get or set the current page index of the DataPager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int CurrentPageIndex { get; set; }
Visual Basic (Declaration)
Public Property CurrentPageIndex As Integer
Visual C++
public:
property int CurrentPageIndex {
    int get ();
    void set (int value);
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.LocatorExpression Property
RadDataPager Class See Also Send Feedback
Get the item locator FindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PageCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.PageCount Property
RadDataPager Class See Also Send Feedback
Get the page count of the DataPager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PagerNumericTextBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.PagerNumericTextBox Property
RadDataPager Class See Also Send Feedback
The numeric textbox in the pager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadNumericTextBox PagerNumericTextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagerNumericTextBox As RadNumericTextBox
Visual C++
public:
property RadNumericTextBox^ PagerNumericTextBox {
    RadNumericTextBox^ get ();
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PageSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.PageSize Property
RadDataPager Class See Also Send Feedback
Get or set the page size of the DataPager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageSize { get; set; }
Visual Basic (Declaration)
Public Property PageSize As Integer
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PageSizeCombo Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.PageSizeCombo Property
RadDataPager Class See Also Send Feedback
The page size ComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBox PageSizeCombo { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSizeCombo As RadComboBox
Visual C++
public:
property RadComboBox^ PageSizeCombo {
    RadComboBox^ get ();
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


TotalRowCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDataPager..::.TotalRowCount Property
RadDataPager Class See Also Send Feedback
The row count.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int TotalRowCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalRowCount As Integer
Visual C++
public:
property int TotalRowCount {
    int get ();
}

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


RadDateInput Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput Class
Members See Also Send Feedback
Represents the RadDateInput for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDateInput : RadInput
Visual Basic (Declaration)
Public Class RadDateInput _
    Inherits RadInput
Visual C++
public ref class RadDateInput : public RadInput

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInput
Telerik.WebAii.Controls.Html..::.RadDateInput

See Also

RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


RadDateInput Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput Members
RadDateInput Class Constructors Methods Properties See Also Send Feedback

The RadDateInput type exposes the following members.

Constructors

Name | Description
RadDateInput | Initializes a new instance of the RadDateInput class

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DateFormat | Get the date format of the DateInput control.
DisplayDateFormat | Get the display date format of the DateInput control.
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Get or set the latest valid date value.
MinDate | Get or set the earliest valid date value.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Get or set the selected date of the RadDateInput control. If the date input is empty, the property returns the DateTime.MinValue value.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


RadDateInput Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput Constructor
RadDateInput Class See Also Send Feedback
Initializes a new instance of the RadDateInput class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDateInput()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDateInput()

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


RadDateInput Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput Methods
RadDateInput Class See Also Send Feedback

The RadDateInput type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.CallMethod Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.Capture Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.Click Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.DragTo Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.GetValue Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.InvokeEvent Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.MouseClick Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.MouseHover Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.ScrollToVisible Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.SetValue Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.TypeText Method
RadDateInput Class See Also Send Feedback

Overload List

Name | Description
TypeText(String) | Types text into the input. (Inherited from RadInput.)
TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


RadDateInput Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput Properties
RadDateInput Class See Also Send Feedback

The RadDateInput type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DateFormat | Get the date format of the DateInput control.
DisplayDateFormat | Get the display date format of the DateInput control.
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Get or set the latest valid date value.
MinDate | Get or set the earliest valid date value.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Get or set the selected date of the RadDateInput control. If the date input is empty, the property returns the DateTime.MinValue value.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


DateFormat Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.DateFormat Property
RadDateInput Class See Also Send Feedback
Get the date format of the DateInput control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DateFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateFormat As String
Visual C++
public:
property String^ DateFormat {
    String^ get ();
}

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


DisplayDateFormat Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.DisplayDateFormat Property
RadDateInput Class See Also Send Feedback
Get the display date format of the DateInput control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DisplayDateFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayDateFormat As String
Visual C++
public:
property String^ DisplayDateFormat {
    String^ get ();
}

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


MaxDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.MaxDate Property
RadDateInput Class See Also Send Feedback
Get or set the latest valid date value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime MaxDate { get; set; }
Visual Basic (Declaration)
Public Property MaxDate As DateTime
Visual C++
public:
property DateTime MaxDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


MinDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.MinDate Property
RadDateInput Class See Also Send Feedback
Get or set the earliest valid date value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime MinDate { get; set; }
Visual Basic (Declaration)
Public Property MinDate As DateTime
Visual C++
public:
property DateTime MinDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


SelectedDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateInput..::.SelectedDate Property
RadDateInput Class See Also Send Feedback
Get or set the selected date of the RadDateInput control. If the date input is empty, the property returns the DateTime.MinValue value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime SelectedDate { get; set; }
Visual Basic (Declaration)
Public Property SelectedDate As DateTime
Visual C++
public:
property DateTime SelectedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Class
Members See Also Send Feedback
Represents the RadDatePicker for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDatePicker : RadPicker
Visual Basic (Declaration)
Public Class RadDatePicker _
    Inherits RadPicker
Visual C++
public ref class RadDatePicker : public RadPicker

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPicker
Telerik.WebAii.Controls.Html..::.RadDatePicker
Telerik.WebAii.Controls.Html..::.RadDateTimePicker

See Also

RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Members
RadDatePicker Class Constructors Methods Properties See Also Send Feedback

The RadDatePicker type exposes the following members.

Constructors

Name | Description
RadDatePicker | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Calendar | Gets the Calendar part of the picker wrapper.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker. (Inherited from RadPicker.)
PickerType | Gets the Picker control type. (Inherited from RadPicker.)
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Constructor
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
RadDatePicker()()() | Initializes a new instance of the RadDatePicker class.
RadDatePicker(Element) | Initializes a new instance of the RadDatePicker class.

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Constructor
RadDatePicker Class See Also Send Feedback
Initializes a new instance of the RadDatePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDatePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDatePicker()

See Also

RadDatePicker Class
RadDatePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Constructor (Element)
RadDatePicker Class See Also Send Feedback
Initializes a new instance of the RadDatePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDatePicker(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDatePicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDatePicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDatePicker Class
RadDatePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Methods
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.CallMethod Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Capture Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Click Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.DragTo Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.GetValue Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.InvokeEvent Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.MouseClick Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.MouseHover Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.ScrollToVisible Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.SetValue Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Properties
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Calendar | Gets the Calendar part of the picker wrapper.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker. (Inherited from RadPicker.)
PickerType | Gets the Picker control type. (Inherited from RadPicker.)
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


Calendar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Calendar Property
RadDatePicker Class See Also Send Feedback
Gets the Calendar part of the picker wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCalendar Calendar { get; }
Visual Basic (Declaration)
Public ReadOnly Property Calendar As RadCalendar
Visual C++
public:
property RadCalendar^ Calendar {
    RadCalendar^ get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Class
Members See Also Send Feedback
Represents the RadDateTimePicker for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDateTimePicker : RadDatePicker
Visual Basic (Declaration)
Public Class RadDateTimePicker _
    Inherits RadDatePicker
Visual C++
public ref class RadDateTimePicker : public RadDatePicker

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPicker
Telerik.WebAii.Controls.Html..::.RadDatePicker
Telerik.WebAii.Controls.Html..::.RadDateTimePicker

See Also

RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Members
RadDateTimePicker Class Constructors Methods Properties See Also Send Feedback

The RadDateTimePicker type exposes the following members.

Constructors

Name | Description
RadDateTimePicker | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Calendar | Gets the Calendar part of the picker wrapper. (Inherited from RadDatePicker.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker. (Inherited from RadPicker.)
PickerType | Gets the Picker control type. (Inherited from RadPicker.)
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TimeView | Gets the TimeView wrapper of the picker.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Constructor
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
RadDateTimePicker()()() | Initializes a new instance of the RadDateTimePicker class.
RadDateTimePicker(Element) | Initializes a new instance of the RadDateTimePicker class.

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Constructor
RadDateTimePicker Class See Also Send Feedback
Initializes a new instance of the RadDateTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDateTimePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDateTimePicker()

See Also

RadDateTimePicker Class
RadDateTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Constructor (Element)
RadDateTimePicker Class See Also Send Feedback
Initializes a new instance of the RadDateTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDateTimePicker(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDateTimePicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDateTimePicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDateTimePicker Class
RadDateTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Methods
RadDateTimePicker Class See Also Send Feedback

The RadDateTimePicker type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.CallMethod Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.Capture Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.Click Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.DragTo Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.GetValue Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.InvokeEvent Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.MouseClick Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.MouseHover Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.ScrollToVisible Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.SetValue Method
RadDateTimePicker Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker Properties
RadDateTimePicker Class See Also Send Feedback

The RadDateTimePicker type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Calendar | Gets the Calendar part of the picker wrapper. (Inherited from RadDatePicker.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker. (Inherited from RadPicker.)
PickerType | Gets the Picker control type. (Inherited from RadPicker.)
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TimeView | Gets the TimeView wrapper of the picker.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


TimeView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDateTimePicker..::.TimeView Property
RadDateTimePicker Class See Also Send Feedback
Gets the TimeView wrapper of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimeView TimeView { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeView As RadTimeView
Visual C++
public:
property RadTimeView^ TimeView {
    RadTimeView^ get ();
}

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadEditor Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Class
Members See Also Send Feedback
A simple control wrapper for the RadEditor for the ASP.NET AJAX.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadEditor : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadEditor _
    Inherits HtmlContainerControl
Visual C++
public ref class RadEditor : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadEditor

See Also

RadEditor Members
Telerik.WebAii.Controls.Html Namespace


RadEditor Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Members
RadEditor Class Constructors Methods Properties See Also Send Feedback

The RadEditor type exposes the following members.

Constructors

Name | Description
RadEditor | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindDropDownByName | Gets the the dropdown by its command name.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FindSplitButtonByName | Gets the the splitbutton by its command name.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowToolBar | Shows toolbar, when toolbar mode is OnFocus or PageTop.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EditModes | Gets/Sets which editor modes are included in RadEditor.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets RadEditor's height.
Html | Gets/Sets html of RadEditor.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsFullScreen | Determines whether RadEditor is in FullScreen mode.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadEditor. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Mode | Gets/Sets current RadEditor Mode.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectionHtml | Gets selected html.
SelectionText | Gets selected text.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Gets/Sets text of the RadEditor.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolBarMode | Gets/Sets toolbar mode of RadEditor.
ToolCount | Gets the RadEditor tool count.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets RadEditor's width.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


RadEditor Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Constructor
RadEditor Class See Also Send Feedback

Overload List

Name | Description
RadEditor()()() | Initializes a new instance of the RadEditor class.
RadEditor(Element) | Initializes a new instance of the RadEditor class.

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


RadEditor Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Constructor
RadEditor Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadEditor()

See Also

RadEditor Class
RadEditor Overload
Telerik.WebAii.Controls.Html Namespace


RadEditor Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Constructor (Element)
RadEditor Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadEditor(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadEditor(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadEditor.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadEditor Class
RadEditor Overload
Telerik.WebAii.Controls.Html Namespace


RadEditor Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Methods
RadEditor Class See Also Send Feedback

The RadEditor type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindDropDownByName | Gets the the dropdown by its command name.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FindSplitButtonByName | Gets the the splitbutton by its command name.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ShowToolBar | Shows toolbar, when toolbar mode is OnFocus or PageTop.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.AssignElement Method
RadEditor Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.CallMethod Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Capture Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Click Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.ControlAssert Method
RadEditor Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.DragTo Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


FindDropDownByName Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.FindDropDownByName Method
RadEditor Class See Also Send Feedback
Gets the the dropdown by its command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorDropDown FindDropDownByName(
    string commandName
)
Visual Basic (Declaration)
Public Function FindDropDownByName ( _
    commandName As String _
) As EditorDropDown
Visual C++
public:
EditorDropDown^ FindDropDownByName(
    String^ commandName
)

Parameters

commandName
Type: System..::.String
The commnad name of the EditorDropDown.

Return Value

EditorDropDown control.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


FindSplitButtonByName Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.FindSplitButtonByName Method
RadEditor Class See Also Send Feedback
Gets the the splitbutton by its command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorSplitButton FindSplitButtonByName(
    string commandName
)
Visual Basic (Declaration)
Public Function FindSplitButtonByName ( _
    commandName As String _
) As EditorSplitButton
Visual C++
public:
EditorSplitButton^ FindSplitButtonByName(
    String^ commandName
)

Parameters

commandName
Type: System..::.String
The commnad name of the EditorSplitButton.

Return Value

EditorSplitButton control.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.GetValue Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.InvokeEvent Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.MouseClick Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.MouseHover Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.ScrollToVisible Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.SetValue Method
RadEditor Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


ShowToolBar Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.ShowToolBar Method
RadEditor Class See Also Send Feedback
Shows toolbar, when toolbar mode is OnFocus or PageTop.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowToolBar()
Visual Basic (Declaration)
Public Sub ShowToolBar
Visual C++
public:
void ShowToolBar()

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


RadEditor Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor Properties
RadEditor Class See Also Send Feedback

The RadEditor type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EditModes | Gets/Sets which editor modes are included in RadEditor.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets RadEditor's height.
Html | Gets/Sets html of RadEditor.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsFullScreen | Determines whether RadEditor is in FullScreen mode.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadEditor. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Mode | Gets/Sets current RadEditor Mode.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectionHtml | Gets selected html.
SelectionText | Gets selected text.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Gets/Sets text of the RadEditor.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolBarMode | Gets/Sets toolbar mode of RadEditor.
ToolCount | Gets the RadEditor tool count.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets RadEditor's width.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.ClientSideLocator Property
RadEditor Class See Also Send Feedback
Gets the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


EditModes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.EditModes Property
RadEditor Class See Also Send Feedback
Gets/Sets which editor modes are included in RadEditor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int EditModes { get; set; }
Visual Basic (Declaration)
Public Property EditModes As Integer
Visual C++
public:
property int EditModes {
    int get ();
    void set (int value);
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Height Property
RadEditor Class See Also Send Feedback
Gets/Sets RadEditor's height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


Html Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Html Property
RadEditor Class See Also Send Feedback
Gets/Sets html of RadEditor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Html { get; set; }
Visual Basic (Declaration)
Public Property Html As String
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


IsFullScreen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.IsFullScreen Property
RadEditor Class See Also Send Feedback
Determines whether RadEditor is in FullScreen mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFullScreen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFullScreen As Boolean
Visual C++
public:
property bool IsFullScreen {
    bool get ();
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.LocatorExpression Property
RadEditor Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadEditor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


Mode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Mode Property
RadEditor Class See Also Send Feedback
Gets/Sets current RadEditor Mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As EditorMode
Visual C++
public:
property EditorMode Mode {
    EditorMode get ();
    void set (EditorMode value);
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


SelectionHtml Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.SelectionHtml Property
RadEditor Class See Also Send Feedback
Gets selected html.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectionHtml { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionHtml As String
Visual C++
public:
property String^ SelectionHtml {
    String^ get ();
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


SelectionText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.SelectionText Property
RadEditor Class See Also Send Feedback
Gets selected text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectionText { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionText As String
Visual C++
public:
property String^ SelectionText {
    String^ get ();
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Text Property
RadEditor Class See Also Send Feedback
Gets/Sets text of the RadEditor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


ToolBarMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.ToolBarMode Property
RadEditor Class See Also Send Feedback
Gets/Sets toolbar mode of RadEditor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public EditorToolBarMode ToolBarMode { get; set; }
Visual Basic (Declaration)
Public Property ToolBarMode As EditorToolBarMode
Visual C++
public:
property EditorToolBarMode ToolBarMode {
    EditorToolBarMode get ();
    void set (EditorToolBarMode value);
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


ToolCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.ToolCount Property
RadEditor Class See Also Send Feedback
Gets the RadEditor tool count.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ToolCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToolCount As Integer
Visual C++
public:
property int ToolCount {
    int get ();
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadEditor..::.Width Property
RadEditor Class See Also Send Feedback
Gets/Sets RadEditor's width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


RadGrid Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Class
Members See Also Send Feedback
Represents the RadGrid for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadGrid : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadGrid _
    Inherits HtmlContainerControl
Visual C++
public ref class RadGrid : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadGrid

See Also

RadGrid Members
Telerik.WebAii.Controls.Html Namespace


RadGrid Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Members
RadGrid Class Constructors Methods Properties See Also Send Feedback

The RadGrid type exposes the following members.

Constructors

Name | Description
RadGrid | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindColumn | Find column by given predicate.
FindColumnByName | Finds column by name.
FindColumns | Get a list of columns matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllowColumnResize | Get whether the column resizing is allowed.
AllowColumnsReorder | Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.
AllowMultiRowSelection | Get whether the multi-row selection is enabled.
AllowRowResize | Get whether the row resizing is allowed.
AllowRowSelection | Get whether the client-side row selection is enabled.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the RadGrid control. (Overrides HtmlControl..::.ClientSideLocator.)
ClipCellContentOnResize | Get whether the clip-cell-content-on-resize is enabled.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DetailTableCount | Get the detail table levels of the Grid.
EnableDragToSelectRows | Get whether the drag-to-select option is enabled.
EnableHeaderContextMenu | Get whether the header context menu is enabled.
EnableRealTimeResize | Get whether the real-time resizing is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
GridFilterItem | Get the FilterItem HtmlControl if fitering is enabled.
GroupPanel | Get the GroupPanel HtmlControl if RadGrid's GroupPanel is enabled or null otherwise.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MasterTable | Get the Grid MasterTable.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Pager | Get the Grid pager control.
ReorderColumnsOnClient | Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.
ResizeGridOnColumnResize | Get whether the resize-grid-on-column-resizing is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


RadGrid Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Constructor
RadGrid Class See Also Send Feedback

Overload List

Name | Description
RadGrid()()() | Initializes a new instance of the RadGrid class.
RadGrid(Element) | Initializes a new instance of the RadGrid class.

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


RadGrid Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Constructor
RadGrid Class See Also Send Feedback
Initializes a new instance of the RadGrid class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadGrid()

See Also

RadGrid Class
RadGrid Overload
Telerik.WebAii.Controls.Html Namespace


RadGrid Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Constructor (Element)
RadGrid Class See Also Send Feedback
Initializes a new instance of the RadGrid class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGrid(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadGrid(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadGrid.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadGrid Class
RadGrid Overload
Telerik.WebAii.Controls.Html Namespace


RadGrid Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Methods
RadGrid Class See Also Send Feedback

The RadGrid type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindColumn | Find column by given predicate.
FindColumnByName | Finds column by name.
FindColumns | Get a list of columns matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.AssignElement Method
RadGrid Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.CallMethod Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.Capture Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.Click Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.ControlAssert Method
RadGrid Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.DragTo Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


FindColumn Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.FindColumn Method
RadGrid Class See Also Send Feedback
Find column by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableHeader FindColumn(
    Predicate<GridTableHeader> predicate
)
Visual Basic (Declaration)
Public Function FindColumn ( _
    predicate As Predicate(Of GridTableHeader) _
) As GridTableHeader
Visual C++
public:
GridTableHeader^ FindColumn(
    Predicate<GridTableHeader^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( GridTableHeader >)>)
The predicate used as search criteria.

Return Value

The column matching the given criteria or null if nothing matches the search.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


FindColumnByName Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.FindColumnByName Method
RadGrid Class See Also Send Feedback
Finds column by name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableHeader FindColumnByName(
    string columnName
)
Visual Basic (Declaration)
Public Function FindColumnByName ( _
    columnName As String _
) As GridTableHeader
Visual C++
public:
GridTableHeader^ FindColumnByName(
    String^ columnName
)

Parameters

columnName
Type: System..::.String

[Missing <param name="columnName"/> documentation for "M:Telerik.WebAii.Controls.Html.RadGrid.FindColumnByName(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadGrid.FindColumnByName(System.String)"]

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


FindColumns Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.FindColumns Method
RadGrid Class See Also Send Feedback
Get a list of columns matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridTableHeader> FindColumns(
    Predicate<GridTableHeader> predicate
)
Visual Basic (Declaration)
Public Function FindColumns ( _
    predicate As Predicate(Of GridTableHeader) _
) As IList(Of GridTableHeader)
Visual C++
public:
IList<GridTableHeader^>^ FindColumns(
    Predicate<GridTableHeader^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( GridTableHeader >)>)
The predicate.

Return Value

The columns matching the given predicate.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.GetValue Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.InvokeEvent Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.MouseClick Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.MouseHover Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.ScrollToVisible Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.SetValue Method
RadGrid Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


RadGrid Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid Properties
RadGrid Class See Also Send Feedback

The RadGrid type exposes the following members.

Properties

Name | Description
AllowColumnResize | Get whether the column resizing is allowed.
AllowColumnsReorder | Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.
AllowMultiRowSelection | Get whether the multi-row selection is enabled.
AllowRowResize | Get whether the row resizing is allowed.
AllowRowSelection | Get whether the client-side row selection is enabled.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the RadGrid control. (Overrides HtmlControl..::.ClientSideLocator.)
ClipCellContentOnResize | Get whether the clip-cell-content-on-resize is enabled.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DetailTableCount | Get the detail table levels of the Grid.
EnableDragToSelectRows | Get whether the drag-to-select option is enabled.
EnableHeaderContextMenu | Get whether the header context menu is enabled.
EnableRealTimeResize | Get whether the real-time resizing is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
GridFilterItem | Get the FilterItem HtmlControl if fitering is enabled.
GroupPanel | Get the GroupPanel HtmlControl if RadGrid's GroupPanel is enabled or null otherwise.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MasterTable | Get the Grid MasterTable.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Pager | Get the Grid pager control.
ReorderColumnsOnClient | Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.
ResizeGridOnColumnResize | Get whether the resize-grid-on-column-resizing is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AllowColumnResize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.AllowColumnResize Property
RadGrid Class See Also Send Feedback
Get whether the column resizing is allowed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowColumnResize { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowColumnResize As Boolean
Visual C++
public:
property bool AllowColumnResize {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AllowColumnsReorder Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.AllowColumnsReorder Property
RadGrid Class See Also Send Feedback
Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowColumnsReorder { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowColumnsReorder As Boolean
Visual C++
public:
property bool AllowColumnsReorder {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AllowMultiRowSelection Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.AllowMultiRowSelection Property
RadGrid Class See Also Send Feedback
Get whether the multi-row selection is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowMultiRowSelection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowMultiRowSelection As Boolean
Visual C++
public:
property bool AllowMultiRowSelection {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AllowRowResize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.AllowRowResize Property
RadGrid Class See Also Send Feedback
Get whether the row resizing is allowed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowRowResize { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowRowResize As Boolean
Visual C++
public:
property bool AllowRowResize {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AllowRowSelection Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.AllowRowSelection Property
RadGrid Class See Also Send Feedback
Get whether the client-side row selection is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowRowSelection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowRowSelection As Boolean
Visual C++
public:
property bool AllowRowSelection {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.ClientSideLocator Property
RadGrid Class See Also Send Feedback
The client-side locator of the RadGrid control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


ClipCellContentOnResize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.ClipCellContentOnResize Property
RadGrid Class See Also Send Feedback
Get whether the clip-cell-content-on-resize is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ClipCellContentOnResize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClipCellContentOnResize As Boolean
Visual C++
public:
property bool ClipCellContentOnResize {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


DetailTableCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.DetailTableCount Property
RadGrid Class See Also Send Feedback
Get the detail table levels of the Grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int DetailTableCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property DetailTableCount As Integer
Visual C++
public:
property int DetailTableCount {
    int get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


EnableDragToSelectRows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.EnableDragToSelectRows Property
RadGrid Class See Also Send Feedback
Get whether the drag-to-select option is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableDragToSelectRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnableDragToSelectRows As Boolean
Visual C++
public:
property bool EnableDragToSelectRows {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


EnableHeaderContextMenu Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.EnableHeaderContextMenu Property
RadGrid Class See Also Send Feedback
Get whether the header context menu is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableHeaderContextMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnableHeaderContextMenu As Boolean
Visual C++
public:
property bool EnableHeaderContextMenu {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


EnableRealTimeResize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.EnableRealTimeResize Property
RadGrid Class See Also Send Feedback
Get whether the real-time resizing is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableRealTimeResize { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnableRealTimeResize As Boolean
Visual C++
public:
property bool EnableRealTimeResize {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.GridFilterItem Property
RadGrid Class See Also Send Feedback
Get the FilterItem HtmlControl if fitering is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridFilterItem GridFilterItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property GridFilterItem As GridFilterItem
Visual C++
public:
property GridFilterItem^ GridFilterItem {
    GridFilterItem^ get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


GroupPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.GroupPanel Property
RadGrid Class See Also Send Feedback
Get the GroupPanel HtmlControl if RadGrid's GroupPanel is enabled or null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridGroupPanel GroupPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupPanel As GridGroupPanel
Visual C++
public:
property GridGroupPanel^ GroupPanel {
    GridGroupPanel^ get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.LocatorExpression Property
RadGrid Class See Also Send Feedback
Get the locator FindParam of the Grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


MasterTable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.MasterTable Property
RadGrid Class See Also Send Feedback
Get the Grid MasterTable.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridTableView MasterTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterTable As GridTableView
Visual C++
public:
property GridTableView^ MasterTable {
    GridTableView^ get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


Pager Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.Pager Property
RadGrid Class See Also Send Feedback
Get the Grid pager control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridPager Pager { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pager As GridPager
Visual C++
public:
property GridPager^ Pager {
    GridPager^ get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


ReorderColumnsOnClient Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.ReorderColumnsOnClient Property
RadGrid Class See Also Send Feedback
Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ReorderColumnsOnClient { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReorderColumnsOnClient As Boolean
Visual C++
public:
property bool ReorderColumnsOnClient {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


ResizeGridOnColumnResize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGrid..::.ResizeGridOnColumnResize Property
RadGrid Class See Also Send Feedback
Get whether the resize-grid-on-column-resizing is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ResizeGridOnColumnResize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResizeGridOnColumnResize As Boolean
Visual C++
public:
property bool ResizeGridOnColumnResize {
    bool get ();
}

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


RadInput Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Class
Members See Also Send Feedback
Represents the RadCalendar for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadInput : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadInput _
    Inherits HtmlContainerControl
Visual C++
public ref class RadInput : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInput
Telerik.WebAii.Controls.Html..::.RadDateInput
Telerik.WebAii.Controls.Html..::.RadMaskedTextBox
Telerik.WebAii.Controls.Html..::.RadNumericTextBox
Telerik.WebAii.Controls.Html..::.RadTextBox

See Also

RadInput Members
Telerik.WebAii.Controls.Html Namespace


RadInput Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Members
RadInput Class Constructors Methods Properties See Also Send Feedback

The RadInput type exposes the following members.

Constructors

Name | Description
RadInput | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page.
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Disable | Disables the input.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Overrides HtmlControl..::.Focus()()().)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input.
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control.
ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus.
EditValue | Get the value of the control as it is formatted when the control has focus.
EmptyMessage | Get or set the message that appears when the value is not set.
Enabled | Get whether the input is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.
InputValue | Get or set the client-side input value.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty.
IsReadOnly | Get whether the input is in read-only mode.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


RadInput Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Constructor
RadInput Class See Also Send Feedback

Overload List

Name | Description
RadInput()()() | Initializes a new instance of the RadInput class.
RadInput(Element) | Initializes a new instance of the RadInput class.

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


RadInput Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Constructor
RadInput Class See Also Send Feedback
Initializes a new instance of the RadInput class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadInput()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadInput()

See Also

RadInput Class
RadInput Overload
Telerik.WebAii.Controls.Html Namespace


RadInput Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Constructor (Element)
RadInput Class See Also Send Feedback
Initializes a new instance of the RadInput class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadInput(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadInput(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInput.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadInput Class
RadInput Overload
Telerik.WebAii.Controls.Html Namespace


RadInput Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Methods
RadInput Class See Also Send Feedback

The RadInput type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page.
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Disable | Disables the input.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Overrides HtmlControl..::.Focus()()().)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input.
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.AssignElement Method
RadInput Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Blur Method
RadInput Class See Also Send Feedback
Removes focus from the text box, moving it to the next control in the tab order of the page.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Blur()
Visual Basic (Declaration)
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.CallMethod Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Capture Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


Clear Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Clear Method
RadInput Class See Also Send Feedback
Sets the value of the text box to an empty string.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Click Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.ControlAssert Method
RadInput Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Disable Method
RadInput Class See Also Send Feedback
Disables the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.DragTo Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Enable Method
RadInput Class See Also Send Feedback
Enables the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Focus Method
RadInput Class See Also Send Feedback
Sets focus to the text box so that the user can edit its value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Focus()
Visual Basic (Declaration)
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.GetValue Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.InvokeEvent Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.MouseClick Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.MouseHover Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.ScrollToVisible Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


SelectAllText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.SelectAllText Method
RadInput Class See Also Send Feedback
Selects all the text of the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectAllText()
Visual Basic (Declaration)
Public Sub SelectAllText
Visual C++
public:
void SelectAllText()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


SelectText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.SelectText Method
RadInput Class See Also Send Feedback
Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectText(
    int start,
    int end
)
Visual Basic (Declaration)
Public Sub SelectText ( _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
void SelectText(
    int start,
    int end
)

Parameters

start
Type: System..::.Int32
The start index.
end
Type: System..::.Int32
The end index.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.SetValue Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.TypeText Method
RadInput Class See Also Send Feedback

Overload List

Name | Description
TypeText(String) | Types text into the input.
TypeText(String, Int32) | Types text into the input.

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.TypeText Method (String)
RadInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TypeText(
    string valueTyped
)
Visual Basic (Declaration)
Public Sub TypeText ( _
    valueTyped As String _
)
Visual C++
public:
void TypeText(
    String^ valueTyped
)

Parameters

valueTyped
Type: System..::.String
The text to be typed.

See Also

RadInput Class
TypeText Overload
Telerik.WebAii.Controls.Html Namespace


TypeText Method (String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.TypeText Method (String, Int32)
RadInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TypeText(
    string valueTyped,
    int keyPressTime
)
Visual Basic (Declaration)
Public Sub TypeText ( _
    valueTyped As String, _
    keyPressTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ valueTyped,
    int keyPressTime
)

Parameters

valueTyped
Type: System..::.String
The text to be typed.
keyPressTime
Type: System..::.Int32
The time for each keypress.

See Also

RadInput Class
TypeText Overload
Telerik.WebAii.Controls.Html Namespace


RadInput Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput Properties
RadInput Class See Also Send Feedback

The RadInput type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control.
ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus.
EditValue | Get the value of the control as it is formatted when the control has focus.
EmptyMessage | Get or set the message that appears when the value is not set.
Enabled | Get whether the input is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.
InputValue | Get or set the client-side input value.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty.
IsReadOnly | Get whether the input is in read-only mode.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


AutoPostBack Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.AutoPostBack Property
RadInput Class See Also Send Feedback
Get or set the auto postback enabled value of the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AutoPostBack { get; set; }
Visual Basic (Declaration)
Public Property AutoPostBack As Boolean
Visual C++
public:
property bool AutoPostBack {
    bool get ();
    void set (bool value);
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


CaretPosition Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.CaretPosition Property
RadInput Class See Also Send Feedback
Get or set the caret position of the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int CaretPosition { get; set; }
Visual Basic (Declaration)
Public Property CaretPosition As Integer
Visual C++
public:
property int CaretPosition {
    int get ();
    void set (int value);
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.ClientId Property
RadInput Class See Also Send Feedback
Get the client Id of the input control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.ClientSideLocator Property
RadInput Class See Also Send Feedback
Get the Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


DisplayValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.DisplayValue Property
RadInput Class See Also Send Feedback
Gets the value of the control as it is formatted when the control does not have focus.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DisplayValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayValue As String
Visual C++
public:
property String^ DisplayValue {
    String^ get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


EditValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.EditValue Property
RadInput Class See Also Send Feedback
Get the value of the control as it is formatted when the control has focus.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EditValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditValue As String
Visual C++
public:
property String^ EditValue {
    String^ get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


EmptyMessage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.EmptyMessage Property
RadInput Class See Also Send Feedback
Get or set the message that appears when the value is not set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EmptyMessage { get; set; }
Visual Basic (Declaration)
Public Property EmptyMessage As String
Visual C++
public:
property String^ EmptyMessage {
    String^ get ();
    void set (String^ value);
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.Enabled Property
RadInput Class See Also Send Feedback
Get whether the input is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


HiddenInput Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.HiddenInput Property
RadInput Class See Also Send Feedback
Gets the hiddent input element of RadInput.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected Element HiddenInput { get; }
Visual Basic (Declaration)
Protected ReadOnly Property HiddenInput As Element
Visual C++
protected:
property Element^ HiddenInput {
    Element^ get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


InputType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.InputType Property
RadInput Class See Also Send Feedback
Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadInputControlType InputType { get; internal set; }
Visual Basic (Declaration)
Public Property InputType As RadInputControlType
Visual C++
public:
property RadInputControlType InputType {
    RadInputControlType get ();
    void set (RadInputControlType value);
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


InputValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.InputValue Property
RadInput Class See Also Send Feedback
Get or set the client-side input value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string InputValue { get; set; }
Visual Basic (Declaration)
Public Property InputValue As String
Visual C++
public:
property String^ InputValue {
    String^ get ();
    void set (String^ value);
}

Return Value

The input value.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


IsEmpty Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.IsEmpty Property
RadInput Class See Also Send Feedback
Get whether the input is empty.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.IsReadOnly Property
RadInput Class See Also Send Feedback
Get whether the input is in read-only mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.LocatorExpression Property
RadInput Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


TextBoxValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInput..::.TextBoxValue Property
RadInput Class See Also Send Feedback
Gets the string that the user typed into the control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TextBoxValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBoxValue As String
Visual C++
public:
property String^ TextBoxValue {
    String^ get ();
}

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


RadInputControlType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputControlType Enumeration
See Also Send Feedback
Control type of the Input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum RadInputControlType
Visual Basic (Declaration)
Public Enumeration RadInputControlType
Visual C++
public enum class RadInputControlType

Members

Member name | Description
TextBox | The TextBox control type.
NumericTextBox | NumericTextBox control type.
DateInput | DateInput control type.
MaskedTextBox | MaskedTextBox control type.
InputManagerTextBox | RadInputManager enhanced textbox control type.

See Also

Telerik.WebAii.Controls.Html Namespace


RadInputManager Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager Class
Members See Also Send Feedback
Represents the RadInputManager for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadInputManager : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadInputManager _
    Inherits HtmlContainerControl
Visual C++
public ref class RadInputManager : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInputManager

See Also

RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


RadInputManager Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager Members
RadInputManager Class Constructors Methods Properties See Also Send Feedback

The RadInputManager type exposes the following members.

Constructors

Name | Description
RadInputManager | Initializes a new instance of the RadInputManager class.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


RadInputManager Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager Constructor
RadInputManager Class See Also Send Feedback
Initializes a new instance of the RadInputManager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadInputManager(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadInputManager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInputManager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


RadInputManager Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager Methods
RadInputManager Class See Also Send Feedback

The RadInputManager type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.CallMethod Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.Capture Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.Click Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.DragTo Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.GetValue Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.InvokeEvent Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.MouseClick Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.MouseHover Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.ScrollToVisible Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.SetValue Method
RadInputManager Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


RadInputManager Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager Properties
RadInputManager Class See Also Send Feedback

The RadInputManager type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManager..::.LocatorExpression Property
RadInputManager Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Class
Members See Also Send Feedback
Represents the TextBox extended with RadInputManager for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadInputManagerTextBox : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadInputManagerTextBox _
    Inherits HtmlContainerControl
Visual C++
public ref class RadInputManagerTextBox : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInputManagerTextBox

See Also

RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Members
RadInputManagerTextBox Class Constructors Methods Properties See Also Send Feedback

The RadInputManagerTextBox type exposes the following members.

Constructors

Name | Description
RadInputManagerTextBox | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputValue | Get or set the client-side input value.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the Text of the Input.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Constructor
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
RadInputManagerTextBox()()() | Initializes a new instance of the RadInputManagerTextBox class.
RadInputManagerTextBox(Element) | Initializes a new instance of the RadInputManagerTextBox class.

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Constructor
RadInputManagerTextBox Class See Also Send Feedback
Initializes a new instance of the RadInputManagerTextBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadInputManagerTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadInputManagerTextBox()

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Overload
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Constructor (Element)
RadInputManagerTextBox Class See Also Send Feedback
Initializes a new instance of the RadInputManagerTextBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadInputManagerTextBox(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadInputManagerTextBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInputManagerTextBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Overload
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Methods
RadInputManagerTextBox Class See Also Send Feedback

The RadInputManagerTextBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.AssignElement Method
RadInputManagerTextBox Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.CallMethod Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.Capture Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.Click Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.DragTo Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.GetValue Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.InvokeEvent Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.MouseClick Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.MouseHover Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.ScrollToVisible Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.SetValue Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox Properties
RadInputManagerTextBox Class See Also Send Feedback

The RadInputManagerTextBox type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputValue | Get or set the client-side input value.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the Text of the Input.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.ClientSideLocator Property
RadInputManagerTextBox Class See Also Send Feedback
Get the Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


InputValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.InputValue Property
RadInputManagerTextBox Class See Also Send Feedback
Get or set the client-side input value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string InputValue { get; set; }
Visual Basic (Declaration)
Public Property InputValue As String
Visual C++
public:
property String^ InputValue {
    String^ get ();
    void set (String^ value);
}

Return Value

The input value.

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.LocatorExpression Property
RadInputManagerTextBox Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadInputManagerTextBox..::.Text Property
RadInputManagerTextBox Class See Also Send Feedback
Get or set the Text of the Input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Class
Members See Also Send Feedback
Represents the RadListBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadListBox : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadListBox _
    Inherits HtmlContainerControl
Visual C++
public ref class RadListBox : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadListBox

See Also

RadListBox Members
Telerik.WebAii.Controls.Html Namespace


RadListBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Members
RadListBox Class Constructors Methods Properties See Also Send Feedback

The RadListBox type exposes the following members.

Constructors

Name | Description
RadListBox | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadListBox control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Delete | Click the delete button.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItems | Get a list of items matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
MoveDown | Click the move down button.
MoveUp | Click the move up button.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TransferAllFrom | Click the transfer all from button.
TransferAllTo | Click the transfer all to button.
TransferFrom | Click the transfer from button.
TransferTo | Click the transfer to button.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllowTransferOnDoubleClick | Get the value of the AllowTransferOnDoubleClick property.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get whether Listbox AutoPostBack is enabled.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonPosition | ListBox button position.
CheckBoxesEnabled | Get whether the ListBox check box support is enabled.
CheckedItems | Gets a list of the checked items.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DeleteButton | The delete button.
ElementOffsetWidth | Get the offset width of the Listbox element.
Enabled | Get whether Listbox is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of items.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MoveDownButton | The move down button.
MoveUpButton | The move up button.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets the selected index of the RadListBox. Returns '-1' if there is no selected item.
SelectedItems | Gets a list of the selected items.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TransferAllFromButton | The transfer all from button.
TransferAllToButton | The transfer all to button.
TransferFromButton | The transfer from button.
TransferToButton | The transfer to button.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBox Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Constructor
RadListBox Class See Also Send Feedback

Overload List

Name | Description
RadListBox()()() | Initializes a new instance of the RadListBox class.
RadListBox(Element) | Initializes a new instance of the RadListBox class.

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


RadListBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Constructor
RadListBox Class See Also Send Feedback
Initializes a new instance of the RadListBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadListBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadListBox()

See Also

RadListBox Class
RadListBox Overload
Telerik.WebAii.Controls.Html Namespace


RadListBox Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Constructor (Element)
RadListBox Class See Also Send Feedback
Initializes a new instance of the RadListBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadListBox(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadListBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBox Class
RadListBox Overload
Telerik.WebAii.Controls.Html Namespace


RadListBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Methods
RadListBox Class See Also Send Feedback

The RadListBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadListBox control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control.
Delete | Click the delete button.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItems | Get a list of items matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
MoveDown | Click the move down button.
MoveUp | Click the move up button.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TransferAllFrom | Click the transfer all from button.
TransferAllTo | Click the transfer all to button.
TransferFrom | Click the transfer from button.
TransferTo | Click the transfer to button.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.AssignElement Method
RadListBox Class See Also Send Feedback
Assign the DOM element to be the RadListBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBox.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.CallMethod Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.Capture Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.Click Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.ControlAssert Method
RadListBox Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


Delete Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.Delete Method
RadListBox Class See Also Send Feedback
Click the delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.DragTo Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.FindItems Method
RadListBox Class See Also Send Feedback
Get a list of items matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadListBoxItem> FindItems(
    Predicate<RadListBoxItem> predicate
)
Visual Basic (Declaration)
Public Function FindItems ( _
    predicate As Predicate(Of RadListBoxItem) _
) As IList(Of RadListBoxItem)
Visual C++
public:
IList<RadListBoxItem^>^ FindItems(
    Predicate<RadListBoxItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadListBoxItem >)>)
The predicate, i.e. (item => item.Text == myText).

Return Value

The items matching the given predicate.

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.GetValue Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.InvokeEvent Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.MouseClick Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.MouseHover Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


MoveDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.MoveDown Method
RadListBox Class See Also Send Feedback
Click the move down button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveDown()
Visual Basic (Declaration)
Public Sub MoveDown
Visual C++
public:
void MoveDown()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


MoveUp Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.MoveUp Method
RadListBox Class See Also Send Feedback
Click the move up button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveUp()
Visual Basic (Declaration)
Public Sub MoveUp
Visual C++
public:
void MoveUp()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.ScrollToVisible Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.SetValue Method
RadListBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


TransferAllFrom Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferAllFrom Method
RadListBox Class See Also Send Feedback
Click the transfer all from button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TransferAllFrom()
Visual Basic (Declaration)
Public Sub TransferAllFrom
Visual C++
public:
void TransferAllFrom()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferAllTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferAllTo Method
RadListBox Class See Also Send Feedback
Click the transfer all to button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TransferAllTo()
Visual Basic (Declaration)
Public Sub TransferAllTo
Visual C++
public:
void TransferAllTo()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferFrom Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferFrom Method
RadListBox Class See Also Send Feedback
Click the transfer from button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TransferFrom()
Visual Basic (Declaration)
Public Sub TransferFrom
Visual C++
public:
void TransferFrom()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferTo Method
RadListBox Class See Also Send Feedback
Click the transfer to button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TransferTo()
Visual Basic (Declaration)
Public Sub TransferTo
Visual C++
public:
void TransferTo()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox Properties
RadListBox Class See Also Send Feedback

The RadListBox type exposes the following members.

Properties

Name | Description
AllowTransferOnDoubleClick | Get the value of the AllowTransferOnDoubleClick property.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get whether Listbox AutoPostBack is enabled.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonPosition | ListBox button position.
CheckBoxesEnabled | Get whether the ListBox check box support is enabled.
CheckedItems | Gets a list of the checked items.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DeleteButton | The delete button.
ElementOffsetWidth | Get the offset width of the Listbox element.
Enabled | Get whether Listbox is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of items.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MoveDownButton | The move down button.
MoveUpButton | The move up button.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedIndex | Gets the selected index of the RadListBox. Returns '-1' if there is no selected item.
SelectedItems | Gets a list of the selected items.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TransferAllFromButton | The transfer all from button.
TransferAllToButton | The transfer all to button.
TransferFromButton | The transfer from button.
TransferToButton | The transfer to button.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


AllowTransferOnDoubleClick Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.AllowTransferOnDoubleClick Property
RadListBox Class See Also Send Feedback
Get the value of the AllowTransferOnDoubleClick property.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowTransferOnDoubleClick { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowTransferOnDoubleClick As Boolean
Visual C++
public:
property bool AllowTransferOnDoubleClick {
    bool get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


AutoPostBack Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.AutoPostBack Property
RadListBox Class See Also Send Feedback
Get whether Listbox AutoPostBack is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AutoPostBack { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoPostBack As Boolean
Visual C++
public:
property bool AutoPostBack {
    bool get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


ButtonPosition Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.ButtonPosition Property
RadListBox Class See Also Send Feedback
ListBox button position.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ListBoxButtonPosition ButtonPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property ButtonPosition As ListBoxButtonPosition
Visual C++
public:
property ListBoxButtonPosition ButtonPosition {
    ListBoxButtonPosition get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


CheckBoxesEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.CheckBoxesEnabled Property
RadListBox Class See Also Send Feedback
Get whether the ListBox check box support is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CheckBoxesEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckBoxesEnabled As Boolean
Visual C++
public:
property bool CheckBoxesEnabled {
    bool get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


CheckedItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.CheckedItems Property
RadListBox Class See Also Send Feedback
Gets a list of the checked items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadListBoxItem> CheckedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedItems As IList(Of RadListBoxItem)
Visual C++
public:
property IList<RadListBoxItem^>^ CheckedItems {
    IList<RadListBoxItem^>^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.ClientSideLocator Property
RadListBox Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


DeleteButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.DeleteButton Property
RadListBox Class See Also Send Feedback
The delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor DeleteButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeleteButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ DeleteButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


ElementOffsetWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.ElementOffsetWidth Property
RadListBox Class See Also Send Feedback
Get the offset width of the Listbox element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ElementOffsetWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElementOffsetWidth As Integer
Visual C++
public:
property int ElementOffsetWidth {
    int get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.Enabled Property
RadListBox Class See Also Send Feedback
Get whether Listbox is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.Items Property
RadListBox Class See Also Send Feedback
Get the list of items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadListBoxItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadListBoxItem)
Visual C++
public:
property IList<RadListBoxItem^>^ Items {
    IList<RadListBoxItem^>^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.LocatorExpression Property
RadListBox Class See Also Send Feedback
Get the FindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


MoveDownButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.MoveDownButton Property
RadListBox Class See Also Send Feedback
The move down button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor MoveDownButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveDownButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ MoveDownButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


MoveUpButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.MoveUpButton Property
RadListBox Class See Also Send Feedback
The move up button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor MoveUpButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveUpButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ MoveUpButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


SelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.SelectedIndex Property
RadListBox Class See Also Send Feedback
Gets the selected index of the RadListBox. Returns '-1' if there is no selected item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectedIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


SelectedItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.SelectedItems Property
RadListBox Class See Also Send Feedback
Gets a list of the selected items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadListBoxItem> SelectedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItems As IList(Of RadListBoxItem)
Visual C++
public:
property IList<RadListBoxItem^>^ SelectedItems {
    IList<RadListBoxItem^>^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferAllFromButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferAllFromButton Property
RadListBox Class See Also Send Feedback
The transfer all from button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor TransferAllFromButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransferAllFromButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ TransferAllFromButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferAllToButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferAllToButton Property
RadListBox Class See Also Send Feedback
The transfer all to button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor TransferAllToButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransferAllToButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ TransferAllToButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferFromButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferFromButton Property
RadListBox Class See Also Send Feedback
The transfer from button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor TransferFromButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransferFromButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ TransferFromButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferToButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBox..::.TransferToButton Property
RadListBox Class See Also Send Feedback
The transfer to button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor TransferToButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransferToButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ TransferToButton {
    HtmlAnchor^ get ();
}

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Class
Members See Also Send Feedback
Represents the RadListBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadListBoxItem : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadListBoxItem _
    Inherits HtmlContainerControl
Visual C++
public ref class RadListBoxItem : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadListBoxItem

See Also

RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Members
RadListBoxItem Class Constructors Methods Properties See Also Send Feedback

The RadListBoxItem type exposes the following members.

Constructors

Name | Description
RadListBoxItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadListBoxItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Check | Check the item.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the item.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragAndDropTo | Drag and drop the item to the specified control. Drops into the center of the element.
DragAndDropWithOffset | Drag and drop the item with the specified x and y offset.
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the item.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UNCheck | UNCheck the item.
UNSelect | Unselect the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllowDrag | Returns/sets the AllowDrag property.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Checkable | Get whether the item contains check box so that it can be checked.
Checked | Check/set whether the item is checked.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the List item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
ImageUrl | Gets the value of the ImageUrl property.
Index | Get the List item index.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemValue | Get or set the value for this item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression that defines the pattern for a listbox item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Check/set whether the item is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text for this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Gets the tooltip of the item.
Visible | Get whether the List item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Constructor
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
RadListBoxItem()()() | Initializes a new instance of the RadListBoxItem class.
RadListBoxItem(Element) | Initializes a new instance of the RadListBoxItem class.

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Constructor
RadListBoxItem Class See Also Send Feedback
Initializes a new instance of the RadListBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadListBoxItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadListBoxItem()

See Also

RadListBoxItem Class
RadListBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Constructor (Element)
RadListBoxItem Class See Also Send Feedback
Initializes a new instance of the RadListBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadListBoxItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadListBoxItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBoxItem Class
RadListBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Methods
RadListBoxItem Class See Also Send Feedback

The RadListBoxItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadListBoxItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Check | Check the item.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the item.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragAndDropTo | Drag and drop the item to the specified control. Drops into the center of the element.
DragAndDropWithOffset | Drag and drop the item with the specified x and y offset.
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the item.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UNCheck | UNCheck the item.
UNSelect | Unselect the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.AssignElement Method
RadListBoxItem Class See Also Send Feedback
Assign the DOM element to be the RadListBoxItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.CallMethod Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Capture Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Check Method
RadListBoxItem Class See Also Send Feedback
Check the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Check()
Visual Basic (Declaration)
Public Sub Check
Visual C++
public:
void Check()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Click Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.ControlAssert Method
RadListBoxItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Disable Method
RadListBoxItem Class See Also Send Feedback
Disables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.DragAndDropTo Method
RadListBoxItem Class See Also Send Feedback
Drag and drop the item to the specified control. Drops into the center of the element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAndDropTo(
    HtmlControl destination
)
Visual Basic (Declaration)
Public Sub DragAndDropTo ( _
    destination As HtmlControl _
)
Visual C++
public:
void DragAndDropTo(
    HtmlControl^ destination
)

Parameters

destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
The destination control.

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragAndDropWithOffset Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.DragAndDropWithOffset Method
RadListBoxItem Class See Also Send Feedback
Drag and drop the item with the specified x and y offset.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)
Visual Basic (Declaration)
Public Sub DragAndDropWithOffset ( _
    offsetX As Integer, _
    offsetY As Integer _
)
Visual C++
public:
void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)

Parameters

offsetX
Type: System..::.Int32

[Missing <param name="offsetX"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.DragAndDropWithOffset(System.Int32,System.Int32)"]

offsetY
Type: System..::.Int32

[Missing <param name="offsetY"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.DragAndDropWithOffset(System.Int32,System.Int32)"]

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.DragTo Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Enable Method
RadListBoxItem Class See Also Send Feedback
Enables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.GetValue Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.InvokeEvent Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.MouseClick Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.MouseHover Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.ScrollToVisible Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Select Method
RadListBoxItem Class See Also Send Feedback
Select the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.SetValue Method
RadListBoxItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


UNCheck Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.UNCheck Method
RadListBoxItem Class See Also Send Feedback
UNCheck the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UNCheck()
Visual Basic (Declaration)
Public Sub UNCheck
Visual C++
public:
void UNCheck()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


UNSelect Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.UNSelect Method
RadListBoxItem Class See Also Send Feedback
Unselect the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UNSelect()
Visual Basic (Declaration)
Public Sub UNSelect
Visual C++
public:
void UNSelect()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem Properties
RadListBoxItem Class See Also Send Feedback

The RadListBoxItem type exposes the following members.

Properties

Name | Description
AllowDrag | Returns/sets the AllowDrag property.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Checkable | Get whether the item contains check box so that it can be checked.
Checked | Check/set whether the item is checked.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the List item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
ImageUrl | Gets the value of the ImageUrl property.
Index | Get the List item index.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
ItemValue | Get or set the value for this item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression that defines the pattern for a listbox item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Check/set whether the item is selected.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text for this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Gets the tooltip of the item.
Visible | Get whether the List item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


AllowDrag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.AllowDrag Property
RadListBoxItem Class See Also Send Feedback
Returns/sets the AllowDrag property.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowDrag { get; set; }
Visual Basic (Declaration)
Public Property AllowDrag As Boolean
Visual C++
public:
property bool AllowDrag {
    bool get ();
    void set (bool value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Checkable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Checkable Property
RadListBoxItem Class See Also Send Feedback
Get whether the item contains check box so that it can be checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Checkable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Checkable As Boolean
Visual C++
public:
property bool Checkable {
    bool get ();
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Checked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Checked Property
RadListBoxItem Class See Also Send Feedback
Check/set whether the item is checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.ClientSideLocator Property
RadListBoxItem Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Enabled Property
RadListBoxItem Class See Also Send Feedback
Get whether the List item is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


ImageUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.ImageUrl Property
RadListBoxItem Class See Also Send Feedback
Gets the value of the ImageUrl property.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ImageUrl { get; set; }
Visual Basic (Declaration)
Public Property ImageUrl As String
Visual C++
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Index Property
RadListBoxItem Class See Also Send Feedback
Get the List item index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


ItemValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.ItemValue Property
RadListBoxItem Class See Also Send Feedback
Get or set the value for this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemValue { get; set; }
Visual Basic (Declaration)
Public Property ItemValue As String
Visual C++
public:
property String^ ItemValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.LocatorExpression Property
RadListBoxItem Class See Also Send Feedback
Get the FindExpression that defines the pattern for a listbox item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Selected Property
RadListBoxItem Class See Also Send Feedback
Check/set whether the item is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; set; }
Visual Basic (Declaration)
Public Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Text Property
RadListBoxItem Class See Also Send Feedback
Get or set the text for this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


ToolTip Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.ToolTip Property
RadListBoxItem Class See Also Send Feedback
Gets the tooltip of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListBoxItem..::.Visible Property
RadListBoxItem Class See Also Send Feedback
Get whether the List item is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadListView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Class
Members See Also Send Feedback
Represents RadListView for Asp.Net Ajax control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadListView : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadListView _
    Inherits HtmlContainerControl
Visual C++
public ref class RadListView : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadListView

See Also

RadListView Members
Telerik.WebAii.Controls.Html Namespace


RadListView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Members
RadListView Class Constructors Methods Properties See Also Send Feedback

The RadListView type exposes the following members.

Constructors

Name | Description
RadListView | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of the ListView.
ClientObjectElement | Get the span element which holds the client-side object of the ListView.
ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentLayout | Get the layout type of the ListView.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | Get the page count of the ListView.
PageSize | Get the page size of the ListView.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


RadListView Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Constructor
RadListView Class See Also Send Feedback

Overload List

Name | Description
RadListView()()() | Initializes a new instance of the RadListView class.
RadListView(Element) | Initializes a new instance of the RadListView class.

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


RadListView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Constructor
RadListView Class See Also Send Feedback
Initializes a new instance of the RadListView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadListView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadListView()

See Also

RadListView Class
RadListView Overload
Telerik.WebAii.Controls.Html Namespace


RadListView Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Constructor (Element)
RadListView Class See Also Send Feedback
Initializes a new instance of the RadListView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadListView(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadListView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListView Class
RadListView Overload
Telerik.WebAii.Controls.Html Namespace


RadListView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Methods
RadListView Class See Also Send Feedback

The RadListView type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.AssignElement Method
RadListView Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.CallMethod Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.Capture Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.Click Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.DragTo Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.GetValue Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.InvokeEvent Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.MouseClick Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.MouseHover Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.ScrollToVisible Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.SetValue Method
RadListView Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


RadListView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView Properties
RadListView Class See Also Send Feedback

The RadListView type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of the ListView.
ClientObjectElement | Get the span element which holds the client-side object of the ListView.
ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentLayout | Get the layout type of the ListView.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PageCount | Get the page count of the ListView.
PageSize | Get the page size of the ListView.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.ClientId Property
RadListView Class See Also Send Feedback
The client id of the ListView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


ClientObjectElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.ClientObjectElement Property
RadListView Class See Also Send Feedback
Get the span element which holds the client-side object of the ListView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected HtmlSpan ClientObjectElement { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ClientObjectElement As HtmlSpan
Visual C++
protected:
property HtmlSpan^ ClientObjectElement {
    HtmlSpan^ get ();
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.ClientSideLocator Property
RadListView Class See Also Send Feedback
The client-side locator of the RadCalendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


CurrentLayout Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.CurrentLayout Property
RadListView Class See Also Send Feedback
Get the layout type of the ListView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PredefinedLayoutType CurrentLayout { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentLayout As PredefinedLayoutType
Visual C++
public:
property PredefinedLayoutType CurrentLayout {
    PredefinedLayoutType get ();
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.LocatorExpression Property
RadListView Class See Also Send Feedback
Get the item locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


PageCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.PageCount Property
RadListView Class See Also Send Feedback
Get the page count of the ListView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


PageSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadListView..::.PageSize Property
RadListView Class See Also Send Feedback
Get the page size of the ListView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As Integer
Visual C++
public:
property int PageSize {
    int get ();
}

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Class
Members See Also Send Feedback
Represents the RadMaskedTextBox for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMaskedTextBox : RadInput
Visual Basic (Declaration)
Public Class RadMaskedTextBox _
    Inherits RadInput
Visual C++
public ref class RadMaskedTextBox : public RadInput

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInput
Telerik.WebAii.Controls.Html..::.RadMaskedTextBox

See Also

RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Members
RadMaskedTextBox Class Constructors Methods Properties See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Constructors

Name | Description
RadMaskedTextBox | Initializes a new instance of the RadMaskedTextBox class

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllowEmptyEnumerations | Get or set whether enumerated mask parts can be set to an empty string.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
HideOnBlur | Get or set whether the prompt characters and literals are not displayed when the text box is empty and does not have focus.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsMultiline | Get whether the text mode is MultiLine.
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ValueWithLiterals | Get the value of the text box, including the literal characters from the mask.
ValueWithPromptAndLiterals | Get the value of the text box, including the prompt characters and literal characters from the mask.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Constructor
RadMaskedTextBox Class See Also Send Feedback
Initializes a new instance of the RadMaskedTextBox class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMaskedTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMaskedTextBox()

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Methods
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.CallMethod Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.Capture Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.Click Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.DragTo Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.GetValue Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.InvokeEvent Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.MouseClick Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.MouseHover Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.ScrollToVisible Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.SetValue Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.TypeText Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
TypeText(String) | Types text into the input. (Inherited from RadInput.)
TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Properties
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Properties

Name | Description
AllowEmptyEnumerations | Get or set whether enumerated mask parts can be set to an empty string.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
HideOnBlur | Get or set whether the prompt characters and literals are not displayed when the text box is empty and does not have focus.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsMultiline | Get whether the text mode is MultiLine.
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ValueWithLiterals | Get the value of the text box, including the literal characters from the mask.
ValueWithPromptAndLiterals | Get the value of the text box, including the prompt characters and literal characters from the mask.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


AllowEmptyEnumerations Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.AllowEmptyEnumerations Property
RadMaskedTextBox Class See Also Send Feedback
Get or set whether enumerated mask parts can be set to an empty string.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowEmptyEnumerations { get; set; }
Visual Basic (Declaration)
Public Property AllowEmptyEnumerations As Boolean
Visual C++
public:
property bool AllowEmptyEnumerations {
    bool get ();
    void set (bool value);
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


HideOnBlur Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.HideOnBlur Property
RadMaskedTextBox Class See Also Send Feedback
Get or set whether the prompt characters and literals are not displayed when the text box is empty and does not have focus.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HideOnBlur { get; set; }
Visual Basic (Declaration)
Public Property HideOnBlur As Boolean
Visual C++
public:
property bool HideOnBlur {
    bool get ();
    void set (bool value);
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


IsMultiline Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.IsMultiline Property
RadMaskedTextBox Class See Also Send Feedback
Get whether the text mode is MultiLine.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMultiline { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMultiline As Boolean
Visual C++
public:
property bool IsMultiline {
    bool get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


ValueWithLiterals Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.ValueWithLiterals Property
RadMaskedTextBox Class See Also Send Feedback
Get the value of the text box, including the literal characters from the mask.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ValueWithLiterals { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueWithLiterals As String
Visual C++
public:
property String^ ValueWithLiterals {
    String^ get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


ValueWithPromptAndLiterals Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.ValueWithPromptAndLiterals Property
RadMaskedTextBox Class See Also Send Feedback
Get the value of the text box, including the prompt characters and literal characters from the mask.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ValueWithPromptAndLiterals { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueWithPromptAndLiterals As String
Visual C++
public:
property String^ ValueWithPromptAndLiterals {
    String^ get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadMenu Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Class
Members See Also Send Feedback
Represents the RadMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMenu : HtmlDiv
Visual Basic (Declaration)
Public Class RadMenu _
    Inherits HtmlDiv
Visual C++
public ref class RadMenu : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadMenu

See Also

RadMenu Members
Telerik.WebAii.Controls.Html Namespace


RadMenu Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Members
RadMenu Class Constructors Methods Properties See Also Send Feedback

The RadMenu type exposes the following members.

Constructors

Name | Description
RadMenu | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the Menu control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Closes all opened items from the menu.
ControlAssert | Get the RadControlInstance initialized for this control.
Disable | Disables all items in the menu. Clicking on any item has no effect, child items cannot be opened.
DisableEvents | Disables the control client-side event emitting.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables all items in the menu.
EnableEvents | Enables the control client-side event emitting. Events are enabled by default.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindItems | Get the list of the items find by given predicate.
FindItemsByLevel | Get the list of items by given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Brings the focus to the menu so that it can be controlled via the keyboard. (Overrides HtmlControl..::.Focus()()().)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeItems | Initializes all menu items.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllItems | Get all the Menu items.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Clicked | True if the user has clicked on a root menu item to expand it when ClickToOpen is True.
ClickToOpen | Get whether the menu ClickToOpen property is set to true.
ClientId | The client ID of this Menu control.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the menu is enabled.
EnableRootItemScroll | True if the menu EnableRootItemScroll property is true.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedItem | Returns the focused root level item. Null if no item has focus.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsGridFilteringMenu | Get whether the menu is a context menu as RadGrid filtering menu.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OpenedItem | Returns the opened root level item. If no item is opened at the root level returns null.
OrientationType | Menu orientation.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootItems | Get the list of the root items.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


RadMenu Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Constructor
RadMenu Class See Also Send Feedback

Overload List

Name | Description
RadMenu()()() | Initializes a new instance of the RadMenu class.
RadMenu(Element) | Initializes a new instance of the RadMenu class.

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


RadMenu Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Constructor
RadMenu Class See Also Send Feedback
Initializes a new instance of the RadMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenu()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMenu()

See Also

RadMenu Class
RadMenu Overload
Telerik.WebAii.Controls.Html Namespace


RadMenu Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Constructor (Element)
RadMenu Class See Also Send Feedback
Initializes a new instance of the RadMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenu(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadMenu(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenu Class
RadMenu Overload
Telerik.WebAii.Controls.Html Namespace


RadMenu Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Methods
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the Menu control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Closes all opened items from the menu.
ControlAssert | Get the RadControlInstance initialized for this control.
Disable | Disables all items in the menu. Clicking on any item has no effect, child items cannot be opened.
DisableEvents | Disables the control client-side event emitting.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables all items in the menu.
EnableEvents | Enables the control client-side event emitting. Events are enabled by default.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindItems | Get the list of the items find by given predicate.
FindItemsByLevel | Get the list of items by given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Brings the focus to the menu so that it can be controlled via the keyboard. (Overrides HtmlControl..::.Focus()()().)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeItems | Initializes all menu items.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.AssignElement Method
RadMenu Class See Also Send Feedback
Assign the DOM element to be the Menu control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.CallMethod Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Capture Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Click Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Close Method
RadMenu Class See Also Send Feedback
Closes all opened items from the menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.ControlAssert Method
RadMenu Class See Also Send Feedback
Get the RadControlInstance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.ControlAssert"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Disable Method
RadMenu Class See Also Send Feedback
Disables all items in the menu. Clicking on any item has no effect, child items cannot be opened.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


DisableEvents Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.DisableEvents Method
RadMenu Class See Also Send Feedback
Disables the control client-side event emitting.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DisableEvents()
Visual Basic (Declaration)
Public Sub DisableEvents
Visual C++
public:
void DisableEvents()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.DragTo Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Enable Method
RadMenu Class See Also Send Feedback
Enables all items in the menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


EnableEvents Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.EnableEvents Method
RadMenu Class See Also Send Feedback
Enables the control client-side event emitting. Events are enabled by default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void EnableEvents()
Visual Basic (Declaration)
Public Sub EnableEvents
Visual C++
public:
void EnableEvents()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.FindItem Method
RadMenu Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FindItem(
    Predicate<RadMenuItem> predicate
)
Visual Basic (Declaration)
Public Function FindItem ( _
    predicate As Predicate(Of RadMenuItem) _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItem(
    Predicate<RadMenuItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadMenuItem >)>)
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.FindItemByText Method
RadMenu Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FindItemByText(
    string itemText
)
Visual Basic (Declaration)
Public Function FindItemByText ( _
    itemText As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::.String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByText(System.String)"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.FindItemByValue Method
RadMenu Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FindItemByValue(
    string itemValue
)
Visual Basic (Declaration)
Public Function FindItemByValue ( _
    itemValue As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::.String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByValue(System.String)"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.FindItems Method
RadMenu Class See Also Send Feedback
Get the list of the items find by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> FindItems(
    Predicate<RadMenuItem> predicate
)
Visual Basic (Declaration)
Public Function FindItems ( _
    predicate As Predicate(Of RadMenuItem) _
) As IList(Of RadMenuItem)
Visual C++
public:
IList<RadMenuItem^>^ FindItems(
    Predicate<RadMenuItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadMenuItem >)>)
The predicate used for search criteria.

Return Value

The list of the root items.

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItemsByLevel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.FindItemsByLevel Method
RadMenu Class See Also Send Feedback
Get the list of items by given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> FindItemsByLevel(
    int level
)
Visual Basic (Declaration)
Public Function FindItemsByLevel ( _
    level As Integer _
) As IList(Of RadMenuItem)
Visual C++
public:
IList<RadMenuItem^>^ FindItemsByLevel(
    int level
)

Parameters

level
Type: System..::.Int32
The level to search for.

Return Value

The list of items by the given level.

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Focus Method
RadMenu Class See Also Send Feedback
Brings the focus to the menu so that it can be controlled via the keyboard.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Focus()
Visual Basic (Declaration)
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.GetValue Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


InitializeItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.InitializeItems Method
RadMenu Class See Also Send Feedback
Initializes all menu items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InitializeItems()
Visual Basic (Declaration)
Public Sub InitializeItems
Visual C++
public:
void InitializeItems()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.InvokeEvent Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.MouseClick Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.MouseHover Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.ScrollToVisible Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.SetValue Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


RadMenu Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Properties
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Properties

Name | Description
AllItems | Get all the Menu items.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Clicked | True if the user has clicked on a root menu item to expand it when ClickToOpen is True.
ClickToOpen | Get whether the menu ClickToOpen property is set to true.
ClientId | The client ID of this Menu control.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the menu is enabled.
EnableRootItemScroll | True if the menu EnableRootItemScroll property is true.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedItem | Returns the focused root level item. Null if no item has focus.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsGridFilteringMenu | Get whether the menu is a context menu as RadGrid filtering menu.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OpenedItem | Returns the opened root level item. If no item is opened at the root level returns null.
OrientationType | Menu orientation.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootItems | Get the list of the root items.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


AllItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.AllItems Property
RadMenu Class See Also Send Feedback
Get all the Menu items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> AllItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllItems As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ AllItems {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


Clicked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Clicked Property
RadMenu Class See Also Send Feedback
True if the user has clicked on a root menu item to expand it when ClickToOpen is True.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Clicked { get; set; }
Visual Basic (Declaration)
Public Property Clicked As Boolean
Visual C++
public:
property bool Clicked {
    bool get ();
    void set (bool value);
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


ClickToOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.ClickToOpen Property
RadMenu Class See Also Send Feedback
Get whether the menu ClickToOpen property is set to true.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ClickToOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClickToOpen As Boolean
Visual C++
public:
property bool ClickToOpen {
    bool get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.ClientId Property
RadMenu Class See Also Send Feedback
The client ID of this Menu control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.ClientSideLocator Property
RadMenu Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Enabled Property
RadMenu Class See Also Send Feedback
Get whether the menu is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


EnableRootItemScroll Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.EnableRootItemScroll Property
RadMenu Class See Also Send Feedback
True if the menu EnableRootItemScroll property is true.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnableRootItemScroll { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnableRootItemScroll As Boolean
Visual C++
public:
property bool EnableRootItemScroll {
    bool get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FocusedItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.FocusedItem Property
RadMenu Class See Also Send Feedback
Returns the focused root level item. Null if no item has focus.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FocusedItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FocusedItem As RadMenuItem
Visual C++
public:
property RadMenuItem^ FocusedItem {
    RadMenuItem^ get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


IsGridFilteringMenu Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.IsGridFilteringMenu Property
RadMenu Class See Also Send Feedback
Get whether the menu is a context menu as RadGrid filtering menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsGridFilteringMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsGridFilteringMenu As Boolean
Visual C++
public:
property bool IsGridFilteringMenu {
    bool get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.LocatorExpression Property
RadMenu Class See Also Send Feedback
Get the FindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


OpenedItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.OpenedItem Property
RadMenu Class See Also Send Feedback
Returns the opened root level item. If no item is opened at the root level returns null.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem OpenedItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property OpenedItem As RadMenuItem
Visual C++
public:
property RadMenuItem^ OpenedItem {
    RadMenuItem^ get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


OrientationType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.OrientationType Property
RadMenu Class See Also Send Feedback
Menu orientation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public MenuOrientationType OrientationType { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrientationType As MenuOrientationType
Visual C++
public:
property MenuOrientationType OrientationType {
    MenuOrientationType get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


RootItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.RootItems Property
RadMenu Class See Also Send Feedback
Get the list of the root items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> RootItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootItems As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ RootItems {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Class
Members See Also Send Feedback
Represents the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMenuItem : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadMenuItem _
    Inherits HtmlContainerControl
Visual C++
public ref class RadMenuItem : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadMenuItem

See Also

RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Members
RadMenuItem Class Constructors Methods Properties See Also Send Feedback

The RadMenuItem type exposes the following members.

Constructors

Name | Description
RadMenuItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadMenuItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Closes a item.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the item. (Overrides HtmlControl..::.Focus()()().)
FocusFirstChild | Moves focus to the first child of the item.
FocusLastChild | Moves focus to the last child of the item.
FocusNextItem | Moves focus to the next item.
FocusPreviousItem | Moves focus to the previous item.
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Open | Opens the item.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator used in most of the properties. Returns 'null' for item separators. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether the menu item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get or set whether this item is focused.
HasChildren | Check whether the item has children.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the item.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Returns the list of child items of this menu item.
ItemValue | Get or set the value for this item.
Level | Get the level of the item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this item.
Opened | Get whether this item is opened.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShouldNavigate | Check whether the item should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text of this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Constructor
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
RadMenuItem()()() | Initializes a new instance of the RadMenuItem class.
RadMenuItem(Element) | Initializes a new instance of the RadMenuItem class.

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Constructor
RadMenuItem Class See Also Send Feedback
Initializes a new instance of the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMenuItem()

See Also

RadMenuItem Class
RadMenuItem Overload
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Constructor (Element)
RadMenuItem Class See Also Send Feedback
Initializes a new instance of the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadMenuItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenuItem Class
RadMenuItem Overload
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Methods
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadMenuItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Closes a item.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the item. (Overrides HtmlControl..::.Focus()()().)
FocusFirstChild | Moves focus to the first child of the item.
FocusLastChild | Moves focus to the last child of the item.
FocusNextItem | Moves focus to the next item.
FocusPreviousItem | Moves focus to the previous item.
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Open | Opens the item.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.AssignElement Method
RadMenuItem Class See Also Send Feedback
Assign the DOM element to be the RadMenuItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.CallMethod Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Capture Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Click Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click()()().)
Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click(Boolean).)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Click Method
RadMenuItem Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click()
Visual Basic (Declaration)
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadMenuItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Click Method (Boolean)
RadMenuItem Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic (Declaration)
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::.Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.Click(System.Boolean)"]

See Also

RadMenuItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Close Method
RadMenuItem Class See Also Send Feedback
Closes a item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ControlAssert Method
RadMenuItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.DragTo Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FindItem Method
RadMenuItem Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FindItem(
    Predicate<RadMenuItem> predicate
)
Visual Basic (Declaration)
Public Function FindItem ( _
    predicate As Predicate(Of RadMenuItem) _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItem(
    Predicate<RadMenuItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadMenuItem >)>)
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FindItemByText Method
RadMenuItem Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FindItemByText(
    string itemText
)
Visual Basic (Declaration)
Public Function FindItemByText ( _
    itemText As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::.String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByText(System.String)"]

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FindItemByValue Method
RadMenuItem Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem FindItemByValue(
    string itemValue
)
Visual Basic (Declaration)
Public Function FindItemByValue ( _
    itemValue As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::.String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByValue(System.String)"]

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Focus Method
RadMenuItem Class See Also Send Feedback
Focus the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Focus()
Visual Basic (Declaration)
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusFirstChild Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FocusFirstChild Method
RadMenuItem Class See Also Send Feedback
Moves focus to the first child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusFirstChild()
Visual Basic (Declaration)
Public Sub FocusFirstChild
Visual C++
public:
void FocusFirstChild()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusLastChild Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FocusLastChild Method
RadMenuItem Class See Also Send Feedback
Moves focus to the last child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusLastChild()
Visual Basic (Declaration)
Public Sub FocusLastChild
Visual C++
public:
void FocusLastChild()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusNextItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FocusNextItem Method
RadMenuItem Class See Also Send Feedback
Moves focus to the next item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusNextItem()
Visual Basic (Declaration)
Public Sub FocusNextItem
Visual C++
public:
void FocusNextItem()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusPreviousItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.FocusPreviousItem Method
RadMenuItem Class See Also Send Feedback
Moves focus to the previous item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusPreviousItem()
Visual Basic (Declaration)
Public Sub FocusPreviousItem
Visual C++
public:
void FocusPreviousItem()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.GetValue Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Hide Method
RadMenuItem Class See Also Send Feedback
Hide the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.InvokeEvent Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.MouseClick Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.MouseHover Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Navigate Method
RadMenuItem Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Navigate()
Visual Basic (Declaration)
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Open Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Open Method
RadMenuItem Class See Also Send Feedback
Opens the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Open()
Visual Basic (Declaration)
Public Sub Open
Visual C++
public:
void Open()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ScrollToVisible Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.SetValue Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Show Method
RadMenuItem Class See Also Send Feedback
Show the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Properties
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator used in most of the properties. Returns 'null' for item separators. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether the menu item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get or set whether this item is focused.
HasChildren | Check whether the item has children.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the item.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Returns the list of child items of this menu item.
ItemValue | Get or set the value for this item.
Level | Get the level of the item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this item.
Opened | Get whether this item is opened.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShouldNavigate | Check whether the item should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text of this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ClientSideLocator Property
RadMenuItem Class See Also Send Feedback
Get the Client side locator used in most of the properties. Returns 'null' for item separators.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Enabled Property
RadMenuItem Class See Also Send Feedback
Get or set whether the menu item is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Focused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Focused Property
RadMenuItem Class See Also Send Feedback
Get or set whether this item is focused.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Focused { get; set; }
Visual Basic (Declaration)
Public Property Focused As Boolean
Visual C++
public:
property bool Focused {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


HasChildren Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.HasChildren Property
RadMenuItem Class See Also Send Feedback
Check whether the item has children.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasChildren { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
Visual C++
public:
property bool HasChildren {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Index Property
RadMenuItem Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Items Property
RadMenuItem Class See Also Send Feedback
Returns the list of child items of this menu item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ Items {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ItemValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ItemValue Property
RadMenuItem Class See Also Send Feedback
Get or set the value for this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemValue { get; set; }
Visual Basic (Declaration)
Public Property ItemValue As String
Visual C++
public:
property String^ ItemValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Level Property
RadMenuItem Class See Also Send Feedback
Get the level of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.LocatorExpression Property
RadMenuItem Class See Also Send Feedback
Get the FindParam that defines the pattern for a menu item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


NavigateUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.NavigateUrl Property
RadMenuItem Class See Also Send Feedback
Get or set the navigate url of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string NavigateUrl { get; set; }
Visual Basic (Declaration)
Public Property NavigateUrl As String
Visual C++
public:
property String^ NavigateUrl {
    String^ get ();
    void set (String^ value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Opened Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Opened Property
RadMenuItem Class See Also Send Feedback
Get whether this item is opened.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Opened { get; }
Visual Basic (Declaration)
Public ReadOnly Property Opened As Boolean
Visual C++
public:
property bool Opened {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ShouldNavigate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ShouldNavigate Property
RadMenuItem Class See Also Send Feedback
Check whether the item should navigate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShouldNavigate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShouldNavigate As Boolean
Visual C++
public:
property bool ShouldNavigate {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Text Property
RadMenuItem Class See Also Send Feedback
Get or set the text of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Visible Property
RadMenuItem Class See Also Send Feedback
Get whether the item is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox Class
Members See Also Send Feedback
Represents the RadNumericTextBox for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadNumericTextBox : RadInput
Visual Basic (Declaration)
Public Class RadNumericTextBox _
    Inherits RadInput
Visual C++
public ref class RadNumericTextBox : public RadInput

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInput
Telerik.WebAii.Controls.Html..::.RadNumericTextBox

See Also

RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox Members
RadNumericTextBox Class Constructors Methods Properties See Also Send Feedback

The RadNumericTextBox type exposes the following members.

Constructors

Name | Description
RadNumericTextBox | Initializes a new instance of the RadNumericTextBox class

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides RadInput..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
SpinDownClick | NumericTextBox spin down button click.
SpinUpClick | NumericTextBox spin up button click.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsNegative | Get whether the value of the text box is a negative number.
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxValue | Get or set the maximum value the user can enter.
MinValue | Get or set the minimum value the user can enter.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShowSpinButtons | Get whether the numeric text box has an associated pair of spin buttons.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox Constructor
RadNumericTextBox Class See Also Send Feedback
Initializes a new instance of the RadNumericTextBox class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadNumericTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadNumericTextBox()

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox Methods
RadNumericTextBox Class See Also Send Feedback

The RadNumericTextBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides RadInput..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
SpinDownClick | NumericTextBox spin down button click.
SpinUpClick | NumericTextBox spin up button click.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.AssignElement Method
RadNumericTextBox Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.CallMethod Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.Capture Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.Click Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.DragTo Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.GetValue Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.InvokeEvent Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.MouseClick Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.MouseHover Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.ScrollToVisible Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.SetValue Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


SpinDownClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.SpinDownClick Method
RadNumericTextBox Class See Also Send Feedback
NumericTextBox spin down button click.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SpinDownClick()
Visual Basic (Declaration)
Public Sub SpinDownClick
Visual C++
public:
void SpinDownClick()

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


SpinUpClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.SpinUpClick Method
RadNumericTextBox Class See Also Send Feedback
NumericTextBox spin up button click.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SpinUpClick()
Visual Basic (Declaration)
Public Sub SpinUpClick
Visual C++
public:
void SpinUpClick()

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.TypeText Method
RadNumericTextBox Class See Also Send Feedback

Overload List

Name | Description
TypeText(String) | Types text into the input. (Inherited from RadInput.)
TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox Properties
RadNumericTextBox Class See Also Send Feedback

The RadNumericTextBox type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsNegative | Get whether the value of the text box is a negative number.
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxValue | Get or set the maximum value the user can enter.
MinValue | Get or set the minimum value the user can enter.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShowSpinButtons | Get whether the numeric text box has an associated pair of spin buttons.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


IsNegative Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.IsNegative Property
RadNumericTextBox Class See Also Send Feedback
Get whether the value of the text box is a negative number.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsNegative { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNegative As Boolean
Visual C++
public:
property bool IsNegative {
    bool get ();
}

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


MaxValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.MaxValue Property
RadNumericTextBox Class See Also Send Feedback
Get or set the maximum value the user can enter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double MaxValue { get; set; }
Visual Basic (Declaration)
Public Property MaxValue As Double
Visual C++
public:
property double MaxValue {
    double get ();
    void set (double value);
}

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


MinValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.MinValue Property
RadNumericTextBox Class See Also Send Feedback
Get or set the minimum value the user can enter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double MinValue { get; set; }
Visual Basic (Declaration)
Public Property MinValue As Double
Visual C++
public:
property double MinValue {
    double get ();
    void set (double value);
}

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


ShowSpinButtons Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericTextBox..::.ShowSpinButtons Property
RadNumericTextBox Class See Also Send Feedback
Get whether the numeric text box has an associated pair of spin buttons.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShowSpinButtons { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowSpinButtons As Boolean
Visual C++
public:
property bool ShowSpinButtons {
    bool get ();
}

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadPane Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Class
Members See Also Send Feedback
The RadPane of the RadSplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPane : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadPane _
    Inherits HtmlContainerControl
Visual C++
public ref class RadPane : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPane

See Also

RadPane Members
Telerik.WebAii.Controls.Html Namespace


RadPane Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Members
RadPane Class Constructors Methods Properties See Also Send Feedback

The RadPane type exposes the following members.

Constructors

Name | Description
RadPane | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapses the pane.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the pane.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadPane. (Overrides HtmlControl..::.ClientSideLocator.)
Collapsed | Determines or set whether the pane is collapsed.
ContentUrl | Gets/Sets the content url of the pane.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the height of the pane.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsExternalContent | Determines whether the page is loaded as content in the pane.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadPane. (Overrides Control..::.LocatorExpression.)
Locked | Determines or set whether the pane is locked.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxHeight | Gets/Sets the maximum of the pane's height.
MaxWidth | Gets/Sets the maximum of the pane's width.
MinHeight | Gets/Sets the minimum of the pane's height.
MinWidth | Gets/Sets the minimum of the pane's width.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollingEnabled | Determines whether the scrolling of pane is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the width of the pane.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


RadPane Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Constructor
RadPane Class See Also Send Feedback

Overload List

Name | Description
RadPane()()() | Initializes a new instance of the RadPane class.
RadPane(Element) | Initializes a new instance of the RadPane class.

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


RadPane Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Constructor
RadPane Class See Also Send Feedback
Initializes a new instance of the RadPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPane()

See Also

RadPane Class
RadPane Overload
Telerik.WebAii.Controls.Html Namespace


RadPane Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Constructor (Element)
RadPane Class See Also Send Feedback
Initializes a new instance of the RadPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPane(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPane(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPane.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPane Class
RadPane Overload
Telerik.WebAii.Controls.Html Namespace


RadPane Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Methods
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapses the pane.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the pane.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.AssignElement Method
RadPane Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.CallMethod Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Capture Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Click Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Collapse Method
RadPane Class See Also Send Feedback
Collapses the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.ControlAssert Method
RadPane Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.DragTo Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Expand Method
RadPane Class See Also Send Feedback
Expands the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.GetValue Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.InvokeEvent Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.MouseClick Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.MouseHover Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.ScrollToVisible Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.SetValue Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


RadPane Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Properties
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadPane. (Overrides HtmlControl..::.ClientSideLocator.)
Collapsed | Determines or set whether the pane is collapsed.
ContentUrl | Gets/Sets the content url of the pane.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the height of the pane.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsExternalContent | Determines whether the page is loaded as content in the pane.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadPane. (Overrides Control..::.LocatorExpression.)
Locked | Determines or set whether the pane is locked.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxHeight | Gets/Sets the maximum of the pane's height.
MaxWidth | Gets/Sets the maximum of the pane's width.
MinHeight | Gets/Sets the minimum of the pane's height.
MinWidth | Gets/Sets the minimum of the pane's width.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollingEnabled | Determines whether the scrolling of pane is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the width of the pane.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.ClientSideLocator Property
RadPane Class See Also Send Feedback
Gets the client-side code that defines the RadPane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


Collapsed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Collapsed Property
RadPane Class See Also Send Feedback
Determines or set whether the pane is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Collapsed { get; set; }
Visual Basic (Declaration)
Public Property Collapsed As Boolean
Visual C++
public:
property bool Collapsed {
    bool get ();
    void set (bool value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


ContentUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.ContentUrl Property
RadPane Class See Also Send Feedback
Gets/Sets the content url of the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ContentUrl { get; set; }
Visual Basic (Declaration)
Public Property ContentUrl As String
Visual C++
public:
property String^ ContentUrl {
    String^ get ();
    void set (String^ value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Height Property
RadPane Class See Also Send Feedback
Gets/Sets the height of the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


IsExternalContent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.IsExternalContent Property
RadPane Class See Also Send Feedback
Determines whether the page is loaded as content in the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExternalContent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExternalContent As Boolean
Visual C++
public:
property bool IsExternalContent {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.LocatorExpression Property
RadPane Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadPane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


Locked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Locked Property
RadPane Class See Also Send Feedback
Determines or set whether the pane is locked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Locked { get; set; }
Visual Basic (Declaration)
Public Property Locked As Boolean
Visual C++
public:
property bool Locked {
    bool get ();
    void set (bool value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


MaxHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.MaxHeight Property
RadPane Class See Also Send Feedback
Gets/Sets the maximum of the pane's height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MaxHeight { get; set; }
Visual Basic (Declaration)
Public Property MaxHeight As Integer
Visual C++
public:
property int MaxHeight {
    int get ();
    void set (int value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


MaxWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.MaxWidth Property
RadPane Class See Also Send Feedback
Gets/Sets the maximum of the pane's width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MaxWidth { get; set; }
Visual Basic (Declaration)
Public Property MaxWidth As Integer
Visual C++
public:
property int MaxWidth {
    int get ();
    void set (int value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


MinHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.MinHeight Property
RadPane Class See Also Send Feedback
Gets/Sets the minimum of the pane's height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MinHeight { get; set; }
Visual Basic (Declaration)
Public Property MinHeight As Integer
Visual C++
public:
property int MinHeight {
    int get ();
    void set (int value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


MinWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.MinWidth Property
RadPane Class See Also Send Feedback
Gets/Sets the minimum of the pane's width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MinWidth { get; set; }
Visual Basic (Declaration)
Public Property MinWidth As Integer
Visual C++
public:
property int MinWidth {
    int get ();
    void set (int value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


ScrollingEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.ScrollingEnabled Property
RadPane Class See Also Send Feedback
Determines whether the scrolling of pane is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ScrollingEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScrollingEnabled As Boolean
Visual C++
public:
property bool ScrollingEnabled {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Width Property
RadPane Class See Also Send Feedback
Gets/Sets the width of the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Class
Members See Also Send Feedback
Represents the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPanelBar : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadPanelBar _
    Inherits HtmlContainerControl
Visual C++
public ref class RadPanelBar : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPanelBar

See Also

RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Members
RadPanelBar Class Constructors Methods Properties See Also Send Feedback

The RadPanelBar type exposes the following members.

Constructors

Name | Description
RadPanelBar | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the PanelBar control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disable the panelbar.
DisableEvents | Disables the panel bar's client-side event emitting.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enable the panelbar.
EnableEvents | Enables the panel bar's client-side event emitting. Events are enabled by default.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindItems | Find items by given predicate.
FindItemsByLevel | Find the panelbar items by given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeItems | Initializes all RadPanelBar items.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllItems | Get the list of all PanelBar items.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of this PanelBar control.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the panelbar is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FullExpandedItem | Get whether the panelbar FullExpandedItem property is true.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootItems | Get root items of the PanelBar.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SingleExpandedItem | Get whether the panelbar SingleExpandedItem property is true.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Constructor
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
RadPanelBar()()() | Initializes a new instance of the RadPanelBar class.
RadPanelBar(Element) | Initializes a new instance of the RadPanelBar class.

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Constructor
RadPanelBar Class See Also Send Feedback
Initializes a new instance of the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPanelBar()

See Also

RadPanelBar Class
RadPanelBar Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Constructor (Element)
RadPanelBar Class See Also Send Feedback
Initializes a new instance of the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBar(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPanelBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBar Class
RadPanelBar Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Methods
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the PanelBar control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disable the panelbar.
DisableEvents | Disables the panel bar's client-side event emitting.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enable the panelbar.
EnableEvents | Enables the panel bar's client-side event emitting. Events are enabled by default.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by Text.
FindItemByValue | Finds item by Value.
FindItems | Find items by given predicate.
FindItemsByLevel | Find the panelbar items by given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeItems | Initializes all RadPanelBar items.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.AssignElement Method
RadPanelBar Class See Also Send Feedback
Assign the DOM element to be the PanelBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.CallMethod Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Capture Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Click Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.ControlAssert Method
RadPanelBar Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Disable Method
RadPanelBar Class See Also Send Feedback
Disable the panelbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


DisableEvents Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.DisableEvents Method
RadPanelBar Class See Also Send Feedback
Disables the panel bar's client-side event emitting.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DisableEvents()
Visual Basic (Declaration)
Public Sub DisableEvents
Visual C++
public:
void DisableEvents()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.DragTo Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Enable Method
RadPanelBar Class See Also Send Feedback
Enable the panelbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


EnableEvents Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.EnableEvents Method
RadPanelBar Class See Also Send Feedback
Enables the panel bar's client-side event emitting. Events are enabled by default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void EnableEvents()
Visual Basic (Declaration)
Public Sub EnableEvents
Visual C++
public:
void EnableEvents()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.FindItem Method
RadPanelBar Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem FindItem(
    Predicate<RadPanelBarItem> predicate
)
Visual Basic (Declaration)
Public Function FindItem ( _
    predicate As Predicate(Of RadPanelBarItem) _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItem(
    Predicate<RadPanelBarItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadPanelBarItem >)>)
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.FindItemByText Method
RadPanelBar Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem FindItemByText(
    string itemText
)
Visual Basic (Declaration)
Public Function FindItemByText ( _
    itemText As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::.String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByText(System.String)"]

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.FindItemByValue Method
RadPanelBar Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem FindItemByValue(
    string itemValue
)
Visual Basic (Declaration)
Public Function FindItemByValue ( _
    itemValue As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::.String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByValue(System.String)"]

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.FindItems Method
RadPanelBar Class See Also Send Feedback
Find items by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> FindItems(
    Predicate<RadPanelBarItem> predicate
)
Visual Basic (Declaration)
Public Function FindItems ( _
    predicate As Predicate(Of RadPanelBarItem) _
) As IList(Of RadPanelBarItem)
Visual C++
public:
IList<RadPanelBarItem^>^ FindItems(
    Predicate<RadPanelBarItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadPanelBarItem >)>)
The predicate used for search criteria.

Return Value

The list of the root items.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemsByLevel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.FindItemsByLevel Method
RadPanelBar Class See Also Send Feedback
Find the panelbar items by given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> FindItemsByLevel(
    int level
)
Visual Basic (Declaration)
Public Function FindItemsByLevel ( _
    level As Integer _
) As IList(Of RadPanelBarItem)
Visual C++
public:
IList<RadPanelBarItem^>^ FindItemsByLevel(
    int level
)

Parameters

level
Type: System..::.Int32
The level to search for.

Return Value

The list of the panelbar items matching the given level.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.GetValue Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


InitializeItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.InitializeItems Method
RadPanelBar Class See Also Send Feedback
Initializes all RadPanelBar items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InitializeItems()
Visual Basic (Declaration)
Public Sub InitializeItems
Visual C++
public:
void InitializeItems()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.InvokeEvent Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.MouseClick Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.MouseHover Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.ScrollToVisible Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.SetValue Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Properties
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Properties

Name | Description
AllItems | Get the list of all PanelBar items.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of this PanelBar control.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the panelbar is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FullExpandedItem | Get whether the panelbar FullExpandedItem property is true.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootItems | Get root items of the PanelBar.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SingleExpandedItem | Get whether the panelbar SingleExpandedItem property is true.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


AllItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.AllItems Property
RadPanelBar Class See Also Send Feedback
Get the list of all PanelBar items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> AllItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllItems As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ AllItems {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.ClientId Property
RadPanelBar Class See Also Send Feedback
The client id of this PanelBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.ClientSideLocator Property
RadPanelBar Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Enabled Property
RadPanelBar Class See Also Send Feedback
Get whether the panelbar is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FullExpandedItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.FullExpandedItem Property
RadPanelBar Class See Also Send Feedback
Get whether the panelbar FullExpandedItem property is true.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool FullExpandedItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullExpandedItem As Boolean
Visual C++
public:
property bool FullExpandedItem {
    bool get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.LocatorExpression Property
RadPanelBar Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


RootItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.RootItems Property
RadPanelBar Class See Also Send Feedback
Get root items of the PanelBar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> RootItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootItems As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ RootItems {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


SingleExpandedItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.SingleExpandedItem Property
RadPanelBar Class See Also Send Feedback
Get whether the panelbar SingleExpandedItem property is true.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool SingleExpandedItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property SingleExpandedItem As Boolean
Visual C++
public:
property bool SingleExpandedItem {
    bool get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Class
Members See Also Send Feedback
Represents the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPanelBarItem : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadPanelBarItem _
    Inherits HtmlContainerControl
Visual C++
public ref class RadPanelBarItem : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPanelBarItem

See Also

RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Members
RadPanelBarItem Class Constructors Methods Properties See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Constructors

Name | Description
RadPanelBarItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadPanelBarItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the item.
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapse a item if it is not already expanded. The click of the root item also selects it.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the item. The click of the root item also selects it.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds sub item by given text.
FindItemByValue | Finds sub item by given value.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Moves focus to the item. (Overrides HtmlControl..::.Focus()()().)
FocusFirstChild | Moves focus to the first child of the item.
FocusLastChild | Moves focus to the last child of the item.
FocusNextItem | Moves focus to the next item.
FocusPreviousItem | Moves focus to the previous item.
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Makes the item invisible.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Selects the item.
SetValue | Overloaded.
Show | Makes the item visible.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Unselect | De-selects the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether this item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expandable | Get whether this item is expandable.
Expanded | Get whether this item is expanded.
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether this item is focused.
HasChildren | Check whether the item has children.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the item.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of child items of the panelbar item.
ItemValue | Get or set the value for this item.
Level | Get the level of the item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a panelbar item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this item.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Scrollable | Get whether the item is scrollable.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get whether this item is selected.
ShouldNavigate | Check whether the item should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text of this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether this item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Constructor
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
RadPanelBarItem()()() | Initializes a new instance of the RadPanelBarItem class.
RadPanelBarItem(Element) | Initializes a new instance of the RadPanelBarItem class.

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Constructor
RadPanelBarItem Class See Also Send Feedback
Initializes a new instance of the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPanelBarItem()

See Also

RadPanelBarItem Class
RadPanelBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Constructor (Element)
RadPanelBarItem Class See Also Send Feedback
Initializes a new instance of the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPanelBarItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBarItem Class
RadPanelBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Methods
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadPanelBarItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the item.
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapse a item if it is not already expanded. The click of the root item also selects it.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the item. The click of the root item also selects it.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds sub item by given text.
FindItemByValue | Finds sub item by given value.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Moves focus to the item. (Overrides HtmlControl..::.Focus()()().)
FocusFirstChild | Moves focus to the first child of the item.
FocusLastChild | Moves focus to the last child of the item.
FocusNextItem | Moves focus to the next item.
FocusPreviousItem | Moves focus to the previous item.
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Makes the item invisible.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Selects the item.
SetValue | Overloaded.
Show | Makes the item visible.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Unselect | De-selects the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.AssignElement Method
RadPanelBarItem Class See Also Send Feedback
Assign the DOM element to be the RadPanelBarItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Blur Method
RadPanelBarItem Class See Also Send Feedback
Removes focus from the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Blur()
Visual Basic (Declaration)
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.CallMethod Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Capture Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Click Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click()()().)
Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click(Boolean).)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Click Method
RadPanelBarItem Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click()
Visual Basic (Declaration)
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadPanelBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Click Method (Boolean)
RadPanelBarItem Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic (Declaration)
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::.Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.Click(System.Boolean)"]

See Also

RadPanelBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Collapse Method
RadPanelBarItem Class See Also Send Feedback
Collapse a item if it is not already expanded. The click of the root item also selects it.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.ControlAssert Method
RadPanelBarItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.DragTo Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Expand Method
RadPanelBarItem Class See Also Send Feedback
Expands the item. The click of the root item also selects it.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FindItem Method
RadPanelBarItem Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem FindItem(
    Predicate<RadPanelBarItem> predicate
)
Visual Basic (Declaration)
Public Function FindItem ( _
    predicate As Predicate(Of RadPanelBarItem) _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItem(
    Predicate<RadPanelBarItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadPanelBarItem >)>)
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FindItemByText Method
RadPanelBarItem Class See Also Send Feedback
Finds sub item by given text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem FindItemByText(
    string text
)
Visual Basic (Declaration)
Public Function FindItemByText ( _
    text As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByText(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByText(System.String)"]

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FindItemByValue Method
RadPanelBarItem Class See Also Send Feedback
Finds sub item by given value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem FindItemByValue(
    string itemValue
)
Visual Basic (Declaration)
Public Function FindItemByValue ( _
    itemValue As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::.String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByValue(System.String)"]

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Focus Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Focus()
Visual Basic (Declaration)
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusFirstChild Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FocusFirstChild Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the first child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusFirstChild()
Visual Basic (Declaration)
Public Sub FocusFirstChild
Visual C++
public:
void FocusFirstChild()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusLastChild Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FocusLastChild Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the last child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusLastChild()
Visual Basic (Declaration)
Public Sub FocusLastChild
Visual C++
public:
void FocusLastChild()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusNextItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FocusNextItem Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the next item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusNextItem()
Visual Basic (Declaration)
Public Sub FocusNextItem
Visual C++
public:
void FocusNextItem()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusPreviousItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.FocusPreviousItem Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the previous item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FocusPreviousItem()
Visual Basic (Declaration)
Public Sub FocusPreviousItem
Visual C++
public:
void FocusPreviousItem()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.GetValue Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Hide Method
RadPanelBarItem Class See Also Send Feedback
Makes the item invisible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.InvokeEvent Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.MouseClick Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.MouseHover Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Navigate Method
RadPanelBarItem Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Navigate()
Visual Basic (Declaration)
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.ScrollToVisible Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Select Method
RadPanelBarItem Class See Also Send Feedback
Selects the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.SetValue Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Show Method
RadPanelBarItem Class See Also Send Feedback
Makes the item visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Unselect Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Unselect Method
RadPanelBarItem Class See Also Send Feedback
De-selects the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Unselect()
Visual Basic (Declaration)
Public Sub Unselect
Visual C++
public:
void Unselect()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Properties
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether this item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expandable | Get whether this item is expandable.
Expanded | Get whether this item is expanded.
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether this item is focused.
HasChildren | Check whether the item has children.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the item.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | Get the list of child items of the panelbar item.
ItemValue | Get or set the value for this item.
Level | Get the level of the item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a panelbar item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this item.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Scrollable | Get whether the item is scrollable.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get whether this item is selected.
ShouldNavigate | Check whether the item should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get or set the text of this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether this item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.ClientSideLocator Property
RadPanelBarItem Class See Also Send Feedback
Get the Client side locator - call method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Enabled Property
RadPanelBarItem Class See Also Send Feedback
Get whether this item is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Expandable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Expandable Property
RadPanelBarItem Class See Also Send Feedback
Get whether this item is expandable.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Expandable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expandable As Boolean
Visual C++
public:
property bool Expandable {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Expanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Expanded Property
RadPanelBarItem Class See Also Send Feedback
Get whether this item is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Expanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expanded As Boolean
Visual C++
public:
property bool Expanded {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Focused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Focused Property
RadPanelBarItem Class See Also Send Feedback
Get whether this item is focused.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Focused { get; set; }
Visual Basic (Declaration)
Public Property Focused As Boolean
Visual C++
public:
property bool Focused {
    bool get ();
    void set (bool value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


HasChildren Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.HasChildren Property
RadPanelBarItem Class See Also Send Feedback
Check whether the item has children.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasChildren { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
Visual C++
public:
property bool HasChildren {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Index Property
RadPanelBarItem Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Items Property
RadPanelBarItem Class See Also Send Feedback
Get the list of child items of the panelbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ Items {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ItemValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.ItemValue Property
RadPanelBarItem Class See Also Send Feedback
Get or set the value for this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemValue { get; set; }
Visual Basic (Declaration)
Public Property ItemValue As String
Visual C++
public:
property String^ ItemValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Level Property
RadPanelBarItem Class See Also Send Feedback
Get the level of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.LocatorExpression Property
RadPanelBarItem Class See Also Send Feedback
Get the FindParam that defines the pattern for a panelbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


NavigateUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.NavigateUrl Property
RadPanelBarItem Class See Also Send Feedback
Get or set the navigate url of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string NavigateUrl { get; set; }
Visual Basic (Declaration)
Public Property NavigateUrl As String
Visual C++
public:
property String^ NavigateUrl {
    String^ get ();
    void set (String^ value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Scrollable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Scrollable Property
RadPanelBarItem Class See Also Send Feedback
Get whether the item is scrollable.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Scrollable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scrollable As Boolean
Visual C++
public:
property bool Scrollable {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Selected Property
RadPanelBarItem Class See Also Send Feedback
Get whether this item is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ShouldNavigate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.ShouldNavigate Property
RadPanelBarItem Class See Also Send Feedback
Check whether the item should navigate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShouldNavigate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShouldNavigate As Boolean
Visual C++
public:
property bool ShouldNavigate {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Text Property
RadPanelBarItem Class See Also Send Feedback
Get or set the text of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Visible Property
RadPanelBarItem Class See Also Send Feedback
Get whether this item is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadPicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Class
Members See Also Send Feedback
Represents the RadDate/DateTime/TimePicker for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPicker : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadPicker _
    Inherits HtmlContainerControl
Visual C++
public ref class RadPicker : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPicker
Telerik.WebAii.Controls.Html..::.RadDatePicker
Telerik.WebAii.Controls.Html..::.RadTimePicker

See Also

RadPicker Members
Telerik.WebAii.Controls.Html Namespace


RadPicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Members
RadPicker Class Constructors Methods Properties See Also Send Feedback

The RadPicker type exposes the following members.

Constructors

Name | Description
RadPicker | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar.
OpenTimeView | Clicks on the button which opens the TimeView.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using.
DateInput | Gets the Input part of the picker.
DateTimePattern | The DateTime pattern.
Enabled | Gets or sets whenther the picker is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar.
IsEmpty | Check whether the picker is empty.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker.
MinDate | Gets the MinDate of the picker.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker.
PickerType | Gets the Picker control type.
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


RadPicker Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Constructor
RadPicker Class See Also Send Feedback

Overload List

Name | Description
RadPicker()()() | Initializes a new instance of the RadPicker class.
RadPicker(Element) | Initializes a new instance of the RadPicker class.

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


RadPicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Constructor
RadPicker Class See Also Send Feedback
Initializes a new instance of the RadPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPicker()

See Also

RadPicker Class
RadPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadPicker Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Constructor (Element)
RadPicker Class See Also Send Feedback
Initializes a new instance of the RadPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPicker(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPicker Class
RadPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadPicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Methods
RadPicker Class See Also Send Feedback

The RadPicker type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar.
OpenTimeView | Clicks on the button which opens the TimeView.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.AssignElement Method
RadPicker Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element associated with the control.

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.CallMethod Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.Capture Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.Click Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.DragTo Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.GetValue Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.InvokeEvent Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.MouseClick Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.MouseHover Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


OpenCalendar Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.OpenCalendar Method
RadPicker Class See Also Send Feedback
Clicks on the button which opens the calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenCalendar()
Visual Basic (Declaration)
Public Sub OpenCalendar
Visual C++
public:
void OpenCalendar()

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


OpenTimeView Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.OpenTimeView Method
RadPicker Class See Also Send Feedback
Clicks on the button which opens the TimeView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenTimeView()
Visual Basic (Declaration)
Public Sub OpenTimeView
Visual C++
public:
void OpenTimeView()

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.ScrollToVisible Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


SetSelectedDate Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.SetSelectedDate Method
RadPicker Class See Also Send Feedback
Sets date to the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SetSelectedDate(
    DateTime selectedDate
)
Visual Basic (Declaration)
Public Sub SetSelectedDate ( _
    selectedDate As DateTime _
)
Visual C++
public:
void SetSelectedDate(
    DateTime selectedDate
)

Parameters

selectedDate
Type: System..::.DateTime
The Date to be set.

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.SetValue Method
RadPicker Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


RadPicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker Properties
RadPicker Class See Also Send Feedback

The RadPicker type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using.
DateInput | Gets the Input part of the picker.
DateTimePattern | The DateTime pattern.
Enabled | Gets or sets whenther the picker is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar.
IsEmpty | Check whether the picker is empty.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker.
MinDate | Gets the MinDate of the picker.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker.
PickerType | Gets the Picker control type.
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.ClientSideLocator Property
RadPicker Class See Also Send Feedback
The client-side locator of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


Culture Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.Culture Property
RadPicker Class See Also Send Feedback
Gets the culture which the picker is using.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Culture { get; }
Visual Basic (Declaration)
Public ReadOnly Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


DateInput Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.DateInput Property
RadPicker Class See Also Send Feedback
Gets the Input part of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDateInput DateInput { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateInput As RadDateInput
Visual C++
public:
property RadDateInput^ DateInput {
    RadDateInput^ get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


DateTimePattern Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.DateTimePattern Property
RadPicker Class See Also Send Feedback
The DateTime pattern.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected virtual string DateTimePattern { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property DateTimePattern As String
Visual C++
protected:
virtual property String^ DateTimePattern {
    String^ get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.Enabled Property
RadPicker Class See Also Send Feedback
Gets or sets whenther the picker is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


FocusedDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.FocusedDate Property
RadPicker Class See Also Send Feedback
Gets the focused date of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime FocusedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FocusedDate As DateTime
Visual C++
public:
property DateTime FocusedDate {
    DateTime get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


InputTimeFormat Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.InputTimeFormat Property
RadPicker Class See Also Send Feedback
Gets the time format that the input is currently using.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string InputTimeFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputTimeFormat As String
Visual C++
public:
property String^ InputTimeFormat {
    String^ get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


IsCalendarPopupVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.IsCalendarPopupVisible Property
RadPicker Class See Also Send Feedback
Gets the visibility of the popup calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsCalendarPopupVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCalendarPopupVisible As Boolean
Visual C++
public:
property bool IsCalendarPopupVisible {
    bool get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


IsEmpty Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.IsEmpty Property
RadPicker Class See Also Send Feedback
Check whether the picker is empty.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


IsTimePopupVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.IsTimePopupVisible Property
RadPicker Class See Also Send Feedback
Gets the visibility of the TimeView popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsTimePopupVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTimePopupVisible As Boolean
Visual C++
public:
property bool IsTimePopupVisible {
    bool get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.LocatorExpression Property
RadPicker Class See Also Send Feedback
Get the item locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


MaxDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.MaxDate Property
RadPicker Class See Also Send Feedback
Gets the MaxDate of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime MaxDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxDate As DateTime
Visual C++
public:
property DateTime MaxDate {
    DateTime get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


MinDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.MinDate Property
RadPicker Class See Also Send Feedback
Gets the MinDate of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime MinDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinDate As DateTime
Visual C++
public:
property DateTime MinDate {
    DateTime get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


PickerId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.PickerId Property
RadPicker Class See Also Send Feedback
The id of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string PickerId { get; }
Visual Basic (Declaration)
Public ReadOnly Property PickerId As String
Visual C++
public:
property String^ PickerId {
    String^ get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


PickerType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.PickerType Property
RadPicker Class See Also Send Feedback
Gets the Picker control type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPickerControlType PickerType { get; internal set; }
Visual Basic (Declaration)
Public Property PickerType As RadPickerControlType
Visual C++
public:
property RadPickerControlType PickerType {
    RadPickerControlType get ();
    void set (RadPickerControlType value);
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


PopupTimeFormat Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.PopupTimeFormat Property
RadPicker Class See Also Send Feedback
Gets the TimeFormat that the TimeView is currently using.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string PopupTimeFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupTimeFormat As String
Visual C++
public:
property String^ PopupTimeFormat {
    String^ get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


SelectedDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPicker..::.SelectedDate Property
RadPicker Class See Also Send Feedback
Gets the selected date of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime SelectedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDate As DateTime
Visual C++
public:
property DateTime SelectedDate {
    DateTime get ();
}

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


RadPickerControlType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPickerControlType Enumeration
See Also Send Feedback
Enumerates the different picker types.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum RadPickerControlType
Visual Basic (Declaration)
Public Enumeration RadPickerControlType
Visual C++
public enum class RadPickerControlType

Members

Member name | Description
DatePicker | DatePicker control type.
TimePicker | TimePicker control type.
DateTimePicker | DateTimePicker control type.

See Also

Telerik.WebAii.Controls.Html Namespace


RadRotator Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Class
Members See Also Send Feedback
RadRotator control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRotator : HtmlDiv
Visual Basic (Declaration)
Public Class RadRotator _
    Inherits HtmlDiv
Visual C++
public ref class RadRotator : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadRotator

See Also

RadRotator Members
Telerik.WebAii.Controls.Html Namespace


RadRotator Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Members
RadRotator Class Constructors Methods Properties See Also Send Feedback

The RadRotator type exposes the following members.

Constructors

Name | Description
RadRotator | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Pause | Pauses the animation.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Resume | Resumes the paused animation.
Scroll | Scrolls the rotator according to the given direction. Accepts 'Left', 'Right', 'Up' and 'Down' scroll direction arguments.
ScrollItem | Scrolls the rotator item.
ScrollToVisible | Overloaded.
ScrollViewPort | Scrolls the rotator view port.
SetValue | Overloaded.
Start | Starts the animation.
StartAutoPlay | Starts auto playing the rotator items.
Stop | Stops the animation.
StopViewportAnimation | If an item is partially shown and the rotator is paused, calling this function will force the rotator to fully display the item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AnimationDirection | Gets/Sets the animation direction.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentItemIndex | Gets the current item index.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FrameDuration | Gets/Sets the time in milliseconds each frame will displays in automatic scrolling scenarios.
Height | Gets/Sets the Rotator height.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InitialItemIndex | Gets/Sets the initial item index.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsAutomaticAdvance | Determines whether the rotator is set in AutomaticAdvance mode.
IsPaused | Determines whether the RadRotator is paused or not.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsScrollingForward | Determines whether the rotator is scrolling forward.
IsScrollingLeft | Determines whether the rotator is scrolling to the left.
IsScrollingUp | Determines whether the rotator is scrolling upward.
IsSlideShow | Determines whether the rotator is set in SlideShow mode.
IsVertical | Determines whether the rotator is vertical.
IsViewportScrollMode | Determines whether the rotator is scrolling item by item or it is scrolling the whole viewport.
ItemCount | Gets the item count of the Rotator.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PauseOnMouseOver | Determines or set whether the scrolling pauses on mouse over.
RotatorType | Gets/Sets the rotator type.
ScrollDirection | Gets/Sets the rotator scrolling direction.
ScrollDuration | Gets/Sets the speed in milliseconds for scrolling rotator items.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the Rotator width.
WrapFrames | Determines or set whether to start scrolling the frames from the beginning as soon as the rotator shows the last frame.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RadRotator Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Constructor
RadRotator Class See Also Send Feedback

Overload List

Name | Description
RadRotator()()() | Initializes a new instance of the RadRotator class.
RadRotator(Element) | Initializes a new instance of the RadRotator class.

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


RadRotator Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Constructor
RadRotator Class See Also Send Feedback
Initializes a new instance of the RadRotator class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRotator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRotator()

See Also

RadRotator Class
RadRotator Overload
Telerik.WebAii.Controls.Html Namespace


RadRotator Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Constructor (Element)
RadRotator Class See Also Send Feedback
Initializes a new instance of the RadRotator class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRotator(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRotator(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRotator.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRotator Class
RadRotator Overload
Telerik.WebAii.Controls.Html Namespace


RadRotator Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Methods
RadRotator Class See Also Send Feedback

The RadRotator type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Pause | Pauses the animation.
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Resume | Resumes the paused animation.
Scroll | Scrolls the rotator according to the given direction. Accepts 'Left', 'Right', 'Up' and 'Down' scroll direction arguments.
ScrollItem | Scrolls the rotator item.
ScrollToVisible | Overloaded.
ScrollViewPort | Scrolls the rotator view port.
SetValue | Overloaded.
Start | Starts the animation.
StartAutoPlay | Starts auto playing the rotator items.
Stop | Stops the animation.
StopViewportAnimation | If an item is partially shown and the rotator is paused, calling this function will force the rotator to fully display the item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.AssignElement Method
RadRotator Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.CallMethod Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Capture Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Click Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ControlAssert Method
RadRotator Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.DragTo Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.GetValue Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.InvokeEvent Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.MouseClick Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.MouseHover Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Pause Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Pause Method
RadRotator Class See Also Send Feedback
Pauses the animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Pause()
Visual Basic (Declaration)
Public Sub Pause
Visual C++
public:
void Pause()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Resume Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Resume Method
RadRotator Class See Also Send Feedback
Resumes the paused animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resume()
Visual Basic (Declaration)
Public Sub Resume
Visual C++
public:
void Resume()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Scroll Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Scroll Method
RadRotator Class See Also Send Feedback
Scrolls the rotator according to the given direction. Accepts 'Left', 'Right', 'Up' and 'Down' scroll direction arguments.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Scroll(
    RotatorScrollDirection direction
)
Visual Basic (Declaration)
Public Sub Scroll ( _
    direction As RotatorScrollDirection _
)
Visual C++
public:
void Scroll(
    RotatorScrollDirection direction
)

Parameters

direction
Type: Telerik.WebAii.Controls.Html..::.RotatorScrollDirection

[Missing <param name="direction"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRotator.Scroll(Telerik.WebAii.Controls.Html.RotatorScrollDirection)"]

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ScrollItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ScrollItem Method
RadRotator Class See Also Send Feedback
Scrolls the rotator item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollItem()
Visual Basic (Declaration)
Public Sub ScrollItem
Visual C++
public:
void ScrollItem()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ScrollToVisible Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


ScrollViewPort Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ScrollViewPort Method
RadRotator Class See Also Send Feedback
Scrolls the rotator view port.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollViewPort()
Visual Basic (Declaration)
Public Sub ScrollViewPort
Visual C++
public:
void ScrollViewPort()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.SetValue Method
RadRotator Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Start Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Start Method
RadRotator Class See Also Send Feedback
Starts the animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Start()
Visual Basic (Declaration)
Public Sub Start
Visual C++
public:
void Start()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


StartAutoPlay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.StartAutoPlay Method
RadRotator Class See Also Send Feedback
Starts auto playing the rotator items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void StartAutoPlay()
Visual Basic (Declaration)
Public Sub StartAutoPlay
Visual C++
public:
void StartAutoPlay()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Stop Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Stop Method
RadRotator Class See Also Send Feedback
Stops the animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Stop()
Visual Basic (Declaration)
Public Sub Stop
Visual C++
public:
void Stop()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


StopViewportAnimation Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.StopViewportAnimation Method
RadRotator Class See Also Send Feedback
If an item is partially shown and the rotator is paused, calling this function will force the rotator to fully display the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void StopViewportAnimation()
Visual Basic (Declaration)
Public Sub StopViewportAnimation
Visual C++
public:
void StopViewportAnimation()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RadRotator Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator Properties
RadRotator Class See Also Send Feedback

The RadRotator type exposes the following members.

Properties

Name | Description
AnimationDirection | Gets/Sets the animation direction.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentItemIndex | Gets the current item index.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FrameDuration | Gets/Sets the time in milliseconds each frame will displays in automatic scrolling scenarios.
Height | Gets/Sets the Rotator height.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InitialItemIndex | Gets/Sets the initial item index.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsAutomaticAdvance | Determines whether the rotator is set in AutomaticAdvance mode.
IsPaused | Determines whether the RadRotator is paused or not.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsScrollingForward | Determines whether the rotator is scrolling forward.
IsScrollingLeft | Determines whether the rotator is scrolling to the left.
IsScrollingUp | Determines whether the rotator is scrolling upward.
IsSlideShow | Determines whether the rotator is set in SlideShow mode.
IsVertical | Determines whether the rotator is vertical.
IsViewportScrollMode | Determines whether the rotator is scrolling item by item or it is scrolling the whole viewport.
ItemCount | Gets the item count of the Rotator.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the locator HtmlFindExpression. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PauseOnMouseOver | Determines or set whether the scrolling pauses on mouse over.
RotatorType | Gets/Sets the rotator type.
ScrollDirection | Gets/Sets the rotator scrolling direction.
ScrollDuration | Gets/Sets the speed in milliseconds for scrolling rotator items.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the Rotator width.
WrapFrames | Determines or set whether to start scrolling the frames from the beginning as soon as the rotator shows the last frame.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


AnimationDirection Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.AnimationDirection Property
RadRotator Class See Also Send Feedback
Gets/Sets the animation direction.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int AnimationDirection { get; set; }
Visual Basic (Declaration)
Public Property AnimationDirection As Integer
Visual C++
public:
property int AnimationDirection {
    int get ();
    void set (int value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ClientSideLocator Property
RadRotator Class See Also Send Feedback
Gets the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


CurrentItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.CurrentItemIndex Property
RadRotator Class See Also Send Feedback
Gets the current item index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int CurrentItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentItemIndex As Integer
Visual C++
public:
property int CurrentItemIndex {
    int get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


FrameDuration Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.FrameDuration Property
RadRotator Class See Also Send Feedback
Gets/Sets the time in milliseconds each frame will displays in automatic scrolling scenarios.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int FrameDuration { get; set; }
Visual Basic (Declaration)
Public Property FrameDuration As Integer
Visual C++
public:
property int FrameDuration {
    int get ();
    void set (int value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Height Property
RadRotator Class See Also Send Feedback
Gets/Sets the Rotator height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Height { get; set; }
Visual Basic (Declaration)
Public Property Height As String
Visual C++
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


InitialItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.InitialItemIndex Property
RadRotator Class See Also Send Feedback
Gets/Sets the initial item index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int InitialItemIndex { get; set; }
Visual Basic (Declaration)
Public Property InitialItemIndex As Integer
Visual C++
public:
property int InitialItemIndex {
    int get ();
    void set (int value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsAutomaticAdvance Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsAutomaticAdvance Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is set in AutomaticAdvance mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAutomaticAdvance { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAutomaticAdvance As Boolean
Visual C++
public:
property bool IsAutomaticAdvance {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsPaused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsPaused Property
RadRotator Class See Also Send Feedback
Determines whether the RadRotator is paused or not.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPaused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPaused As Boolean
Visual C++
public:
property bool IsPaused {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsScrollingForward Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsScrollingForward Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is scrolling forward.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsScrollingForward { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScrollingForward As Boolean
Visual C++
public:
property bool IsScrollingForward {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsScrollingLeft Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsScrollingLeft Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is scrolling to the left.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsScrollingLeft { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScrollingLeft As Boolean
Visual C++
public:
property bool IsScrollingLeft {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsScrollingUp Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsScrollingUp Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is scrolling upward.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsScrollingUp { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScrollingUp As Boolean
Visual C++
public:
property bool IsScrollingUp {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsSlideShow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsSlideShow Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is set in SlideShow mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSlideShow { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSlideShow As Boolean
Visual C++
public:
property bool IsSlideShow {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsVertical Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsVertical Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is vertical.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsVertical { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVertical As Boolean
Visual C++
public:
property bool IsVertical {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


IsViewportScrollMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.IsViewportScrollMode Property
RadRotator Class See Also Send Feedback
Determines whether the rotator is scrolling item by item or it is scrolling the whole viewport.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsViewportScrollMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsViewportScrollMode As Boolean
Visual C++
public:
property bool IsViewportScrollMode {
    bool get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ItemCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ItemCount Property
RadRotator Class See Also Send Feedback
Gets the item count of the Rotator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
Visual C++
public:
property int ItemCount {
    int get ();
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.LocatorExpression Property
RadRotator Class See Also Send Feedback
Gets the locator HtmlFindExpression.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


PauseOnMouseOver Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.PauseOnMouseOver Property
RadRotator Class See Also Send Feedback
Determines or set whether the scrolling pauses on mouse over.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool PauseOnMouseOver { get; set; }
Visual Basic (Declaration)
Public Property PauseOnMouseOver As Boolean
Visual C++
public:
property bool PauseOnMouseOver {
    bool get ();
    void set (bool value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RotatorType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.RotatorType Property
RadRotator Class See Also Send Feedback
Gets/Sets the rotator type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RotatorType RotatorType { get; set; }
Visual Basic (Declaration)
Public Property RotatorType As RotatorType
Visual C++
public:
property RotatorType RotatorType {
    RotatorType get ();
    void set (RotatorType value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ScrollDirection Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ScrollDirection Property
RadRotator Class See Also Send Feedback
Gets/Sets the rotator scrolling direction.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RotatorScrollDirection ScrollDirection { get; set; }
Visual Basic (Declaration)
Public Property ScrollDirection As RotatorScrollDirection
Visual C++
public:
property RotatorScrollDirection ScrollDirection {
    RotatorScrollDirection get ();
    void set (RotatorScrollDirection value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ScrollDuration Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.ScrollDuration Property
RadRotator Class See Also Send Feedback
Gets/Sets the speed in milliseconds for scrolling rotator items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ScrollDuration { get; set; }
Visual Basic (Declaration)
Public Property ScrollDuration As Integer
Visual C++
public:
property int ScrollDuration {
    int get ();
    void set (int value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.Width Property
RadRotator Class See Also Send Feedback
Gets/Sets the Rotator width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Width { get; set; }
Visual Basic (Declaration)
Public Property Width As String
Visual C++
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


WrapFrames Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRotator..::.WrapFrames Property
RadRotator Class See Also Send Feedback
Determines or set whether to start scrolling the frames from the beginning as soon as the rotator shows the last frame.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool WrapFrames { get; set; }
Visual Basic (Declaration)
Public Property WrapFrames As Boolean
Visual C++
public:
property bool WrapFrames {
    bool get ();
    void set (bool value);
}

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RadScheduler Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Class
Members See Also Send Feedback
A simple control wrapper for the scheduler Control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadScheduler : HtmlDiv
Visual Basic (Declaration)
Public Class RadScheduler _
    Inherits HtmlDiv
Visual C++
public ref class RadScheduler : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadScheduler

See Also

RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


RadScheduler Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Members
RadScheduler Class Constructors Methods Properties See Also Send Feedback

The RadScheduler type exposes the following members.

Constructors

Name | Description
RadScheduler | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AdvancedFormSetText | Advanced form set text method.
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangeHours | Click the ChangeHours link.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetDayViewTimeSlot | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMonthViewTimeSlot | Get the TimeSlot form scheduler MonthView by timeSlot index and day index.
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetTimeLineTimeSlot | Get the TimeSlot form scheduler TimeLineView.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
GetWeekViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler WeekView.
GetWeekViewTimeSlot | Get the TimeSlot form scheduler WeekView by timeSlot index and day index.
GoNext | Go to the Next day.
GoPrevious | Go to the Previous day.
GoToday | Navigate to today.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InlineFormSetText | Inline form set text method.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
NavigateDayView | Navigate to day view.
NavigateMonthView | Navigate to month view.
NavigateTimelineView | Navigate to timeline view.
NavigateWeekView | Navigate to week view.
OpenCalendar | Activate date picker.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AdvancedFormAllDayCheckBox | Advanced form all day checkbox.
AdvancedFormAllDayCheckBoxChecked | Advanced form all day checkbox checked state.
AdvancedFormCancelButton | Get the advanced form Cancel button.
AdvancedFormDiv | Get the advanced form if visible or null otherwise.
AdvancedFormMoreControlsPanel | Advanced form more controls panel.
AdvancedFormMoreControlsPanelVisible | Advanced form more controls visible state.
AdvancedFormRecurrenceCheckBox | Advanced form recurrence checkbox.
AdvancedFormRecurrenceCheckBoxChecked | Advanced form recurrence checkbox checked state.
AdvancedFormRecurrencePanel | Advanced form recurrence panel.
AdvancedFormRecurrencePanelVisible | Advanced form recurrence panel visible state.
AdvancedFormSaveButton | Get the advanced form Save button.
AdvancedFormText | Advanced form text in case the advanced form is visible, null otherwise.
AdvancedFormVisible | Check whether the advanced form is visible.
Appointments | Get the Appointments object of the scheduler.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CalendarVisible | Returns whether the calendar is visible.
CalendarWrapper | Scheduler calendar wrapper.
ChangeHoursLinkText | Change hours link text.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FirstDayStart | Current day in the day view.
GetDayViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler DayView.
HeaderText | Get the current header text.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InlineFormDiv | Get the inline form div if visible, null otherwise.
InlineFormText | Get the text of the inline form if visible, or null otherwise.
InlineFormVisible | Get whether the inline form is visible.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsVisibleModalDialog | Check whether the modal dialog is visible.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for scheduler. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
ModalDialogTitle | Returns modal dialog title.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ResourceTypesString | Returns a string containing the scheduler resource types.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedView | Selected view in the scheduler.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


RadScheduler Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Constructor
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
RadScheduler()()() | Initializes a new instance of the RadScheduler class.
RadScheduler(Element) | Initializes a new instance of the RadScheduler class.

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


RadScheduler Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Constructor
RadScheduler Class See Also Send Feedback
Initializes a new instance of the RadScheduler class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadScheduler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadScheduler()

See Also

RadScheduler Class
RadScheduler Overload
Telerik.WebAii.Controls.Html Namespace


RadScheduler Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Constructor (Element)
RadScheduler Class See Also Send Feedback
Initializes a new instance of the RadScheduler class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadScheduler(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadScheduler(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadScheduler Class
RadScheduler Overload
Telerik.WebAii.Controls.Html Namespace


RadScheduler Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Methods
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AdvancedFormSetText | Advanced form set text method.
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangeHours | Click the ChangeHours link.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetDayViewTimeSlot | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMonthViewTimeSlot | Get the TimeSlot form scheduler MonthView by timeSlot index and day index.
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetTimeLineTimeSlot | Get the TimeSlot form scheduler TimeLineView.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
GetWeekViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler WeekView.
GetWeekViewTimeSlot | Get the TimeSlot form scheduler WeekView by timeSlot index and day index.
GoNext | Go to the Next day.
GoPrevious | Go to the Previous day.
GoToday | Navigate to today.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InlineFormSetText | Inline form set text method.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
NavigateDayView | Navigate to day view.
NavigateMonthView | Navigate to month view.
NavigateTimelineView | Navigate to timeline view.
NavigateWeekView | Navigate to week view.
OpenCalendar | Activate date picker.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormSetText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormSetText Method
RadScheduler Class See Also Send Feedback
Advanced form set text method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void AdvancedFormSetText(
    string text
)
Visual Basic (Declaration)
Public Sub AdvancedFormSetText ( _
    text As String _
)
Visual C++
public:
void AdvancedFormSetText(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.AdvancedFormSetText(System.String)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AssignElement Method
RadScheduler Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.CallMethod Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.Capture Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


ChangeHours Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ChangeHours Method
RadScheduler Class See Also Send Feedback
Click the ChangeHours link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangeHours()
Visual Basic (Declaration)
Public Sub ChangeHours
Visual C++
public:
void ChangeHours()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.Click Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ControlAssert Method
RadScheduler Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.DragTo Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


GetDayViewTimeSlot Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetDayViewTimeSlot Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
GetDayViewTimeSlot(Int32) | Get the TimeSlot form scheduler DayView by index.
GetDayViewTimeSlot(Int32, Int32) | Get the TimeSlot form scheduler DayView by index and resource index.

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


GetDayViewTimeSlot Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetDayViewTimeSlot Method (Int32)
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler DayView by index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetDayViewTimeSlot(
    int index
)
Visual Basic (Declaration)
Public Function GetDayViewTimeSlot ( _
    index As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetDayViewTimeSlot(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32)"]

See Also

RadScheduler Class
GetDayViewTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


GetDayViewTimeSlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetDayViewTimeSlot Method (Int32, Int32)
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler DayView by index and resource index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetDayViewTimeSlot(
    int index,
    int resourceIndex
)
Visual Basic (Declaration)
Public Function GetDayViewTimeSlot ( _
    index As Integer, _
    resourceIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetDayViewTimeSlot(
    int index,
    int resourceIndex
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32,System.Int32)"]

resourceIndex
Type: System..::.Int32

[Missing <param name="resourceIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32,System.Int32)"]

See Also

RadScheduler Class
GetDayViewTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


GetMonthViewTimeSlot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetMonthViewTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler MonthView by timeSlot index and day index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetMonthViewTimeSlot(
    int index,
    int dayIndex
)
Visual Basic (Declaration)
Public Function GetMonthViewTimeSlot ( _
    index As Integer, _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetMonthViewTimeSlot(
    int index,
    int dayIndex
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetMonthViewTimeSlot(System.Int32,System.Int32)"]

dayIndex
Type: System..::.Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetMonthViewTimeSlot(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetMonthViewTimeSlot(System.Int32,System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetTimeLineTimeSlot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetTimeLineTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler TimeLineView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetTimeLineTimeSlot(
    int dayIndex
)
Visual Basic (Declaration)
Public Function GetTimeLineTimeSlot ( _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetTimeLineTimeSlot(
    int dayIndex
)

Parameters

dayIndex
Type: System..::.Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetTimeLineTimeSlot(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetTimeLineTimeSlot(System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetValue Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


GetWeekViewAllDayTimeSlot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetWeekViewAllDayTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the AllDay TimeSlot form scheduler WeekView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetWeekViewAllDayTimeSlot(
    int dayIndex
)
Visual Basic (Declaration)
Public Function GetWeekViewAllDayTimeSlot ( _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetWeekViewAllDayTimeSlot(
    int dayIndex
)

Parameters

dayIndex
Type: System..::.Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewAllDayTimeSlot(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewAllDayTimeSlot(System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetWeekViewTimeSlot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetWeekViewTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler WeekView by timeSlot index and day index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetWeekViewTimeSlot(
    int index,
    int dayIndex
)
Visual Basic (Declaration)
Public Function GetWeekViewTimeSlot ( _
    index As Integer, _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetWeekViewTimeSlot(
    int index,
    int dayIndex
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewTimeSlot(System.Int32,System.Int32)"]

dayIndex
Type: System..::.Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewTimeSlot(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewTimeSlot(System.Int32,System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GoNext Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GoNext Method
RadScheduler Class See Also Send Feedback
Go to the Next day.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GoNext()
Visual Basic (Declaration)
Public Sub GoNext
Visual C++
public:
void GoNext()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GoPrevious Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GoPrevious Method
RadScheduler Class See Also Send Feedback
Go to the Previous day.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GoPrevious()
Visual Basic (Declaration)
Public Sub GoPrevious
Visual C++
public:
void GoPrevious()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GoToday Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GoToday Method
RadScheduler Class See Also Send Feedback
Navigate to today.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GoToday()
Visual Basic (Declaration)
Public Sub GoToday
Visual C++
public:
void GoToday()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InlineFormSetText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InlineFormSetText Method
RadScheduler Class See Also Send Feedback
Inline form set text method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InlineFormSetText(
    string text
)
Visual Basic (Declaration)
Public Sub InlineFormSetText ( _
    text As String _
)
Visual C++
public:
void InlineFormSetText(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.InlineFormSetText(System.String)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InvokeEvent Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.MouseClick Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.MouseHover Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


NavigateDayView Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigateDayView Method
RadScheduler Class See Also Send Feedback
Navigate to day view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NavigateDayView()
Visual Basic (Declaration)
Public Sub NavigateDayView
Visual C++
public:
void NavigateDayView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


NavigateMonthView Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigateMonthView Method
RadScheduler Class See Also Send Feedback
Navigate to month view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NavigateMonthView()
Visual Basic (Declaration)
Public Sub NavigateMonthView
Visual C++
public:
void NavigateMonthView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


NavigateTimelineView Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigateTimelineView Method
RadScheduler Class See Also Send Feedback
Navigate to timeline view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NavigateTimelineView()
Visual Basic (Declaration)
Public Sub NavigateTimelineView
Visual C++
public:
void NavigateTimelineView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


NavigateWeekView Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigateWeekView Method
RadScheduler Class See Also Send Feedback
Navigate to week view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NavigateWeekView()
Visual Basic (Declaration)
Public Sub NavigateWeekView
Visual C++
public:
void NavigateWeekView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


OpenCalendar Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.OpenCalendar Method
RadScheduler Class See Also Send Feedback
Activate date picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenCalendar()
Visual Basic (Declaration)
Public Sub OpenCalendar
Visual C++
public:
void OpenCalendar()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ScrollToVisible Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.SetValue Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


RadScheduler Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Properties
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Properties

Name | Description
AdvancedFormAllDayCheckBox | Advanced form all day checkbox.
AdvancedFormAllDayCheckBoxChecked | Advanced form all day checkbox checked state.
AdvancedFormCancelButton | Get the advanced form Cancel button.
AdvancedFormDiv | Get the advanced form if visible or null otherwise.
AdvancedFormMoreControlsPanel | Advanced form more controls panel.
AdvancedFormMoreControlsPanelVisible | Advanced form more controls visible state.
AdvancedFormRecurrenceCheckBox | Advanced form recurrence checkbox.
AdvancedFormRecurrenceCheckBoxChecked | Advanced form recurrence checkbox checked state.
AdvancedFormRecurrencePanel | Advanced form recurrence panel.
AdvancedFormRecurrencePanelVisible | Advanced form recurrence panel visible state.
AdvancedFormSaveButton | Get the advanced form Save button.
AdvancedFormText | Advanced form text in case the advanced form is visible, null otherwise.
AdvancedFormVisible | Check whether the advanced form is visible.
Appointments | Get the Appointments object of the scheduler.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CalendarVisible | Returns whether the calendar is visible.
CalendarWrapper | Scheduler calendar wrapper.
ChangeHoursLinkText | Change hours link text.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FirstDayStart | Current day in the day view.
GetDayViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler DayView.
HeaderText | Get the current header text.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InlineFormDiv | Get the inline form div if visible, null otherwise.
InlineFormText | Get the text of the inline form if visible, or null otherwise.
InlineFormVisible | Get whether the inline form is visible.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsVisibleModalDialog | Check whether the modal dialog is visible.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for scheduler. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
ModalDialogTitle | Returns modal dialog title.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ResourceTypesString | Returns a string containing the scheduler resource types.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedView | Selected view in the scheduler.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormAllDayCheckBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormAllDayCheckBox Property
RadScheduler Class See Also Send Feedback
Advanced form all day checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputCheckBox AdvancedFormAllDayCheckBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormAllDayCheckBox As HtmlInputCheckBox
Visual C++
public:
property HtmlInputCheckBox^ AdvancedFormAllDayCheckBox {
    HtmlInputCheckBox^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormAllDayCheckBoxChecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormAllDayCheckBoxChecked Property
RadScheduler Class See Also Send Feedback
Advanced form all day checkbox checked state.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AdvancedFormAllDayCheckBoxChecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormAllDayCheckBoxChecked As Boolean
Visual C++
public:
property bool AdvancedFormAllDayCheckBoxChecked {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormCancelButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormCancelButton Property
RadScheduler Class See Also Send Feedback
Get the advanced form Cancel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor AdvancedFormCancelButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormCancelButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ AdvancedFormCancelButton {
    HtmlAnchor^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormDiv Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormDiv Property
RadScheduler Class See Also Send Feedback
Get the advanced form if visible or null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlDiv AdvancedFormDiv { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormDiv As HtmlDiv
Visual C++
public:
property HtmlDiv^ AdvancedFormDiv {
    HtmlDiv^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormMoreControlsPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormMoreControlsPanel Property
RadScheduler Class See Also Send Feedback
Advanced form more controls panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlDiv AdvancedFormMoreControlsPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormMoreControlsPanel As HtmlDiv
Visual C++
public:
property HtmlDiv^ AdvancedFormMoreControlsPanel {
    HtmlDiv^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormMoreControlsPanelVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormMoreControlsPanelVisible Property
RadScheduler Class See Also Send Feedback
Advanced form more controls visible state.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AdvancedFormMoreControlsPanelVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormMoreControlsPanelVisible As Boolean
Visual C++
public:
property bool AdvancedFormMoreControlsPanelVisible {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormRecurrenceCheckBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormRecurrenceCheckBox Property
RadScheduler Class See Also Send Feedback
Advanced form recurrence checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputCheckBox AdvancedFormRecurrenceCheckBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormRecurrenceCheckBox As HtmlInputCheckBox
Visual C++
public:
property HtmlInputCheckBox^ AdvancedFormRecurrenceCheckBox {
    HtmlInputCheckBox^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormRecurrenceCheckBoxChecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormRecurrenceCheckBoxChecked Property
RadScheduler Class See Also Send Feedback
Advanced form recurrence checkbox checked state.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AdvancedFormRecurrenceCheckBoxChecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormRecurrenceCheckBoxChecked As Boolean
Visual C++
public:
property bool AdvancedFormRecurrenceCheckBoxChecked {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormRecurrencePanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormRecurrencePanel Property
RadScheduler Class See Also Send Feedback
Advanced form recurrence panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlDiv AdvancedFormRecurrencePanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormRecurrencePanel As HtmlDiv
Visual C++
public:
property HtmlDiv^ AdvancedFormRecurrencePanel {
    HtmlDiv^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormRecurrencePanelVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormRecurrencePanelVisible Property
RadScheduler Class See Also Send Feedback
Advanced form recurrence panel visible state.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AdvancedFormRecurrencePanelVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormRecurrencePanelVisible As Boolean
Visual C++
public:
property bool AdvancedFormRecurrencePanelVisible {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormSaveButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormSaveButton Property
RadScheduler Class See Also Send Feedback
Get the advanced form Save button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlAnchor AdvancedFormSaveButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormSaveButton As HtmlAnchor
Visual C++
public:
property HtmlAnchor^ AdvancedFormSaveButton {
    HtmlAnchor^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormText Property
RadScheduler Class See Also Send Feedback
Advanced form text in case the advanced form is visible, null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string AdvancedFormText { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormText As String
Visual C++
public:
property String^ AdvancedFormText {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AdvancedFormVisible Property
RadScheduler Class See Also Send Feedback
Check whether the advanced form is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AdvancedFormVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdvancedFormVisible As Boolean
Visual C++
public:
property bool AdvancedFormVisible {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


Appointments Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.Appointments Property
RadScheduler Class See Also Send Feedback
Get the Appointments object of the scheduler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<SchedulerAppointment> Appointments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appointments As IList(Of SchedulerAppointment)
Visual C++
public:
property IList<SchedulerAppointment^>^ Appointments {
    IList<SchedulerAppointment^>^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


CalendarVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.CalendarVisible Property
RadScheduler Class See Also Send Feedback
Returns whether the calendar is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CalendarVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalendarVisible As Boolean
Visual C++
public:
property bool CalendarVisible {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


CalendarWrapper Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.CalendarWrapper Property
RadScheduler Class See Also Send Feedback
Scheduler calendar wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlDiv CalendarWrapper { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalendarWrapper As HtmlDiv
Visual C++
public:
property HtmlDiv^ CalendarWrapper {
    HtmlDiv^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


ChangeHoursLinkText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ChangeHoursLinkText Property
RadScheduler Class See Also Send Feedback
Change hours link text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ChangeHoursLinkText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangeHoursLinkText As String
Visual C++
public:
property String^ ChangeHoursLinkText {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ClientSideLocator Property
RadScheduler Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


FirstDayStart Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.FirstDayStart Property
RadScheduler Class See Also Send Feedback
Current day in the day view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime FirstDayStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstDayStart As DateTime
Visual C++
public:
property DateTime FirstDayStart {
    DateTime get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetDayViewAllDayTimeSlot Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetDayViewAllDayTimeSlot Property
RadScheduler Class See Also Send Feedback
Get the AllDay TimeSlot form scheduler DayView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot GetDayViewAllDayTimeSlot { get; }
Visual Basic (Declaration)
Public ReadOnly Property GetDayViewAllDayTimeSlot As SchedulerTimeSlot
Visual C++
public:
property SchedulerTimeSlot^ GetDayViewAllDayTimeSlot {
    SchedulerTimeSlot^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.HeaderText Property
RadScheduler Class See Also Send Feedback
Get the current header text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InlineFormDiv Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InlineFormDiv Property
RadScheduler Class See Also Send Feedback
Get the inline form div if visible, null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlDiv InlineFormDiv { get; }
Visual Basic (Declaration)
Public ReadOnly Property InlineFormDiv As HtmlDiv
Visual C++
public:
property HtmlDiv^ InlineFormDiv {
    HtmlDiv^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InlineFormText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InlineFormText Property
RadScheduler Class See Also Send Feedback
Get the text of the inline form if visible, or null otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string InlineFormText { get; }
Visual Basic (Declaration)
Public ReadOnly Property InlineFormText As String
Visual C++
public:
property String^ InlineFormText {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InlineFormVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InlineFormVisible Property
RadScheduler Class See Also Send Feedback
Get whether the inline form is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool InlineFormVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property InlineFormVisible As Boolean
Visual C++
public:
property bool InlineFormVisible {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


IsVisibleModalDialog Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.IsVisibleModalDialog Property
RadScheduler Class See Also Send Feedback
Check whether the modal dialog is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsVisibleModalDialog { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVisibleModalDialog As Boolean
Visual C++
public:
property bool IsVisibleModalDialog {
    bool get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.LocatorExpression Property
RadScheduler Class See Also Send Feedback
Get the FindParam that defines the pattern for scheduler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


ModalDialogTitle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ModalDialogTitle Property
RadScheduler Class See Also Send Feedback
Returns modal dialog title.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ModalDialogTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModalDialogTitle As String
Visual C++
public:
property String^ ModalDialogTitle {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


ResourceTypesString Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ResourceTypesString Property
RadScheduler Class See Also Send Feedback
Returns a string containing the scheduler resource types.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ResourceTypesString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResourceTypesString As String
Visual C++
public:
property String^ ResourceTypesString {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


SelectedView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.SelectedView Property
RadScheduler Class See Also Send Feedback
Selected view in the scheduler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerViewNavigationType SelectedView { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedView As SchedulerViewNavigationType
Visual C++
public:
property SchedulerViewNavigationType SelectedView {
    SchedulerViewNavigationType get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


RadSlider Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Class
Members See Also Send Feedback
RadSlider control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSlider : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadSlider _
    Inherits HtmlContainerControl
Visual C++
public ref class RadSlider : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadSlider

See Also

RadSlider Members
Telerik.WebAii.Controls.Html Namespace


RadSlider Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Members
RadSlider Class Constructors Methods Properties See Also Send Feedback

The RadSlider type exposes the following members.

Constructors

Name | Description
RadSlider | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangeSelectedRegion | Initiates selected region change of the start/end values.
ChangeValue | Initiates change Slider value action.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadSlider. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentValue | Gets/Sets RadSlider's value.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the Slider height.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsDirectionReversed | Determines or set whether the Slider direction is reversed.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsSelectionRangeEnabled | Determines or set whether the slider range selection is enabled.
LargeChange | Gets/Sets the large change step of the Slider.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlider. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaximumValue | Gets/Sets the maximum value of the Slider.
MinimumValue | Gets/Sets the minimum value of the Slider.
Orientation | Gets/Sets the Slider orientation.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedRegionHeight | Gets RadSlider's Selected Region Height.
SelectedRegionWidth | Get RadSlider's Selected Region Width.
SelectionEnd | Gets/Sets RadSlider's selection end value.
SelectionStart | Gets/Sets RadSlider's selection start value.
SliderId | Gets the ID of the slider.
SmallChange | Gets/Sets the small change step of the Slider.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the Slider width.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


RadSlider Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Constructor
RadSlider Class See Also Send Feedback

Overload List

Name | Description
RadSlider()()() | Initializes a new instance of the RadSlider class.
RadSlider(Element) | Initializes a new instance of the RadSlider class.

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


RadSlider Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Constructor
RadSlider Class See Also Send Feedback
Initializes a new instance of the RadSlider class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSlider()

See Also

RadSlider Class
RadSlider Overload
Telerik.WebAii.Controls.Html Namespace


RadSlider Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Constructor (Element)
RadSlider Class See Also Send Feedback
Initializes a new instance of the RadSlider class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlider(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSlider(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
RadSlider wrapper div.

See Also

RadSlider Class
RadSlider Overload
Telerik.WebAii.Controls.Html Namespace


RadSlider Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Methods
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangeSelectedRegion | Initiates selected region change of the start/end values.
ChangeValue | Initiates change Slider value action.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.AssignElement Method
RadSlider Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.CallMethod Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Capture Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


ChangeSelectedRegion Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ChangeSelectedRegion Method
RadSlider Class See Also Send Feedback
Initiates selected region change of the start/end values.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangeSelectedRegion(
    int start,
    int end
)
Visual Basic (Declaration)
Public Sub ChangeSelectedRegion ( _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
void ChangeSelectedRegion(
    int start,
    int end
)

Parameters

start
Type: System..::.Int32
The new start value.
end
Type: System..::.Int32
The new end value.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


ChangeValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ChangeValue Method
RadSlider Class See Also Send Feedback
Initiates change Slider value action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangeValue(
    int value
)
Visual Basic (Declaration)
Public Sub ChangeValue ( _
    value As Integer _
)
Visual C++
public:
void ChangeValue(
    int value
)

Parameters

value
Type: System..::.Int32
The new value to be set.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Click Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ControlAssert Method
RadSlider Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.DragTo Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.GetValue Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.InvokeEvent Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.MouseClick Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.MouseHover Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ScrollToVisible Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SetValue Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


RadSlider Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Properties
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadSlider. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentValue | Gets/Sets RadSlider's value.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the Slider height.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsDirectionReversed | Determines or set whether the Slider direction is reversed.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsSelectionRangeEnabled | Determines or set whether the slider range selection is enabled.
LargeChange | Gets/Sets the large change step of the Slider.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlider. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaximumValue | Gets/Sets the maximum value of the Slider.
MinimumValue | Gets/Sets the minimum value of the Slider.
Orientation | Gets/Sets the Slider orientation.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedRegionHeight | Gets RadSlider's Selected Region Height.
SelectedRegionWidth | Get RadSlider's Selected Region Width.
SelectionEnd | Gets/Sets RadSlider's selection end value.
SelectionStart | Gets/Sets RadSlider's selection start value.
SliderId | Gets the ID of the slider.
SmallChange | Gets/Sets the small change step of the Slider.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the Slider width.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ClientSideLocator Property
RadSlider Class See Also Send Feedback
Gets the client-side code that defines the RadSlider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


CurrentValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.CurrentValue Property
RadSlider Class See Also Send Feedback
Gets/Sets RadSlider's value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int CurrentValue { get; set; }
Visual Basic (Declaration)
Public Property CurrentValue As Integer
Visual C++
public:
property int CurrentValue {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Height Property
RadSlider Class See Also Send Feedback
Gets/Sets the Slider height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Height { get; set; }
Visual Basic (Declaration)
Public Property Height As String
Visual C++
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


IsDirectionReversed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.IsDirectionReversed Property
RadSlider Class See Also Send Feedback
Determines or set whether the Slider direction is reversed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsDirectionReversed { get; set; }
Visual Basic (Declaration)
Public Property IsDirectionReversed As Boolean
Visual C++
public:
property bool IsDirectionReversed {
    bool get ();
    void set (bool value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


IsSelectionRangeEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.IsSelectionRangeEnabled Property
RadSlider Class See Also Send Feedback
Determines or set whether the slider range selection is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelectionRangeEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsSelectionRangeEnabled As Boolean
Visual C++
public:
property bool IsSelectionRangeEnabled {
    bool get ();
    void set (bool value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


LargeChange Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.LargeChange Property
RadSlider Class See Also Send Feedback
Gets/Sets the large change step of the Slider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int LargeChange { get; set; }
Visual Basic (Declaration)
Public Property LargeChange As Integer
Visual C++
public:
property int LargeChange {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.LocatorExpression Property
RadSlider Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadSlider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


MaximumValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.MaximumValue Property
RadSlider Class See Also Send Feedback
Gets/Sets the maximum value of the Slider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MaximumValue { get; set; }
Visual Basic (Declaration)
Public Property MaximumValue As Integer
Visual C++
public:
property int MaximumValue {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


MinimumValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.MinimumValue Property
RadSlider Class See Also Send Feedback
Gets/Sets the minimum value of the Slider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MinimumValue { get; set; }
Visual Basic (Declaration)
Public Property MinimumValue As Integer
Visual C++
public:
property int MinimumValue {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Orientation Property
RadSlider Class See Also Send Feedback
Gets/Sets the Slider orientation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SliderOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As SliderOrientation
Visual C++
public:
property SliderOrientation Orientation {
    SliderOrientation get ();
    void set (SliderOrientation value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


SelectedRegionHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SelectedRegionHeight Property
RadSlider Class See Also Send Feedback
Gets RadSlider's Selected Region Height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedRegionHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedRegionHeight As String
Visual C++
public:
property String^ SelectedRegionHeight {
    String^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


SelectedRegionWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SelectedRegionWidth Property
RadSlider Class See Also Send Feedback
Get RadSlider's Selected Region Width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedRegionWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedRegionWidth As String
Visual C++
public:
property String^ SelectedRegionWidth {
    String^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


SelectionEnd Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SelectionEnd Property
RadSlider Class See Also Send Feedback
Gets/Sets RadSlider's selection end value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectionEnd { get; set; }
Visual Basic (Declaration)
Public Property SelectionEnd As Integer
Visual C++
public:
property int SelectionEnd {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


SelectionStart Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SelectionStart Property
RadSlider Class See Also Send Feedback
Gets/Sets RadSlider's selection start value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectionStart { get; set; }
Visual Basic (Declaration)
Public Property SelectionStart As Integer
Visual C++
public:
property int SelectionStart {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


SliderId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SliderId Property
RadSlider Class See Also Send Feedback
Gets the ID of the slider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SliderId { get; }
Visual Basic (Declaration)
Public ReadOnly Property SliderId As String
Visual C++
public:
property String^ SliderId {
    String^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


SmallChange Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SmallChange Property
RadSlider Class See Also Send Feedback
Gets/Sets the small change step of the Slider.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SmallChange { get; set; }
Visual Basic (Declaration)
Public Property SmallChange As Integer
Visual C++
public:
property int SmallChange {
    int get ();
    void set (int value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Width Property
RadSlider Class See Also Send Feedback
Gets/Sets the Slider width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Width { get; set; }
Visual Basic (Declaration)
Public Property Width As String
Visual C++
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Class
Members See Also Send Feedback
The sliding pane of Radsplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSlidingPane : HtmlDiv
Visual Basic (Declaration)
Public Class RadSlidingPane _
    Inherits HtmlDiv
Visual C++
public ref class RadSlidingPane : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadSlidingPane

See Also

RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Members
RadSlidingPane Class Constructors Methods Properties See Also Send Feedback

The RadSlidingPane type exposes the following members.

Constructors

Name | Description
RadSlidingPane | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapses the sliding pane.
Dock | Docks the sliding pane.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Undock | Undocks the sliding pane.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Docked | Determines whether the sliding pane is docked.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Determines whether the sliding pane is expanded (If the pane is docked, it is not expanded).
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingPane. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollingEnabled | Determines whether the sliding pane scrolling is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Constructor
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
RadSlidingPane()()() | Initializes a new instance of the RadSlidingPane class.
RadSlidingPane(Element) | Initializes a new instance of the RadSlidingPane class.

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Constructor
RadSlidingPane Class See Also Send Feedback
Initializes a new instance of the RadSlidingPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlidingPane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSlidingPane()

See Also

RadSlidingPane Class
RadSlidingPane Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Constructor (Element)
RadSlidingPane Class See Also Send Feedback
Initializes a new instance of the RadSlidingPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlidingPane(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSlidingPane(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSlidingPane.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSlidingPane Class
RadSlidingPane Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Methods
RadSlidingPane Class See Also Send Feedback

The RadSlidingPane type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Collapse | Collapses the sliding pane.
Dock | Docks the sliding pane.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Undock | Undocks the sliding pane.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.AssignElement Method
RadSlidingPane Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.CallMethod Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Capture Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Click Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Collapse Method
RadSlidingPane Class See Also Send Feedback
Collapses the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


Dock Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Dock Method
RadSlidingPane Class See Also Send Feedback
Docks the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Dock()
Visual Basic (Declaration)
Public Sub Dock
Visual C++
public:
void Dock()

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.DragTo Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.GetValue Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.InvokeEvent Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.MouseClick Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.MouseHover Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.ScrollToVisible Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.SetValue Method
RadSlidingPane Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Undock Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Undock Method
RadSlidingPane Class See Also Send Feedback
Undocks the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Undock()
Visual Basic (Declaration)
Public Sub Undock
Visual C++
public:
void Undock()

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane Properties
RadSlidingPane Class See Also Send Feedback

The RadSlidingPane type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Docked | Determines whether the sliding pane is docked.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Determines whether the sliding pane is expanded (If the pane is docked, it is not expanded).
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingPane. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollingEnabled | Determines whether the sliding pane scrolling is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.ClientSideLocator Property
RadSlidingPane Class See Also Send Feedback
Gets the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


Docked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Docked Property
RadSlidingPane Class See Also Send Feedback
Determines whether the sliding pane is docked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Docked { get; }
Visual Basic (Declaration)
Public ReadOnly Property Docked As Boolean
Visual C++
public:
property bool Docked {
    bool get ();
}

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


Expanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.Expanded Property
RadSlidingPane Class See Also Send Feedback
Determines whether the sliding pane is expanded (If the pane is docked, it is not expanded).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Expanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expanded As Boolean
Visual C++
public:
property bool Expanded {
    bool get ();
}

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.LocatorExpression Property
RadSlidingPane Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadSlidingPane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


ScrollingEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingPane..::.ScrollingEnabled Property
RadSlidingPane Class See Also Send Feedback
Determines whether the sliding pane scrolling is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ScrollingEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScrollingEnabled As Boolean
Visual C++
public:
property bool ScrollingEnabled {
    bool get ();
}

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Class
Members See Also Send Feedback
RadSlidingZone of the RadSplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSlidingZone : HtmlTable
Visual Basic (Declaration)
Public Class RadSlidingZone _
    Inherits HtmlTable
Visual C++
public ref class RadSlidingZone : public HtmlTable

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTable
Telerik.WebAii.Controls.Html..::.RadSlidingZone

See Also

RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Members
RadSlidingZone Class Constructors Methods Properties See Also Send Feedback

The RadSlidingZone type exposes the following members.

Constructors

Name | Description
RadSlidingZone | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlTable..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands sliding pane.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Border | Gets the width of the table border. (Inherited from HtmlTable.)
Caption | Gets the caption of a table. (Inherited from HtmlTable.)
CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClickToOpen | Determines or set whether click on the tab is needed to open the sliding pane.
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Gets requested row by index. (Inherited from HtmlTable.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingZone. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaneCount | Gets the sliding pane count.
Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SlideDirection | Gets the direction of pane sliding.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Constructor
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
RadSlidingZone()()() | Initializes a new instance of the RadSlidingZone class.
RadSlidingZone(Element) | Initializes a new instance of the RadSlidingZone class.

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Constructor
RadSlidingZone Class See Also Send Feedback
Initializes a new instance of the RadSlidingZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlidingZone()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSlidingZone()

See Also

RadSlidingZone Class
RadSlidingZone Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Constructor (Element)
RadSlidingZone Class See Also Send Feedback
Initializes a new instance of the RadSlidingZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlidingZone(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSlidingZone(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSlidingZone.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSlidingZone Class
RadSlidingZone Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Methods
RadSlidingZone Class See Also Send Feedback

The RadSlidingZone type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlTable..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands sliding pane.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.AssignElement Method
RadSlidingZone Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.CallMethod Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.Capture Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.Click Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.ControlAssert Method
RadSlidingZone Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.DragTo Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.Expand Method
RadSlidingZone Class See Also Send Feedback
Expands sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand(
    string id
)
Visual Basic (Declaration)
Public Sub Expand ( _
    id As String _
)
Visual C++
public:
void Expand(
    String^ id
)

Parameters

id
Type: System..::.String
Sliding pane id.

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.GetValue Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.InvokeEvent Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.MouseClick Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.MouseHover Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.ScrollToVisible Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.SetValue Method
RadSlidingZone Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone Properties
RadSlidingZone Class See Also Send Feedback

The RadSlidingZone type exposes the following members.

Properties

Name | Description
AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Border | Gets the width of the table border. (Inherited from HtmlTable.)
Caption | Gets the caption of a table. (Inherited from HtmlTable.)
CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClickToOpen | Determines or set whether click on the tab is needed to open the sliding pane.
ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::.ClientSideLocator.)
ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Item | Gets requested row by index. (Inherited from HtmlTable.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingZone. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaneCount | Gets the sliding pane count.
Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SlideDirection | Gets the direction of pane sliding.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


ClickToOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.ClickToOpen Property
RadSlidingZone Class See Also Send Feedback
Determines or set whether click on the tab is needed to open the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ClickToOpen { get; set; }
Visual Basic (Declaration)
Public Property ClickToOpen As Boolean
Visual C++
public:
property bool ClickToOpen {
    bool get ();
    void set (bool value);
}

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.ClientSideLocator Property
RadSlidingZone Class See Also Send Feedback
Gets the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.LocatorExpression Property
RadSlidingZone Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadSlidingZone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


PaneCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.PaneCount Property
RadSlidingZone Class See Also Send Feedback
Gets the sliding pane count.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PaneCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaneCount As Integer
Visual C++
public:
property int PaneCount {
    int get ();
}

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


SlideDirection Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlidingZone..::.SlideDirection Property
RadSlidingZone Class See Also Send Feedback
Gets the direction of pane sliding.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SplitterSlideDirection SlideDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlideDirection As SplitterSlideDirection
Visual C++
public:
property SplitterSlideDirection SlideDirection {
    SplitterSlideDirection get ();
}

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Class
Members See Also Send Feedback
The content of Radspell dialog window.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSpellDialog : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadSpellDialog _
    Inherits HtmlContainerControl
Visual C++
public ref class RadSpellDialog : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadSpellDialog

See Also

RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Members
RadSpellDialog Class Constructors Methods Properties See Also Send Feedback

The RadSpellDialog type exposes the following members.

Constructors

Name | Description
RadSpellDialog | Overloaded.

Methods

Name | Description
AddCustomButtonClick | Clicks the add custom button.
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangeAllButtonClick | Clicks the change all button.
ChangeButtonClick | Clicks the change button.
Click | Overloaded.
CloseButtonClick | Clicks the close button.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
IgnoreAllButtonClick | Clicks the ignore all button.
IgnoreButtonClick | Clicks the ignore button.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UndoButtonClick | Clicks the undo button.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AddCustomButton | Gets spell add custom button.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChangeAllButton | Gets spell change all button.
ChangeButton | Gets spell change button.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadSpell. (Overrides HtmlControl..::.ClientSideLocator.)
CloseButton | Gets spell close button.
ControlToCheck | Gets/Sets the ID of the control to spell check..
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentText | Gets the current text in the TextContainer.
DialogOpenerSkin | Gets/Sets the skinof the DialogOpener.
DictionaryLanguage | Gets/Sets the dictionary language culture code.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
IgnoreAllButton | Gets spell ignore all button.
IgnoreButton | Gets spell ignore button.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSpellDialog. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedLanguage | Get the language currently selected in the drop down displayed when the SupportedLanguages language property is set.
SourceText | Gets/Sets the text of the TextSource object that RadSpell is attached to.
Spellchecked | Determines whether the spell checking for the target control has been completed. (the OnClientCheckFinished event has been fired).
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
UndoButton | Gets spell undo button.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Constructor
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
RadSpellDialog()()() | Initializes a new instance of the RadSpellDialog class.
RadSpellDialog(Element) | Initializes a new instance of the RadSpellDialog class.

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Constructor
RadSpellDialog Class See Also Send Feedback
Initializes a new instance of the RadSpellDialog class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSpellDialog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSpellDialog()

See Also

RadSpellDialog Class
RadSpellDialog Overload
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Constructor (Element)
RadSpellDialog Class See Also Send Feedback
Initializes a new instance of the RadSpellDialog class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSpellDialog(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSpellDialog(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSpellDialog.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSpellDialog Class
RadSpellDialog Overload
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Methods
RadSpellDialog Class See Also Send Feedback

The RadSpellDialog type exposes the following members.

Methods

Name | Description
AddCustomButtonClick | Clicks the add custom button.
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
ChangeAllButtonClick | Clicks the change all button.
ChangeButtonClick | Clicks the change button.
Click | Overloaded.
CloseButtonClick | Clicks the close button.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
IgnoreAllButtonClick | Clicks the ignore all button.
IgnoreButtonClick | Clicks the ignore button.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UndoButtonClick | Clicks the undo button.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


AddCustomButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.AddCustomButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the add custom button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void AddCustomButtonClick()
Visual Basic (Declaration)
Public Sub AddCustomButtonClick
Visual C++
public:
void AddCustomButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.AssignElement Method
RadSpellDialog Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.CallMethod Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.Capture Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


ChangeAllButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ChangeAllButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the change all button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangeAllButtonClick()
Visual Basic (Declaration)
Public Sub ChangeAllButtonClick
Visual C++
public:
void ChangeAllButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ChangeButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ChangeButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the change button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangeButtonClick()
Visual Basic (Declaration)
Public Sub ChangeButtonClick
Visual C++
public:
void ChangeButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.Click Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


CloseButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.CloseButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the close button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CloseButtonClick()
Visual Basic (Declaration)
Public Sub CloseButtonClick
Visual C++
public:
void CloseButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ControlAssert Method
RadSpellDialog Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.DragTo Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.GetValue Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


IgnoreAllButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.IgnoreAllButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the ignore all button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void IgnoreAllButtonClick()
Visual Basic (Declaration)
Public Sub IgnoreAllButtonClick
Visual C++
public:
void IgnoreAllButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


IgnoreButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.IgnoreButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the ignore button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void IgnoreButtonClick()
Visual Basic (Declaration)
Public Sub IgnoreButtonClick
Visual C++
public:
void IgnoreButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.InvokeEvent Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.MouseClick Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.MouseHover Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ScrollToVisible Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.SetValue Method
RadSpellDialog Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


UndoButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.UndoButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the undo button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UndoButtonClick()
Visual Basic (Declaration)
Public Sub UndoButtonClick
Visual C++
public:
void UndoButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog Properties
RadSpellDialog Class See Also Send Feedback

The RadSpellDialog type exposes the following members.

Properties

Name | Description
AddCustomButton | Gets spell add custom button.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChangeAllButton | Gets spell change all button.
ChangeButton | Gets spell change button.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadSpell. (Overrides HtmlControl..::.ClientSideLocator.)
CloseButton | Gets spell close button.
ControlToCheck | Gets/Sets the ID of the control to spell check..
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
CurrentText | Gets the current text in the TextContainer.
DialogOpenerSkin | Gets/Sets the skinof the DialogOpener.
DictionaryLanguage | Gets/Sets the dictionary language culture code.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
IgnoreAllButton | Gets spell ignore all button.
IgnoreButton | Gets spell ignore button.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSpellDialog. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedLanguage | Get the language currently selected in the drop down displayed when the SupportedLanguages language property is set.
SourceText | Gets/Sets the text of the TextSource object that RadSpell is attached to.
Spellchecked | Determines whether the spell checking for the target control has been completed. (the OnClientCheckFinished event has been fired).
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
UndoButton | Gets spell undo button.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


AddCustomButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.AddCustomButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell add custom button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton AddCustomButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddCustomButton As HtmlButton
Visual C++
public:
property HtmlButton^ AddCustomButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ChangeAllButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ChangeAllButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell change all button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton ChangeAllButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangeAllButton As HtmlButton
Visual C++
public:
property HtmlButton^ ChangeAllButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ChangeButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ChangeButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell change button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton ChangeButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangeButton As HtmlButton
Visual C++
public:
property HtmlButton^ ChangeButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ClientSideLocator Property
RadSpellDialog Class See Also Send Feedback
Gets the client-side code that defines the RadSpell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


CloseButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.CloseButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell close button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton CloseButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property CloseButton As HtmlButton
Visual C++
public:
property HtmlButton^ CloseButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ControlToCheck Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.ControlToCheck Property
RadSpellDialog Class See Also Send Feedback
Gets/Sets the ID of the control to spell check..

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ControlToCheck { get; set; }
Visual Basic (Declaration)
Public Property ControlToCheck As String
Visual C++
public:
property String^ ControlToCheck {
    String^ get ();
    void set (String^ value);
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


CurrentText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.CurrentText Property
RadSpellDialog Class See Also Send Feedback
Gets the current text in the TextContainer.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CurrentText { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentText As String
Visual C++
public:
property String^ CurrentText {
    String^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


DialogOpenerSkin Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.DialogOpenerSkin Property
RadSpellDialog Class See Also Send Feedback
Gets/Sets the skinof the DialogOpener.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DialogOpenerSkin { get; set; }
Visual Basic (Declaration)
Public Property DialogOpenerSkin As String
Visual C++
public:
property String^ DialogOpenerSkin {
    String^ get ();
    void set (String^ value);
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


DictionaryLanguage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.DictionaryLanguage Property
RadSpellDialog Class See Also Send Feedback
Gets/Sets the dictionary language culture code.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DictionaryLanguage { get; set; }
Visual Basic (Declaration)
Public Property DictionaryLanguage As String
Visual C++
public:
property String^ DictionaryLanguage {
    String^ get ();
    void set (String^ value);
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


IgnoreAllButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.IgnoreAllButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell ignore all button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton IgnoreAllButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property IgnoreAllButton As HtmlButton
Visual C++
public:
property HtmlButton^ IgnoreAllButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


IgnoreButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.IgnoreButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell ignore button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton IgnoreButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property IgnoreButton As HtmlButton
Visual C++
public:
property HtmlButton^ IgnoreButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.LocatorExpression Property
RadSpellDialog Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadSpellDialog.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


SelectedLanguage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.SelectedLanguage Property
RadSpellDialog Class See Also Send Feedback
Get the language currently selected in the drop down displayed when the SupportedLanguages language property is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedLanguage { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedLanguage As String
Visual C++
public:
property String^ SelectedLanguage {
    String^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


SourceText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.SourceText Property
RadSpellDialog Class See Also Send Feedback
Gets/Sets the text of the TextSource object that RadSpell is attached to.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SourceText { get; set; }
Visual Basic (Declaration)
Public Property SourceText As String
Visual C++
public:
property String^ SourceText {
    String^ get ();
    void set (String^ value);
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


Spellchecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.Spellchecked Property
RadSpellDialog Class See Also Send Feedback
Determines whether the spell checking for the target control has been completed. (the OnClientCheckFinished event has been fired).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Spellchecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property Spellchecked As Boolean
Visual C++
public:
property bool Spellchecked {
    bool get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


UndoButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSpellDialog..::.UndoButton Property
RadSpellDialog Class See Also Send Feedback
Gets spell undo button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlButton UndoButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property UndoButton As HtmlButton
Visual C++
public:
property HtmlButton^ UndoButton {
    HtmlButton^ get ();
}

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Class
Members See Also Send Feedback
The splitbar of the RadSplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSplitBar : HtmlTableCell
Visual Basic (Declaration)
Public Class RadSplitBar _
    Inherits HtmlTableCell
Visual C++
public ref class RadSplitBar : public HtmlTableCell

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableCell
Telerik.WebAii.Controls.Html..::.RadSplitBar

See Also

RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Members
RadSplitBar Class Constructors Methods Properties See Also Send Feedback

The RadSplitBar type exposes the following members.

Constructors

Name | Description
RadSplitBar | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
CollapsePane | Collapses the pane.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandPane | Expands the pane.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Resize | Resizes the previous or the next pane.
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the client-side code that defines the Radsplitter splitbar. (Overrides HtmlControl..::.ClientSideLocator.)
Collapsed | Determines whether the previous or next pane is collapsed.
CollapseMode | Gets/Sets the collapse mode of the splitbar.
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EnabledResize | Determines or set whether the resize is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
LeftPaneCollapsed | Determines whether the left pane is collapsed.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NextPaneHeight | Gets/Sets the next pane (right or down) height.
NextPaneId | Gets the next pane (right or down) Id.
NextPaneWidth | Gets/Sets the next pane (right or down) width.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PreviousPaneHeight | Gets/Sets the previous pane (left or upper) height.
PreviousPaneId | Gets the previous pane (left or upper) Id.
PreviousPaneWidth | Gets/Sets the previous pane (left or upper) width.
RightPaneCollapsed | Determines whether the right pane is collapsed.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Constructor
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
RadSplitBar()()() | Initializes a new instance of the RadSplitBar class.
RadSplitBar(Element) | Initializes a new instance of the RadSplitBar class.

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Constructor
RadSplitBar Class See Also Send Feedback
Initializes a new instance of the RadSplitBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSplitBar()

See Also

RadSplitBar Class
RadSplitBar Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Constructor (Element)
RadSplitBar Class See Also Send Feedback
Initializes a new instance of the RadSplitBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitBar(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSplitBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSplitBar Class
RadSplitBar Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Methods
RadSplitBar Class See Also Send Feedback

The RadSplitBar type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
CollapsePane | Collapses the pane.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandPane | Expands the pane.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Resize | Resizes the previous or the next pane.
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.AssignElement Method
RadSplitBar Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.CallMethod Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.Capture Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.Click Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


CollapsePane Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.CollapsePane Method
RadSplitBar Class See Also Send Feedback
Collapses the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CollapsePane(
    SplitterPaneType pane
)
Visual Basic (Declaration)
Public Sub CollapsePane ( _
    pane As SplitterPaneType _
)
Visual C++
public:
void CollapsePane(
    SplitterPaneType pane
)

Parameters

pane
Type: Telerik.WebAii.Controls.Html..::.SplitterPaneType

[Missing <param name="pane"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.CollapsePane(Telerik.WebAii.Controls.Html.SplitterPaneType)"]

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.DragTo Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


ExpandPane Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.ExpandPane Method
RadSplitBar Class See Also Send Feedback
Expands the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ExpandPane(
    SplitterPaneType pane
)
Visual Basic (Declaration)
Public Sub ExpandPane ( _
    pane As SplitterPaneType _
)
Visual C++
public:
void ExpandPane(
    SplitterPaneType pane
)

Parameters

pane
Type: Telerik.WebAii.Controls.Html..::.SplitterPaneType

[Missing <param name="pane"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.ExpandPane(Telerik.WebAii.Controls.Html.SplitterPaneType)"]

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.GetValue Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.InvokeEvent Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.MouseClick Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.MouseHover Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


Resize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.Resize Method
RadSplitBar Class See Also Send Feedback
Resizes the previous or the next pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resize(
    int previousPaneSize,
    int nextPaneSize,
    SplitterOrientation orientation
)
Visual Basic (Declaration)
Public Sub Resize ( _
    previousPaneSize As Integer, _
    nextPaneSize As Integer, _
    orientation As SplitterOrientation _
)
Visual C++
public:
void Resize(
    int previousPaneSize,
    int nextPaneSize,
    SplitterOrientation orientation
)

Parameters

previousPaneSize
Type: System..::.Int32

[Missing <param name="previousPaneSize"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.Resize(System.Int32,System.Int32,Telerik.WebAii.Controls.Html.SplitterOrientation)"]

nextPaneSize
Type: System..::.Int32

[Missing <param name="nextPaneSize"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.Resize(System.Int32,System.Int32,Telerik.WebAii.Controls.Html.SplitterOrientation)"]

orientation
Type: Telerik.WebAii.Controls.Html..::.SplitterOrientation

[Missing <param name="orientation"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.Resize(System.Int32,System.Int32,Telerik.WebAii.Controls.Html.SplitterOrientation)"]

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.ScrollToVisible Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.SetValue Method
RadSplitBar Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar Properties
RadSplitBar Class See Also Send Feedback

The RadSplitBar type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the client-side code that defines the Radsplitter splitbar. (Overrides HtmlControl..::.ClientSideLocator.)
Collapsed | Determines whether the previous or next pane is collapsed.
CollapseMode | Gets/Sets the collapse mode of the splitbar.
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
EnabledResize | Determines or set whether the resize is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
LeftPaneCollapsed | Determines whether the left pane is collapsed.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NextPaneHeight | Gets/Sets the next pane (right or down) height.
NextPaneId | Gets the next pane (right or down) Id.
NextPaneWidth | Gets/Sets the next pane (right or down) width.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PreviousPaneHeight | Gets/Sets the previous pane (left or upper) height.
PreviousPaneId | Gets the previous pane (left or upper) Id.
PreviousPaneWidth | Gets/Sets the previous pane (left or upper) width.
RightPaneCollapsed | Determines whether the right pane is collapsed.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.ClientSideLocator Property
RadSplitBar Class See Also Send Feedback
Get the client-side code that defines the Radsplitter splitbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


Collapsed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.Collapsed Property
RadSplitBar Class See Also Send Feedback
Determines whether the previous or next pane is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Collapsed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Collapsed As Boolean
Visual C++
public:
property bool Collapsed {
    bool get ();
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


CollapseMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.CollapseMode Property
RadSplitBar Class See Also Send Feedback
Gets/Sets the collapse mode of the splitbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SplitBarCollapseDirection CollapseMode { get; set; }
Visual Basic (Declaration)
Public Property CollapseMode As SplitBarCollapseDirection
Visual C++
public:
property SplitBarCollapseDirection CollapseMode {
    SplitBarCollapseDirection get ();
    void set (SplitBarCollapseDirection value);
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


EnabledResize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.EnabledResize Property
RadSplitBar Class See Also Send Feedback
Determines or set whether the resize is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EnabledResize { get; set; }
Visual Basic (Declaration)
Public Property EnabledResize As Boolean
Visual C++
public:
property bool EnabledResize {
    bool get ();
    void set (bool value);
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


LeftPaneCollapsed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.LeftPaneCollapsed Property
RadSplitBar Class See Also Send Feedback
Determines whether the left pane is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool LeftPaneCollapsed { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftPaneCollapsed As Boolean
Visual C++
public:
property bool LeftPaneCollapsed {
    bool get ();
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.LocatorExpression Property
RadSplitBar Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadSplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


NextPaneHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.NextPaneHeight Property
RadSplitBar Class See Also Send Feedback
Gets/Sets the next pane (right or down) height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int NextPaneHeight { get; set; }
Visual Basic (Declaration)
Public Property NextPaneHeight As Integer
Visual C++
public:
property int NextPaneHeight {
    int get ();
    void set (int value);
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


NextPaneId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.NextPaneId Property
RadSplitBar Class See Also Send Feedback
Gets the next pane (right or down) Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string NextPaneId { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextPaneId As String
Visual C++
public:
property String^ NextPaneId {
    String^ get ();
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


NextPaneWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.NextPaneWidth Property
RadSplitBar Class See Also Send Feedback
Gets/Sets the next pane (right or down) width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int NextPaneWidth { get; set; }
Visual Basic (Declaration)
Public Property NextPaneWidth As Integer
Visual C++
public:
property int NextPaneWidth {
    int get ();
    void set (int value);
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


PreviousPaneHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.PreviousPaneHeight Property
RadSplitBar Class See Also Send Feedback
Gets/Sets the previous pane (left or upper) height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PreviousPaneHeight { get; set; }
Visual Basic (Declaration)
Public Property PreviousPaneHeight As Integer
Visual C++
public:
property int PreviousPaneHeight {
    int get ();
    void set (int value);
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


PreviousPaneId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.PreviousPaneId Property
RadSplitBar Class See Also Send Feedback
Gets the previous pane (left or upper) Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string PreviousPaneId { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousPaneId As String
Visual C++
public:
property String^ PreviousPaneId {
    String^ get ();
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


PreviousPaneWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.PreviousPaneWidth Property
RadSplitBar Class See Also Send Feedback
Gets/Sets the previous pane (left or upper) width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PreviousPaneWidth { get; set; }
Visual Basic (Declaration)
Public Property PreviousPaneWidth As Integer
Visual C++
public:
property int PreviousPaneWidth {
    int get ();
    void set (int value);
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


RightPaneCollapsed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitBar..::.RightPaneCollapsed Property
RadSplitBar Class See Also Send Feedback
Determines whether the right pane is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool RightPaneCollapsed { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightPaneCollapsed As Boolean
Visual C++
public:
property bool RightPaneCollapsed {
    bool get ();
}

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


RadSplitter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Class
Members See Also Send Feedback
RadSplitter control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSplitter : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadSplitter _
    Inherits HtmlContainerControl
Visual C++
public ref class RadSplitter : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadSplitter

See Also

RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


RadSplitter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Members
RadSplitter Class Constructors Methods Properties See Also Send Feedback

The RadSplitter type exposes the following members.

Constructors

Name | Description
RadSplitter | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadSplitter. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the height of the splitter.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsNested | Determines whether the splitter is nested in another splitter.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Orientation | The orientation of the splitter.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaneCount | Gets the number of the splitter panes.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SplitBarCount | Gets the number of the splitter splitbars.
SplitterId | The splitter's id.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the width of the splitter.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


RadSplitter Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Constructor
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
RadSplitter()()() | Initializes a new instance of the RadSplitter class.
RadSplitter(Element) | Initializes a new instance of the RadSplitter class.

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


RadSplitter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Constructor
RadSplitter Class See Also Send Feedback
Initializes a new instance of the RadSplitter class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSplitter()

See Also

RadSplitter Class
RadSplitter Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitter Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Constructor (Element)
RadSplitter Class See Also Send Feedback
Initializes a new instance of the RadSplitter class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitter(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSplitter(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitter.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSplitter Class
RadSplitter Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Methods
RadSplitter Class See Also Send Feedback

The RadSplitter type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.AssignElement Method
RadSplitter Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.CallMethod Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.Capture Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.Click Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.ControlAssert Method
RadSplitter Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.DragTo Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.GetValue Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.InvokeEvent Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.MouseClick Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.MouseHover Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.ScrollToVisible Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.SetValue Method
RadSplitter Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


RadSplitter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter Properties
RadSplitter Class See Also Send Feedback

The RadSplitter type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadSplitter. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the height of the splitter.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsNested | Determines whether the splitter is nested in another splitter.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Orientation | The orientation of the splitter.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PaneCount | Gets the number of the splitter panes.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SplitBarCount | Gets the number of the splitter splitbars.
SplitterId | The splitter's id.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the width of the splitter.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.ClientSideLocator Property
RadSplitter Class See Also Send Feedback
Gets the client-side code that defines the RadSplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.Height Property
RadSplitter Class See Also Send Feedback
Gets/Sets the height of the splitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


IsNested Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.IsNested Property
RadSplitter Class See Also Send Feedback
Determines whether the splitter is nested in another splitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsNested { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNested As Boolean
Visual C++
public:
property bool IsNested {
    bool get ();
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.LocatorExpression Property
RadSplitter Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadSplitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.Orientation Property
RadSplitter Class See Also Send Feedback
The orientation of the splitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SplitterOrientation Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As SplitterOrientation
Visual C++
public:
property SplitterOrientation Orientation {
    SplitterOrientation get ();
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


PaneCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.PaneCount Property
RadSplitter Class See Also Send Feedback
Gets the number of the splitter panes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int PaneCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaneCount As Integer
Visual C++
public:
property int PaneCount {
    int get ();
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


SplitBarCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.SplitBarCount Property
RadSplitter Class See Also Send Feedback
Gets the number of the splitter splitbars.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SplitBarCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitBarCount As Integer
Visual C++
public:
property int SplitBarCount {
    int get ();
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


SplitterId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.SplitterId Property
RadSplitter Class See Also Send Feedback
The splitter's id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SplitterId { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitterId As String
Visual C++
public:
property String^ SplitterId {
    String^ get ();
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitter..::.Width Property
RadSplitter Class See Also Send Feedback
Gets/Sets the width of the splitter.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


RadTab Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Class
Members See Also Send Feedback
Represents the RadTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTab : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadTab _
    Inherits HtmlContainerControl
Visual C++
public ref class RadTab : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadTab

See Also

RadTab Members
Telerik.WebAii.Controls.Html Namespace


RadTab Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Members
RadTab Class Constructors Methods Properties See Also Send Feedback

The RadTab type exposes the following members.

Constructors

Name | Description
RadTab | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadTab control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FindTab | Finds sub-tab by given predicate.
FindTabByText | Finds sub-tab having given text.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the tab.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Unselect | UnSelect the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether this tab is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HasChildren | Check whether the item has children.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the tab.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Level | Get the level of the tab.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this tab.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get or set whether this tab is selected.
ShouldNavigate | Check whether the tab should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TabCount | Returns the tabs collection of the tab.
Tabs | Returns the tabs collection of the tab.
TabValue | Get the value set for this tab.
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this tab.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the tab is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


RadTab Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Constructor
RadTab Class See Also Send Feedback

Overload List

Name | Description
RadTab()()() | Initializes a new instance of the RadTab class.
RadTab(Element) | Initializes a new instance of the RadTab class.

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


RadTab Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Constructor
RadTab Class See Also Send Feedback
Initializes a new instance of the RadTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTab()

See Also

RadTab Class
RadTab Overload
Telerik.WebAii.Controls.Html Namespace


RadTab Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Constructor (Element)
RadTab Class See Also Send Feedback
Initializes a new instance of the RadTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTab(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTab.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTab Class
RadTab Overload
Telerik.WebAii.Controls.Html Namespace


RadTab Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Methods
RadTab Class See Also Send Feedback

The RadTab type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadTab control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FindTab | Finds sub-tab by given predicate.
FindTabByText | Finds sub-tab having given text.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the tab.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Unselect | UnSelect the item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.AssignElement Method
RadTab Class See Also Send Feedback
Assign the DOM element to be the RadTab control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTab.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.CallMethod Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Capture Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Click Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Navigate if NavigateUrl is set, Click otherwise. (Overrides HtmlControl..::.Click()()().)
Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click(Boolean).)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Click Method
RadTab Class See Also Send Feedback
Navigate if NavigateUrl is set, Click otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click()
Visual Basic (Declaration)
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadTab Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Click Method (Boolean)
RadTab Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic (Declaration)
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::.Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTab.Click(System.Boolean)"]

See Also

RadTab Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.ControlAssert Method
RadTab Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.DragTo Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


FindTab Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.FindTab Method
RadTab Class See Also Send Feedback
Finds sub-tab by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab FindTab(
    Predicate<RadTab> predicate
)
Visual Basic (Declaration)
Public Function FindTab ( _
    predicate As Predicate(Of RadTab) _
) As RadTab
Visual C++
public:
RadTab^ FindTab(
    Predicate<RadTab^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTab >)>)
The predicate to seacrh for.

Return Value

The sub-tab mathing the search criteria.

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


FindTabByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.FindTabByText Method
RadTab Class See Also Send Feedback
Finds sub-tab having given text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab FindTabByText(
    string tabText
)
Visual Basic (Declaration)
Public Function FindTabByText ( _
    tabText As String _
) As RadTab
Visual C++
public:
RadTab^ FindTabByText(
    String^ tabText
)

Parameters

tabText
Type: System..::.String
The tab text to search for.

Return Value

Sub-tab having given text.

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.GetValue Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.InvokeEvent Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.MouseClick Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.MouseHover Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Navigate Method
RadTab Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Navigate()
Visual Basic (Declaration)
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.ScrollToVisible Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Select Method
RadTab Class See Also Send Feedback
Select the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.SetValue Method
RadTab Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Unselect Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Unselect Method
RadTab Class See Also Send Feedback
UnSelect the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Unselect()
Visual Basic (Declaration)
Public Sub Unselect
Visual C++
public:
void Unselect()

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


RadTab Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab Properties
RadTab Class See Also Send Feedback

The RadTab type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether this tab is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HasChildren | Check whether the item has children.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the tab.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Level | Get the level of the tab.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this tab.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get or set whether this tab is selected.
ShouldNavigate | Check whether the tab should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TabCount | Returns the tabs collection of the tab.
Tabs | Returns the tabs collection of the tab.
TabValue | Get the value set for this tab.
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this tab.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Visible | Get whether the tab is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.ClientSideLocator Property
RadTab Class See Also Send Feedback
Get the Client side locator - call method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Enabled Property
RadTab Class See Also Send Feedback
Get or set whether this tab is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


HasChildren Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.HasChildren Property
RadTab Class See Also Send Feedback
Check whether the item has children.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasChildren { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
Visual C++
public:
property bool HasChildren {
    bool get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Index Property
RadTab Class See Also Send Feedback
Get the index of the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Level Property
RadTab Class See Also Send Feedback
Get the level of the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.LocatorExpression Property
RadTab Class See Also Send Feedback
Get the FindParam that defines the pattern for a menu item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


NavigateUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.NavigateUrl Property
RadTab Class See Also Send Feedback
Get or set the navigate url of this tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string NavigateUrl { get; set; }
Visual Basic (Declaration)
Public Property NavigateUrl As String
Visual C++
public:
property String^ NavigateUrl {
    String^ get ();
    void set (String^ value);
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Selected Property
RadTab Class See Also Send Feedback
Get or set whether this tab is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; set; }
Visual Basic (Declaration)
Public Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


ShouldNavigate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.ShouldNavigate Property
RadTab Class See Also Send Feedback
Check whether the tab should navigate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShouldNavigate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShouldNavigate As Boolean
Visual C++
public:
property bool ShouldNavigate {
    bool get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


TabCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.TabCount Property
RadTab Class See Also Send Feedback
Returns the tabs collection of the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int TabCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabCount As Integer
Visual C++
public:
property int TabCount {
    int get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Tabs Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Tabs Property
RadTab Class See Also Send Feedback
Returns the tabs collection of the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTab> Tabs { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tabs As IList(Of RadTab)
Visual C++
public:
property IList<RadTab^>^ Tabs {
    IList<RadTab^>^ get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


TabValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.TabValue Property
RadTab Class See Also Send Feedback
Get the value set for this tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TabValue { get; set; }
Visual Basic (Declaration)
Public Property TabValue As String
Visual C++
public:
property String^ TabValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Text Property
RadTab Class See Also Send Feedback
Get the text of this tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTab..::.Visible Property
RadTab Class See Also Send Feedback
Get whether the tab is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Class
Members See Also Send Feedback
Represents the RadTabStrip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTabStrip : HtmlDiv
Visual Basic (Declaration)
Public Class RadTabStrip _
    Inherits HtmlDiv
Visual C++
public ref class RadTabStrip : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadTabStrip

See Also

RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Members
RadTabStrip Class Constructors Methods Properties See Also Send Feedback

The RadTabStrip type exposes the following members.

Constructors

Name | Description
RadTabStrip | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the Tabstrip control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disable the TabStrip.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enable the TabStrip.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FindTab | Find tab by given predicate.
FindTabByText | Find tab by given Text.
FindTabByValue | Find tab by Value.
FindTabs | Find tabs by given predicate.
FindTabsByLevel | Get the list of tabs by the given level.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InitializeTabs | Initializes tabs of the RadTabStrip.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllTabs | Get a list of all the tabs.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of this TabStrip control.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Returns whether the tab strip is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HasMultiPage | Get whether the TabStrip has associated MultiPage.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MultiPageId | The client id of the associated MultiPage control.
MultiPageSelectedIndex | Get or set the index of the selected MultiPage page view. Returns '-1' if there is no MultiPage associated with the TabStrip.
MultiPageViewsCount | Get the MultiPage views count or -1 if there is no MultiPage associated with the TabStrip.
MultiPageVisible | Get or set whether the MultiPage control is visible.
OrientationType | Tabstrip orientation.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootTabs | Get a list of the TabStrip root tabs.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Constructor
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
RadTabStrip()()() | Initializes a new instance of the RadTabStrip class.
RadTabStrip(Element) | Initializes a new instance of the RadTabStrip class.

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Constructor
RadTabStrip Class See Also Send Feedback
Initializes a new instance of the RadTabStrip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTabStrip()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTabStrip()

See Also

RadTabStrip Class
RadTabStrip Overload
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Constructor (Element)
RadTabStrip Class See Also Send Feedback
Initializes a new instance of the RadTabStrip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTabStrip(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTabStrip(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTabStrip Class
RadTabStrip Overload
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Methods
RadTabStrip Class See Also Send Feedback

The RadTabStrip type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the Tabstrip control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disable the TabStrip.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enable the TabStrip.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
FindTab | Find tab by given predicate.
FindTabByText | Find tab by given Text.
FindTabByValue | Find tab by Value.
FindTabs | Find tabs by given predicate.
FindTabsByLevel | Get the list of tabs by the given level.
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InitializeTabs | Initializes tabs of the RadTabStrip.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.AssignElement Method
RadTabStrip Class See Also Send Feedback
Assign the DOM element to be the Tabstrip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.CallMethod Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.Capture Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.Click Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.ControlAssert Method
RadTabStrip Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.Disable Method
RadTabStrip Class See Also Send Feedback
Disable the TabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.DragTo Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.Enable Method
RadTabStrip Class See Also Send Feedback
Enable the TabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTab Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.FindTab Method
RadTabStrip Class See Also Send Feedback
Find tab by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab FindTab(
    Predicate<RadTab> predicate
)
Visual Basic (Declaration)
Public Function FindTab ( _
    predicate As Predicate(Of RadTab) _
) As RadTab
Visual C++
public:
RadTab^ FindTab(
    Predicate<RadTab^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTab >)>)
The predicate used as a search criteria.

Return Value

The tab found or 'null' if no tab matches the given search criteria.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.FindTabByText Method
RadTabStrip Class See Also Send Feedback
Find tab by given Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab FindTabByText(
    string tabText
)
Visual Basic (Declaration)
Public Function FindTabByText ( _
    tabText As String _
) As RadTab
Visual C++
public:
RadTab^ FindTabByText(
    String^ tabText
)

Parameters

tabText
Type: System..::.String

[Missing <param name="tabText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByText(System.String)"]

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.FindTabByValue Method
RadTabStrip Class See Also Send Feedback
Find tab by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTab FindTabByValue(
    string tabValue
)
Visual Basic (Declaration)
Public Function FindTabByValue ( _
    tabValue As String _
) As RadTab
Visual C++
public:
RadTab^ FindTabByValue(
    String^ tabValue
)

Parameters

tabValue
Type: System..::.String

[Missing <param name="tabValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByValue(System.String)"]

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabs Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.FindTabs Method
RadTabStrip Class See Also Send Feedback
Find tabs by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTab> FindTabs(
    Predicate<RadTab> predicate
)
Visual Basic (Declaration)
Public Function FindTabs ( _
    predicate As Predicate(Of RadTab) _
) As IList(Of RadTab)
Visual C++
public:
IList<RadTab^>^ FindTabs(
    Predicate<RadTab^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTab >)>)
The predicate used as a search criteria.

Return Value

The list of found tabs or empty list if no tab matches the given search criteria.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabsByLevel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.FindTabsByLevel Method
RadTabStrip Class See Also Send Feedback
Get the list of tabs by the given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTab> FindTabsByLevel(
    int level
)
Visual Basic (Declaration)
Public Function FindTabsByLevel ( _
    level As Integer _
) As IList(Of RadTab)
Visual C++
public:
IList<RadTab^>^ FindTabsByLevel(
    int level
)

Parameters

level
Type: System..::.Int32
The level to search the tabs for.

Return Value

The list of tabs by the given level.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.GetValue Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


InitializeTabs Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.InitializeTabs Method
RadTabStrip Class See Also Send Feedback
Initializes tabs of the RadTabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InitializeTabs()
Visual Basic (Declaration)
Public Sub InitializeTabs
Visual C++
public:
void InitializeTabs()

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.InvokeEvent Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.MouseClick Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.MouseHover Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.ScrollToVisible Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.SetValue Method
RadTabStrip Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip Properties
RadTabStrip Class See Also Send Feedback

The RadTabStrip type exposes the following members.

Properties

Name | Description
AllTabs | Get a list of all the tabs.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The client id of this TabStrip control.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Returns whether the tab strip is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HasMultiPage | Get whether the TabStrip has associated MultiPage.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MultiPageId | The client id of the associated MultiPage control.
MultiPageSelectedIndex | Get or set the index of the selected MultiPage page view. Returns '-1' if there is no MultiPage associated with the TabStrip.
MultiPageViewsCount | Get the MultiPage views count or -1 if there is no MultiPage associated with the TabStrip.
MultiPageVisible | Get or set whether the MultiPage control is visible.
OrientationType | Tabstrip orientation.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootTabs | Get a list of the TabStrip root tabs.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


AllTabs Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.AllTabs Property
RadTabStrip Class See Also Send Feedback
Get a list of all the tabs.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTab> AllTabs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllTabs As IList(Of RadTab)
Visual C++
public:
property IList<RadTab^>^ AllTabs {
    IList<RadTab^>^ get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.ClientId Property
RadTabStrip Class See Also Send Feedback
The client id of this TabStrip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.ClientSideLocator Property
RadTabStrip Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.Enabled Property
RadTabStrip Class See Also Send Feedback
Returns whether the tab strip is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


HasMultiPage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.HasMultiPage Property
RadTabStrip Class See Also Send Feedback
Get whether the TabStrip has associated MultiPage.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasMultiPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasMultiPage As Boolean
Visual C++
public:
property bool HasMultiPage {
    bool get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.LocatorExpression Property
RadTabStrip Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


MultiPageId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.MultiPageId Property
RadTabStrip Class See Also Send Feedback
The client id of the associated MultiPage control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string MultiPageId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MultiPageId As String
Visual C++
public:
property String^ MultiPageId {
    String^ get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


MultiPageSelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.MultiPageSelectedIndex Property
RadTabStrip Class See Also Send Feedback
Get or set the index of the selected MultiPage page view. Returns '-1' if there is no MultiPage associated with the TabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MultiPageSelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property MultiPageSelectedIndex As Integer
Visual C++
public:
property int MultiPageSelectedIndex {
    int get ();
    void set (int value);
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


MultiPageViewsCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.MultiPageViewsCount Property
RadTabStrip Class See Also Send Feedback
Get the MultiPage views count or -1 if there is no MultiPage associated with the TabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MultiPageViewsCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property MultiPageViewsCount As Integer
Visual C++
public:
property int MultiPageViewsCount {
    int get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


MultiPageVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.MultiPageVisible Property
RadTabStrip Class See Also Send Feedback
Get or set whether the MultiPage control is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool MultiPageVisible { get; set; }
Visual Basic (Declaration)
Public Property MultiPageVisible As Boolean
Visual C++
public:
property bool MultiPageVisible {
    bool get ();
    void set (bool value);
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


OrientationType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.OrientationType Property
RadTabStrip Class See Also Send Feedback
Tabstrip orientation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TabStripOrientationType OrientationType { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrientationType As TabStripOrientationType
Visual C++
public:
property TabStripOrientationType OrientationType {
    TabStripOrientationType get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


RootTabs Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabStrip..::.RootTabs Property
RadTabStrip Class See Also Send Feedback
Get a list of the TabStrip root tabs.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTab> RootTabs { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootTabs As IList(Of RadTab)
Visual C++
public:
property IList<RadTab^>^ RootTabs {
    IList<RadTab^>^ get ();
}

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


RadTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox Class
Members See Also Send Feedback
The HtmlControl wrapper for RadTextBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTextBox : RadInput
Visual Basic (Declaration)
Public Class RadTextBox _
    Inherits RadInput
Visual C++
public ref class RadTextBox : public RadInput

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadInput
Telerik.WebAii.Controls.Html..::.RadTextBox

See Also

RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox Members
RadTextBox Class Constructors Methods Properties See Also Send Feedback

The RadTextBox type exposes the following members.

Constructors

Name | Description
RadTextBox | Initializes a new instance of the RadTextBox class

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides RadInput..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
ButtonClick | TextBox built-in button click. Throws exception if the button is not enabled.
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsInPasswordMode | Return whether the TextBox is in password mode.
IsMultiline | Get whether the text box is in multi-line mode.
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
LabelMessage | Return the TextBox label message.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShowButton | Return whether the TextBox built-in button is enabled.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox Constructor
RadTextBox Class See Also Send Feedback
Initializes a new instance of the RadTextBox class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTextBox()

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox Methods
RadTextBox Class See Also Send Feedback

The RadTextBox type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides RadInput..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
ButtonClick | TextBox built-in button click. Throws exception if the button is not enabled.
CallMethod | Overloaded.
Capture | Overloaded.
Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Click | Overloaded.
ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Disable | Disables the input. (Inherited from RadInput.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the input. (Inherited from RadInput.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
TypeText | Overloaded.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.AssignElement Method
RadTextBox Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


ButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.ButtonClick Method
RadTextBox Class See Also Send Feedback
TextBox built-in button click. Throws exception if the button is not enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ButtonClick()
Visual Basic (Declaration)
Public Sub ButtonClick
Visual C++
public:
void ButtonClick()

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.CallMethod Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.Capture Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.Click Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.DragTo Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.GetValue Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.InvokeEvent Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.MouseClick Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.MouseHover Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.ScrollToVisible Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.SetValue Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.TypeText Method
RadTextBox Class See Also Send Feedback

Overload List

Name | Description
TypeText(String) | Types text into the input. (Inherited from RadInput.)
TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox Properties
RadTextBox Class See Also Send Feedback

The RadTextBox type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | Get the client Id of the input control. (Inherited from RadInput.)
ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
InputValue | Get or set the client-side input value. (Inherited from RadInput.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
IsInPasswordMode | Return whether the TextBox is in password mode.
IsMultiline | Get whether the text box is in multi-line mode.
IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
LabelMessage | Return the TextBox label message.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShowButton | Return whether the TextBox built-in button is enabled.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


IsInPasswordMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.IsInPasswordMode Property
RadTextBox Class See Also Send Feedback
Return whether the TextBox is in password mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsInPasswordMode { get; set; }
Visual Basic (Declaration)
Public Property IsInPasswordMode As Boolean
Visual C++
public:
property bool IsInPasswordMode {
    bool get ();
    void set (bool value);
}

Return Value

True, if the TextBox is in password mode, otherwise 'false'.

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


IsMultiline Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.IsMultiline Property
RadTextBox Class See Also Send Feedback
Get whether the text box is in multi-line mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMultiline { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMultiline As Boolean
Visual C++
public:
property bool IsMultiline {
    bool get ();
}

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


LabelMessage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.LabelMessage Property
RadTextBox Class See Also Send Feedback
Return the TextBox label message.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelMessage { get; set; }
Visual Basic (Declaration)
Public Property LabelMessage As String
Visual C++
public:
property String^ LabelMessage {
    String^ get ();
    void set (String^ value);
}

Return Value

The TextBox label message if its built-in label is enabled, 'null' otherwise.

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


ShowButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTextBox..::.ShowButton Property
RadTextBox Class See Also Send Feedback
Return whether the TextBox built-in button is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShowButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowButton As Boolean
Visual C++
public:
property bool ShowButton {
    bool get ();
}

Return Value

True, if the TextBox built-in button is enabled, 'false' otherwise.

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Class
Members See Also Send Feedback
Represents the RadTimePicker for ASP.NET AJAX control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTimePicker : RadPicker
Visual Basic (Declaration)
Public Class RadTimePicker _
    Inherits RadPicker
Visual C++
public ref class RadTimePicker : public RadPicker

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadPicker
Telerik.WebAii.Controls.Html..::.RadTimePicker

See Also

RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Members
RadTimePicker Class Constructors Methods Properties See Also Send Feedback

The RadTimePicker type exposes the following members.

Constructors

Name | Description
RadTimePicker | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker. (Inherited from RadPicker.)
PickerType | Gets the Picker control type. (Inherited from RadPicker.)
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TimeView | Gets the TimeView wrapper of the picker.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Constructor
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
RadTimePicker()()() | Initializes a new instance of the RadTimePicker class.
RadTimePicker(Element) | Initializes a new instance of the RadTimePicker class.

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Constructor
RadTimePicker Class See Also Send Feedback
Initializes a new instance of the RadTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTimePicker()

See Also

RadTimePicker Class
RadTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Constructor (Element)
RadTimePicker Class See Also Send Feedback
Initializes a new instance of the RadTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimePicker(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTimePicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTimePicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTimePicker Class
RadTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Methods
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.CallMethod Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Capture Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Click Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.DragTo Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.GetValue Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.InvokeEvent Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.MouseClick Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.MouseHover Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.ScrollToVisible Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.SetValue Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Properties
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
PickerId | The id of the picker. (Inherited from RadPicker.)
PickerType | Gets the Picker control type. (Inherited from RadPicker.)
PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TimeView | Gets the TimeView wrapper of the picker.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


TimeView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.TimeView Property
RadTimePicker Class See Also Send Feedback
Gets the TimeView wrapper of the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimeView TimeView { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeView As RadTimeView
Visual C++
public:
property RadTimeView^ TimeView {
    RadTimeView^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadTimeView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Class
Members See Also Send Feedback
Represents the RadDateTimePicker/RadTimePicker for ASP.NET AJAX TimeView control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTimeView : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadTimeView _
    Inherits HtmlContainerControl
Visual C++
public ref class RadTimeView : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadTimeView

See Also

RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


RadTimeView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Members
RadTimeView Class Constructors Methods Properties See Also Send Feedback

The RadTimeView type exposes the following members.

Constructors

Name | Description
RadTimeView | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectTime | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the TimeView control. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TimeFormat | Gets the TimeFormat that the TimeView is currently using.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


RadTimeView Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Constructor
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
RadTimeView()()() | Initializes a new instance of the RadTimeView class.
RadTimeView(Element) | Initializes a new instance of the RadTimeView class.

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


RadTimeView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Constructor
RadTimeView Class See Also Send Feedback
Initializes a new instance of the RadTimeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTimeView()

See Also

RadTimeView Class
RadTimeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTimeView Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Constructor (Element)
RadTimeView Class See Also Send Feedback
Initializes a new instance of the RadTimeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimeView(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTimeView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTimeView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTimeView Class
RadTimeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTimeView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Methods
RadTimeView Class See Also Send Feedback

The RadTimeView type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SelectTime | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.AssignElement Method
RadTimeView Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The element.

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.CallMethod Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.Capture Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.Click Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.DragTo Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.GetValue Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.InvokeEvent Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.MouseClick Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.MouseHover Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.ScrollToVisible Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


SelectTime Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.SelectTime Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
SelectTime(DateTime) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time, the current Culture and TimeFormat.
SelectTime(String) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time string that is parsed with the help of the current Culture.
SelectTime(DateTime, String, String) | Clicks on a time cell in the TimeView.

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


SelectTime Method (DateTime)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.SelectTime Method (DateTime)
RadTimeView Class See Also Send Feedback
Simulates click on a time cell in the TimeView. The cell is identified by the given selected time, the current Culture and TimeFormat.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectTime(
    DateTime selectedTime
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    selectedTime As DateTime _
)
Visual C++
public:
void SelectTime(
    DateTime selectedTime
)

Parameters

selectedTime
Type: System..::.DateTime
The time to be selected.

See Also

RadTimeView Class
SelectTime Overload
Telerik.WebAii.Controls.Html Namespace


SelectTime Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.SelectTime Method (String)
RadTimeView Class See Also Send Feedback
Simulates click on a time cell in the TimeView. The cell is identified by the given selected time string that is parsed with the help of the current Culture.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectTime(
    string selectedTimeValue
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    selectedTimeValue As String _
)
Visual C++
public:
void SelectTime(
    String^ selectedTimeValue
)

Parameters

selectedTimeValue
Type: System..::.String
The time to be selected.

See Also

RadTimeView Class
SelectTime Overload
Telerik.WebAii.Controls.Html Namespace


SelectTime Method (DateTime, String, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.SelectTime Method (DateTime, String, String)
RadTimeView Class See Also Send Feedback
Clicks on a time cell in the TimeView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectTime(
    DateTime selectedTime,
    string currentCulture,
    string currentTimeFormat
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    selectedTime As DateTime, _
    currentCulture As String, _
    currentTimeFormat As String _
)
Visual C++
public:
void SelectTime(
    DateTime selectedTime,
    String^ currentCulture,
    String^ currentTimeFormat
)

Parameters

selectedTime
Type: System..::.DateTime
The time to be selected.
currentCulture
Type: System..::.String
The culture whitch the TimeView is currently using.
currentTimeFormat
Type: System..::.String
The time format whitch the TimeView is currently using.

See Also

RadTimeView Class
SelectTime Overload
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.SetValue Method
RadTimeView Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


RadTimeView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView Properties
RadTimeView Class See Also Send Feedback

The RadTimeView type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | The client-side locator of the TimeView control. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Culture | Gets the culture which the picker is using.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the item locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
TimeFormat | Gets the TimeFormat that the TimeView is currently using.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.ClientSideLocator Property
RadTimeView Class See Also Send Feedback
The client-side locator of the TimeView control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


Culture Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.Culture Property
RadTimeView Class See Also Send Feedback
Gets the culture which the picker is using.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Culture { get; }
Visual Basic (Declaration)
Public ReadOnly Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
}

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.LocatorExpression Property
RadTimeView Class See Also Send Feedback
Get the item locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


TimeFormat Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimeView..::.TimeFormat Property
RadTimeView Class See Also Send Feedback
Gets the TimeFormat that the TimeView is currently using.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TimeFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeFormat As String
Visual C++
public:
property String^ TimeFormat {
    String^ get ();
}

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


RadToolBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Class
Members See Also Send Feedback
Represents the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBar : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadToolBar _
    Inherits HtmlContainerControl
Visual C++
public ref class RadToolBar : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadToolBar

See Also

RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


RadToolBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Members
RadToolBar Class Constructors Methods Properties See Also Send Feedback

The RadToolBar type exposes the following members.

Constructors

Name | Description
RadToolBar | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by text.
FindItemByValue | Finds item by value.
FindItems | Find items by given predicate.
FindItemsByLevel | Find items by given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllItems | Get all the toolbar items.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Orientation | Get or set ToolBar orientation client-side: '0' if the toolbar is horizontal, '1' if it is vertical.
OrientationType | Get or set the ToolBar Orientation type.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootItems | Get the root items of the toolbar.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


RadToolBar Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Constructor
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
RadToolBar()()() | Initializes a new instance of the RadToolBar class.
RadToolBar(Element) | Initializes a new instance of the RadToolBar class.

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


RadToolBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Constructor
RadToolBar Class See Also Send Feedback
Initializes a new instance of the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBar()

See Also

RadToolBar Class
RadToolBar Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBar Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Constructor (Element)
RadToolBar Class See Also Send Feedback
Initializes a new instance of the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBar(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBar Class
RadToolBar Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Methods
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Find item by given predicate.
FindItemByText | Finds item by text.
FindItemByValue | Finds item by value.
FindItems | Find items by given predicate.
FindItemsByLevel | Find items by given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.AssignElement Method
RadToolBar Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.CallMethod Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Capture Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Click Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.ControlAssert Method
RadToolBar Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.DragTo Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.FindItem Method
RadToolBar Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarItem FindItem(
    Predicate<RadToolBarItem> predicate
)
Visual Basic (Declaration)
Public Function FindItem ( _
    predicate As Predicate(Of RadToolBarItem) _
) As RadToolBarItem
Visual C++
public:
RadToolBarItem^ FindItem(
    Predicate<RadToolBarItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadToolBarItem >)>)
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.FindItemByText Method
RadToolBar Class See Also Send Feedback
Finds item by text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarItem FindItemByText(
    string itemText
)
Visual Basic (Declaration)
Public Function FindItemByText ( _
    itemText As String _
) As RadToolBarItem
Visual C++
public:
RadToolBarItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::.String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByText(System.String)"]

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.FindItemByValue Method
RadToolBar Class See Also Send Feedback
Finds item by value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarItem FindItemByValue(
    string itemValue
)
Visual Basic (Declaration)
Public Function FindItemByValue ( _
    itemValue As String _
) As RadToolBarItem
Visual C++
public:
RadToolBarItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::.String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByValue(System.String)"]

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.FindItems Method
RadToolBar Class See Also Send Feedback
Find items by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadToolBarItem> FindItems(
    Predicate<RadToolBarItem> predicate
)
Visual Basic (Declaration)
Public Function FindItems ( _
    predicate As Predicate(Of RadToolBarItem) _
) As IList(Of RadToolBarItem)
Visual C++
public:
IList<RadToolBarItem^>^ FindItems(
    Predicate<RadToolBarItem^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadToolBarItem >)>)
The predicate used as a search criteria.

Return Value

The list of items matching the search.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemsByLevel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.FindItemsByLevel Method
RadToolBar Class See Also Send Feedback
Find items by given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadToolBarItem> FindItemsByLevel(
    int level
)
Visual Basic (Declaration)
Public Function FindItemsByLevel ( _
    level As Integer _
) As IList(Of RadToolBarItem)
Visual C++
public:
IList<RadToolBarItem^>^ FindItemsByLevel(
    int level
)

Parameters

level
Type: System..::.Int32
The level to search for.

Return Value

The list of items matching the search.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.GetValue Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.InvokeEvent Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.MouseClick Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.MouseHover Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.ScrollToVisible Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.SetValue Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


RadToolBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Properties
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Properties

Name | Description
AllItems | Get all the toolbar items.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Orientation | Get or set ToolBar orientation client-side: '0' if the toolbar is horizontal, '1' if it is vertical.
OrientationType | Get or set the ToolBar Orientation type.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootItems | Get the root items of the toolbar.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


AllItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.AllItems Property
RadToolBar Class See Also Send Feedback
Get all the toolbar items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadToolBarItem> AllItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllItems As IList(Of RadToolBarItem)
Visual C++
public:
property IList<RadToolBarItem^>^ AllItems {
    IList<RadToolBarItem^>^ get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.ClientSideLocator Property
RadToolBar Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.LocatorExpression Property
RadToolBar Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Orientation Property
RadToolBar Class See Also Send Feedback
Get or set ToolBar orientation client-side: '0' if the toolbar is horizontal, '1' if it is vertical.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Integer
Visual C++
public:
property int Orientation {
    int get ();
    void set (int value);
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


OrientationType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.OrientationType Property
RadToolBar Class See Also Send Feedback
Get or set the ToolBar Orientation type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToolBarOrientationType OrientationType { get; set; }
Visual Basic (Declaration)
Public Property OrientationType As ToolBarOrientationType
Visual C++
public:
property ToolBarOrientationType OrientationType {
    ToolBarOrientationType get ();
    void set (ToolBarOrientationType value);
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


RootItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.RootItems Property
RadToolBar Class See Also Send Feedback
Get the root items of the toolbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadToolBarItem> RootItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootItems As IList(Of RadToolBarItem)
Visual C++
public:
property IList<RadToolBarItem^>^ RootItems {
    IList<RadToolBarItem^>^ get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Class
Members See Also Send Feedback
Represents the RadToolBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBarButton : RadToolBarItem
Visual Basic (Declaration)
Public Class RadToolBarButton _
    Inherits RadToolBarItem
Visual C++
public ref class RadToolBarButton : public RadToolBarItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadToolBarItem
Telerik.WebAii.Controls.Html..::.RadToolBarButton

See Also

RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Members
RadToolBarButton Class Constructors Methods Properties See Also Send Feedback

The RadToolBarButton type exposes the following members.

Constructors

Name | Description
RadToolBarButton | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
CallMethod | Overloaded.
Capture | Overloaded.
Check | Check the toolbar item.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item. (Inherited from RadToolBarItem.)
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UNCheck | UnCheck the toolbar item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllowSelfUNCheck | Gets whether the toolbar item AllowSelfUnCheck property is set.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Checked | Get whether the toolbar item is checked.
CheckOnClick | Get whether the toolbar item CheckOnClick property is set.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Group | Gets the name of the group to which the item belongs.
Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Level | Get the level of this item. (Inherited from RadToolBarItem.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadToolBarItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item. (Inherited from RadToolBarItem.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Constructor
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
RadToolBarButton()()() | Initializes a new instance of the RadToolBarButton class.
RadToolBarButton(Element) | Initializes a new instance of the RadToolBarButton class.

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Constructor
RadToolBarButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBarButton()

See Also

RadToolBarButton Class
RadToolBarButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Constructor (Element)
RadToolBarButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarButton(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarButton Class
RadToolBarButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Methods
RadToolBarButton Class See Also Send Feedback

The RadToolBarButton type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
CallMethod | Overloaded.
Capture | Overloaded.
Check | Check the toolbar item.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item. (Inherited from RadToolBarItem.)
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UNCheck | UnCheck the toolbar item.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.AssignElement Method
RadToolBarButton Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.CallMethod Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.Capture Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.Check Method
RadToolBarButton Class See Also Send Feedback
Check the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Check()
Visual Basic (Declaration)
Public Sub Check
Visual C++
public:
void Check()

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.Click Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.DragTo Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.GetValue Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.InvokeEvent Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.MouseClick Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.MouseHover Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.ScrollToVisible Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.SetValue Method
RadToolBarButton Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


UNCheck Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.UNCheck Method
RadToolBarButton Class See Also Send Feedback
UnCheck the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UNCheck()
Visual Basic (Declaration)
Public Sub UNCheck
Visual C++
public:
void UNCheck()

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton Properties
RadToolBarButton Class See Also Send Feedback

The RadToolBarButton type exposes the following members.

Properties

Name | Description
AllowSelfUNCheck | Gets whether the toolbar item AllowSelfUnCheck property is set.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Checked | Get whether the toolbar item is checked.
CheckOnClick | Get whether the toolbar item CheckOnClick property is set.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Group | Gets the name of the group to which the item belongs.
Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Level | Get the level of this item. (Inherited from RadToolBarItem.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadToolBarItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item. (Inherited from RadToolBarItem.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


AllowSelfUNCheck Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.AllowSelfUNCheck Property
RadToolBarButton Class See Also Send Feedback
Gets whether the toolbar item AllowSelfUnCheck property is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowSelfUNCheck { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowSelfUNCheck As Boolean
Visual C++
public:
property bool AllowSelfUNCheck {
    bool get ();
}

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


Checked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.Checked Property
RadToolBarButton Class See Also Send Feedback
Get whether the toolbar item is checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Checked { get; }
Visual Basic (Declaration)
Public ReadOnly Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
}

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


CheckOnClick Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.CheckOnClick Property
RadToolBarButton Class See Also Send Feedback
Get whether the toolbar item CheckOnClick property is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CheckOnClick { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckOnClick As Boolean
Visual C++
public:
property bool CheckOnClick {
    bool get ();
}

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


Group Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarButton..::.Group Property
RadToolBarButton Class See Also Send Feedback
Gets the name of the group to which the item belongs.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Group { get; set; }
Visual Basic (Declaration)
Public Property Group As String
Visual C++
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Class
Members See Also Send Feedback
Represents the RadToolBarDropDownButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBarDropDownButton : RadToolBarItem
Visual Basic (Declaration)
Public Class RadToolBarDropDownButton _
    Inherits RadToolBarItem
Visual C++
public ref class RadToolBarDropDownButton : public RadToolBarItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadToolBarItem
Telerik.WebAii.Controls.Html..::.RadToolBarDropDownButton

See Also

RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Members
RadToolBarDropDownButton Class Constructors Methods Properties See Also Send Feedback

The RadToolBarDropDownButton type exposes the following members.

Constructors

Name | Description
RadToolBarDropDownButton | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item. (Inherited from RadToolBarItem.)
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonCount | Get the button count for the drop down.
ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownVisible | Get whether the drop down is opened.
Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Level | Get the level of this item. (Inherited from RadToolBarItem.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression that defines the pattern for a toolbar drop down button. (Overrides RadToolBarItem..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item. (Inherited from RadToolBarItem.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Constructor
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
RadToolBarDropDownButton()()() | Initializes a new instance of the RadToolBarDropDownButton class.
RadToolBarDropDownButton(Element) | Initializes a new instance of the RadToolBarDropDownButton class.

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Constructor
RadToolBarDropDownButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarDropDownButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarDropDownButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBarDropDownButton()

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Constructor (Element)
RadToolBarDropDownButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarDropDownButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarDropDownButton(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarDropDownButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarDropDownButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Methods
RadToolBarDropDownButton Class See Also Send Feedback

The RadToolBarDropDownButton type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item. (Inherited from RadToolBarItem.)
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.AssignElement Method
RadToolBarDropDownButton Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarDropDownButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.CallMethod Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.Capture Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.Click Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.DragTo Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.GetValue Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.InvokeEvent Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.MouseClick Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.MouseHover Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.ScrollToVisible Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.SetValue Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton Properties
RadToolBarDropDownButton Class See Also Send Feedback

The RadToolBarDropDownButton type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonCount | Get the button count for the drop down.
ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownVisible | Get whether the drop down is opened.
Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Level | Get the level of this item. (Inherited from RadToolBarItem.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression that defines the pattern for a toolbar drop down button. (Overrides RadToolBarItem..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item. (Inherited from RadToolBarItem.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


ButtonCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.ButtonCount Property
RadToolBarDropDownButton Class See Also Send Feedback
Get the button count for the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ButtonCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ButtonCount As Integer
Visual C++
public:
property int ButtonCount {
    int get ();
}

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


DropDownVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.DropDownVisible Property
RadToolBarDropDownButton Class See Also Send Feedback
Get whether the drop down is opened.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool DropDownVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownVisible As Boolean
Visual C++
public:
property bool DropDownVisible {
    bool get ();
}

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarDropDownButton..::.LocatorExpression Property
RadToolBarDropDownButton Class See Also Send Feedback
Get the FindExpression that defines the pattern for a toolbar drop down button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Class
Members See Also Send Feedback
Represents the RadToolBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBarItem : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadToolBarItem _
    Inherits HtmlContainerControl
Visual C++
public ref class RadToolBarItem : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadToolBarItem
Telerik.WebAii.Controls.Html..::.RadToolBarButton
Telerik.WebAii.Controls.Html..::.RadToolBarDropDownButton
Telerik.WebAii.Controls.Html..::.RadToolBarSplitButton

See Also

RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Members
RadToolBarItem Class Constructors Methods Properties See Also Send Feedback

The RadToolBarItem type exposes the following members.

Constructors

Name | Description
RadToolBarItem | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBarItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item.
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button).
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the toolbar item.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Overrides HtmlControl..::.Focus()()().)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button).
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonType | Returns the type of the toolbar item(button, split button, drop down button).
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the toolbar item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused.
Hovered | Get whether the toolbar item is hovered.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons.
ItemValue | Get or set the value set of this item.
Level | Get the level of this item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item.
Visible | Get whether the toolbar item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Constructor
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
RadToolBarItem()()() | Initializes a new instance of the RadToolBarItem class.
RadToolBarItem(Element) | Initializes a new instance of the RadToolBarItem class.

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Constructor
RadToolBarItem Class See Also Send Feedback
Initializes a new instance of the RadToolBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBarItem()

See Also

RadToolBarItem Class
RadToolBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Constructor (Element)
RadToolBarItem Class See Also Send Feedback
Initializes a new instance of the RadToolBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarItem(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarItem Class
RadToolBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Methods
RadToolBarItem Class See Also Send Feedback

The RadToolBarItem type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBarItem control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item.
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button).
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the toolbar item.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Overrides HtmlControl..::.Focus()()().)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button).
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.AssignElement Method
RadToolBarItem Class See Also Send Feedback
Assign the DOM element to be the ToolBarItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Blur Method
RadToolBarItem Class See Also Send Feedback
Blur the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Blur()
Visual Basic (Declaration)
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.CallMethod Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Capture Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Click Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the toolbar item. (Overrides HtmlControl..::.Click()()().)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Click Method
RadToolBarItem Class See Also Send Feedback
Click the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click()
Visual Basic (Declaration)
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadToolBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Close Method
RadToolBarItem Class See Also Send Feedback
Close the toolbar item(if the item is drop down or split button).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.ControlAssert Method
RadToolBarItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Disable Method
RadToolBarItem Class See Also Send Feedback
Disables the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.DragTo Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Enable Method
RadToolBarItem Class See Also Send Feedback
Enables the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Focus Method
RadToolBarItem Class See Also Send Feedback
Focus the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Focus()
Visual Basic (Declaration)
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.GetValue Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Hide Method
RadToolBarItem Class See Also Send Feedback
Hide the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.InvokeEvent Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.MouseClick Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.MouseHover Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Open Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Open Method
RadToolBarItem Class See Also Send Feedback
Open the toolbar item(if the item is drop down or split button).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Open()
Visual Basic (Declaration)
Public Sub Open
Visual C++
public:
void Open()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.ScrollToVisible Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.SetValue Method
RadToolBarItem Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Show Method
RadToolBarItem Class See Also Send Feedback
Show the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem Properties
RadToolBarItem Class See Also Send Feedback

The RadToolBarItem type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonType | Returns the type of the toolbar item(button, split button, drop down button).
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get whether the toolbar item is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused.
Hovered | Get whether the toolbar item is hovered.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item.
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons.
ItemValue | Get or set the value set of this item.
Level | Get the level of this item.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item.
Visible | Get whether the toolbar item is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ButtonType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.ButtonType Property
RadToolBarItem Class See Also Send Feedback
Returns the type of the toolbar item(button, split button, drop down button).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToolBarButtonType ButtonType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ButtonType As ToolBarButtonType
Visual C++
public:
property ToolBarButtonType ButtonType {
    ToolBarButtonType get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.ClientSideLocator Property
RadToolBarItem Class See Also Send Feedback
Get the Client side locator - call method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Enabled Property
RadToolBarItem Class See Also Send Feedback
Get whether the toolbar item is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Focused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Focused Property
RadToolBarItem Class See Also Send Feedback
Get whether the toolbar item is focused.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Focused { get; }
Visual Basic (Declaration)
Public ReadOnly Property Focused As Boolean
Visual C++
public:
property bool Focused {
    bool get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Hovered Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Hovered Property
RadToolBarItem Class See Also Send Feedback
Get whether the toolbar item is hovered.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Hovered { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hovered As Boolean
Visual C++
public:
property bool Hovered {
    bool get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Index Property
RadToolBarItem Class See Also Send Feedback
Get the index of the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Items Property
RadToolBarItem Class See Also Send Feedback
The items of the current toolbar item if any. Returns empty list for the toolbar buttons.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadToolBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadToolBarItem)
Visual C++
public:
property IList<RadToolBarItem^>^ Items {
    IList<RadToolBarItem^>^ get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ItemValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.ItemValue Property
RadToolBarItem Class See Also Send Feedback
Get or set the value set of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemValue { get; set; }
Visual Basic (Declaration)
Public Property ItemValue As String
Visual C++
public:
property String^ ItemValue {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Level Property
RadToolBarItem Class See Also Send Feedback
Get the level of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.LocatorExpression Property
RadToolBarItem Class See Also Send Feedback
Get the FindParam that defines the pattern for a toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Text Property
RadToolBarItem Class See Also Send Feedback
Get the text of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ToolTip Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.ToolTip Property
RadToolBarItem Class See Also Send Feedback
Get or set the tooltip of the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarItem..::.Visible Property
RadToolBarItem Class See Also Send Feedback
Get whether the toolbar item is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Class
Members See Also Send Feedback
Represents the RadToolBar SplitButton control wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBarSplitButton : RadToolBarItem
Visual Basic (Declaration)
Public Class RadToolBarSplitButton _
    Inherits RadToolBarItem
Visual C++
public ref class RadToolBarSplitButton : public RadToolBarItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadToolBarItem
Telerik.WebAii.Controls.Html..::.RadToolBarSplitButton

See Also

RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Members
RadToolBarSplitButton Class Constructors Methods Properties See Also Send Feedback

The RadToolBarSplitButton type exposes the following members.

Constructors

Name | Description
RadToolBarSplitButton | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item. (Inherited from RadToolBarItem.)
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonCount | Get the button count of the drop down.
ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownVisible | Get whether the drop down is opened.
Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Level | Get the level of this item. (Inherited from RadToolBarItem.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression that defines the pattern for a toolbar split button. (Overrides RadToolBarItem..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item. (Inherited from RadToolBarItem.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Constructor
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
RadToolBarSplitButton()()() | Initializes a new instance of the RadToolBarSplitButton class.
RadToolBarSplitButton(Element) | Initializes a new instance of the RadToolBarSplitButton class.

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Constructor
RadToolBarSplitButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarSplitButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBarSplitButton()

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Constructor (Element)
RadToolBarSplitButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarSplitButton(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarSplitButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarSplitButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Methods
RadToolBarSplitButton Class See Also Send Feedback

The RadToolBarSplitButton type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Show the toolbar item. (Inherited from RadToolBarItem.)
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.AssignElement Method
RadToolBarSplitButton Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarSplitButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.CallMethod Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.Capture Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.Click Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.DragTo Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.GetValue Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.InvokeEvent Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.MouseClick Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.MouseHover Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.ScrollToVisible Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.SetValue Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton Properties
RadToolBarSplitButton Class See Also Send Feedback

The RadToolBarSplitButton type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ButtonCount | Get the button count of the drop down.
ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DropDownVisible | Get whether the drop down is opened.
Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Level | Get the level of this item. (Inherited from RadToolBarItem.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindExpression that defines the pattern for a toolbar split button. (Overrides RadToolBarItem..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Get the text of this item. (Inherited from RadToolBarItem.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


ButtonCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.ButtonCount Property
RadToolBarSplitButton Class See Also Send Feedback
Get the button count of the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ButtonCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ButtonCount As Integer
Visual C++
public:
property int ButtonCount {
    int get ();
}

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


DropDownVisible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.DropDownVisible Property
RadToolBarSplitButton Class See Also Send Feedback
Get whether the drop down is opened.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool DropDownVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownVisible As Boolean
Visual C++
public:
property bool DropDownVisible {
    bool get ();
}

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarSplitButton..::.LocatorExpression Property
RadToolBarSplitButton Class See Also Send Feedback
Get the FindExpression that defines the pattern for a toolbar split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolTip Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Class
Members See Also Send Feedback
RadToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolTip : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadToolTip _
    Inherits HtmlContainerControl
Visual C++
public ref class RadToolTip : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadToolTip

See Also

RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


RadToolTip Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Members
RadToolTip Class Constructors Methods Properties See Also Send Feedback

The RadToolTip type exposes the following members.

Constructors

Name | Description
RadToolTip | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hides the ToolTip.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Shows the ToolTip.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoCloseDelay | Gets/Sets delay in milliseconds for the tooltip when closes automatically.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The RadToolTip client ID.
ClientSideLocator | Gets the client-side code that defines the RadToolTip. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets ToolTip height.
HideDelay | Gets/Sets the delay in milliseconds before the tooltip becomes hidden.
HideEvent | Gets/Sets ToolTip HideEvent type.
HideMode | Gets/Sets ToolTip 'Hide' mode.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadToolTipHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Modal | Get\set ToolTip modal mode.
MouseTrailing | Determines or set whether the tooltip should follow the mouse movement.
OffsetX | Gets/Sets the horizontal offset relative to its target element.
OffsetY | Gets/Sets the vertical offset relative to its target element.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RelativeTo | Gets/Sets what element the ToolTip is relative to.
RelativeToMode | Gets the 'relative to' mode of the ToolTip -- 'Element', 'BrowserWindow', 'Mouse'.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShowCallout | Determines or set whether the tooltip callout image will be displayed.
ShowDelay | Gets/Sets delay in milliseconds for the tooltip when appears.
ShowEvent | Gets/Sets ToolTip ShowEvent type.
ShowMode | Gets/Sets ToolTip 'Show' mode.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TargetControlId | Gets/Sets the ToolTip target control Id.
Text | Gets/Sets ToolTip Text.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | Gets/Sets ToolTip Title.
Visible | Determines whether the tooltip is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the ToolTip width.
ZIndex | Gets/Sets the ToolTip ZIndex.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RadToolTip Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Constructor
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
RadToolTip()()() | Initializes a new instance of the RadToolTip class.
RadToolTip(Element) | Initializes a new instance of the RadToolTip class.

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


RadToolTip Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Constructor
RadToolTip Class See Also Send Feedback
Initializes a new instance of the RadToolTip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolTip()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolTip()

See Also

RadToolTip Class
RadToolTip Overload
Telerik.WebAii.Controls.Html Namespace


RadToolTip Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Constructor (Element)
RadToolTip Class See Also Send Feedback
Initializes a new instance of the RadToolTip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolTip(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolTip(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The ToolTip table element.

See Also

RadToolTip Class
RadToolTip Overload
Telerik.WebAii.Controls.Html Namespace


RadToolTip Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Methods
RadToolTip Class See Also Send Feedback

The RadToolTip type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Hide | Hides the ToolTip.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Shows the ToolTip.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.AssignElement Method
RadToolTip Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.CallMethod Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Capture Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Click Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ControlAssert Method
RadToolTip Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.DragTo Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.GetValue Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Hide Method
RadToolTip Class See Also Send Feedback
Hides the ToolTip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.InvokeEvent Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.MouseClick Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.MouseHover Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ScrollToVisible Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.SetValue Method
RadToolTip Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Show Method
RadToolTip Class See Also Send Feedback
Shows the ToolTip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RadToolTip Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip Properties
RadToolTip Class See Also Send Feedback

The RadToolTip type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
AutoCloseDelay | Gets/Sets delay in milliseconds for the tooltip when closes automatically.
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientId | The RadToolTip client ID.
ClientSideLocator | Gets the client-side code that defines the RadToolTip. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets ToolTip height.
HideDelay | Gets/Sets the delay in milliseconds before the tooltip becomes hidden.
HideEvent | Gets/Sets ToolTip HideEvent type.
HideMode | Gets/Sets ToolTip 'Hide' mode.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadToolTipHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Modal | Get\set ToolTip modal mode.
MouseTrailing | Determines or set whether the tooltip should follow the mouse movement.
OffsetX | Gets/Sets the horizontal offset relative to its target element.
OffsetY | Gets/Sets the vertical offset relative to its target element.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RelativeTo | Gets/Sets what element the ToolTip is relative to.
RelativeToMode | Gets the 'relative to' mode of the ToolTip -- 'Element', 'BrowserWindow', 'Mouse'.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
ShowCallout | Determines or set whether the tooltip callout image will be displayed.
ShowDelay | Gets/Sets delay in milliseconds for the tooltip when appears.
ShowEvent | Gets/Sets ToolTip ShowEvent type.
ShowMode | Gets/Sets ToolTip 'Show' mode.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TargetControlId | Gets/Sets the ToolTip target control Id.
Text | Gets/Sets ToolTip Text.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | Gets/Sets ToolTip Title.
Visible | Determines whether the tooltip is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the ToolTip width.
ZIndex | Gets/Sets the ToolTip ZIndex.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


AutoCloseDelay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.AutoCloseDelay Property
RadToolTip Class See Also Send Feedback
Gets/Sets delay in milliseconds for the tooltip when closes automatically.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int AutoCloseDelay { get; set; }
Visual Basic (Declaration)
Public Property AutoCloseDelay As Integer
Visual C++
public:
property int AutoCloseDelay {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ClientId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ClientId Property
RadToolTip Class See Also Send Feedback
The RadToolTip client ID.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ClientId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientId As String
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ClientSideLocator Property
RadToolTip Class See Also Send Feedback
Gets the client-side code that defines the RadToolTip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Height Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Height { get; set; }
Visual Basic (Declaration)
Public Property Height As String
Visual C++
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


HideDelay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.HideDelay Property
RadToolTip Class See Also Send Feedback
Gets/Sets the delay in milliseconds before the tooltip becomes hidden.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int HideDelay { get; set; }
Visual Basic (Declaration)
Public Property HideDelay As Integer
Visual C++
public:
property int HideDelay {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


HideEvent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.HideEvent Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip HideEvent type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int HideEvent { get; set; }
Visual Basic (Declaration)
Public Property HideEvent As Integer
Visual C++
public:
property int HideEvent {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


HideMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.HideMode Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip 'Hide' mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToolTipHideMode HideMode { get; set; }
Visual Basic (Declaration)
Public Property HideMode As ToolTipHideMode
Visual C++
public:
property ToolTipHideMode HideMode {
    ToolTipHideMode get ();
    void set (ToolTipHideMode value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.LocatorExpression Property
RadToolTip Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadToolTipHtmlControl.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


Modal Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Modal Property
RadToolTip Class See Also Send Feedback
Get\set ToolTip modal mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Modal { get; set; }
Visual Basic (Declaration)
Public Property Modal As Boolean
Visual C++
public:
property bool Modal {
    bool get ();
    void set (bool value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


MouseTrailing Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.MouseTrailing Property
RadToolTip Class See Also Send Feedback
Determines or set whether the tooltip should follow the mouse movement.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool MouseTrailing { get; set; }
Visual Basic (Declaration)
Public Property MouseTrailing As Boolean
Visual C++
public:
property bool MouseTrailing {
    bool get ();
    void set (bool value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


OffsetX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.OffsetX Property
RadToolTip Class See Also Send Feedback
Gets/Sets the horizontal offset relative to its target element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int OffsetX { get; set; }
Visual Basic (Declaration)
Public Property OffsetX As Integer
Visual C++
public:
property int OffsetX {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


OffsetY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.OffsetY Property
RadToolTip Class See Also Send Feedback
Gets/Sets the vertical offset relative to its target element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int OffsetY { get; set; }
Visual Basic (Declaration)
Public Property OffsetY As Integer
Visual C++
public:
property int OffsetY {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RelativeTo Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.RelativeTo Property
RadToolTip Class See Also Send Feedback
Gets/Sets what element the ToolTip is relative to.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int RelativeTo { get; set; }
Visual Basic (Declaration)
Public Property RelativeTo As Integer
Visual C++
public:
property int RelativeTo {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RelativeToMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.RelativeToMode Property
RadToolTip Class See Also Send Feedback
Gets the 'relative to' mode of the ToolTip -- 'Element', 'BrowserWindow', 'Mouse'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToolTipRelativeToMode RelativeToMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelativeToMode As ToolTipRelativeToMode
Visual C++
public:
property ToolTipRelativeToMode RelativeToMode {
    ToolTipRelativeToMode get ();
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ShowCallout Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ShowCallout Property
RadToolTip Class See Also Send Feedback
Determines or set whether the tooltip callout image will be displayed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShowCallout { get; set; }
Visual Basic (Declaration)
Public Property ShowCallout As Boolean
Visual C++
public:
property bool ShowCallout {
    bool get ();
    void set (bool value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ShowDelay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ShowDelay Property
RadToolTip Class See Also Send Feedback
Gets/Sets delay in milliseconds for the tooltip when appears.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ShowDelay { get; set; }
Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual C++
public:
property int ShowDelay {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ShowEvent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ShowEvent Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip ShowEvent type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ShowEvent { get; set; }
Visual Basic (Declaration)
Public Property ShowEvent As Integer
Visual C++
public:
property int ShowEvent {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ShowMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ShowMode Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip 'Show' mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToolTipShowMode ShowMode { get; set; }
Visual Basic (Declaration)
Public Property ShowMode As ToolTipShowMode
Visual C++
public:
property ToolTipShowMode ShowMode {
    ToolTipShowMode get ();
    void set (ToolTipShowMode value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


TargetControlId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.TargetControlId Property
RadToolTip Class See Also Send Feedback
Gets/Sets the ToolTip target control Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TargetControlId { get; set; }
Visual Basic (Declaration)
Public Property TargetControlId As String
Visual C++
public:
property String^ TargetControlId {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Text Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Title Property
RadToolTip Class See Also Send Feedback
Gets/Sets ToolTip Title.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Visible Property
RadToolTip Class See Also Send Feedback
Determines whether the tooltip is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.Width Property
RadToolTip Class See Also Send Feedback
Gets/Sets the ToolTip width.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Width { get; set; }
Visual Basic (Declaration)
Public Property Width As String
Visual C++
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


ZIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolTip..::.ZIndex Property
RadToolTip Class See Also Send Feedback
Gets/Sets the ToolTip ZIndex.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ZIndex { get; set; }
Visual Basic (Declaration)
Public Property ZIndex As Integer
Visual C++
public:
property int ZIndex {
    int get ();
    void set (int value);
}

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Class
Members See Also Send Feedback
Represents the RadTreeNode class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTreeNode : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadTreeNode _
    Inherits HtmlContainerControl
Visual C++
public ref class RadTreeNode : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadTreeNode

See Also

RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Members
RadTreeNode Class Constructors Methods Properties See Also Send Feedback

The RadTreeNode type exposes the following members.

Constructors

Name | Description
RadTreeNode | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadTreeNode control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Check | Check the node if it is not already checked.
Click | Overloaded.
Collapse | Collapse the node if it is not already collapsed.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the node.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragAndDropTo | Overloaded.
DragAndDropWithOffset | Drag and drop the node with the specified x and y offset.
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the node.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expand the node if it is not already expanded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindNode | Find node by given predicate.
FindNodeByText | Finds node by Text.
FindNodeByValue | Finds node by Value.
FindNodes | Get a list of nodes matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Highlight | Highlight the node.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the node.
SetValue | Overloaded.
ShowContextMenu | Show the context menu.
Toggle | Toggle the expand/collapse of the node.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Uncheck | UnCheck the node if it is checked.
UNHighlight | Unhighlight the node.
Unselect | UnSelect the node.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Category | Get or set the category of this node.
Checkable | Get whether the tree node contains check box so that it can be checked.
Checked | Get or set whether the node is checked.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
ContextMenuId | Get or set the ID of the context menu.
ContextMenuShown | Get whether the context menu (if such is set for this node) is shown.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether the node is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Get or set whether this node is expanded.
Find | Find property (Inherited from HtmlControl.)
HasChildren | Check whether the node has children.
HasContextMenu | True if context menu is available, false otherwise.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Level | Get the level of the node.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this item.
Nodes | Get the list of child nodes of the treenode.
NodeValue | Get the value set for this node.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ParentNode | Get the parent node of this node. Returns 'null' for the root nodes.
PostBack | Get whether the postback of the node is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get or set whether this node is selected.
ShouldNavigate | Check whether the item should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Get or set the target of the node.
Text | Get the text of this node.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the node. If a ToolTip is not set, returns 'null'.
Visible | Get whether this node is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Constructor
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
RadTreeNode()()() | Initializes a new instance of the RadTreeNode class.
RadTreeNode(Element) | Initializes a new instance of the RadTreeNode class.

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Constructor
RadTreeNode Class See Also Send Feedback
Initializes a new instance of the RadTreeNode class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeNode()

See Also

RadTreeNode Class
RadTreeNode Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Constructor (Element)
RadTreeNode Class See Also Send Feedback
Initializes a new instance of the RadTreeNode class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTreeNode(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeNode Class
RadTreeNode Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Methods
RadTreeNode Class See Also Send Feedback

The RadTreeNode type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the RadTreeNode control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Check | Check the node if it is not already checked.
Click | Overloaded.
Collapse | Collapse the node if it is not already collapsed.
ControlAssert | Get RadControlAssert instance initialized for this control.
Disable | Disables the node.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragAndDropTo | Overloaded.
DragAndDropWithOffset | Drag and drop the node with the specified x and y offset.
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Enable | Enables the node.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expand the node if it is not already expanded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindNode | Find node by given predicate.
FindNodeByText | Finds node by Text.
FindNodeByValue | Finds node by Value.
FindNodes | Get a list of nodes matching the given predicate.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
Highlight | Highlight the node.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Navigate | Navigate if NavigateUrl is set.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
Select | Select the node.
SetValue | Overloaded.
ShowContextMenu | Show the context menu.
Toggle | Toggle the expand/collapse of the node.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Uncheck | UnCheck the node if it is checked.
UNHighlight | Unhighlight the node.
Unselect | UnSelect the node.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.AssignElement Method
RadTreeNode Class See Also Send Feedback
Assign the DOM element to be the RadTreeNode control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.CallMethod Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Capture Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Check Method
RadTreeNode Class See Also Send Feedback
Check the node if it is not already checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Check()
Visual Basic (Declaration)
Public Sub Check
Visual C++
public:
void Check()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Click Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Click the node or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click()()().)
Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::.Click(Boolean).)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Click Method
RadTreeNode Class See Also Send Feedback
Click the node or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click()
Visual Basic (Declaration)
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadTreeNode Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Click Method (Boolean)
RadTreeNode Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic (Declaration)
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::.Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.Click(System.Boolean)"]

See Also

RadTreeNode Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Collapse Method
RadTreeNode Class See Also Send Feedback
Collapse the node if it is not already collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ControlAssert Method
RadTreeNode Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Disable Method
RadTreeNode Class See Also Send Feedback
Disables the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Disable()
Visual Basic (Declaration)
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.DragAndDropTo Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
DragAndDropTo(HtmlControl) | Drag and drop the node to the specified control. Drops into the center of the element.
DragAndDropTo(RadTreeNode) | Drag and drop the node to the specified node.

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method (HtmlControl)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.DragAndDropTo Method (HtmlControl)
RadTreeNode Class See Also Send Feedback
Drag and drop the node to the specified control. Drops into the center of the element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAndDropTo(
    HtmlControl destination
)
Visual Basic (Declaration)
Public Sub DragAndDropTo ( _
    destination As HtmlControl _
)
Visual C++
public:
void DragAndDropTo(
    HtmlControl^ destination
)

Parameters

destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
The destination control.

See Also

RadTreeNode Class
DragAndDropTo Overload
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method (RadTreeNode)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.DragAndDropTo Method (RadTreeNode)
RadTreeNode Class See Also Send Feedback
Drag and drop the node to the specified node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAndDropTo(
    RadTreeNode node
)
Visual Basic (Declaration)
Public Sub DragAndDropTo ( _
    node As RadTreeNode _
)
Visual C++
public:
void DragAndDropTo(
    RadTreeNode^ node
)

Parameters

node
Type: Telerik.WebAii.Controls.Html..::.RadTreeNode
The target node to drop to.

See Also

RadTreeNode Class
DragAndDropTo Overload
Telerik.WebAii.Controls.Html Namespace


DragAndDropWithOffset Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.DragAndDropWithOffset Method
RadTreeNode Class See Also Send Feedback
Drag and drop the node with the specified x and y offset.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)
Visual Basic (Declaration)
Public Sub DragAndDropWithOffset ( _
    offsetX As Integer, _
    offsetY As Integer _
)
Visual C++
public:
void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)

Parameters

offsetX
Type: System..::.Int32

[Missing <param name="offsetX"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.DragAndDropWithOffset(System.Int32,System.Int32)"]

offsetY
Type: System..::.Int32

[Missing <param name="offsetY"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.DragAndDropWithOffset(System.Int32,System.Int32)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.DragTo Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Enable Method
RadTreeNode Class See Also Send Feedback
Enables the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Expand Method
RadTreeNode Class See Also Send Feedback
Expand the node if it is not already expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.FindNode Method
RadTreeNode Class See Also Send Feedback
Find node by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode FindNode(
    Predicate<RadTreeNode> predicate
)
Visual Basic (Declaration)
Public Function FindNode ( _
    predicate As Predicate(Of RadTreeNode) _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNode(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTreeNode >)>)
The predicate used as search criteria, i.e. "node => node.NodeText == myNodeText".

Return Value

The node matching the given criteria or null if nothing matches the search.

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.FindNodeByText Method
RadTreeNode Class See Also Send Feedback
Finds node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode FindNodeByText(
    string nodeText
)
Visual Basic (Declaration)
Public Function FindNodeByText ( _
    nodeText As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::.String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByText(System.String)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.FindNodeByValue Method
RadTreeNode Class See Also Send Feedback
Finds node by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode FindNodeByValue(
    string nodeValue
)
Visual Basic (Declaration)
Public Function FindNodeByValue ( _
    nodeValue As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByValue(
    String^ nodeValue
)

Parameters

nodeValue
Type: System..::.String

[Missing <param name="nodeValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByValue(System.String)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNodes Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.FindNodes Method
RadTreeNode Class See Also Send Feedback
Get a list of nodes matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> FindNodes(
    Predicate<RadTreeNode> predicate
)
Visual Basic (Declaration)
Public Function FindNodes ( _
    predicate As Predicate(Of RadTreeNode) _
) As IList(Of RadTreeNode)
Visual C++
public:
IList<RadTreeNode^>^ FindNodes(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTreeNode >)>)
The predicate, i.e. (node => node.NodeText == myText).

Return Value

The nodes matching the given predicate.

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.GetValue Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Highlight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Highlight Method
RadTreeNode Class See Also Send Feedback
Highlight the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Highlight()
Visual Basic (Declaration)
Public Sub Highlight
Visual C++
public:
void Highlight()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.InvokeEvent Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.MouseClick Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.MouseHover Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Navigate Method
RadTreeNode Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Navigate()
Visual Basic (Declaration)
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ScrollToVisible Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Select Method
RadTreeNode Class See Also Send Feedback
Select the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.SetValue Method
RadTreeNode Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


ShowContextMenu Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ShowContextMenu Method
RadTreeNode Class See Also Send Feedback
Show the context menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowContextMenu()
Visual Basic (Declaration)
Public Sub ShowContextMenu
Visual C++
public:
void ShowContextMenu()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Toggle Method
RadTreeNode Class See Also Send Feedback
Toggle the expand/collapse of the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Uncheck Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Uncheck Method
RadTreeNode Class See Also Send Feedback
UnCheck the node if it is checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Uncheck()
Visual Basic (Declaration)
Public Sub Uncheck
Visual C++
public:
void Uncheck()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


UNHighlight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.UNHighlight Method
RadTreeNode Class See Also Send Feedback
Unhighlight the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UNHighlight()
Visual Basic (Declaration)
Public Sub UNHighlight
Visual C++
public:
void UNHighlight()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Unselect Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Unselect Method
RadTreeNode Class See Also Send Feedback
UnSelect the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Unselect()
Visual Basic (Declaration)
Public Sub Unselect
Visual C++
public:
void Unselect()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode Properties
RadTreeNode Class See Also Send Feedback

The RadTreeNode type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Category | Get or set the category of this node.
Checkable | Get whether the tree node contains check box so that it can be checked.
Checked | Get or set whether the node is checked.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
ContextMenuId | Get or set the ID of the context menu.
ContextMenuShown | Get whether the context menu (if such is set for this node) is shown.
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether the node is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Expanded | Get or set whether this node is expanded.
Find | Find property (Inherited from HtmlControl.)
HasChildren | Check whether the node has children.
HasContextMenu | True if context menu is available, false otherwise.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Level | Get the level of the node.
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
NavigateUrl | Get or set the navigate url of this item.
Nodes | Get the list of child nodes of the treenode.
NodeValue | Get the value set for this node.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ParentNode | Get the parent node of this node. Returns 'null' for the root nodes.
PostBack | Get whether the postback of the node is enabled.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Selected | Get or set whether this node is selected.
ShouldNavigate | Check whether the item should navigate.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Target | Get or set the target of the node.
Text | Get the text of this node.
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
ToolTip | Get or set the tooltip of the node. If a ToolTip is not set, returns 'null'.
Visible | Get whether this node is visible.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Category Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Category Property
RadTreeNode Class See Also Send Feedback
Get or set the category of this node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Checkable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Checkable Property
RadTreeNode Class See Also Send Feedback
Get whether the tree node contains check box so that it can be checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Checkable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Checkable As Boolean
Visual C++
public:
property bool Checkable {
    bool get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Checked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Checked Property
RadTreeNode Class See Also Send Feedback
Get or set whether the node is checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ClientSideLocator Property
RadTreeNode Class See Also Send Feedback
Get the Client side locator - call method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ContextMenuId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ContextMenuId Property
RadTreeNode Class See Also Send Feedback
Get or set the ID of the context menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ContextMenuId { get; set; }
Visual Basic (Declaration)
Public Property ContextMenuId As String
Visual C++
public:
property String^ ContextMenuId {
    String^ get ();
    void set (String^ value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ContextMenuShown Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ContextMenuShown Property
RadTreeNode Class See Also Send Feedback
Get whether the context menu (if such is set for this node) is shown.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ContextMenuShown { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContextMenuShown As Boolean
Visual C++
public:
property bool ContextMenuShown {
    bool get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Enabled Property
RadTreeNode Class See Also Send Feedback
Get or set whether the node is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Expanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Expanded Property
RadTreeNode Class See Also Send Feedback
Get or set whether this node is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Expanded { get; set; }
Visual Basic (Declaration)
Public Property Expanded As Boolean
Visual C++
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


HasChildren Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.HasChildren Property
RadTreeNode Class See Also Send Feedback
Check whether the node has children.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasChildren { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
Visual C++
public:
property bool HasChildren {
    bool get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


HasContextMenu Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.HasContextMenu Property
RadTreeNode Class See Also Send Feedback
True if context menu is available, false otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasContextMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasContextMenu As Boolean
Visual C++
public:
property bool HasContextMenu {
    bool get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Level Property
RadTreeNode Class See Also Send Feedback
Get the level of the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.LocatorExpression Property
RadTreeNode Class See Also Send Feedback
Get the FindParam that defines the pattern for a treeview node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


NavigateUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.NavigateUrl Property
RadTreeNode Class See Also Send Feedback
Get or set the navigate url of this item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string NavigateUrl { get; set; }
Visual Basic (Declaration)
Public Property NavigateUrl As String
Visual C++
public:
property String^ NavigateUrl {
    String^ get ();
    void set (String^ value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Nodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Nodes Property
RadTreeNode Class See Also Send Feedback
Get the list of child nodes of the treenode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As IList(Of RadTreeNode)
Visual C++
public:
property IList<RadTreeNode^>^ Nodes {
    IList<RadTreeNode^>^ get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


NodeValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.NodeValue Property
RadTreeNode Class See Also Send Feedback
Get the value set for this node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string NodeValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property NodeValue As String
Visual C++
public:
property String^ NodeValue {
    String^ get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ParentNode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ParentNode Property
RadTreeNode Class See Also Send Feedback
Get the parent node of this node. Returns 'null' for the root nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode ParentNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentNode As RadTreeNode
Visual C++
public:
property RadTreeNode^ ParentNode {
    RadTreeNode^ get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


PostBack Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.PostBack Property
RadTreeNode Class See Also Send Feedback
Get whether the postback of the node is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool PostBack { get; set; }
Visual Basic (Declaration)
Public Property PostBack As Boolean
Visual C++
public:
property bool PostBack {
    bool get ();
    void set (bool value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Selected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Selected Property
RadTreeNode Class See Also Send Feedback
Get or set whether this node is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Selected { get; set; }
Visual Basic (Declaration)
Public Property Selected As Boolean
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ShouldNavigate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ShouldNavigate Property
RadTreeNode Class See Also Send Feedback
Check whether the item should navigate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShouldNavigate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShouldNavigate As Boolean
Visual C++
public:
property bool ShouldNavigate {
    bool get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Target Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Target Property
RadTreeNode Class See Also Send Feedback
Get or set the target of the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Target { get; set; }
Visual Basic (Declaration)
Public Property Target As String
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Text Property
RadTreeNode Class See Also Send Feedback
Get the text of this node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ToolTip Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.ToolTip Property
RadTreeNode Class See Also Send Feedback
Get or set the tooltip of the node. If a ToolTip is not set, returns 'null'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Visible Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeNode..::.Visible Property
RadTreeNode Class See Also Send Feedback
Get whether this node is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


RadTreeView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Class
Members See Also Send Feedback
Represents the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTreeView : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadTreeView _
    Inherits HtmlContainerControl
Visual C++
public ref class RadTreeView : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadTreeView

See Also

RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


RadTreeView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Members
RadTreeView Class Constructors Methods Properties See Also Send Feedback

The RadTreeView type exposes the following members.

Constructors

Name | Description
RadTreeView | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the radTreeView control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindNode | Find node by given predicate.
FindNodeByText | Finds node by Text.
FindNodeByValue | Finds node by Value.
FindNodes | Get a list of nodes matching the given predicate.
FindNodesByLevel | Get a list of nodes matching the given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InitializeNodes | Initializes the RadTreeView nodes.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UnselectAllNodes | UnSelect all nodes.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AllNodes | Gets a list of all nodes.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CheckBoxesEnabled | Get whether the TreeView check box support is enabled.
CheckedNodes | Gets a list of the checked nodes.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether the node is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootNodes | Gets a list of root nodes of the treeview.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedNodes | Gets a list of the selected nodes.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RadTreeView Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Constructor
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
RadTreeView()()() | Initializes a new instance of the RadTreeView class.
RadTreeView(Element) | Initializes a new instance of the RadTreeView class.

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


RadTreeView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Constructor
RadTreeView Class See Also Send Feedback
Initializes a new instance of the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeView()

See Also

RadTreeView Class
RadTreeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeView Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Constructor (Element)
RadTreeView Class See Also Send Feedback
Initializes a new instance of the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeView(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTreeView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeView Class
RadTreeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Methods
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the radTreeView control. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindNode | Find node by given predicate.
FindNodeByText | Finds node by Text.
FindNodeByValue | Finds node by Value.
FindNodes | Get a list of nodes matching the given predicate.
FindNodesByLevel | Get a list of nodes matching the given level.
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InitializeNodes | Initializes the RadTreeView nodes.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
UnselectAllNodes | UnSelect all nodes.
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.AssignElement Method
RadTreeView Class See Also Send Feedback
Assign the DOM element to be the radTreeView control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.CallMethod Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.Capture Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.Click Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.ControlAssert Method
RadTreeView Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.DragTo Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


FindNode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNode Method
RadTreeView Class See Also Send Feedback
Find node by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode FindNode(
    Predicate<RadTreeNode> predicate
)
Visual Basic (Declaration)
Public Function FindNode ( _
    predicate As Predicate(Of RadTreeNode) _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNode(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTreeNode >)>)
The predicate used as search criteria, i.e. "node => node.NodeText == myNodeText".

Return Value

The node matching the given criteria or null if nothing matches the search.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNodeByText Method
RadTreeView Class See Also Send Feedback
Finds node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode FindNodeByText(
    string nodeText
)
Visual Basic (Declaration)
Public Function FindNodeByText ( _
    nodeText As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::.String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNodeByValue Method
RadTreeView Class See Also Send Feedback
Finds node by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeNode FindNodeByValue(
    string nodeValue
)
Visual Basic (Declaration)
Public Function FindNodeByValue ( _
    nodeValue As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByValue(
    String^ nodeValue
)

Parameters

nodeValue
Type: System..::.String

[Missing <param name="nodeValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByValue(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodes Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNodes Method
RadTreeView Class See Also Send Feedback
Get a list of nodes matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> FindNodes(
    Predicate<RadTreeNode> predicate
)
Visual Basic (Declaration)
Public Function FindNodes ( _
    predicate As Predicate(Of RadTreeNode) _
) As IList(Of RadTreeNode)
Visual C++
public:
IList<RadTreeNode^>^ FindNodes(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <( RadTreeNode >)>)
The predicate, i.e. (node => node.NodeText == myText).

Return Value

The nodes matching the given predicate.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodesByLevel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNodesByLevel Method
RadTreeView Class See Also Send Feedback
Get a list of nodes matching the given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> FindNodesByLevel(
    int level
)
Visual Basic (Declaration)
Public Function FindNodesByLevel ( _
    level As Integer _
) As IList(Of RadTreeNode)
Visual C++
public:
IList<RadTreeNode^>^ FindNodesByLevel(
    int level
)

Parameters

level
Type: System..::.Int32
The level to search for.

Return Value

The list of nodes matching the given level.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.GetValue Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


InitializeNodes Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.InitializeNodes Method
RadTreeView Class See Also Send Feedback
Initializes the RadTreeView nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InitializeNodes()
Visual Basic (Declaration)
Public Sub InitializeNodes
Visual C++
public:
void InitializeNodes()

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.InvokeEvent Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.MouseClick Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.MouseHover Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.ScrollToVisible Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.SetValue Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


UnselectAllNodes Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.UnselectAllNodes Method
RadTreeView Class See Also Send Feedback
UnSelect all nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UnselectAllNodes()
Visual Basic (Declaration)
Public Sub UnselectAllNodes
Visual C++
public:
void UnselectAllNodes()

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RadTreeView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Properties
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Properties

Name | Description
AllNodes | Gets a list of all nodes.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CheckBoxesEnabled | Get whether the TreeView check box support is enabled.
CheckedNodes | Gets a list of the checked nodes.
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Enabled | Get or set whether the node is enabled.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the locator FindParam. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RootNodes | Gets a list of root nodes of the treeview.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectedNodes | Gets a list of the selected nodes.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


AllNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.AllNodes Property
RadTreeView Class See Also Send Feedback
Gets a list of all nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> AllNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllNodes As IList(Of RadTreeNode)
Visual C++
public:
property IList<RadTreeNode^>^ AllNodes {
    IList<RadTreeNode^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


CheckBoxesEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.CheckBoxesEnabled Property
RadTreeView Class See Also Send Feedback
Get whether the TreeView check box support is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CheckBoxesEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckBoxesEnabled As Boolean
Visual C++
public:
property bool CheckBoxesEnabled {
    bool get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


CheckedNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.CheckedNodes Property
RadTreeView Class See Also Send Feedback
Gets a list of the checked nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> CheckedNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedNodes As IList(Of RadTreeNode)
Visual C++
public:
property IList<RadTreeNode^>^ CheckedNodes {
    IList<RadTreeNode^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.ClientSideLocator Property
RadTreeView Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


Enabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.Enabled Property
RadTreeView Class See Also Send Feedback
Get or set whether the node is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.LocatorExpression Property
RadTreeView Class See Also Send Feedback
Get the locator FindParam.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RootNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.RootNodes Property
RadTreeView Class See Also Send Feedback
Gets a list of root nodes of the treeview.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> RootNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootNodes As IList(Of RadTreeNode)
Visual C++
public:
property IList<RadTreeNode^>^ RootNodes {
    IList<RadTreeNode^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


SelectedNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.SelectedNodes Property
RadTreeView Class See Also Send Feedback
Gets a list of the selected nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeNode> SelectedNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedNodes As IList(Of RadTreeNode)
Visual C++
public:
property IList<RadTreeNode^>^ SelectedNodes {
    IList<RadTreeNode^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RadUpload Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Class
Members See Also Send Feedback
Represents the RadUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadUpload : HtmlContainerControl
Visual Basic (Declaration)
Public Class RadUpload _
    Inherits HtmlContainerControl
Visual C++
public ref class RadUpload : public HtmlContainerControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
Telerik.WebAii.Controls.Html..::.RadUpload

See Also

RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RadUpload Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Members
RadUpload Class Constructors Methods Properties See Also Send Feedback

The RadUpload type exposes the following members.

Constructors

Name | Description
RadUpload | Overloaded.

Methods

Name | Description
AddButtonClick | Clicks the add button.
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
CheckBoxCheck | Checks the checkbox.
ClearButtonClick | Clicks the clear button.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
DeleteButtonClick | Clicks the delete button.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FileSelect | Selects the file by specifid index.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveButtonClick | Clicks the remove button.
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
AddButton | Returns upload add button.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClearButton | Returns upload clear button.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DeleteButton | Returns upload delete button.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
FileExtensions | Returns an array containing the allowed file extensions.
FileExtensionsString | Returns a string containing the allowed file extensions.
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InitialFileInputCount | Returns the initial number of rows when the RadUpload control is first loaded..
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputFileCheckBox | Returns file upload checkbox.
InputFiles | Returns upload input file controls.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a RadUploadHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxFileCount | Get or set the maximum number of rows in the RadUpload control.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RemoveButton | Returns upload remove button.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectButton | Returns upload select button.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


RadUpload Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Constructor
RadUpload Class See Also Send Feedback

Overload List

Name | Description
RadUpload()()() | Initializes a new instance of the RadUpload class.
RadUpload(Element) | Initializes a new instance of the RadUpload class.

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RadUpload Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Constructor
RadUpload Class See Also Send Feedback
Initializes a new instance of the RadUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUpload()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUpload()

See Also

RadUpload Class
RadUpload Overload
Telerik.WebAii.Controls.Html Namespace


RadUpload Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Constructor (Element)
RadUpload Class See Also Send Feedback
Initializes a new instance of the RadUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUpload(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadUpload(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadUpload Class
RadUpload Overload
Telerik.WebAii.Controls.Html Namespace


RadUpload Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Methods
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Methods

Name | Description
AddButtonClick | Clicks the add button.
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlContainerControl..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
CheckBoxCheck | Checks the checkbox.
ClearButtonClick | Clicks the clear button.
Click | Overloaded.
ControlAssert | Get RadControlAssert instance initialized for this control.
DeleteButtonClick | Clicks the delete button.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FileSelect | Selects the file by specifid index.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveButtonClick | Clicks the remove button.
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


AddButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.AddButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the add button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void AddButtonClick()
Visual Basic (Declaration)
Public Sub AddButtonClick
Visual C++
public:
void AddButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.AssignElement Method
RadUpload Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.CallMethod Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Capture Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


CheckBoxCheck Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.CheckBoxCheck Method
RadUpload Class See Also Send Feedback
Checks the checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CheckBoxCheck()
Visual Basic (Declaration)
Public Sub CheckBoxCheck
Visual C++
public:
void CheckBoxCheck()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


ClearButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ClearButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the clear button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClearButtonClick()
Visual Basic (Declaration)
Public Sub ClearButtonClick
Visual C++
public:
void ClearButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Click Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ControlAssert Method
RadUpload Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


DeleteButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.DeleteButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DeleteButtonClick()
Visual Basic (Declaration)
Public Sub DeleteButtonClick
Visual C++
public:
void DeleteButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.DragTo Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


FileSelect Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.FileSelect Method
RadUpload Class See Also Send Feedback
Selects the file by specifid index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void FileSelect(
    int index
)
Visual Basic (Declaration)
Public Sub FileSelect ( _
    index As Integer _
)
Visual C++
public:
void FileSelect(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.FileSelect(System.Int32)"]

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.GetValue Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.InvokeEvent Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.MouseClick Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.MouseHover Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RemoveButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.RemoveButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the remove button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void RemoveButtonClick()
Visual Basic (Declaration)
Public Sub RemoveButtonClick
Visual C++
public:
void RemoveButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ScrollToVisible Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.SetValue Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RadUpload Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Properties
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Properties

Name | Description
AddButton | Returns upload add button.
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClearButton | Returns upload clear button.
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
DeleteButton | Returns upload delete button.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
FileExtensions | Returns an array containing the allowed file extensions.
FileExtensionsString | Returns a string containing the allowed file extensions.
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InitialFileInputCount | Returns the initial number of rows when the RadUpload control is first loaded..
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
InputFileCheckBox | Returns file upload checkbox.
InputFiles | Returns upload input file controls.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for a RadUploadHtmlControl. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
MaxFileCount | Get or set the maximum number of rows in the RadUpload control.
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RemoveButton | Returns upload remove button.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
SelectButton | Returns upload select button.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


AddButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.AddButton Property
RadUpload Class See Also Send Feedback
Returns upload add button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputButton AddButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddButton As HtmlInputButton
Visual C++
public:
property HtmlInputButton^ AddButton {
    HtmlInputButton^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


ClearButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ClearButton Property
RadUpload Class See Also Send Feedback
Returns upload clear button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputButton ClearButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClearButton As HtmlInputButton
Visual C++
public:
property HtmlInputButton^ ClearButton {
    HtmlInputButton^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ClientSideLocator Property
RadUpload Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


DeleteButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.DeleteButton Property
RadUpload Class See Also Send Feedback
Returns upload delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputButton DeleteButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeleteButton As HtmlInputButton
Visual C++
public:
property HtmlInputButton^ DeleteButton {
    HtmlInputButton^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


FileExtensions Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.FileExtensions Property
RadUpload Class See Also Send Feedback
Returns an array containing the allowed file extensions.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<string> FileExtensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileExtensions As IList(Of String)
Visual C++
public:
property IList<String^>^ FileExtensions {
    IList<String^>^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


FileExtensionsString Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.FileExtensionsString Property
RadUpload Class See Also Send Feedback
Returns a string containing the allowed file extensions.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string FileExtensionsString { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileExtensionsString As String
Visual C++
public:
property String^ FileExtensionsString {
    String^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


InitialFileInputCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.InitialFileInputCount Property
RadUpload Class See Also Send Feedback
Returns the initial number of rows when the RadUpload control is first loaded..

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int InitialFileInputCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialFileInputCount As Integer
Visual C++
public:
property int InitialFileInputCount {
    int get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


InputFileCheckBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.InputFileCheckBox Property
RadUpload Class See Also Send Feedback
Returns file upload checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputCheckBox InputFileCheckBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputFileCheckBox As HtmlInputCheckBox
Visual C++
public:
property HtmlInputCheckBox^ InputFileCheckBox {
    HtmlInputCheckBox^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


InputFiles Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.InputFiles Property
RadUpload Class See Also Send Feedback
Returns upload input file controls.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<HtmlInputFile> InputFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputFiles As IList(Of HtmlInputFile)
Visual C++
public:
property IList<HtmlInputFile^>^ InputFiles {
    IList<HtmlInputFile^>^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.LocatorExpression Property
RadUpload Class See Also Send Feedback
Get the FindParam that defines the pattern for a RadUploadHtmlControl.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


MaxFileCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.MaxFileCount Property
RadUpload Class See Also Send Feedback
Get or set the maximum number of rows in the RadUpload control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MaxFileCount { get; set; }
Visual Basic (Declaration)
Public Property MaxFileCount As Integer
Visual C++
public:
property int MaxFileCount {
    int get ();
    void set (int value);
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


RemoveButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.RemoveButton Property
RadUpload Class See Also Send Feedback
Returns upload remove button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputButton RemoveButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property RemoveButton As HtmlInputButton
Visual C++
public:
property HtmlInputButton^ RemoveButton {
    HtmlInputButton^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


SelectButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.SelectButton Property
RadUpload Class See Also Send Feedback
Returns upload select button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HtmlInputButton SelectButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectButton As HtmlInputButton
Visual C++
public:
property HtmlInputButton^ SelectButton {
    HtmlInputButton^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


RadWindow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Class
Members See Also Send Feedback
RadWindow control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadWindow : HtmlDiv
Visual Basic (Declaration)
Public Class RadWindow _
    Inherits HtmlDiv
Visual C++
public ref class RadWindow : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.RadWindow

See Also

RadWindow Members
Telerik.WebAii.Controls.Html Namespace


RadWindow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Members
RadWindow Class Constructors Methods Properties See Also Send Feedback

The RadWindow type exposes the following members.

Constructors

Name | Description
RadWindow | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Closes RadWindow.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Maximize | Maximizes RadWindow.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes/Restores the RadWindow.
MouseClick | Overloaded.
MouseHover | Overloaded.
MoveTo | Moves RadWindow to specific coordinates(correct setting of Left and Top is only for Window without restriction zone).
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Reload | Reloads RadWindow.
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Resize | Resizes RadWindow.
Restore | Restores RadWindow.
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Shows RadWindow.
TogglePin | Toggles pin RadWindow.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadWindow. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the height of the Window.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActive | Determines whether the Window is active.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsClosed | Determines whether the Window is closed.
IsMaximized | Determines whether the Window is maximized.
IsMinimized | Determines whether the Window is minimized.
IsModal | Determines whether the Window is modal.
IsPinned | Determines whether the Window is pinned.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Left | Gets/Sets the left of the Window(correct setting of Left is only for Window without restriction zone).
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadWindow. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RestrictionZoneId | Gets/Sets the Id of the Window's restriction zone.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Status | Gets/Sets RadWindow status.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | Gets/Sets current RadWindow title.
Top | Gets/Sets the top of the Window(correct setting of Top is only for Window without restriction zone).
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the width of the Window.
WindowId | The Window's id.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RadWindow Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Constructor
RadWindow Class See Also Send Feedback

Overload List

Name | Description
RadWindow()()() | Initializes a new instance of the RadWindow class.
RadWindow(Element) | Initializes a new instance of the RadWindow class.

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


RadWindow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Constructor
RadWindow Class See Also Send Feedback
Initializes a new instance of the RadWindow class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadWindow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadWindow()

See Also

RadWindow Class
RadWindow Overload
Telerik.WebAii.Controls.Html Namespace


RadWindow Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Constructor (Element)
RadWindow Class See Also Send Feedback
Initializes a new instance of the RadWindow class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadWindow(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadWindow(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadWindow Class
RadWindow Overload
Telerik.WebAii.Controls.Html Namespace


RadWindow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Methods
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the control element. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Close | Closes RadWindow.
ControlAssert | Gets RadControlAssert instance initialized for this control.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Maximize | Maximizes RadWindow.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes/Restores the RadWindow.
MouseClick | Overloaded.
MouseHover | Overloaded.
MoveTo | Moves RadWindow to specific coordinates(correct setting of Left and Top is only for Window without restriction zone).
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Reload | Reloads RadWindow.
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Resize | Resizes RadWindow.
Restore | Restores RadWindow.
ScrollToVisible | Overloaded.
SetValue | Overloaded.
Show | Shows RadWindow.
TogglePin | Toggles pin RadWindow.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.AssignElement Method
RadWindow Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element
The underlying element object.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.CallMethod Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Capture Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Click Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Close Method
RadWindow Class See Also Send Feedback
Closes RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ControlAssert Method
RadWindow Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic (Declaration)
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.DragTo Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.GetValue Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.InvokeEvent Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Maximize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Maximize Method
RadWindow Class See Also Send Feedback
Maximizes RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Maximize()
Visual Basic (Declaration)
Public Sub Maximize
Visual C++
public:
void Maximize()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Minimize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Minimize Method
RadWindow Class See Also Send Feedback
Minimizes/Restores the RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Minimize()
Visual Basic (Declaration)
Public Sub Minimize
Visual C++
public:
void Minimize()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.MouseClick Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.MouseHover Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


MoveTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.MoveTo Method
RadWindow Class See Also Send Feedback
Moves RadWindow to specific coordinates(correct setting of Left and Top is only for Window without restriction zone).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveTo(
    int left,
    int top
)
Visual Basic (Declaration)
Public Sub MoveTo ( _
    left As Integer, _
    top As Integer _
)
Visual C++
public:
void MoveTo(
    int left,
    int top
)

Parameters

left
Type: System..::.Int32

[Missing <param name="left"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.MoveTo(System.Int32,System.Int32)"]

top
Type: System..::.Int32

[Missing <param name="top"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.MoveTo(System.Int32,System.Int32)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Reload Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Reload Method
RadWindow Class See Also Send Feedback
Reloads RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Reload()
Visual Basic (Declaration)
Public Sub Reload
Visual C++
public:
void Reload()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Resize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Resize Method
RadWindow Class See Also Send Feedback
Resizes RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resize(
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub Resize ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void Resize(
    int width,
    int height
)

Parameters

width
Type: System..::.Int32

[Missing <param name="width"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.Resize(System.Int32,System.Int32)"]

height
Type: System..::.Int32

[Missing <param name="height"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.Resize(System.Int32,System.Int32)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Restore Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Restore Method
RadWindow Class See Also Send Feedback
Restores RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Restore()
Visual Basic (Declaration)
Public Sub Restore
Visual C++
public:
void Restore()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ScrollToVisible Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.SetValue Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Show Method
RadWindow Class See Also Send Feedback
Shows RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


TogglePin Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.TogglePin Method
RadWindow Class See Also Send Feedback
Toggles pin RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePin()
Visual Basic (Declaration)
Public Sub TogglePin
Visual C++
public:
void TogglePin()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RadWindow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Properties
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Gets the client-side code that defines the RadWindow. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets/Sets the height of the Window.
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActive | Determines whether the Window is active.
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsClosed | Determines whether the Window is closed.
IsMaximized | Determines whether the Window is maximized.
IsMinimized | Determines whether the Window is minimized.
IsModal | Determines whether the Window is modal.
IsPinned | Determines whether the Window is pinned.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Left | Gets/Sets the left of the Window(correct setting of Left is only for Window without restriction zone).
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadWindow. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RestrictionZoneId | Gets/Sets the Id of the Window's restriction zone.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Status | Gets/Sets RadWindow status.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Title | Gets/Sets current RadWindow title.
Top | Gets/Sets the top of the Window(correct setting of Top is only for Window without restriction zone).
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets/Sets the width of the Window.
WindowId | The Window's id.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ClientSideLocator Property
RadWindow Class See Also Send Feedback
Gets the client-side code that defines the RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Height Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Height Property
RadWindow Class See Also Send Feedback
Gets/Sets the height of the Window.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


IsActive Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsActive Property
RadWindow Class See Also Send Feedback
Determines whether the Window is active.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsActive { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActive As Boolean
Visual C++
public:
property bool IsActive {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


IsClosed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsClosed Property
RadWindow Class See Also Send Feedback
Determines whether the Window is closed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsClosed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsClosed As Boolean
Visual C++
public:
property bool IsClosed {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


IsMaximized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsMaximized Property
RadWindow Class See Also Send Feedback
Determines whether the Window is maximized.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMaximized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMaximized As Boolean
Visual C++
public:
property bool IsMaximized {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


IsMinimized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsMinimized Property
RadWindow Class See Also Send Feedback
Determines whether the Window is minimized.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMinimized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMinimized As Boolean
Visual C++
public:
property bool IsMinimized {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


IsModal Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsModal Property
RadWindow Class See Also Send Feedback
Determines whether the Window is modal.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsModal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModal As Boolean
Visual C++
public:
property bool IsModal {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


IsPinned Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsPinned Property
RadWindow Class See Also Send Feedback
Determines whether the Window is pinned.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPinned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPinned As Boolean
Visual C++
public:
property bool IsPinned {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Left Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Left Property
RadWindow Class See Also Send Feedback
Gets/Sets the left of the Window(correct setting of Left is only for Window without restriction zone).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.LocatorExpression Property
RadWindow Class See Also Send Feedback
Gets the HtmlFindExpression that defines the pattern for a RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RestrictionZoneId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.RestrictionZoneId Property
RadWindow Class See Also Send Feedback
Gets/Sets the Id of the Window's restriction zone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string RestrictionZoneId { get; set; }
Visual Basic (Declaration)
Public Property RestrictionZoneId As String
Visual C++
public:
property String^ RestrictionZoneId {
    String^ get ();
    void set (String^ value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Status Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Status Property
RadWindow Class See Also Send Feedback
Gets/Sets RadWindow status.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Title Property
RadWindow Class See Also Send Feedback
Gets/Sets current RadWindow title.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Top Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Top Property
RadWindow Class See Also Send Feedback
Gets/Sets the top of the Window(correct setting of Top is only for Window without restriction zone).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Width Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Width Property
RadWindow Class See Also Send Feedback
Gets/Sets the width of the Window.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


WindowId Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.WindowId Property
RadWindow Class See Also Send Feedback
The Window's id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string WindowId { get; }
Visual Basic (Declaration)
Public ReadOnly Property WindowId As String
Visual C++
public:
property String^ WindowId {
    String^ get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RotatorConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorConstants Class
Members See Also Send Feedback
String constatns of the rotator(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class RotatorConstants
Visual Basic (Declaration)
Public NotInheritable Class RotatorConstants
Visual C++
public ref class RotatorConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.RotatorConstants

See Also

RotatorConstants Members
Telerik.WebAii.Controls.Html Namespace


RotatorConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorConstants Members
RotatorConstants Class Fields See Also Send Feedback

The RotatorConstants type exposes the following members.

Fields

Name | Description
CssButtons | The CSS class unique part of the Rotator scrolling buttons.
CssRotatorDiv | The CSS class unique part of the Rotator outer div element.
KeyRotator | The constant used as a key for the rotator level.

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


RotatorConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorConstants Fields
RotatorConstants Class See Also Send Feedback

The RotatorConstants type exposes the following members.

Fields

Name | Description
CssButtons | The CSS class unique part of the Rotator scrolling buttons.
CssRotatorDiv | The CSS class unique part of the Rotator outer div element.
KeyRotator | The constant used as a key for the rotator level.

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssButtons Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorConstants..::.CssButtons Field
RotatorConstants Class See Also Send Feedback
The CSS class unique part of the Rotator scrolling buttons.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssButtons
Visual Basic (Declaration)
Public Const CssButtons As String
Visual C++
public:
literal String^ CssButtons

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRotatorDiv Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorConstants..::.CssRotatorDiv Field
RotatorConstants Class See Also Send Feedback
The CSS class unique part of the Rotator outer div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRotatorDiv
Visual Basic (Declaration)
Public Const CssRotatorDiv As String
Visual C++
public:
literal String^ CssRotatorDiv

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyRotator Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorConstants..::.KeyRotator Field
RotatorConstants Class See Also Send Feedback
The constant used as a key for the rotator level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyRotator
Visual Basic (Declaration)
Public Const KeyRotator As String
Visual C++
public:
literal String^ KeyRotator

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


RotatorScrollDirection Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorScrollDirection Enumeration
See Also Send Feedback
Rotator scroll direction enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum RotatorScrollDirection
Visual Basic (Declaration)
Public Enumeration RotatorScrollDirection
Visual C++
public enum class RotatorScrollDirection

Members

Member name | Description
Left | The 'Left' direction.
Right | The 'Right' direction.
Horizontal | The 'Horizontal' direction.
Up | The 'Up' direction.
Down | The 'Down' direction.
Vertical | The 'Vertical' direction.

See Also

Telerik.WebAii.Controls.Html Namespace


RotatorScrollType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorScrollType Enumeration
See Also Send Feedback
Rotator scroll type enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum RotatorScrollType
Visual Basic (Declaration)
Public Enumeration RotatorScrollType
Visual C++
public enum class RotatorScrollType

Members

Member name | Description
Click | Click on a scroll button.
HoverOver | Hover over a scroll button.

See Also

Telerik.WebAii.Controls.Html Namespace


RotatorType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RotatorType Enumeration
See Also Send Feedback
The type of approach, that changes the icons of rotaror.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum RotatorType
Visual Basic (Declaration)
Public Enumeration RotatorType
Visual C++
public enum class RotatorType

Members

Member name | Description
AutomaticAdvance | The 'AutomaticAdvance' rotator type.
ButtonsOver | The 'ButtonsOver' rotator type.
Buttons | The 'Buttons' rotator type.
SlideShow | The 'SlideShow' rotator type.
SlideShowButtons | The 'SlideShowButtons' rotator type.
FromCode | The 'FromCode' rotator type.

See Also

Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Class
Members See Also Send Feedback
Class that represents the scheduler appointment object.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerAppointment : HtmlDiv
Visual Basic (Declaration)
Public Class SchedulerAppointment _
    Inherits HtmlDiv
Visual C++
public ref class SchedulerAppointment : public HtmlDiv

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlDiv
Telerik.WebAii.Controls.Html..::.SchedulerAppointment

See Also

SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Members
SchedulerAppointment Class Constructors Methods Properties See Also Send Feedback

The SchedulerAppointment type exposes the following members.

Constructors

Name | Description
SchedulerAppointment | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the scheduler appointment control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Delete | Delete appointment method.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Edit | Edit appointment method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Duration | Get the duration of the appointment.
End | Get the end date of the appointment.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsAllDay | Check whether the appointment is 'all day'.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RecurrenceState | Recurrence state of the appointment.
ResourceString | Returns a string containing the appointment resource types.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Start | Get the start date of the appointment.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Subject | Get the subject of this appointment.
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Tooltip | Get the tooltip of this appointment.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Constructor
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
SchedulerAppointment()()() | Initializes a new instance of the SchedulerAppointment class.
SchedulerAppointment(Element) | Initializes a new instance of the SchedulerAppointment class.

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Constructor
SchedulerAppointment Class See Also Send Feedback
Initializes a new instance of the SchedulerAppointment class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerAppointment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerAppointment()

See Also

SchedulerAppointment Class
SchedulerAppointment Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Constructor (Element)
SchedulerAppointment Class See Also Send Feedback
Initializes a new instance of the SchedulerAppointment class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerAppointment(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SchedulerAppointment(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerAppointment.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerAppointment Class
SchedulerAppointment Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Methods
SchedulerAppointment Class See Also Send Feedback

The SchedulerAppointment type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the scheduler appointment control. (Overrides HtmlDiv..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Delete | Delete appointment method.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Edit | Edit appointment method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.AssignElement Method
SchedulerAppointment Class See Also Send Feedback
Assign the DOM element to be the scheduler appointment control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerAppointment.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.CallMethod Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Capture Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Click Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Delete Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Delete Method
SchedulerAppointment Class See Also Send Feedback
Delete appointment method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.DragTo Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Edit Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Edit Method
SchedulerAppointment Class See Also Send Feedback
Edit appointment method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Edit()
Visual Basic (Declaration)
Public Sub Edit
Visual C++
public:
void Edit()

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.GetValue Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.InvokeEvent Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.MouseClick Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.MouseHover Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.ScrollToVisible Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.SetValue Method
SchedulerAppointment Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment Properties
SchedulerAppointment Class See Also Send Feedback

The SchedulerAppointment type exposes the following members.

Properties

Name | Description
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::.ClientSideLocator.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Duration | Get the duration of the appointment.
End | Get the end date of the appointment.
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsAllDay | Check whether the appointment is 'all day'.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
RecurrenceState | Recurrence state of the appointment.
ResourceString | Returns a string containing the appointment resource types.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Start | Get the start date of the appointment.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Subject | Get the subject of this appointment.
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Tooltip | Get the tooltip of this appointment.
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.ClientSideLocator Property
SchedulerAppointment Class See Also Send Feedback
Get the Client side locator - call method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


Duration Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Duration Property
SchedulerAppointment Class See Also Send Feedback
Get the duration of the appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Duration { get; }
Visual Basic (Declaration)
Public ReadOnly Property Duration As Integer
Visual C++
public:
property int Duration {
    int get ();
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


End Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.End Property
SchedulerAppointment Class See Also Send Feedback
Get the end date of the appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime End { get; set; }
Visual Basic (Declaration)
Public Property End As DateTime
Visual C++
public:
property DateTime End {
    DateTime get ();
    void set (DateTime value);
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


IsAllDay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.IsAllDay Property
SchedulerAppointment Class See Also Send Feedback
Check whether the appointment is 'all day'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAllDay { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAllDay As Boolean
Visual C++
public:
property bool IsAllDay {
    bool get ();
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.LocatorExpression Property
SchedulerAppointment Class See Also Send Feedback
Get the FindParam that defines the pattern for appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


RecurrenceState Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.RecurrenceState Property
SchedulerAppointment Class See Also Send Feedback
Recurrence state of the appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string RecurrenceState { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecurrenceState As String
Visual C++
public:
property String^ RecurrenceState {
    String^ get ();
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


ResourceString Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.ResourceString Property
SchedulerAppointment Class See Also Send Feedback
Returns a string containing the appointment resource types.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ResourceString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResourceString As String
Visual C++
public:
property String^ ResourceString {
    String^ get ();
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


Start Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Start Property
SchedulerAppointment Class See Also Send Feedback
Get the start date of the appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DateTime Start { get; set; }
Visual Basic (Declaration)
Public Property Start As DateTime
Visual C++
public:
property DateTime Start {
    DateTime get ();
    void set (DateTime value);
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


Subject Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Subject Property
SchedulerAppointment Class See Also Send Feedback
Get the subject of this appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Subject { get; }
Visual Basic (Declaration)
Public ReadOnly Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


Tooltip Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerAppointment..::.Tooltip Property
SchedulerAppointment Class See Also Send Feedback
Get the tooltip of this appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Tooltip { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tooltip As String
Visual C++
public:
property String^ Tooltip {
    String^ get ();
}

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


SchedulerConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants Class
Members See Also Send Feedback
Represents the scheduler constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SchedulerConstants
Visual Basic (Declaration)
Public NotInheritable Class SchedulerConstants
Visual C++
public ref class SchedulerConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.SchedulerConstants

See Also

SchedulerConstants Members
Telerik.WebAii.Controls.Html Namespace


SchedulerConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants Members
SchedulerConstants Class Fields See Also Send Feedback

The SchedulerConstants type exposes the following members.

Fields

Name | Description
AdvancedFormKey | The advanced form key used accross the verifications and action messages.
AppointmentKey | The appointment key used accross the verifications and action messages.
CssAdvancedFormCancel | CSS classes constants -- advanced form button cancel.
CssAdvancedFormSave | CSS classes constants -- advanced form button save.
CssAllDayTable | CSS classes constants -- advanced form button cancel.
CssAppointment | CSS classes constants -- appointment.
CssAppointmentAptOut | CSS classes constants -- appointment inner div.
CssAppointmentDelete | CSS classes constants -- appointment delete button.
CssAppointmentWrapper | CSS classes constants -- appointment wrapper.
CssContentTable | CSS classes constants -- advanced form button cancel.
CssInlineFormCancel | CSS classes constants -- inline form cancel button.
CssInlineFormConfirm | CSS classes constants -- inline form save button.
CssInlineFormMore | CSS classes constants -- inline form options button.
CssModalDialogClose | CSS classes constants -- modal dialog button cancel.
CssModalDialogConfirm | CSS classes constants -- modal dialog button save.
CssScheduler | CSS class of the scheduler.
CssSchedulerAdvancedEditWrapper | CSS class of the scheduler advanced edit form wrapper.
CssSchedulerAdvancedForm | CSS class of the scheduler advanced form.
CssSchedulerAdvancedFormHidden | CSS class of the scheduler advanced form hidden.
CssSchedulerAdvancedInsertWrapper | CSS class of the scheduler advanced insert form wrapper.
CssSchedulerDatePicker | CSS class of the scheduler picker activator arrow.
CssSchedulerDayView | CSS class of the scheduler day view header.
CssSchedulerHeader | CSS class of the scheduler header.
CssSchedulerHoursLink | CSS class of the scheduler full time link.
CssSchedulerInlineForm | CSS class of the scheduler inline form wrapper.
CssSchedulerModalDialog | CSS class of the scheduler modal dialog.
CssSchedulerModalDialogTitle | CSS class of the scheduler modal dialog title.
CssSchedulerMonthView | CSS class of the scheduler month view header.
CssSchedulerNextDay | CSS class of the scheduler next day arrow.
CssSchedulerPickerWrapper | CSS class of the scheduler date picker wrapper.
CssSchedulerPreviousDay | CSS class of the scheduler previous day arrow.
CssSchedulerTimelineView | CSS class of the scheduler timeline view header.
CssSchedulerToday | CSS class of the scheduler today arrow.
CssSchedulerWeekView | CSS class of the scheduler week view header.
CssTimeslot | CSS classes constants -- timeslot.
IdModalDialogOption1 | The modal dialog option1 key used accross the verifications and action messages.
IdModalDialogOption2 | The modal dialog option2 key used accross the verifications and action messages.
IdSchedulerAdvancedFormAllDayCheckBox | The advanced form all day checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormCancelButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerAdvancedFormMoreControlsPanel | The advanced form more controls panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrenceCheckBox | The advanced form recurrence checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrencePanel | The advanced form recurrence panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormText | The advanced form subject textbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormUpdateButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerInlineFormText | The inline form textbox id used accross the verifications and action messages.
SchedulerKey | The Scheduler key used accross the verifications and action messages.

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants Fields
SchedulerConstants Class See Also Send Feedback

The SchedulerConstants type exposes the following members.

Fields

Name | Description
AdvancedFormKey | The advanced form key used accross the verifications and action messages.
AppointmentKey | The appointment key used accross the verifications and action messages.
CssAdvancedFormCancel | CSS classes constants -- advanced form button cancel.
CssAdvancedFormSave | CSS classes constants -- advanced form button save.
CssAllDayTable | CSS classes constants -- advanced form button cancel.
CssAppointment | CSS classes constants -- appointment.
CssAppointmentAptOut | CSS classes constants -- appointment inner div.
CssAppointmentDelete | CSS classes constants -- appointment delete button.
CssAppointmentWrapper | CSS classes constants -- appointment wrapper.
CssContentTable | CSS classes constants -- advanced form button cancel.
CssInlineFormCancel | CSS classes constants -- inline form cancel button.
CssInlineFormConfirm | CSS classes constants -- inline form save button.
CssInlineFormMore | CSS classes constants -- inline form options button.
CssModalDialogClose | CSS classes constants -- modal dialog button cancel.
CssModalDialogConfirm | CSS classes constants -- modal dialog button save.
CssScheduler | CSS class of the scheduler.
CssSchedulerAdvancedEditWrapper | CSS class of the scheduler advanced edit form wrapper.
CssSchedulerAdvancedForm | CSS class of the scheduler advanced form.
CssSchedulerAdvancedFormHidden | CSS class of the scheduler advanced form hidden.
CssSchedulerAdvancedInsertWrapper | CSS class of the scheduler advanced insert form wrapper.
CssSchedulerDatePicker | CSS class of the scheduler picker activator arrow.
CssSchedulerDayView | CSS class of the scheduler day view header.
CssSchedulerHeader | CSS class of the scheduler header.
CssSchedulerHoursLink | CSS class of the scheduler full time link.
CssSchedulerInlineForm | CSS class of the scheduler inline form wrapper.
CssSchedulerModalDialog | CSS class of the scheduler modal dialog.
CssSchedulerModalDialogTitle | CSS class of the scheduler modal dialog title.
CssSchedulerMonthView | CSS class of the scheduler month view header.
CssSchedulerNextDay | CSS class of the scheduler next day arrow.
CssSchedulerPickerWrapper | CSS class of the scheduler date picker wrapper.
CssSchedulerPreviousDay | CSS class of the scheduler previous day arrow.
CssSchedulerTimelineView | CSS class of the scheduler timeline view header.
CssSchedulerToday | CSS class of the scheduler today arrow.
CssSchedulerWeekView | CSS class of the scheduler week view header.
CssTimeslot | CSS classes constants -- timeslot.
IdModalDialogOption1 | The modal dialog option1 key used accross the verifications and action messages.
IdModalDialogOption2 | The modal dialog option2 key used accross the verifications and action messages.
IdSchedulerAdvancedFormAllDayCheckBox | The advanced form all day checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormCancelButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerAdvancedFormMoreControlsPanel | The advanced form more controls panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrenceCheckBox | The advanced form recurrence checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrencePanel | The advanced form recurrence panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormText | The advanced form subject textbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormUpdateButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerInlineFormText | The inline form textbox id used accross the verifications and action messages.
SchedulerKey | The Scheduler key used accross the verifications and action messages.

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.AdvancedFormKey Field
SchedulerConstants Class See Also Send Feedback
The advanced form key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AdvancedFormKey
Visual Basic (Declaration)
Public Const AdvancedFormKey As String
Visual C++
public:
literal String^ AdvancedFormKey

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


AppointmentKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.AppointmentKey Field
SchedulerConstants Class See Also Send Feedback
The appointment key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentKey
Visual Basic (Declaration)
Public Const AppointmentKey As String
Visual C++
public:
literal String^ AppointmentKey

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedFormCancel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAdvancedFormCancel Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAdvancedFormCancel
Visual Basic (Declaration)
Public Const CssAdvancedFormCancel As String
Visual C++
public:
literal String^ CssAdvancedFormCancel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedFormSave Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAdvancedFormSave Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button save.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAdvancedFormSave
Visual Basic (Declaration)
Public Const CssAdvancedFormSave As String
Visual C++
public:
literal String^ CssAdvancedFormSave

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAllDayTable Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAllDayTable Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAllDayTable
Visual Basic (Declaration)
Public Const CssAllDayTable As String
Visual C++
public:
literal String^ CssAllDayTable

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointment Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAppointment Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAppointment
Visual Basic (Declaration)
Public Const CssAppointment As String
Visual C++
public:
literal String^ CssAppointment

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointmentAptOut Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAppointmentAptOut Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment inner div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAppointmentAptOut
Visual Basic (Declaration)
Public Const CssAppointmentAptOut As String
Visual C++
public:
literal String^ CssAppointmentAptOut

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointmentDelete Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAppointmentDelete Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAppointmentDelete
Visual Basic (Declaration)
Public Const CssAppointmentDelete As String
Visual C++
public:
literal String^ CssAppointmentDelete

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointmentWrapper Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssAppointmentWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAppointmentWrapper
Visual Basic (Declaration)
Public Const CssAppointmentWrapper As String
Visual C++
public:
literal String^ CssAppointmentWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssContentTable Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssContentTable Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssContentTable
Visual Basic (Declaration)
Public Const CssContentTable As String
Visual C++
public:
literal String^ CssContentTable

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInlineFormCancel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssInlineFormCancel Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- inline form cancel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssInlineFormCancel
Visual Basic (Declaration)
Public Const CssInlineFormCancel As String
Visual C++
public:
literal String^ CssInlineFormCancel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInlineFormConfirm Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssInlineFormConfirm Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- inline form save button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssInlineFormConfirm
Visual Basic (Declaration)
Public Const CssInlineFormConfirm As String
Visual C++
public:
literal String^ CssInlineFormConfirm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInlineFormMore Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssInlineFormMore Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- inline form options button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssInlineFormMore
Visual Basic (Declaration)
Public Const CssInlineFormMore As String
Visual C++
public:
literal String^ CssInlineFormMore

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssModalDialogClose Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssModalDialogClose Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- modal dialog button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssModalDialogClose
Visual Basic (Declaration)
Public Const CssModalDialogClose As String
Visual C++
public:
literal String^ CssModalDialogClose

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssModalDialogConfirm Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssModalDialogConfirm Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- modal dialog button save.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssModalDialogConfirm
Visual Basic (Declaration)
Public Const CssModalDialogConfirm As String
Visual C++
public:
literal String^ CssModalDialogConfirm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssScheduler Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssScheduler Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssScheduler
Visual Basic (Declaration)
Public Const CssScheduler As String
Visual C++
public:
literal String^ CssScheduler

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedEditWrapper Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerAdvancedEditWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced edit form wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerAdvancedEditWrapper
Visual Basic (Declaration)
Public Const CssSchedulerAdvancedEditWrapper As String
Visual C++
public:
literal String^ CssSchedulerAdvancedEditWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedForm Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerAdvancedForm Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerAdvancedForm
Visual Basic (Declaration)
Public Const CssSchedulerAdvancedForm As String
Visual C++
public:
literal String^ CssSchedulerAdvancedForm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedFormHidden Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerAdvancedFormHidden Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced form hidden.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerAdvancedFormHidden
Visual Basic (Declaration)
Public Const CssSchedulerAdvancedFormHidden As String
Visual C++
public:
literal String^ CssSchedulerAdvancedFormHidden

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedInsertWrapper Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerAdvancedInsertWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced insert form wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerAdvancedInsertWrapper
Visual Basic (Declaration)
Public Const CssSchedulerAdvancedInsertWrapper As String
Visual C++
public:
literal String^ CssSchedulerAdvancedInsertWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerDatePicker Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerDatePicker Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler picker activator arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerDatePicker
Visual Basic (Declaration)
Public Const CssSchedulerDatePicker As String
Visual C++
public:
literal String^ CssSchedulerDatePicker

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerDayView Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerDayView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler day view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerDayView
Visual Basic (Declaration)
Public Const CssSchedulerDayView As String
Visual C++
public:
literal String^ CssSchedulerDayView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerHeader Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerHeader Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerHeader
Visual Basic (Declaration)
Public Const CssSchedulerHeader As String
Visual C++
public:
literal String^ CssSchedulerHeader

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerHoursLink Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerHoursLink Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler full time link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerHoursLink
Visual Basic (Declaration)
Public Const CssSchedulerHoursLink As String
Visual C++
public:
literal String^ CssSchedulerHoursLink

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerInlineForm Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerInlineForm Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler inline form wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerInlineForm
Visual Basic (Declaration)
Public Const CssSchedulerInlineForm As String
Visual C++
public:
literal String^ CssSchedulerInlineForm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerModalDialog Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerModalDialog Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler modal dialog.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerModalDialog
Visual Basic (Declaration)
Public Const CssSchedulerModalDialog As String
Visual C++
public:
literal String^ CssSchedulerModalDialog

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerModalDialogTitle Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerModalDialogTitle Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler modal dialog title.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerModalDialogTitle
Visual Basic (Declaration)
Public Const CssSchedulerModalDialogTitle As String
Visual C++
public:
literal String^ CssSchedulerModalDialogTitle

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerMonthView Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerMonthView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler month view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerMonthView
Visual Basic (Declaration)
Public Const CssSchedulerMonthView As String
Visual C++
public:
literal String^ CssSchedulerMonthView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerNextDay Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerNextDay Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler next day arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerNextDay
Visual Basic (Declaration)
Public Const CssSchedulerNextDay As String
Visual C++
public:
literal String^ CssSchedulerNextDay

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerPickerWrapper Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerPickerWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler date picker wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerPickerWrapper
Visual Basic (Declaration)
Public Const CssSchedulerPickerWrapper As String
Visual C++
public:
literal String^ CssSchedulerPickerWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerPreviousDay Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerPreviousDay Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler previous day arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerPreviousDay
Visual Basic (Declaration)
Public Const CssSchedulerPreviousDay As String
Visual C++
public:
literal String^ CssSchedulerPreviousDay

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerTimelineView Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerTimelineView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler timeline view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerTimelineView
Visual Basic (Declaration)
Public Const CssSchedulerTimelineView As String
Visual C++
public:
literal String^ CssSchedulerTimelineView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerToday Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerToday Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler today arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerToday
Visual Basic (Declaration)
Public Const CssSchedulerToday As String
Visual C++
public:
literal String^ CssSchedulerToday

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerWeekView Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssSchedulerWeekView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler week view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSchedulerWeekView
Visual Basic (Declaration)
Public Const CssSchedulerWeekView As String
Visual C++
public:
literal String^ CssSchedulerWeekView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTimeslot Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.CssTimeslot Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- timeslot.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTimeslot
Visual Basic (Declaration)
Public Const CssTimeslot As String
Visual C++
public:
literal String^ CssTimeslot

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdModalDialogOption1 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdModalDialogOption1 Field
SchedulerConstants Class See Also Send Feedback
The modal dialog option1 key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdModalDialogOption1
Visual Basic (Declaration)
Public Const IdModalDialogOption1 As String
Visual C++
public:
literal String^ IdModalDialogOption1

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdModalDialogOption2 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdModalDialogOption2 Field
SchedulerConstants Class See Also Send Feedback
The modal dialog option2 key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdModalDialogOption2
Visual Basic (Declaration)
Public Const IdModalDialogOption2 As String
Visual C++
public:
literal String^ IdModalDialogOption2

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormAllDayCheckBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormAllDayCheckBox Field
SchedulerConstants Class See Also Send Feedback
The advanced form all day checkbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormAllDayCheckBox
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormAllDayCheckBox As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormAllDayCheckBox

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormCancelButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormCancelButton Field
SchedulerConstants Class See Also Send Feedback
The advanced form save button used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormCancelButton
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormCancelButton As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormCancelButton

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormMoreControlsPanel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormMoreControlsPanel Field
SchedulerConstants Class See Also Send Feedback
The advanced form more controls panel id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormMoreControlsPanel
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormMoreControlsPanel As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormMoreControlsPanel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormRecurrenceCheckBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormRecurrenceCheckBox Field
SchedulerConstants Class See Also Send Feedback
The advanced form recurrence checkbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormRecurrenceCheckBox
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormRecurrenceCheckBox As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormRecurrenceCheckBox

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormRecurrencePanel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormRecurrencePanel Field
SchedulerConstants Class See Also Send Feedback
The advanced form recurrence panel id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormRecurrencePanel
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormRecurrencePanel As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormRecurrencePanel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormText Field
SchedulerConstants Class See Also Send Feedback
The advanced form subject textbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormText
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormText As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormText

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormUpdateButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerAdvancedFormUpdateButton Field
SchedulerConstants Class See Also Send Feedback
The advanced form save button used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerAdvancedFormUpdateButton
Visual Basic (Declaration)
Public Const IdSchedulerAdvancedFormUpdateButton As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormUpdateButton

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerInlineFormText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.IdSchedulerInlineFormText Field
SchedulerConstants Class See Also Send Feedback
The inline form textbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdSchedulerInlineFormText
Visual Basic (Declaration)
Public Const IdSchedulerInlineFormText As String
Visual C++
public:
literal String^ IdSchedulerInlineFormText

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerConstants..::.SchedulerKey Field
SchedulerConstants Class See Also Send Feedback
The Scheduler key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SchedulerKey
Visual Basic (Declaration)
Public Const SchedulerKey As String
Visual C++
public:
literal String^ SchedulerKey

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Class
Members See Also Send Feedback
Represents the SchedulerTimeSlot class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerTimeSlot : HtmlTableCell
Visual Basic (Declaration)
Public Class SchedulerTimeSlot _
    Inherits HtmlTableCell
Visual C++
public ref class SchedulerTimeSlot : public HtmlTableCell

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Controls..::.Control
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlContainerControl
ArtOfTest.WebAii.Controls.HtmlControls..::.HtmlTableCell
Telerik.WebAii.Controls.Html..::.SchedulerTimeSlot

See Also

SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Members
SchedulerTimeSlot Class Constructors Methods Properties See Also Send Feedback

The SchedulerTimeSlot type exposes the following members.

Constructors

Name | Description
SchedulerTimeSlot | Overloaded.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the TimeSlot control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InsertAppointment | Insert appointment method.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsAllDay | Get whether the time slot is all day type.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ResourceText | Get the resource text if available or null, otherwise.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Scheduler | Get the parent scheduler.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
StartTime | Get start time of the time slot.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Constructor
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
SchedulerTimeSlot()()() | Initializes a new instance of the SchedulerTimeSlot class.
SchedulerTimeSlot(Element) | Initializes a new instance of the SchedulerTimeSlot class.

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Constructor
SchedulerTimeSlot Class See Also Send Feedback
Initializes a new instance of the SchedulerTimeSlot class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerTimeSlot()

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Constructor (Element)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Constructor (Element)
SchedulerTimeSlot Class See Also Send Feedback
Initializes a new instance of the SchedulerTimeSlot class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimeSlot(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SchedulerTimeSlot(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerTimeSlot.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Methods
SchedulerTimeSlot Class See Also Send Feedback

The SchedulerTimeSlot type exposes the following members.

Methods

Name | Description
AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
AssignElement | Assign the DOM element to be the TimeSlot control. (Overrides HtmlTableCell..::.AssignElement(Element).)
AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
CallMethod | Overloaded.
Capture | Overloaded.
Click | Overloaded.
Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
DragTo | Overloaded.
DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParentContainer<(Of <(TContainerControl>)>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Focus | Give this Html element focus. (Inherited from HtmlControl.)
GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
InsertAppointment | Insert appointment method.
InvokeEvent | Overloaded.
IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseHover | Overloaded.
Parent<(Of <(TContainerControl>)>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
ScrollToVisible | Overloaded.
SetValue | Overloaded.
ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
ValidateTag | Validate a tag name (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.AssignElement Method
SchedulerTimeSlot Class See Also Send Feedback
Assign the DOM element to be the TimeSlot control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic (Declaration)
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::.Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerTimeSlot.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.CallMethod Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
CallMethod<(Of <(T>)>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.Capture Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
Capture()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.Click Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
Click()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.DragTo Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.GetValue Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
GetValue<(Of <(T>)>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
GetValue<(Of <(T>)>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


InsertAppointment Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.InsertAppointment Method
SchedulerTimeSlot Class See Also Send Feedback
Insert appointment method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void InsertAppointment()
Visual Basic (Declaration)
Public Sub InsertAppointment
Visual C++
public:
void InsertAppointment()

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.InvokeEvent Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.MouseClick Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
MouseClick()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.MouseHover Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
MouseHover()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.ScrollToVisible Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.SetValue Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

Name | Description
SetValue<(Of <(T>)>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
SetValue<(Of <(T>)>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot Properties
SchedulerTimeSlot Class See Also Send Feedback

The SchedulerTimeSlot type exposes the following members.

Properties

Name | Description
Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
ClientSideLocator | Client side locator. (Overrides HtmlControl..::.ClientSideLocator.)
ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Find | Find property (Inherited from HtmlControl.)
Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
ID | This HtmlControl's ID. (Inherited from HtmlControl.)
InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
IsAllDay | Get whether the time slot is all day type.
IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::.LocatorExpression.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
ResourceText | Get the resource text if available or null, otherwise.
RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Scheduler | Get the parent scheduler.
ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
StartTime | Get start time of the time slot.
Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Text | Obsolete. Gets the text content of the cell. (Inherited from HtmlTableCell.)
TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


ClientSideLocator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.ClientSideLocator Property
SchedulerTimeSlot Class See Also Send Feedback
Client side locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string ClientSideLocator { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ClientSideLocator As String
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get () override;
}

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


IsAllDay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.IsAllDay Property
SchedulerTimeSlot Class See Also Send Feedback
Get whether the time slot is all day type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAllDay { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAllDay As Boolean
Visual C++
public:
property bool IsAllDay {
    bool get ();
}

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


LocatorExpression Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.LocatorExpression Property
SchedulerTimeSlot Class See Also Send Feedback
Get the FindParam that defines the pattern for appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override IFindExpression LocatorExpression { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LocatorExpression As IFindExpression
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get () override;
}

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


ResourceText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.ResourceText Property
SchedulerTimeSlot Class See Also Send Feedback
Get the resource text if available or null, otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ResourceText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResourceText As String
Visual C++
public:
property String^ ResourceText {
    String^ get ();
}

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


Scheduler Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.Scheduler Property
SchedulerTimeSlot Class See Also Send Feedback
Get the parent scheduler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadScheduler Scheduler { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scheduler As RadScheduler
Visual C++
public:
property RadScheduler^ Scheduler {
    RadScheduler^ get ();
}

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


StartTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimeSlot..::.StartTime Property
SchedulerTimeSlot Class See Also Send Feedback
Get start time of the time slot.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StartTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTime As String
Visual C++
public:
property String^ StartTime {
    String^ get ();
}

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


SchedulerViewNavigationType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerViewNavigationType Enumeration
See Also Send Feedback
Type of scheduler view navigarion.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SchedulerViewNavigationType
Visual Basic (Declaration)
Public Enumeration SchedulerViewNavigationType
Visual C++
public enum class SchedulerViewNavigationType

Members

Member name | Description
DayView | Describes navigate to DayView action.
WeekView | Describes navigate to WeekView action.
MonthView | Describes navigate to MonthView action.
TimelineView | Describes navigate to TimeLineView action.

See Also

Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Class
Members See Also Send Feedback
Represents a custom collection of DateTime objects, serving as return type of RadCalendar wrapper properties and methods.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
[SerializableAttribute]
public class SelectedDateCollection : Collection<DateTime>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SelectedDateCollection _
    Inherits Collection(Of DateTime)
Visual C++
[SerializableAttribute]
public ref class SelectedDateCollection : public Collection<DateTime>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DateTime >)>)
Telerik.WebAii.Controls.Html..::.SelectedDateCollection

See Also

SelectedDateCollection Members
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Members
SelectedDateCollection Class Constructors Methods Properties See Also Send Feedback

The SelectedDateCollection type exposes the following members.

Constructors

Name | Description
SelectedDateCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DateTime >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
InitializeCodeExpression | Generates initialization code for the selected date collection.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
Matches | Get whether the current colleciton items match those from the given collection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Constructor
SelectedDateCollection Class See Also Send Feedback

Overload List

Name | Description
SelectedDateCollection()()() | Initializes a new instance of the SelectedDateCollection class. The empty constructor.
SelectedDateCollection(IList<(Of <(DateTime>)>)) | Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified list.
SelectedDateCollection(array<DateTime>[]()[]) | Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified DateTime objects array.

See Also

SelectedDateCollection Class
SelectedDateCollection Members
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Constructor
SelectedDateCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDateCollection class. The empty constructor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SelectedDateCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectedDateCollection()

See Also

SelectedDateCollection Class
SelectedDateCollection Overload
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor (IList(DateTime))

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Constructor (IList<(Of <(DateTime>)>))
SelectedDateCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified list.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SelectedDateCollection(
    IList<DateTime> list
)
Visual Basic (Declaration)
Public Sub New ( _
    list As IList(Of DateTime) _
)
Visual C++
public:
SelectedDateCollection(
    IList<DateTime>^ list
)

Parameters

list
Type: System.Collections.Generic..::.IList <(Of <( DateTime >)>)

[Missing <param name="list"/> documentation for "M:Telerik.WebAii.Controls.Html.SelectedDateCollection.#ctor(System.Collections.Generic.IList{System.DateTime})"]

See Also

SelectedDateCollection Class
SelectedDateCollection Overload
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor (DateTime[])

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Constructor (array<DateTime>[]()[])
SelectedDateCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified DateTime objects array.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SelectedDateCollection(
    DateTime[] datesArray
)
Visual Basic (Declaration)
Public Sub New ( _
    datesArray As DateTime() _
)
Visual C++
public:
SelectedDateCollection(
    array<DateTime>^ datesArray
)

Parameters

datesArray
Type: array< System..::.DateTime >[]()[]

[Missing <param name="datesArray"/> documentation for "M:Telerik.WebAii.Controls.Html.SelectedDateCollection.#ctor(System.DateTime[])"]

See Also

SelectedDateCollection Class
SelectedDateCollection Overload
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Methods
SelectedDateCollection Class See Also Send Feedback

The SelectedDateCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DateTime >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
InitializeCodeExpression | Generates initialization code for the selected date collection.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
Matches | Get whether the current colleciton items match those from the given collection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


InitializeCodeExpression Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection..::.InitializeCodeExpression Method
SelectedDateCollection Class See Also Send Feedback
Generates initialization code for the selected date collection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string InitializeCodeExpression()
Visual Basic (Declaration)
Public Function InitializeCodeExpression As String
Visual C++
public:
String^ InitializeCodeExpression()

Return Value

The initialization code for the selected date collection.

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


Matches Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection..::.Matches Method
SelectedDateCollection Class See Also Send Feedback
Get whether the current colleciton items match those from the given collection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Matches(
    SelectedDateCollection dates
)
Visual Basic (Declaration)
Public Function Matches ( _
    dates As SelectedDateCollection _
) As Boolean
Visual C++
public:
bool Matches(
    SelectedDateCollection^ dates
)

Parameters

dates
Type: Telerik.WebAii.Controls.Html..::.SelectedDateCollection
The date collection to compare.

Return Value

Whether the current colleciton items match those from the given collection.

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SelectedDateCollection Properties
SelectedDateCollection Class See Also Send Feedback

The SelectedDateCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DateTime >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DateTime >)>).)

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


SliderConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants Class
Members See Also Send Feedback
String constatns of the slider(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SliderConstants
Visual Basic (Declaration)
Public NotInheritable Class SliderConstants
Visual C++
public ref class SliderConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.SliderConstants

See Also

SliderConstants Members
Telerik.WebAii.Controls.Html Namespace


SliderConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants Members
SliderConstants Class Fields See Also Send Feedback

The SliderConstants type exposes the following members.

Fields

Name | Description
CssDragHandle | The CSS class identifying the Slider thumb anchor.
CssHandleDecrease | The CSS class identifying the Slider's decrease handler element.
CssHandleIncrease | The CSS class identifying the Slider's increase handler element.
CssLargeTick | The CSS class identifying the Slider thumb anchor.
CssSliderItem | The CSS class identifying a Slider item.
CssSliderRegion | The CSS class identifying the Slider's selected region element.
CssSliderTrack | The CSS class identifying the Slider's track element.
CssSmallTick | The CSS class identifying the Slider thumb anchor.
KeySlider | The key identifying the Slider control.
SliderIdPrefix | The ID prefix identifying the Slider control.

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


SliderConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants Fields
SliderConstants Class See Also Send Feedback

The SliderConstants type exposes the following members.

Fields

Name | Description
CssDragHandle | The CSS class identifying the Slider thumb anchor.
CssHandleDecrease | The CSS class identifying the Slider's decrease handler element.
CssHandleIncrease | The CSS class identifying the Slider's increase handler element.
CssLargeTick | The CSS class identifying the Slider thumb anchor.
CssSliderItem | The CSS class identifying a Slider item.
CssSliderRegion | The CSS class identifying the Slider's selected region element.
CssSliderTrack | The CSS class identifying the Slider's track element.
CssSmallTick | The CSS class identifying the Slider thumb anchor.
KeySlider | The key identifying the Slider control.
SliderIdPrefix | The ID prefix identifying the Slider control.

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDragHandle Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssDragHandle Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider thumb anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssDragHandle
Visual Basic (Declaration)
Public Const CssDragHandle As String
Visual C++
public:
literal String^ CssDragHandle

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHandleDecrease Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssHandleDecrease Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's decrease handler element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssHandleDecrease
Visual Basic (Declaration)
Public Const CssHandleDecrease As String
Visual C++
public:
literal String^ CssHandleDecrease

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHandleIncrease Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssHandleIncrease Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's increase handler element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssHandleIncrease
Visual Basic (Declaration)
Public Const CssHandleIncrease As String
Visual C++
public:
literal String^ CssHandleIncrease

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLargeTick Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssLargeTick Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider thumb anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssLargeTick
Visual Basic (Declaration)
Public Const CssLargeTick As String
Visual C++
public:
literal String^ CssLargeTick

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssSliderItem Field
SliderConstants Class See Also Send Feedback
The CSS class identifying a Slider item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSliderItem
Visual Basic (Declaration)
Public Const CssSliderItem As String
Visual C++
public:
literal String^ CssSliderItem

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderRegion Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssSliderRegion Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's selected region element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSliderRegion
Visual Basic (Declaration)
Public Const CssSliderRegion As String
Visual C++
public:
literal String^ CssSliderRegion

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderTrack Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssSliderTrack Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's track element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSliderTrack
Visual Basic (Declaration)
Public Const CssSliderTrack As String
Visual C++
public:
literal String^ CssSliderTrack

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSmallTick Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.CssSmallTick Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider thumb anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSmallTick
Visual Basic (Declaration)
Public Const CssSmallTick As String
Visual C++
public:
literal String^ CssSmallTick

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySlider Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.KeySlider Field
SliderConstants Class See Also Send Feedback
The key identifying the Slider control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeySlider
Visual Basic (Declaration)
Public Const KeySlider As String
Visual C++
public:
literal String^ KeySlider

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


SliderIdPrefix Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderConstants..::.SliderIdPrefix Field
SliderConstants Class See Also Send Feedback
The ID prefix identifying the Slider control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SliderIdPrefix
Visual Basic (Declaration)
Public Const SliderIdPrefix As String
Visual C++
public:
literal String^ SliderIdPrefix

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


SliderDirection Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderDirection Enumeration
See Also Send Feedback
Slider direction.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SliderDirection
Visual Basic (Declaration)
Public Enumeration SliderDirection
Visual C++
public enum class SliderDirection

Members

Member name | Description
Standard | Direction is standard.
Reversed | Direction is reversed.

See Also

Telerik.WebAii.Controls.Html Namespace


SliderOrientation Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderOrientation Enumeration
See Also Send Feedback
Slider orientation enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SliderOrientation
Visual Basic (Declaration)
Public Enumeration SliderOrientation
Visual C++
public enum class SliderOrientation

Members

Member name | Description
Horizontal | Slider is horizontal.
Vertical | Slider is vertical.

See Also

Telerik.WebAii.Controls.Html Namespace


SlidingPaneActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SlidingPaneActionType Enumeration
See Also Send Feedback
Action type enumeration of the splitter sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SlidingPaneActionType
Visual Basic (Declaration)
Public Enumeration SlidingPaneActionType
Visual C++
public enum class SlidingPaneActionType

Members

Member name | Description
Collapse | Collapse the sliding pane.
Expand | Expand the sliding pane.
Dock | Dock the sliding pane.
Undock | Undock the sliding pane.

See Also

Telerik.WebAii.Controls.Html Namespace


SpellConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants Class
Members See Also Send Feedback
String constatns of the radspell(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SpellConstants
Visual Basic (Declaration)
Public NotInheritable Class SpellConstants
Visual C++
public ref class SpellConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.SpellConstants

See Also

SpellConstants Members
Telerik.WebAii.Controls.Html Namespace


SpellConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants Members
SpellConstants Class Fields See Also Send Feedback

The SpellConstants type exposes the following members.

Fields

Name | Description
CssInner | CSS of the inner spell dialog button span element.
CssLink | CSS of the outer spell dialog button link element.
CssRadSpellDialog | CSS class of the spell dialog div element.
IdButtonAddCustom | Id of the spell dialog "AddCustom" button.
IdButtonCancel | Id of the spell dialog "Close" button.
IdButtonChange | Id of the spell dialog "Change" button.
IdButtonChangeAll | Id of the spell dialog "ChangeAll" button.
IdButtonIgnore | Id of the spell dialog "Ignore" button.
IdButtonIgnoreAll | Id of the spell dialog "IgnoreAlll" button.
IdButtonUndo | Id of the spell dialog "Undo" button.
IdLink | Id of the outer spell dialog button link element.
IdLinkAddCustom | Id of the outer spell dialog "AddCustom" button link element.
IdLinkCancel | Id of the outer spell dialog "Close" button link element.
IdLinkChange | Id of the outer spell dialog "Change" button link element.
IdLinkChangeAll | Id of the outer spell dialog "ChangeAll" button link element.
IdLinkIgnore | Id of the outer spell dialog "Ignore" button link element.
IdLinkIgnoreAll | Id of the outer spell dialog "IgnoreAll" button link element.
IdLinkUndo | Id of the outer spell dialog "Undo" button link element.

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


SpellConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants Fields
SpellConstants Class See Also Send Feedback

The SpellConstants type exposes the following members.

Fields

Name | Description
CssInner | CSS of the inner spell dialog button span element.
CssLink | CSS of the outer spell dialog button link element.
CssRadSpellDialog | CSS class of the spell dialog div element.
IdButtonAddCustom | Id of the spell dialog "AddCustom" button.
IdButtonCancel | Id of the spell dialog "Close" button.
IdButtonChange | Id of the spell dialog "Change" button.
IdButtonChangeAll | Id of the spell dialog "ChangeAll" button.
IdButtonIgnore | Id of the spell dialog "Ignore" button.
IdButtonIgnoreAll | Id of the spell dialog "IgnoreAlll" button.
IdButtonUndo | Id of the spell dialog "Undo" button.
IdLink | Id of the outer spell dialog button link element.
IdLinkAddCustom | Id of the outer spell dialog "AddCustom" button link element.
IdLinkCancel | Id of the outer spell dialog "Close" button link element.
IdLinkChange | Id of the outer spell dialog "Change" button link element.
IdLinkChangeAll | Id of the outer spell dialog "ChangeAll" button link element.
IdLinkIgnore | Id of the outer spell dialog "Ignore" button link element.
IdLinkIgnoreAll | Id of the outer spell dialog "IgnoreAll" button link element.
IdLinkUndo | Id of the outer spell dialog "Undo" button link element.

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInner Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.CssInner Field
SpellConstants Class See Also Send Feedback
CSS of the inner spell dialog button span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssInner
Visual Basic (Declaration)
Public Const CssInner As String
Visual C++
public:
literal String^ CssInner

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLink Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.CssLink Field
SpellConstants Class See Also Send Feedback
CSS of the outer spell dialog button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssLink
Visual Basic (Declaration)
Public Const CssLink As String
Visual C++
public:
literal String^ CssLink

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSpellDialog Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.CssRadSpellDialog Field
SpellConstants Class See Also Send Feedback
CSS class of the spell dialog div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadSpellDialog
Visual Basic (Declaration)
Public Const CssRadSpellDialog As String
Visual C++
public:
literal String^ CssRadSpellDialog

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonAddCustom Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonAddCustom Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "AddCustom" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonAddCustom
Visual Basic (Declaration)
Public Const IdButtonAddCustom As String
Visual C++
public:
literal String^ IdButtonAddCustom

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonCancel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonCancel Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Close" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonCancel
Visual Basic (Declaration)
Public Const IdButtonCancel As String
Visual C++
public:
literal String^ IdButtonCancel

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonChange Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonChange Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Change" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonChange
Visual Basic (Declaration)
Public Const IdButtonChange As String
Visual C++
public:
literal String^ IdButtonChange

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonChangeAll Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonChangeAll Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "ChangeAll" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonChangeAll
Visual Basic (Declaration)
Public Const IdButtonChangeAll As String
Visual C++
public:
literal String^ IdButtonChangeAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonIgnore Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonIgnore Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Ignore" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonIgnore
Visual Basic (Declaration)
Public Const IdButtonIgnore As String
Visual C++
public:
literal String^ IdButtonIgnore

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonIgnoreAll Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonIgnoreAll Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "IgnoreAlll" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonIgnoreAll
Visual Basic (Declaration)
Public Const IdButtonIgnoreAll As String
Visual C++
public:
literal String^ IdButtonIgnoreAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonUndo Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdButtonUndo Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Undo" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdButtonUndo
Visual Basic (Declaration)
Public Const IdButtonUndo As String
Visual C++
public:
literal String^ IdButtonUndo

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLink Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLink Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLink
Visual Basic (Declaration)
Public Const IdLink As String
Visual C++
public:
literal String^ IdLink

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkAddCustom Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkAddCustom Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "AddCustom" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkAddCustom
Visual Basic (Declaration)
Public Const IdLinkAddCustom As String
Visual C++
public:
literal String^ IdLinkAddCustom

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkCancel Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkCancel Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Close" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkCancel
Visual Basic (Declaration)
Public Const IdLinkCancel As String
Visual C++
public:
literal String^ IdLinkCancel

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkChange Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkChange Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Change" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkChange
Visual Basic (Declaration)
Public Const IdLinkChange As String
Visual C++
public:
literal String^ IdLinkChange

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkChangeAll Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkChangeAll Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "ChangeAll" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkChangeAll
Visual Basic (Declaration)
Public Const IdLinkChangeAll As String
Visual C++
public:
literal String^ IdLinkChangeAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkIgnore Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkIgnore Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Ignore" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkIgnore
Visual Basic (Declaration)
Public Const IdLinkIgnore As String
Visual C++
public:
literal String^ IdLinkIgnore

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkIgnoreAll Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkIgnoreAll Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "IgnoreAll" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkIgnoreAll
Visual Basic (Declaration)
Public Const IdLinkIgnoreAll As String
Visual C++
public:
literal String^ IdLinkIgnoreAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkUndo Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SpellConstants..::.IdLinkUndo Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Undo" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdLinkUndo
Visual Basic (Declaration)
Public Const IdLinkUndo As String
Visual C++
public:
literal String^ IdLinkUndo

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitBarActionType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitBarActionType Enumeration
See Also Send Feedback
Action type enumeration of the splitbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SplitBarActionType
Visual Basic (Declaration)
Public Enumeration SplitBarActionType
Visual C++
public enum class SplitBarActionType

Members

Member name | Description
Collapse | Collapse the pane.
Expand | Expand the pane.
Resize | Resize the pane.

See Also

Telerik.WebAii.Controls.Html Namespace


SplitBarCollapseDirection Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitBarCollapseDirection Enumeration
See Also Send Feedback
The direction of the splitbar collapsing.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SplitBarCollapseDirection
Visual Basic (Declaration)
Public Enumeration SplitBarCollapseDirection
Visual C++
public enum class SplitBarCollapseDirection

Members

Member name | Description
None | Collapse is not enabled.
Forward | The pane at the left (top) position of the SpltBar will be collapsed. This is the default value.
Backward | The pane at the right (bottom) position of the SpltBar will be collapsed.
Both | Collapse can be done in both direction.

See Also

Telerik.WebAii.Controls.Html Namespace


SplitterConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants Class
Members See Also Send Feedback
String constatns of the splitter(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SplitterConstants
Visual Basic (Declaration)
Public NotInheritable Class SplitterConstants
Visual C++
public ref class SplitterConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.SplitterConstants

See Also

SplitterConstants Members
Telerik.WebAii.Controls.Html Namespace


SplitterConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants Members
SplitterConstants Class Fields See Also Send Feedback

The SplitterConstants type exposes the following members.

Fields

Name | Description
CssCollapseBar | The CSS class identifying the Splitter vertical collapsebar icon.
CssCollapseExpand | The CSS class identifying the Splitter collapse/expand icon.
CssExpandBar | The CSS class identifying the Splitter vertical expandbar icon.
CssHorizontalCollapseBar | The CSS class identifying the Splitter horizontal collapsebar icon.
CssHorizontalExpandBar | The CSS class identifying the Splitter horizontal expandbar icon.
CssPane | The CSS class identifying the Splitter pane control.
CssSlidingPane | The CSS class identifying the spliding pane.
CssSlidingPaneChildElement | The CSS class identifying the SplidingPane child HTML element(table).
CssSlidingPaneCommand1 | The 1st string from CSS class identifying the spliding pane command.
CssSlidingPaneCommand2 | The 2nd string from CSS class identifying the spliding pane command.
CssSlidingZone | The CSS class identifying the spliding zone control.
CssSlidingZoneTab | The CSS class identifying the spliding zone tab.
CssSplitBar | The CSS class identifying the Splitter splitbar control.
CssSplitter | The CSS class identifying the Splitter control.
IdPrefix | The ID prefix identifying the Splitter control.
KeyPane | The key representing the Splitter Pane.
KeySlidingPane | The key representing the Splitter Sliding Pane.
KeySlidingZone | The key representing the Splitter Sliding Zone.
KeySplitBar | The key representing the Splitter SplitBar.
TabPaneIdDifference | The string difference between tab id and pane id.

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitterConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants Fields
SplitterConstants Class See Also Send Feedback

The SplitterConstants type exposes the following members.

Fields

Name | Description
CssCollapseBar | The CSS class identifying the Splitter vertical collapsebar icon.
CssCollapseExpand | The CSS class identifying the Splitter collapse/expand icon.
CssExpandBar | The CSS class identifying the Splitter vertical expandbar icon.
CssHorizontalCollapseBar | The CSS class identifying the Splitter horizontal collapsebar icon.
CssHorizontalExpandBar | The CSS class identifying the Splitter horizontal expandbar icon.
CssPane | The CSS class identifying the Splitter pane control.
CssSlidingPane | The CSS class identifying the spliding pane.
CssSlidingPaneChildElement | The CSS class identifying the SplidingPane child HTML element(table).
CssSlidingPaneCommand1 | The 1st string from CSS class identifying the spliding pane command.
CssSlidingPaneCommand2 | The 2nd string from CSS class identifying the spliding pane command.
CssSlidingZone | The CSS class identifying the spliding zone control.
CssSlidingZoneTab | The CSS class identifying the spliding zone tab.
CssSplitBar | The CSS class identifying the Splitter splitbar control.
CssSplitter | The CSS class identifying the Splitter control.
IdPrefix | The ID prefix identifying the Splitter control.
KeyPane | The key representing the Splitter Pane.
KeySlidingPane | The key representing the Splitter Sliding Pane.
KeySlidingZone | The key representing the Splitter Sliding Zone.
KeySplitBar | The key representing the Splitter SplitBar.
TabPaneIdDifference | The string difference between tab id and pane id.

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapseBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssCollapseBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter vertical collapsebar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCollapseBar
Visual Basic (Declaration)
Public Const CssCollapseBar As String
Visual C++
public:
literal String^ CssCollapseBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapseExpand Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssCollapseExpand Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter collapse/expand icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCollapseExpand
Visual Basic (Declaration)
Public Const CssCollapseExpand As String
Visual C++
public:
literal String^ CssCollapseExpand

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpandBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssExpandBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter vertical expandbar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssExpandBar
Visual Basic (Declaration)
Public Const CssExpandBar As String
Visual C++
public:
literal String^ CssExpandBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHorizontalCollapseBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssHorizontalCollapseBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter horizontal collapsebar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssHorizontalCollapseBar
Visual Basic (Declaration)
Public Const CssHorizontalCollapseBar As String
Visual C++
public:
literal String^ CssHorizontalCollapseBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHorizontalExpandBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssHorizontalExpandBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter horizontal expandbar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssHorizontalExpandBar
Visual Basic (Declaration)
Public Const CssHorizontalExpandBar As String
Visual C++
public:
literal String^ CssHorizontalExpandBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPane Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssPane Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter pane control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPane
Visual Basic (Declaration)
Public Const CssPane As String
Visual C++
public:
literal String^ CssPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPane Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSlidingPane Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the spliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSlidingPane
Visual Basic (Declaration)
Public Const CssSlidingPane As String
Visual C++
public:
literal String^ CssSlidingPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPaneChildElement Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSlidingPaneChildElement Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the SplidingPane child HTML element(table).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSlidingPaneChildElement
Visual Basic (Declaration)
Public Const CssSlidingPaneChildElement As String
Visual C++
public:
literal String^ CssSlidingPaneChildElement

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPaneCommand1 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSlidingPaneCommand1 Field
SplitterConstants Class See Also Send Feedback
The 1st string from CSS class identifying the spliding pane command.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSlidingPaneCommand1
Visual Basic (Declaration)
Public Const CssSlidingPaneCommand1 As String
Visual C++
public:
literal String^ CssSlidingPaneCommand1

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPaneCommand2 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSlidingPaneCommand2 Field
SplitterConstants Class See Also Send Feedback
The 2nd string from CSS class identifying the spliding pane command.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSlidingPaneCommand2
Visual Basic (Declaration)
Public Const CssSlidingPaneCommand2 As String
Visual C++
public:
literal String^ CssSlidingPaneCommand2

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingZone Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSlidingZone Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the spliding zone control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSlidingZone
Visual Basic (Declaration)
Public Const CssSlidingZone As String
Visual C++
public:
literal String^ CssSlidingZone

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingZoneTab Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSlidingZoneTab Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the spliding zone tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSlidingZoneTab
Visual Basic (Declaration)
Public Const CssSlidingZoneTab As String
Visual C++
public:
literal String^ CssSlidingZoneTab

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSplitBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter splitbar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSplitBar
Visual Basic (Declaration)
Public Const CssSplitBar As String
Visual C++
public:
literal String^ CssSplitBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitter Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.CssSplitter Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSplitter
Visual Basic (Declaration)
Public Const CssSplitter As String
Visual C++
public:
literal String^ CssSplitter

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


IdPrefix Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.IdPrefix Field
SplitterConstants Class See Also Send Feedback
The ID prefix identifying the Splitter control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdPrefix
Visual Basic (Declaration)
Public Const IdPrefix As String
Visual C++
public:
literal String^ IdPrefix

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyPane Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.KeyPane Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter Pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyPane
Visual Basic (Declaration)
Public Const KeyPane As String
Visual C++
public:
literal String^ KeyPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySlidingPane Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.KeySlidingPane Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter Sliding Pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeySlidingPane
Visual Basic (Declaration)
Public Const KeySlidingPane As String
Visual C++
public:
literal String^ KeySlidingPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySlidingZone Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.KeySlidingZone Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter Sliding Zone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeySlidingZone
Visual Basic (Declaration)
Public Const KeySlidingZone As String
Visual C++
public:
literal String^ KeySlidingZone

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySplitBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.KeySplitBar Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter SplitBar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeySplitBar
Visual Basic (Declaration)
Public Const KeySplitBar As String
Visual C++
public:
literal String^ KeySplitBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


TabPaneIdDifference Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterConstants..::.TabPaneIdDifference Field
SplitterConstants Class See Also Send Feedback
The string difference between tab id and pane id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabPaneIdDifference
Visual Basic (Declaration)
Public Const TabPaneIdDifference As String
Visual C++
public:
literal String^ TabPaneIdDifference

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitterOrientation Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterOrientation Enumeration
See Also Send Feedback
Splitter orientation enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SplitterOrientation
Visual Basic (Declaration)
Public Enumeration SplitterOrientation
Visual C++
public enum class SplitterOrientation

Members

Member name | Description
Horizontal | The panes are ordered horizontally side by side.
Vertical | Default - The panes are ordered vertically side by side.

See Also

Telerik.WebAii.Controls.Html Namespace


SplitterPaneType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterPaneType Enumeration
See Also Send Feedback
Splitter pane type: Previous(Left or Upper) or Next(Right or Down).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SplitterPaneType
Visual Basic (Declaration)
Public Enumeration SplitterPaneType
Visual C++
public enum class SplitterPaneType

Members

Member name | Description
Previous | Previous pane.
Next | Next pane.

See Also

Telerik.WebAii.Controls.Html Namespace


SplitterSlideDirection Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitterSlideDirection Enumeration
See Also Send Feedback
Splitter slide direction enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum SplitterSlideDirection
Visual Basic (Declaration)
Public Enumeration SplitterSlideDirection
Visual C++
public enum class SplitterSlideDirection

Members

Member name | Description
Right | Left to Right sliding direction.
Left | Right to Left sliding direction.
Bottom | Top to Bottom sliding direction.
Top | Bottom to Top sliding direction.

See Also

Telerik.WebAii.Controls.Html Namespace


TabStripConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants Class
Members See Also Send Feedback
The TabStrip constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TabStripConstants
Visual Basic (Declaration)
Public NotInheritable Class TabStripConstants
Visual C++
public ref class TabStripConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.TabStripConstants

See Also

TabStripConstants Members
Telerik.WebAii.Controls.Html Namespace


TabStripConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants Members
TabStripConstants Class Fields See Also Send Feedback

The TabStripConstants type exposes the following members.

Fields

Name | Description
CssTab | The CSS class for the tab 'li' element.
CssTabLink | The CSS class for the tab link element.
CssTabStrip | The CSS class identifying the TabStrip 'div' element.
CssTabText | The CSS class for the tab text 'span' element.
TabKey | The Tab key used accross the classes.
TabStripKey | The TabStrip key used accross the classes.

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabStripConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants Fields
TabStripConstants Class See Also Send Feedback

The TabStripConstants type exposes the following members.

Fields

Name | Description
CssTab | The CSS class for the tab 'li' element.
CssTabLink | The CSS class for the tab link element.
CssTabStrip | The CSS class identifying the TabStrip 'div' element.
CssTabText | The CSS class for the tab text 'span' element.
TabKey | The Tab key used accross the classes.
TabStripKey | The TabStrip key used accross the classes.

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTab Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants..::.CssTab Field
TabStripConstants Class See Also Send Feedback
The CSS class for the tab 'li' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTab
Visual Basic (Declaration)
Public Const CssTab As String
Visual C++
public:
literal String^ CssTab

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabLink Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants..::.CssTabLink Field
TabStripConstants Class See Also Send Feedback
The CSS class for the tab link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTabLink
Visual Basic (Declaration)
Public Const CssTabLink As String
Visual C++
public:
literal String^ CssTabLink

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabStrip Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants..::.CssTabStrip Field
TabStripConstants Class See Also Send Feedback
The CSS class identifying the TabStrip 'div' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTabStrip
Visual Basic (Declaration)
Public Const CssTabStrip As String
Visual C++
public:
literal String^ CssTabStrip

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants..::.CssTabText Field
TabStripConstants Class See Also Send Feedback
The CSS class for the tab text 'span' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTabText
Visual Basic (Declaration)
Public Const CssTabText As String
Visual C++
public:
literal String^ CssTabText

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants..::.TabKey Field
TabStripConstants Class See Also Send Feedback
The Tab key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabKey
Visual Basic (Declaration)
Public Const TabKey As String
Visual C++
public:
literal String^ TabKey

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabStripKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripConstants..::.TabStripKey Field
TabStripConstants Class See Also Send Feedback
The TabStrip key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabStripKey
Visual Basic (Declaration)
Public Const TabStripKey As String
Visual C++
public:
literal String^ TabStripKey

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabStripOrientationType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabStripOrientationType Enumeration
See Also Send Feedback
Type of scheduler view navigarion.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum TabStripOrientationType
Visual Basic (Declaration)
Public Enumeration TabStripOrientationType
Visual C++
public enum class TabStripOrientationType

Members

Member name | Description
HorizontalTop | Horizontal top orientation.
HorizontalBottom | Horizontal bottom orientation.
VerticalLeft | Vertical left orientation.
VerticalRight | Vertical right orientation.

See Also

Telerik.WebAii.Controls.Html Namespace


ToolBarButtonType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarButtonType Enumeration
See Also Send Feedback
The ToolBar button type.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ToolBarButtonType
Visual Basic (Declaration)
Public Enumeration ToolBarButtonType
Visual C++
public enum class ToolBarButtonType

Members

Member name | Description
ToolBarButton | Describes toolbar button type.
ToolBarDropDownButton | Describes toolbar drop down button type.
ToolBarSplitButton | Describes toolbar split utton type.

See Also

Telerik.WebAii.Controls.Html Namespace


ToolBarConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants Class
Members See Also Send Feedback
Class that represents toolbar constants.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ToolBarConstants
Visual Basic (Declaration)
Public NotInheritable Class ToolBarConstants
Visual C++
public ref class ToolBarConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.ToolBarConstants

See Also

ToolBarConstants Members
Telerik.WebAii.Controls.Html Namespace


ToolBarConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants Members
ToolBarConstants Class Fields See Also Send Feedback

The ToolBarConstants type exposes the following members.

Fields

Name | Description
CssToolBar | The CSS class identifying the ToolBar control.
CssToolBarButton | The CSS class identifying the ToolBar button.
CssToolBarButtonChoiceArrow | The CSS class identifying the ToolBar drop down and split button arrow.
CssToolBarDropDownButton | The CSS class identifying the ToolBar drop down button.
CssToolBarDropDownExpanded | The CSS class identifying the ToolBar drop down and split button expanded state.
CssToolBarItem | The CSS class identifying the ToolBar item.
CssToolBarItemText | The CSS class identifying the ToolBar item text span element.
CssToolBarItemWrap | The CSS class identifying the ToolBar item wrap link element.
CssToolBarSeparator | The CSS class identifying the ToolBar item separator.
CssToolBarSplitButton | The CSS class identifying the ToolBar split button.
DropDownButtonKey | The ToolBarDropDownButton key used across the source classes.
SplitButtonKey | The ToolBarSplitButton key used across the source classes.
ToolBar | The ToolBar key used across the source classes.
ToolBarButtonKey | The ToolBarButton key used across the source classes.
ToolBarItemKey | The ToolBarItem key used across the source classes.

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants Fields
ToolBarConstants Class See Also Send Feedback

The ToolBarConstants type exposes the following members.

Fields

Name | Description
CssToolBar | The CSS class identifying the ToolBar control.
CssToolBarButton | The CSS class identifying the ToolBar button.
CssToolBarButtonChoiceArrow | The CSS class identifying the ToolBar drop down and split button arrow.
CssToolBarDropDownButton | The CSS class identifying the ToolBar drop down button.
CssToolBarDropDownExpanded | The CSS class identifying the ToolBar drop down and split button expanded state.
CssToolBarItem | The CSS class identifying the ToolBar item.
CssToolBarItemText | The CSS class identifying the ToolBar item text span element.
CssToolBarItemWrap | The CSS class identifying the ToolBar item wrap link element.
CssToolBarSeparator | The CSS class identifying the ToolBar item separator.
CssToolBarSplitButton | The CSS class identifying the ToolBar split button.
DropDownButtonKey | The ToolBarDropDownButton key used across the source classes.
SplitButtonKey | The ToolBarSplitButton key used across the source classes.
ToolBar | The ToolBar key used across the source classes.
ToolBarButtonKey | The ToolBarButton key used across the source classes.
ToolBarItemKey | The ToolBarItem key used across the source classes.

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBar Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBar
Visual Basic (Declaration)
Public Const CssToolBar As String
Visual C++
public:
literal String^ CssToolBar

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarButton Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarButton
Visual Basic (Declaration)
Public Const CssToolBarButton As String
Visual C++
public:
literal String^ CssToolBarButton

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarButtonChoiceArrow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarButtonChoiceArrow Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar drop down and split button arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarButtonChoiceArrow
Visual Basic (Declaration)
Public Const CssToolBarButtonChoiceArrow As String
Visual C++
public:
literal String^ CssToolBarButtonChoiceArrow

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarDropDownButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarDropDownButton Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar drop down button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarDropDownButton
Visual Basic (Declaration)
Public Const CssToolBarDropDownButton As String
Visual C++
public:
literal String^ CssToolBarDropDownButton

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarDropDownExpanded Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarDropDownExpanded Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar drop down and split button expanded state.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarDropDownExpanded
Visual Basic (Declaration)
Public Const CssToolBarDropDownExpanded As String
Visual C++
public:
literal String^ CssToolBarDropDownExpanded

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarItem Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarItem Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarItem
Visual Basic (Declaration)
Public Const CssToolBarItem As String
Visual C++
public:
literal String^ CssToolBarItem

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarItemText Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarItemText Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item text span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarItemText
Visual Basic (Declaration)
Public Const CssToolBarItemText As String
Visual C++
public:
literal String^ CssToolBarItemText

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarItemWrap Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarItemWrap Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item wrap link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarItemWrap
Visual Basic (Declaration)
Public Const CssToolBarItemWrap As String
Visual C++
public:
literal String^ CssToolBarItemWrap

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarSeparator Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarSeparator Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item separator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarSeparator
Visual Basic (Declaration)
Public Const CssToolBarSeparator As String
Visual C++
public:
literal String^ CssToolBarSeparator

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarSplitButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.CssToolBarSplitButton Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolBarSplitButton
Visual Basic (Declaration)
Public Const CssToolBarSplitButton As String
Visual C++
public:
literal String^ CssToolBarSplitButton

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


DropDownButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.DropDownButtonKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarDropDownButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownButtonKey
Visual Basic (Declaration)
Public Const DropDownButtonKey As String
Visual C++
public:
literal String^ DropDownButtonKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.SplitButtonKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarSplitButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplitButtonKey
Visual Basic (Declaration)
Public Const SplitButtonKey As String
Visual C++
public:
literal String^ SplitButtonKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.ToolBar Field
ToolBarConstants Class See Also Send Feedback
The ToolBar key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBar
Visual Basic (Declaration)
Public Const ToolBar As String
Visual C++
public:
literal String^ ToolBar

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.ToolBarButtonKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBarButtonKey
Visual Basic (Declaration)
Public Const ToolBarButtonKey As String
Visual C++
public:
literal String^ ToolBarButtonKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarConstants..::.ToolBarItemKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBarItemKey
Visual Basic (Declaration)
Public Const ToolBarItemKey As String
Visual C++
public:
literal String^ ToolBarItemKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarOrientationType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarOrientationType Enumeration
See Also Send Feedback
ToolBar orientation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ToolBarOrientationType
Visual Basic (Declaration)
Public Enumeration ToolBarOrientationType
Visual C++
public enum class ToolBarOrientationType

Members

Member name | Description
Horizontal | The 'Horizontal' toolbar orientation type.
Vertical | The 'Vertical' toolbar orientation type.

See Also

Telerik.WebAii.Controls.Html Namespace


ToolTipConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants Class
Members See Also Send Feedback
String constatns of the tooltip(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ToolTipConstants
Visual Basic (Declaration)
Public NotInheritable Class ToolTipConstants
Visual C++
public ref class ToolTipConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.ToolTipConstants

See Also

ToolTipConstants Members
Telerik.WebAii.Controls.Html Namespace


ToolTipConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants Members
ToolTipConstants Class Fields See Also Send Feedback

The ToolTipConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the ToolTip's close button element.
CssToolTip | The CSS class identifying the ToolTip control.
KeyToolTip | The key representing the ToolTip control.
ToolTipIdPrefix | The ID prefix identifying the ToolTip control.

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolTipConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants Fields
ToolTipConstants Class See Also Send Feedback

The ToolTipConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the ToolTip's close button element.
CssToolTip | The CSS class identifying the ToolTip control.
KeyToolTip | The key representing the ToolTip control.
ToolTipIdPrefix | The ID prefix identifying the ToolTip control.

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCloseButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants..::.CssCloseButton Field
ToolTipConstants Class See Also Send Feedback
The CSS class identifying the ToolTip's close button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCloseButton
Visual Basic (Declaration)
Public Const CssCloseButton As String
Visual C++
public:
literal String^ CssCloseButton

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolTip Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants..::.CssToolTip Field
ToolTipConstants Class See Also Send Feedback
The CSS class identifying the ToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssToolTip
Visual Basic (Declaration)
Public Const CssToolTip As String
Visual C++
public:
literal String^ CssToolTip

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyToolTip Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants..::.KeyToolTip Field
ToolTipConstants Class See Also Send Feedback
The key representing the ToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyToolTip
Visual Basic (Declaration)
Public Const KeyToolTip As String
Visual C++
public:
literal String^ KeyToolTip

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolTipIdPrefix Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipConstants..::.ToolTipIdPrefix Field
ToolTipConstants Class See Also Send Feedback
The ID prefix identifying the ToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolTipIdPrefix
Visual Basic (Declaration)
Public Const ToolTipIdPrefix As String
Visual C++
public:
literal String^ ToolTipIdPrefix

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolTipHideMode Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipHideMode Enumeration
See Also Send Feedback
Tooltip hide mode enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ToolTipHideMode
Visual Basic (Declaration)
Public Enumeration ToolTipHideMode
Visual C++
public enum class ToolTipHideMode

Members

Member name | Description
LeaveTarget | Hides when mouse is out of the target element.
LeaveToolTip | Hides when user hovers the tooltip and then leaves it.
ManualClose | Hides when user presses the [x] button of the tooltip.
LeaveTargetAndToolTip | Hides when mouse is neither over the tooltip, nor over the target element.
FromCode | Hides by explicit javascript call to its hide method.

See Also

Telerik.WebAii.Controls.Html Namespace


ToolTipRelativeToMode Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipRelativeToMode Enumeration
See Also Send Feedback
Tooltip RelativeTo mode enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ToolTipRelativeToMode
Visual Basic (Declaration)
Public Enumeration ToolTipRelativeToMode
Visual C++
public enum class ToolTipRelativeToMode

Members

Member name | Description
Mouse | The default scenario is when the RadToolTip has its TargetControlID set and also has these settings: RelativeTo="Mouse" or MouseTrailing = "true". In this case its position is calculated according to the mouse coordinates. If the tooltip has RelativeTo="Mouse" and TargetControl is set, and yet its showing is invoked programmatically from code the tooltip is positioned relative to the target element.
BrowserWindow | The setting RelativeTo=BrowserWindow has a highest priority - the RadToolTip is shown relative to the browser, not to a target control even if a TargetControlID has been specified.
Element | If the tooltip has RelativeTo="Element" and TargetControl is set, its position is calculated according to the specified element.

See Also

Telerik.WebAii.Controls.Html Namespace


ToolTipShowMode Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolTipShowMode Enumeration
See Also Send Feedback
Tooltip show mode enumeration.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ToolTipShowMode
Visual Basic (Declaration)
Public Enumeration ToolTipShowMode
Visual C++
public enum class ToolTipShowMode

Members

Member name | Description
OnMouseOver | RadToolTip appears on mouse over the target control.
OnClick | RadToolTip appears on clicking with the left button of the mouse on the target control.
OnRightClick | RadToolTip appears on right click with the mouse on the target control.
OnFocus | RadToolTip appears on focus of the target control.

See Also

Telerik.WebAii.Controls.Html Namespace


TreeViewConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants Class
Members See Also Send Feedback
Represents the treeview constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TreeViewConstants
Visual Basic (Declaration)
Public NotInheritable Class TreeViewConstants
Visual C++
public ref class TreeViewConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.TreeViewConstants

See Also

TreeViewConstants Members
Telerik.WebAii.Controls.Html Namespace


TreeViewConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants Members
TreeViewConstants Class Fields See Also Send Feedback

The TreeViewConstants type exposes the following members.

Fields

Name | Description
CssNodeCheckBox | The CSS class of the tree node check box.
CssNodeCollapse | The CSS class identifying the tree node is collapsed.
CssNodeDiv | The CSS class of the tree node inner div element.
CssNodeExpand | The CSS class identifying the tree node is expanded.
CssNodeImage | The CSS class of the tree node image element.
CssNodeLI | The CSS class of the tree node 'li' element.
CssNodeSelected | The CSS class identifying the tree node is selected.
CssNodeSpan | The CSS class of the tree node span element.
CssTreeView | The CSS class of the tree.
TreeNodeKey | The TreeNode key used accross the classes.
TreeViewKey | The TreeView key used accross the classes.

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeViewConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants Fields
TreeViewConstants Class See Also Send Feedback

The TreeViewConstants type exposes the following members.

Fields

Name | Description
CssNodeCheckBox | The CSS class of the tree node check box.
CssNodeCollapse | The CSS class identifying the tree node is collapsed.
CssNodeDiv | The CSS class of the tree node inner div element.
CssNodeExpand | The CSS class identifying the tree node is expanded.
CssNodeImage | The CSS class of the tree node image element.
CssNodeLI | The CSS class of the tree node 'li' element.
CssNodeSelected | The CSS class identifying the tree node is selected.
CssNodeSpan | The CSS class of the tree node span element.
CssTreeView | The CSS class of the tree.
TreeNodeKey | The TreeNode key used accross the classes.
TreeViewKey | The TreeView key used accross the classes.

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeCheckBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeCheckBox Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node check box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeCheckBox
Visual Basic (Declaration)
Public Const CssNodeCheckBox As String
Visual C++
public:
literal String^ CssNodeCheckBox

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeCollapse Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeCollapse Field
TreeViewConstants Class See Also Send Feedback
The CSS class identifying the tree node is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeCollapse
Visual Basic (Declaration)
Public Const CssNodeCollapse As String
Visual C++
public:
literal String^ CssNodeCollapse

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeDiv Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeDiv Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node inner div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeDiv
Visual Basic (Declaration)
Public Const CssNodeDiv As String
Visual C++
public:
literal String^ CssNodeDiv

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeExpand Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeExpand Field
TreeViewConstants Class See Also Send Feedback
The CSS class identifying the tree node is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeExpand
Visual Basic (Declaration)
Public Const CssNodeExpand As String
Visual C++
public:
literal String^ CssNodeExpand

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeImage Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeImage Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node image element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeImage
Visual Basic (Declaration)
Public Const CssNodeImage As String
Visual C++
public:
literal String^ CssNodeImage

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeLI Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeLI Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node 'li' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeLI
Visual Basic (Declaration)
Public Const CssNodeLI As String
Visual C++
public:
literal String^ CssNodeLI

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeSelected Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeSelected Field
TreeViewConstants Class See Also Send Feedback
The CSS class identifying the tree node is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeSelected
Visual Basic (Declaration)
Public Const CssNodeSelected As String
Visual C++
public:
literal String^ CssNodeSelected

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeSpan Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssNodeSpan Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssNodeSpan
Visual Basic (Declaration)
Public Const CssNodeSpan As String
Visual C++
public:
literal String^ CssNodeSpan

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTreeView Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.CssTreeView Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssTreeView
Visual Basic (Declaration)
Public Const CssTreeView As String
Visual C++
public:
literal String^ CssTreeView

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeNodeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.TreeNodeKey Field
TreeViewConstants Class See Also Send Feedback
The TreeNode key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeNodeKey
Visual Basic (Declaration)
Public Const TreeNodeKey As String
Visual C++
public:
literal String^ TreeNodeKey

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewConstants..::.TreeViewKey Field
TreeViewConstants Class See Also Send Feedback
The TreeView key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeViewKey
Visual Basic (Declaration)
Public Const TreeViewKey As String
Visual C++
public:
literal String^ TreeViewKey

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


UploadConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants Class
Members See Also Send Feedback
Represents the upload constants class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class UploadConstants
Visual Basic (Declaration)
Public NotInheritable Class UploadConstants
Visual C++
public ref class UploadConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.UploadConstants

See Also

UploadConstants Members
Telerik.WebAii.Controls.Html Namespace


UploadConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants Members
UploadConstants Class Fields See Also Send Feedback

The UploadConstants type exposes the following members.

Fields

Name | Description
CssAddButton | CSS class of the 'Add' button.
CssCheckBox | CSS class of the 'Check' button.
CssClearButton | CSS class of the 'Clear' button.
CssDeleteButton | CSS class of the 'Delete' button.
CssFileInput | CSS class of the file input.
CssRadUpload | CSS class of the upload main div element.
CssRemoveButton | CSS class of the 'Remove' button.
CssSelectButton | CSS class of the 'Select' button.
KeyUpload | The key identifying the Upload control.

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


UploadConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants Fields
UploadConstants Class See Also Send Feedback

The UploadConstants type exposes the following members.

Fields

Name | Description
CssAddButton | CSS class of the 'Add' button.
CssCheckBox | CSS class of the 'Check' button.
CssClearButton | CSS class of the 'Clear' button.
CssDeleteButton | CSS class of the 'Delete' button.
CssFileInput | CSS class of the file input.
CssRadUpload | CSS class of the upload main div element.
CssRemoveButton | CSS class of the 'Remove' button.
CssSelectButton | CSS class of the 'Select' button.
KeyUpload | The key identifying the Upload control.

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAddButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssAddButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Add' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssAddButton
Visual Basic (Declaration)
Public Const CssAddButton As String
Visual C++
public:
literal String^ CssAddButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCheckBox Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssCheckBox Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Check' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCheckBox
Visual Basic (Declaration)
Public Const CssCheckBox As String
Visual C++
public:
literal String^ CssCheckBox

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssClearButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssClearButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Clear' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssClearButton
Visual Basic (Declaration)
Public Const CssClearButton As String
Visual C++
public:
literal String^ CssClearButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDeleteButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssDeleteButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Delete' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssDeleteButton
Visual Basic (Declaration)
Public Const CssDeleteButton As String
Visual C++
public:
literal String^ CssDeleteButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFileInput Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssFileInput Field
UploadConstants Class See Also Send Feedback
CSS class of the file input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssFileInput
Visual Basic (Declaration)
Public Const CssFileInput As String
Visual C++
public:
literal String^ CssFileInput

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadUpload Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssRadUpload Field
UploadConstants Class See Also Send Feedback
CSS class of the upload main div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRadUpload
Visual Basic (Declaration)
Public Const CssRadUpload As String
Visual C++
public:
literal String^ CssRadUpload

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRemoveButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssRemoveButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Remove' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssRemoveButton
Visual Basic (Declaration)
Public Const CssRemoveButton As String
Visual C++
public:
literal String^ CssRemoveButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.CssSelectButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Select' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssSelectButton
Visual Basic (Declaration)
Public Const CssSelectButton As String
Visual C++
public:
literal String^ CssSelectButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyUpload Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadConstants..::.KeyUpload Field
UploadConstants Class See Also Send Feedback
The key identifying the Upload control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyUpload
Visual Basic (Declaration)
Public Const KeyUpload As String
Visual C++
public:
literal String^ KeyUpload

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


WindowConstants Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants Class
Members See Also Send Feedback
String constatns of the window(Css classes, Id prefix, etc).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class WindowConstants
Visual Basic (Declaration)
Public NotInheritable Class WindowConstants
Visual C++
public ref class WindowConstants abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Html..::.WindowConstants

See Also

WindowConstants Members
Telerik.WebAii.Controls.Html Namespace


WindowConstants Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants Members
WindowConstants Class Fields See Also Send Feedback

The WindowConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the Window's close button element.
CssMaximizeButton | The CSS class identifying the Window's maximize button element.
CssMinimizeButton | The CSS class identifying the Window's minimize button element.
CssPinButton | The CSS class identifying the Window's pin button element.
CssReloadButton | The CSS class identifying the Window's reload button element.
CssResizeBorder1 | The CSS class identifying the Window's div element, which handles top resize.
CssResizeBorder2 | The CSS class identifying the Window's table cell element, which handles bottom resize.
CssResizeBorder3 | The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.
CssStatusBar | The CSS class identifying the Window's statusbar element.
CssWindow | The CSS class identifying the Window control.
IdPrefix | The string that is prefix in window Id.
KeyWindow | The name identifying the Window control.

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


WindowConstants Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants Fields
WindowConstants Class See Also Send Feedback

The WindowConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the Window's close button element.
CssMaximizeButton | The CSS class identifying the Window's maximize button element.
CssMinimizeButton | The CSS class identifying the Window's minimize button element.
CssPinButton | The CSS class identifying the Window's pin button element.
CssReloadButton | The CSS class identifying the Window's reload button element.
CssResizeBorder1 | The CSS class identifying the Window's div element, which handles top resize.
CssResizeBorder2 | The CSS class identifying the Window's table cell element, which handles bottom resize.
CssResizeBorder3 | The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.
CssStatusBar | The CSS class identifying the Window's statusbar element.
CssWindow | The CSS class identifying the Window control.
IdPrefix | The string that is prefix in window Id.
KeyWindow | The name identifying the Window control.

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCloseButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssCloseButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's close button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssCloseButton
Visual Basic (Declaration)
Public Const CssCloseButton As String
Visual C++
public:
literal String^ CssCloseButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMaximizeButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssMaximizeButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's maximize button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMaximizeButton
Visual Basic (Declaration)
Public Const CssMaximizeButton As String
Visual C++
public:
literal String^ CssMaximizeButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMinimizeButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssMinimizeButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's minimize button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssMinimizeButton
Visual Basic (Declaration)
Public Const CssMinimizeButton As String
Visual C++
public:
literal String^ CssMinimizeButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPinButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssPinButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's pin button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssPinButton
Visual Basic (Declaration)
Public Const CssPinButton As String
Visual C++
public:
literal String^ CssPinButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssReloadButton Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssReloadButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's reload button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssReloadButton
Visual Basic (Declaration)
Public Const CssReloadButton As String
Visual C++
public:
literal String^ CssReloadButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeBorder1 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssResizeBorder1 Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's div element, which handles top resize.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssResizeBorder1
Visual Basic (Declaration)
Public Const CssResizeBorder1 As String
Visual C++
public:
literal String^ CssResizeBorder1

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeBorder2 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssResizeBorder2 Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's table cell element, which handles bottom resize.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssResizeBorder2
Visual Basic (Declaration)
Public Const CssResizeBorder2 As String
Visual C++
public:
literal String^ CssResizeBorder2

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeBorder3 Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssResizeBorder3 Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssResizeBorder3
Visual Basic (Declaration)
Public Const CssResizeBorder3 As String
Visual C++
public:
literal String^ CssResizeBorder3

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssStatusBar Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssStatusBar Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's statusbar element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssStatusBar
Visual Basic (Declaration)
Public Const CssStatusBar As String
Visual C++
public:
literal String^ CssStatusBar

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssWindow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.CssWindow Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CssWindow
Visual Basic (Declaration)
Public Const CssWindow As String
Visual C++
public:
literal String^ CssWindow

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


IdPrefix Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.IdPrefix Field
WindowConstants Class See Also Send Feedback
The string that is prefix in window Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IdPrefix
Visual Basic (Declaration)
Public Const IdPrefix As String
Visual C++
public:
literal String^ IdPrefix

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyWindow Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowConstants..::.KeyWindow Field
WindowConstants Class See Also Send Feedback
The name identifying the Window control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string KeyWindow
Visual Basic (Declaration)
Public Const KeyWindow As String
Visual C++
public:
literal String^ KeyWindow

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


Telerik.WebAii.Controls.Xaml Namespace

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
Telerik.WebAii.Controls.Xaml Namespace
Send Feedback
Contains the WebAii RadControls for Silverlight.

Classes

Class | Description
AggregateResultsList | Represents the RadGridView for Silverlight AggregateResultsList control wrapper.
AppointmentItem | The Scheduler AppointmentItem wrapper.
AppointmentItemDialog | Represents the Scheduler appointment item dialog window wrapper.
AppointmentsControl | The AppointmentsControl serves as a holder for the TimeSlot and Appointment lists.
AutoHideArea | Represents the RadDocking for Silverlight AutoHideArea control wrapper.
CalendarButton | Represents the RadCalendarButton custom control wrapper.
CalendarElementNames | Holds the list of the important Calendar element names.
CalendarPanel | The Calendar panel holding the CalendarButtons.
CalendarView | Represents the RadCalendar for Silverlight CalendarView control.
ChartArea | Represents the RadChart for Silverlight ChartArea control wrapper.
ChartAxisX | Represents the RadChart for Silverlight RadChartAxisX control wrapper.
ChartAxisY | Represents the RadChart for Silverlight RadChartAxisY control wrapper.
ChartHorizontalGridLines | Represents the RadChart for Silverlight ChartHorizontalGridLines control wrapper.
ChartLegend | Represents the RadChart for Silverlight ChartLegend control wrapper.
ChartLegendItem | Represents the RadChart for Silverlight ChartLegendItem control wrapper.
ChartPanel | The Chart series panel holder.
ChartTitle | Represents the RadChart for Silverlight ChartTitle control wrapper.
ChartVerticalGridLines | Represents the RadChart for Silverlight ChartVerticalGridLines control wrapper.
ChartXAxisItem | Represents the RadChart for Silverlight RadChartXAxisItem control wrapper.
ChartXAxisLabel | Represents the RadChart for Silverlight RadChartXAxisLabel control wrapper.
ChartXAxisMinorTicks | Represents the RadChart for Silverlight ChartXAxisMinorTicks control wrapper.
ChartYAxisItem | Represents the RadChart for Silverlight RadChartYAxisItem control wrapper.
ChartYAxisLabel | Represents the RadChart for Silverlight RadChartYAxisLabel control wrapper.
ChartYAxisMinorTicks | Represents the RadChart for Silverlight ChartYAxisMinorTicks control wrapper.
ColorPickerElementNames | Holds the list of the important ColorPicker element names.
ComboBoxElementNames | A list of names specific to RadComboBox component elements.
DatePickerElementNames | Holds the list of the important DatePicker element names.
DockingElementNames | Holds the list of the important RadDocking element names.
DocumentHost | Represents the RadDocking for Silverlight DocumentHost control wrapper.
ExpanderElementNames | Represents a list of control element names.
ExtendedTextBox | Represents the Silverlight MaskedTextBox's ExtendedTextBox control wrapper.
FluidContentControlElementNames | Represents the FluidContentControl important sub element names.
GridViewAggregateResultCell | Represents the RadGridView for Silverlight AggregateResultCell control wrapper.
GridViewCell | Represents the RadGridView for Silverlight GridViewCell control wrapper.
GridViewFooterCell | Represents the RadGridView for Silverlight GridViewFooterCell control wrapper.
GridViewFooterRow | Represents the RadGridView for Silverlight GridViewFooterRow control wrapper.
GridViewGroupPanel | Represents the RadGridView for Silverlight GridViewGroupPanel control wrapper.
GridViewGroupPanelCell | Represents the RadGridView for Silverlight GridViewGroupPanelCell control wrapper.
GridViewGroupPanelItem | Represents the RadGridView for Silverlight GridViewGroupPanelItem control wrapper.
GridViewGroupRow | Represents the RadGridView for Silverlight GridViewGroupRow control wrapper.
GridViewHeaderCell | Represents the RadGridView for Silverlight GridViewHeaderCell control wrapper.
GridViewHeaderRow | Represents the RadGridView for Silverlight GridViewHeaderRow control wrapper.
GridViewNewRow | Represents the RadGridView for Silverlight GridViewNewRow control wrapper.
GridViewRow | Represents the RadGridView for Silverlight GridViewRow control wrapper.
MediaPlayerElementNames | Represents the MediaPlayer important sub element names.
MinimizedOutlookBarArea | Represents the Silverlight MinimizedOutlookBarArea control wrapper.
MinimizedOutlookBarItem | Represents the Silverlight MinimizedOutlookBarItem control wrapper.
NumericUpDownElementNames | Represents a list of control sub elements names.
OutlookBarElementNames | Represents the OutlookBar important sub element names.
PaneHeader | Represents the RadDocking for Silverlight PaneHeader control wrapper.
PanelBarElementNames | Represents the PanelBar/PanelBarItem important sub element names.
PickerTextBox | Represents the PickerTextBox control wrapper.
PickerToggleButton | Represents the Silverlight PickerToggleButton control wrapper.
PlaylistPresenter | Represents the Silverlight MediaPlayer PlaylistPresenter control wrapper. Holds the media item controls.
QuickAccessToolBar | Represents the Silverlight RadRibbonBar's QuickAccessToolBar control wrapper.
RadBook | Represents the Silverlight RadBook wrapper.
RadBookItem | Represents the Silverlight RadBookItem control wrapper.
RadButton | Represents the RadButton for Silverlight control wrapper.
RadCalendar | The class represents the RadCalendar Silverlight control wrapper.
RadCell | Represents the Silverlight TreeListView RadColumn control wrapper.
RadChart | Represents the RadChart for Silverlight RadChart control wrapper.
RadClock | Represents the RadClock for Silverlight control wrapper.
RadClockItem | Represents the RadClockItem for Silverlight control wrapper.
RadColorPaletteView | Represents the Silverlight RadColorPaletteView control wrapper.
RadColorPaletteViewItem | Represents the Silverlight RadColorPaletteViewItem control wrapper.
RadColorPicker | Represents the Silverlight RadColorPicker control wrapper.
RadColorSelector | Represents the Silverlight RadColorSelector control wrapper.
RadColumn | Represents the Silverlight TreeListView RadColumn control wrapper.
RadComboBox | Represents the Silverlight RadComboBox control wrapper.
RadComboBoxItem | Represents the Silverlight RadComboBoxItem control wrapper.
RadContextMenu | Represents the Silverlight RadContextMenu wrapper.
RadControlMappingKeys | Represents a collection of keys identifying RadControls in the framework.
RadCoverFlow | Represents the Silverlight RadCoverFlow wrapper.
RadCoverFlowItem | Represents the Silverlight RadCoverFlowItem control wrapper.
RadDatePicker | Represents the DatePicker control wrapper.
RadDocking | Represents the RadDocking for Silverlight control wrapper. Serves as a holder for the child split containers and tool windows.
RadDocumentPane | Represents the RadDocking for Silverlight RadDocumentPane control wrapper.
RadDropDownButton | Represents the RadDropDownButton for Silverlight control wrapper.
RadExpander | Represents the RadExpander for Silverlight control wrapper.
RadFluidContentControl | Represents the Silverlight RadFluidContentControl wrapper.
RadGridResizer | Represents the RadDocking for Silverlight RadGridResizer control wrapper.
RadGridView | Represents the RadGridView for Silverlight control wrapper.
RadHtmlPlaceholder | Represents the RadHtmlPlaceholder for Silverlight control wrapper.
RadMaskedTextBox | Represents the Silverlight MaskedTextBox control wrapper.
RadMediaChapter | Represents the Silverlight RadMediaChapter control wrapper.
RadMediaItem | Represents the Silverlight RadMediaItem control wrapper.
RadMediaPlayer | Represents the Silverlight RadMediaPlayer control wrapper. Holds the chapter controls.
RadMenu | Represents the Silverlight RadMenu wrapper.
RadMenuBase | Serves as the base for the Silverlight RadMenu and RadContextMenu wrappers.
RadMenuItem | Represents the Silverlight RadMenuItem wrapper.
RadNumericUpDown | Represents the RadNumericUpDown for Silverlight control wrapper.
RadOutlookBar | Represents the Silverlight RadOutlookBar control wrapper.
RadOutlookBarItem | Represents the Silverlight RadOutlookBarItem control wrapper.
RadPane | Represents the RadDocking for Silverlight RadPane control wrapper.
RadPaneGroup | Represents the RadDocking for Silverlight RadPaneGroup control wrapper.
RadPanelBar | Represents the Silverlight RadPanelBar control wrapper.
RadPanelBarItem | Represents the Silverlight RadPanelBarItem control wrapper.
RadProgressBar | Represents the RadProgressBar for Silverlight control wrapper.
RadRadioButton | Represents the RadRadioButton for Silverlight control wrapper.
RadRibbonBar | Represents the Silverlight RadRibbonBar control wrapper.
RadRibbonButton | Represents the Silverlight RadRibbonBar's Button control wrapper.
RadRibbonDropDownButton | Represents the Silverlight RadRibbonBar's DropDownButton control wrapper.
RadRibbonGroup | Represents the Silverlight RadRibbonGroup control wrapper.
RadRibbonRadioButton | Represents the Silverlight RadRibbonRadioButton control wrapper.
RadRibbonSplitButton | Represents the RadRibbonSplitButton for Silverlight control wrapper.
RadScheduler | Represents the RadScheduler control wrapper. Serves as a main entry point for the entire Scheduler API.
RadSlider | Represents the Silverlight RadSlider control wrapper.
RadSplitButton | Represents the RadSplitButton for Silverlight control wrapper.
RadSplitContainer | Represents the RadDocking for Silverlight RadSplitContainer control wrapper. The instance may contain child split containers as well as pane group controls.
RadTabControl | Represents the Silverlight RadTabControl wrapper.
RadTabItem | Represents the Silverlight RadTabItem wrapper.
RadTickBar | Represents the Silverlight RadTickBar control wrapper. Holds the Slider ticks.
RadTileView | Represents the Silverlight RadTileView wrapper.
RadTileViewItem | Represents the Silverlight RadTileViewItem wrapper.
RadTimePicker | Represents the RadTimePicker for Silverlight control wrapper.
RadToggleButton | Represents the RadToggleButton for Silverlight control wrapper.
RadToolBar | Represents the Silverlight RadToolBar control wrapper.
RadToolBarTray | Represents the Silverlight RadToolBar control wrapper.
RadTreeListView | Represents the Silverlight RadTreeListView control wrapper.
RadTreeListViewItem | Represents the Silverlight RadTreeViewItem control wrapper.
RadTreeView | Represents the Silverlight RadTreeView control wrapper.
RadTreeViewItem | Represents the Silverlight RadTreeViewItem control wrapper.
RadUniformGrid | Represents the RadUniformGrid for Silverlight control wrapper.
RadUpload | Represents the RadUpload for Silverlight control wrapper.
RadUploadItem | Represents the RadUploadItem for Silverlight control wrapper.
RadWindow | Represents the Silverlight RadWindow control wrapper.
RibbonBarElementNames | Represents the RadRibbonBar important sub element names.
SchedulerDayPresenter | The Scheduler DayView presenter.
SchedulerElementNames | Represents the Scheduler important sub element names.
SchedulerMonthPresenter | The Scheduler MonthView presenter.
SchedulerPresenter | The Scheduler View presenter base control.
SchedulerTimelinePresenter | Represents the RadScheduler Timeline presenter control wrapper.
SchedulerWeekPresenter | Represents the Scheduler WeekView wrapper.
SliderElementNames | Represents a list of RadSlider element names used accross the wrapper controls.
SplitButtonElementNames | Represents the RadSplitButton important sub element names.
TabControlElementNames | Represents the TabControl/TabItem important sub element names.
TileViewElementNames | Represents the TileView important sub element names.
TimePickerElementNames | Holds the list of the important TimePicker element names.
TimeSlotItem | Represents the TimeSlotItem control.
ToolBarElementNames | Represents the ToolBar/ToolBarTray important sub element names.
ToolWindow | Represents the RadDocking for Silverlight ToolWindow control wrapper. The tool window always contains a single SplitContainer instance that may hold other containers or pane groups.
TreeListViewElementNames | Represents the TreeListView important element names.
TreeViewElementNames | Represents the TreeView and TreeViewItem important sub element names.
UploadElementNames | Holds the list of important RadUpload element names.
WindowElementNames | Represents a list of RadWindow element names used accross the wrappers.
WindowTitle | Represents the Silverlight WindowTitle control wrapper.

Enumerations

Enumeration | Description
CalendarDisplayMode | Represents the Calendar display mode.
DockingDragDirection | The RadDocking drag direction enumeration - left, right, up and down.
DockPosition | The dock position enumeration. Used as an argument for RadDocking.DockToX like methods.
FluidContentControlState | Represents the FluidContentControl state values.
HeaderCellThumbName | Enumerates the HeaderCell thumbs user interacts with.
Position | Represents an enumeration of possible positions specific to the control layout.
SchedulerViewType | The enumeration holding the supported Scheduler view types.
ThumbName | Enumerates the Slider control thumbs user interacts with.
TurnPagePosition | Represents the RadBook enumeration for the possible corner positions to turn a page from.


AggregateResultsList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight AggregateResultsList control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class AggregateResultsList : ItemsControl
Visual Basic (Declaration)
Public Class AggregateResultsList _
    Inherits ItemsControl
Visual C++
public ref class AggregateResultsList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.AggregateResultsList

See Also

AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList Members
AggregateResultsList Class Constructors Methods Properties See Also Send Feedback

The AggregateResultsList type exposes the following members.

Constructors

Name | Description
AggregateResultsList | Initializes a new instance of the AggregateResultsList class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView AggregateResultsList control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AggregateResultCells | Gets the aggregate result cells.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the aggregate result list control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList Constructor
AggregateResultsList Class See Also Send Feedback
Initializes a new instance of the AggregateResultsList class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AggregateResultsList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AggregateResultsList()

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList Methods
AggregateResultsList Class See Also Send Feedback

The AggregateResultsList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView AggregateResultsList control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.AnySibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.GetProperty Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.GetRectangle Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.Highlight Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.InitializeMappings Method
AggregateResultsList Class See Also Send Feedback
Initializes the mapping of the GridView AggregateResultsList control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.InvokeMethod Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.NextSibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.Parent Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.PreviousSibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.ScrollToVisible Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList Properties
AggregateResultsList Class See Also Send Feedback

The AggregateResultsList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AggregateResultCells | Gets the aggregate result cells.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the aggregate result list control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultCells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.AggregateResultCells Property
AggregateResultsList Class See Also Send Feedback
Gets the aggregate result cells.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewAggregateResultCell> AggregateResultCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property AggregateResultCells As IList(Of GridViewAggregateResultCell)
Visual C++
public:
property IList<GridViewAggregateResultCell^>^ AggregateResultCells {
    IList<GridViewAggregateResultCell^>^ get ();
}

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AggregateResultsList..::.XamlTag Property
AggregateResultsList Class See Also Send Feedback
Get the xaml tag of the aggregate result list control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem Class
Members See Also Send Feedback
The Scheduler AppointmentItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class AppointmentItem : ListBoxItem
Visual Basic (Declaration)
Public Class AppointmentItem _
    Inherits ListBoxItem
Visual C++
public ref class AppointmentItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBoxItem
Telerik.WebAii.Controls.Xaml..::.AppointmentItem

See Also

AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem Members
AppointmentItem Class Constructors Methods Properties See Also Send Feedback

The AppointmentItem type exposes the following members.

Constructors

Name | Description
AppointmentItem | Initializes a new instance of the AppointmentItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Delete | Simulate user clicking on the appointment delete button.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToTimeSlot | Overloaded.
DragToTimeSlotDay | Drag the appointment item to the MonthView time slot with the given index and occurrence.
EndsWithDaySlot | Overloaded.
EndsWithSlotIndex | Get whether the appointment item ends in the time slot with given index.
EndsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
FallsInDaySlot | Overloaded.
FallsInSlotIndex | Get whether the appointment rectangle completely resides within the time slot with given index.
FallsInSlotRectangle | Checks whether the appointment item falls within the given time slot's rectangle.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler AppointmentItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeFromEnd | Resizes the appointment item from the end with the slots/steps as given in the argument.
ResizeFromStart | Resizes the appointment item from the start with the slots/steps as given in the argument.
ScrollToVisible | Overloaded.
Select | Selects the appointment.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StartsWithDaySlot | Overloaded.
StartsWithSlotIndex | Get whether the appointment item starts in the time slot with given index.
StartsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
DeleteButton | Get the delete button of this appointment item.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndTimeSlot | Get the TimeSlotItem this AppointmentItem ends (and doesn't start) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RecurrentMaskVisibility | Get the recurrent mask visibility value.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartTimeSlot | Get the TimeSlotItem this AppointmentItem starts (and doesn't end) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.
Subject | Get the appointment subject.
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeSlotLength | Get the length of the appointment item in time slots.
TimeSlotOwner | Get the TimeSlotItem this AppointmentItem falls (comepletely) in. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns null for the appointments falling in two or more time slots, see the StartTimeSlot and EndTimeSlot properties.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the AppointmentItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem Constructor
AppointmentItem Class See Also Send Feedback
Initializes a new instance of the AppointmentItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AppointmentItem()

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem Methods
AppointmentItem Class See Also Send Feedback

The AppointmentItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Delete | Simulate user clicking on the appointment delete button.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToTimeSlot | Overloaded.
DragToTimeSlotDay | Drag the appointment item to the MonthView time slot with the given index and occurrence.
EndsWithDaySlot | Overloaded.
EndsWithSlotIndex | Get whether the appointment item ends in the time slot with given index.
EndsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
FallsInDaySlot | Overloaded.
FallsInSlotIndex | Get whether the appointment rectangle completely resides within the time slot with given index.
FallsInSlotRectangle | Checks whether the appointment item falls within the given time slot's rectangle.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler AppointmentItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeFromEnd | Resizes the appointment item from the end with the slots/steps as given in the argument.
ResizeFromStart | Resizes the appointment item from the start with the slots/steps as given in the argument.
ScrollToVisible | Overloaded.
Select | Selects the appointment.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StartsWithDaySlot | Overloaded.
StartsWithSlotIndex | Get whether the appointment item starts in the time slot with given index.
StartsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.AnySibling Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


Delete Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.Delete Method
AppointmentItem Class See Also Send Feedback
Simulate user clicking on the appointment delete button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


DragToTimeSlot Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.DragToTimeSlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
DragToTimeSlot(FrameworkElement) | Drag the appointment item to the given time slot element.
DragToTimeSlot(Int32) | Drag the appointment item to the time slot with the given index.

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


DragToTimeSlot Method (FrameworkElement)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.DragToTimeSlot Method (FrameworkElement)
AppointmentItem Class See Also Send Feedback
Drag the appointment item to the given time slot element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToTimeSlot(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Sub DragToTimeSlot ( _
    timeSlot As FrameworkElement _
)
Visual C++
public:
void DragToTimeSlot(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The time slot element to drag to.

See Also

AppointmentItem Class
DragToTimeSlot Overload
Telerik.WebAii.Controls.Xaml Namespace


DragToTimeSlot Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.DragToTimeSlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Drag the appointment item to the time slot with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToTimeSlot(
    int slotIndex
)
Visual Basic (Declaration)
Public Sub DragToTimeSlot ( _
    slotIndex As Integer _
)
Visual C++
public:
void DragToTimeSlot(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The index of the time slot to drag to.

See Also

AppointmentItem Class
DragToTimeSlot Overload
Telerik.WebAii.Controls.Xaml Namespace


DragToTimeSlotDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.DragToTimeSlotDay Method
AppointmentItem Class See Also Send Feedback
Drag the appointment item to the MonthView time slot with the given index and occurrence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToTimeSlotDay(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Sub DragToTimeSlotDay ( _
    slotDay As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void DragToTimeSlotDay(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The time slot day value (e.g. '25' for the 25th of the month) to drag to.
occurrence
Type: System..::.Int32
The occurrence, i.e. if the 29th is shown twice in this month (previous and current month) use '1' as index.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


EndsWithDaySlot Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.EndsWithDaySlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
EndsWithDaySlot(Int32) | Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.
EndsWithDaySlot(Int32, Int32) | Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


EndsWithDaySlot Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.EndsWithDaySlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EndsWithDaySlot(
    int slotDay
)
Visual Basic (Declaration)
Public Function EndsWithDaySlot ( _
    slotDay As Integer _
) As Boolean
Visual C++
public:
bool EndsWithDaySlot(
    int slotDay
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.

Return Value

Whether the appointment ends with the time slot and starts with a previous slot.

See Also

AppointmentItem Class
EndsWithDaySlot Overload
Telerik.WebAii.Controls.Xaml Namespace


EndsWithDaySlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.EndsWithDaySlot Method (Int32, Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EndsWithDaySlot(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Function EndsWithDaySlot ( _
    slotDay As Integer, _
    occurrence As Integer _
) As Boolean
Visual C++
public:
bool EndsWithDaySlot(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.
occurrence
Type: System..::.Int32
The occurence of that day in the month.

Return Value

Whether the appointment ends with the time slot and starts with a previous slot.

See Also

AppointmentItem Class
EndsWithDaySlot Overload
Telerik.WebAii.Controls.Xaml Namespace


EndsWithSlotIndex Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.EndsWithSlotIndex Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item ends in the time slot with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EndsWithSlotIndex(
    int slotIndex
)
Visual Basic (Declaration)
Public Function EndsWithSlotIndex ( _
    slotIndex As Integer _
) As Boolean
Visual C++
public:
bool EndsWithSlotIndex(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The index of the time slot to compare with.

Return Value

Whether the appointment item ends in the time slot with given index.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


EndsWithSlotRectangle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.EndsWithSlotRectangle Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item starts within the rectangle of the given time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool EndsWithSlotRectangle(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Function EndsWithSlotRectangle ( _
    timeSlot As FrameworkElement _
) As Boolean
Visual C++
public:
bool EndsWithSlotRectangle(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The time slot to compare with.

Return Value

Whether the appointment item starts within the rectangle of the given time slot.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


FallsInDaySlot Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.FallsInDaySlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
FallsInDaySlot(Int32) | Get whether the appointment rectangle completely resides within the time slot with given day.
FallsInDaySlot(Int32, Int32) | Get whether the appointment rectangle completely resides within the given time slot. Supposed to be used in MonthView only.

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


FallsInDaySlot Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.FallsInDaySlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment rectangle completely resides within the time slot with given day.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool FallsInDaySlot(
    int slotDay
)
Visual Basic (Declaration)
Public Function FallsInDaySlot ( _
    slotDay As Integer _
) As Boolean
Visual C++
public:
bool FallsInDaySlot(
    int slotDay
)

Parameters

slotDay
Type: System..::.Int32
The day to check whether the appointment item falls within.

Return Value

Whether the appointment rectangle completely resides within the time slot with given day.

See Also

AppointmentItem Class
FallsInDaySlot Overload
Telerik.WebAii.Controls.Xaml Namespace


FallsInDaySlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.FallsInDaySlot Method (Int32, Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment rectangle completely resides within the given time slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool FallsInDaySlot(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Function FallsInDaySlot ( _
    slotDay As Integer, _
    occurrence As Integer _
) As Boolean
Visual C++
public:
bool FallsInDaySlot(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The day to check whether the appointment item falls within.
occurrence
Type: System..::.Int32
The occurrence of that day in the month.

Return Value

Whether the appointment rectangle completely resides within the given time slot.

See Also

AppointmentItem Class
FallsInDaySlot Overload
Telerik.WebAii.Controls.Xaml Namespace


FallsInSlotIndex Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.FallsInSlotIndex Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment rectangle completely resides within the time slot with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool FallsInSlotIndex(
    int slotIndex
)
Visual Basic (Declaration)
Public Function FallsInSlotIndex ( _
    slotIndex As Integer _
) As Boolean
Visual C++
public:
bool FallsInSlotIndex(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The day to check whether the appointment item falls within.

Return Value

Whether the appointment rectangle completely resides within the time slot with given index.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


FallsInSlotRectangle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.FallsInSlotRectangle Method
AppointmentItem Class See Also Send Feedback
Checks whether the appointment item falls within the given time slot's rectangle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool FallsInSlotRectangle(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Function FallsInSlotRectangle ( _
    timeSlot As FrameworkElement _
) As Boolean
Visual C++
public:
bool FallsInSlotRectangle(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The time slot to compare with.

Return Value

Whether the appointment item falls within the given time slot's rectangle.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.GetProperty Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.GetRectangle Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.Highlight Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.InitializeMappings Method
AppointmentItem Class See Also Send Feedback
Initializes the mapping of the RadScheduler AppointmentItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.InvokeMethod Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.NextSibling Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.Parent Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.PreviousSibling Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


ResizeFromEnd Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.ResizeFromEnd Method
AppointmentItem Class See Also Send Feedback
Resizes the appointment item from the end with the slots/steps as given in the argument.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeFromEnd(
    int slots
)
Visual Basic (Declaration)
Public Sub ResizeFromEnd ( _
    slots As Integer _
)
Visual C++
public:
void ResizeFromEnd(
    int slots
)

Parameters

slots
Type: System..::.Int32
The slots to resize from end with. Use negative value to resize to left and positive -- to right.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeFromStart Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.ResizeFromStart Method
AppointmentItem Class See Also Send Feedback
Resizes the appointment item from the start with the slots/steps as given in the argument.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeFromStart(
    int slots
)
Visual Basic (Declaration)
Public Sub ResizeFromStart ( _
    slots As Integer _
)
Visual C++
public:
void ResizeFromStart(
    int slots
)

Parameters

slots
Type: System..::.Int32
The slots to resize from start with. Use negative value to resize to left and positive -- to right.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.ScrollToVisible Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.Select Method
AppointmentItem Class See Also Send Feedback
Selects the appointment.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


StartsWithDaySlot Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.StartsWithDaySlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
StartsWithDaySlot(Int32) | Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.
StartsWithDaySlot(Int32, Int32) | Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.

See Also

AppointmentItem Class
AppointmentItem Members
Telerik.WebAii.Controls.Xaml Namespace


StartsWithDaySlot Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.StartsWithDaySlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StartsWithDaySlot(
    int slotDay
)
Visual Basic (Declaration)
Public Function StartsWithDaySlot ( _
    slotDay As Integer _
) As Boolean
Visual C++
public:
bool StartsWithDaySlot(
    int slotDay
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.

Return Value

Whether the appointment starts with the time slot and continues on the next slot.

See Also

AppointmentItem Class
StartsWithDaySlot Overload
Telerik.WebAii.Controls.Xaml Namespace


StartsWithDaySlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.StartsWithDaySlot Method (Int32, Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StartsWithDaySlot(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Function StartsWithDaySlot ( _
    slotDay As Integer, _
    occurrence As Integer _
) As Boolean
Visual C++
public:
bool StartsWithDaySlot(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.
occurrence
Type: System..::.Int32
The occurence of that day in the month.

Return Value

Whether the appointment starts with the time slot and continues on the next slot.

See Also

AppointmentItem Class
StartsWithDaySlot Overload
Telerik.WebAii.Controls.Xaml Namespace


StartsWithSlotIndex Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.StartsWithSlotIndex Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item starts in the time slot with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StartsWithSlotIndex(
    int slotIndex
)
Visual Basic (Declaration)
Public Function StartsWithSlotIndex ( _
    slotIndex As Integer _
) As Boolean
Visual C++
public:
bool StartsWithSlotIndex(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The index of the time slot to compare with.

Return Value

Whether the appointment item starts in the time slot with given index.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


StartsWithSlotRectangle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.StartsWithSlotRectangle Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item starts within the rectangle of the given time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StartsWithSlotRectangle(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Function StartsWithSlotRectangle ( _
    timeSlot As FrameworkElement _
) As Boolean
Visual C++
public:
bool StartsWithSlotRectangle(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The time slot to compare with.

Return Value

Whether the appointment item starts within the rectangle of the given time slot.

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem Properties
AppointmentItem Class See Also Send Feedback

The AppointmentItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
DeleteButton | Get the delete button of this appointment item.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndTimeSlot | Get the TimeSlotItem this AppointmentItem ends (and doesn't start) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RecurrentMaskVisibility | Get the recurrent mask visibility value.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartTimeSlot | Get the TimeSlotItem this AppointmentItem starts (and doesn't end) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.
Subject | Get the appointment subject.
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeSlotLength | Get the length of the appointment item in time slots.
TimeSlotOwner | Get the TimeSlotItem this AppointmentItem falls (comepletely) in. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns null for the appointments falling in two or more time slots, see the StartTimeSlot and EndTimeSlot properties.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the AppointmentItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


DeleteButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.DeleteButton Property
AppointmentItem Class See Also Send Feedback
Get the delete button of this appointment item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Button DeleteButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeleteButton As Button
Visual C++
public:
property Button^ DeleteButton {
    Button^ get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


EndTimeSlot Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.EndTimeSlot Property
AppointmentItem Class See Also Send Feedback
Get the TimeSlotItem this AppointmentItem ends (and doesn't start) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSlotItem EndTimeSlot { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndTimeSlot As TimeSlotItem
Visual C++
public:
property TimeSlotItem^ EndTimeSlot {
    TimeSlotItem^ get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


RecurrentMaskVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.RecurrentMaskVisibility Property
AppointmentItem Class See Also Send Feedback
Get the recurrent mask visibility value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility RecurrentMaskVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecurrentMaskVisibility As Visibility
Visual C++
public:
property Visibility RecurrentMaskVisibility {
    Visibility get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


StartTimeSlot Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.StartTimeSlot Property
AppointmentItem Class See Also Send Feedback
Get the TimeSlotItem this AppointmentItem starts (and doesn't end) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSlotItem StartTimeSlot { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTimeSlot As TimeSlotItem
Visual C++
public:
property TimeSlotItem^ StartTimeSlot {
    TimeSlotItem^ get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


Subject Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.Subject Property
AppointmentItem Class See Also Send Feedback
Get the appointment subject.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Subject { get; }
Visual Basic (Declaration)
Public ReadOnly Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotLength Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.TimeSlotLength Property
AppointmentItem Class See Also Send Feedback
Get the length of the appointment item in time slots.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int TimeSlotLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlotLength As Integer
Visual C++
public:
property int TimeSlotLength {
    int get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotOwner Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.TimeSlotOwner Property
AppointmentItem Class See Also Send Feedback
Get the TimeSlotItem this AppointmentItem falls (comepletely) in. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns null for the appointments falling in two or more time slots, see the StartTimeSlot and EndTimeSlot properties.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSlotItem TimeSlotOwner { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlotOwner As TimeSlotItem
Visual C++
public:
property TimeSlotItem^ TimeSlotOwner {
    TimeSlotItem^ get ();
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItem..::.XamlTag Property
AppointmentItem Class See Also Send Feedback
Get the xaml tag of the AppointmentItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItemDialog Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog Class
Members See Also Send Feedback
Represents the Scheduler appointment item dialog window wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class AppointmentItemDialog : RadWindow
Visual Basic (Declaration)
Public Class AppointmentItemDialog _
    Inherits RadWindow
Visual C++
public ref class AppointmentItemDialog : public RadWindow

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadWindow
Telerik.WebAii.Controls.Xaml..::.AppointmentItemDialog

See Also

AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItemDialog Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog Members
AppointmentItemDialog Class Constructors Methods Properties See Also Send Feedback

The AppointmentItemDialog type exposes the following members.

Constructors

Name | Description
AppointmentItemDialog | Initializes a new instance of the AppointmentItemDialog class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AllDayEventCheck | Click the 'AllDayEvent' check box.
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Closes the window by a 'Close' button Click action. (Inherited from RadWindow.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeightCloseTo | Round the height of the window. (Inherited from RadWindow.)
Highlight | Overloaded.
HorizontalCoordinateCloseTo | Round the horizontal coordinates of the window. (Inherited from RadWindow.)
InitializeMappings | Initializes the mapping of the RadWindow control. (Inherited from RadWindow.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Maximize | Maximizes the window by a 'Maximize' button Click action. (Inherited from RadWindow.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes the window by a 'Minimize' button Click action. (Inherited from RadWindow.)
MoveBy | Moves the window dragging its header thumb by the given pixels on X and Y coordinates. (Inherited from RadWindow.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeDown | Resizes (Down) the window with given pixels. (Inherited from RadWindow.)
ResizeDownLeft | Resizes to down/left the window with given pixels. (Inherited from RadWindow.)
ResizeDownRight | Resizes to down/right the window with given pixels. (Inherited from RadWindow.)
ResizeLeft | Resizes (Left) the window with given pixels. (Inherited from RadWindow.)
ResizeRight | Resizes (Right) the window with given pixels. (Inherited from RadWindow.)
ResizeUp | Resizes (UP) the window with given pixels. (Inherited from RadWindow.)
ResizeUpLeft | Resizes to up/left the window with given pixels. (Inherited from RadWindow.)
ResizeUpRight | Resizes to up/right the window with given pixels. (Inherited from RadWindow.)
Restore | Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button. (Inherited from RadWindow.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TypeDescription | Simulates user typing new description.
TypeSubject | Simulates user typing a new subject value.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
VerticalCoordinateCloseTo | Round the vertical coordinates of the window. (Inherited from RadWindow.)
WidthCloseTo | Round the width of the window. (Inherited from RadWindow.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanClose | Gets a value indicating whether the current RadWindow can be closed. (Inherited from RadWindow.)
CanMove | Gets a value indicating whether the current RadWindow can be moved. (Inherited from RadWindow.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the Window content presenter element. (Inherited from RadWindow.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Description | Get the appointment description.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndDatePicker | Get the end time RadDatePicker control.
EndTimeComboBox | Get the end time RadComboBox control.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsActiveWindow | Gets a value indicating whether this instance is active. (Inherited from RadWindow.)
IsAllDayEvent | Get whether the all day event check box is checked.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMaximized | Gets a value that represents whether the RadWindow is maximized. (Inherited from RadWindow.)
IsMinimized | Gets a value that represents whether the RadWindow is minimized. (Inherited from RadWindow.)
IsModal | Gets a value that represents whether the RadWindow is modal. (Inherited from RadWindow.)
IsOpen | Gets a value representing the current RadWindow open state. (Inherited from RadWindow.)
IsPinned | Gets a value indicating whether the current RadWindow is pinned. (Inherited from RadWindow.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page. (Inherited from RadWindow.)
LeftOffset | Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent. (Inherited from RadWindow.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RestoreMinimizedLocation | Gets the value determining whether the window preserves its size and location when the state is changed. (Inherited from RadWindow.)
StartDatePicker | Get the start date RadDatePicker control.
StartTimeComboBox | Get the start time RadComboBox control.
Subject | Get the subject field of the appointment dialog.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the window. (Inherited from RadWindow.)
Top | Gets or sets a value that represents the distance between the top of an element and the top of the page. (Inherited from RadWindow.)
TopOffset | Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'. (Inherited from RadWindow.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadWindow control. (Inherited from RadWindow.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItemDialog Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog Constructor
AppointmentItemDialog Class See Also Send Feedback
Initializes a new instance of the AppointmentItemDialog class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentItemDialog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AppointmentItemDialog()

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItemDialog Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog Methods
AppointmentItemDialog Class See Also Send Feedback

The AppointmentItemDialog type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AllDayEventCheck | Click the 'AllDayEvent' check box.
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Closes the window by a 'Close' button Click action. (Inherited from RadWindow.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeightCloseTo | Round the height of the window. (Inherited from RadWindow.)
Highlight | Overloaded.
HorizontalCoordinateCloseTo | Round the horizontal coordinates of the window. (Inherited from RadWindow.)
InitializeMappings | Initializes the mapping of the RadWindow control. (Inherited from RadWindow.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Maximize | Maximizes the window by a 'Maximize' button Click action. (Inherited from RadWindow.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes the window by a 'Minimize' button Click action. (Inherited from RadWindow.)
MoveBy | Moves the window dragging its header thumb by the given pixels on X and Y coordinates. (Inherited from RadWindow.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeDown | Resizes (Down) the window with given pixels. (Inherited from RadWindow.)
ResizeDownLeft | Resizes to down/left the window with given pixels. (Inherited from RadWindow.)
ResizeDownRight | Resizes to down/right the window with given pixels. (Inherited from RadWindow.)
ResizeLeft | Resizes (Left) the window with given pixels. (Inherited from RadWindow.)
ResizeRight | Resizes (Right) the window with given pixels. (Inherited from RadWindow.)
ResizeUp | Resizes (UP) the window with given pixels. (Inherited from RadWindow.)
ResizeUpLeft | Resizes to up/left the window with given pixels. (Inherited from RadWindow.)
ResizeUpRight | Resizes to up/right the window with given pixels. (Inherited from RadWindow.)
Restore | Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button. (Inherited from RadWindow.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TypeDescription | Simulates user typing new description.
TypeSubject | Simulates user typing a new subject value.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
VerticalCoordinateCloseTo | Round the vertical coordinates of the window. (Inherited from RadWindow.)
WidthCloseTo | Round the width of the window. (Inherited from RadWindow.)

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


AllDayEventCheck Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.AllDayEventCheck Method
AppointmentItemDialog Class See Also Send Feedback
Click the 'AllDayEvent' check box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void AllDayEventCheck()
Visual Basic (Declaration)
Public Sub AllDayEventCheck
Visual C++
public:
void AllDayEventCheck()

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.AnySibling Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.GetProperty Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.GetRectangle Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.Highlight Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.InvokeMethod Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.NextSibling Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.Parent Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.PreviousSibling Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.ScrollToVisible Method
AppointmentItemDialog Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
AppointmentItemDialog Members
Telerik.WebAii.Controls.Xaml Namespace


TypeDescription Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.TypeDescription Method
AppointmentItemDialog Class See Also Send Feedback
Simulates user typing new description.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TypeDescription(
    string description
)
Visual Basic (Declaration)
Public Sub TypeDescription ( _
    description As String _
)
Visual C++
public:
void TypeDescription(
    String^ description
)

Parameters

description
Type: System..::.String
The description to be set.

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


TypeSubject Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.TypeSubject Method
AppointmentItemDialog Class See Also Send Feedback
Simulates user typing a new subject value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TypeSubject(
    string subject
)
Visual Basic (Declaration)
Public Sub TypeSubject ( _
    subject As String _
)
Visual C++
public:
void TypeSubject(
    String^ subject
)

Parameters

subject
Type: System..::.String
The new subject to set.

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItemDialog Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog Properties
AppointmentItemDialog Class See Also Send Feedback

The AppointmentItemDialog type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanClose | Gets a value indicating whether the current RadWindow can be closed. (Inherited from RadWindow.)
CanMove | Gets a value indicating whether the current RadWindow can be moved. (Inherited from RadWindow.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the Window content presenter element. (Inherited from RadWindow.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Description | Get the appointment description.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndDatePicker | Get the end time RadDatePicker control.
EndTimeComboBox | Get the end time RadComboBox control.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsActiveWindow | Gets a value indicating whether this instance is active. (Inherited from RadWindow.)
IsAllDayEvent | Get whether the all day event check box is checked.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMaximized | Gets a value that represents whether the RadWindow is maximized. (Inherited from RadWindow.)
IsMinimized | Gets a value that represents whether the RadWindow is minimized. (Inherited from RadWindow.)
IsModal | Gets a value that represents whether the RadWindow is modal. (Inherited from RadWindow.)
IsOpen | Gets a value representing the current RadWindow open state. (Inherited from RadWindow.)
IsPinned | Gets a value indicating whether the current RadWindow is pinned. (Inherited from RadWindow.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page. (Inherited from RadWindow.)
LeftOffset | Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent. (Inherited from RadWindow.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RestoreMinimizedLocation | Gets the value determining whether the window preserves its size and location when the state is changed. (Inherited from RadWindow.)
StartDatePicker | Get the start date RadDatePicker control.
StartTimeComboBox | Get the start time RadComboBox control.
Subject | Get the subject field of the appointment dialog.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the window. (Inherited from RadWindow.)
Top | Gets or sets a value that represents the distance between the top of an element and the top of the page. (Inherited from RadWindow.)
TopOffset | Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'. (Inherited from RadWindow.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadWindow control. (Inherited from RadWindow.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


Description Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.Description Property
AppointmentItemDialog Class See Also Send Feedback
Get the appointment description.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


EndDatePicker Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.EndDatePicker Property
AppointmentItemDialog Class See Also Send Feedback
Get the end time RadDatePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDatePicker EndDatePicker { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndDatePicker As RadDatePicker
Visual C++
public:
property RadDatePicker^ EndDatePicker {
    RadDatePicker^ get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


EndTimeComboBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.EndTimeComboBox Property
AppointmentItemDialog Class See Also Send Feedback
Get the end time RadComboBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBox EndTimeComboBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndTimeComboBox As RadComboBox
Visual C++
public:
property RadComboBox^ EndTimeComboBox {
    RadComboBox^ get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


IsAllDayEvent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.IsAllDayEvent Property
AppointmentItemDialog Class See Also Send Feedback
Get whether the all day event check box is checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAllDayEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAllDayEvent As Boolean
Visual C++
public:
property bool IsAllDayEvent {
    bool get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


StartDatePicker Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.StartDatePicker Property
AppointmentItemDialog Class See Also Send Feedback
Get the start date RadDatePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDatePicker StartDatePicker { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartDatePicker As RadDatePicker
Visual C++
public:
property RadDatePicker^ StartDatePicker {
    RadDatePicker^ get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


StartTimeComboBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.StartTimeComboBox Property
AppointmentItemDialog Class See Also Send Feedback
Get the start time RadComboBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBox StartTimeComboBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTimeComboBox As RadComboBox
Visual C++
public:
property RadComboBox^ StartTimeComboBox {
    RadComboBox^ get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


Subject Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentItemDialog..::.Subject Property
AppointmentItemDialog Class See Also Send Feedback
Get the subject field of the appointment dialog.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Subject { get; }
Visual Basic (Declaration)
Public ReadOnly Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
}

See Also

AppointmentItemDialog Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl Class
Members See Also Send Feedback
The AppointmentsControl serves as a holder for the TimeSlot and Appointment lists.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class AppointmentsControl : Control
Visual Basic (Declaration)
Public Class AppointmentsControl _
    Inherits Control
Visual C++
public ref class AppointmentsControl : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.AppointmentsControl

See Also

AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl Members
AppointmentsControl Class Constructors Methods Properties See Also Send Feedback

The AppointmentsControl type exposes the following members.

Constructors

Name | Description
AppointmentsControl | Initializes a new instance of the AppointmentsControl class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
DeleteAppointment | Simulates user deleting the appointment with the given index. Refreshes the content internally.
DeleteRecurringItem | Simulates user deleting the recurring item with the given appointment index. Refreshes the content internally.
DeleteRecurringSeries | Simulates user deleting the recurring series with the given appointment index. Refreshes the content internally.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragAppointmentToTimeSlot | Overloaded.
DragAppointmentToTimeSlotDay | Drags the appointment with given index to the time slot with the given index and occurence. Refreshes the content internally.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetDayTimeSlotItem | Overloaded.
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler AppointmentsControl control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Simulates user clicking on the specified day to open it.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeAppointmentFromEnd | Resizes the appointment with the given index with the specified slots/steps. Refreshes the content internally.
ResizeAppointmentFromStart | Resizes the appointment with the given index with the specified slots/steps. Refreshes the content internally.
ScrollToVisible | Overloaded.
SelectDay | Simulates user selecting the specified day.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Appointments | Get the list of appointments.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeSlots | Get the list of TimeSlots for the appointments control.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the Scheduler Appointments control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl Constructor
AppointmentsControl Class See Also Send Feedback
Initializes a new instance of the AppointmentsControl class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AppointmentsControl()

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl Methods
AppointmentsControl Class See Also Send Feedback

The AppointmentsControl type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
DeleteAppointment | Simulates user deleting the appointment with the given index. Refreshes the content internally.
DeleteRecurringItem | Simulates user deleting the recurring item with the given appointment index. Refreshes the content internally.
DeleteRecurringSeries | Simulates user deleting the recurring series with the given appointment index. Refreshes the content internally.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragAppointmentToTimeSlot | Overloaded.
DragAppointmentToTimeSlotDay | Drags the appointment with given index to the time slot with the given index and occurence. Refreshes the content internally.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetDayTimeSlotItem | Overloaded.
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler AppointmentsControl control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Simulates user clicking on the specified day to open it.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeAppointmentFromEnd | Resizes the appointment with the given index with the specified slots/steps. Refreshes the content internally.
ResizeAppointmentFromStart | Resizes the appointment with the given index with the specified slots/steps. Refreshes the content internally.
ScrollToVisible | Overloaded.
SelectDay | Simulates user selecting the specified day.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.AnySibling Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.AssignReference Method
AppointmentsControl Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


DeleteAppointment Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DeleteAppointment Method
AppointmentsControl Class See Also Send Feedback
Simulates user deleting the appointment with the given index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DeleteAppointment(
    int appIndex
)
Visual Basic (Declaration)
Public Sub DeleteAppointment ( _
    appIndex As Integer _
)
Visual C++
public:
void DeleteAppointment(
    int appIndex
)

Parameters

appIndex
Type: System..::.Int32
The index of the appointment to delete.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


DeleteRecurringItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DeleteRecurringItem Method
AppointmentsControl Class See Also Send Feedback
Simulates user deleting the recurring item with the given appointment index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DeleteRecurringItem(
    int appIndex
)
Visual Basic (Declaration)
Public Sub DeleteRecurringItem ( _
    appIndex As Integer _
)
Visual C++
public:
void DeleteRecurringItem(
    int appIndex
)

Parameters

appIndex
Type: System..::.Int32
The index of the recurring appointment to delete.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


DeleteRecurringSeries Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DeleteRecurringSeries Method
AppointmentsControl Class See Also Send Feedback
Simulates user deleting the recurring series with the given appointment index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DeleteRecurringSeries(
    int appIndex
)
Visual Basic (Declaration)
Public Sub DeleteRecurringSeries ( _
    appIndex As Integer _
)
Visual C++
public:
void DeleteRecurringSeries(
    int appIndex
)

Parameters

appIndex
Type: System..::.Int32
The index of the recurring series appointment to delete.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


DragAppointmentToTimeSlot Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DragAppointmentToTimeSlot Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
DragAppointmentToTimeSlot(Int32, FrameworkElement) | Drags the appointment with the given index to the passed time slot element.
DragAppointmentToTimeSlot(Int32, Int32) | Drags the appointment with given index to the time slot with the given index. Refreshes the content internally.

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


DragAppointmentToTimeSlot Method (Int32, FrameworkElement)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DragAppointmentToTimeSlot Method (Int32, FrameworkElement)
AppointmentsControl Class See Also Send Feedback
Drags the appointment with the given index to the passed time slot element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAppointmentToTimeSlot(
    int appIndex,
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Sub DragAppointmentToTimeSlot ( _
    appIndex As Integer, _
    timeSlot As FrameworkElement _
)
Visual C++
public:
void DragAppointmentToTimeSlot(
    int appIndex,
    FrameworkElement^ timeSlot
)

Parameters

appIndex
Type: System..::.Int32
The index of the appointment to drag.
timeSlot
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The time slot element to drag into.

See Also

AppointmentsControl Class
DragAppointmentToTimeSlot Overload
Telerik.WebAii.Controls.Xaml Namespace


DragAppointmentToTimeSlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DragAppointmentToTimeSlot Method (Int32, Int32)
AppointmentsControl Class See Also Send Feedback
Drags the appointment with given index to the time slot with the given index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAppointmentToTimeSlot(
    int appIndex,
    int slotIndex
)
Visual Basic (Declaration)
Public Sub DragAppointmentToTimeSlot ( _
    appIndex As Integer, _
    slotIndex As Integer _
)
Visual C++
public:
void DragAppointmentToTimeSlot(
    int appIndex,
    int slotIndex
)

Parameters

appIndex
Type: System..::.Int32
The appointment index to drag.
slotIndex
Type: System..::.Int32
The time slot index to drag into.

See Also

AppointmentsControl Class
DragAppointmentToTimeSlot Overload
Telerik.WebAii.Controls.Xaml Namespace


DragAppointmentToTimeSlotDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.DragAppointmentToTimeSlotDay Method
AppointmentsControl Class See Also Send Feedback
Drags the appointment with given index to the time slot with the given index and occurence. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragAppointmentToTimeSlotDay(
    int appIndex,
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Sub DragAppointmentToTimeSlotDay ( _
    appIndex As Integer, _
    slotDay As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void DragAppointmentToTimeSlotDay(
    int appIndex,
    int slotDay,
    int occurrence
)

Parameters

appIndex
Type: System..::.Int32
The appointment index to drag.
slotDay
Type: System..::.Int32
The day value of the time slot to drag into.
occurrence
Type: System..::.Int32
The day occurrence index.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


GetDayTimeSlotItem Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.GetDayTimeSlotItem Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
GetDayTimeSlotItem(Int32) | Get the first occurrence of the time slot with the given day value.
GetDayTimeSlotItem(Int32, Int32) | Get the time slot item control for the given day and day occurrence.

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


GetDayTimeSlotItem Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.GetDayTimeSlotItem Method (Int32)
AppointmentsControl Class See Also Send Feedback
Get the first occurrence of the time slot with the given day value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSlotItem GetDayTimeSlotItem(
    int day
)
Visual Basic (Declaration)
Public Function GetDayTimeSlotItem ( _
    day As Integer _
) As TimeSlotItem
Visual C++
public:
TimeSlotItem^ GetDayTimeSlotItem(
    int day
)

Parameters

day
Type: System..::.Int32
The day value of the time slot item.

Return Value

The first occurrence of the time slot with the given day value.

See Also

AppointmentsControl Class
GetDayTimeSlotItem Overload
Telerik.WebAii.Controls.Xaml Namespace


GetDayTimeSlotItem Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.GetDayTimeSlotItem Method (Int32, Int32)
AppointmentsControl Class See Also Send Feedback
Get the time slot item control for the given day and day occurrence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSlotItem GetDayTimeSlotItem(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Function GetDayTimeSlotItem ( _
    day As Integer, _
    occurrence As Integer _
) As TimeSlotItem
Visual C++
public:
TimeSlotItem^ GetDayTimeSlotItem(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The day value to search for as displayed in the current.
occurrence
Type: System..::.Int32
The day value occurrence in the current view, e.g. '30' may appear twice because of previous month so use '1' as occurence index to get the one from the current view.

Return Value

The time slot item control for the given day and day occurrence.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown if the time slot with the given day value cannot be found.
System..::.ArgumentOutOfRangeException | Thrown if the occurrence index is out of the range of the time slot count with the given day value.

See Also

AppointmentsControl Class
GetDayTimeSlotItem Overload
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.GetProperty Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.GetRectangle Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.Highlight Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.InitializeMappings Method
AppointmentsControl Class See Also Send Feedback
Initializes the mapping of the RadScheduler AppointmentsControl control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.InvokeMethod Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.NextSibling Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


OpenDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.OpenDay Method
AppointmentsControl Class See Also Send Feedback
Simulates user clicking on the specified day to open it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void OpenDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The day, e.g. '25' value displayed in the view.
occurrence
Type: System..::.Int32
The occurrence index of that day, i.e. the end or start day values can be displayed more then once in the current view.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.Parent Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.PreviousSibling Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


ResizeAppointmentFromEnd Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.ResizeAppointmentFromEnd Method
AppointmentsControl Class See Also Send Feedback
Resizes the appointment with the given index with the specified slots/steps. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeAppointmentFromEnd(
    int appIndex,
    int slots
)
Visual Basic (Declaration)
Public Sub ResizeAppointmentFromEnd ( _
    appIndex As Integer, _
    slots As Integer _
)
Visual C++
public:
void ResizeAppointmentFromEnd(
    int appIndex,
    int slots
)

Parameters

appIndex
Type: System..::.Int32
The index of the appointment to resize.
slots
Type: System..::.Int32
The slots to resize with. Use negative value to resize to left and positive - to right.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeAppointmentFromStart Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.ResizeAppointmentFromStart Method
AppointmentsControl Class See Also Send Feedback
Resizes the appointment with the given index with the specified slots/steps. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeAppointmentFromStart(
    int appIndex,
    int slots
)
Visual Basic (Declaration)
Public Sub ResizeAppointmentFromStart ( _
    appIndex As Integer, _
    slots As Integer _
)
Visual C++
public:
void ResizeAppointmentFromStart(
    int appIndex,
    int slots
)

Parameters

appIndex
Type: System..::.Int32
The index of the appointment to resize.
slots
Type: System..::.Int32
The slots to resize with. Use negative value to resize to left and positive - to right.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.ScrollToVisible Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.SelectDay Method
AppointmentsControl Class See Also Send Feedback
Simulates user selecting the specified day.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub SelectDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void SelectDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The day, e.g. '25' value displayed in the view.
occurrence
Type: System..::.Int32
The occurrence index of that day, i.e. the end or start day values can be displayed more then once in the current view.

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl Properties
AppointmentsControl Class See Also Send Feedback

The AppointmentsControl type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Appointments | Get the list of appointments.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeSlots | Get the list of TimeSlots for the appointments control.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the Scheduler Appointments control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


Appointments Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.Appointments Property
AppointmentsControl Class See Also Send Feedback
Get the list of appointments.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<AppointmentItem> Appointments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appointments As IList(Of AppointmentItem)
Visual C++
public:
property IList<AppointmentItem^>^ Appointments {
    IList<AppointmentItem^>^ get ();
}

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlots Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.TimeSlots Property
AppointmentsControl Class See Also Send Feedback
Get the list of TimeSlots for the appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<TimeSlotItem> TimeSlots { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlots As IList(Of TimeSlotItem)
Visual C++
public:
property IList<TimeSlotItem^>^ TimeSlots {
    IList<TimeSlotItem^>^ get ();
}

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AppointmentsControl..::.XamlTag Property
AppointmentsControl Class See Also Send Feedback
Get the xaml tag of the Scheduler Appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AppointmentsControl Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight AutoHideArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class AutoHideArea : RadTabControl
Visual Basic (Declaration)
Public Class AutoHideArea _
    Inherits RadTabControl
Visual C++
public ref class AutoHideArea : public RadTabControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.AutoHideArea

See Also

AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


AutoHideArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea Members
AutoHideArea Class Constructors Methods Properties See Also Send Feedback

The AutoHideArea type exposes the following members.

Constructors

Name | Description
AutoHideArea | Initializes a new instance of the AutoHideArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderClose | Simulates user clicking on the 'close' button in the header of the popup.
HeaderPin | Simulates user clicking on the 'pin' button in the header of the popup.
Highlight | Overloaded.
HoverOverItem | Hover over an item in the area to show it.
InitializeMappings | Initializes the mapping of the RadDocking AutoHideArea control. (Overrides RadTabControl..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button. (Inherited from RadTabControl.)
ScrollRight | Simulates user clicking on the right scrolling repeat button. (Inherited from RadTabControl.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items. (Inherited from RadTabControl.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem. (Inherited from RadTabControl.)
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging. (Inherited from RadTabControl.)
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. (Inherited from RadTabControl.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl. (Inherited from RadTabControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButtonElement | Get the toggle button showing the remaining tab items on click. (Inherited from RadTabControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCommandsButton | Get the popup pane header 'Commands' toggle button.
HeaderTitle | Get the popup pane header title.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the auto hide area popup is open.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left. (Inherited from RadTabControl.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
Panes | Get the list of panes for this group.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PopupContent | Get the content presenter from the popup if open, returns 'null' otherwise.
PopupHeader | Get the pane header element from the popup if open, returns 'null' otherwise.
PopupResizer | Get the GridResizer from the popup if open, returns 'null' otherwise.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. (Inherited from RadTabControl.)
RightScrollButton | Get the repeat button which on click scrolls the tab items on right. (Inherited from RadTabControl.)
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. (Inherited from RadTabControl.)
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements. (Inherited from RadTabControl.)
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl. (Inherited from RadTabControl.)
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the auto hide area control. (Overrides RadTabControl..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea Constructor
AutoHideArea Class See Also Send Feedback
Initializes a new instance of the AutoHideArea class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AutoHideArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AutoHideArea()

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea Methods
AutoHideArea Class See Also Send Feedback

The AutoHideArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderClose | Simulates user clicking on the 'close' button in the header of the popup.
HeaderPin | Simulates user clicking on the 'pin' button in the header of the popup.
Highlight | Overloaded.
HoverOverItem | Hover over an item in the area to show it.
InitializeMappings | Initializes the mapping of the RadDocking AutoHideArea control. (Overrides RadTabControl..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button. (Inherited from RadTabControl.)
ScrollRight | Simulates user clicking on the right scrolling repeat button. (Inherited from RadTabControl.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items. (Inherited from RadTabControl.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.AnySibling Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.AssignReference Method
AutoHideArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.AutoHideArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.GetProperty Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.GetRectangle Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


HeaderClose Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.HeaderClose Method
AutoHideArea Class See Also Send Feedback
Simulates user clicking on the 'close' button in the header of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HeaderClose()
Visual Basic (Declaration)
Public Sub HeaderClose
Visual C++
public:
void HeaderClose()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the popup is not open.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderPin Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.HeaderPin Method
AutoHideArea Class See Also Send Feedback
Simulates user clicking on the 'pin' button in the header of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HeaderPin()
Visual Basic (Declaration)
Public Sub HeaderPin
Visual C++
public:
void HeaderPin()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the popup is not open.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.Highlight Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


HoverOverItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.HoverOverItem Method
AutoHideArea Class See Also Send Feedback
Hover over an item in the area to show it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HoverOverItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub HoverOverItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void HoverOverItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to hover over.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the item index is out of the pane count range.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.InitializeMappings Method
AutoHideArea Class See Also Send Feedback
Initializes the mapping of the RadDocking AutoHideArea control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.InvokeMethod Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.NextSibling Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.Parent Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.PreviousSibling Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.ScrollToVisible Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members
Telerik.WebAii.Controls.Xaml Namespace


WaitPopupAnimation Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.WaitPopupAnimation Method
AutoHideArea Class See Also Send Feedback
Useful upon any open/close action of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitPopupAnimation(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupAnimation ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupAnimation(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea Properties
AutoHideArea Class See Also Send Feedback

The AutoHideArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem. (Inherited from RadTabControl.)
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging. (Inherited from RadTabControl.)
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. (Inherited from RadTabControl.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl. (Inherited from RadTabControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButtonElement | Get the toggle button showing the remaining tab items on click. (Inherited from RadTabControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCommandsButton | Get the popup pane header 'Commands' toggle button.
HeaderTitle | Get the popup pane header title.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the auto hide area popup is open.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left. (Inherited from RadTabControl.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
Panes | Get the list of panes for this group.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PopupContent | Get the content presenter from the popup if open, returns 'null' otherwise.
PopupHeader | Get the pane header element from the popup if open, returns 'null' otherwise.
PopupResizer | Get the GridResizer from the popup if open, returns 'null' otherwise.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. (Inherited from RadTabControl.)
RightScrollButton | Get the repeat button which on click scrolls the tab items on right. (Inherited from RadTabControl.)
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. (Inherited from RadTabControl.)
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements. (Inherited from RadTabControl.)
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl. (Inherited from RadTabControl.)
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the auto hide area control. (Overrides RadTabControl..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderCommandsButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.HeaderCommandsButton Property
AutoHideArea Class See Also Send Feedback
Get the popup pane header 'Commands' toggle button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToggleButton HeaderCommandsButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderCommandsButton As RadToggleButton
Visual C++
public:
property RadToggleButton^ HeaderCommandsButton {
    RadToggleButton^ get ();
}

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderTitle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.HeaderTitle Property
AutoHideArea Class See Also Send Feedback
Get the popup pane header title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderTitle As String
Visual C++
public:
property String^ HeaderTitle {
    String^ get ();
}

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.IsPopupOpen Property
AutoHideArea Class See Also Send Feedback
Get whether the auto hide area popup is open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


Panes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.Panes Property
AutoHideArea Class See Also Send Feedback
Get the list of panes for this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPane> Panes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panes As IList(Of RadPane)
Visual C++
public:
property IList<RadPane^>^ Panes {
    IList<RadPane^>^ get ();
}

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


PopupContent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.PopupContent Property
AutoHideArea Class See Also Send Feedback
Get the content presenter from the popup if open, returns 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter PopupContent { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupContent As ContentPresenter
Visual C++
public:
property ContentPresenter^ PopupContent {
    ContentPresenter^ get ();
}

Return Value

The content presenter element from the popup.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


PopupHeader Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.PopupHeader Property
AutoHideArea Class See Also Send Feedback
Get the pane header element from the popup if open, returns 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PaneHeader PopupHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupHeader As PaneHeader
Visual C++
public:
property PaneHeader^ PopupHeader {
    PaneHeader^ get ();
}

Return Value

The pane header element from the popup.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


PopupResizer Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.PopupResizer Property
AutoHideArea Class See Also Send Feedback
Get the GridResizer from the popup if open, returns 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGridResizer PopupResizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupResizer As RadGridResizer
Visual C++
public:
property RadGridResizer^ PopupResizer {
    RadGridResizer^ get ();
}

Return Value

The GridResizer element from the popup.

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AutoHideArea..::.XamlTag Property
AutoHideArea Class See Also Send Feedback
Get the xaml tag of the auto hide area control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AutoHideArea Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton Class
Members See Also Send Feedback
Represents the RadCalendarButton custom control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class CalendarButton : ContentControl
Visual Basic (Declaration)
Public Class CalendarButton _
    Inherits ContentControl
Visual C++
public ref class CalendarButton : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.CalendarButton

See Also

CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


CalendarButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton Members
CalendarButton Class Constructors Methods Properties See Also Send Feedback

The CalendarButton type exposes the following members.

Constructors

Name | Description
CalendarButton | Initializes a new instance of the CalendarButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar Button control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasTodayBackground | Get whether the button is styled with 'today' background.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFromCurrentView | Gets whether the date represented by this button is from the current view. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the button is selected. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Gets the text of the button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TextOccurrence | Gets the occurence of this button text in the current view. Returns '-1' if that button does not appear in the current view.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of Calendar button. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton Constructor
CalendarButton Class See Also Send Feedback
Initializes a new instance of the CalendarButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarButton()

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton Methods
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar Button control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.AnySibling Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.AssignReference Method
CalendarButton Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.CalendarButton.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.GetProperty Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.GetRectangle Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.Highlight Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.InitializeMappings Method
CalendarButton Class See Also Send Feedback
Initializes the mapping of the RadCalendar Button control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.InvokeMethod Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.NextSibling Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.Parent Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.PreviousSibling Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.ScrollToVisible Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
Telerik.WebAii.Controls.Xaml Namespace


CalendarButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton Properties
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasTodayBackground | Get whether the button is styled with 'today' background.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFromCurrentView | Gets whether the date represented by this button is from the current view. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the button is selected. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Gets the text of the button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TextOccurrence | Gets the occurence of this button text in the current view. Returns '-1' if that button does not appear in the current view.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of Calendar button. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


HasTodayBackground Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.HasTodayBackground Property
CalendarButton Class See Also Send Feedback
Get whether the button is styled with 'today' background.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasTodayBackground { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasTodayBackground As Boolean
Visual C++
public:
property bool HasTodayBackground {
    bool get ();
}

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsFromCurrentView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.IsFromCurrentView Property
CalendarButton Class See Also Send Feedback
Gets whether the date represented by this button is from the current view. This is automation property, i.e. gets the value from the CalendarButton control itself.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFromCurrentView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFromCurrentView As Boolean
Visual C++
public:
property bool IsFromCurrentView {
    bool get ();
}

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.IsSelected Property
CalendarButton Class See Also Send Feedback
Gets whether the button is selected. This is automation property, i.e. gets the value from the CalendarButton control itself.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
}

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.Text Property
CalendarButton Class See Also Send Feedback
Gets the text of the button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextOccurrence Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.TextOccurrence Property
CalendarButton Class See Also Send Feedback
Gets the occurence of this button text in the current view. Returns '-1' if that button does not appear in the current view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int TextOccurrence { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextOccurrence As Integer
Visual C++
public:
property int TextOccurrence {
    int get ();
}

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarButton..::.XamlTag Property
CalendarButton Class See Also Send Feedback
The xaml tag of Calendar button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

CalendarButton Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarDisplayMode Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarDisplayMode Enumeration
See Also Send Feedback
Represents the Calendar display mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
[SerializableAttribute]
public enum CalendarDisplayMode
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration CalendarDisplayMode
Visual C++
[SerializableAttribute]
public enum class CalendarDisplayMode

Members

Member name | Description
Month | Represents the calendar 'Month' display mode.
Year | Represents the calendar 'Year' display mode.
Decade | Represents the calendar 'Decade' display mode.
Century | Represents the calendar 'Century' display mode.

See Also

Telerik.WebAii.Controls.Xaml Namespace


CalendarElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames Class
Members See Also Send Feedback
Holds the list of the important Calendar element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class CalendarElementNames
Visual Basic (Declaration)
Public NotInheritable Class CalendarElementNames
Visual C++
public ref class CalendarElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.CalendarElementNames

See Also

CalendarElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


CalendarElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames Members
CalendarElementNames Class Fields See Also Send Feedback

The CalendarElementNames type exposes the following members.

Fields

Name | Description
CenturyViewsName | The name of the uniform grid holding the century calendar views.
DecadeViewsName | The name of the uniform grid holding the decade calendar views.
HeaderButtonName | The name of the header button used to change the Calendar view.
HeaderGridName | The name of the header Grid holding the navigation buttons and header text.
MonthViewsName | The name of the uniform grid holding the month calendar views.
MoveLeftButtonName | The name of the navigation to left button from the header.
MoveRightButtonName | The name of the navigation to right button from the header.
TransitionPanelName | The name of the panel holding all the calendar views.
YearViewsName | The name of the uniform grid holding the year calendar views.

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames Fields
CalendarElementNames Class See Also Send Feedback

The CalendarElementNames type exposes the following members.

Fields

Name | Description
CenturyViewsName | The name of the uniform grid holding the century calendar views.
DecadeViewsName | The name of the uniform grid holding the decade calendar views.
HeaderButtonName | The name of the header button used to change the Calendar view.
HeaderGridName | The name of the header Grid holding the navigation buttons and header text.
MonthViewsName | The name of the uniform grid holding the month calendar views.
MoveLeftButtonName | The name of the navigation to left button from the header.
MoveRightButtonName | The name of the navigation to right button from the header.
TransitionPanelName | The name of the panel holding all the calendar views.
YearViewsName | The name of the uniform grid holding the year calendar views.

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CenturyViewsName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.CenturyViewsName Field
CalendarElementNames Class See Also Send Feedback
The name of the uniform grid holding the century calendar views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CenturyViewsName
Visual Basic (Declaration)
Public Const CenturyViewsName As String
Visual C++
public:
literal String^ CenturyViewsName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DecadeViewsName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.DecadeViewsName Field
CalendarElementNames Class See Also Send Feedback
The name of the uniform grid holding the decade calendar views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DecadeViewsName
Visual Basic (Declaration)
Public Const DecadeViewsName As String
Visual C++
public:
literal String^ DecadeViewsName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.HeaderButtonName Field
CalendarElementNames Class See Also Send Feedback
The name of the header button used to change the Calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HeaderButtonName
Visual Basic (Declaration)
Public Const HeaderButtonName As String
Visual C++
public:
literal String^ HeaderButtonName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.HeaderGridName Field
CalendarElementNames Class See Also Send Feedback
The name of the header Grid holding the navigation buttons and header text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HeaderGridName
Visual Basic (Declaration)
Public Const HeaderGridName As String
Visual C++
public:
literal String^ HeaderGridName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MonthViewsName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.MonthViewsName Field
CalendarElementNames Class See Also Send Feedback
The name of the uniform grid holding the month calendar views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MonthViewsName
Visual Basic (Declaration)
Public Const MonthViewsName As String
Visual C++
public:
literal String^ MonthViewsName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MoveLeftButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.MoveLeftButtonName Field
CalendarElementNames Class See Also Send Feedback
The name of the navigation to left button from the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MoveLeftButtonName
Visual Basic (Declaration)
Public Const MoveLeftButtonName As String
Visual C++
public:
literal String^ MoveLeftButtonName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MoveRightButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.MoveRightButtonName Field
CalendarElementNames Class See Also Send Feedback
The name of the navigation to right button from the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MoveRightButtonName
Visual Basic (Declaration)
Public Const MoveRightButtonName As String
Visual C++
public:
literal String^ MoveRightButtonName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TransitionPanelName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.TransitionPanelName Field
CalendarElementNames Class See Also Send Feedback
The name of the panel holding all the calendar views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TransitionPanelName
Visual Basic (Declaration)
Public Const TransitionPanelName As String
Visual C++
public:
literal String^ TransitionPanelName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


YearViewsName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarElementNames..::.YearViewsName Field
CalendarElementNames Class See Also Send Feedback
The name of the uniform grid holding the year calendar views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string YearViewsName
Visual Basic (Declaration)
Public Const YearViewsName As String
Visual C++
public:
literal String^ YearViewsName

See Also

CalendarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarPanel Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel Class
Members See Also Send Feedback
The Calendar panel holding the CalendarButtons.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class CalendarPanel : RadUniformGrid
Visual Basic (Declaration)
Public Class CalendarPanel _
    Inherits RadUniformGrid
Visual C++
public ref class CalendarPanel : public RadUniformGrid

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Panel
Telerik.WebAii.Controls.Xaml..::.RadUniformGrid
Telerik.WebAii.Controls.Xaml..::.CalendarPanel

See Also

CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


CalendarPanel Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel Members
CalendarPanel Class Constructors Methods Properties See Also Send Feedback

The CalendarPanel type exposes the following members.

Constructors

Name | Description
CalendarPanel | Initializes a new instance of the CalendarPanel class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
ButtonClick | Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetButtons | Get the list of the calendar buttons matching the given text. Useful in month view where a day text may duplicates either in the previous/next month or with the week number.
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar Panel control. (Overrides RadUniformGrid..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDayRange | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the number of columns that are in the grid. (Inherited from RadUniformGrid.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FirstColumn | Gets the number of leading blank cells in the first row of the grid. (Inherited from RadUniformGrid.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Rows | Gets the number of rows that are in the grid. (Inherited from RadUniformGrid.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of CalendarPanel control. (Overrides RadUniformGrid..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarPanel Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel Constructor
CalendarPanel Class See Also Send Feedback
Initializes a new instance of the CalendarPanel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarPanel()

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarPanel Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel Methods
CalendarPanel Class See Also Send Feedback

The CalendarPanel type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
ButtonClick | Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetButtons | Get the list of the calendar buttons matching the given text. Useful in month view where a day text may duplicates either in the previous/next month or with the week number.
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar Panel control. (Overrides RadUniformGrid..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDayRange | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.AnySibling Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


ButtonClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.ButtonClick Method
CalendarPanel Class See Also Send Feedback
Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ButtonClick(
    string buttonText,
    int occurrence
)
Visual Basic (Declaration)
Public Sub ButtonClick ( _
    buttonText As String, _
    occurrence As Integer _
)
Visual C++
public:
void ButtonClick(
    String^ buttonText,
    int occurrence
)

Parameters

buttonText
Type: System..::.String
The button text to search for.
occurrence
Type: System..::.Int32
The occurence index of the button with this text.

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


ContainsButton Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.ContainsButton Method
CalendarPanel Class See Also Send Feedback
Get whether the panel contains button with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ContainsButton(
    string buttonText
)
Visual Basic (Declaration)
Public Function ContainsButton ( _
    buttonText As String _
) As Boolean
Visual C++
public:
bool ContainsButton(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text to search for.

Return Value

Whether the panel contains button with the given text.

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GetButton Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.GetButton Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
GetButton(String) | Get the first occurence of the Calendar button matching the given text.
GetButton(String, Int32) | Get the Calendar button matching the given text.

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


GetButton Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.GetButton Method (String)
CalendarPanel Class See Also Send Feedback
Get the first occurence of the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarButton GetButton(
    string dateText
)
Visual Basic (Declaration)
Public Function GetButton ( _
    dateText As String _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ dateText
)

Parameters

dateText
Type: System..::.String
The text to search for.

Return Value

The Calendar button matching the given text.

See Also

CalendarPanel Class
GetButton Overload
Telerik.WebAii.Controls.Xaml Namespace


GetButton Method (String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.GetButton Method (String, Int32)
CalendarPanel Class See Also Send Feedback
Get the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarButton GetButton(
    string buttonText,
    int occurrenceIndex
)
Visual Basic (Declaration)
Public Function GetButton ( _
    buttonText As String, _
    occurrenceIndex As Integer _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ buttonText,
    int occurrenceIndex
)

Parameters

buttonText
Type: System..::.String
The text to search for.
occurrenceIndex
Type: System..::.Int32
The occurence index of the button when there are more than one matching the given text.

Return Value

The Calendar button matching the given text.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the button with given text is not available.
System..::.ArgumentOutOfRangeException | Thrown when the occurrence index is out of range of the available button count with the given text.

See Also

CalendarPanel Class
GetButton Overload
Telerik.WebAii.Controls.Xaml Namespace


GetButtons Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.GetButtons Method
CalendarPanel Class See Also Send Feedback
Get the list of the calendar buttons matching the given text. Useful in month view where a day text may duplicates either in the previous/next month or with the week number.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<CalendarButton> GetButtons(
    string buttonText
)
Visual Basic (Declaration)
Public Function GetButtons ( _
    buttonText As String _
) As IList(Of CalendarButton)
Visual C++
public:
IList<CalendarButton^>^ GetButtons(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The button text to search for.

Return Value

The list of the calendar buttons matching the given text.

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.GetProperty Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.GetRectangle Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.Highlight Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.InitializeMappings Method
CalendarPanel Class See Also Send Feedback
Initializes the mapping of the RadCalendar Panel control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.InvokeMethod Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.NextSibling Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.Parent Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.PreviousSibling Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.ScrollToVisible Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.SelectDayRange Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
SelectDayRange(String, String) | Simulates user dragging to select the dates from the given range.
SelectDayRange(String, Int32, String, Int32) | Simulates user dragging to select the dates from the given range.

See Also

CalendarPanel Class
CalendarPanel Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method (String, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.SelectDayRange Method (String, String)
CalendarPanel Class See Also Send Feedback
Simulates user dragging to select the dates from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDayRange(
    string firstDay,
    string lastDay
)
Visual Basic (Declaration)
Public Sub SelectDayRange ( _
    firstDay As String, _
    lastDay As String _
)
Visual C++
public:
void SelectDayRange(
    String^ firstDay,
    String^ lastDay
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
lastDay
Type: System..::.String
The day to end select from, uses the first occurence.

See Also

CalendarPanel Class
SelectDayRange Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method (String, Int32, String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.SelectDayRange Method (String, Int32, String, Int32)
CalendarPanel Class See Also Send Feedback
Simulates user dragging to select the dates from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDayRange(
    string firstDay,
    int firstDayOccurrence,
    string lastDay,
    int lastDayOccurrence
)
Visual Basic (Declaration)
Public Sub SelectDayRange ( _
    firstDay As String, _
    firstDayOccurrence As Integer, _
    lastDay As String, _
    lastDayOccurrence As Integer _
)
Visual C++
public:
void SelectDayRange(
    String^ firstDay,
    int firstDayOccurrence,
    String^ lastDay,
    int lastDayOccurrence
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
firstDayOccurrence
Type: System..::.Int32
The occurence (index) of the 'firstDate' text.
lastDay
Type: System..::.String
The day to end select from, uses the first occurence.
lastDayOccurrence
Type: System..::.Int32
The occurence (index) of the 'lastDate' text.

See Also

CalendarPanel Class
SelectDayRange Overload
Telerik.WebAii.Controls.Xaml Namespace


CalendarPanel Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel Properties
CalendarPanel Class See Also Send Feedback

The CalendarPanel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the number of columns that are in the grid. (Inherited from RadUniformGrid.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FirstColumn | Gets the number of leading blank cells in the first row of the grid. (Inherited from RadUniformGrid.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Rows | Gets the number of rows that are in the grid. (Inherited from RadUniformGrid.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of CalendarPanel control. (Overrides RadUniformGrid..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarPanel..::.XamlTag Property
CalendarPanel Class See Also Send Feedback
The xaml tag of CalendarPanel control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

CalendarPanel Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView Class
Members See Also Send Feedback
Represents the RadCalendar for Silverlight CalendarView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class CalendarView : ItemsControl
Visual Basic (Declaration)
Public Class CalendarView _
    Inherits ItemsControl
Visual C++
public ref class CalendarView : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.CalendarView

See Also

CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


CalendarView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView Members
CalendarView Class Constructors Methods Properties See Also Send Feedback

The CalendarView type exposes the following members.

Constructors

Name | Description
CalendarView | Initializes a new instance of the CalendarView class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
ButtonClick | Overloaded.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar View control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDayRange | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DisplayMode | Get the current Calendar display mode -- Month, Year, Decade or Century.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the calendar view index.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Gets the title of the calendar view.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the CalendarView xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView Constructor
CalendarView Class See Also Send Feedback
Initializes a new instance of the CalendarView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarView()

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView Methods
CalendarView Class See Also Send Feedback

The CalendarView type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
ButtonClick | Overloaded.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar View control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDayRange | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.AnySibling Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.AssignReference Method
CalendarView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.CalendarView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


ButtonClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.ButtonClick Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
ButtonClick(String) | Simulates user clicking on the calendar button in the view. Uses the firstly found button matching the given text.
ButtonClick(String, Int32) | Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


ButtonClick Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.ButtonClick Method (String)
CalendarView Class See Also Send Feedback
Simulates user clicking on the calendar button in the view. Uses the firstly found button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ButtonClick(
    string buttonText
)
Visual Basic (Declaration)
Public Sub ButtonClick ( _
    buttonText As String _
)
Visual C++
public:
void ButtonClick(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The button text to search for.

See Also

CalendarView Class
ButtonClick Overload
Telerik.WebAii.Controls.Xaml Namespace


ButtonClick Method (String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.ButtonClick Method (String, Int32)
CalendarView Class See Also Send Feedback
Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ButtonClick(
    string buttonText,
    int occurrence
)
Visual Basic (Declaration)
Public Sub ButtonClick ( _
    buttonText As String, _
    occurrence As Integer _
)
Visual C++
public:
void ButtonClick(
    String^ buttonText,
    int occurrence
)

Parameters

buttonText
Type: System..::.String
The button text to search for.
occurrence
Type: System..::.Int32
The occurence index of the button with this text.

See Also

CalendarView Class
ButtonClick Overload
Telerik.WebAii.Controls.Xaml Namespace


ContainsButton Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.ContainsButton Method
CalendarView Class See Also Send Feedback
Get whether the panel contains button with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ContainsButton(
    string buttonText
)
Visual Basic (Declaration)
Public Function ContainsButton ( _
    buttonText As String _
) As Boolean
Visual C++
public:
bool ContainsButton(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text to search for.

Return Value

Whether the panel contains button with the given text.

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


GetButton Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.GetButton Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
GetButton(String) | Get the Calendar button matching the given text.
GetButton(String, Int32) | Get the Calendar button matching the given text.

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


GetButton Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.GetButton Method (String)
CalendarView Class See Also Send Feedback
Get the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarButton GetButton(
    string dateText
)
Visual Basic (Declaration)
Public Function GetButton ( _
    dateText As String _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ dateText
)

Parameters

dateText
Type: System..::.String
The text to search for.

Return Value

The Calendar button matching the given text.

See Also

CalendarView Class
GetButton Overload
Telerik.WebAii.Controls.Xaml Namespace


GetButton Method (String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.GetButton Method (String, Int32)
CalendarView Class See Also Send Feedback
Get the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarButton GetButton(
    string dateText,
    int occurrence
)
Visual Basic (Declaration)
Public Function GetButton ( _
    dateText As String, _
    occurrence As Integer _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ dateText,
    int occurrence
)

Parameters

dateText
Type: System..::.String
The text to search for.
occurrence
Type: System..::.Int32
The occurence of the button when there are more than one matching the given text.

Return Value

The Calendar button matching the given text.

See Also

CalendarView Class
GetButton Overload
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.GetProperty Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.GetRectangle Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.Highlight Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.InitializeMappings Method
CalendarView Class See Also Send Feedback
Initializes the mapping of the RadCalendar View control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.InvokeMethod Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.NextSibling Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.Parent Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.PreviousSibling Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.ScrollToVisible Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.SelectDayRange Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
SelectDayRange(String, String) | Simulates user dragging to select the days from the given range.
SelectDayRange(String, Int32, String, Int32) | Simulates user dragging to select the days from the given range.

See Also

CalendarView Class
CalendarView Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method (String, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.SelectDayRange Method (String, String)
CalendarView Class See Also Send Feedback
Simulates user dragging to select the days from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDayRange(
    string firstDay,
    string lastDay
)
Visual Basic (Declaration)
Public Sub SelectDayRange ( _
    firstDay As String, _
    lastDay As String _
)
Visual C++
public:
void SelectDayRange(
    String^ firstDay,
    String^ lastDay
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
lastDay
Type: System..::.String
The date to end select from, uses the first occurence.

See Also

CalendarView Class
SelectDayRange Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method (String, Int32, String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.SelectDayRange Method (String, Int32, String, Int32)
CalendarView Class See Also Send Feedback
Simulates user dragging to select the days from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDayRange(
    string firstDay,
    int firstDayOccurrence,
    string lastDay,
    int lastDayOccurrence
)
Visual Basic (Declaration)
Public Sub SelectDayRange ( _
    firstDay As String, _
    firstDayOccurrence As Integer, _
    lastDay As String, _
    lastDayOccurrence As Integer _
)
Visual C++
public:
void SelectDayRange(
    String^ firstDay,
    int firstDayOccurrence,
    String^ lastDay,
    int lastDayOccurrence
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
firstDayOccurrence
Type: System..::.Int32
The start day occurence in this view.
lastDay
Type: System..::.String
The date to end select from, uses the first occurence.
lastDayOccurrence
Type: System..::.Int32
The last day occurence in this view.

See Also

CalendarView Class
SelectDayRange Overload
Telerik.WebAii.Controls.Xaml Namespace


CalendarView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView Properties
CalendarView Class See Also Send Feedback

The CalendarView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DisplayMode | Get the current Calendar display mode -- Month, Year, Decade or Century.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the calendar view index.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Gets the title of the calendar view.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the CalendarView xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


DisplayMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.DisplayMode Property
CalendarView Class See Also Send Feedback
Get the current Calendar display mode -- Month, Year, Decade or Century.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarDisplayMode DisplayMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayMode As CalendarDisplayMode
Visual C++
public:
property CalendarDisplayMode DisplayMode {
    CalendarDisplayMode get ();
}

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.Index Property
CalendarView Class See Also Send Feedback
Get the calendar view index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.Title Property
CalendarView Class See Also Send Feedback
Gets the title of the calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
CalendarView..::.XamlTag Property
CalendarView Class See Also Send Feedback
Get the CalendarView xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

CalendarView Class
Telerik.WebAii.Controls.Xaml Namespace


ChartArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartArea : ContentControl
Visual Basic (Declaration)
Public Class ChartArea _
    Inherits ContentControl
Visual C++
public ref class ChartArea : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartArea

See Also

ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


ChartArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea Members
ChartArea Class Constructors Methods Properties See Also Send Feedback

The ChartArea type exposes the following members.

Constructors

Name | Description
ChartArea | Initializes a new instance of the ChartArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartArea. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalGridLines | Get the list of Chart horizontal grid lines.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SeriesPanel | Get the Chart series panel xaml control.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalGridLines | Get the list of Chart vertical grid lines.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartArea. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XAxis | Get the XAxis xaml control.
YAxis | Get the YAxis xaml control.

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


ChartArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea Constructor
ChartArea Class See Also Send Feedback
Initializes a new instance of the ChartArea class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartArea()

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


ChartArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea Methods
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartArea. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.AnySibling Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.AssignReference Method
ChartArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.GetProperty Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.GetRectangle Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.Highlight Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.InitializeMappings Method
ChartArea Class See Also Send Feedback
Initializes the mapping of ChartArea.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.InvokeMethod Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.NextSibling Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.Parent Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.PreviousSibling Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.ScrollToVisible Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members
Telerik.WebAii.Controls.Xaml Namespace


ChartArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea Properties
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalGridLines | Get the list of Chart horizontal grid lines.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SeriesPanel | Get the Chart series panel xaml control.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalGridLines | Get the list of Chart vertical grid lines.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartArea. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XAxis | Get the XAxis xaml control.
YAxis | Get the YAxis xaml control.

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalGridLines Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.HorizontalGridLines Property
ChartArea Class See Also Send Feedback
Get the list of Chart horizontal grid lines.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartHorizontalGridLines> HorizontalGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalGridLines As IList(Of ChartHorizontalGridLines)
Visual C++
public:
property IList<ChartHorizontalGridLines^>^ HorizontalGridLines {
    IList<ChartHorizontalGridLines^>^ get ();
}

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


SeriesPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.SeriesPanel Property
ChartArea Class See Also Send Feedback
Get the Chart series panel xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartPanel SeriesPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property SeriesPanel As ChartPanel
Visual C++
public:
property ChartPanel^ SeriesPanel {
    ChartPanel^ get ();
}

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalGridLines Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.VerticalGridLines Property
ChartArea Class See Also Send Feedback
Get the list of Chart vertical grid lines.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartVerticalGridLines> VerticalGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalGridLines As IList(Of ChartVerticalGridLines)
Visual C++
public:
property IList<ChartVerticalGridLines^>^ VerticalGridLines {
    IList<ChartVerticalGridLines^>^ get ();
}

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.XamlTag Property
ChartArea Class See Also Send Feedback
Get the xaml tag of ChartArea.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


XAxis Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.XAxis Property
ChartArea Class See Also Send Feedback
Get the XAxis xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartAxisX XAxis { get; }
Visual Basic (Declaration)
Public ReadOnly Property XAxis As ChartAxisX
Visual C++
public:
property ChartAxisX^ XAxis {
    ChartAxisX^ get ();
}

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


YAxis Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartArea..::.YAxis Property
ChartArea Class See Also Send Feedback
Get the YAxis xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartAxisY YAxis { get; }
Visual Basic (Declaration)
Public ReadOnly Property YAxis As ChartAxisY
Visual C++
public:
property ChartAxisY^ YAxis {
    ChartAxisY^ get ();
}

See Also

ChartArea Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisX Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChartAxisX control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartAxisX : ItemsControl
Visual Basic (Declaration)
Public Class ChartAxisX _
    Inherits ItemsControl
Visual C++
public ref class ChartAxisX : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.ChartAxisX

See Also

ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisX Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX Members
ChartAxisX Class Constructors Methods Properties See Also Send Feedback

The ChartAxisX type exposes the following members.

Constructors

Name | Description
ChartAxisX | Initializes a new instance of the ChartAxisX class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisX2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLineColor | Get the axis line color.
AxisTitleColor | Get the title text color.
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of Chart axis items.
Labels | Get the list of Chart axis labels.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinorTicks | Get the list of Chart minor ticks.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
SelectedAxisTitleColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
VerticalMinorTickCount | Get the minor tick points count value.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisX2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisX Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX Constructor
ChartAxisX Class See Also Send Feedback
Initializes a new instance of the ChartAxisX class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartAxisX()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartAxisX()

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisX Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX Methods
ChartAxisX Class See Also Send Feedback

The ChartAxisX type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisX2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.AnySibling Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.AssignReference Method
ChartAxisX Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartAxisX.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.GetProperty Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.GetRectangle Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.Highlight Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.InitializeMappings Method
ChartAxisX Class See Also Send Feedback
Initializes the mapping of AxisX2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.InvokeMethod Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.NextSibling Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.Parent Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.PreviousSibling Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.ScrollToVisible Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisX Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX Properties
ChartAxisX Class See Also Send Feedback

The ChartAxisX type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLineColor | Get the axis line color.
AxisTitleColor | Get the title text color.
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of Chart axis items.
Labels | Get the list of Chart axis labels.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinorTicks | Get the list of Chart minor ticks.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
SelectedAxisTitleColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
VerticalMinorTickCount | Get the minor tick points count value.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisX2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


AxisLineColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.AxisLineColor Property
ChartAxisX Class See Also Send Feedback
Get the axis line color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisLineColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisLineColor As Color
Visual C++
public:
property Color^ AxisLineColor {
    Color^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


AxisTitleColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.AxisTitleColor Property
ChartAxisX Class See Also Send Feedback
Get the title text color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisTitleColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisTitleColor As Color
Visual C++
public:
property Color^ AxisTitleColor {
    Color^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.Items Property
ChartAxisX Class See Also Send Feedback
Get the list of Chart axis items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartXAxisItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of ChartXAxisItem)
Visual C++
public:
property IList<ChartXAxisItem^>^ Items {
    IList<ChartXAxisItem^>^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


Labels Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.Labels Property
ChartAxisX Class See Also Send Feedback
Get the list of Chart axis labels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartXAxisLabel> Labels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Labels As IList(Of ChartXAxisLabel)
Visual C++
public:
property IList<ChartXAxisLabel^>^ Labels {
    IList<ChartXAxisLabel^>^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


MinorTicks Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.MinorTicks Property
ChartAxisX Class See Also Send Feedback
Get the list of Chart minor ticks.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartXAxisMinorTicks> MinorTicks { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinorTicks As IList(Of ChartXAxisMinorTicks)
Visual C++
public:
property IList<ChartXAxisMinorTicks^>^ MinorTicks {
    IList<ChartXAxisMinorTicks^>^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisLineColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.SelectedAxisLineColorValue Property
ChartAxisX Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisLineColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisLineColorValue As String
Visual C++
public:
property String^ SelectedAxisLineColorValue {
    String^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisTitleColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.SelectedAxisTitleColorValue Property
ChartAxisX Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisTitleColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisTitleColorValue As String
Visual C++
public:
property String^ SelectedAxisTitleColorValue {
    String^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


TitleText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.TitleText Property
ChartAxisX Class See Also Send Feedback
The header text of the Chart axis.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TitleText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleText As String
Visual C++
public:
property String^ TitleText {
    String^ get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalMinorTickCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.VerticalMinorTickCount Property
ChartAxisX Class See Also Send Feedback
Get the minor tick points count value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int VerticalMinorTickCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalMinorTickCount As Integer
Visual C++
public:
property int VerticalMinorTickCount {
    int get ();
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisX..::.XamlTag Property
ChartAxisX Class See Also Send Feedback
Get the xaml tag of AxisX2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartAxisX Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisY Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChartAxisY control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartAxisY : ItemsControl
Visual Basic (Declaration)
Public Class ChartAxisY _
    Inherits ItemsControl
Visual C++
public ref class ChartAxisY : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.ChartAxisY

See Also

ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisY Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY Members
ChartAxisY Class Constructors Methods Properties See Also Send Feedback

The ChartAxisY type exposes the following members.

Constructors

Name | Description
ChartAxisY | Initializes a new instance of the ChartAxisY class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisY2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLineColor | Get the axis line color.
AxisTitleColor | Get the title text color.
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of Chart axis items.
Labels | Get the list of Chart axis labels.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinorTickCount | Get the minor tick points count value.
MinorTicks | Get the list of Chart minor ticks.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
SelectedAxisTitleColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisY2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisY Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY Constructor
ChartAxisY Class See Also Send Feedback
Initializes a new instance of the ChartAxisY class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartAxisY()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartAxisY()

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisY Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY Methods
ChartAxisY Class See Also Send Feedback

The ChartAxisY type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisY2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.AnySibling Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.AssignReference Method
ChartAxisY Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartAxisY.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.GetProperty Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.GetRectangle Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.Highlight Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.InitializeMappings Method
ChartAxisY Class See Also Send Feedback
Initializes the mapping of AxisY2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.InvokeMethod Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.NextSibling Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.Parent Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.PreviousSibling Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.ScrollToVisible Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members
Telerik.WebAii.Controls.Xaml Namespace


ChartAxisY Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY Properties
ChartAxisY Class See Also Send Feedback

The ChartAxisY type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLineColor | Get the axis line color.
AxisTitleColor | Get the title text color.
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of Chart axis items.
Labels | Get the list of Chart axis labels.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinorTickCount | Get the minor tick points count value.
MinorTicks | Get the list of Chart minor ticks.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
SelectedAxisTitleColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisY2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


AxisLineColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.AxisLineColor Property
ChartAxisY Class See Also Send Feedback
Get the axis line color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisLineColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisLineColor As Color
Visual C++
public:
property Color^ AxisLineColor {
    Color^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


AxisTitleColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.AxisTitleColor Property
ChartAxisY Class See Also Send Feedback
Get the title text color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisTitleColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisTitleColor As Color
Visual C++
public:
property Color^ AxisTitleColor {
    Color^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.Items Property
ChartAxisY Class See Also Send Feedback
Get the list of Chart axis items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartYAxisItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of ChartYAxisItem)
Visual C++
public:
property IList<ChartYAxisItem^>^ Items {
    IList<ChartYAxisItem^>^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


Labels Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.Labels Property
ChartAxisY Class See Also Send Feedback
Get the list of Chart axis labels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartYAxisLabel> Labels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Labels As IList(Of ChartYAxisLabel)
Visual C++
public:
property IList<ChartYAxisLabel^>^ Labels {
    IList<ChartYAxisLabel^>^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


MinorTickCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.MinorTickCount Property
ChartAxisY Class See Also Send Feedback
Get the minor tick points count value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MinorTickCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinorTickCount As Integer
Visual C++
public:
property int MinorTickCount {
    int get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


MinorTicks Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.MinorTicks Property
ChartAxisY Class See Also Send Feedback
Get the list of Chart minor ticks.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartYAxisMinorTicks> MinorTicks { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinorTicks As IList(Of ChartYAxisMinorTicks)
Visual C++
public:
property IList<ChartYAxisMinorTicks^>^ MinorTicks {
    IList<ChartYAxisMinorTicks^>^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisLineColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.SelectedAxisLineColorValue Property
ChartAxisY Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisLineColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisLineColorValue As String
Visual C++
public:
property String^ SelectedAxisLineColorValue {
    String^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisTitleColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.SelectedAxisTitleColorValue Property
ChartAxisY Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisTitleColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisTitleColorValue As String
Visual C++
public:
property String^ SelectedAxisTitleColorValue {
    String^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


TitleText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.TitleText Property
ChartAxisY Class See Also Send Feedback
The header text of the Chart axis.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TitleText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleText As String
Visual C++
public:
property String^ TitleText {
    String^ get ();
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartAxisY..::.XamlTag Property
ChartAxisY Class See Also Send Feedback
Get the xaml tag of AxisY2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartAxisY Class
Telerik.WebAii.Controls.Xaml Namespace


ChartHorizontalGridLines Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartHorizontalGridLines control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartHorizontalGridLines : ContentControl
Visual Basic (Declaration)
Public Class ChartHorizontalGridLines _
    Inherits ContentControl
Visual C++
public ref class ChartHorizontalGridLines : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartHorizontalGridLines

See Also

ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


ChartHorizontalGridLines Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines Members
ChartHorizontalGridLines Class Constructors Methods Properties See Also Send Feedback

The ChartHorizontalGridLines type exposes the following members.

Constructors

Name | Description
ChartHorizontalGridLines | Initializes a new instance of the ChartHorizontalGridLines class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of HorizontalGridLine2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalGridlineColor | Get the gridlines color.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedHorizontalGridlineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of HorizontalGridLine2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


ChartHorizontalGridLines Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines Constructor
ChartHorizontalGridLines Class See Also Send Feedback
Initializes a new instance of the ChartHorizontalGridLines class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartHorizontalGridLines()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartHorizontalGridLines()

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


ChartHorizontalGridLines Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines Methods
ChartHorizontalGridLines Class See Also Send Feedback

The ChartHorizontalGridLines type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of HorizontalGridLine2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.AnySibling Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.AssignReference Method
ChartHorizontalGridLines Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartHorizontalGridLines.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.GetProperty Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.GetRectangle Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.Highlight Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.InitializeMappings Method
ChartHorizontalGridLines Class See Also Send Feedback
Initializes the mapping of HorizontalGridLine2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.InvokeMethod Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.NextSibling Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.Parent Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.PreviousSibling Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.ScrollToVisible Method
ChartHorizontalGridLines Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
ChartHorizontalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


ChartHorizontalGridLines Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines Properties
ChartHorizontalGridLines Class See Also Send Feedback

The ChartHorizontalGridLines type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalGridlineColor | Get the gridlines color.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedHorizontalGridlineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of HorizontalGridLine2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalGridlineColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.HorizontalGridlineColor Property
ChartHorizontalGridLines Class See Also Send Feedback
Get the gridlines color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color HorizontalGridlineColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalGridlineColor As Color
Visual C++
public:
property Color^ HorizontalGridlineColor {
    Color^ get ();
}

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedHorizontalGridlineColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.SelectedHorizontalGridlineColorValue Property
ChartHorizontalGridLines Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedHorizontalGridlineColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedHorizontalGridlineColorValue As String
Visual C++
public:
property String^ SelectedHorizontalGridlineColorValue {
    String^ get ();
}

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartHorizontalGridLines..::.XamlTag Property
ChartHorizontalGridLines Class See Also Send Feedback
Get the xaml tag of HorizontalGridLine2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartHorizontalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegend Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartLegend control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartLegend : ItemsControl
Visual Basic (Declaration)
Public Class ChartLegend _
    Inherits ItemsControl
Visual C++
public ref class ChartLegend : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.ChartLegend

See Also

ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


ChartLegend Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend Members
ChartLegend Class Constructors Methods Properties See Also Send Feedback

The ChartLegend type exposes the following members.

Constructors

Name | Description
ChartLegend | Initializes a new instance of the ChartLegend class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartLegend. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderText | The header text of the ChartLegend.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of ChartLegend items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartLegend. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegend Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend Constructor
ChartLegend Class See Also Send Feedback
Initializes a new instance of the ChartLegend class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartLegend()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartLegend()

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegend Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend Methods
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartLegend. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.AnySibling Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.AssignReference Method
ChartLegend Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartLegend.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.GetProperty Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.GetRectangle Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.Highlight Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.InitializeMappings Method
ChartLegend Class See Also Send Feedback
Initializes the mapping of ChartLegend.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.InvokeMethod Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.NextSibling Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.Parent Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.PreviousSibling Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.ScrollToVisible Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.WebAii.Controls.Xaml Namespace


ChartLegend Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend Properties
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderText | The header text of the ChartLegend.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of ChartLegend items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartLegend. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.HeaderText Property
ChartLegend Class See Also Send Feedback
The header text of the ChartLegend.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.Items Property
ChartLegend Class See Also Send Feedback
Get the list of ChartLegend items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartLegendItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of ChartLegendItem)
Visual C++
public:
property IList<ChartLegendItem^>^ Items {
    IList<ChartLegendItem^>^ get ();
}

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegend..::.XamlTag Property
ChartLegend Class See Also Send Feedback
Get the xaml tag of ChartLegend.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartLegend Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartLegendItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartLegendItem : ContentControl
Visual Basic (Declaration)
Public Class ChartLegendItem _
    Inherits ContentControl
Visual C++
public ref class ChartLegendItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartLegendItem

See Also

ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem Members
ChartLegendItem Class Constructors Methods Properties See Also Send Feedback

The ChartLegendItem type exposes the following members.

Constructors

Name | Description
ChartLegendItem | Initializes a new instance of the ChartLegendItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartLegendItem. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the legend item color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the legend item text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartLegendItem. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem Constructor
ChartLegendItem Class See Also Send Feedback
Initializes a new instance of the ChartLegendItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartLegendItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartLegendItem()

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem Methods
ChartLegendItem Class See Also Send Feedback

The ChartLegendItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartLegendItem. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.AnySibling Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.AssignReference Method
ChartLegendItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartLegendItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.GetProperty Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.GetRectangle Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.Highlight Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.InitializeMappings Method
ChartLegendItem Class See Also Send Feedback
Initializes the mapping of ChartLegendItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.InvokeMethod Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.NextSibling Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.Parent Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.PreviousSibling Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.ScrollToVisible Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem Properties
ChartLegendItem Class See Also Send Feedback

The ChartLegendItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the legend item color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the legend item text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartLegendItem. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.Color Property
ChartLegendItem Class See Also Send Feedback
Get the legend item color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.SelectedColorValue Property
ChartLegendItem Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedColorValue As String
Visual C++
public:
property String^ SelectedColorValue {
    String^ get ();
}

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.Text Property
ChartLegendItem Class See Also Send Feedback
Get the legend item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartLegendItem..::.XamlTag Property
ChartLegendItem Class See Also Send Feedback
Get the xaml tag of ChartLegendItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartLegendItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartPanel Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel Class
Members See Also Send Feedback
The Chart series panel holder.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartPanel : Panel
Visual Basic (Declaration)
Public Class ChartPanel _
    Inherits Panel
Visual C++
public ref class ChartPanel : public Panel

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Panel
Telerik.WebAii.Controls.Xaml..::.ChartPanel

See Also

ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


ChartPanel Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel Members
ChartPanel Class Constructors Methods Properties See Also Send Feedback

The ChartPanel type exposes the following members.

Constructors

Name | Description
ChartPanel | Initializes a new instance of the ChartPanel class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartPanel. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeries | Get the list of Chart area series.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LineSeries | Get the list of Chart Line series.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeSeries | Get the list of Chart Range series.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Series | Get the list of Chart panel series.
SplineAreaSeries | Get the list of Chart SplineArea series.
SplineRangeSeries | Get the list of Chart SplineRange series.
SplineSeries | Get the list of Chart Spline series.
StackedArea100Series | Get the list of Chart StackedArea100 series.
StackedAreaSeries | Get the list of Chart StackedArea series.
StackedLineSeries | Get the list of Chart StackedLine series.
StackedSplineArea100Series | Get the list of Chart Stacked Spline Area 100 series.
StackedSplineAreaSeries | Get the list of Chart Stacked Spline Area series.
StackedSplineSeries | Get the list of Chart Stacked Spline series.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartPanel. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartPanel Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel Constructor
ChartPanel Class See Also Send Feedback
Initializes a new instance of the ChartPanel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartPanel()

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartPanel Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel Methods
ChartPanel Class See Also Send Feedback

The ChartPanel type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartPanel. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.AnySibling Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.AssignReference Method
ChartPanel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartPanel.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.GetProperty Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.GetRectangle Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.Highlight Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.InitializeMappings Method
ChartPanel Class See Also Send Feedback
Initializes the mapping of ChartPanel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.InvokeMethod Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.NextSibling Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.Parent Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.PreviousSibling Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.ScrollToVisible Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members
Telerik.WebAii.Controls.Xaml Namespace


ChartPanel Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel Properties
ChartPanel Class See Also Send Feedback

The ChartPanel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeries | Get the list of Chart area series.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LineSeries | Get the list of Chart Line series.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeSeries | Get the list of Chart Range series.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Series | Get the list of Chart panel series.
SplineAreaSeries | Get the list of Chart SplineArea series.
SplineRangeSeries | Get the list of Chart SplineRange series.
SplineSeries | Get the list of Chart Spline series.
StackedArea100Series | Get the list of Chart StackedArea100 series.
StackedAreaSeries | Get the list of Chart StackedArea series.
StackedLineSeries | Get the list of Chart StackedLine series.
StackedSplineArea100Series | Get the list of Chart Stacked Spline Area 100 series.
StackedSplineAreaSeries | Get the list of Chart Stacked Spline Area series.
StackedSplineSeries | Get the list of Chart Stacked Spline series.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartPanel. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


AreaSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.AreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart area series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<AreaChartSeriesList> AreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaSeries As IList(Of AreaChartSeriesList)
Visual C++
public:
property IList<AreaChartSeriesList^>^ AreaSeries {
    IList<AreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


LineSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.LineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Line series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<LineChartSeriesList> LineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineSeries As IList(Of LineChartSeriesList)
Visual C++
public:
property IList<LineChartSeriesList^>^ LineSeries {
    IList<LineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


RangeSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.RangeSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Range series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RangeChartSeriesList> RangeSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property RangeSeries As IList(Of RangeChartSeriesList)
Visual C++
public:
property IList<RangeChartSeriesList^>^ RangeSeries {
    IList<RangeChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


Series Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.Series Property
ChartPanel Class See Also Send Feedback
Get the list of Chart panel series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeries> Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property Series As IList(Of ChartSeries)
Visual C++
public:
property IList<ChartSeries^>^ Series {
    IList<ChartSeries^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


SplineAreaSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.SplineAreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart SplineArea series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<SplineAreaChartSeriesList> SplineAreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineAreaSeries As IList(Of SplineAreaChartSeriesList)
Visual C++
public:
property IList<SplineAreaChartSeriesList^>^ SplineAreaSeries {
    IList<SplineAreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


SplineRangeSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.SplineRangeSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart SplineRange series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<SplineRangeChartSeriesList> SplineRangeSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineRangeSeries As IList(Of SplineRangeChartSeriesList)
Visual C++
public:
property IList<SplineRangeChartSeriesList^>^ SplineRangeSeries {
    IList<SplineRangeChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


SplineSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.SplineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Spline series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<SplineChartSeriesList> SplineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineSeries As IList(Of SplineChartSeriesList)
Visual C++
public:
property IList<SplineChartSeriesList^>^ SplineSeries {
    IList<SplineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


StackedArea100Series Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.StackedArea100Series Property
ChartPanel Class See Also Send Feedback
Get the list of Chart StackedArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<StackedArea100ChartSeriesList> StackedArea100Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedArea100Series As IList(Of StackedArea100ChartSeriesList)
Visual C++
public:
property IList<StackedArea100ChartSeriesList^>^ StackedArea100Series {
    IList<StackedArea100ChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


StackedAreaSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.StackedAreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart StackedArea series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<StackedAreaChartSeriesList> StackedAreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedAreaSeries As IList(Of StackedAreaChartSeriesList)
Visual C++
public:
property IList<StackedAreaChartSeriesList^>^ StackedAreaSeries {
    IList<StackedAreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


StackedLineSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.StackedLineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart StackedLine series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<StackedLineChartSeriesList> StackedLineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedLineSeries As IList(Of StackedLineChartSeriesList)
Visual C++
public:
property IList<StackedLineChartSeriesList^>^ StackedLineSeries {
    IList<StackedLineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineArea100Series Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.StackedSplineArea100Series Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Stacked Spline Area 100 series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<StackedSplineArea100ChartSeriesList> StackedSplineArea100Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineArea100Series As IList(Of StackedSplineArea100ChartSeriesList)
Visual C++
public:
property IList<StackedSplineArea100ChartSeriesList^>^ StackedSplineArea100Series {
    IList<StackedSplineArea100ChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineAreaSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.StackedSplineAreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Stacked Spline Area series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<StackedSplineAreaChartSeriesList> StackedSplineAreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineAreaSeries As IList(Of StackedSplineAreaChartSeriesList)
Visual C++
public:
property IList<StackedSplineAreaChartSeriesList^>^ StackedSplineAreaSeries {
    IList<StackedSplineAreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineSeries Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.StackedSplineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Stacked Spline series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<StackedSplineChartSeriesList> StackedSplineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineSeries As IList(Of StackedSplineChartSeriesList)
Visual C++
public:
property IList<StackedSplineChartSeriesList^>^ StackedSplineSeries {
    IList<StackedSplineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartPanel..::.XamlTag Property
ChartPanel Class See Also Send Feedback
Get the xaml tag of ChartPanel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartPanel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartTitle Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartTitle control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartTitle : ContentControl
Visual Basic (Declaration)
Public Class ChartTitle _
    Inherits ContentControl
Visual C++
public ref class ChartTitle : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartTitle

See Also

ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


ChartTitle Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle Members
ChartTitle Class Constructors Methods Properties See Also Send Feedback

The ChartTitle type exposes the following members.

Constructors

Name | Description
ChartTitle | Initializes a new instance of the ChartTitle class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartTitle. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the schart title text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartTitle. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


ChartTitle Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle Constructor
ChartTitle Class See Also Send Feedback
Initializes a new instance of the ChartTitle class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartTitle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartTitle()

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


ChartTitle Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle Methods
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ChartTitle. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.AnySibling Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.AssignReference Method
ChartTitle Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartTitle.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.GetProperty Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.GetRectangle Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.Highlight Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.InitializeMappings Method
ChartTitle Class See Also Send Feedback
Initializes the mapping of ChartTitle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.InvokeMethod Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.NextSibling Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.Parent Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.PreviousSibling Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.ScrollToVisible Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.WebAii.Controls.Xaml Namespace


ChartTitle Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle Properties
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the schart title text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of ChartTitle. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.Text Property
ChartTitle Class See Also Send Feedback
Get the schart title text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartTitle..::.XamlTag Property
ChartTitle Class See Also Send Feedback
Get the xaml tag of ChartTitle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartTitle Class
Telerik.WebAii.Controls.Xaml Namespace


ChartVerticalGridLines Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartVerticalGridLines control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartVerticalGridLines : ContentControl
Visual Basic (Declaration)
Public Class ChartVerticalGridLines _
    Inherits ContentControl
Visual C++
public ref class ChartVerticalGridLines : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartVerticalGridLines

See Also

ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


ChartVerticalGridLines Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines Members
ChartVerticalGridLines Class Constructors Methods Properties See Also Send Feedback

The ChartVerticalGridLines type exposes the following members.

Constructors

Name | Description
ChartVerticalGridLines | Initializes a new instance of the ChartVerticalGridLines class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of VerticalGridLine2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedVerticalGridlineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalGridlineColor | Get the gridlines color.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of VerticalGridLine2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


ChartVerticalGridLines Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines Constructor
ChartVerticalGridLines Class See Also Send Feedback
Initializes a new instance of the ChartVerticalGridLines class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartVerticalGridLines()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartVerticalGridLines()

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


ChartVerticalGridLines Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines Methods
ChartVerticalGridLines Class See Also Send Feedback

The ChartVerticalGridLines type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of VerticalGridLine2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.AnySibling Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.AssignReference Method
ChartVerticalGridLines Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartVerticalGridLines.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.GetProperty Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.GetRectangle Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.Highlight Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.InitializeMappings Method
ChartVerticalGridLines Class See Also Send Feedback
Initializes the mapping of VerticalGridLine2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.InvokeMethod Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.NextSibling Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.Parent Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.PreviousSibling Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.ScrollToVisible Method
ChartVerticalGridLines Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
ChartVerticalGridLines Members
Telerik.WebAii.Controls.Xaml Namespace


ChartVerticalGridLines Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines Properties
ChartVerticalGridLines Class See Also Send Feedback

The ChartVerticalGridLines type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedVerticalGridlineColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalGridlineColor | Get the gridlines color.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of VerticalGridLine2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedVerticalGridlineColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.SelectedVerticalGridlineColorValue Property
ChartVerticalGridLines Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedVerticalGridlineColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedVerticalGridlineColorValue As String
Visual C++
public:
property String^ SelectedVerticalGridlineColorValue {
    String^ get ();
}

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalGridlineColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.VerticalGridlineColor Property
ChartVerticalGridLines Class See Also Send Feedback
Get the gridlines color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color VerticalGridlineColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalGridlineColor As Color
Visual C++
public:
property Color^ VerticalGridlineColor {
    Color^ get ();
}

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartVerticalGridLines..::.XamlTag Property
ChartVerticalGridLines Class See Also Send Feedback
Get the xaml tag of VerticalGridLine2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartVerticalGridLines Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChartXAxisItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartXAxisItem : ContentControl
Visual Basic (Declaration)
Public Class ChartXAxisItem _
    Inherits ContentControl
Visual C++
public ref class ChartXAxisItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartXAxisItem

See Also

ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem Members
ChartXAxisItem Class Constructors Methods Properties See Also Send Feedback

The ChartXAxisItem type exposes the following members.

Constructors

Name | Description
ChartXAxisItem | Initializes a new instance of the ChartXAxisItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisXItem2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart X axis items.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisXItem2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem Constructor
ChartXAxisItem Class See Also Send Feedback
Initializes a new instance of the ChartXAxisItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartXAxisItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartXAxisItem()

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem Methods
ChartXAxisItem Class See Also Send Feedback

The ChartXAxisItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisXItem2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.AnySibling Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.AssignReference Method
ChartXAxisItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartXAxisItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.GetProperty Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.GetRectangle Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.Highlight Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.InitializeMappings Method
ChartXAxisItem Class See Also Send Feedback
Initializes the mapping of AxisXItem2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.InvokeMethod Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.NextSibling Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.Parent Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.PreviousSibling Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.ScrollToVisible Method
ChartXAxisItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
ChartXAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem Properties
ChartXAxisItem Class See Also Send Feedback

The ChartXAxisItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart X axis items.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisXItem2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


AxisTickColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.AxisTickColor Property
ChartXAxisItem Class See Also Send Feedback
Get the ticks color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisTickColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisTickColor As Color
Visual C++
public:
property Color^ AxisTickColor {
    Color^ get ();
}

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisTickColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.SelectedAxisTickColorValue Property
ChartXAxisItem Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisTickColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisTickColorValue As String
Visual C++
public:
property String^ SelectedAxisTickColorValue {
    String^ get ();
}

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.Text Property
ChartXAxisItem Class See Also Send Feedback
The text of the Chart X axis items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisItem..::.XamlTag Property
ChartXAxisItem Class See Also Send Feedback
Get the xaml tag of AxisXItem2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartXAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisLabel Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChartXAxisLabel control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartXAxisLabel : ContentControl
Visual Basic (Declaration)
Public Class ChartXAxisLabel _
    Inherits ContentControl
Visual C++
public ref class ChartXAxisLabel : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartXAxisLabel

See Also

ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisLabel Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel Members
ChartXAxisLabel Class Constructors Methods Properties See Also Send Feedback

The ChartXAxisLabel type exposes the following members.

Constructors

Name | Description
ChartXAxisLabel | Initializes a new instance of the ChartXAxisLabel class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisLabel2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLabelColor | Get the labels text color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLabelColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart axis labels.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisLabel2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XOffset | The X axis label offset.

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisLabel Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel Constructor
ChartXAxisLabel Class See Also Send Feedback
Initializes a new instance of the ChartXAxisLabel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartXAxisLabel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartXAxisLabel()

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisLabel Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel Methods
ChartXAxisLabel Class See Also Send Feedback

The ChartXAxisLabel type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisLabel2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.AnySibling Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.AssignReference Method
ChartXAxisLabel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartXAxisLabel.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.GetProperty Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.GetRectangle Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.Highlight Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.InitializeMappings Method
ChartXAxisLabel Class See Also Send Feedback
Initializes the mapping of AxisLabel2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.InvokeMethod Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.NextSibling Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.Parent Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.PreviousSibling Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.ScrollToVisible Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisLabel Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel Properties
ChartXAxisLabel Class See Also Send Feedback

The ChartXAxisLabel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLabelColor | Get the labels text color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLabelColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart axis labels.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisLabel2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XOffset | The X axis label offset.

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


AxisLabelColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.AxisLabelColor Property
ChartXAxisLabel Class See Also Send Feedback
Get the labels text color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisLabelColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisLabelColor As Color
Visual C++
public:
property Color^ AxisLabelColor {
    Color^ get ();
}

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisLabelColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.SelectedAxisLabelColorValue Property
ChartXAxisLabel Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisLabelColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisLabelColorValue As String
Visual C++
public:
property String^ SelectedAxisLabelColorValue {
    String^ get ();
}

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.Text Property
ChartXAxisLabel Class See Also Send Feedback
The text of the Chart axis labels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.XamlTag Property
ChartXAxisLabel Class See Also Send Feedback
Get the xaml tag of AxisLabel2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


XOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisLabel..::.XOffset Property
ChartXAxisLabel Class See Also Send Feedback
The X axis label offset.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double XOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property XOffset As Double
Visual C++
public:
property double XOffset {
    double get ();
}

See Also

ChartXAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisMinorTicks Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartXAxisMinorTicks control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartXAxisMinorTicks : ContentControl
Visual Basic (Declaration)
Public Class ChartXAxisMinorTicks _
    Inherits ContentControl
Visual C++
public ref class ChartXAxisMinorTicks : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartXAxisMinorTicks

See Also

ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisMinorTicks Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks Members
ChartXAxisMinorTicks Class Constructors Methods Properties See Also Send Feedback

The ChartXAxisMinorTicks type exposes the following members.

Constructors

Name | Description
ChartXAxisMinorTicks | Initializes a new instance of the ChartXAxisMinorTicks class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of MinorTick2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinorTick2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisMinorTicks Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks Constructor
ChartXAxisMinorTicks Class See Also Send Feedback
Initializes a new instance of the ChartXAxisMinorTicks class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartXAxisMinorTicks()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartXAxisMinorTicks()

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisMinorTicks Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks Methods
ChartXAxisMinorTicks Class See Also Send Feedback

The ChartXAxisMinorTicks type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of MinorTick2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.AnySibling Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.AssignReference Method
ChartXAxisMinorTicks Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartXAxisMinorTicks.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.GetProperty Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.GetRectangle Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.Highlight Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.InitializeMappings Method
ChartXAxisMinorTicks Class See Also Send Feedback
Initializes the mapping of MinorTick2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.InvokeMethod Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.NextSibling Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.Parent Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.PreviousSibling Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.ScrollToVisible Method
ChartXAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
ChartXAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


ChartXAxisMinorTicks Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks Properties
ChartXAxisMinorTicks Class See Also Send Feedback

The ChartXAxisMinorTicks type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinorTick2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


AxisTickColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.AxisTickColor Property
ChartXAxisMinorTicks Class See Also Send Feedback
Get the ticks color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisTickColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisTickColor As Color
Visual C++
public:
property Color^ AxisTickColor {
    Color^ get ();
}

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisTickColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.SelectedAxisTickColorValue Property
ChartXAxisMinorTicks Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisTickColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisTickColorValue As String
Visual C++
public:
property String^ SelectedAxisTickColorValue {
    String^ get ();
}

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartXAxisMinorTicks..::.XamlTag Property
ChartXAxisMinorTicks Class See Also Send Feedback
Get the xaml tag of MinorTick2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartXAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChartYAxisItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartYAxisItem : ContentControl
Visual Basic (Declaration)
Public Class ChartYAxisItem _
    Inherits ContentControl
Visual C++
public ref class ChartYAxisItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartYAxisItem

See Also

ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem Members
ChartYAxisItem Class Constructors Methods Properties See Also Send Feedback

The ChartYAxisItem type exposes the following members.

Constructors

Name | Description
ChartYAxisItem | Initializes a new instance of the ChartYAxisItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisYItem2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart Y axis items.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisYItem2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem Constructor
ChartYAxisItem Class See Also Send Feedback
Initializes a new instance of the ChartYAxisItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartYAxisItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartYAxisItem()

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem Methods
ChartYAxisItem Class See Also Send Feedback

The ChartYAxisItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisYItem2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.AnySibling Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.AssignReference Method
ChartYAxisItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartYAxisItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.GetProperty Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.GetRectangle Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.Highlight Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.InitializeMappings Method
ChartYAxisItem Class See Also Send Feedback
Initializes the mapping of AxisYItem2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.InvokeMethod Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.NextSibling Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.Parent Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.PreviousSibling Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.ScrollToVisible Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem Properties
ChartYAxisItem Class See Also Send Feedback

The ChartYAxisItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart Y axis items.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisYItem2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


AxisTickColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.AxisTickColor Property
ChartYAxisItem Class See Also Send Feedback
Get the ticks color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisTickColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisTickColor As Color
Visual C++
public:
property Color^ AxisTickColor {
    Color^ get ();
}

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisTickColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.SelectedAxisTickColorValue Property
ChartYAxisItem Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisTickColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisTickColorValue As String
Visual C++
public:
property String^ SelectedAxisTickColorValue {
    String^ get ();
}

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.Text Property
ChartYAxisItem Class See Also Send Feedback
The text of the Chart Y axis items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisItem..::.XamlTag Property
ChartYAxisItem Class See Also Send Feedback
Get the xaml tag of AxisYItem2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartYAxisItem Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisLabel Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChartYAxisLabel control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartYAxisLabel : ContentControl
Visual Basic (Declaration)
Public Class ChartYAxisLabel _
    Inherits ContentControl
Visual C++
public ref class ChartYAxisLabel : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartYAxisLabel

See Also

ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisLabel Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel Members
ChartYAxisLabel Class Constructors Methods Properties See Also Send Feedback

The ChartYAxisLabel type exposes the following members.

Constructors

Name | Description
ChartYAxisLabel | Initializes a new instance of the ChartYAxisLabel class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisLabel2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLabelColor | Get the labels text color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLabelColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart Y axis labels.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisLabel2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisLabel Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel Constructor
ChartYAxisLabel Class See Also Send Feedback
Initializes a new instance of the ChartYAxisLabel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartYAxisLabel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartYAxisLabel()

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisLabel Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel Methods
ChartYAxisLabel Class See Also Send Feedback

The ChartYAxisLabel type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AxisLabel2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.AnySibling Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.AssignReference Method
ChartYAxisLabel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartYAxisLabel.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.GetProperty Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.GetRectangle Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.Highlight Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.InitializeMappings Method
ChartYAxisLabel Class See Also Send Feedback
Initializes the mapping of AxisLabel2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.InvokeMethod Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.NextSibling Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.Parent Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.PreviousSibling Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.ScrollToVisible Method
ChartYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
ChartYAxisLabel Members
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisLabel Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel Properties
ChartYAxisLabel Class See Also Send Feedback

The ChartYAxisLabel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisLabelColor | Get the labels text color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisLabelColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | The text of the Chart Y axis labels.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AxisLabel2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


AxisLabelColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.AxisLabelColor Property
ChartYAxisLabel Class See Also Send Feedback
Get the labels text color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisLabelColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisLabelColor As Color
Visual C++
public:
property Color^ AxisLabelColor {
    Color^ get ();
}

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisLabelColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.SelectedAxisLabelColorValue Property
ChartYAxisLabel Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisLabelColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisLabelColorValue As String
Visual C++
public:
property String^ SelectedAxisLabelColorValue {
    String^ get ();
}

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.Text Property
ChartYAxisLabel Class See Also Send Feedback
The text of the Chart Y axis labels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisLabel..::.XamlTag Property
ChartYAxisLabel Class See Also Send Feedback
Get the xaml tag of AxisLabel2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartYAxisLabel Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisMinorTicks Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartYAxisMinorTicks control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartYAxisMinorTicks : ContentControl
Visual Basic (Declaration)
Public Class ChartYAxisMinorTicks _
    Inherits ContentControl
Visual C++
public ref class ChartYAxisMinorTicks : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartYAxisMinorTicks

See Also

ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisMinorTicks Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks Members
ChartYAxisMinorTicks Class Constructors Methods Properties See Also Send Feedback

The ChartYAxisMinorTicks type exposes the following members.

Constructors

Name | Description
ChartYAxisMinorTicks | Initializes a new instance of the ChartYAxisMinorTicks class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of MinorTick2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinorTick2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisMinorTicks Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks Constructor
ChartYAxisMinorTicks Class See Also Send Feedback
Initializes a new instance of the ChartYAxisMinorTicks class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartYAxisMinorTicks()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartYAxisMinorTicks()

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisMinorTicks Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks Methods
ChartYAxisMinorTicks Class See Also Send Feedback

The ChartYAxisMinorTicks type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of MinorTick2D. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.AnySibling Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.AssignReference Method
ChartYAxisMinorTicks Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartYAxisMinorTicks.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.GetProperty Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.GetRectangle Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.Highlight Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.InitializeMappings Method
ChartYAxisMinorTicks Class See Also Send Feedback
Initializes the mapping of MinorTick2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.InvokeMethod Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.NextSibling Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.Parent Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.PreviousSibling Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.ScrollToVisible Method
ChartYAxisMinorTicks Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
ChartYAxisMinorTicks Members
Telerik.WebAii.Controls.Xaml Namespace


ChartYAxisMinorTicks Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks Properties
ChartYAxisMinorTicks Class See Also Send Feedback

The ChartYAxisMinorTicks type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AxisTickColor | Get the ticks color.
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedAxisTickColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinorTick2D. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


AxisTickColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.AxisTickColor Property
ChartYAxisMinorTicks Class See Also Send Feedback
Get the ticks color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color AxisTickColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisTickColor As Color
Visual C++
public:
property Color^ AxisTickColor {
    Color^ get ();
}

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedAxisTickColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.SelectedAxisTickColorValue Property
ChartYAxisMinorTicks Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedAxisTickColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedAxisTickColorValue As String
Visual C++
public:
property String^ SelectedAxisTickColorValue {
    String^ get ();
}

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartYAxisMinorTicks..::.XamlTag Property
ChartYAxisMinorTicks Class See Also Send Feedback
Get the xaml tag of MinorTick2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartYAxisMinorTicks Class
Telerik.WebAii.Controls.Xaml Namespace


ColorPickerElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames Class
Members See Also Send Feedback
Holds the list of the important ColorPicker element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ColorPickerElementNames
Visual Basic (Declaration)
Public NotInheritable Class ColorPickerElementNames
Visual C++
public ref class ColorPickerElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.ColorPickerElementNames

See Also

ColorPickerElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


ColorPickerElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames Members
ColorPickerElementNames Class Fields See Also Send Feedback

The ColorPickerElementNames type exposes the following members.

Fields

Name | Description
ColorButtonName | The name of the ColorPicker button holding the selected color element.
HeaderPaletteName | The name of the header palette element.
MainPaletteHeaderTextBlockName | The name of the selector main palette header text block element.
MainPaletteName | The name of the main palette element.
PopupName | The name of the ColorPicker popup element.
SelectorPaletteHeaderButtonName | The name of the ColorPicker selector palette header button element.
StandardPaletteHeaderTextBlockName | The name of the selector standard palette header text block element.
StandardPaletteName | The name of the standard palette element.
ToggleButtonName | The name of the ColorPicker toggle button element.

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ColorPickerElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames Fields
ColorPickerElementNames Class See Also Send Feedback

The ColorPickerElementNames type exposes the following members.

Fields

Name | Description
ColorButtonName | The name of the ColorPicker button holding the selected color element.
HeaderPaletteName | The name of the header palette element.
MainPaletteHeaderTextBlockName | The name of the selector main palette header text block element.
MainPaletteName | The name of the main palette element.
PopupName | The name of the ColorPicker popup element.
SelectorPaletteHeaderButtonName | The name of the ColorPicker selector palette header button element.
StandardPaletteHeaderTextBlockName | The name of the selector standard palette header text block element.
StandardPaletteName | The name of the standard palette element.
ToggleButtonName | The name of the ColorPicker toggle button element.

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ColorButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.ColorButtonName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the ColorPicker button holding the selected color element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColorButtonName
Visual Basic (Declaration)
Public Const ColorButtonName As String
Visual C++
public:
literal String^ ColorButtonName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderPaletteName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.HeaderPaletteName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the header palette element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HeaderPaletteName
Visual Basic (Declaration)
Public Const HeaderPaletteName As String
Visual C++
public:
literal String^ HeaderPaletteName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MainPaletteHeaderTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.MainPaletteHeaderTextBlockName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the selector main palette header text block element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MainPaletteHeaderTextBlockName
Visual Basic (Declaration)
Public Const MainPaletteHeaderTextBlockName As String
Visual C++
public:
literal String^ MainPaletteHeaderTextBlockName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MainPaletteName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.MainPaletteName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the main palette element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MainPaletteName
Visual Basic (Declaration)
Public Const MainPaletteName As String
Visual C++
public:
literal String^ MainPaletteName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.PopupName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the ColorPicker popup element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PopupName
Visual Basic (Declaration)
Public Const PopupName As String
Visual C++
public:
literal String^ PopupName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SelectorPaletteHeaderButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.SelectorPaletteHeaderButtonName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the ColorPicker selector palette header button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SelectorPaletteHeaderButtonName
Visual Basic (Declaration)
Public Const SelectorPaletteHeaderButtonName As String
Visual C++
public:
literal String^ SelectorPaletteHeaderButtonName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


StandardPaletteHeaderTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.StandardPaletteHeaderTextBlockName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the selector standard palette header text block element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StandardPaletteHeaderTextBlockName
Visual Basic (Declaration)
Public Const StandardPaletteHeaderTextBlockName As String
Visual C++
public:
literal String^ StandardPaletteHeaderTextBlockName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


StandardPaletteName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.StandardPaletteName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the standard palette element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StandardPaletteName
Visual Basic (Declaration)
Public Const StandardPaletteName As String
Visual C++
public:
literal String^ StandardPaletteName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ColorPickerElementNames..::.ToggleButtonName Field
ColorPickerElementNames Class See Also Send Feedback
The name of the ColorPicker toggle button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToggleButtonName
Visual Basic (Declaration)
Public Const ToggleButtonName As String
Visual C++
public:
literal String^ ToggleButtonName

See Also

ColorPickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ComboBoxElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames Class
Members See Also Send Feedback
A list of names specific to RadComboBox component elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ComboBoxElementNames
Visual Basic (Declaration)
Public NotInheritable Class ComboBoxElementNames
Visual C++
public ref class ComboBoxElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.ComboBoxElementNames

See Also

ComboBoxElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


ComboBoxElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames Members
ComboBoxElementNames Class Fields See Also Send Feedback

The ComboBoxElementNames type exposes the following members.

Fields

Name | Description
ContentPresenterElementName | The combobox content presenter content name used in case of non-editable combo.
DropDownButtonName | The PART related to the drop down toggle button.
EditableTextBoxName | The PART related to the combobox input editable text box.
PopupName | The PART related to the combobox popup.
PopupScrollViewerName | The ComboBox drop dowen popup ScrollViewer element name.

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ComboBoxElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames Fields
ComboBoxElementNames Class See Also Send Feedback

The ComboBoxElementNames type exposes the following members.

Fields

Name | Description
ContentPresenterElementName | The combobox content presenter content name used in case of non-editable combo.
DropDownButtonName | The PART related to the drop down toggle button.
EditableTextBoxName | The PART related to the combobox input editable text box.
PopupName | The PART related to the combobox popup.
PopupScrollViewerName | The ComboBox drop dowen popup ScrollViewer element name.

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames..::.ContentPresenterElementName Field
ComboBoxElementNames Class See Also Send Feedback
The combobox content presenter content name used in case of non-editable combo.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ContentPresenterElementName
Visual Basic (Declaration)
Public Const ContentPresenterElementName As String
Visual C++
public:
literal String^ ContentPresenterElementName

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames..::.DropDownButtonName Field
ComboBoxElementNames Class See Also Send Feedback
The PART related to the drop down toggle button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownButtonName
Visual Basic (Declaration)
Public Const DropDownButtonName As String
Visual C++
public:
literal String^ DropDownButtonName

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


EditableTextBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames..::.EditableTextBoxName Field
ComboBoxElementNames Class See Also Send Feedback
The PART related to the combobox input editable text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string EditableTextBoxName
Visual Basic (Declaration)
Public Const EditableTextBoxName As String
Visual C++
public:
literal String^ EditableTextBoxName

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames..::.PopupName Field
ComboBoxElementNames Class See Also Send Feedback
The PART related to the combobox popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PopupName
Visual Basic (Declaration)
Public Const PopupName As String
Visual C++
public:
literal String^ PopupName

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PopupScrollViewerName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ComboBoxElementNames..::.PopupScrollViewerName Field
ComboBoxElementNames Class See Also Send Feedback
The ComboBox drop dowen popup ScrollViewer element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PopupScrollViewerName
Visual Basic (Declaration)
Public Const PopupScrollViewerName As String
Visual C++
public:
literal String^ PopupScrollViewerName

See Also

ComboBoxElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DatePickerElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DatePickerElementNames Class
Members See Also Send Feedback
Holds the list of the important DatePicker element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class DatePickerElementNames
Visual Basic (Declaration)
Public NotInheritable Class DatePickerElementNames
Visual C++
public ref class DatePickerElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.DatePickerElementNames

See Also

DatePickerElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


DatePickerElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DatePickerElementNames Members
DatePickerElementNames Class Fields See Also Send Feedback

The DatePickerElementNames type exposes the following members.

Fields

Name | Description
InputBoxName | The name of the DatePicker input box element.
PopupName | The name of the DatePicker popup element.
ToggleButtonName | The name of the DatePicker toggle button element.

See Also

DatePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DatePickerElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DatePickerElementNames Fields
DatePickerElementNames Class See Also Send Feedback

The DatePickerElementNames type exposes the following members.

Fields

Name | Description
InputBoxName | The name of the DatePicker input box element.
PopupName | The name of the DatePicker popup element.
ToggleButtonName | The name of the DatePicker toggle button element.

See Also

DatePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


InputBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DatePickerElementNames..::.InputBoxName Field
DatePickerElementNames Class See Also Send Feedback
The name of the DatePicker input box element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string InputBoxName
Visual Basic (Declaration)
Public Const InputBoxName As String
Visual C++
public:
literal String^ InputBoxName

See Also

DatePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DatePickerElementNames..::.PopupName Field
DatePickerElementNames Class See Also Send Feedback
The name of the DatePicker popup element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PopupName
Visual Basic (Declaration)
Public Const PopupName As String
Visual C++
public:
literal String^ PopupName

See Also

DatePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DatePickerElementNames..::.ToggleButtonName Field
DatePickerElementNames Class See Also Send Feedback
The name of the DatePicker toggle button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToggleButtonName
Visual Basic (Declaration)
Public Const ToggleButtonName As String
Visual C++
public:
literal String^ ToggleButtonName

See Also

DatePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingDragDirection Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingDragDirection Enumeration
See Also Send Feedback
The RadDocking drag direction enumeration - left, right, up and down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum DockingDragDirection
Visual Basic (Declaration)
Public Enumeration DockingDragDirection
Visual C++
public enum class DockingDragDirection

Members

Member name | Description
Left | Drag left.
Right | Drag right.
Up | Drag up.
Down | Drag down.

See Also

Telerik.WebAii.Controls.Xaml Namespace


DockingElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames Class
Members See Also Send Feedback
Holds the list of the important RadDocking element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class DockingElementNames
Visual Basic (Declaration)
Public NotInheritable Class DockingElementNames
Visual C++
public ref class DockingElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.DockingElementNames

See Also

DockingElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


DockingElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames Members
DockingElementNames Class Fields See Also Send Feedback

The DockingElementNames type exposes the following members.

Fields

Name | Description
BottomAutoHideAreaName | The name of the docking bottom auto hide area element.
DockingBottomIndicatorName | The name of the docking compass bottom border indicator.
DockingCenterIndicatorName | The name of the docking compass center border indicator.
DockingLeftIndicatorName | The name of the docking compass left border indicator.
DockingPanelName | The name of the docking panel element.
DockingRightIndicatorName | The name of the docking compass right border indicator.
DockingTopIndicatorName | The name of the docking compass top border indicator.
DockResizerName | The name of the docking pane group and split container resizer element.
DocumentHostName | The name of the docking document host element.
GridResizerHorizontalTemplateName | The name of the docking grid resizer horizontal template grid element.
LeftAutoHideAreaName | The name of the docking left auto hide area element.
PaneHeaderCloseButtonName | The name of the docking pane header close button element.
PaneHeaderContentControlName | The name of the docking pane header content control element.
PaneHeaderDropDownMenuName | The name of the docking pane header drop down menu element.
PaneHeaderName | The name of the docking pane header element in the auto hide area.
PaneHeaderPinButtonName | The name of the docking pane header pin button element.
PanePopupContentElementName | The name of the docking pane popup content element in the auto hide area.
PopupPanelCanvasName | The name of the docking popup panel canvas element.
RightAutoHideAreaName | The name of the docking right auto hide area element.
ToolWindowCloseButtonName | The name of the docking tool window close button element.
ToolWindowHeaderName | The name of the docking tool window header element.
ToolWindowVisualRootName | The name of the docking tool window visual root border element.
TopAutoHideAreaName | The name of the docking top auto hide area element.

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames Fields
DockingElementNames Class See Also Send Feedback

The DockingElementNames type exposes the following members.

Fields

Name | Description
BottomAutoHideAreaName | The name of the docking bottom auto hide area element.
DockingBottomIndicatorName | The name of the docking compass bottom border indicator.
DockingCenterIndicatorName | The name of the docking compass center border indicator.
DockingLeftIndicatorName | The name of the docking compass left border indicator.
DockingPanelName | The name of the docking panel element.
DockingRightIndicatorName | The name of the docking compass right border indicator.
DockingTopIndicatorName | The name of the docking compass top border indicator.
DockResizerName | The name of the docking pane group and split container resizer element.
DocumentHostName | The name of the docking document host element.
GridResizerHorizontalTemplateName | The name of the docking grid resizer horizontal template grid element.
LeftAutoHideAreaName | The name of the docking left auto hide area element.
PaneHeaderCloseButtonName | The name of the docking pane header close button element.
PaneHeaderContentControlName | The name of the docking pane header content control element.
PaneHeaderDropDownMenuName | The name of the docking pane header drop down menu element.
PaneHeaderName | The name of the docking pane header element in the auto hide area.
PaneHeaderPinButtonName | The name of the docking pane header pin button element.
PanePopupContentElementName | The name of the docking pane popup content element in the auto hide area.
PopupPanelCanvasName | The name of the docking popup panel canvas element.
RightAutoHideAreaName | The name of the docking right auto hide area element.
ToolWindowCloseButtonName | The name of the docking tool window close button element.
ToolWindowHeaderName | The name of the docking tool window header element.
ToolWindowVisualRootName | The name of the docking tool window visual root border element.
TopAutoHideAreaName | The name of the docking top auto hide area element.

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


BottomAutoHideAreaName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.BottomAutoHideAreaName Field
DockingElementNames Class See Also Send Feedback
The name of the docking bottom auto hide area element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BottomAutoHideAreaName
Visual Basic (Declaration)
Public Const BottomAutoHideAreaName As String
Visual C++
public:
literal String^ BottomAutoHideAreaName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingBottomIndicatorName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockingBottomIndicatorName Field
DockingElementNames Class See Also Send Feedback
The name of the docking compass bottom border indicator.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingBottomIndicatorName
Visual Basic (Declaration)
Public Const DockingBottomIndicatorName As String
Visual C++
public:
literal String^ DockingBottomIndicatorName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingCenterIndicatorName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockingCenterIndicatorName Field
DockingElementNames Class See Also Send Feedback
The name of the docking compass center border indicator.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingCenterIndicatorName
Visual Basic (Declaration)
Public Const DockingCenterIndicatorName As String
Visual C++
public:
literal String^ DockingCenterIndicatorName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingLeftIndicatorName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockingLeftIndicatorName Field
DockingElementNames Class See Also Send Feedback
The name of the docking compass left border indicator.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingLeftIndicatorName
Visual Basic (Declaration)
Public Const DockingLeftIndicatorName As String
Visual C++
public:
literal String^ DockingLeftIndicatorName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingPanelName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockingPanelName Field
DockingElementNames Class See Also Send Feedback
The name of the docking panel element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingPanelName
Visual Basic (Declaration)
Public Const DockingPanelName As String
Visual C++
public:
literal String^ DockingPanelName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingRightIndicatorName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockingRightIndicatorName Field
DockingElementNames Class See Also Send Feedback
The name of the docking compass right border indicator.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingRightIndicatorName
Visual Basic (Declaration)
Public Const DockingRightIndicatorName As String
Visual C++
public:
literal String^ DockingRightIndicatorName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockingTopIndicatorName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockingTopIndicatorName Field
DockingElementNames Class See Also Send Feedback
The name of the docking compass top border indicator.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingTopIndicatorName
Visual Basic (Declaration)
Public Const DockingTopIndicatorName As String
Visual C++
public:
literal String^ DockingTopIndicatorName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockResizerName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DockResizerName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane group and split container resizer element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockResizerName
Visual Basic (Declaration)
Public Const DockResizerName As String
Visual C++
public:
literal String^ DockResizerName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentHostName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.DocumentHostName Field
DockingElementNames Class See Also Send Feedback
The name of the docking document host element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DocumentHostName
Visual Basic (Declaration)
Public Const DocumentHostName As String
Visual C++
public:
literal String^ DocumentHostName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


GridResizerHorizontalTemplateName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.GridResizerHorizontalTemplateName Field
DockingElementNames Class See Also Send Feedback
The name of the docking grid resizer horizontal template grid element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridResizerHorizontalTemplateName
Visual Basic (Declaration)
Public Const GridResizerHorizontalTemplateName As String
Visual C++
public:
literal String^ GridResizerHorizontalTemplateName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


LeftAutoHideAreaName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.LeftAutoHideAreaName Field
DockingElementNames Class See Also Send Feedback
The name of the docking left auto hide area element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LeftAutoHideAreaName
Visual Basic (Declaration)
Public Const LeftAutoHideAreaName As String
Visual C++
public:
literal String^ LeftAutoHideAreaName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeaderCloseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PaneHeaderCloseButtonName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane header close button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneHeaderCloseButtonName
Visual Basic (Declaration)
Public Const PaneHeaderCloseButtonName As String
Visual C++
public:
literal String^ PaneHeaderCloseButtonName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeaderContentControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PaneHeaderContentControlName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane header content control element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneHeaderContentControlName
Visual Basic (Declaration)
Public Const PaneHeaderContentControlName As String
Visual C++
public:
literal String^ PaneHeaderContentControlName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeaderDropDownMenuName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PaneHeaderDropDownMenuName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane header drop down menu element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneHeaderDropDownMenuName
Visual Basic (Declaration)
Public Const PaneHeaderDropDownMenuName As String
Visual C++
public:
literal String^ PaneHeaderDropDownMenuName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeaderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PaneHeaderName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane header element in the auto hide area.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneHeaderName
Visual Basic (Declaration)
Public Const PaneHeaderName As String
Visual C++
public:
literal String^ PaneHeaderName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeaderPinButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PaneHeaderPinButtonName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane header pin button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneHeaderPinButtonName
Visual Basic (Declaration)
Public Const PaneHeaderPinButtonName As String
Visual C++
public:
literal String^ PaneHeaderPinButtonName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PanePopupContentElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PanePopupContentElementName Field
DockingElementNames Class See Also Send Feedback
The name of the docking pane popup content element in the auto hide area.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PanePopupContentElementName
Visual Basic (Declaration)
Public Const PanePopupContentElementName As String
Visual C++
public:
literal String^ PanePopupContentElementName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PopupPanelCanvasName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.PopupPanelCanvasName Field
DockingElementNames Class See Also Send Feedback
The name of the docking popup panel canvas element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PopupPanelCanvasName
Visual Basic (Declaration)
Public Const PopupPanelCanvasName As String
Visual C++
public:
literal String^ PopupPanelCanvasName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


RightAutoHideAreaName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.RightAutoHideAreaName Field
DockingElementNames Class See Also Send Feedback
The name of the docking right auto hide area element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RightAutoHideAreaName
Visual Basic (Declaration)
Public Const RightAutoHideAreaName As String
Visual C++
public:
literal String^ RightAutoHideAreaName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindowCloseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.ToolWindowCloseButtonName Field
DockingElementNames Class See Also Send Feedback
The name of the docking tool window close button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolWindowCloseButtonName
Visual Basic (Declaration)
Public Const ToolWindowCloseButtonName As String
Visual C++
public:
literal String^ ToolWindowCloseButtonName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindowHeaderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.ToolWindowHeaderName Field
DockingElementNames Class See Also Send Feedback
The name of the docking tool window header element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolWindowHeaderName
Visual Basic (Declaration)
Public Const ToolWindowHeaderName As String
Visual C++
public:
literal String^ ToolWindowHeaderName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindowVisualRootName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.ToolWindowVisualRootName Field
DockingElementNames Class See Also Send Feedback
The name of the docking tool window visual root border element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolWindowVisualRootName
Visual Basic (Declaration)
Public Const ToolWindowVisualRootName As String
Visual C++
public:
literal String^ ToolWindowVisualRootName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TopAutoHideAreaName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockingElementNames..::.TopAutoHideAreaName Field
DockingElementNames Class See Also Send Feedback
The name of the docking top auto hide area element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TopAutoHideAreaName
Visual Basic (Declaration)
Public Const TopAutoHideAreaName As String
Visual C++
public:
literal String^ TopAutoHideAreaName

See Also

DockingElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DockPosition Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DockPosition Enumeration
See Also Send Feedback
The dock position enumeration. Used as an argument for RadDocking.DockToX like methods.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum DockPosition
Visual Basic (Declaration)
Public Enumeration DockPosition
Visual C++
public enum class DockPosition

Members

Member name | Description
Left | Dock to the left.
Right | Dock to the right.
Top | Dock to the top.
Bottom | Dock to the bottom.
Center | Dock to the center.

See Also

Telerik.WebAii.Controls.Xaml Namespace


DocumentHost Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight DocumentHost control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class DocumentHost : ContentControl
Visual Basic (Declaration)
Public Class DocumentHost _
    Inherits ContentControl
Visual C++
public ref class DocumentHost : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.DocumentHost

See Also

DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


DocumentHost Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost Members
DocumentHost Class Constructors Methods Properties See Also Send Feedback

The DocumentHost type exposes the following members.

Constructors

Name | Description
DocumentHost | Initializes a new instance of the DocumentHost class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking DocumentHost control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document host control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentHost Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost Constructor
DocumentHost Class See Also Send Feedback
Initializes a new instance of the DocumentHost class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DocumentHost()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentHost()

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentHost Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost Methods
DocumentHost Class See Also Send Feedback

The DocumentHost type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking DocumentHost control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.AnySibling Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.GetProperty Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.GetRectangle Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.Highlight Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.InitializeMappings Method
DocumentHost Class See Also Send Feedback
Initializes the mapping of the RadDocking DocumentHost control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.InvokeMethod Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.NextSibling Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.Parent Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.PreviousSibling Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.ScrollToVisible Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members
Telerik.WebAii.Controls.Xaml Namespace


DocumentHost Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost Properties
DocumentHost Class See Also Send Feedback

The DocumentHost type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document host control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


SplitContainer Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.SplitContainer Property
DocumentHost Class See Also Send Feedback
Get the split container element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitContainer SplitContainer { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainer As RadSplitContainer
Visual C++
public:
property RadSplitContainer^ SplitContainer {
    RadSplitContainer^ get ();
}

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
DocumentHost..::.XamlTag Property
DocumentHost Class See Also Send Feedback
Get the xaml tag of the document host control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

DocumentHost Class
Telerik.WebAii.Controls.Xaml Namespace


ExpanderElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExpanderElementNames Class
Members See Also Send Feedback
Represents a list of control element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ExpanderElementNames
Visual Basic (Declaration)
Public NotInheritable Class ExpanderElementNames
Visual C++
public ref class ExpanderElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.ExpanderElementNames

See Also

ExpanderElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


ExpanderElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExpanderElementNames Members
ExpanderElementNames Class Fields See Also Send Feedback

The ExpanderElementNames type exposes the following members.

Fields

Name | Description
CaptionTextBlockName | The expander caption text block name.
ContentPresenterName | The content presenter name.
ToggleButtonName | The toggle button name.

See Also

ExpanderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ExpanderElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExpanderElementNames Fields
ExpanderElementNames Class See Also Send Feedback

The ExpanderElementNames type exposes the following members.

Fields

Name | Description
CaptionTextBlockName | The expander caption text block name.
ContentPresenterName | The content presenter name.
ToggleButtonName | The toggle button name.

See Also

ExpanderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CaptionTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExpanderElementNames..::.CaptionTextBlockName Field
ExpanderElementNames Class See Also Send Feedback
The expander caption text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CaptionTextBlockName
Visual Basic (Declaration)
Public Const CaptionTextBlockName As String
Visual C++
public:
literal String^ CaptionTextBlockName

See Also

ExpanderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExpanderElementNames..::.ContentPresenterName Field
ExpanderElementNames Class See Also Send Feedback
The content presenter name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ContentPresenterName
Visual Basic (Declaration)
Public Const ContentPresenterName As String
Visual C++
public:
literal String^ ContentPresenterName

See Also

ExpanderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExpanderElementNames..::.ToggleButtonName Field
ExpanderElementNames Class See Also Send Feedback
The toggle button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToggleButtonName
Visual Basic (Declaration)
Public Const ToggleButtonName As String
Visual C++
public:
literal String^ ToggleButtonName

See Also

ExpanderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ExtendedTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox Class
Members See Also Send Feedback
Represents the Silverlight MaskedTextBox's ExtendedTextBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ExtendedTextBox : TextBox
Visual Basic (Declaration)
Public Class ExtendedTextBox _
    Inherits TextBox
Visual C++
public ref class ExtendedTextBox : public TextBox

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.TextBox
Telerik.WebAii.Controls.Xaml..::.ExtendedTextBox

See Also

ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


ExtendedTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox Members
ExtendedTextBox Class Constructors Methods Properties See Also Send Feedback

The ExtendedTextBox type exposes the following members.

Constructors

Name | Description
ExtendedTextBox | Initializes a new instance of the ExtendedTextBox class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from TextBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMaskedTextBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from TextBox.)
BorderBrush | (Inherited from TextBox.)
BorderThickness | (Inherited from TextBox.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from TextBox.)
FontSize | (Inherited from TextBox.)
FontStretch | (Inherited from TextBox.)
FontStyle | (Inherited from TextBox.)
FontWeight | (Inherited from TextBox.)
Foreground | (Inherited from TextBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from TextBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from TextBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from TextBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from TextBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
TabIndex | (Inherited from TextBox.)
TabNavigation | (Inherited from TextBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TextWrapping | (Inherited from TextBox.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from TextBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Masked ExtendedTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


ExtendedTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox Constructor
ExtendedTextBox Class See Also Send Feedback
Initializes a new instance of the ExtendedTextBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ExtendedTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtendedTextBox()

See Also

ExtendedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


ExtendedTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox Methods
ExtendedTextBox Class See Also Send Feedback

The ExtendedTextBox type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from TextBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMaskedTextBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.AnySibling Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.GetProperty Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.GetRectangle Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.Highlight Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.InitializeMappings Method
ExtendedTextBox Class See Also Send Feedback
Initializes the mapping of the RadMaskedTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ExtendedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.InvokeMethod Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.NextSibling Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.Parent Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.PreviousSibling Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.ScrollToVisible Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


ExtendedTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox Properties
ExtendedTextBox Class See Also Send Feedback

The ExtendedTextBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from TextBox.)
BorderBrush | (Inherited from TextBox.)
BorderThickness | (Inherited from TextBox.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from TextBox.)
FontSize | (Inherited from TextBox.)
FontStretch | (Inherited from TextBox.)
FontStyle | (Inherited from TextBox.)
FontWeight | (Inherited from TextBox.)
Foreground | (Inherited from TextBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from TextBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from TextBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from TextBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from TextBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
TabIndex | (Inherited from TextBox.)
TabNavigation | (Inherited from TextBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TextWrapping | (Inherited from TextBox.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from TextBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Masked ExtendedTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ExtendedTextBox..::.XamlTag Property
ExtendedTextBox Class See Also Send Feedback
Get the xaml tag of Masked ExtendedTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ExtendedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


FluidContentControlElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlElementNames Class
Members See Also Send Feedback
Represents the FluidContentControl important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class FluidContentControlElementNames
Visual Basic (Declaration)
Public NotInheritable Class FluidContentControlElementNames
Visual C++
public ref class FluidContentControlElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.FluidContentControlElementNames

See Also

FluidContentControlElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


FluidContentControlElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlElementNames Members
FluidContentControlElementNames Class Fields See Also Send Feedback

The FluidContentControlElementNames type exposes the following members.

Fields

Name | Description
LargeContentPresenterName | The FluidContentControl large content name.
NormalContentPresenterName | The FluidContentControl normal content name.
SmallContentPresenterName | The FluidContentControl small content name.

See Also

FluidContentControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


FluidContentControlElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlElementNames Fields
FluidContentControlElementNames Class See Also Send Feedback

The FluidContentControlElementNames type exposes the following members.

Fields

Name | Description
LargeContentPresenterName | The FluidContentControl large content name.
NormalContentPresenterName | The FluidContentControl normal content name.
SmallContentPresenterName | The FluidContentControl small content name.

See Also

FluidContentControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


LargeContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlElementNames..::.LargeContentPresenterName Field
FluidContentControlElementNames Class See Also Send Feedback
The FluidContentControl large content name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LargeContentPresenterName
Visual Basic (Declaration)
Public Const LargeContentPresenterName As String
Visual C++
public:
literal String^ LargeContentPresenterName

See Also

FluidContentControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


NormalContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlElementNames..::.NormalContentPresenterName Field
FluidContentControlElementNames Class See Also Send Feedback
The FluidContentControl normal content name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string NormalContentPresenterName
Visual Basic (Declaration)
Public Const NormalContentPresenterName As String
Visual C++
public:
literal String^ NormalContentPresenterName

See Also

FluidContentControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SmallContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlElementNames..::.SmallContentPresenterName Field
FluidContentControlElementNames Class See Also Send Feedback
The FluidContentControl small content name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SmallContentPresenterName
Visual Basic (Declaration)
Public Const SmallContentPresenterName As String
Visual C++
public:
literal String^ SmallContentPresenterName

See Also

FluidContentControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


FluidContentControlState Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
FluidContentControlState Enumeration
See Also Send Feedback
Represents the FluidContentControl state values.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
[SerializableAttribute]
public enum FluidContentControlState
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration FluidContentControlState
Visual C++
[SerializableAttribute]
public enum class FluidContentControlState

Members

Member name | Description
Small | The 'Small' state of the fluid content control.
Normal | The 'Normal' state of the fluid content control.
Large | The 'Large' state of the fluid content control.

See Also

Telerik.WebAii.Controls.Xaml Namespace


GridViewAggregateResultCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight AggregateResultCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewAggregateResultCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewAggregateResultCell _
    Inherits ContentControl
Visual C++
public ref class GridViewAggregateResultCell : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewAggregateResultCell

See Also

GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewAggregateResultCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell Members
GridViewAggregateResultCell Class Constructors Methods Properties See Also Send Feedback

The GridViewAggregateResultCell type exposes the following members.

Constructors

Name | Description
GridViewAggregateResultCell | Initializes a new instance of the GridViewAggregateResultCell class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView AggregateResultCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AggregateName | Gets the aggregate name.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewAggregateResultCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewAggregateResultCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell Constructor
GridViewAggregateResultCell Class See Also Send Feedback
Initializes a new instance of the GridViewAggregateResultCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewAggregateResultCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewAggregateResultCell()

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewAggregateResultCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell Methods
GridViewAggregateResultCell Class See Also Send Feedback

The GridViewAggregateResultCell type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView AggregateResultCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.AnySibling Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.GetProperty Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.GetRectangle Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.Highlight Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.InitializeMappings Method
GridViewAggregateResultCell Class See Also Send Feedback
Initializes the mapping of the GridView AggregateResultCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.InvokeMethod Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.NextSibling Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.Parent Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.PreviousSibling Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.ScrollToVisible Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewAggregateResultCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell Properties
GridViewAggregateResultCell Class See Also Send Feedback

The GridViewAggregateResultCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AggregateName | Gets the aggregate name.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewAggregateResultCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.AggregateName Property
GridViewAggregateResultCell Class See Also Send Feedback
Gets the aggregate name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string AggregateName { get; set; }
Visual Basic (Declaration)
Public Property AggregateName As String
Visual C++
public:
property String^ AggregateName {
    String^ get ();
    void set (String^ value);
}

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewAggregateResultCell..::.XamlTag Property
GridViewAggregateResultCell Class See Also Send Feedback
Get the xaml tag of the GridViewAggregateResultCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewAggregateResultCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewCell : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewCell _
    Inherits FrameworkElement
Visual C++
public ref class GridViewCell : public FrameworkElement

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewCell

See Also

GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell Members
GridViewCell Class Constructors Methods Properties See Also Send Feedback

The GridViewCell type exposes the following members.

Constructors

Name | Description
GridViewCell | Initializes a new instance of the GridViewCell class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridViewCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Checkbox | Get the CheckBox in the AlignmentContentPresenter.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ComboBoxEditor | Get the CheckBox in the AlignmentContentPresenter.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
HyperLinkButton | Get the HyperlinkButton in the AlignmentContentPresenter.
Image | Get the Image in the AlignmentContentPresenter.
Index | Get the index of the cell.
IsContentValid | Gets whether the GridViewCell content is valid.
IsCurrent | Gets whether the GridViewCell is current.
IsEditable | Gets or sets a value indicating whether the cells of the column are editable.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInEditMode | Gets whether the GridViewCell is in edit mode.
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the cell text.
TextBlockEditor | Get the TextBlock in the AlignmentContentPresenter.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | Gets the GridViewCell value.
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell Constructor
GridViewCell Class See Also Send Feedback
Initializes a new instance of the GridViewCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewCell()

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell Methods
GridViewCell Class See Also Send Feedback

The GridViewCell type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridViewCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.AnySibling Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.GetProperty Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.GetRectangle Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Highlight Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.InitializeMappings Method
GridViewCell Class See Also Send Feedback
Initializes the mapping of the GridViewCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.InvokeMethod Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.NextSibling Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Parent Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.PreviousSibling Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.ScrollToVisible Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell Properties
GridViewCell Class See Also Send Feedback

The GridViewCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Checkbox | Get the CheckBox in the AlignmentContentPresenter.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ComboBoxEditor | Get the CheckBox in the AlignmentContentPresenter.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
HyperLinkButton | Get the HyperlinkButton in the AlignmentContentPresenter.
Image | Get the Image in the AlignmentContentPresenter.
Index | Get the index of the cell.
IsContentValid | Gets whether the GridViewCell content is valid.
IsCurrent | Gets whether the GridViewCell is current.
IsEditable | Gets or sets a value indicating whether the cells of the column are editable.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInEditMode | Gets whether the GridViewCell is in edit mode.
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the cell text.
TextBlockEditor | Get the TextBlock in the AlignmentContentPresenter.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | Gets the GridViewCell value.
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


Checkbox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Checkbox Property
GridViewCell Class See Also Send Feedback
Get the CheckBox in the AlignmentContentPresenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CheckBox Checkbox { get; }
Visual Basic (Declaration)
Public ReadOnly Property Checkbox As CheckBox
Visual C++
public:
property CheckBox^ Checkbox {
    CheckBox^ get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


ComboBoxEditor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.ComboBoxEditor Property
GridViewCell Class See Also Send Feedback
Get the CheckBox in the AlignmentContentPresenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ComboBox ComboBoxEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property ComboBoxEditor As ComboBox
Visual C++
public:
property ComboBox^ ComboBoxEditor {
    ComboBox^ get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


HyperLinkButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.HyperLinkButton Property
GridViewCell Class See Also Send Feedback
Get the HyperlinkButton in the AlignmentContentPresenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public HyperlinkButton HyperLinkButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property HyperLinkButton As HyperlinkButton
Visual C++
public:
property HyperlinkButton^ HyperLinkButton {
    HyperlinkButton^ get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


Image Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Image Property
GridViewCell Class See Also Send Feedback
Get the Image in the AlignmentContentPresenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Index Property
GridViewCell Class See Also Send Feedback
Get the index of the cell.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


IsContentValid Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.IsContentValid Property
GridViewCell Class See Also Send Feedback
Gets whether the GridViewCell content is valid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsContentValid { get; set; }
Visual Basic (Declaration)
Public Property IsContentValid As Boolean
Visual C++
public:
property bool IsContentValid {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


IsCurrent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.IsCurrent Property
GridViewCell Class See Also Send Feedback
Gets whether the GridViewCell is current.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsCurrent { get; set; }
Visual Basic (Declaration)
Public Property IsCurrent As Boolean
Visual C++
public:
property bool IsCurrent {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


IsEditable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.IsEditable Property
GridViewCell Class See Also Send Feedback
Gets or sets a value indicating whether the cells of the column are editable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic (Declaration)
Public Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


IsInEditMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.IsInEditMode Property
GridViewCell Class See Also Send Feedback
Gets whether the GridViewCell is in edit mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsInEditMode { get; set; }
Visual Basic (Declaration)
Public Property IsInEditMode As Boolean
Visual C++
public:
property bool IsInEditMode {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Text Property
GridViewCell Class See Also Send Feedback
Get the cell text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlockEditor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.TextBlockEditor Property
GridViewCell Class See Also Send Feedback
Get the TextBlock in the AlignmentContentPresenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlockEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlockEditor As TextBlock
Visual C++
public:
property TextBlock^ TextBlockEditor {
    TextBlock^ get ();
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


Value Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.Value Property
GridViewCell Class See Also Send Feedback
Gets the GridViewCell value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewCell..::.XamlTag Property
GridViewCell Class See Also Send Feedback
Get the xaml tag of the GridViewCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewFooterCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewFooterCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewFooterCell _
    Inherits ContentControl
Visual C++
public ref class GridViewFooterCell : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewFooterCell

See Also

GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell Members
GridViewFooterCell Class Constructors Methods Properties See Also Send Feedback

The GridViewFooterCell type exposes the following members.

Constructors

Name | Description
GridViewFooterCell | Initializes a new instance of the GridViewFooterCell class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView FooterCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AggregateResultList | Gets the aggregare results list.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the header cell text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewFooterCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell Constructor
GridViewFooterCell Class See Also Send Feedback
Initializes a new instance of the GridViewFooterCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewFooterCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewFooterCell()

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell Methods
GridViewFooterCell Class See Also Send Feedback

The GridViewFooterCell type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView FooterCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.AnySibling Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.GetProperty Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.GetRectangle Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.Highlight Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.InitializeMappings Method
GridViewFooterCell Class See Also Send Feedback
Initializes the mapping of the GridView FooterCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.InvokeMethod Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.NextSibling Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.Parent Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.PreviousSibling Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.ScrollToVisible Method
GridViewFooterCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
GridViewFooterCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell Properties
GridViewFooterCell Class See Also Send Feedback

The GridViewFooterCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AggregateResultList | Gets the aggregare results list.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the header cell text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewFooterCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.AggregateResultList Property
GridViewFooterCell Class See Also Send Feedback
Gets the aggregare results list.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AggregateResultsList AggregateResultList { get; }
Visual Basic (Declaration)
Public ReadOnly Property AggregateResultList As AggregateResultsList
Visual C++
public:
property AggregateResultsList^ AggregateResultList {
    AggregateResultsList^ get ();
}

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.Text Property
GridViewFooterCell Class See Also Send Feedback
Get the header cell text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterCell..::.XamlTag Property
GridViewFooterCell Class See Also Send Feedback
Get the xaml tag of the GridViewFooterCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewFooterCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterRow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewFooterRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewFooterRow : ContentControl
Visual Basic (Declaration)
Public Class GridViewFooterRow _
    Inherits ContentControl
Visual C++
public ref class GridViewFooterRow : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewFooterRow

See Also

GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterRow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow Members
GridViewFooterRow Class Constructors Methods Properties See Also Send Feedback

The GridViewFooterRow type exposes the following members.

Constructors

Name | Description
GridViewFooterRow | Initializes a new instance of the GridViewFooterRow class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView FooterRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
FooterCells | Get the list of GridViewFooterRow children.
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewFooterRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterRow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow Constructor
GridViewFooterRow Class See Also Send Feedback
Initializes a new instance of the GridViewFooterRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewFooterRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewFooterRow()

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterRow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow Methods
GridViewFooterRow Class See Also Send Feedback

The GridViewFooterRow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView FooterRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.AnySibling Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.AssignReference Method
GridViewFooterRow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewFooterRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.GetProperty Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.GetRectangle Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.Highlight Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.InitializeMappings Method
GridViewFooterRow Class See Also Send Feedback
Initializes the mapping of the GridView FooterRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.InvokeMethod Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.NextSibling Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.Parent Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.PreviousSibling Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.ScrollToVisible Method
GridViewFooterRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
GridViewFooterRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterRow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow Properties
GridViewFooterRow Class See Also Send Feedback

The GridViewFooterRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
FooterCells | Get the list of GridViewFooterRow children.
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewFooterRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


FooterCells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.FooterCells Property
GridViewFooterRow Class See Also Send Feedback
Get the list of GridViewFooterRow children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewFooterCell> FooterCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property FooterCells As IList(Of GridViewFooterCell)
Visual C++
public:
property IList<GridViewFooterCell^>^ FooterCells {
    IList<GridViewFooterCell^>^ get ();
}

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewFooterRow..::.XamlTag Property
GridViewFooterRow Class See Also Send Feedback
Get the xaml tag of the GridViewFooterRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewFooterRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanel Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupPanel control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewGroupPanel : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewGroupPanel _
    Inherits FrameworkElement
Visual C++
public ref class GridViewGroupPanel : public FrameworkElement

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewGroupPanel

See Also

GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanel Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel Members
GridViewGroupPanel Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupPanel type exposes the following members.

Constructors

Name | Description
GridViewGroupPanel | Initializes a new instance of the GridViewGroupPanel class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupPanel control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of group panel items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the group panel text block.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupPanel control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanel Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel Constructor
GridViewGroupPanel Class See Also Send Feedback
Initializes a new instance of the GridViewGroupPanel class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewGroupPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupPanel()

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanel Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel Methods
GridViewGroupPanel Class See Also Send Feedback

The GridViewGroupPanel type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupPanel control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.AnySibling Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.AssignReference Method
GridViewGroupPanel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.GetProperty Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.GetRectangle Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.Highlight Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.InitializeMappings Method
GridViewGroupPanel Class See Also Send Feedback
Initializes the mapping of the GridView GroupPanel control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.InvokeMethod Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.NextSibling Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.Parent Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.PreviousSibling Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.ScrollToVisible Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanel Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel Properties
GridViewGroupPanel Class See Also Send Feedback

The GridViewGroupPanel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of group panel items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the group panel text block.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupPanel control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.Items Property
GridViewGroupPanel Class See Also Send Feedback
Gets the list of group panel items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewGroupPanelItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of GridViewGroupPanelItem)
Visual C++
public:
property IList<GridViewGroupPanelItem^>^ Items {
    IList<GridViewGroupPanelItem^>^ get ();
}

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.Text Property
GridViewGroupPanel Class See Also Send Feedback
Get the group panel text block.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanel..::.XamlTag Property
GridViewGroupPanel Class See Also Send Feedback
Get the xaml tag of the GridViewGroupPanel control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupPanel Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupPanelCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewGroupPanelCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewGroupPanelCell _
    Inherits ContentControl
Visual C++
public ref class GridViewGroupPanelCell : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewGroupPanelCell

See Also

GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell Members
GridViewGroupPanelCell Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupPanelCell type exposes the following members.

Constructors

Name | Description
GridViewGroupPanelCell | Initializes a new instance of the GridViewGroupPanelCell class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Simulate user clicking on the group panel cell close button.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupPanelCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupPanelCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell Constructor
GridViewGroupPanelCell Class See Also Send Feedback
Initializes a new instance of the GridViewGroupPanelCell class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewGroupPanelCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupPanelCell()

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell Methods
GridViewGroupPanelCell Class See Also Send Feedback

The GridViewGroupPanelCell type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Simulate user clicking on the group panel cell close button.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupPanelCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.AnySibling Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.AssignReference Method
GridViewGroupPanelCell Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelCell.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.Close Method
GridViewGroupPanelCell Class See Also Send Feedback
Simulate user clicking on the group panel cell close button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.GetProperty Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.GetRectangle Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.Highlight Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.InitializeMappings Method
GridViewGroupPanelCell Class See Also Send Feedback
Initializes the mapping of the GridView GroupPanelCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.InvokeMethod Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.NextSibling Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.Parent Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.PreviousSibling Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.ScrollToVisible Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell Properties
GridViewGroupPanelCell Class See Also Send Feedback

The GridViewGroupPanelCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupPanelCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelCell..::.XamlTag Property
GridViewGroupPanelCell Class See Also Send Feedback
Get the xaml tag of the GridViewGroupPanelCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupPanelCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupPanelItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewGroupPanelItem : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewGroupPanelItem _
    Inherits FrameworkElement
Visual C++
public ref class GridViewGroupPanelItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewGroupPanelItem

See Also

GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem Members
GridViewGroupPanelItem Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupPanelItem type exposes the following members.

Constructors

Name | Description
GridViewGroupPanelItem | Initializes a new instance of the GridViewGroupPanelItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Closes group panel item.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupPanelItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Cells | Gets the list of group panel items.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ConnectingLineOpacity | Gets or sets the connecting line opacity.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
InsertionPointVisibility | Gets or sets the insertion point visibility.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupPanelItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem Constructor
GridViewGroupPanelItem Class See Also Send Feedback
Initializes a new instance of the GridViewGroupPanelItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewGroupPanelItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupPanelItem()

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem Methods
GridViewGroupPanelItem Class See Also Send Feedback

The GridViewGroupPanelItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Closes group panel item.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupPanelItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.AnySibling Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.Close Method
GridViewGroupPanelItem Class See Also Send Feedback
Closes group panel item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.GetProperty Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.GetRectangle Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.Highlight Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.InitializeMappings Method
GridViewGroupPanelItem Class See Also Send Feedback
Initializes the mapping of the GridView GroupPanelItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.InvokeMethod Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.NextSibling Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.Parent Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.PreviousSibling Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.ScrollToVisible Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem Properties
GridViewGroupPanelItem Class See Also Send Feedback

The GridViewGroupPanelItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Cells | Gets the list of group panel items.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ConnectingLineOpacity | Gets or sets the connecting line opacity.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
InsertionPointVisibility | Gets or sets the insertion point visibility.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupPanelItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


Cells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.Cells Property
GridViewGroupPanelItem Class See Also Send Feedback
Gets the list of group panel items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewGroupPanelCell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of GridViewGroupPanelCell)
Visual C++
public:
property IList<GridViewGroupPanelCell^>^ Cells {
    IList<GridViewGroupPanelCell^>^ get ();
}

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


ConnectingLineOpacity Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.ConnectingLineOpacity Property
GridViewGroupPanelItem Class See Also Send Feedback
Gets or sets the connecting line opacity.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double ConnectingLineOpacity { get; set; }
Visual Basic (Declaration)
Public Property ConnectingLineOpacity As Double
Visual C++
public:
property double ConnectingLineOpacity {
    double get ();
    void set (double value);
}

Field Value

The connecting line opacity.

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


InsertionPointVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.InsertionPointVisibility Property
GridViewGroupPanelItem Class See Also Send Feedback
Gets or sets the insertion point visibility.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility InsertionPointVisibility { get; set; }
Visual Basic (Declaration)
Public Property InsertionPointVisibility As Visibility
Visual C++
public:
property Visibility InsertionPointVisibility {
    Visibility get ();
    void set (Visibility value);
}

Field Value

The insertion point visibility.

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupPanelItem..::.XamlTag Property
GridViewGroupPanelItem Class See Also Send Feedback
Get the xaml tag of the GridViewGroupPanelItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupPanelItem Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupRow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewGroupRow : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewGroupRow _
    Inherits FrameworkElement
Visual C++
public ref class GridViewGroupRow : public FrameworkElement

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewGroupRow

See Also

GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupRow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow Members
GridViewGroupRow Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupRow type exposes the following members.

Constructors

Name | Description
GridViewGroupRow | Initializes a new instance of the GridViewGroupRow class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Collapse | Collapse this group.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this group.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this group.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
GroupRows | Get the list of group rows.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsExpanded | Gets whether the GridViewGroupRow is expanded.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Rows | Get the list of rows.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupRow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow Constructor
GridViewGroupRow Class See Also Send Feedback
Initializes a new instance of the GridViewGroupRow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewGroupRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupRow()

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupRow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow Methods
GridViewGroupRow Class See Also Send Feedback

The GridViewGroupRow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Collapse | Collapse this group.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this group.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView GroupRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this group.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.AnySibling Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Collapse Method
GridViewGroupRow Class See Also Send Feedback
Collapse this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Expand Method
GridViewGroupRow Class See Also Send Feedback
Expand this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.GetProperty Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.GetRectangle Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Highlight Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.InitializeMappings Method
GridViewGroupRow Class See Also Send Feedback
Initializes the mapping of the GridView GroupRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.InvokeMethod Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.NextSibling Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Parent Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.PreviousSibling Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.ScrollToVisible Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members
Telerik.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Toggle Method
GridViewGroupRow Class See Also Send Feedback
Toggles (expands/collapses) this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupRow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow Properties
GridViewGroupRow Class See Also Send Feedback

The GridViewGroupRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
GroupRows | Get the list of group rows.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsExpanded | Gets whether the GridViewGroupRow is expanded.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Rows | Get the list of rows.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewGroupRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


GroupRows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.GroupRows Property
GridViewGroupRow Class See Also Send Feedback
Get the list of group rows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewGroupRow> GroupRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupRows As IList(Of GridViewGroupRow)
Visual C++
public:
property IList<GridViewGroupRow^>^ GroupRows {
    IList<GridViewGroupRow^>^ get ();
}

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Index Property
GridViewGroupRow Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.IsExpanded Property
GridViewGroupRow Class See Also Send Feedback
Gets whether the GridViewGroupRow is expanded.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


Rows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.Rows Property
GridViewGroupRow Class See Also Send Feedback
Get the list of rows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewRow> Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of GridViewRow)
Visual C++
public:
property IList<GridViewRow^>^ Rows {
    IList<GridViewRow^>^ get ();
}

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewGroupRow..::.XamlTag Property
GridViewGroupRow Class See Also Send Feedback
Get the xaml tag of the GridViewGroupRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewHeaderCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewHeaderCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewHeaderCell _
    Inherits ContentControl
Visual C++
public ref class GridViewHeaderCell : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewHeaderCell

See Also

GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell Members
GridViewHeaderCell Class Constructors Methods Properties See Also Send Feedback

The GridViewHeaderCell type exposes the following members.

Constructors

Name | Description
GridViewHeaderCell | Initializes a new instance of the GridViewHeaderCell class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToGroupPanel | Overloaded.
DragToHeaderGripper | Drag the header cell to the header cell thumb with the given thumb name.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView HeaderCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resize | Resizes the header cell thumb.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftHeaderGripper | Get the left header gripper of the cell.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightHeaderGripper | Get the right header gripper of the cell.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the header cell text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewHeaderCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell Constructor
GridViewHeaderCell Class See Also Send Feedback
Initializes a new instance of the GridViewHeaderCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewHeaderCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewHeaderCell()

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell Methods
GridViewHeaderCell Class See Also Send Feedback

The GridViewHeaderCell type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToGroupPanel | Overloaded.
DragToHeaderGripper | Drag the header cell to the header cell thumb with the given thumb name.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView HeaderCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resize | Resizes the header cell thumb.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.AnySibling Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


DragToGroupPanel Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.DragToGroupPanel Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
DragToGroupPanel()()() | Drag the header cell to the grouppanel.
DragToGroupPanel(FrameworkElement) | Drag the header cell to the given group panel element.

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


DragToGroupPanel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.DragToGroupPanel Method
GridViewHeaderCell Class See Also Send Feedback
Drag the header cell to the grouppanel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToGroupPanel()
Visual Basic (Declaration)
Public Sub DragToGroupPanel
Visual C++
public:
void DragToGroupPanel()

See Also

GridViewHeaderCell Class
DragToGroupPanel Overload
Telerik.WebAii.Controls.Xaml Namespace


DragToGroupPanel Method (FrameworkElement)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.DragToGroupPanel Method (FrameworkElement)
GridViewHeaderCell Class See Also Send Feedback
Drag the header cell to the given group panel element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToGroupPanel(
    FrameworkElement groupPanel
)
Visual Basic (Declaration)
Public Sub DragToGroupPanel ( _
    groupPanel As FrameworkElement _
)
Visual C++
public:
void DragToGroupPanel(
    FrameworkElement^ groupPanel
)

Parameters

groupPanel
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement

[Missing <param name="groupPanel"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToGroupPanel(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

GridViewHeaderCell Class
DragToGroupPanel Overload
Telerik.WebAii.Controls.Xaml Namespace


DragToHeaderGripper Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.DragToHeaderGripper Method
GridViewHeaderCell Class See Also Send Feedback
Drag the header cell to the header cell thumb with the given thumb name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToHeaderGripper(
    int headerCellIndexTarget,
    HeaderCellThumbName thumbName
)
Visual Basic (Declaration)
Public Sub DragToHeaderGripper ( _
    headerCellIndexTarget As Integer, _
    thumbName As HeaderCellThumbName _
)
Visual C++
public:
void DragToHeaderGripper(
    int headerCellIndexTarget,
    HeaderCellThumbName thumbName
)

Parameters

headerCellIndexTarget
Type: System..::.Int32
The index of the header cell to drag to.
thumbName
Type: Telerik.WebAii.Controls.Xaml..::.HeaderCellThumbName
The thumb name.

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.GetProperty Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.GetRectangle Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.Highlight Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.InitializeMappings Method
GridViewHeaderCell Class See Also Send Feedback
Initializes the mapping of the GridView HeaderCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.InvokeMethod Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.NextSibling Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.Parent Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.PreviousSibling Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


Resize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.Resize Method
GridViewHeaderCell Class See Also Send Feedback
Resizes the header cell thumb.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resize(
    int widthOffset
)
Visual Basic (Declaration)
Public Sub Resize ( _
    widthOffset As Integer _
)
Visual C++
public:
void Resize(
    int widthOffset
)

Parameters

widthOffset
Type: System..::.Int32
Use value smaller than the header cell's width to resize to left and greater -- to right.

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.ScrollToVisible Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell Properties
GridViewHeaderCell Class See Also Send Feedback

The GridViewHeaderCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftHeaderGripper | Get the left header gripper of the cell.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightHeaderGripper | Get the right header gripper of the cell.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the header cell text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewHeaderCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


LeftHeaderGripper Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.LeftHeaderGripper Property
GridViewHeaderCell Class See Also Send Feedback
Get the left header gripper of the cell.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Thumb LeftHeaderGripper { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftHeaderGripper As Thumb
Visual C++
public:
property Thumb^ LeftHeaderGripper {
    Thumb^ get ();
}

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


RightHeaderGripper Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.RightHeaderGripper Property
GridViewHeaderCell Class See Also Send Feedback
Get the right header gripper of the cell.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Thumb RightHeaderGripper { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightHeaderGripper As Thumb
Visual C++
public:
property Thumb^ RightHeaderGripper {
    Thumb^ get ();
}

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.Text Property
GridViewHeaderCell Class See Also Send Feedback
Get the header cell text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderCell..::.XamlTag Property
GridViewHeaderCell Class See Also Send Feedback
Get the xaml tag of the GridViewHeaderCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewHeaderCell Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderRow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewHeaderRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewHeaderRow : ItemsControl
Visual Basic (Declaration)
Public Class GridViewHeaderRow _
    Inherits ItemsControl
Visual C++
public ref class GridViewHeaderRow : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewHeaderRow

See Also

GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderRow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow Members
GridViewHeaderRow Class Constructors Methods Properties See Also Send Feedback

The GridViewHeaderRow type exposes the following members.

Constructors

Name | Description
GridViewHeaderRow | Initializes a new instance of the GridViewHeaderRow class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragHeaderCellToGroupPanel | Drag the header cell with the given index to the grouppanel.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView HeaderRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCells | Get the list of HeaderCells.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewHeaderRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderRow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow Constructor
GridViewHeaderRow Class See Also Send Feedback
Initializes a new instance of the GridViewHeaderRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewHeaderRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewHeaderRow()

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderRow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow Methods
GridViewHeaderRow Class See Also Send Feedback

The GridViewHeaderRow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragHeaderCellToGroupPanel | Drag the header cell with the given index to the grouppanel.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView HeaderRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.AnySibling Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.AssignReference Method
GridViewHeaderRow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


DragHeaderCellToGroupPanel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.DragHeaderCellToGroupPanel Method
GridViewHeaderRow Class See Also Send Feedback
Drag the header cell with the given index to the grouppanel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragHeaderCellToGroupPanel(
    int cellIndex
)
Visual Basic (Declaration)
Public Sub DragHeaderCellToGroupPanel ( _
    cellIndex As Integer _
)
Visual C++
public:
void DragHeaderCellToGroupPanel(
    int cellIndex
)

Parameters

cellIndex
Type: System..::.Int32
The index of the header cell being dragged.

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.GetProperty Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.GetRectangle Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.Highlight Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.InitializeMappings Method
GridViewHeaderRow Class See Also Send Feedback
Initializes the mapping of the GridView HeaderRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.InvokeMethod Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.NextSibling Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.Parent Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.PreviousSibling Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.ScrollToVisible Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderRow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow Properties
GridViewHeaderRow Class See Also Send Feedback

The GridViewHeaderRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCells | Get the list of HeaderCells.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewHeaderRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderCells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.HeaderCells Property
GridViewHeaderRow Class See Also Send Feedback
Get the list of HeaderCells.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewHeaderCell> HeaderCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderCells As IList(Of GridViewHeaderCell)
Visual C++
public:
property IList<GridViewHeaderCell^>^ HeaderCells {
    IList<GridViewHeaderCell^>^ get ();
}

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewHeaderRow..::.XamlTag Property
GridViewHeaderRow Class See Also Send Feedback
Get the xaml tag of the GridViewHeaderRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewHeaderRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewNewRow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewNewRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewNewRow : ItemsControl
Visual Basic (Declaration)
Public Class GridViewNewRow _
    Inherits ItemsControl
Visual C++
public ref class GridViewNewRow : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewNewRow

See Also

GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewNewRow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow Members
GridViewNewRow Class Constructors Methods Properties See Also Send Feedback

The GridViewNewRow type exposes the following members.

Constructors

Name | Description
GridViewNewRow | Initializes a new instance of the GridViewNewRow class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
CommitNewRow | Commits the edit of the new row.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView NewRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | Get the list of GridViewNewRow children.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewNewRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewNewRow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow Constructor
GridViewNewRow Class See Also Send Feedback
Initializes a new instance of the GridViewNewRow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewNewRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewNewRow()

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewNewRow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow Methods
GridViewNewRow Class See Also Send Feedback

The GridViewNewRow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
CommitNewRow | Commits the edit of the new row.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView NewRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.AnySibling Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.AssignReference Method
GridViewNewRow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewNewRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


CommitNewRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.CommitNewRow Method
GridViewNewRow Class See Also Send Feedback
Commits the edit of the new row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CommitNewRow(
    string userInput
)
Visual Basic (Declaration)
Public Sub CommitNewRow ( _
    userInput As String _
)
Visual C++
public:
void CommitNewRow(
    String^ userInput
)

Parameters

userInput
Type: System..::.String

[Missing <param name="userInput"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewNewRow.CommitNewRow(System.String)"]

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.GetProperty Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.GetRectangle Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.Highlight Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.InitializeMappings Method
GridViewNewRow Class See Also Send Feedback
Initializes the mapping of the GridView NewRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.InvokeMethod Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.NextSibling Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.Parent Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.PreviousSibling Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.ScrollToVisible Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewNewRow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow Properties
GridViewNewRow Class See Also Send Feedback

The GridViewNewRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | Get the list of GridViewNewRow children.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewNewRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


Cells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.Cells Property
GridViewNewRow Class See Also Send Feedback
Get the list of GridViewNewRow children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewCell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of GridViewCell)
Visual C++
public:
property IList<GridViewCell^>^ Cells {
    IList<GridViewCell^>^ get ();
}

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewNewRow..::.XamlTag Property
GridViewNewRow Class See Also Send Feedback
Get the xaml tag of the GridViewNewRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewNewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewRow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class GridViewRow : ItemsControl
Visual Basic (Declaration)
Public Class GridViewRow _
    Inherits ItemsControl
Visual C++
public ref class GridViewRow : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewRow

See Also

GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


GridViewRow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow Members
GridViewRow Class Constructors Methods Properties See Also Send Feedback

The GridViewRow type exposes the following members.

Constructors

Name | Description
GridViewRow | Initializes a new instance of the GridViewRow class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Collapse | Collapse this parent row.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this parent row.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridViewRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this parent row.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | Get the list of GridViewRow children.
ChildGridView | Get the Child GridView.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DataContext | Gets GridViewRow DataContext.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
GridViewToggleButton | Get the GridViewToggleButton.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsCurrent | Gets whether the GridViewRow is current.
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Gets whether the GridViewRow is expanded.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the GridViewRow is selected.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewRow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow Constructor
GridViewRow Class See Also Send Feedback
Initializes a new instance of the GridViewRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewRow()

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewRow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow Methods
GridViewRow Class See Also Send Feedback

The GridViewRow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Collapse | Collapse this parent row.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this parent row.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridViewRow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this parent row.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.AnySibling Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.AssignReference Method
GridViewRow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Collapse Method
GridViewRow Class See Also Send Feedback
Collapse this parent row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Expand Method
GridViewRow Class See Also Send Feedback
Expand this parent row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.GetProperty Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.GetRectangle Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Highlight Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.InitializeMappings Method
GridViewRow Class See Also Send Feedback
Initializes the mapping of the GridViewRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.InvokeMethod Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.MouseClick Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType, Int32, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.MouseClick Method (MouseClickType, Int32, Int32)
GridViewRow Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    int index
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    index As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    int index
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.
index
Type: System..::.Int32
The index of the cell.

See Also

GridViewRow Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32, Boolean, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.MouseClick Method (MouseClickType, Int32, Boolean, Int32)
GridViewRow Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft,
    int index
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean, _
    index As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft,
    int index
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.
index
Type: System..::.Int32
The index of the cell.

See Also

GridViewRow Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.NextSibling Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Parent Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.PreviousSibling Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.ScrollToVisible Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members
Telerik.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Toggle Method
GridViewRow Class See Also Send Feedback
Toggles (expands/collapses) this parent row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewRow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow Properties
GridViewRow Class See Also Send Feedback

The GridViewRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | Get the list of GridViewRow children.
ChildGridView | Get the Child GridView.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DataContext | Gets GridViewRow DataContext.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
GridViewToggleButton | Get the GridViewToggleButton.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsCurrent | Gets whether the GridViewRow is current.
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Gets whether the GridViewRow is expanded.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the GridViewRow is selected.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the GridViewRow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


Cells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Cells Property
GridViewRow Class See Also Send Feedback
Get the list of GridViewRow children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewCell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of GridViewCell)
Visual C++
public:
property IList<GridViewCell^>^ Cells {
    IList<GridViewCell^>^ get ();
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


ChildGridView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.ChildGridView Property
GridViewRow Class See Also Send Feedback
Get the Child GridView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGridView ChildGridView { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildGridView As RadGridView
Visual C++
public:
property RadGridView^ ChildGridView {
    RadGridView^ get ();
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


DataContext Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.DataContext Property
GridViewRow Class See Also Send Feedback
Gets GridViewRow DataContext.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Object DataContext { get; set; }
Visual Basic (Declaration)
Public Property DataContext As Object
Visual C++
public:
property Object^ DataContext {
    Object^ get ();
    void set (Object^ value);
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewToggleButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.GridViewToggleButton Property
GridViewRow Class See Also Send Feedback
Get the GridViewToggleButton.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToggleButton GridViewToggleButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property GridViewToggleButton As ToggleButton
Visual C++
public:
property ToggleButton^ GridViewToggleButton {
    ToggleButton^ get ();
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.Index Property
GridViewRow Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


IsCurrent Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.IsCurrent Property
GridViewRow Class See Also Send Feedback
Gets whether the GridViewRow is current.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsCurrent { get; set; }
Visual Basic (Declaration)
Public Property IsCurrent As Boolean
Visual C++
public:
property bool IsCurrent {
    bool get ();
    void set (bool value);
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.IsExpanded Property
GridViewRow Class See Also Send Feedback
Gets whether the GridViewRow is expanded.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.IsSelected Property
GridViewRow Class See Also Send Feedback
Gets whether the GridViewRow is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
GridViewRow..::.XamlTag Property
GridViewRow Class See Also Send Feedback
Get the xaml tag of the GridViewRow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewRow Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderCellThumbName Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
HeaderCellThumbName Enumeration
See Also Send Feedback
Enumerates the HeaderCell thumbs user interacts with.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum HeaderCellThumbName
Visual Basic (Declaration)
Public Enumeration HeaderCellThumbName
Visual C++
public enum class HeaderCellThumbName

Members

Member name | Description
LeftThumb | The left header gripper thumb.
RightThumb | The right header gripper thumb.

See Also

Telerik.WebAii.Controls.Xaml Namespace


MediaPlayerElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames Class
Members See Also Send Feedback
Represents the MediaPlayer important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class MediaPlayerElementNames
Visual Basic (Declaration)
Public NotInheritable Class MediaPlayerElementNames
Visual C++
public ref class MediaPlayerElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.MediaPlayerElementNames

See Also

MediaPlayerElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


MediaPlayerElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames Members
MediaPlayerElementNames Class Fields See Also Send Feedback

The MediaPlayerElementNames type exposes the following members.

Fields

Name | Description
BottomPartGridName | The MediaPlayer bottom part Grid holding the control panel name.
ChaptersPresenterContainerName | The MediaPlayer chapters presenter container name.
ChaptersPresenterName | The MediaPlayer chapters presenter name.
FullScreenButtonName | The MediaPlayer full screen button name.
MediaElementName | The MediaPlayer media element name.
MediaItemPlayButtonName | The MediaItem play button name.
MuteButtonName | The MediaPlayer mute button name.
NextChapterButtonName | The MediaPlayer next chapter button name.
PlayButtonName | The MediaPlayer play button name.
PlaylistButtonName | The MediaPlayer playlist button name.
PlaylistPresenterName | The MediaPlayer Playlist presenter name.
PlaylistScrollContentPresenterName | The PlaylistPresenter scroll content presenter name.
PlaylistVerticalRootName | The PlaylistPresenter vertical root element name.
PlaylistVerticalScrollBarName | The PlaylistPresenter vertical scroll bar name.
PlaylistVerticalSmallDecreaseButtonName | The PlaylistPresenter vertical small decrease button name.
PlaylistVerticalSmallIncreaseButtonName | The PlaylistPresenter vertical small increase button name.
PreviousChapterButtonName | The MediaPlayer previous chapter button name.
StopButtonName | The MediaPlayer stop button name.
TimeSliderName | The MediaPlayer time slider name.
VolumeSliderName | The MediaPlayer volume slider name.

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MediaPlayerElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames Fields
MediaPlayerElementNames Class See Also Send Feedback

The MediaPlayerElementNames type exposes the following members.

Fields

Name | Description
BottomPartGridName | The MediaPlayer bottom part Grid holding the control panel name.
ChaptersPresenterContainerName | The MediaPlayer chapters presenter container name.
ChaptersPresenterName | The MediaPlayer chapters presenter name.
FullScreenButtonName | The MediaPlayer full screen button name.
MediaElementName | The MediaPlayer media element name.
MediaItemPlayButtonName | The MediaItem play button name.
MuteButtonName | The MediaPlayer mute button name.
NextChapterButtonName | The MediaPlayer next chapter button name.
PlayButtonName | The MediaPlayer play button name.
PlaylistButtonName | The MediaPlayer playlist button name.
PlaylistPresenterName | The MediaPlayer Playlist presenter name.
PlaylistScrollContentPresenterName | The PlaylistPresenter scroll content presenter name.
PlaylistVerticalRootName | The PlaylistPresenter vertical root element name.
PlaylistVerticalScrollBarName | The PlaylistPresenter vertical scroll bar name.
PlaylistVerticalSmallDecreaseButtonName | The PlaylistPresenter vertical small decrease button name.
PlaylistVerticalSmallIncreaseButtonName | The PlaylistPresenter vertical small increase button name.
PreviousChapterButtonName | The MediaPlayer previous chapter button name.
StopButtonName | The MediaPlayer stop button name.
TimeSliderName | The MediaPlayer time slider name.
VolumeSliderName | The MediaPlayer volume slider name.

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


BottomPartGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.BottomPartGridName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer bottom part Grid holding the control panel name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BottomPartGridName
Visual Basic (Declaration)
Public Const BottomPartGridName As String
Visual C++
public:
literal String^ BottomPartGridName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ChaptersPresenterContainerName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.ChaptersPresenterContainerName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer chapters presenter container name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChaptersPresenterContainerName
Visual Basic (Declaration)
Public Const ChaptersPresenterContainerName As String
Visual C++
public:
literal String^ ChaptersPresenterContainerName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ChaptersPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.ChaptersPresenterName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer chapters presenter name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChaptersPresenterName
Visual Basic (Declaration)
Public Const ChaptersPresenterName As String
Visual C++
public:
literal String^ ChaptersPresenterName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


FullScreenButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.FullScreenButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer full screen button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FullScreenButtonName
Visual Basic (Declaration)
Public Const FullScreenButtonName As String
Visual C++
public:
literal String^ FullScreenButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MediaElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.MediaElementName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer media element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MediaElementName
Visual Basic (Declaration)
Public Const MediaElementName As String
Visual C++
public:
literal String^ MediaElementName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MediaItemPlayButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.MediaItemPlayButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaItem play button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MediaItemPlayButtonName
Visual Basic (Declaration)
Public Const MediaItemPlayButtonName As String
Visual C++
public:
literal String^ MediaItemPlayButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MuteButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.MuteButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer mute button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MuteButtonName
Visual Basic (Declaration)
Public Const MuteButtonName As String
Visual C++
public:
literal String^ MuteButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


NextChapterButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.NextChapterButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer next chapter button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string NextChapterButtonName
Visual Basic (Declaration)
Public Const NextChapterButtonName As String
Visual C++
public:
literal String^ NextChapterButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlayButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlayButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer play button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlayButtonName
Visual Basic (Declaration)
Public Const PlayButtonName As String
Visual C++
public:
literal String^ PlayButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer playlist button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistButtonName
Visual Basic (Declaration)
Public Const PlaylistButtonName As String
Visual C++
public:
literal String^ PlaylistButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistPresenterName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer Playlist presenter name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistPresenterName
Visual Basic (Declaration)
Public Const PlaylistPresenterName As String
Visual C++
public:
literal String^ PlaylistPresenterName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistScrollContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistScrollContentPresenterName Field
MediaPlayerElementNames Class See Also Send Feedback
The PlaylistPresenter scroll content presenter name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistScrollContentPresenterName
Visual Basic (Declaration)
Public Const PlaylistScrollContentPresenterName As String
Visual C++
public:
literal String^ PlaylistScrollContentPresenterName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistVerticalRootName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistVerticalRootName Field
MediaPlayerElementNames Class See Also Send Feedback
The PlaylistPresenter vertical root element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistVerticalRootName
Visual Basic (Declaration)
Public Const PlaylistVerticalRootName As String
Visual C++
public:
literal String^ PlaylistVerticalRootName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistVerticalScrollBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistVerticalScrollBarName Field
MediaPlayerElementNames Class See Also Send Feedback
The PlaylistPresenter vertical scroll bar name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistVerticalScrollBarName
Visual Basic (Declaration)
Public Const PlaylistVerticalScrollBarName As String
Visual C++
public:
literal String^ PlaylistVerticalScrollBarName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistVerticalSmallDecreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistVerticalSmallDecreaseButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The PlaylistPresenter vertical small decrease button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistVerticalSmallDecreaseButtonName
Visual Basic (Declaration)
Public Const PlaylistVerticalSmallDecreaseButtonName As String
Visual C++
public:
literal String^ PlaylistVerticalSmallDecreaseButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistVerticalSmallIncreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PlaylistVerticalSmallIncreaseButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The PlaylistPresenter vertical small increase button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistVerticalSmallIncreaseButtonName
Visual Basic (Declaration)
Public Const PlaylistVerticalSmallIncreaseButtonName As String
Visual C++
public:
literal String^ PlaylistVerticalSmallIncreaseButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PreviousChapterButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.PreviousChapterButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer previous chapter button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PreviousChapterButtonName
Visual Basic (Declaration)
Public Const PreviousChapterButtonName As String
Visual C++
public:
literal String^ PreviousChapterButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


StopButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.StopButtonName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer stop button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StopButtonName
Visual Basic (Declaration)
Public Const StopButtonName As String
Visual C++
public:
literal String^ StopButtonName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSliderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.TimeSliderName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer time slider name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSliderName
Visual Basic (Declaration)
Public Const TimeSliderName As String
Visual C++
public:
literal String^ TimeSliderName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VolumeSliderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MediaPlayerElementNames..::.VolumeSliderName Field
MediaPlayerElementNames Class See Also Send Feedback
The MediaPlayer volume slider name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VolumeSliderName
Visual Basic (Declaration)
Public Const VolumeSliderName As String
Visual C++
public:
literal String^ VolumeSliderName

See Also

MediaPlayerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea Class
Members See Also Send Feedback
Represents the Silverlight MinimizedOutlookBarArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class MinimizedOutlookBarArea : ListBox
Visual Basic (Declaration)
Public Class MinimizedOutlookBarArea _
    Inherits ListBox
Visual C++
public ref class MinimizedOutlookBarArea : public ListBox

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBox
Telerik.WebAii.Controls.Xaml..::.MinimizedOutlookBarArea

See Also

MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea Members
MinimizedOutlookBarArea Class Constructors Methods Properties See Also Send Feedback

The MinimizedOutlookBarArea type exposes the following members.

Constructors

Name | Description
MinimizedOutlookBarArea | Initializes a new instance of the MinimizedOutlookBarArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the MinimizedOutlookBarArea control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBox.)
BorderBrush | (Inherited from ListBox.)
BorderThickness | (Inherited from ListBox.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ListBox.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBox.)
FontSize | (Inherited from ListBox.)
FontStretch | (Inherited from ListBox.)
FontStyle | (Inherited from ListBox.)
FontWeight | (Inherited from ListBox.)
Foreground | (Inherited from ListBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ListBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | (Inherited from ListBox.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedItems | Gets the list of the root MinimizedOutlookBarItem elements.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from ListBox.)
TabIndex | (Inherited from ListBox.)
TabNavigation | (Inherited from ListBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinimizedOutlookBarArea control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea Constructor
MinimizedOutlookBarArea Class See Also Send Feedback
Initializes a new instance of the MinimizedOutlookBarArea class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public MinimizedOutlookBarArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MinimizedOutlookBarArea()

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea Methods
MinimizedOutlookBarArea Class See Also Send Feedback

The MinimizedOutlookBarArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the MinimizedOutlookBarArea control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.AnySibling Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.AssignReference Method
MinimizedOutlookBarArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.MinimizedOutlookBarArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.GetProperty Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.GetRectangle Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.Highlight Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.InitializeMappings Method
MinimizedOutlookBarArea Class See Also Send Feedback
Initializes the mapping of the MinimizedOutlookBarArea control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.InvokeMethod Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.NextSibling Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.Parent Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.PreviousSibling Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.ScrollToVisible Method
MinimizedOutlookBarArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
MinimizedOutlookBarArea Members
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea Properties
MinimizedOutlookBarArea Class See Also Send Feedback

The MinimizedOutlookBarArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBox.)
BorderBrush | (Inherited from ListBox.)
BorderThickness | (Inherited from ListBox.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ListBox.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBox.)
FontSize | (Inherited from ListBox.)
FontStretch | (Inherited from ListBox.)
FontStyle | (Inherited from ListBox.)
FontWeight | (Inherited from ListBox.)
Foreground | (Inherited from ListBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ListBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | (Inherited from ListBox.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedItems | Gets the list of the root MinimizedOutlookBarItem elements.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from ListBox.)
TabIndex | (Inherited from ListBox.)
TabNavigation | (Inherited from ListBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinimizedOutlookBarArea control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.MinimizedItems Property
MinimizedOutlookBarArea Class See Also Send Feedback
Gets the list of the root MinimizedOutlookBarItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<MinimizedOutlookBarItem> MinimizedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinimizedItems As IList(Of MinimizedOutlookBarItem)
Visual C++
public:
property IList<MinimizedOutlookBarItem^>^ MinimizedItems {
    IList<MinimizedOutlookBarItem^>^ get ();
}

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarArea..::.XamlTag Property
MinimizedOutlookBarArea Class See Also Send Feedback
Get the xaml tag of MinimizedOutlookBarArea control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

MinimizedOutlookBarArea Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem Class
Members See Also Send Feedback
Represents the Silverlight MinimizedOutlookBarItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class MinimizedOutlookBarItem : ListBoxItem
Visual Basic (Declaration)
Public Class MinimizedOutlookBarItem _
    Inherits ListBoxItem
Visual C++
public ref class MinimizedOutlookBarItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBoxItem
Telerik.WebAii.Controls.Xaml..::.MinimizedOutlookBarItem

See Also

MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem Members
MinimizedOutlookBarItem Class Constructors Methods Properties See Also Send Feedback

The MinimizedOutlookBarItem type exposes the following members.

Constructors

Name | Description
MinimizedOutlookBarItem | Initializes a new instance of the MinimizedOutlookBarItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the MinimizedOutlookBarItemKey control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Selects the item refreshing the OutlookBar content as well.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinimizedOutlookBarItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem Constructor
MinimizedOutlookBarItem Class See Also Send Feedback
Initializes a new instance of the MinimizedOutlookBarItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public MinimizedOutlookBarItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MinimizedOutlookBarItem()

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem Methods
MinimizedOutlookBarItem Class See Also Send Feedback

The MinimizedOutlookBarItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the MinimizedOutlookBarItemKey control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Selects the item refreshing the OutlookBar content as well.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.AnySibling Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.GetProperty Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.GetRectangle Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.Highlight Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.InitializeMappings Method
MinimizedOutlookBarItem Class See Also Send Feedback
Initializes the mapping of the MinimizedOutlookBarItemKey control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.InvokeMethod Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.NextSibling Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.Parent Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.PreviousSibling Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.ScrollToVisible Method
MinimizedOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
MinimizedOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.Select Method
MinimizedOutlookBarItem Class See Also Send Feedback
Selects the item refreshing the OutlookBar content as well.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem Properties
MinimizedOutlookBarItem Class See Also Send Feedback

The MinimizedOutlookBarItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MinimizedOutlookBarItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.ItemIndex Property
MinimizedOutlookBarItem Class See Also Send Feedback
Get the item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
MinimizedOutlookBarItem..::.XamlTag Property
MinimizedOutlookBarItem Class See Also Send Feedback
Get the xaml tag of MinimizedOutlookBarItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

MinimizedOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


NumericUpDownElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
NumericUpDownElementNames Class
Members See Also Send Feedback
Represents a list of control sub elements names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class NumericUpDownElementNames
Visual Basic (Declaration)
Public NotInheritable Class NumericUpDownElementNames
Visual C++
public ref class NumericUpDownElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.NumericUpDownElementNames

See Also

NumericUpDownElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


NumericUpDownElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
NumericUpDownElementNames Members
NumericUpDownElementNames Class Fields See Also Send Feedback

The NumericUpDownElementNames type exposes the following members.

Fields

Name | Description
DecreaseButtonName | The Numeric spin down button name.
IncreaseButtonName | The Numeric spin up button name.

See Also

NumericUpDownElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


NumericUpDownElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
NumericUpDownElementNames Fields
NumericUpDownElementNames Class See Also Send Feedback

The NumericUpDownElementNames type exposes the following members.

Fields

Name | Description
DecreaseButtonName | The Numeric spin down button name.
IncreaseButtonName | The Numeric spin up button name.

See Also

NumericUpDownElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DecreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
NumericUpDownElementNames..::.DecreaseButtonName Field
NumericUpDownElementNames Class See Also Send Feedback
The Numeric spin down button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DecreaseButtonName
Visual Basic (Declaration)
Public Const DecreaseButtonName As String
Visual C++
public:
literal String^ DecreaseButtonName

See Also

NumericUpDownElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


IncreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
NumericUpDownElementNames..::.IncreaseButtonName Field
NumericUpDownElementNames Class See Also Send Feedback
The Numeric spin up button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string IncreaseButtonName
Visual Basic (Declaration)
Public Const IncreaseButtonName As String
Visual C++
public:
literal String^ IncreaseButtonName

See Also

NumericUpDownElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


OutlookBarElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames Class
Members See Also Send Feedback
Represents the OutlookBar important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class OutlookBarElementNames
Visual Basic (Declaration)
Public NotInheritable Class OutlookBarElementNames
Visual C++
public ref class OutlookBarElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.OutlookBarElementNames

See Also

OutlookBarElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


OutlookBarElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames Members
OutlookBarElementNames Class Fields See Also Send Feedback

The OutlookBarElementNames type exposes the following members.

Fields

Name | Description
HeaderContentControlName | The OutlookBar header content control element name.
HorizontalSplitterThumbName | The OutlookBar horizontal splitter thumb name.
ItemsPresenterName | The OutlookBar items presenter element name.
MinimizedAreaControlName | The OutlookBar minimized are control name.

See Also

OutlookBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


OutlookBarElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames Fields
OutlookBarElementNames Class See Also Send Feedback

The OutlookBarElementNames type exposes the following members.

Fields

Name | Description
HeaderContentControlName | The OutlookBar header content control element name.
HorizontalSplitterThumbName | The OutlookBar horizontal splitter thumb name.
ItemsPresenterName | The OutlookBar items presenter element name.
MinimizedAreaControlName | The OutlookBar minimized are control name.

See Also

OutlookBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderContentControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames..::.HeaderContentControlName Field
OutlookBarElementNames Class See Also Send Feedback
The OutlookBar header content control element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HeaderContentControlName
Visual Basic (Declaration)
Public Const HeaderContentControlName As String
Visual C++
public:
literal String^ HeaderContentControlName

See Also

OutlookBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalSplitterThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames..::.HorizontalSplitterThumbName Field
OutlookBarElementNames Class See Also Send Feedback
The OutlookBar horizontal splitter thumb name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalSplitterThumbName
Visual Basic (Declaration)
Public Const HorizontalSplitterThumbName As String
Visual C++
public:
literal String^ HorizontalSplitterThumbName

See Also

OutlookBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemsPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames..::.ItemsPresenterName Field
OutlookBarElementNames Class See Also Send Feedback
The OutlookBar items presenter element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemsPresenterName
Visual Basic (Declaration)
Public Const ItemsPresenterName As String
Visual C++
public:
literal String^ ItemsPresenterName

See Also

OutlookBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedAreaControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
OutlookBarElementNames..::.MinimizedAreaControlName Field
OutlookBarElementNames Class See Also Send Feedback
The OutlookBar minimized are control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MinimizedAreaControlName
Visual Basic (Declaration)
Public Const MinimizedAreaControlName As String
Visual C++
public:
literal String^ MinimizedAreaControlName

See Also

OutlookBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeader Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight PaneHeader control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class PaneHeader : ContentControl
Visual Basic (Declaration)
Public Class PaneHeader _
    Inherits ContentControl
Visual C++
public ref class PaneHeader : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.PaneHeader

See Also

PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


PaneHeader Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader Members
PaneHeader Class Constructors Methods Properties See Also Send Feedback

The PaneHeader type exposes the following members.

Constructors

Name | Description
PaneHeader | Initializes a new instance of the PaneHeader class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button in the header.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking PaneHeader control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleCommandButton | Simulates user clicking on the commands toggle button to open/close the context menu.
TogglePin | Simulates user clicking on the pin button in the header to pin/unpin the pane.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseButtonVisibility | Get the close button visibility value.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsCommandButtonChecked | Get whether the commands toggle button is checked (the command menu is open).
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PinButtonVisibility | Get the pin button visibility value.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the docking pane header control.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane header control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeader Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader Constructor
PaneHeader Class See Also Send Feedback
Initializes a new instance of the PaneHeader class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PaneHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaneHeader()

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeader Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader Methods
PaneHeader Class See Also Send Feedback

The PaneHeader type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button in the header.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking PaneHeader control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleCommandButton | Simulates user clicking on the commands toggle button to open/close the context menu.
TogglePin | Simulates user clicking on the pin button in the header to pin/unpin the pane.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.AnySibling Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.Close Method
PaneHeader Class See Also Send Feedback
Simulates user clicking on the close button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Remarks

Use PaneGroup.HeaderClose() if the pain group content will be checked afterwards.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the close button is not visible.

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.GetProperty Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.GetRectangle Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.Highlight Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.InitializeMappings Method
PaneHeader Class See Also Send Feedback
Initializes the mapping of the RadDocking PaneHeader control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.InvokeMethod Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.NextSibling Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.Parent Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.PreviousSibling Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.ScrollToVisible Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members
Telerik.WebAii.Controls.Xaml Namespace


ToggleCommandButton Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.ToggleCommandButton Method
PaneHeader Class See Also Send Feedback
Simulates user clicking on the commands toggle button to open/close the context menu.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleCommandButton()
Visual Basic (Declaration)
Public Sub ToggleCommandButton
Visual C++
public:
void ToggleCommandButton()

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


TogglePin Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.TogglePin Method
PaneHeader Class See Also Send Feedback
Simulates user clicking on the pin button in the header to pin/unpin the pane.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePin()
Visual Basic (Declaration)
Public Sub TogglePin
Visual C++
public:
void TogglePin()

Remarks

Use PaneGroup.HeaderClose() if the pain group content will be checked afterwards.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the pin button is not visible.

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeader Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader Properties
PaneHeader Class See Also Send Feedback

The PaneHeader type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseButtonVisibility | Get the close button visibility value.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsCommandButtonChecked | Get whether the commands toggle button is checked (the command menu is open).
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PinButtonVisibility | Get the pin button visibility value.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the docking pane header control.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane header control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


CloseButtonVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.CloseButtonVisibility Property
PaneHeader Class See Also Send Feedback
Get the close button visibility value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility CloseButtonVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property CloseButtonVisibility As Visibility
Visual C++
public:
property Visibility CloseButtonVisibility {
    Visibility get ();
}

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


IsCommandButtonChecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.IsCommandButtonChecked Property
PaneHeader Class See Also Send Feedback
Get whether the commands toggle button is checked (the command menu is open).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsCommandButtonChecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCommandButtonChecked As Boolean
Visual C++
public:
property bool IsCommandButtonChecked {
    bool get ();
}

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


PinButtonVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.PinButtonVisibility Property
PaneHeader Class See Also Send Feedback
Get the pin button visibility value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility PinButtonVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property PinButtonVisibility As Visibility
Visual C++
public:
property Visibility PinButtonVisibility {
    Visibility get ();
}

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.Title Property
PaneHeader Class See Also Send Feedback
Get the title of the docking pane header control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PaneHeader..::.XamlTag Property
PaneHeader Class See Also Send Feedback
Get the xaml tag of the pane header control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

PaneHeader Class
Telerik.WebAii.Controls.Xaml Namespace


PanelBarElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarElementNames Class
Members See Also Send Feedback
Represents the PanelBar/PanelBarItem important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class PanelBarElementNames
Visual Basic (Declaration)
Public NotInheritable Class PanelBarElementNames
Visual C++
public ref class PanelBarElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.PanelBarElementNames

See Also

PanelBarElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


PanelBarElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarElementNames Members
PanelBarElementNames Class Fields See Also Send Feedback

The PanelBarElementNames type exposes the following members.

Fields

Name | Description
ItemHeaderContentPresenterName | The PanelBarItem header content presenter name.
ItemHeaderRowName | The PanelBarItem header row name.
ItemsContainerName | The PanelBarItem items container name.

See Also

PanelBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PanelBarElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarElementNames Fields
PanelBarElementNames Class See Also Send Feedback

The PanelBarElementNames type exposes the following members.

Fields

Name | Description
ItemHeaderContentPresenterName | The PanelBarItem header content presenter name.
ItemHeaderRowName | The PanelBarItem header row name.
ItemsContainerName | The PanelBarItem items container name.

See Also

PanelBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemHeaderContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarElementNames..::.ItemHeaderContentPresenterName Field
PanelBarElementNames Class See Also Send Feedback
The PanelBarItem header content presenter name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemHeaderContentPresenterName
Visual Basic (Declaration)
Public Const ItemHeaderContentPresenterName As String
Visual C++
public:
literal String^ ItemHeaderContentPresenterName

See Also

PanelBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemHeaderRowName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarElementNames..::.ItemHeaderRowName Field
PanelBarElementNames Class See Also Send Feedback
The PanelBarItem header row name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemHeaderRowName
Visual Basic (Declaration)
Public Const ItemHeaderRowName As String
Visual C++
public:
literal String^ ItemHeaderRowName

See Also

PanelBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemsContainerName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PanelBarElementNames..::.ItemsContainerName Field
PanelBarElementNames Class See Also Send Feedback
The PanelBarItem items container name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemsContainerName
Visual Basic (Declaration)
Public Const ItemsContainerName As String
Visual C++
public:
literal String^ ItemsContainerName

See Also

PanelBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PickerTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox Class
Members See Also Send Feedback
Represents the PickerTextBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class PickerTextBox : TextBox
Visual Basic (Declaration)
Public Class PickerTextBox _
    Inherits TextBox
Visual C++
public ref class PickerTextBox : public TextBox

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.TextBox
Telerik.WebAii.Controls.Xaml..::.PickerTextBox

See Also

PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


PickerTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox Members
PickerTextBox Class Constructors Methods Properties See Also Send Feedback

The PickerTextBox type exposes the following members.

Constructors

Name | Description
PickerTextBox | Initializes a new instance of the PickerTextBox class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from TextBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the PickerTextBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from TextBox.)
BorderBrush | (Inherited from TextBox.)
BorderThickness | (Inherited from TextBox.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from TextBox.)
FontSize | (Inherited from TextBox.)
FontStretch | (Inherited from TextBox.)
FontStyle | (Inherited from TextBox.)
FontWeight | (Inherited from TextBox.)
Foreground | (Inherited from TextBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from TextBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from TextBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from TextBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from TextBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
TabIndex | (Inherited from TextBox.)
TabNavigation | (Inherited from TextBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TextWrapping | (Inherited from TextBox.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from TextBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PickerTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


PickerTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox Constructor
PickerTextBox Class See Also Send Feedback
Initializes a new instance of the PickerTextBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PickerTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PickerTextBox()

See Also

PickerTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


PickerTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox Methods
PickerTextBox Class See Also Send Feedback

The PickerTextBox type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from TextBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the PickerTextBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.AnySibling Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.GetProperty Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.GetRectangle Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.Highlight Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.InitializeMappings Method
PickerTextBox Class See Also Send Feedback
Initializes the mapping of the PickerTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

PickerTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.InvokeMethod Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.NextSibling Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.Parent Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.PreviousSibling Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.ScrollToVisible Method
PickerTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
PickerTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


PickerTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox Properties
PickerTextBox Class See Also Send Feedback

The PickerTextBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from TextBox.)
BorderBrush | (Inherited from TextBox.)
BorderThickness | (Inherited from TextBox.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from TextBox.)
FontSize | (Inherited from TextBox.)
FontStretch | (Inherited from TextBox.)
FontStyle | (Inherited from TextBox.)
FontWeight | (Inherited from TextBox.)
Foreground | (Inherited from TextBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from TextBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from TextBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from TextBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from TextBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
TabIndex | (Inherited from TextBox.)
TabNavigation | (Inherited from TextBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TextWrapping | (Inherited from TextBox.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from TextBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PickerTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PickerTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerTextBox..::.XamlTag Property
PickerTextBox Class See Also Send Feedback
Get the xaml tag of PickerTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

PickerTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


PickerToggleButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton Class
Members See Also Send Feedback
Represents the Silverlight PickerToggleButton control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class PickerToggleButton : ToggleButton
Visual Basic (Declaration)
Public Class PickerToggleButton _
    Inherits ToggleButton
Visual C++
public ref class PickerToggleButton : public ToggleButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ToggleButton
Telerik.WebAii.Controls.Xaml..::.PickerToggleButton

See Also

PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


PickerToggleButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton Members
PickerToggleButton Class Constructors Methods Properties See Also Send Feedback

The PickerToggleButton type exposes the following members.

Constructors

Name | Description
PickerToggleButton | Initializes a new instance of the PickerToggleButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ToggleButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the PickerToggleButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ToggleButton.)
BorderBrush | (Inherited from ToggleButton.)
BorderThickness | (Inherited from ToggleButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from ToggleButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ToggleButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ToggleButton.)
FontSize | (Inherited from ToggleButton.)
FontStretch | (Inherited from ToggleButton.)
FontStyle | (Inherited from ToggleButton.)
FontWeight | (Inherited from ToggleButton.)
Foreground | (Inherited from ToggleButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ToggleButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ToggleButton.)
IsFocused | (Inherited from ToggleButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from ToggleButton.)
IsPressed | (Inherited from ToggleButton.)
IsTabStop | (Inherited from ToggleButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from ToggleButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ToggleButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ToggleButton.)
TabNavigation | (Inherited from ToggleButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ToggleButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PickerToggleButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


PickerToggleButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton Constructor
PickerToggleButton Class See Also Send Feedback
Initializes a new instance of the PickerToggleButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PickerToggleButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PickerToggleButton()

See Also

PickerToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


PickerToggleButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton Methods
PickerToggleButton Class See Also Send Feedback

The PickerToggleButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ToggleButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the PickerToggleButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.AnySibling Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.GetProperty Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.GetRectangle Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.Highlight Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.InitializeMappings Method
PickerToggleButton Class See Also Send Feedback
Initializes the mapping of the PickerToggleButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

PickerToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.InvokeMethod Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.NextSibling Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.Parent Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.PreviousSibling Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.ScrollToVisible Method
PickerToggleButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
PickerToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


PickerToggleButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton Properties
PickerToggleButton Class See Also Send Feedback

The PickerToggleButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ToggleButton.)
BorderBrush | (Inherited from ToggleButton.)
BorderThickness | (Inherited from ToggleButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from ToggleButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ToggleButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ToggleButton.)
FontSize | (Inherited from ToggleButton.)
FontStretch | (Inherited from ToggleButton.)
FontStyle | (Inherited from ToggleButton.)
FontWeight | (Inherited from ToggleButton.)
Foreground | (Inherited from ToggleButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ToggleButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ToggleButton.)
IsFocused | (Inherited from ToggleButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from ToggleButton.)
IsPressed | (Inherited from ToggleButton.)
IsTabStop | (Inherited from ToggleButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from ToggleButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ToggleButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ToggleButton.)
TabNavigation | (Inherited from ToggleButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ToggleButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PickerToggleButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PickerToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PickerToggleButton..::.XamlTag Property
PickerToggleButton Class See Also Send Feedback
Get the xaml tag of PickerToggleButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

PickerToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter Class
Members See Also Send Feedback
Represents the Silverlight MediaPlayer PlaylistPresenter control wrapper. Holds the media item controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class PlaylistPresenter : ContentControl
Visual Basic (Declaration)
Public Class PlaylistPresenter _
    Inherits ContentControl
Visual C++
public ref class PlaylistPresenter : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.PlaylistPresenter

See Also

PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter Members
PlaylistPresenter Class Constructors Methods Properties See Also Send Feedback

The PlaylistPresenter type exposes the following members.

Constructors

Name | Description
PlaylistPresenter | Initializes a new instance of the PlaylistPresenter class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the PlaylistPresenter control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Starts playing the media item with given index.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollDown | Simulates user clicking on the 'vertical small increase' repeat button below the list to scroll it down.
ScrollToVisible | Overloaded.
ScrollUp | Simulates user clicking on the 'vertical small decrease' repeat button above the list to scroll it up.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MediaItems | Get the list of media items for the playlist presenter.
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PlaylistPresenter control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter Constructor
PlaylistPresenter Class See Also Send Feedback
Initializes a new instance of the PlaylistPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PlaylistPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlaylistPresenter()

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter Methods
PlaylistPresenter Class See Also Send Feedback

The PlaylistPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the PlaylistPresenter control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Starts playing the media item with given index.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollDown | Simulates user clicking on the 'vertical small increase' repeat button below the list to scroll it down.
ScrollToVisible | Overloaded.
ScrollUp | Simulates user clicking on the 'vertical small decrease' repeat button above the list to scroll it up.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.AnySibling Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.AssignReference Method
PlaylistPresenter Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.PlaylistPresenter.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.GetProperty Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.GetRectangle Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.Highlight Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.InitializeMappings Method
PlaylistPresenter Class See Also Send Feedback
Initializes the mapping of the PlaylistPresenter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.InvokeMethod Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.NextSibling Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.Parent Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PlayItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.PlayItem Method
PlaylistPresenter Class See Also Send Feedback
Starts playing the media item with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void PlayItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub PlayItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void PlayItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to start playing.

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.PreviousSibling Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.ScrollDown Method
PlaylistPresenter Class See Also Send Feedback
Simulates user clicking on the 'vertical small increase' repeat button below the list to scroll it down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollDown()
Visual Basic (Declaration)
Public Sub ScrollDown
Visual C++
public:
void ScrollDown()

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.ScrollToVisible Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollUp Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.ScrollUp Method
PlaylistPresenter Class See Also Send Feedback
Simulates user clicking on the 'vertical small decrease' repeat button above the list to scroll it up.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollUp()
Visual Basic (Declaration)
Public Sub ScrollUp
Visual C++
public:
void ScrollUp()

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter Properties
PlaylistPresenter Class See Also Send Feedback

The PlaylistPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MediaItems | Get the list of media items for the playlist presenter.
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PlaylistPresenter control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


MediaItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.MediaItems Property
PlaylistPresenter Class See Also Send Feedback
Get the list of media items for the playlist presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMediaItem> MediaItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property MediaItems As IList(Of RadMediaItem)
Visual C++
public:
property IList<RadMediaItem^>^ MediaItems {
    IList<RadMediaItem^>^ get ();
}

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
PlaylistPresenter..::.XamlTag Property
PlaylistPresenter Class See Also Send Feedback
Get the xaml tag of PlaylistPresenter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

PlaylistPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


Position Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
Position Enumeration
See Also Send Feedback
Represents an enumeration of possible positions specific to the control layout.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
[SerializableAttribute]
public enum Position
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration Position
Visual C++
[SerializableAttribute]
public enum class Position

Members

Member name | Description
Top | The 'Top' position.
Bottom | The 'Bottom' position.
Left | The 'Left' position.
Right | The 'Right' position.

See Also

Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar Class
Members See Also Send Feedback
Represents the Silverlight RadRibbonBar's QuickAccessToolBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class QuickAccessToolBar : RadToolBar
Visual Basic (Declaration)
Public Class QuickAccessToolBar _
    Inherits RadToolBar
Visual C++
public ref class QuickAccessToolBar : public RadToolBar

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadToolBar
Telerik.WebAii.Controls.Xaml..::.QuickAccessToolBar

See Also

QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar Members
QuickAccessToolBar Class Constructors Methods Properties See Also Send Feedback

The QuickAccessToolBar type exposes the following members.

Constructors

Name | Description
QuickAccessToolBar | Initializes a new instance of the QuickAccessToolBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Inherited from RadToolBar.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the QuickAccessToolBar control. (Overrides RadToolBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleOverflowDropDown | Opens/closes the overflow drop down. (Inherited from RadToolBar.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
Band | Gets a value indicating on wich Tray's Band the toolbar should be positioned. (Inherited from RadToolBar.)
BandIndex | Gets or sets a value indicating the order in a Tray's Band via automation property. (Inherited from RadToolBar.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButton | Get the quick access toolbar drop down button.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HasOverflowItems | Gets a value indicating whether the Overflow area contains items via automation property. (Inherited from RadToolBar.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsOverflowPopupOpen | Get whether the overflow popup is open. (Inherited from RadToolBar.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of toolbar items. (Inherited from RadToolBar.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the toolbar orientation. (Inherited from RadToolBar.)
OverflowItems | Get the list of overflow items. (Inherited from RadToolBar.)
OverflowPopup | Gets the popup holding the overflow items. (Inherited from RadToolBar.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of QuickAccessToolBar control. (Overrides RadToolBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar Constructor
QuickAccessToolBar Class See Also Send Feedback
Initializes a new instance of the QuickAccessToolBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public QuickAccessToolBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
QuickAccessToolBar()

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar Methods
QuickAccessToolBar Class See Also Send Feedback

The QuickAccessToolBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Inherited from RadToolBar.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the QuickAccessToolBar control. (Overrides RadToolBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleOverflowDropDown | Opens/closes the overflow drop down. (Inherited from RadToolBar.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.AnySibling Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.GetProperty Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.GetRectangle Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.Highlight Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.InitializeMappings Method
QuickAccessToolBar Class See Also Send Feedback
Initializes the mapping of the QuickAccessToolBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.InvokeMethod Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.NextSibling Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.Parent Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.PreviousSibling Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.ScrollToVisible Method
QuickAccessToolBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
QuickAccessToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar Properties
QuickAccessToolBar Class See Also Send Feedback

The QuickAccessToolBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
Band | Gets a value indicating on wich Tray's Band the toolbar should be positioned. (Inherited from RadToolBar.)
BandIndex | Gets or sets a value indicating the order in a Tray's Band via automation property. (Inherited from RadToolBar.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButton | Get the quick access toolbar drop down button.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HasOverflowItems | Gets a value indicating whether the Overflow area contains items via automation property. (Inherited from RadToolBar.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsOverflowPopupOpen | Get whether the overflow popup is open. (Inherited from RadToolBar.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of toolbar items. (Inherited from RadToolBar.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the toolbar orientation. (Inherited from RadToolBar.)
OverflowItems | Get the list of overflow items. (Inherited from RadToolBar.)
OverflowPopup | Gets the popup holding the overflow items. (Inherited from RadToolBar.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of QuickAccessToolBar control. (Overrides RadToolBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.DropDownButton Property
QuickAccessToolBar Class See Also Send Feedback
Get the quick access toolbar drop down button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonDropDownButton DropDownButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownButton As RadRibbonDropDownButton
Visual C++
public:
property RadRibbonDropDownButton^ DropDownButton {
    RadRibbonDropDownButton^ get ();
}

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
QuickAccessToolBar..::.XamlTag Property
QuickAccessToolBar Class See Also Send Feedback
Get the xaml tag of QuickAccessToolBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

QuickAccessToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadBook Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook Class
Members See Also Send Feedback
Represents the Silverlight RadBook wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadBook : ItemsControl
Visual Basic (Declaration)
Public Class RadBook _
    Inherits ItemsControl
Visual C++
public ref class RadBook : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadBook

See Also

RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


RadBook Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook Members
RadBook Class Constructors Methods Properties See Also Send Feedback

The RadBook type exposes the following members.

Constructors

Name | Description
RadBook | Initializes a new instance of the RadBook class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadBook control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TurnPage | Overloaded.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BookItems | Gets the list of all the RadBookItem elements.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsKeyboardNavigationEnabled | Gets or sets whether the keyboard can be used to navigate through the pages of the book.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftPageItem | Get the RadBookItem currently available on the left page.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightPageItem | Get the RadBookItem currently available on the right page.
ShadowsVisibility | Gets or sets the shadows visibility.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadBook control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


RadBook Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook Constructor
RadBook Class See Also Send Feedback
Initializes a new instance of the RadBook class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadBook()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadBook()

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


RadBook Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook Methods
RadBook Class See Also Send Feedback

The RadBook type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadBook control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TurnPage | Overloaded.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.AnySibling Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.AssignReference Method
RadBook Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadBook.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.GetProperty Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.GetRectangle Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.Highlight Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.InitializeMappings Method
RadBook Class See Also Send Feedback
Initializes the mapping of the RadBook control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.InvokeMethod Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.NextSibling Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.Parent Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.PreviousSibling Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.ScrollToVisible Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


TurnPage Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.TurnPage Method
RadBook Class See Also Send Feedback

Overload List

Name | Description
TurnPage(TurnPagePosition) | Turns the book page from the given corner position. Performs that with default offset (from the corner) value.
TurnPage(TurnPagePosition, Int32) | Turns the book page from the given corner position by dragging with the given offset.

See Also

RadBook Class
RadBook Members
Telerik.WebAii.Controls.Xaml Namespace


TurnPage Method (TurnPagePosition)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.TurnPage Method (TurnPagePosition)
RadBook Class See Also Send Feedback
Turns the book page from the given corner position. Performs that with default offset (from the corner) value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TurnPage(
    TurnPagePosition position
)
Visual Basic (Declaration)
Public Sub TurnPage ( _
    position As TurnPagePosition _
)
Visual C++
public:
void TurnPage(
    TurnPagePosition position
)

Parameters

position
Type: Telerik.WebAii.Controls.Xaml..::.TurnPagePosition
The Book turn page position - Left or Right, Top or Bottom.

See Also

RadBook Class
TurnPage Overload
Telerik.WebAii.Controls.Xaml Namespace


TurnPage Method (TurnPagePosition, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.TurnPage Method (TurnPagePosition, Int32)
RadBook Class See Also Send Feedback
Turns the book page from the given corner position by dragging with the given offset.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TurnPage(
    TurnPagePosition position,
    int offset
)
Visual Basic (Declaration)
Public Sub TurnPage ( _
    position As TurnPagePosition, _
    offset As Integer _
)
Visual C++
public:
void TurnPage(
    TurnPagePosition position,
    int offset
)

Parameters

position
Type: Telerik.WebAii.Controls.Xaml..::.TurnPagePosition
The Book turn page position - Left or Right, Top or Bottom.
offset
Type: System..::.Int32
The offset in pixels to drag from the corner.

See Also

RadBook Class
TurnPage Overload
Telerik.WebAii.Controls.Xaml Namespace


RadBook Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook Properties
RadBook Class See Also Send Feedback

The RadBook type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BookItems | Gets the list of all the RadBookItem elements.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsKeyboardNavigationEnabled | Gets or sets whether the keyboard can be used to navigate through the pages of the book.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftPageItem | Get the RadBookItem currently available on the left page.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightPageItem | Get the RadBookItem currently available on the right page.
ShadowsVisibility | Gets or sets the shadows visibility.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadBook control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


BookItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.BookItems Property
RadBook Class See Also Send Feedback
Gets the list of all the RadBookItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadBookItem> BookItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookItems As IList(Of RadBookItem)
Visual C++
public:
property IList<RadBookItem^>^ BookItems {
    IList<RadBookItem^>^ get ();
}

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


IsKeyboardNavigationEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.IsKeyboardNavigationEnabled Property
RadBook Class See Also Send Feedback
Gets or sets whether the keyboard can be used to navigate through the pages of the book.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsKeyboardNavigationEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsKeyboardNavigationEnabled As Boolean
Visual C++
public:
property bool IsKeyboardNavigationEnabled {
    bool get ();
    void set (bool value);
}

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


LeftPageItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.LeftPageItem Property
RadBook Class See Also Send Feedback
Get the RadBookItem currently available on the left page.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadBookItem LeftPageItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftPageItem As RadBookItem
Visual C++
public:
property RadBookItem^ LeftPageItem {
    RadBookItem^ get ();
}

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


RightPageItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.RightPageItem Property
RadBook Class See Also Send Feedback
Get the RadBookItem currently available on the right page.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadBookItem RightPageItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightPageItem As RadBookItem
Visual C++
public:
property RadBookItem^ RightPageItem {
    RadBookItem^ get ();
}

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


ShadowsVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.ShadowsVisibility Property
RadBook Class See Also Send Feedback
Gets or sets the shadows visibility.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility ShadowsVisibility { get; set; }
Visual Basic (Declaration)
Public Property ShadowsVisibility As Visibility
Visual C++
public:
property Visibility ShadowsVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBook..::.XamlTag Property
RadBook Class See Also Send Feedback
Get the xaml tag of RadBook control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadBook Class
Telerik.WebAii.Controls.Xaml Namespace


RadBookItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem Class
Members See Also Send Feedback
Represents the Silverlight RadBookItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadBookItem : ContentControl
Visual Basic (Declaration)
Public Class RadBookItem _
    Inherits ContentControl
Visual C++
public ref class RadBookItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadBookItem

See Also

RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadBookItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem Members
RadBookItem Class Constructors Methods Properties See Also Send Feedback

The RadBookItem type exposes the following members.

Constructors

Name | Description
RadBookItem | Initializes a new instance of the RadBookItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadBookItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the book item index.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadBookItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadBookItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem Constructor
RadBookItem Class See Also Send Feedback
Initializes a new instance of the RadBookItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadBookItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadBookItem()

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadBookItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem Methods
RadBookItem Class See Also Send Feedback

The RadBookItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadBookItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.AnySibling Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.GetProperty Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.GetRectangle Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.Highlight Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.InitializeMappings Method
RadBookItem Class See Also Send Feedback
Initializes the mapping of the RadBookItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.InvokeMethod Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.NextSibling Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.Parent Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.PreviousSibling Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.ScrollToVisible Method
RadBookItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadBookItem Class
RadBookItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadBookItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem Properties
RadBookItem Class See Also Send Feedback

The RadBookItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the book item index.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadBookItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.Index Property
RadBookItem Class See Also Send Feedback
Get the book item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadBookItem..::.XamlTag Property
RadBookItem Class See Also Send Feedback
Get the xaml tag of RadBookItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadBookItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton Class
Members See Also Send Feedback
Represents the RadButton for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadButton : Button
Visual Basic (Declaration)
Public Class RadButton _
    Inherits Button
Visual C++
public ref class RadButton : public Button

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Button
Telerik.WebAii.Controls.Xaml..::.RadButton
Telerik.WebAii.Controls.Xaml..::.RadDropDownButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonButton

See Also

RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton Members
RadButton Class Constructors Methods Properties See Also Send Feedback

The RadButton type exposes the following members.

Constructors

Name | Description
RadButton | Initializes a new instance of the RadButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton Constructor
RadButton Class See Also Send Feedback
Initializes a new instance of the RadButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadButton()

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton Methods
RadButton Class See Also Send Feedback

The RadButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.AnySibling Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.GetProperty Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.GetRectangle Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.Highlight Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.InitializeMappings Method
RadButton Class See Also Send Feedback
Initializes the mapping of the RadButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.InvokeMethod Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.NextSibling Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.Parent Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.PreviousSibling Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.ScrollToVisible Method
RadButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton Properties
RadButton Class See Also Send Feedback

The RadButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.Text Property
RadButton Class See Also Send Feedback
Get the text of the button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadButton..::.XamlTag Property
RadButton Class See Also Send Feedback
Get the xaml tag of RadButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadCalendar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Class
Members See Also Send Feedback
The class represents the RadCalendar Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadCalendar : Control
Visual Basic (Declaration)
Public Class RadCalendar _
    Inherits Control
Visual C++
public ref class RadCalendar : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadCalendar

See Also

RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


RadCalendar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Members
RadCalendar Class Constructors Methods Properties See Also Send Feedback

The RadCalendar type exposes the following members.

Constructors

Name | Description
RadCalendar | Initializes a new instance of the RadCalendar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the 'move left' repeat button.
ScrollRight | Simulates user clicking on the 'move right' repeat button.
ScrollToVisible | Overloaded.
SelectDay | Overloaded.
SelectDayRange | Overloaded.
SelectDecade | Overloaded.
SelectMonth | Overloaded.
SelectYear | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
ViewUp | Simulates user clicking on the calendar title to change the current view: Months -> Years -> Decades -> Centuries; refreshes the Calendar.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CalendarViews | Get the list of the current calendar views.
CanViewUp | Get whether the header button is enabled so that the user can click it and up the view: Months -> Years -> Decade -> Century.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMode | Get the current Calendar display mode -- Month, Year, Decade or Century.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HeaderButton | Gets the header button used to change view up to year, decade, century.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MoveLeftButton | Gets the navigate to left repeat button.
MoveRightButton | Gets the navigate to right repeat button.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedDate | Get the latest calendar selected date.
SelectedDates | Get the list of calendar selected dates.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Gets the title of the calendar.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadCalendar. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


RadCalendar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Constructor
RadCalendar Class See Also Send Feedback
Initializes a new instance of the RadCalendar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCalendar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCalendar()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


RadCalendar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Methods
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCalendar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the 'move left' repeat button.
ScrollRight | Simulates user clicking on the 'move right' repeat button.
ScrollToVisible | Overloaded.
SelectDay | Overloaded.
SelectDayRange | Overloaded.
SelectDecade | Overloaded.
SelectMonth | Overloaded.
SelectYear | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
ViewUp | Simulates user clicking on the calendar title to change the current view: Months -> Years -> Decades -> Centuries; refreshes the Calendar.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.AnySibling Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.AssignReference Method
RadCalendar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadCalendar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.GetProperty Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.GetRectangle Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Highlight Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.InitializeMappings Method
RadCalendar Class See Also Send Feedback
Initializes the mapping of the RadCalendar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.InvokeMethod Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.NextSibling Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Parent Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.PreviousSibling Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollLeft Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ScrollLeft Method
RadCalendar Class See Also Send Feedback
Simulates user clicking on the 'move left' repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollLeft()
Visual Basic (Declaration)
Public Sub ScrollLeft
Visual C++
public:
void ScrollLeft()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollRight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ScrollRight Method
RadCalendar Class See Also Send Feedback
Simulates user clicking on the 'move right' repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollRight()
Visual Basic (Declaration)
Public Sub ScrollRight
Visual C++
public:
void ScrollRight()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ScrollToVisible Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDay Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDay Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SelectDay(String) | Selects the day from the month view. Useful in the default case of a single calendar view.
SelectDay(Int32, String) | Selects the day from an month view with the given index.
SelectDay(String, Int32) | Selects the day from the month view. Useful in the default case of a single calendar view.
SelectDay(Int32, String, Int32) | Selects the day from an month view with the given index.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDay Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDay Method (String)
RadCalendar Class See Also Send Feedback
Selects the day from the month view. Useful in the default case of a single calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDay(
    string day
)
Visual Basic (Declaration)
Public Sub SelectDay ( _
    day As String _
)
Visual C++
public:
void SelectDay(
    String^ day
)

Parameters

day
Type: System..::.String
The day to be selected.

See Also

RadCalendar Class
SelectDay Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDay Method (Int32, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDay Method (Int32, String)
RadCalendar Class See Also Send Feedback
Selects the day from an month view with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDay(
    int monthViewIndex,
    string day
)
Visual Basic (Declaration)
Public Sub SelectDay ( _
    monthViewIndex As Integer, _
    day As String _
)
Visual C++
public:
void SelectDay(
    int monthViewIndex,
    String^ day
)

Parameters

monthViewIndex
Type: System..::.Int32
The month view index to select the day from.
day
Type: System..::.String
The day to be selected.

See Also

RadCalendar Class
SelectDay Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDay Method (String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDay Method (String, Int32)
RadCalendar Class See Also Send Feedback
Selects the day from the month view. Useful in the default case of a single calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDay(
    string day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub SelectDay ( _
    day As String, _
    occurrence As Integer _
)
Visual C++
public:
void SelectDay(
    String^ day,
    int occurrence
)

Parameters

day
Type: System..::.String
The day to be selected.
occurrence
Type: System..::.Int32
The occurence of the day.

See Also

RadCalendar Class
SelectDay Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDay Method (Int32, String, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDay Method (Int32, String, Int32)
RadCalendar Class See Also Send Feedback
Selects the day from an month view with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDay(
    int monthViewIndex,
    string day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub SelectDay ( _
    monthViewIndex As Integer, _
    day As String, _
    occurrence As Integer _
)
Visual C++
public:
void SelectDay(
    int monthViewIndex,
    String^ day,
    int occurrence
)

Parameters

monthViewIndex
Type: System..::.Int32
The month view index to select the day from.
day
Type: System..::.String
The day to be selected.
occurrence
Type: System..::.Int32
The occurence of the day.

See Also

RadCalendar Class
SelectDay Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDayRange Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SelectDayRange(String, String) | Simulates user dragging to select the days from the given range in the calendar month view.
SelectDayRange(Int32, String, String) | Simulates user dragging to select the days from the given range in the calendar month view with the given index.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method (String, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDayRange Method (String, String)
RadCalendar Class See Also Send Feedback
Simulates user dragging to select the days from the given range in the calendar month view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDayRange(
    string firstDay,
    string lastDay
)
Visual Basic (Declaration)
Public Sub SelectDayRange ( _
    firstDay As String, _
    lastDay As String _
)
Visual C++
public:
void SelectDayRange(
    String^ firstDay,
    String^ lastDay
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
lastDay
Type: System..::.String
The date to end select from, uses the first occurence.

See Also

RadCalendar Class
SelectDayRange Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDayRange Method (Int32, String, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDayRange Method (Int32, String, String)
RadCalendar Class See Also Send Feedback
Simulates user dragging to select the days from the given range in the calendar month view with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDayRange(
    int monthViewIndex,
    string firstDay,
    string lastDay
)
Visual Basic (Declaration)
Public Sub SelectDayRange ( _
    monthViewIndex As Integer, _
    firstDay As String, _
    lastDay As String _
)
Visual C++
public:
void SelectDayRange(
    int monthViewIndex,
    String^ firstDay,
    String^ lastDay
)

Parameters

monthViewIndex
Type: System..::.Int32
The index of the month view to select from.
firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
lastDay
Type: System..::.String
The date to end select from, uses the first occurence.

See Also

RadCalendar Class
SelectDayRange Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDecade Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDecade Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SelectDecade(String) | Selects the decade from the century view. Useful in the default case of a single calendar view.
SelectDecade(Int32, String) | Selects the decade from a decade view with the given index.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDecade Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDecade Method (String)
RadCalendar Class See Also Send Feedback
Selects the decade from the century view. Useful in the default case of a single calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDecade(
    string decade
)
Visual Basic (Declaration)
Public Sub SelectDecade ( _
    decade As String _
)
Visual C++
public:
void SelectDecade(
    String^ decade
)

Parameters

decade
Type: System..::.String
The decade to be selected.

See Also

RadCalendar Class
SelectDecade Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectDecade Method (Int32, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectDecade Method (Int32, String)
RadCalendar Class See Also Send Feedback
Selects the decade from a decade view with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDecade(
    int centuryViewIndex,
    string decade
)
Visual Basic (Declaration)
Public Sub SelectDecade ( _
    centuryViewIndex As Integer, _
    decade As String _
)
Visual C++
public:
void SelectDecade(
    int centuryViewIndex,
    String^ decade
)

Parameters

centuryViewIndex
Type: System..::.Int32
The century view index to select the decade from.
decade
Type: System..::.String
The decade to be selected.

See Also

RadCalendar Class
SelectDecade Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectMonth Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectMonth Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SelectMonth(String) | Selects the month from the year view. Useful in the default case of a single calendar view.
SelectMonth(Int32, String) | Selects the month from an year view with the given index.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectMonth Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectMonth Method (String)
RadCalendar Class See Also Send Feedback
Selects the month from the year view. Useful in the default case of a single calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectMonth(
    string month
)
Visual Basic (Declaration)
Public Sub SelectMonth ( _
    month As String _
)
Visual C++
public:
void SelectMonth(
    String^ month
)

Parameters

month
Type: System..::.String
The month to be selected.

See Also

RadCalendar Class
SelectMonth Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectMonth Method (Int32, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectMonth Method (Int32, String)
RadCalendar Class See Also Send Feedback
Selects the month from an year view with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectMonth(
    int yearViewIndex,
    string month
)
Visual Basic (Declaration)
Public Sub SelectMonth ( _
    yearViewIndex As Integer, _
    month As String _
)
Visual C++
public:
void SelectMonth(
    int yearViewIndex,
    String^ month
)

Parameters

yearViewIndex
Type: System..::.Int32
The year view index to select the month from.
month
Type: System..::.String
The month to be selected.

See Also

RadCalendar Class
SelectMonth Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectYear Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectYear Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
SelectYear(String) | Selects the year from the decade view. Useful in the default case of a single calendar view.
SelectYear(Int32, String) | Selects the year from a decade view with the given index.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectYear Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectYear Method (String)
RadCalendar Class See Also Send Feedback
Selects the year from the decade view. Useful in the default case of a single calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectYear(
    string year
)
Visual Basic (Declaration)
Public Sub SelectYear ( _
    year As String _
)
Visual C++
public:
void SelectYear(
    String^ year
)

Parameters

year
Type: System..::.String
The year to be selected.

See Also

RadCalendar Class
SelectYear Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectYear Method (Int32, String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectYear Method (Int32, String)
RadCalendar Class See Also Send Feedback
Selects the year from a decade view with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectYear(
    int decadeViewIndex,
    string year
)
Visual Basic (Declaration)
Public Sub SelectYear ( _
    decadeViewIndex As Integer, _
    year As String _
)
Visual C++
public:
void SelectYear(
    int decadeViewIndex,
    String^ year
)

Parameters

decadeViewIndex
Type: System..::.Int32
The decade view index to select the year from.
year
Type: System..::.String
The year to be selected.

See Also

RadCalendar Class
SelectYear Overload
Telerik.WebAii.Controls.Xaml Namespace


ViewUp Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.ViewUp Method
RadCalendar Class See Also Send Feedback
Simulates user clicking on the calendar title to change the current view: Months -> Years -> Decades -> Centuries; refreshes the Calendar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ViewUp()
Visual Basic (Declaration)
Public Sub ViewUp
Visual C++
public:
void ViewUp()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


RadCalendar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar Properties
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CalendarViews | Get the list of the current calendar views.
CanViewUp | Get whether the header button is enabled so that the user can click it and up the view: Months -> Years -> Decade -> Century.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMode | Get the current Calendar display mode -- Month, Year, Decade or Century.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HeaderButton | Gets the header button used to change view up to year, decade, century.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MoveLeftButton | Gets the navigate to left repeat button.
MoveRightButton | Gets the navigate to right repeat button.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedDate | Get the latest calendar selected date.
SelectedDates | Get the list of calendar selected dates.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Gets the title of the calendar.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadCalendar. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarViews Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.CalendarViews Property
RadCalendar Class See Also Send Feedback
Get the list of the current calendar views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<CalendarView> CalendarViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalendarViews As IList(Of CalendarView)
Visual C++
public:
property IList<CalendarView^>^ CalendarViews {
    IList<CalendarView^>^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


CanViewUp Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.CanViewUp Property
RadCalendar Class See Also Send Feedback
Get whether the header button is enabled so that the user can click it and up the view: Months -> Years -> Decade -> Century.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanViewUp { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanViewUp As Boolean
Visual C++
public:
property bool CanViewUp {
    bool get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


DisplayMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.DisplayMode Property
RadCalendar Class See Also Send Feedback
Get the current Calendar display mode -- Month, Year, Decade or Century.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public CalendarDisplayMode DisplayMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayMode As CalendarDisplayMode
Visual C++
public:
property CalendarDisplayMode DisplayMode {
    CalendarDisplayMode get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.HeaderButton Property
RadCalendar Class See Also Send Feedback
Gets the header button used to change view up to year, decade, century.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Button HeaderButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderButton As Button
Visual C++
public:
property Button^ HeaderButton {
    Button^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


MoveLeftButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.MoveLeftButton Property
RadCalendar Class See Also Send Feedback
Gets the navigate to left repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RepeatButton MoveLeftButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveLeftButton As RepeatButton
Visual C++
public:
property RepeatButton^ MoveLeftButton {
    RepeatButton^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


MoveRightButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.MoveRightButton Property
RadCalendar Class See Also Send Feedback
Gets the navigate to right repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RepeatButton MoveRightButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveRightButton As RepeatButton
Visual C++
public:
property RepeatButton^ MoveRightButton {
    RepeatButton^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectedDate Property
RadCalendar Class See Also Send Feedback
Get the latest calendar selected date.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDate As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedDates Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.SelectedDates Property
RadCalendar Class See Also Send Feedback
Get the list of calendar selected dates.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SelectedDatesCollection SelectedDates { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDates As SelectedDatesCollection
Visual C++
public:
property SelectedDatesCollection^ SelectedDates {
    SelectedDatesCollection^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.Title Property
RadCalendar Class See Also Send Feedback
Gets the title of the calendar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCalendar..::.XamlTag Property
RadCalendar Class See Also Send Feedback
The xaml tag of RadCalendar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCalendar Class
Telerik.WebAii.Controls.Xaml Namespace


RadCell Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell Class
Members See Also Send Feedback
Represents the Silverlight TreeListView RadColumn control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadCell : ItemsControl
Visual Basic (Declaration)
Public Class RadCell _
    Inherits ItemsControl
Visual C++
public ref class RadCell : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadCell

See Also

RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


RadCell Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell Members
RadCell Class Constructors Methods Properties See Also Send Feedback

The RadCell type exposes the following members.

Constructors

Name | Description
RadCell | Initializes a new instance of the RadCell class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TreeListView RadCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | Gets the list of the inner cells.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EditPopup | Get the edit popup element.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the cell index.
IsEditable | Gets or sets a value indicating whether the cells of the column are editable.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInEditMode | Gets or sets a value indicating whether this instance is in edit mode.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the cell text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


RadCell Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell Constructor
RadCell Class See Also Send Feedback
Initializes a new instance of the RadCell class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCell()

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


RadCell Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell Methods
RadCell Class See Also Send Feedback

The RadCell type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TreeListView RadCell control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.AnySibling Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.AssignReference Method
RadCell Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadCell.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.GetProperty Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.GetRectangle Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.Highlight Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.InitializeMappings Method
RadCell Class See Also Send Feedback
Initializes the mapping of the TreeListView RadCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.InvokeMethod Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.NextSibling Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.Parent Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.PreviousSibling Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.ScrollToVisible Method
RadCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadCell Class
RadCell Members
Telerik.WebAii.Controls.Xaml Namespace


RadCell Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell Properties
RadCell Class See Also Send Feedback

The RadCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | Gets the list of the inner cells.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EditPopup | Get the edit popup element.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the cell index.
IsEditable | Gets or sets a value indicating whether the cells of the column are editable.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInEditMode | Gets or sets a value indicating whether this instance is in edit mode.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the cell text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCell control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


Cells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.Cells Property
RadCell Class See Also Send Feedback
Gets the list of the inner cells.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadCell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of RadCell)
Visual C++
public:
property IList<RadCell^>^ Cells {
    IList<RadCell^>^ get ();
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


EditPopup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.EditPopup Property
RadCell Class See Also Send Feedback
Get the edit popup element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Popup EditPopup { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditPopup As Popup
Visual C++
public:
property Popup^ EditPopup {
    Popup^ get ();
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.Index Property
RadCell Class See Also Send Feedback
Get the cell index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


IsEditable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.IsEditable Property
RadCell Class See Also Send Feedback
Gets or sets a value indicating whether the cells of the column are editable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic (Declaration)
Public Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


IsInEditMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.IsInEditMode Property
RadCell Class See Also Send Feedback
Gets or sets a value indicating whether this instance is in edit mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsInEditMode { get; set; }
Visual Basic (Declaration)
Public Property IsInEditMode As Boolean
Visual C++
public:
property bool IsInEditMode {
    bool get ();
    void set (bool value);
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.Text Property
RadCell Class See Also Send Feedback
Get the cell text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCell..::.XamlTag Property
RadCell Class See Also Send Feedback
Get the xaml tag of RadCell control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCell Class
Telerik.WebAii.Controls.Xaml Namespace


RadChart Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart Class
Members See Also Send Feedback
Represents the RadChart for Silverlight RadChart control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadChart : ContentControl
Visual Basic (Declaration)
Public Class RadChart _
    Inherits ContentControl
Visual C++
public ref class RadChart : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadChart

See Also

RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


RadChart Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart Members
RadChart Class Constructors Methods Properties See Also Send Feedback

The RadChart type exposes the following members.

Constructors

Name | Description
RadChart | Initializes a new instance of the RadChart class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of RadChart. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Area | Get the Chart area xaml control.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Legend | Get the Chart legend xaml control.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the Chart title xaml control.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadChart. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


RadChart Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart Constructor
RadChart Class See Also Send Feedback
Initializes a new instance of the RadChart class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadChart()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadChart()

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


RadChart Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart Methods
RadChart Class See Also Send Feedback

The RadChart type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of RadChart. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.AnySibling Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.AssignReference Method
RadChart Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadChart.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.GetProperty Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.GetRectangle Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.Highlight Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.InitializeMappings Method
RadChart Class See Also Send Feedback
Initializes the mapping of RadChart.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.InvokeMethod Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.NextSibling Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.Parent Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.PreviousSibling Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.ScrollToVisible Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members
Telerik.WebAii.Controls.Xaml Namespace


RadChart Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart Properties
RadChart Class See Also Send Feedback

The RadChart type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Area | Get the Chart area xaml control.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Legend | Get the Chart legend xaml control.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the Chart title xaml control.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadChart. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


Area Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.Area Property
RadChart Class See Also Send Feedback
Get the Chart area xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartArea Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As ChartArea
Visual C++
public:
property ChartArea^ Area {
    ChartArea^ get ();
}

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


Legend Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.Legend Property
RadChart Class See Also Send Feedback
Get the Chart legend xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartLegend Legend { get; }
Visual Basic (Declaration)
Public ReadOnly Property Legend As ChartLegend
Visual C++
public:
property ChartLegend^ Legend {
    ChartLegend^ get ();
}

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.Title Property
RadChart Class See Also Send Feedback
Get the Chart title xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartTitle Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As ChartTitle
Visual C++
public:
property ChartTitle^ Title {
    ChartTitle^ get ();
}

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadChart..::.XamlTag Property
RadChart Class See Also Send Feedback
Get the xaml tag of RadChart.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadChart Class
Telerik.WebAii.Controls.Xaml Namespace


RadClock Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock Class
Members See Also Send Feedback
Represents the RadClock for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadClock : ItemsControl
Visual Basic (Declaration)
Public Class RadClock _
    Inherits ItemsControl
Visual C++
public ref class RadClock : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadClock

See Also

RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


RadClock Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock Members
RadClock Class Constructors Methods Properties See Also Send Feedback

The RadClock type exposes the following members.

Constructors

Name | Description
RadClock | Initializes a new instance of the RadClock class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTimePicker Clock control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the item with given text to select that time.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of clock items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedTime | Gets the clock selected time via an automation property.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title text in the header.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClock control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


RadClock Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock Constructor
RadClock Class See Also Send Feedback
Initializes a new instance of the RadClock class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadClock()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadClock()

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


RadClock Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock Methods
RadClock Class See Also Send Feedback

The RadClock type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTimePicker Clock control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the item with given text to select that time.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.AnySibling Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.AssignReference Method
RadClock Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadClock.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.GetProperty Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.GetRectangle Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.Highlight Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.InitializeMappings Method
RadClock Class See Also Send Feedback
Initializes the mapping of the RadTimePicker Clock control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.InvokeMethod Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.NextSibling Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.Parent Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.PreviousSibling Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.ScrollToVisible Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members
Telerik.WebAii.Controls.Xaml Namespace


SelectTime Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.SelectTime Method
RadClock Class See Also Send Feedback
Simulates user clicking on the item with given text to select that time.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectTime(
    string itemText
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    itemText As String _
)
Visual C++
public:
void SelectTime(
    String^ itemText
)

Parameters

itemText
Type: System..::.String
The item text to locate and select.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when a clock item with the given text cannot be found.

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


RadClock Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock Properties
RadClock Class See Also Send Feedback

The RadClock type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of clock items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedTime | Gets the clock selected time via an automation property.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title text in the header.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClock control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.Items Property
RadClock Class See Also Send Feedback
Get the list of clock items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadClockItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadClockItem)
Visual C++
public:
property IList<RadClockItem^>^ Items {
    IList<RadClockItem^>^ get ();
}

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.SelectedTime Property
RadClock Class See Also Send Feedback
Gets the clock selected time via an automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan SelectedTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedTime As TimeSpan
Visual C++
public:
property TimeSpan^ SelectedTime {
    TimeSpan^ get ();
}

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.Title Property
RadClock Class See Also Send Feedback
Get the title text in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClock..::.XamlTag Property
RadClock Class See Also Send Feedback
Get the xaml tag of RadClock control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadClock Class
Telerik.WebAii.Controls.Xaml Namespace


RadClockItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem Class
Members See Also Send Feedback
Represents the RadClockItem for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadClockItem : ContentControl
Visual Basic (Declaration)
Public Class RadClockItem _
    Inherits ContentControl
Visual C++
public ref class RadClockItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadClockItem

See Also

RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadClockItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem Members
RadClockItem Class Constructors Methods Properties See Also Send Feedback

The RadClockItem type exposes the following members.

Constructors

Name | Description
RadClockItem | Initializes a new instance of the RadClockItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTimePicker ClockItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasSelectedStyle | Get whether selected state is applied visually to the current item.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | Gets the bool value indicating whether the control is focused or not. Obtains its value from RadClockItem via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClockItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadClockItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem Constructor
RadClockItem Class See Also Send Feedback
Initializes a new instance of the RadClockItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadClockItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadClockItem()

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadClockItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem Methods
RadClockItem Class See Also Send Feedback

The RadClockItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTimePicker ClockItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.AnySibling Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.GetProperty Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.GetRectangle Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.Highlight Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.InitializeMappings Method
RadClockItem Class See Also Send Feedback
Initializes the mapping of the RadTimePicker ClockItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.InvokeMethod Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.NextSibling Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.Parent Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.PreviousSibling Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.ScrollToVisible Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadClockItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem Properties
RadClockItem Class See Also Send Feedback

The RadClockItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasSelectedStyle | Get whether selected state is applied visually to the current item.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | Gets the bool value indicating whether the control is focused or not. Obtains its value from RadClockItem via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClockItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


HasSelectedStyle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.HasSelectedStyle Property
RadClockItem Class See Also Send Feedback
Get whether selected state is applied visually to the current item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasSelectedStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasSelectedStyle As Boolean
Visual C++
public:
property bool HasSelectedStyle {
    bool get ();
}

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsFocused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.IsFocused Property
RadClockItem Class See Also Send Feedback
Gets the bool value indicating whether the control is focused or not. Obtains its value from RadClockItem via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.Text Property
RadClockItem Class See Also Send Feedback
Get the text of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadClockItem..::.XamlTag Property
RadClockItem Class See Also Send Feedback
Get the xaml tag of RadClockItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadClockItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView Class
Members See Also Send Feedback
Represents the Silverlight RadColorPaletteView control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadColorPaletteView : Selector
Visual Basic (Declaration)
Public Class RadColorPaletteView _
    Inherits Selector
Visual C++
public ref class RadColorPaletteView : public Selector

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Selector
Telerik.WebAii.Controls.Xaml..::.RadColorPaletteView

See Also

RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView Members
RadColorPaletteView Class Constructors Methods Properties See Also Send Feedback

The RadColorPaletteView type exposes the following members.

Constructors

Name | Description
RadColorPaletteView | Initializes a new instance of the RadColorPaletteView class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker PaletteView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Simulates user click to select the item with given index. Throws ArgumentOutOfRangeException if item index is out of range.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ColumnCount | Gets the Palette column count.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of color palette view items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Gets the Palette orientation.
Padding | (Inherited from Selector.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteView control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView Constructor
RadColorPaletteView Class See Also Send Feedback
Initializes a new instance of the RadColorPaletteView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorPaletteView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPaletteView()

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView Methods
RadColorPaletteView Class See Also Send Feedback

The RadColorPaletteView type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker PaletteView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Simulates user click to select the item with given index. Throws ArgumentOutOfRangeException if item index is out of range.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.AnySibling Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.GetProperty Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.GetRectangle Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.Highlight Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.InitializeMappings Method
RadColorPaletteView Class See Also Send Feedback
Initializes the mapping of the RadColorPicker PaletteView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.InvokeMethod Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.NextSibling Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.Parent Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.PreviousSibling Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.ScrollToVisible Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.SelectItem Method
RadColorPaletteView Class See Also Send Feedback
Simulates user click to select the item with given index. Throws ArgumentOutOfRangeException if item index is out of range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView Properties
RadColorPaletteView Class See Also Send Feedback

The RadColorPaletteView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ColumnCount | Gets the Palette column count.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of color palette view items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Gets the Palette orientation.
Padding | (Inherited from Selector.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteView control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


ColumnCount Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.ColumnCount Property
RadColorPaletteView Class See Also Send Feedback
Gets the Palette column count.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ColumnCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnCount As Integer
Visual C++
public:
property int ColumnCount {
    int get ();
}

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.Items Property
RadColorPaletteView Class See Also Send Feedback
Get the list of color palette view items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadColorPaletteViewItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadColorPaletteViewItem)
Visual C++
public:
property IList<RadColorPaletteViewItem^>^ Items {
    IList<RadColorPaletteViewItem^>^ get ();
}

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.Orientation Property
RadColorPaletteView Class See Also Send Feedback
Gets the Palette orientation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
}

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteView..::.XamlTag Property
RadColorPaletteView Class See Also Send Feedback
Get the xaml tag of RadColorPaletteView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorPaletteView Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteViewItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem Class
Members See Also Send Feedback
Represents the Silverlight RadColorPaletteViewItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadColorPaletteViewItem : ListBoxItem
Visual Basic (Declaration)
Public Class RadColorPaletteViewItem _
    Inherits ListBoxItem
Visual C++
public ref class RadColorPaletteViewItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBoxItem
Telerik.WebAii.Controls.Xaml..::.RadColorPaletteViewItem

See Also

RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteViewItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem Members
RadColorPaletteViewItem Class Constructors Methods Properties See Also Send Feedback

The RadColorPaletteViewItem type exposes the following members.

Constructors

Name | Description
RadColorPaletteViewItem | Initializes a new instance of the RadColorPaletteViewItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker PaletteViewItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the color of the item.
ColorValue | Get the item color RGB representation. Example: '255:0:0'.
Content | (Inherited from ListBoxItem.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Gets the bool value indicating whether the control is focused or not.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteViewItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteViewItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem Constructor
RadColorPaletteViewItem Class See Also Send Feedback
Initializes a new instance of the RadColorPaletteViewItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorPaletteViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPaletteViewItem()

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteViewItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem Methods
RadColorPaletteViewItem Class See Also Send Feedback

The RadColorPaletteViewItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker PaletteViewItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.AnySibling Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.GetProperty Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.GetRectangle Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.Highlight Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.InitializeMappings Method
RadColorPaletteViewItem Class See Also Send Feedback
Initializes the mapping of the RadColorPicker PaletteViewItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.InvokeMethod Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.NextSibling Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.Parent Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.PreviousSibling Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.ScrollToVisible Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadColorPaletteViewItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem Properties
RadColorPaletteViewItem Class See Also Send Feedback

The RadColorPaletteViewItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the color of the item.
ColorValue | Get the item color RGB representation. Example: '255:0:0'.
Content | (Inherited from ListBoxItem.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Gets the bool value indicating whether the control is focused or not.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteViewItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.Color Property
RadColorPaletteViewItem Class See Also Send Feedback
Get the color of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.ColorValue Property
RadColorPaletteViewItem Class See Also Send Feedback
Get the item color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorValue As String
Visual C++
public:
property String^ ColorValue {
    String^ get ();
}

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsFocused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.IsFocused Property
RadColorPaletteViewItem Class See Also Send Feedback
Gets the bool value indicating whether the control is focused or not.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPaletteViewItem..::.XamlTag Property
RadColorPaletteViewItem Class See Also Send Feedback
Get the xaml tag of RadColorPaletteViewItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorPaletteViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Class
Members See Also Send Feedback
Represents the Silverlight RadColorPicker control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadColorPicker : Control
Visual Basic (Declaration)
Public Class RadColorPicker _
    Inherits Control
Visual C++
public ref class RadColorPicker : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadColorPicker

See Also

RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


RadColorPicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Members
RadColorPicker Class Constructors Methods Properties See Also Send Feedback

The RadColorPicker type exposes the following members.

Constructors

Name | Description
RadColorPicker | Initializes a new instance of the RadColorPicker class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the popped up selector finding the palette and its item with the given indeces.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the drop down image to open/close the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the color selector popup is opened. Returns false if the popup cannot be found for some reason (e.g. custom control template).
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedColor | Get the left button color (the selected color).
SelectedColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Selector | Get the selector control from the popup if open; return 'null' otherwise.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPicker control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Constructor
RadColorPicker Class See Also Send Feedback
Initializes a new instance of the RadColorPicker class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPicker()

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Methods
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the popped up selector finding the palette and its item with the given indeces.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the drop down image to open/close the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.AnySibling Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.GetProperty Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.GetRectangle Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Highlight Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.InitializeMappings Method
RadColorPicker Class See Also Send Feedback
Initializes the mapping of the RadColorPicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.InvokeMethod Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.NextSibling Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Parent Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.PreviousSibling Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.ScrollToVisible Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.SelectItem Method
RadColorPicker Class See Also Send Feedback
Selects the item from the popped up selector finding the palette and its item with the given indeces.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int paletteIndex,
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    paletteIndex As Integer, _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int paletteIndex,
    int itemIndex
)

Parameters

paletteIndex
Type: System..::.Int32
The index of the palette to select the item from.
itemIndex
Type: System..::.Int32
The index of the item to select from the respective palette.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


TogglePopup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.TogglePopup Method
RadColorPicker Class See Also Send Feedback
Simulates user clicking on the drop down image to open/close the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePopup()
Visual Basic (Declaration)
Public Sub TogglePopup
Visual C++
public:
void TogglePopup()

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


WaitPopupAnimation Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.WaitPopupAnimation Method
RadColorPicker Class See Also Send Feedback
Useful upon any open/close action of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitPopupAnimation(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupAnimation ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupAnimation(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorPicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker Properties
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the color selector popup is opened. Returns false if the popup cannot be found for some reason (e.g. custom control template).
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedColor | Get the left button color (the selected color).
SelectedColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Selector | Get the selector control from the popup if open; return 'null' otherwise.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPicker control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.IsPopupOpen Property
RadColorPicker Class See Also Send Feedback
Get whether the color selector popup is opened. Returns false if the popup cannot be found for some reason (e.g. custom control template).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.SelectedColor Property
RadColorPicker Class See Also Send Feedback
Get the left button color (the selected color).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color SelectedColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedColor As Color
Visual C++
public:
property Color^ SelectedColor {
    Color^ get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.SelectedColorValue Property
RadColorPicker Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SelectedColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedColorValue As String
Visual C++
public:
property String^ SelectedColorValue {
    String^ get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


Selector Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.Selector Property
RadColorPicker Class See Also Send Feedback
Get the selector control from the popup if open; return 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorSelector Selector { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selector As RadColorSelector
Visual C++
public:
property RadColorSelector^ Selector {
    RadColorSelector^ get ();
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorPicker..::.XamlTag Property
RadColorPicker Class See Also Send Feedback
Get the xaml tag of RadColorPicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorSelector Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector Class
Members See Also Send Feedback
Represents the Silverlight RadColorSelector control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadColorSelector : ContentControl
Visual Basic (Declaration)
Public Class RadColorSelector _
    Inherits ContentControl
Visual C++
public ref class RadColorSelector : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadColorSelector

See Also

RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


RadColorSelector Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector Members
RadColorSelector Class Constructors Methods Properties See Also Send Feedback

The RadColorSelector type exposes the following members.

Constructors

Name | Description
RadColorSelector | Initializes a new instance of the RadColorSelector class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker ColorSelector control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the palette with the given index.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderColor | Get the color of the header button.
HeaderColorValue | Get the header color RGB value.
HeaderPaletteVisibility | Get the visibility of the header selector palette.
HeaderText | Get the text of the header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
MainPaletteHeaderText | Get the selector main palette header text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NoColorVisibility | Get the 'NoColor' header color button visibility. Obtains the value from RadColorSelector control via automation property.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
Palettes | Get the list of the available palettes in the selector.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StandardPaletteHeaderText | Get the selector standard palette header text.
StandardPaletteVisibility | Get the visibility of the standard selector palette.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorSelector control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorSelector Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector Constructor
RadColorSelector Class See Also Send Feedback
Initializes a new instance of the RadColorSelector class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColorSelector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorSelector()

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorSelector Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector Methods
RadColorSelector Class See Also Send Feedback

The RadColorSelector type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadColorPicker ColorSelector control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the palette with the given index.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.AnySibling Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.AssignReference Method
RadColorSelector Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadColorSelector.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.GetProperty Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.GetRectangle Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.Highlight Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.InitializeMappings Method
RadColorSelector Class See Also Send Feedback
Initializes the mapping of the RadColorPicker ColorSelector control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.InvokeMethod Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.NextSibling Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.Parent Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.PreviousSibling Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.ScrollToVisible Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.SelectItem Method
RadColorSelector Class See Also Send Feedback
Selects the item from the palette with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int paletteIndex,
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    paletteIndex As Integer, _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int paletteIndex,
    int itemIndex
)

Parameters

paletteIndex
Type: System..::.Int32
The index of the palette to select the item from.
itemIndex
Type: System..::.Int32
The index of the item to select from the respective palette.

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


RadColorSelector Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector Properties
RadColorSelector Class See Also Send Feedback

The RadColorSelector type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderColor | Get the color of the header button.
HeaderColorValue | Get the header color RGB value.
HeaderPaletteVisibility | Get the visibility of the header selector palette.
HeaderText | Get the text of the header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
MainPaletteHeaderText | Get the selector main palette header text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NoColorVisibility | Get the 'NoColor' header color button visibility. Obtains the value from RadColorSelector control via automation property.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
Palettes | Get the list of the available palettes in the selector.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StandardPaletteHeaderText | Get the selector standard palette header text.
StandardPaletteVisibility | Get the visibility of the standard selector palette.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorSelector control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderColor Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.HeaderColor Property
RadColorSelector Class See Also Send Feedback
Get the color of the header button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color HeaderColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderColor As Color
Visual C++
public:
property Color^ HeaderColor {
    Color^ get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.HeaderColorValue Property
RadColorSelector Class See Also Send Feedback
Get the header color RGB value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderColorValue As String
Visual C++
public:
property String^ HeaderColorValue {
    String^ get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderPaletteVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.HeaderPaletteVisibility Property
RadColorSelector Class See Also Send Feedback
Get the visibility of the header selector palette.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility HeaderPaletteVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderPaletteVisibility As Visibility
Visual C++
public:
property Visibility HeaderPaletteVisibility {
    Visibility get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.HeaderText Property
RadColorSelector Class See Also Send Feedback
Get the text of the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


MainPaletteHeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.MainPaletteHeaderText Property
RadColorSelector Class See Also Send Feedback
Get the selector main palette header text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string MainPaletteHeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property MainPaletteHeaderText As String
Visual C++
public:
property String^ MainPaletteHeaderText {
    String^ get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


NoColorVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.NoColorVisibility Property
RadColorSelector Class See Also Send Feedback
Get the 'NoColor' header color button visibility. Obtains the value from RadColorSelector control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility NoColorVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoColorVisibility As Visibility
Visual C++
public:
property Visibility NoColorVisibility {
    Visibility get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


Palettes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.Palettes Property
RadColorSelector Class See Also Send Feedback
Get the list of the available palettes in the selector.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadColorPaletteView> Palettes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Palettes As IList(Of RadColorPaletteView)
Visual C++
public:
property IList<RadColorPaletteView^>^ Palettes {
    IList<RadColorPaletteView^>^ get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


StandardPaletteHeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.StandardPaletteHeaderText Property
RadColorSelector Class See Also Send Feedback
Get the selector standard palette header text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StandardPaletteHeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property StandardPaletteHeaderText As String
Visual C++
public:
property String^ StandardPaletteHeaderText {
    String^ get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


StandardPaletteVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.StandardPaletteVisibility Property
RadColorSelector Class See Also Send Feedback
Get the visibility of the standard selector palette.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility StandardPaletteVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property StandardPaletteVisibility As Visibility
Visual C++
public:
property Visibility StandardPaletteVisibility {
    Visibility get ();
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColorSelector..::.XamlTag Property
RadColorSelector Class See Also Send Feedback
Get the xaml tag of RadColorSelector control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorSelector Class
Telerik.WebAii.Controls.Xaml Namespace


RadColumn Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn Class
Members See Also Send Feedback
Represents the Silverlight TreeListView RadColumn control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadColumn : ItemsControl
Visual Basic (Declaration)
Public Class RadColumn _
    Inherits ItemsControl
Visual C++
public ref class RadColumn : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadColumn

See Also

RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


RadColumn Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn Members
RadColumn Class Constructors Methods Properties See Also Send Feedback

The RadColumn type exposes the following members.

Constructors

Name | Description
RadColumn | Initializes a new instance of the RadColumn class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TreeListView RadColumn control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resize | Resize the column by the given offset.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the list of the columns.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the column index.
IsEditable | Gets or sets a value indicating whether the cells of the column are editable.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Gets or sets a value indicating whether the mouse is over the header of the column.
IsResizable | Gets or sets a value indicating whether a column is resizeable.
IsSortable | Gets or sets a value indicating whether the column is sortable.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Level | Gets an integer specifying the nesting level of the column. Unnested columns have Level 0.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
PropertyName | Gets or sets the name of the property that will be for generation, sorting and grouping.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the column text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColumn control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


RadColumn Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn Constructor
RadColumn Class See Also Send Feedback
Initializes a new instance of the RadColumn class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColumn()

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


RadColumn Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn Methods
RadColumn Class See Also Send Feedback

The RadColumn type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TreeListView RadColumn control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resize | Resize the column by the given offset.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.AnySibling Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.AssignReference Method
RadColumn Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadColumn.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.GetProperty Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.GetRectangle Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Highlight Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.InitializeMappings Method
RadColumn Class See Also Send Feedback
Initializes the mapping of the TreeListView RadColumn control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.InvokeMethod Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.NextSibling Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Parent Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.PreviousSibling Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


Resize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Resize Method
RadColumn Class See Also Send Feedback
Resize the column by the given offset.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resize(
    int offset
)
Visual Basic (Declaration)
Public Sub Resize ( _
    offset As Integer _
)
Visual C++
public:
void Resize(
    int offset
)

Parameters

offset
Type: System..::.Int32
The offset to resize by.

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.ScrollToVisible Method
RadColumn Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadColumn Class
RadColumn Members
Telerik.WebAii.Controls.Xaml Namespace


RadColumn Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn Properties
RadColumn Class See Also Send Feedback

The RadColumn type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the list of the columns.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the column index.
IsEditable | Gets or sets a value indicating whether the cells of the column are editable.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Gets or sets a value indicating whether the mouse is over the header of the column.
IsResizable | Gets or sets a value indicating whether a column is resizeable.
IsSortable | Gets or sets a value indicating whether the column is sortable.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Level | Gets an integer specifying the nesting level of the column. Unnested columns have Level 0.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
PropertyName | Gets or sets the name of the property that will be for generation, sorting and grouping.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the column text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColumn control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


Columns Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Columns Property
RadColumn Class See Also Send Feedback
Gets the list of the columns.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadColumn> Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As IList(Of RadColumn)
Visual C++
public:
property IList<RadColumn^>^ Columns {
    IList<RadColumn^>^ get ();
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Index Property
RadColumn Class See Also Send Feedback
Get the column index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


IsEditable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.IsEditable Property
RadColumn Class See Also Send Feedback
Gets or sets a value indicating whether the cells of the column are editable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic (Declaration)
Public Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


IsMouseOver Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.IsMouseOver Property
RadColumn Class See Also Send Feedback
Gets or sets a value indicating whether the mouse is over the header of the column.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMouseOver { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMouseOver As Boolean
Visual C++
public:
property bool IsMouseOver {
    bool get ();
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


IsResizable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.IsResizable Property
RadColumn Class See Also Send Feedback
Gets or sets a value indicating whether a column is resizeable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsResizable { get; set; }
Visual Basic (Declaration)
Public Property IsResizable As Boolean
Visual C++
public:
property bool IsResizable {
    bool get ();
    void set (bool value);
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


IsSortable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.IsSortable Property
RadColumn Class See Also Send Feedback
Gets or sets a value indicating whether the column is sortable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSortable { get; set; }
Visual Basic (Declaration)
Public Property IsSortable As Boolean
Visual C++
public:
property bool IsSortable {
    bool get ();
    void set (bool value);
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Level Property
RadColumn Class See Also Send Feedback
Gets an integer specifying the nesting level of the column. Unnested columns have Level 0.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


PropertyName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.PropertyName Property
RadColumn Class See Also Send Feedback
Gets or sets the name of the property that will be for generation, sorting and grouping.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.Text Property
RadColumn Class See Also Send Feedback
Get the column text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadColumn..::.XamlTag Property
RadColumn Class See Also Send Feedback
Get the xaml tag of RadColumn control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColumn Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Class
Members See Also Send Feedback
Represents the Silverlight RadComboBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadComboBox : Selector
Visual Basic (Declaration)
Public Class RadComboBox _
    Inherits Selector
Visual C++
public ref class RadComboBox : public Selector

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Selector
Telerik.WebAii.Controls.Xaml..::.RadComboBox

See Also

RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


RadComboBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Members
RadComboBox Class Constructors Methods Properties See Also Send Feedback

The RadComboBox type exposes the following members.

Constructors

Name | Description
RadComboBox | Initializes a new instance of the RadComboBox class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DropDownMouseWheelScroll | Simulates user scrolling the drop down.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadComboBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the drop down button to open/close it.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitDropDownAnimation | Overloaded.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Gets the content presenter element for non-editable ComboBox. Returns null if the combo is editable.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
DropDownPopup | Get the drop down popup of the combobox.
EditableTextBox | Gets the editable text box if the combo is in editable mode, 'null' otherwise.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsDropDownOpen | Get whether the combo drop down is opened. Returns 'false' also if the popup cannot be found with the current control template.
IsEditable | Get whether the combo is in editable mode. Uses an automation property (i.e. the RadComboBox control property called).
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of ComboBox items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the ComboBox text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Constructor
RadComboBox Class See Also Send Feedback
Initializes a new instance of the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadComboBox()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Methods
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DropDownMouseWheelScroll | Simulates user scrolling the drop down.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadComboBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the drop down button to open/close it.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitDropDownAnimation | Overloaded.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.AnySibling Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.AssignReference Method
RadComboBox Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadComboBox.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownMouseWheelScroll Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.DropDownMouseWheelScroll Method
RadComboBox Class See Also Send Feedback
Simulates user scrolling the drop down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DropDownMouseWheelScroll(
    int delta,
    MouseWheelTurnDirection direction
)
Visual Basic (Declaration)
Public Sub DropDownMouseWheelScroll ( _
    delta As Integer, _
    direction As MouseWheelTurnDirection _
)
Visual C++
public:
void DropDownMouseWheelScroll(
    int delta,
    MouseWheelTurnDirection direction
)

Parameters

delta
Type: System..::.Int32
The period turning the mouse wheel.
direction
Type: ArtOfTest.WebAii.Core..::.MouseWheelTurnDirection
The mouse wheel turning direction -- either 'forward' or 'backward'.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.GetProperty Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.GetRectangle Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Highlight Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.InitializeMappings Method
RadComboBox Class See Also Send Feedback
Initializes the mapping of the RadComboBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.InvokeMethod Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.NextSibling Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Parent Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.PreviousSibling Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ScrollToVisible Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SelectItem Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
SelectItem(Int32) | Simulate user opening the drop down (by default) and selecting an item.
SelectItem(String) | Simulate user opening the drop down (by default) and selecting the item with the given text.
SelectItem(Int32, Boolean) | Simulate user opening the drop down depending on 'openDropDown' argument and selecting an item.
SelectItem(String, Boolean) | Simulate user opening the drop down depending on 'openDropDown' argument and selecting the item with the given text.

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SelectItem Method (Int32)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down (by default) and selecting an item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.

See Also

RadComboBox Class
SelectItem Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SelectItem Method (String)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down (by default) and selecting the item with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    string itemText
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemText As String _
)
Visual C++
public:
void SelectItem(
    String^ itemText
)

Parameters

itemText
Type: System..::.String
The text of the item to be selected.

See Also

RadComboBox Class
SelectItem Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method (Int32, Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SelectItem Method (Int32, Boolean)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down depending on 'openDropDown' argument and selecting an item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    int itemIndex,
    bool openDropDown
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer, _
    openDropDown As Boolean _
)
Visual C++
public:
void SelectItem(
    int itemIndex,
    bool openDropDown
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.
openDropDown
Type: System..::.Boolean
Open the drop down first.

See Also

RadComboBox Class
SelectItem Overload
Telerik.WebAii.Controls.Xaml Namespace


SelectItem Method (String, Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.SelectItem Method (String, Boolean)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down depending on 'openDropDown' argument and selecting the item with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectItem(
    string itemText,
    bool openDropDown
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemText As String, _
    openDropDown As Boolean _
)
Visual C++
public:
void SelectItem(
    String^ itemText,
    bool openDropDown
)

Parameters

itemText
Type: System..::.String
The text of the item to be selected.
openDropDown
Type: System..::.Boolean
Open the drop down first.

See Also

RadComboBox Class
SelectItem Overload
Telerik.WebAii.Controls.Xaml Namespace


ToggleDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ToggleDropDown Method
RadComboBox Class See Also Send Feedback
Simulates user clicking on the drop down button to open/close it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleDropDown()
Visual Basic (Declaration)
Public Sub ToggleDropDown
Visual C++
public:
void ToggleDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


WaitDropDownAnimation Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.WaitDropDownAnimation Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
WaitDropDownAnimation()()() | Wait fow how a second to complete the Combo drop down animation.
WaitDropDownAnimation(Int32) | Wait fow the given timeout in millis to complete the Combo drop down animation.

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Xaml Namespace


WaitDropDownAnimation Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.WaitDropDownAnimation Method
RadComboBox Class See Also Send Feedback
Wait fow how a second to complete the Combo drop down animation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitDropDownAnimation()
Visual Basic (Declaration)
Public Sub WaitDropDownAnimation
Visual C++
public:
void WaitDropDownAnimation()

See Also

RadComboBox Class
WaitDropDownAnimation Overload
Telerik.WebAii.Controls.Xaml Namespace


WaitDropDownAnimation Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.WaitDropDownAnimation Method (Int32)
RadComboBox Class See Also Send Feedback
Wait fow the given timeout in millis to complete the Combo drop down animation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitDropDownAnimation(
    int millis
)
Visual Basic (Declaration)
Public Sub WaitDropDownAnimation ( _
    millis As Integer _
)
Visual C++
public:
void WaitDropDownAnimation(
    int millis
)

Parameters

millis
Type: System..::.Int32

[Missing <param name="millis"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadComboBox.WaitDropDownAnimation(System.Int32)"]

See Also

RadComboBox Class
WaitDropDownAnimation Overload
Telerik.WebAii.Controls.Xaml Namespace


RadComboBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox Properties
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Gets the content presenter element for non-editable ComboBox. Returns null if the combo is editable.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
DropDownPopup | Get the drop down popup of the combobox.
EditableTextBox | Gets the editable text box if the combo is in editable mode, 'null' otherwise.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsDropDownOpen | Get whether the combo drop down is opened. Returns 'false' also if the popup cannot be found with the current control template.
IsEditable | Get whether the combo is in editable mode. Uses an automation property (i.e. the RadComboBox control property called).
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of ComboBox items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the ComboBox text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.ContentPresenterElement Property
RadComboBox Class See Also Send Feedback
Gets the content presenter element for non-editable ComboBox. Returns null if the combo is editable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownPopup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.DropDownPopup Property
RadComboBox Class See Also Send Feedback
Get the drop down popup of the combobox.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Popup DropDownPopup { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownPopup As Popup
Visual C++
public:
property Popup^ DropDownPopup {
    Popup^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


EditableTextBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.EditableTextBox Property
RadComboBox Class See Also Send Feedback
Gets the editable text box if the combo is in editable mode, 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PickerTextBox EditableTextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditableTextBox As PickerTextBox
Visual C++
public:
property PickerTextBox^ EditableTextBox {
    PickerTextBox^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


IsDropDownOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.IsDropDownOpen Property
RadComboBox Class See Also Send Feedback
Get whether the combo drop down is opened. Returns 'false' also if the popup cannot be found with the current control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsDropDownOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDropDownOpen As Boolean
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


IsEditable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.IsEditable Property
RadComboBox Class See Also Send Feedback
Get whether the combo is in editable mode. Uses an automation property (i.e. the RadComboBox control property called).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEditable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Items Property
RadComboBox Class See Also Send Feedback
Get the list of ComboBox items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadComboBoxItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadComboBoxItem)
Visual C++
public:
property IList<RadComboBoxItem^>^ Items {
    IList<RadComboBoxItem^>^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.Text Property
RadComboBox Class See Also Send Feedback
Get the ComboBox text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBox..::.XamlTag Property
RadComboBox Class See Also Send Feedback
Get the xaml tag of RadComboBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadComboBox Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBoxItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Class
Members See Also Send Feedback
Represents the Silverlight RadComboBoxItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadComboBoxItem : ListBoxItem
Visual Basic (Declaration)
Public Class RadComboBoxItem _
    Inherits ListBoxItem
Visual C++
public ref class RadComboBoxItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBoxItem
Telerik.WebAii.Controls.Xaml..::.RadComboBoxItem

See Also

RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadComboBoxItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Members
RadComboBoxItem Class Constructors Methods Properties See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Constructors

Name | Description
RadComboBoxItem | Initializes a new instance of the RadComboBoxItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadComboBoxItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user click on the item to select it in the combobox.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
ContentPresenterElement | Get the content present element part of the standard control template.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Get whether the item is focused.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBoxItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBoxItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Constructor
RadComboBoxItem Class See Also Send Feedback
Initializes a new instance of the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadComboBoxItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadComboBoxItem()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBoxItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Methods
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadComboBoxItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user click on the item to select it in the combobox.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.AnySibling Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.GetProperty Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.GetRectangle Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Highlight Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.InitializeMappings Method
RadComboBoxItem Class See Also Send Feedback
Initializes the mapping of the RadComboBoxItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.InvokeMethod Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.NextSibling Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Parent Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.PreviousSibling Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.ScrollToVisible Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Select Method
RadComboBoxItem Class See Also Send Feedback
Simulates user click on the item to select it in the combobox.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadComboBoxItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem Properties
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
ContentPresenterElement | Get the content present element part of the standard control template.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Get whether the item is focused.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBoxItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.ContentPresenterElement Property
RadComboBoxItem Class See Also Send Feedback
Get the content present element part of the standard control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Index Property
RadComboBoxItem Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsFocused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.IsFocused Property
RadComboBoxItem Class See Also Send Feedback
Get whether the item is focused.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.Text Property
RadComboBoxItem Class See Also Send Feedback
Get the text of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadComboBoxItem..::.XamlTag Property
RadComboBoxItem Class See Also Send Feedback
Get the xaml tag of RadComboBoxItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadContextMenu Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu Class
Members See Also Send Feedback
Represents the Silverlight RadContextMenu wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadContextMenu : RadMenuBase
Visual Basic (Declaration)
Public Class RadContextMenu _
    Inherits RadMenuBase
Visual C++
public ref class RadContextMenu : public RadMenuBase

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadMenuBase
Telerik.WebAii.Controls.Xaml..::.RadContextMenu

See Also

RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


RadContextMenu Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu Members
RadContextMenu Class Constructors Methods Properties See Also Send Feedback

The RadContextMenu type exposes the following members.

Constructors

Name | Description
RadContextMenu | Initializes a new instance of the RadContextMenu class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadContextMenu control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Selects an option from the context menu.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickToOpen | Gets or sets whether the child group opens upon clicking a parent item. (Inherited from RadMenuBase.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EventName | Gets or sets the name of the event that will open the context menu.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsOpen | Gets or sets a value that indicates whether the RadContextMenu is visible.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the collection of all the root RadMenuItem elements.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MousePosition | Gets the position of the mouse at the moment when the menu was opened.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StaysOpen | Gets or sets a value that indicates whether the RadContextMenu should close automatically.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
VerticalOffset | Get or sets the vertical distance between the target origin and the popup alignment point.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadContextMenu control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadContextMenu Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu Constructor
RadContextMenu Class See Also Send Feedback
Initializes a new instance of the RadContextMenu class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadContextMenu()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadContextMenu()

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadContextMenu Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu Methods
RadContextMenu Class See Also Send Feedback

The RadContextMenu type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadContextMenu control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Selects an option from the context menu.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.AnySibling Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.AssignReference Method
RadContextMenu Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadContextMenu.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.GetProperty Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.GetRectangle Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.Highlight Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.InitializeMappings Method
RadContextMenu Class See Also Send Feedback
Initializes the mapping of the RadContextMenu control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.InvokeMethod Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.NextSibling Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.Parent Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.PreviousSibling Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.ScrollToVisible Method
RadContextMenu Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
RadContextMenu Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.Select Method
RadContextMenu Class See Also Send Feedback
Selects an option from the context menu.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub Select ( _
    itemIndex As Integer _
)
Visual C++
public:
void Select(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadContextMenu Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu Properties
RadContextMenu Class See Also Send Feedback

The RadContextMenu type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickToOpen | Gets or sets whether the child group opens upon clicking a parent item. (Inherited from RadMenuBase.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EventName | Gets or sets the name of the event that will open the context menu.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsOpen | Gets or sets a value that indicates whether the RadContextMenu is visible.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the collection of all the root RadMenuItem elements.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MousePosition | Gets the position of the mouse at the moment when the menu was opened.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StaysOpen | Gets or sets a value that indicates whether the RadContextMenu should close automatically.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
VerticalOffset | Get or sets the vertical distance between the target origin and the popup alignment point.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadContextMenu control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


EventName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.EventName Property
RadContextMenu Class See Also Send Feedback
Gets or sets the name of the event that will open the context menu.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string EventName { get; set; }
Visual Basic (Declaration)
Public Property EventName As String
Visual C++
public:
property String^ EventName {
    String^ get ();
    void set (String^ value);
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.HorizontalOffset Property
RadContextMenu Class See Also Send Feedback
Get or sets the horizontal distance between the target origin and the popup alignment point.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property HorizontalOffset As Double
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


IsOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.IsOpen Property
RadContextMenu Class See Also Send Feedback
Gets or sets a value that indicates whether the RadContextMenu is visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsOpen { get; set; }
Visual Basic (Declaration)
Public Property IsOpen As Boolean
Visual C++
public:
property bool IsOpen {
    bool get ();
    void set (bool value);
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.Items Property
RadContextMenu Class See Also Send Feedback
Gets the collection of all the root RadMenuItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ Items {
    IList<RadMenuItem^>^ get ();
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


MousePosition Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.MousePosition Property
RadContextMenu Class See Also Send Feedback
Gets the position of the mouse at the moment when the menu was opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point MousePosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property MousePosition As Point
Visual C++
public:
property Point^ MousePosition {
    Point^ get ();
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


StaysOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.StaysOpen Property
RadContextMenu Class See Also Send Feedback
Gets or sets a value that indicates whether the RadContextMenu should close automatically.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StaysOpen { get; set; }
Visual Basic (Declaration)
Public Property StaysOpen As Boolean
Visual C++
public:
property bool StaysOpen {
    bool get ();
    void set (bool value);
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.VerticalOffset Property
RadContextMenu Class See Also Send Feedback
Get or sets the vertical distance between the target origin and the popup alignment point.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property VerticalOffset As Double
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadContextMenu..::.XamlTag Property
RadContextMenu Class See Also Send Feedback
Get the xaml tag of RadContextMenu control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadContextMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadControlMappingKeys Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys Class
Members See Also Send Feedback
Represents a collection of keys identifying RadControls in the framework.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class RadControlMappingKeys
Visual Basic (Declaration)
Public NotInheritable Class RadControlMappingKeys
Visual C++
public ref class RadControlMappingKeys abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.RadControlMappingKeys

See Also

RadControlMappingKeys Members
Telerik.WebAii.Controls.Xaml Namespace


RadControlMappingKeys Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys Members
RadControlMappingKeys Class Fields See Also Send Feedback

The RadControlMappingKeys type exposes the following members.

Fields

Name | Description
AggregateResultsListKey | The GridView AggregateResultsList key.
AppointmentItemKey | The RadScheduler AppointmentItem key.
AppointmentsControlKey | The RadScheduler AppointmentsControl key.
AreaKey | The Area key.
AreaSeriesKey | The AreaSeries key.
AutoHideAreaKey | The AutoHideArea key.
AxisLabel2DKey | The AxisLabel2D key.
AxisX2DKey | The AxisX2D key.
AxisXItem2DKey | The AxisXitem2D key.
AxisY2DKey | The AxisY2D key.
AxisYItem2DKey | The AxisYItem2D key.
BarKey | The Bar key.
BookItemKey | The BookItem key.
BookKey | The Book key.
BubbleKey | The Bubble key.
ButtonKey | The RadButton key.
CalendarButtonKey | The CalendarButton key.
CalendarKey | The RadCalendar key.
CalendarPanelKey | The CalendarPanel key.
CalendarViewKey | The CalendarView key.
CandleStickKey | The CandleStick key.
ChartAreaKey | The ChartArea key.
ChartLegendItemKey | The ChartLegendItem key.
ChartLegendKey | The ChartLegend key.
ChartPanelKey | The ChartPanel key.
ChartTextBoxKey | The ChartTextBox key.
ChartTitleKey | The ChartTitle key.
ClockItemKey | The RadClockItem key.
ClockKey | The RadClock key.
ColorPaletteViewItemKey | The RadColorPaletteViewItem key.
ColorPaletteViewKey | The RadColorPaletteView key.
ColorPickerKey | The RadColorPicker key.
ColorSelectorKey | The RadColorSelector key.
ComboBoxItemKey | The ComboBoxItem key.
ComboBoxKey | The ComboBox key.
ContextMenuKey | The ContextMenu key.
CoverFlowItemKey | The CoverFlowItem key.
CoverFlowKey | The CoverFlow key.
DatePickerKey | The RadDatePicker key.
DockingKey | The RadDocking key.
DocumentHostKey | The DocumentHost key.
DocumentPaneKey | The RadDocumentPane key.
DoughnutKey | The Doughnut key.
DropDownButtonKey | The RadDropDownButton key.
ExpanderKey | The RadExpander key.
ExtendedTextBoxKey | The Masked ExtendedTextBox key.
FluidContentControlKey | The FluidContentControl key.
GaugeIndicatorKey | The GaugeIndicator key.
GaugeLinearBarKey | The GaugeLinearBar key.
GaugeLinearLabelKey | The GaugeLinearLabel key.
GaugeLinearRangeKey | The GaugeLinearRange key.
GaugeLinearScaleKey | The GaugeLinearScale key.
GaugeLinearTickKey | The GaugeLinearTick key.
GaugeMarkerKey | The GaugeMarker key.
GaugeNeedleKey | The GaugeNeedle key.
GaugeNumericIndicatorKey | The GaugeNumericIndicator key.
GaugeRadialBarKey | The GaugeRadialBar key.
GaugeRadialLabelKey | The GaugeRadialLabel key.
GaugeRadialRangeKey | The GaugeRadialRange key.
GaugeRadialScaleKey | The GaugeRadialScale key.
GaugeRadialTickKey | The GaugeRadialTick key.
GaugeStateIndicatorKey | The GaugeStateIndicator key.
GridResizerKey | The GridResizer key.
GridViewAggregateResultCellKey | The GridView AggregateResultCell key.
GridViewCellKey | The GridViewCell key.
GridViewExpandableRowKey | The GridViewExpandableRow key.
GridViewFooterCellKey | The GridViewFooterCell key.
GridViewFooterRowKey | The GridViewFooterRow key.
GridViewGroupPanelCellKey | The GridViewGroupPanelCell key.
GridViewGroupPanelItemKey | The GridViewGroupPanelItem key.
GridViewGroupPanelKey | The GridViewGroupPanel key.
GridViewGroupRowKey | The GridViewGroupRow key.
GridViewHeaderCellKey | The GridViewHeaderCell key.
GridViewHeaderRowKey | The GridViewHeaderRow key.
GridViewKey | The GridView key.
GridViewNewRowKey | The GridViewNewRow key.
GridViewRowKey | The GridViewRow key.
HorizontalBarKey | The HorizontalBar key.
HorizontalGridLine2DKey | The HorizontalGridLine2D key.
HorizontalMinorTick2DKey | The HorizontalMinorTick2D key.
HorizontalStackedBar100Key | The HorizontalStackedBar100 key.
HorizontalStackedBarKey | The HorizontalStackedBar key.
HtmlPlaceholderKey | The RadHtmlPlaceholder key.
LinearGaugeKey | The LinearGauge key.
LineKey | The Line key.
LineSeriesKey | The LineSeries key.
MaskedTextBoxKey | The RadMaskedTextBox key.
MediaChapterKey | The RadMediaChapter key.
MediaItemKey | The RadMediaItem key.
MediaPlayerKey | The RadMediaPlayer key.
MenuItemKey | The MenuItem key.
MenuKey | The Menu key.
MinimizedOutlookBarAreaKey | The MinimizedOutlookBarArea key.
MinimizedOutlookBarItemKey | The MinimizedOutlookBarItem key.
NumericKey | The RadNumericUpDown key.
OutlookBarItemKey | The OutlookBarItem key.
OutlookBarKey | The OutlookBar key.
PaneGroupKey | The RadPaneGroup key.
PaneHeaderKey | The RadPaneHeader key.
PaneKey | The RadPane key.
PanelBarItemKey | The PanelBarItem key.
PanelBarKey | The PanelBar key.
ParametricLineKey | The ParametricLine key.
PickerTextBoxKey | The PickerTextBox key.
PickerToggleButtonKey | The PickerToggleButton key.
PieKey | The Pie key.
PlaylistPresenterKey | The PlaylistPresenter key.
ProgressBarKey | The RadProgressBar key.
QuickAccessToolbarKey | The QuickAccessToolbar key.
RadChartKey | The RadChart key.
RadGaugeKey | The RadGauge key.
RadialGaugeKey | The RadialGauge key.
RadioButtonKey | The RadRadioButton key.
RangeKey | The Range key.
RangeSeriesKey | The RangeSeries key.
RibbonBarKey | The RadRibbonBar key.
RibbonButtonKey | The RadRibbonButton key.
RibbonDropDownButtonKey | The RadRibbonDropDownButton key.
RibbonGroupKey | The RadRibbonGroup key.
RibbonRadioButtonKey | The RadRibbonRadioButton key.
RibbonSplitButtonKey | The RadRibbonSplitButton key.
SchedulerKey | The RadScheduler key.
SchedulerPresenterKey | The RadScheduler SchedulerPresenter key.
SeriesKey | The Series key.
SliderKey | The RadSlider key.
SplineAreaKey | The SplineArea key.
SplineAreaSeriesKey | The SplineAreaSeries key.
SplineKey | The Spline key.
SplineRangeKey | The SplineRange key.
SplineRangeSeriesKey | The SplineRangeSeries key.
SplineSeriesKey | The SplineSeries key.
SplitButtonKey | The RadSplitButton key.
SplitContainerKey | The RadSplitContainer key.
StackedArea100Key | The StackedArea100 key.
StackedArea100SeriesKey | The StackedArea100Series key.
StackedAreaKey | The StackedArea key.
StackedAreaSeriesKey | The StackedAreaSeries key.
StackedBar100Key | The StackedBar100 key.
StackedBarKey | The StackedBar key.
StackedLineKey | The StackedLine key.
StackedLineSeriesKey | The StackedLineSeries key.
StackedSplineArea100Key | The StackedSplineArea100 key.
StackedSplineArea100SeriesKey | The StackedSplineArea100Series key.
StackedSplineAreaKey | The StackedSplineArea key.
StackedSplineAreaSeriesKey | The StackedSplineAreaSeries key.
StackedSplineKey | The StackedSpline key.
StackedSplineSeriesKey | The StackedSplineSeries key.
StickKey | The Stick key.
TabControlKey | The TabControl key.
TabItemKey | The TabItem key.
TickBarKey | The RadTickBar key.
TileViewItemKey | The TileViewItem key.
TileViewKey | The TileView key.
TimePickerKey | The RadTimePicker key.
TimeSlotItemKey | The RadScheduler TimeSlotItem key.
ToggleButtonKey | The RadToggleButton key.
ToolBarKey | The ToolBar key.
ToolBarTrayKey | The ToolBarTray key.
ToolWindowKey | The ToolWindow key.
TreeListViewCellKey | The TreeListViewCell key.
TreeListViewColumnKey | The TreeListViewColumn key.
TreeListViewItemKey | The TreeListViewItem key.
TreeListViewKey | The TreeListView key.
TreeViewItemKey | The TreeViewItem key.
TreeViewKey | The TreeView key.
UniformGridKey | The RadUniformGrid key.
UploadItemKey | The RadUploadItem key.
UploadKey | The RadUpload key.
VerticalGridLine2DKey | The VerticalGridLine2D key.
VerticalMinorTick2DKey | The VerticalMinorTick2D key.
WindowKey | The Window key.
WindowTitleKey | The WindowTitle key.

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RadControlMappingKeys Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys Fields
RadControlMappingKeys Class See Also Send Feedback

The RadControlMappingKeys type exposes the following members.

Fields

Name | Description
AggregateResultsListKey | The GridView AggregateResultsList key.
AppointmentItemKey | The RadScheduler AppointmentItem key.
AppointmentsControlKey | The RadScheduler AppointmentsControl key.
AreaKey | The Area key.
AreaSeriesKey | The AreaSeries key.
AutoHideAreaKey | The AutoHideArea key.
AxisLabel2DKey | The AxisLabel2D key.
AxisX2DKey | The AxisX2D key.
AxisXItem2DKey | The AxisXitem2D key.
AxisY2DKey | The AxisY2D key.
AxisYItem2DKey | The AxisYItem2D key.
BarKey | The Bar key.
BookItemKey | The BookItem key.
BookKey | The Book key.
BubbleKey | The Bubble key.
ButtonKey | The RadButton key.
CalendarButtonKey | The CalendarButton key.
CalendarKey | The RadCalendar key.
CalendarPanelKey | The CalendarPanel key.
CalendarViewKey | The CalendarView key.
CandleStickKey | The CandleStick key.
ChartAreaKey | The ChartArea key.
ChartLegendItemKey | The ChartLegendItem key.
ChartLegendKey | The ChartLegend key.
ChartPanelKey | The ChartPanel key.
ChartTextBoxKey | The ChartTextBox key.
ChartTitleKey | The ChartTitle key.
ClockItemKey | The RadClockItem key.
ClockKey | The RadClock key.
ColorPaletteViewItemKey | The RadColorPaletteViewItem key.
ColorPaletteViewKey | The RadColorPaletteView key.
ColorPickerKey | The RadColorPicker key.
ColorSelectorKey | The RadColorSelector key.
ComboBoxItemKey | The ComboBoxItem key.
ComboBoxKey | The ComboBox key.
ContextMenuKey | The ContextMenu key.
CoverFlowItemKey | The CoverFlowItem key.
CoverFlowKey | The CoverFlow key.
DatePickerKey | The RadDatePicker key.
DockingKey | The RadDocking key.
DocumentHostKey | The DocumentHost key.
DocumentPaneKey | The RadDocumentPane key.
DoughnutKey | The Doughnut key.
DropDownButtonKey | The RadDropDownButton key.
ExpanderKey | The RadExpander key.
ExtendedTextBoxKey | The Masked ExtendedTextBox key.
FluidContentControlKey | The FluidContentControl key.
GaugeIndicatorKey | The GaugeIndicator key.
GaugeLinearBarKey | The GaugeLinearBar key.
GaugeLinearLabelKey | The GaugeLinearLabel key.
GaugeLinearRangeKey | The GaugeLinearRange key.
GaugeLinearScaleKey | The GaugeLinearScale key.
GaugeLinearTickKey | The GaugeLinearTick key.
GaugeMarkerKey | The GaugeMarker key.
GaugeNeedleKey | The GaugeNeedle key.
GaugeNumericIndicatorKey | The GaugeNumericIndicator key.
GaugeRadialBarKey | The GaugeRadialBar key.
GaugeRadialLabelKey | The GaugeRadialLabel key.
GaugeRadialRangeKey | The GaugeRadialRange key.
GaugeRadialScaleKey | The GaugeRadialScale key.
GaugeRadialTickKey | The GaugeRadialTick key.
GaugeStateIndicatorKey | The GaugeStateIndicator key.
GridResizerKey | The GridResizer key.
GridViewAggregateResultCellKey | The GridView AggregateResultCell key.
GridViewCellKey | The GridViewCell key.
GridViewExpandableRowKey | The GridViewExpandableRow key.
GridViewFooterCellKey | The GridViewFooterCell key.
GridViewFooterRowKey | The GridViewFooterRow key.
GridViewGroupPanelCellKey | The GridViewGroupPanelCell key.
GridViewGroupPanelItemKey | The GridViewGroupPanelItem key.
GridViewGroupPanelKey | The GridViewGroupPanel key.
GridViewGroupRowKey | The GridViewGroupRow key.
GridViewHeaderCellKey | The GridViewHeaderCell key.
GridViewHeaderRowKey | The GridViewHeaderRow key.
GridViewKey | The GridView key.
GridViewNewRowKey | The GridViewNewRow key.
GridViewRowKey | The GridViewRow key.
HorizontalBarKey | The HorizontalBar key.
HorizontalGridLine2DKey | The HorizontalGridLine2D key.
HorizontalMinorTick2DKey | The HorizontalMinorTick2D key.
HorizontalStackedBar100Key | The HorizontalStackedBar100 key.
HorizontalStackedBarKey | The HorizontalStackedBar key.
HtmlPlaceholderKey | The RadHtmlPlaceholder key.
LinearGaugeKey | The LinearGauge key.
LineKey | The Line key.
LineSeriesKey | The LineSeries key.
MaskedTextBoxKey | The RadMaskedTextBox key.
MediaChapterKey | The RadMediaChapter key.
MediaItemKey | The RadMediaItem key.
MediaPlayerKey | The RadMediaPlayer key.
MenuItemKey | The MenuItem key.
MenuKey | The Menu key.
MinimizedOutlookBarAreaKey | The MinimizedOutlookBarArea key.
MinimizedOutlookBarItemKey | The MinimizedOutlookBarItem key.
NumericKey | The RadNumericUpDown key.
OutlookBarItemKey | The OutlookBarItem key.
OutlookBarKey | The OutlookBar key.
PaneGroupKey | The RadPaneGroup key.
PaneHeaderKey | The RadPaneHeader key.
PaneKey | The RadPane key.
PanelBarItemKey | The PanelBarItem key.
PanelBarKey | The PanelBar key.
ParametricLineKey | The ParametricLine key.
PickerTextBoxKey | The PickerTextBox key.
PickerToggleButtonKey | The PickerToggleButton key.
PieKey | The Pie key.
PlaylistPresenterKey | The PlaylistPresenter key.
ProgressBarKey | The RadProgressBar key.
QuickAccessToolbarKey | The QuickAccessToolbar key.
RadChartKey | The RadChart key.
RadGaugeKey | The RadGauge key.
RadialGaugeKey | The RadialGauge key.
RadioButtonKey | The RadRadioButton key.
RangeKey | The Range key.
RangeSeriesKey | The RangeSeries key.
RibbonBarKey | The RadRibbonBar key.
RibbonButtonKey | The RadRibbonButton key.
RibbonDropDownButtonKey | The RadRibbonDropDownButton key.
RibbonGroupKey | The RadRibbonGroup key.
RibbonRadioButtonKey | The RadRibbonRadioButton key.
RibbonSplitButtonKey | The RadRibbonSplitButton key.
SchedulerKey | The RadScheduler key.
SchedulerPresenterKey | The RadScheduler SchedulerPresenter key.
SeriesKey | The Series key.
SliderKey | The RadSlider key.
SplineAreaKey | The SplineArea key.
SplineAreaSeriesKey | The SplineAreaSeries key.
SplineKey | The Spline key.
SplineRangeKey | The SplineRange key.
SplineRangeSeriesKey | The SplineRangeSeries key.
SplineSeriesKey | The SplineSeries key.
SplitButtonKey | The RadSplitButton key.
SplitContainerKey | The RadSplitContainer key.
StackedArea100Key | The StackedArea100 key.
StackedArea100SeriesKey | The StackedArea100Series key.
StackedAreaKey | The StackedArea key.
StackedAreaSeriesKey | The StackedAreaSeries key.
StackedBar100Key | The StackedBar100 key.
StackedBarKey | The StackedBar key.
StackedLineKey | The StackedLine key.
StackedLineSeriesKey | The StackedLineSeries key.
StackedSplineArea100Key | The StackedSplineArea100 key.
StackedSplineArea100SeriesKey | The StackedSplineArea100Series key.
StackedSplineAreaKey | The StackedSplineArea key.
StackedSplineAreaSeriesKey | The StackedSplineAreaSeries key.
StackedSplineKey | The StackedSpline key.
StackedSplineSeriesKey | The StackedSplineSeries key.
StickKey | The Stick key.
TabControlKey | The TabControl key.
TabItemKey | The TabItem key.
TickBarKey | The RadTickBar key.
TileViewItemKey | The TileViewItem key.
TileViewKey | The TileView key.
TimePickerKey | The RadTimePicker key.
TimeSlotItemKey | The RadScheduler TimeSlotItem key.
ToggleButtonKey | The RadToggleButton key.
ToolBarKey | The ToolBar key.
ToolBarTrayKey | The ToolBarTray key.
ToolWindowKey | The ToolWindow key.
TreeListViewCellKey | The TreeListViewCell key.
TreeListViewColumnKey | The TreeListViewColumn key.
TreeListViewItemKey | The TreeListViewItem key.
TreeListViewKey | The TreeListView key.
TreeViewItemKey | The TreeViewItem key.
TreeViewKey | The TreeView key.
UniformGridKey | The RadUniformGrid key.
UploadItemKey | The RadUploadItem key.
UploadKey | The RadUpload key.
VerticalGridLine2DKey | The VerticalGridLine2D key.
VerticalMinorTick2DKey | The VerticalMinorTick2D key.
WindowKey | The Window key.
WindowTitleKey | The WindowTitle key.

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsListKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AggregateResultsListKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridView AggregateResultsList key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AggregateResultsListKey
Visual Basic (Declaration)
Public Const AggregateResultsListKey As String
Visual C++
public:
literal String^ AggregateResultsListKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AppointmentItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadScheduler AppointmentItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentItemKey
Visual Basic (Declaration)
Public Const AppointmentItemKey As String
Visual C++
public:
literal String^ AppointmentItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControlKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AppointmentsControlKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadScheduler AppointmentsControl key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentsControlKey
Visual Basic (Declaration)
Public Const AppointmentsControlKey As String
Visual C++
public:
literal String^ AppointmentsControlKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The Area key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AreaKey
Visual Basic (Declaration)
Public Const AreaKey As String
Visual C++
public:
literal String^ AreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AreaSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AreaSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The AreaSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AreaSeriesKey
Visual Basic (Declaration)
Public Const AreaSeriesKey As String
Visual C++
public:
literal String^ AreaSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideAreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AutoHideAreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The AutoHideArea key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AutoHideAreaKey
Visual Basic (Declaration)
Public Const AutoHideAreaKey As String
Visual C++
public:
literal String^ AutoHideAreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AxisLabel2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AxisLabel2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The AxisLabel2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AxisLabel2DKey
Visual Basic (Declaration)
Public Const AxisLabel2DKey As String
Visual C++
public:
literal String^ AxisLabel2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AxisX2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AxisX2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The AxisX2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AxisX2DKey
Visual Basic (Declaration)
Public Const AxisX2DKey As String
Visual C++
public:
literal String^ AxisX2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AxisXItem2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AxisXItem2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The AxisXitem2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AxisXItem2DKey
Visual Basic (Declaration)
Public Const AxisXItem2DKey As String
Visual C++
public:
literal String^ AxisXItem2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AxisY2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AxisY2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The AxisY2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AxisY2DKey
Visual Basic (Declaration)
Public Const AxisY2DKey As String
Visual C++
public:
literal String^ AxisY2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


AxisYItem2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.AxisYItem2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The AxisYItem2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AxisYItem2DKey
Visual Basic (Declaration)
Public Const AxisYItem2DKey As String
Visual C++
public:
literal String^ AxisYItem2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


BarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.BarKey Field
RadControlMappingKeys Class See Also Send Feedback
The Bar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BarKey
Visual Basic (Declaration)
Public Const BarKey As String
Visual C++
public:
literal String^ BarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


BookItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.BookItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The BookItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BookItemKey
Visual Basic (Declaration)
Public Const BookItemKey As String
Visual C++
public:
literal String^ BookItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


BookKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.BookKey Field
RadControlMappingKeys Class See Also Send Feedback
The Book key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BookKey
Visual Basic (Declaration)
Public Const BookKey As String
Visual C++
public:
literal String^ BookKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


BubbleKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.BubbleKey Field
RadControlMappingKeys Class See Also Send Feedback
The Bubble key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BubbleKey
Visual Basic (Declaration)
Public Const BubbleKey As String
Visual C++
public:
literal String^ BubbleKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ButtonKey
Visual Basic (Declaration)
Public Const ButtonKey As String
Visual C++
public:
literal String^ ButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CalendarButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The CalendarButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CalendarButtonKey
Visual Basic (Declaration)
Public Const CalendarButtonKey As String
Visual C++
public:
literal String^ CalendarButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CalendarKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadCalendar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CalendarKey
Visual Basic (Declaration)
Public Const CalendarKey As String
Visual C++
public:
literal String^ CalendarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarPanelKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CalendarPanelKey Field
RadControlMappingKeys Class See Also Send Feedback
The CalendarPanel key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CalendarPanelKey
Visual Basic (Declaration)
Public Const CalendarPanelKey As String
Visual C++
public:
literal String^ CalendarPanelKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CalendarViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CalendarViewKey Field
RadControlMappingKeys Class See Also Send Feedback
The CalendarView key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CalendarViewKey
Visual Basic (Declaration)
Public Const CalendarViewKey As String
Visual C++
public:
literal String^ CalendarViewKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CandleStickKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CandleStickKey Field
RadControlMappingKeys Class See Also Send Feedback
The CandleStick key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CandleStickKey
Visual Basic (Declaration)
Public Const CandleStickKey As String
Visual C++
public:
literal String^ CandleStickKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ChartAreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ChartAreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The ChartArea key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChartAreaKey
Visual Basic (Declaration)
Public Const ChartAreaKey As String
Visual C++
public:
literal String^ ChartAreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ChartLegendItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The ChartLegendItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChartLegendItemKey
Visual Basic (Declaration)
Public Const ChartLegendItemKey As String
Visual C++
public:
literal String^ ChartLegendItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ChartLegendKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ChartLegendKey Field
RadControlMappingKeys Class See Also Send Feedback
The ChartLegend key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChartLegendKey
Visual Basic (Declaration)
Public Const ChartLegendKey As String
Visual C++
public:
literal String^ ChartLegendKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ChartPanelKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ChartPanelKey Field
RadControlMappingKeys Class See Also Send Feedback
The ChartPanel key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChartPanelKey
Visual Basic (Declaration)
Public Const ChartPanelKey As String
Visual C++
public:
literal String^ ChartPanelKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ChartTextBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ChartTextBoxKey Field
RadControlMappingKeys Class See Also Send Feedback
The ChartTextBox key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChartTextBoxKey
Visual Basic (Declaration)
Public Const ChartTextBoxKey As String
Visual C++
public:
literal String^ ChartTextBoxKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ChartTitleKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ChartTitleKey Field
RadControlMappingKeys Class See Also Send Feedback
The ChartTitle key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ChartTitleKey
Visual Basic (Declaration)
Public Const ChartTitleKey As String
Visual C++
public:
literal String^ ChartTitleKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ClockItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ClockItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadClockItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ClockItemKey
Visual Basic (Declaration)
Public Const ClockItemKey As String
Visual C++
public:
literal String^ ClockItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ClockKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ClockKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadClock key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ClockKey
Visual Basic (Declaration)
Public Const ClockKey As String
Visual C++
public:
literal String^ ClockKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ColorPaletteViewItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ColorPaletteViewItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadColorPaletteViewItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColorPaletteViewItemKey
Visual Basic (Declaration)
Public Const ColorPaletteViewItemKey As String
Visual C++
public:
literal String^ ColorPaletteViewItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ColorPaletteViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ColorPaletteViewKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadColorPaletteView key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColorPaletteViewKey
Visual Basic (Declaration)
Public Const ColorPaletteViewKey As String
Visual C++
public:
literal String^ ColorPaletteViewKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ColorPickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ColorPickerKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadColorPicker key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColorPickerKey
Visual Basic (Declaration)
Public Const ColorPickerKey As String
Visual C++
public:
literal String^ ColorPickerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ColorSelectorKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ColorSelectorKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadColorSelector key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColorSelectorKey
Visual Basic (Declaration)
Public Const ColorSelectorKey As String
Visual C++
public:
literal String^ ColorSelectorKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ComboBoxItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ComboBoxItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The ComboBoxItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ComboBoxItemKey
Visual Basic (Declaration)
Public Const ComboBoxItemKey As String
Visual C++
public:
literal String^ ComboBoxItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ComboBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ComboBoxKey Field
RadControlMappingKeys Class See Also Send Feedback
The ComboBox key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ComboBoxKey
Visual Basic (Declaration)
Public Const ComboBoxKey As String
Visual C++
public:
literal String^ ComboBoxKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ContextMenuKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ContextMenuKey Field
RadControlMappingKeys Class See Also Send Feedback
The ContextMenu key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ContextMenuKey
Visual Basic (Declaration)
Public Const ContextMenuKey As String
Visual C++
public:
literal String^ ContextMenuKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CoverFlowItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CoverFlowItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The CoverFlowItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CoverFlowItemKey
Visual Basic (Declaration)
Public Const CoverFlowItemKey As String
Visual C++
public:
literal String^ CoverFlowItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


CoverFlowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.CoverFlowKey Field
RadControlMappingKeys Class See Also Send Feedback
The CoverFlow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CoverFlowKey
Visual Basic (Declaration)
Public Const CoverFlowKey As String
Visual C++
public:
literal String^ CoverFlowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


DatePickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.DatePickerKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadDatePicker key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DatePickerKey
Visual Basic (Declaration)
Public Const DatePickerKey As String
Visual C++
public:
literal String^ DatePickerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


DockingKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.DockingKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadDocking key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DockingKey
Visual Basic (Declaration)
Public Const DockingKey As String
Visual C++
public:
literal String^ DockingKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentHostKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.DocumentHostKey Field
RadControlMappingKeys Class See Also Send Feedback
The DocumentHost key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DocumentHostKey
Visual Basic (Declaration)
Public Const DocumentHostKey As String
Visual C++
public:
literal String^ DocumentHostKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentPaneKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.DocumentPaneKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadDocumentPane key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DocumentPaneKey
Visual Basic (Declaration)
Public Const DocumentPaneKey As String
Visual C++
public:
literal String^ DocumentPaneKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


DoughnutKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.DoughnutKey Field
RadControlMappingKeys Class See Also Send Feedback
The Doughnut key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DoughnutKey
Visual Basic (Declaration)
Public Const DoughnutKey As String
Visual C++
public:
literal String^ DoughnutKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.DropDownButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadDropDownButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownButtonKey
Visual Basic (Declaration)
Public Const DropDownButtonKey As String
Visual C++
public:
literal String^ DropDownButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ExpanderKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ExpanderKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadExpander key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ExpanderKey
Visual Basic (Declaration)
Public Const ExpanderKey As String
Visual C++
public:
literal String^ ExpanderKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ExtendedTextBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ExtendedTextBoxKey Field
RadControlMappingKeys Class See Also Send Feedback
The Masked ExtendedTextBox key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ExtendedTextBoxKey
Visual Basic (Declaration)
Public Const ExtendedTextBoxKey As String
Visual C++
public:
literal String^ ExtendedTextBoxKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


FluidContentControlKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.FluidContentControlKey Field
RadControlMappingKeys Class See Also Send Feedback
The FluidContentControl key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string FluidContentControlKey
Visual Basic (Declaration)
Public Const FluidContentControlKey As String
Visual C++
public:
literal String^ FluidContentControlKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeIndicatorKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeIndicatorKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeIndicator key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeIndicatorKey
Visual Basic (Declaration)
Public Const GaugeIndicatorKey As String
Visual C++
public:
literal String^ GaugeIndicatorKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeLinearBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeLinearBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeLinearBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeLinearBarKey
Visual Basic (Declaration)
Public Const GaugeLinearBarKey As String
Visual C++
public:
literal String^ GaugeLinearBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeLinearLabelKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeLinearLabelKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeLinearLabel key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeLinearLabelKey
Visual Basic (Declaration)
Public Const GaugeLinearLabelKey As String
Visual C++
public:
literal String^ GaugeLinearLabelKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeLinearRangeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeLinearRangeKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeLinearRange key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeLinearRangeKey
Visual Basic (Declaration)
Public Const GaugeLinearRangeKey As String
Visual C++
public:
literal String^ GaugeLinearRangeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeLinearScaleKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeLinearScaleKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeLinearScale key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeLinearScaleKey
Visual Basic (Declaration)
Public Const GaugeLinearScaleKey As String
Visual C++
public:
literal String^ GaugeLinearScaleKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeLinearTickKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeLinearTickKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeLinearTick key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeLinearTickKey
Visual Basic (Declaration)
Public Const GaugeLinearTickKey As String
Visual C++
public:
literal String^ GaugeLinearTickKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeMarkerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeMarkerKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeMarker key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeMarkerKey
Visual Basic (Declaration)
Public Const GaugeMarkerKey As String
Visual C++
public:
literal String^ GaugeMarkerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeNeedleKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeNeedleKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeNeedle key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeNeedleKey
Visual Basic (Declaration)
Public Const GaugeNeedleKey As String
Visual C++
public:
literal String^ GaugeNeedleKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeNumericIndicatorKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeNumericIndicatorKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeNumericIndicator key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeNumericIndicatorKey
Visual Basic (Declaration)
Public Const GaugeNumericIndicatorKey As String
Visual C++
public:
literal String^ GaugeNumericIndicatorKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeRadialBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeRadialBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeRadialBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeRadialBarKey
Visual Basic (Declaration)
Public Const GaugeRadialBarKey As String
Visual C++
public:
literal String^ GaugeRadialBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeRadialLabelKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeRadialLabelKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeRadialLabel key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeRadialLabelKey
Visual Basic (Declaration)
Public Const GaugeRadialLabelKey As String
Visual C++
public:
literal String^ GaugeRadialLabelKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeRadialRangeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeRadialRangeKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeRadialRange key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeRadialRangeKey
Visual Basic (Declaration)
Public Const GaugeRadialRangeKey As String
Visual C++
public:
literal String^ GaugeRadialRangeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeRadialScaleKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeRadialScaleKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeRadialScale key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeRadialScaleKey
Visual Basic (Declaration)
Public Const GaugeRadialScaleKey As String
Visual C++
public:
literal String^ GaugeRadialScaleKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeRadialTickKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeRadialTickKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeRadialTick key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeRadialTickKey
Visual Basic (Declaration)
Public Const GaugeRadialTickKey As String
Visual C++
public:
literal String^ GaugeRadialTickKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GaugeStateIndicatorKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GaugeStateIndicatorKey Field
RadControlMappingKeys Class See Also Send Feedback
The GaugeStateIndicator key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GaugeStateIndicatorKey
Visual Basic (Declaration)
Public Const GaugeStateIndicatorKey As String
Visual C++
public:
literal String^ GaugeStateIndicatorKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridResizerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridResizerKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridResizer key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridResizerKey
Visual Basic (Declaration)
Public Const GridResizerKey As String
Visual C++
public:
literal String^ GridResizerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewAggregateResultCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewAggregateResultCellKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridView AggregateResultCell key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewAggregateResultCellKey
Visual Basic (Declaration)
Public Const GridViewAggregateResultCellKey As String
Visual C++
public:
literal String^ GridViewAggregateResultCellKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewCellKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewCell key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewCellKey
Visual Basic (Declaration)
Public Const GridViewCellKey As String
Visual C++
public:
literal String^ GridViewCellKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewExpandableRowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewExpandableRowKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewExpandableRow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewExpandableRowKey
Visual Basic (Declaration)
Public Const GridViewExpandableRowKey As String
Visual C++
public:
literal String^ GridViewExpandableRowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewFooterCellKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewFooterCell key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewFooterCellKey
Visual Basic (Declaration)
Public Const GridViewFooterCellKey As String
Visual C++
public:
literal String^ GridViewFooterCellKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewFooterRowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewFooterRowKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewFooterRow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewFooterRowKey
Visual Basic (Declaration)
Public Const GridViewFooterRowKey As String
Visual C++
public:
literal String^ GridViewFooterRowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewGroupPanelCellKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewGroupPanelCell key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewGroupPanelCellKey
Visual Basic (Declaration)
Public Const GridViewGroupPanelCellKey As String
Visual C++
public:
literal String^ GridViewGroupPanelCellKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewGroupPanelItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewGroupPanelItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewGroupPanelItemKey
Visual Basic (Declaration)
Public Const GridViewGroupPanelItemKey As String
Visual C++
public:
literal String^ GridViewGroupPanelItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupPanelKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewGroupPanelKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewGroupPanel key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewGroupPanelKey
Visual Basic (Declaration)
Public Const GridViewGroupPanelKey As String
Visual C++
public:
literal String^ GridViewGroupPanelKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewGroupRowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewGroupRowKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewGroupRow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewGroupRowKey
Visual Basic (Declaration)
Public Const GridViewGroupRowKey As String
Visual C++
public:
literal String^ GridViewGroupRowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewHeaderCellKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewHeaderCell key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewHeaderCellKey
Visual Basic (Declaration)
Public Const GridViewHeaderCellKey As String
Visual C++
public:
literal String^ GridViewHeaderCellKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewHeaderRowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewHeaderRowKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewHeaderRow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewHeaderRowKey
Visual Basic (Declaration)
Public Const GridViewHeaderRowKey As String
Visual C++
public:
literal String^ GridViewHeaderRowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridView key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewKey
Visual Basic (Declaration)
Public Const GridViewKey As String
Visual C++
public:
literal String^ GridViewKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewNewRowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewNewRowKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewNewRow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewNewRowKey
Visual Basic (Declaration)
Public Const GridViewNewRowKey As String
Visual C++
public:
literal String^ GridViewNewRowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


GridViewRowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.GridViewRowKey Field
RadControlMappingKeys Class See Also Send Feedback
The GridViewRow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GridViewRowKey
Visual Basic (Declaration)
Public Const GridViewRowKey As String
Visual C++
public:
literal String^ GridViewRowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.HorizontalBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The HorizontalBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalBarKey
Visual Basic (Declaration)
Public Const HorizontalBarKey As String
Visual C++
public:
literal String^ HorizontalBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalGridLine2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.HorizontalGridLine2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The HorizontalGridLine2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalGridLine2DKey
Visual Basic (Declaration)
Public Const HorizontalGridLine2DKey As String
Visual C++
public:
literal String^ HorizontalGridLine2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalMinorTick2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.HorizontalMinorTick2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The HorizontalMinorTick2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalMinorTick2DKey
Visual Basic (Declaration)
Public Const HorizontalMinorTick2DKey As String
Visual C++
public:
literal String^ HorizontalMinorTick2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalStackedBar100Key Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.HorizontalStackedBar100Key Field
RadControlMappingKeys Class See Also Send Feedback
The HorizontalStackedBar100 key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalStackedBar100Key
Visual Basic (Declaration)
Public Const HorizontalStackedBar100Key As String
Visual C++
public:
literal String^ HorizontalStackedBar100Key

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalStackedBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.HorizontalStackedBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The HorizontalStackedBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalStackedBarKey
Visual Basic (Declaration)
Public Const HorizontalStackedBarKey As String
Visual C++
public:
literal String^ HorizontalStackedBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


HtmlPlaceholderKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.HtmlPlaceholderKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadHtmlPlaceholder key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HtmlPlaceholderKey
Visual Basic (Declaration)
Public Const HtmlPlaceholderKey As String
Visual C++
public:
literal String^ HtmlPlaceholderKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


LinearGaugeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.LinearGaugeKey Field
RadControlMappingKeys Class See Also Send Feedback
The LinearGauge key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LinearGaugeKey
Visual Basic (Declaration)
Public Const LinearGaugeKey As String
Visual C++
public:
literal String^ LinearGaugeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


LineKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.LineKey Field
RadControlMappingKeys Class See Also Send Feedback
The Line key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LineKey
Visual Basic (Declaration)
Public Const LineKey As String
Visual C++
public:
literal String^ LineKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


LineSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.LineSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The LineSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LineSeriesKey
Visual Basic (Declaration)
Public Const LineSeriesKey As String
Visual C++
public:
literal String^ LineSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MaskedTextBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MaskedTextBoxKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadMaskedTextBox key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MaskedTextBoxKey
Visual Basic (Declaration)
Public Const MaskedTextBoxKey As String
Visual C++
public:
literal String^ MaskedTextBoxKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MediaChapterKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MediaChapterKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadMediaChapter key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MediaChapterKey
Visual Basic (Declaration)
Public Const MediaChapterKey As String
Visual C++
public:
literal String^ MediaChapterKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MediaItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MediaItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadMediaItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MediaItemKey
Visual Basic (Declaration)
Public Const MediaItemKey As String
Visual C++
public:
literal String^ MediaItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MediaPlayerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MediaPlayerKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadMediaPlayer key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MediaPlayerKey
Visual Basic (Declaration)
Public Const MediaPlayerKey As String
Visual C++
public:
literal String^ MediaPlayerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MenuItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MenuItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The MenuItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MenuItemKey
Visual Basic (Declaration)
Public Const MenuItemKey As String
Visual C++
public:
literal String^ MenuItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MenuKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MenuKey Field
RadControlMappingKeys Class See Also Send Feedback
The Menu key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MenuKey
Visual Basic (Declaration)
Public Const MenuKey As String
Visual C++
public:
literal String^ MenuKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarAreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MinimizedOutlookBarAreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The MinimizedOutlookBarArea key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MinimizedOutlookBarAreaKey
Visual Basic (Declaration)
Public Const MinimizedOutlookBarAreaKey As String
Visual C++
public:
literal String^ MinimizedOutlookBarAreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.MinimizedOutlookBarItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The MinimizedOutlookBarItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MinimizedOutlookBarItemKey
Visual Basic (Declaration)
Public Const MinimizedOutlookBarItemKey As String
Visual C++
public:
literal String^ MinimizedOutlookBarItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


NumericKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.NumericKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadNumericUpDown key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string NumericKey
Visual Basic (Declaration)
Public Const NumericKey As String
Visual C++
public:
literal String^ NumericKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


OutlookBarItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.OutlookBarItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The OutlookBarItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string OutlookBarItemKey
Visual Basic (Declaration)
Public Const OutlookBarItemKey As String
Visual C++
public:
literal String^ OutlookBarItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


OutlookBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.OutlookBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The OutlookBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string OutlookBarKey
Visual Basic (Declaration)
Public Const OutlookBarKey As String
Visual C++
public:
literal String^ OutlookBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PaneGroupKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PaneGroupKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadPaneGroup key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneGroupKey
Visual Basic (Declaration)
Public Const PaneGroupKey As String
Visual C++
public:
literal String^ PaneGroupKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeaderKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PaneHeaderKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadPaneHeader key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneHeaderKey
Visual Basic (Declaration)
Public Const PaneHeaderKey As String
Visual C++
public:
literal String^ PaneHeaderKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PaneKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PaneKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadPane key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PaneKey
Visual Basic (Declaration)
Public Const PaneKey As String
Visual C++
public:
literal String^ PaneKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PanelBarItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PanelBarItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The PanelBarItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PanelBarItemKey
Visual Basic (Declaration)
Public Const PanelBarItemKey As String
Visual C++
public:
literal String^ PanelBarItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PanelBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PanelBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The PanelBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PanelBarKey
Visual Basic (Declaration)
Public Const PanelBarKey As String
Visual C++
public:
literal String^ PanelBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ParametricLineKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ParametricLineKey Field
RadControlMappingKeys Class See Also Send Feedback
The ParametricLine key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ParametricLineKey
Visual Basic (Declaration)
Public Const ParametricLineKey As String
Visual C++
public:
literal String^ ParametricLineKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PickerTextBoxKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PickerTextBoxKey Field
RadControlMappingKeys Class See Also Send Feedback
The PickerTextBox key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PickerTextBoxKey
Visual Basic (Declaration)
Public Const PickerTextBoxKey As String
Visual C++
public:
literal String^ PickerTextBoxKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PickerToggleButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PickerToggleButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The PickerToggleButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PickerToggleButtonKey
Visual Basic (Declaration)
Public Const PickerToggleButtonKey As String
Visual C++
public:
literal String^ PickerToggleButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PieKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PieKey Field
RadControlMappingKeys Class See Also Send Feedback
The Pie key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PieKey
Visual Basic (Declaration)
Public Const PieKey As String
Visual C++
public:
literal String^ PieKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


PlaylistPresenterKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.PlaylistPresenterKey Field
RadControlMappingKeys Class See Also Send Feedback
The PlaylistPresenter key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PlaylistPresenterKey
Visual Basic (Declaration)
Public Const PlaylistPresenterKey As String
Visual C++
public:
literal String^ PlaylistPresenterKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ProgressBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ProgressBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadProgressBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ProgressBarKey
Visual Basic (Declaration)
Public Const ProgressBarKey As String
Visual C++
public:
literal String^ ProgressBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolbarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.QuickAccessToolbarKey Field
RadControlMappingKeys Class See Also Send Feedback
The QuickAccessToolbar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string QuickAccessToolbarKey
Visual Basic (Declaration)
Public Const QuickAccessToolbarKey As String
Visual C++
public:
literal String^ QuickAccessToolbarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RadChartKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RadChartKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadChart key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RadChartKey
Visual Basic (Declaration)
Public Const RadChartKey As String
Visual C++
public:
literal String^ RadChartKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RadGaugeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RadGaugeKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadGauge key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RadGaugeKey
Visual Basic (Declaration)
Public Const RadGaugeKey As String
Visual C++
public:
literal String^ RadGaugeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RadialGaugeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RadialGaugeKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadialGauge key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RadialGaugeKey
Visual Basic (Declaration)
Public Const RadialGaugeKey As String
Visual C++
public:
literal String^ RadialGaugeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RadioButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RadioButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRadioButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RadioButtonKey
Visual Basic (Declaration)
Public Const RadioButtonKey As String
Visual C++
public:
literal String^ RadioButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RangeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RangeKey Field
RadControlMappingKeys Class See Also Send Feedback
The Range key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RangeKey
Visual Basic (Declaration)
Public Const RangeKey As String
Visual C++
public:
literal String^ RangeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RangeSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RangeSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The RangeSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RangeSeriesKey
Visual Basic (Declaration)
Public Const RangeSeriesKey As String
Visual C++
public:
literal String^ RangeSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RibbonBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRibbonBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RibbonBarKey
Visual Basic (Declaration)
Public Const RibbonBarKey As String
Visual C++
public:
literal String^ RibbonBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RibbonButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRibbonButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RibbonButtonKey
Visual Basic (Declaration)
Public Const RibbonButtonKey As String
Visual C++
public:
literal String^ RibbonButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonDropDownButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RibbonDropDownButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRibbonDropDownButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RibbonDropDownButtonKey
Visual Basic (Declaration)
Public Const RibbonDropDownButtonKey As String
Visual C++
public:
literal String^ RibbonDropDownButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonGroupKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RibbonGroupKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRibbonGroup key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RibbonGroupKey
Visual Basic (Declaration)
Public Const RibbonGroupKey As String
Visual C++
public:
literal String^ RibbonGroupKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonRadioButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RibbonRadioButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRibbonRadioButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RibbonRadioButtonKey
Visual Basic (Declaration)
Public Const RibbonRadioButtonKey As String
Visual C++
public:
literal String^ RibbonRadioButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonSplitButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.RibbonSplitButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadRibbonSplitButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RibbonSplitButtonKey
Visual Basic (Declaration)
Public Const RibbonSplitButtonKey As String
Visual C++
public:
literal String^ RibbonSplitButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SchedulerKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadScheduler key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SchedulerKey
Visual Basic (Declaration)
Public Const SchedulerKey As String
Visual C++
public:
literal String^ SchedulerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerPresenterKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SchedulerPresenterKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadScheduler SchedulerPresenter key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SchedulerPresenterKey
Visual Basic (Declaration)
Public Const SchedulerPresenterKey As String
Visual C++
public:
literal String^ SchedulerPresenterKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The Series key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SeriesKey
Visual Basic (Declaration)
Public Const SeriesKey As String
Visual C++
public:
literal String^ SeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SliderKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SliderKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadSlider key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SliderKey
Visual Basic (Declaration)
Public Const SliderKey As String
Visual C++
public:
literal String^ SliderKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplineAreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplineAreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The SplineArea key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplineAreaKey
Visual Basic (Declaration)
Public Const SplineAreaKey As String
Visual C++
public:
literal String^ SplineAreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplineAreaSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplineAreaSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The SplineAreaSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplineAreaSeriesKey
Visual Basic (Declaration)
Public Const SplineAreaSeriesKey As String
Visual C++
public:
literal String^ SplineAreaSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplineKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplineKey Field
RadControlMappingKeys Class See Also Send Feedback
The Spline key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplineKey
Visual Basic (Declaration)
Public Const SplineKey As String
Visual C++
public:
literal String^ SplineKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplineRangeKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplineRangeKey Field
RadControlMappingKeys Class See Also Send Feedback
The SplineRange key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplineRangeKey
Visual Basic (Declaration)
Public Const SplineRangeKey As String
Visual C++
public:
literal String^ SplineRangeKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplineRangeSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplineRangeSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The SplineRangeSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplineRangeSeriesKey
Visual Basic (Declaration)
Public Const SplineRangeSeriesKey As String
Visual C++
public:
literal String^ SplineRangeSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplineSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplineSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The SplineSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplineSeriesKey
Visual Basic (Declaration)
Public Const SplineSeriesKey As String
Visual C++
public:
literal String^ SplineSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplitButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplitButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadSplitButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplitButtonKey
Visual Basic (Declaration)
Public Const SplitButtonKey As String
Visual C++
public:
literal String^ SplitButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


SplitContainerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.SplitContainerKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadSplitContainer key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string SplitContainerKey
Visual Basic (Declaration)
Public Const SplitContainerKey As String
Visual C++
public:
literal String^ SplitContainerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedArea100Key Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedArea100Key Field
RadControlMappingKeys Class See Also Send Feedback
The StackedArea100 key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedArea100Key
Visual Basic (Declaration)
Public Const StackedArea100Key As String
Visual C++
public:
literal String^ StackedArea100Key

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedArea100SeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedArea100SeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedArea100Series key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedArea100SeriesKey
Visual Basic (Declaration)
Public Const StackedArea100SeriesKey As String
Visual C++
public:
literal String^ StackedArea100SeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedAreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedAreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedArea key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedAreaKey
Visual Basic (Declaration)
Public Const StackedAreaKey As String
Visual C++
public:
literal String^ StackedAreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedAreaSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedAreaSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedAreaSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedAreaSeriesKey
Visual Basic (Declaration)
Public Const StackedAreaSeriesKey As String
Visual C++
public:
literal String^ StackedAreaSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedBar100Key Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedBar100Key Field
RadControlMappingKeys Class See Also Send Feedback
The StackedBar100 key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedBar100Key
Visual Basic (Declaration)
Public Const StackedBar100Key As String
Visual C++
public:
literal String^ StackedBar100Key

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedBarKey
Visual Basic (Declaration)
Public Const StackedBarKey As String
Visual C++
public:
literal String^ StackedBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedLineKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedLineKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedLine key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedLineKey
Visual Basic (Declaration)
Public Const StackedLineKey As String
Visual C++
public:
literal String^ StackedLineKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedLineSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedLineSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedLineSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedLineSeriesKey
Visual Basic (Declaration)
Public Const StackedLineSeriesKey As String
Visual C++
public:
literal String^ StackedLineSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineArea100Key Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedSplineArea100Key Field
RadControlMappingKeys Class See Also Send Feedback
The StackedSplineArea100 key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedSplineArea100Key
Visual Basic (Declaration)
Public Const StackedSplineArea100Key As String
Visual C++
public:
literal String^ StackedSplineArea100Key

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineArea100SeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedSplineArea100SeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedSplineArea100Series key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedSplineArea100SeriesKey
Visual Basic (Declaration)
Public Const StackedSplineArea100SeriesKey As String
Visual C++
public:
literal String^ StackedSplineArea100SeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineAreaKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedSplineAreaKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedSplineArea key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedSplineAreaKey
Visual Basic (Declaration)
Public Const StackedSplineAreaKey As String
Visual C++
public:
literal String^ StackedSplineAreaKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineAreaSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedSplineAreaSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedSplineAreaSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedSplineAreaSeriesKey
Visual Basic (Declaration)
Public Const StackedSplineAreaSeriesKey As String
Visual C++
public:
literal String^ StackedSplineAreaSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedSplineKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedSpline key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedSplineKey
Visual Basic (Declaration)
Public Const StackedSplineKey As String
Visual C++
public:
literal String^ StackedSplineKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StackedSplineSeriesKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StackedSplineSeriesKey Field
RadControlMappingKeys Class See Also Send Feedback
The StackedSplineSeries key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StackedSplineSeriesKey
Visual Basic (Declaration)
Public Const StackedSplineSeriesKey As String
Visual C++
public:
literal String^ StackedSplineSeriesKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


StickKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.StickKey Field
RadControlMappingKeys Class See Also Send Feedback
The Stick key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string StickKey
Visual Basic (Declaration)
Public Const StickKey As String
Visual C++
public:
literal String^ StickKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TabControlKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TabControlKey Field
RadControlMappingKeys Class See Also Send Feedback
The TabControl key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabControlKey
Visual Basic (Declaration)
Public Const TabControlKey As String
Visual C++
public:
literal String^ TabControlKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TabItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TabItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The TabItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabItemKey
Visual Basic (Declaration)
Public Const TabItemKey As String
Visual C++
public:
literal String^ TabItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TickBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TickBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadTickBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TickBarKey
Visual Basic (Declaration)
Public Const TickBarKey As String
Visual C++
public:
literal String^ TickBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TileViewItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TileViewItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The TileViewItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TileViewItemKey
Visual Basic (Declaration)
Public Const TileViewItemKey As String
Visual C++
public:
literal String^ TileViewItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TileViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TileViewKey Field
RadControlMappingKeys Class See Also Send Feedback
The TileView key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TileViewKey
Visual Basic (Declaration)
Public Const TileViewKey As String
Visual C++
public:
literal String^ TileViewKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TimePickerKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TimePickerKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadTimePicker key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimePickerKey
Visual Basic (Declaration)
Public Const TimePickerKey As String
Visual C++
public:
literal String^ TimePickerKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TimeSlotItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadScheduler TimeSlotItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSlotItemKey
Visual Basic (Declaration)
Public Const TimeSlotItemKey As String
Visual C++
public:
literal String^ TimeSlotItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleButtonKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ToggleButtonKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadToggleButton key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToggleButtonKey
Visual Basic (Declaration)
Public Const ToggleButtonKey As String
Visual C++
public:
literal String^ ToggleButtonKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ToolBarKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ToolBarKey Field
RadControlMappingKeys Class See Also Send Feedback
The ToolBar key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBarKey
Visual Basic (Declaration)
Public Const ToolBarKey As String
Visual C++
public:
literal String^ ToolBarKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ToolBarTrayKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ToolBarTrayKey Field
RadControlMappingKeys Class See Also Send Feedback
The ToolBarTray key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolBarTrayKey
Visual Basic (Declaration)
Public Const ToolBarTrayKey As String
Visual C++
public:
literal String^ ToolBarTrayKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.ToolWindowKey Field
RadControlMappingKeys Class See Also Send Feedback
The ToolWindow key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToolWindowKey
Visual Basic (Declaration)
Public Const ToolWindowKey As String
Visual C++
public:
literal String^ ToolWindowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewCellKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TreeListViewCellKey Field
RadControlMappingKeys Class See Also Send Feedback
The TreeListViewCell key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeListViewCellKey
Visual Basic (Declaration)
Public Const TreeListViewCellKey As String
Visual C++
public:
literal String^ TreeListViewCellKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewColumnKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TreeListViewColumnKey Field
RadControlMappingKeys Class See Also Send Feedback
The TreeListViewColumn key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeListViewColumnKey
Visual Basic (Declaration)
Public Const TreeListViewColumnKey As String
Visual C++
public:
literal String^ TreeListViewColumnKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TreeListViewItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The TreeListViewItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeListViewItemKey
Visual Basic (Declaration)
Public Const TreeListViewItemKey As String
Visual C++
public:
literal String^ TreeListViewItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TreeListViewKey Field
RadControlMappingKeys Class See Also Send Feedback
The TreeListView key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeListViewKey
Visual Basic (Declaration)
Public Const TreeListViewKey As String
Visual C++
public:
literal String^ TreeListViewKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TreeViewItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TreeViewItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The TreeViewItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeViewItemKey
Visual Basic (Declaration)
Public Const TreeViewItemKey As String
Visual C++
public:
literal String^ TreeViewItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


TreeViewKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.TreeViewKey Field
RadControlMappingKeys Class See Also Send Feedback
The TreeView key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TreeViewKey
Visual Basic (Declaration)
Public Const TreeViewKey As String
Visual C++
public:
literal String^ TreeViewKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


UniformGridKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.UniformGridKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadUniformGrid key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string UniformGridKey
Visual Basic (Declaration)
Public Const UniformGridKey As String
Visual C++
public:
literal String^ UniformGridKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


UploadItemKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.UploadItemKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadUploadItem key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string UploadItemKey
Visual Basic (Declaration)
Public Const UploadItemKey As String
Visual C++
public:
literal String^ UploadItemKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


UploadKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.UploadKey Field
RadControlMappingKeys Class See Also Send Feedback
The RadUpload key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string UploadKey
Visual Basic (Declaration)
Public Const UploadKey As String
Visual C++
public:
literal String^ UploadKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalGridLine2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.VerticalGridLine2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The VerticalGridLine2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalGridLine2DKey
Visual Basic (Declaration)
Public Const VerticalGridLine2DKey As String
Visual C++
public:
literal String^ VerticalGridLine2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalMinorTick2DKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.VerticalMinorTick2DKey Field
RadControlMappingKeys Class See Also Send Feedback
The VerticalMinorTick2D key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalMinorTick2DKey
Visual Basic (Declaration)
Public Const VerticalMinorTick2DKey As String
Visual C++
public:
literal String^ VerticalMinorTick2DKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


WindowKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.WindowKey Field
RadControlMappingKeys Class See Also Send Feedback
The Window key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WindowKey
Visual Basic (Declaration)
Public Const WindowKey As String
Visual C++
public:
literal String^ WindowKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitleKey Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadControlMappingKeys..::.WindowTitleKey Field
RadControlMappingKeys Class See Also Send Feedback
The WindowTitle key.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WindowTitleKey
Visual Basic (Declaration)
Public Const WindowTitleKey As String
Visual C++
public:
literal String^ WindowTitleKey

See Also

RadControlMappingKeys Class
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow Class
Members See Also Send Feedback
Represents the Silverlight RadCoverFlow wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadCoverFlow : ListBox
Visual Basic (Declaration)
Public Class RadCoverFlow _
    Inherits ListBox
Visual C++
public ref class RadCoverFlow : public ListBox

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBox
Telerik.WebAii.Controls.Xaml..::.RadCoverFlow

See Also

RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow Members
RadCoverFlow Class Constructors Methods Properties See Also Send Feedback

The RadCoverFlow type exposes the following members.

Constructors

Name | Description
RadCoverFlow | Initializes a new instance of the RadCoverFlow class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCoverFlow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBox.)
BorderBrush | (Inherited from ListBox.)
BorderThickness | (Inherited from ListBox.)
CameraDistance | Get the camera distance RadCoverFlow control value.
CameraRotation | Get the camera rotation RadCoverFlow control value.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CoverItems | Gets the list of all the RadCoverFlowItem elements.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ListBox.)
DistanceBetweenItems | Get the RadCoverFlow control distance between items value.
DistanceFromSelectedItem | Get the RadCoverFlow control distance from selected item value.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBox.)
FontSize | (Inherited from ListBox.)
FontStretch | (Inherited from ListBox.)
FontStyle | (Inherited from ListBox.)
FontWeight | (Inherited from ListBox.)
Foreground | (Inherited from ListBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReflectionEnabled | Get the RadCoverFlow control IsReflectionEnabled value.
IsTabStop | (Inherited from ListBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemChangeDelay | Get the RadCoverFlow control item change delay value.
Items | (Inherited from ListBox.)
ItemScale | Get the RadCoverFlow control item scale value.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
OffsetX | Get the RadCoverFlow control offset X value.
OffsetY | Get the RadCoverFlow control offset X value.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RotationY | Get the RadCoverFlow control rotation Y value.
SelectedIndex | (Inherited from ListBox.)
TabIndex | (Inherited from ListBox.)
TabNavigation | (Inherited from ListBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow Constructor
RadCoverFlow Class See Also Send Feedback
Initializes a new instance of the RadCoverFlow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCoverFlow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCoverFlow()

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow Methods
RadCoverFlow Class See Also Send Feedback

The RadCoverFlow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBox.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCoverFlow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.AnySibling Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.AssignReference Method
RadCoverFlow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadCoverFlow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.GetProperty Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.GetRectangle Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.Highlight Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.InitializeMappings Method
RadCoverFlow Class See Also Send Feedback
Initializes the mapping of the RadCoverFlow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.InvokeMethod Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.NextSibling Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.Parent Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.PreviousSibling Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.ScrollToVisible Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow Properties
RadCoverFlow Class See Also Send Feedback

The RadCoverFlow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBox.)
BorderBrush | (Inherited from ListBox.)
BorderThickness | (Inherited from ListBox.)
CameraDistance | Get the camera distance RadCoverFlow control value.
CameraRotation | Get the camera rotation RadCoverFlow control value.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CoverItems | Gets the list of all the RadCoverFlowItem elements.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ListBox.)
DistanceBetweenItems | Get the RadCoverFlow control distance between items value.
DistanceFromSelectedItem | Get the RadCoverFlow control distance from selected item value.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBox.)
FontSize | (Inherited from ListBox.)
FontStretch | (Inherited from ListBox.)
FontStyle | (Inherited from ListBox.)
FontWeight | (Inherited from ListBox.)
Foreground | (Inherited from ListBox.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBox.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBox.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReflectionEnabled | Get the RadCoverFlow control IsReflectionEnabled value.
IsTabStop | (Inherited from ListBox.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemChangeDelay | Get the RadCoverFlow control item change delay value.
Items | (Inherited from ListBox.)
ItemScale | Get the RadCoverFlow control item scale value.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
OffsetX | Get the RadCoverFlow control offset X value.
OffsetY | Get the RadCoverFlow control offset X value.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBox.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RotationY | Get the RadCoverFlow control rotation Y value.
SelectedIndex | (Inherited from ListBox.)
TabIndex | (Inherited from ListBox.)
TabNavigation | (Inherited from ListBox.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBox.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


CameraDistance Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.CameraDistance Property
RadCoverFlow Class See Also Send Feedback
Get the camera distance RadCoverFlow control value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double CameraDistance { get; }
Visual Basic (Declaration)
Public ReadOnly Property CameraDistance As Double
Visual C++
public:
property double CameraDistance {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


CameraRotation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.CameraRotation Property
RadCoverFlow Class See Also Send Feedback
Get the camera rotation RadCoverFlow control value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double CameraRotation { get; }
Visual Basic (Declaration)
Public ReadOnly Property CameraRotation As Double
Visual C++
public:
property double CameraRotation {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


CoverItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.CoverItems Property
RadCoverFlow Class See Also Send Feedback
Gets the list of all the RadCoverFlowItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadCoverFlowItem> CoverItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property CoverItems As IList(Of RadCoverFlowItem)
Visual C++
public:
property IList<RadCoverFlowItem^>^ CoverItems {
    IList<RadCoverFlowItem^>^ get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


DistanceBetweenItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.DistanceBetweenItems Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control distance between items value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DistanceBetweenItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property DistanceBetweenItems As Double
Visual C++
public:
property double DistanceBetweenItems {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


DistanceFromSelectedItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.DistanceFromSelectedItem Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control distance from selected item value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DistanceFromSelectedItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property DistanceFromSelectedItem As Double
Visual C++
public:
property double DistanceFromSelectedItem {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


IsReflectionEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.IsReflectionEnabled Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control IsReflectionEnabled value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsReflectionEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReflectionEnabled As Boolean
Visual C++
public:
property bool IsReflectionEnabled {
    bool get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


ItemChangeDelay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.ItemChangeDelay Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control item change delay value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan ItemChangeDelay { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemChangeDelay As TimeSpan
Visual C++
public:
property TimeSpan^ ItemChangeDelay {
    TimeSpan^ get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


ItemScale Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.ItemScale Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control item scale value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double ItemScale { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemScale As Double
Visual C++
public:
property double ItemScale {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


OffsetX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.OffsetX Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control offset X value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double OffsetX { get; }
Visual Basic (Declaration)
Public ReadOnly Property OffsetX As Double
Visual C++
public:
property double OffsetX {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


OffsetY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.OffsetY Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control offset X value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double OffsetY { get; }
Visual Basic (Declaration)
Public ReadOnly Property OffsetY As Double
Visual C++
public:
property double OffsetY {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


RotationY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.RotationY Property
RadCoverFlow Class See Also Send Feedback
Get the RadCoverFlow control rotation Y value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double RotationY { get; }
Visual Basic (Declaration)
Public ReadOnly Property RotationY As Double
Visual C++
public:
property double RotationY {
    double get ();
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlow..::.XamlTag Property
RadCoverFlow Class See Also Send Feedback
Get the xaml tag of RadCoverFlow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCoverFlow Class
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlowItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem Class
Members See Also Send Feedback
Represents the Silverlight RadCoverFlowItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadCoverFlowItem : ListBoxItem
Visual Basic (Declaration)
Public Class RadCoverFlowItem _
    Inherits ListBoxItem
Visual C++
public ref class RadCoverFlowItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBoxItem
Telerik.WebAii.Controls.Xaml..::.RadCoverFlowItem

See Also

RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlowItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem Members
RadCoverFlowItem Class Constructors Methods Properties See Also Send Feedback

The RadCoverFlowItem type exposes the following members.

Constructors

Name | Description
RadCoverFlowItem | Initializes a new instance of the RadCoverFlowItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on a cover flow item. Can be clicked only if the item is visible.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCoverFlowItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
ContentImage | Get the item image if any.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsContentValid | Gets a value indicating whether to display the error image, or not.
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsLoading | Gets a value indicating whether to display the loading animation.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlowItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlowItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem Constructor
RadCoverFlowItem Class See Also Send Feedback
Initializes a new instance of the RadCoverFlowItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCoverFlowItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCoverFlowItem()

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlowItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem Methods
RadCoverFlowItem Class See Also Send Feedback

The RadCoverFlowItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on a cover flow item. Can be clicked only if the item is visible.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadCoverFlowItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.AnySibling Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.Click Method
RadCoverFlowItem Class See Also Send Feedback
Simulates user clicking on a cover flow item. Can be clicked only if the item is visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Click()
Visual Basic (Declaration)
Public Sub Click
Visual C++
public:
void Click()

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.GetProperty Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.GetRectangle Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.Highlight Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.InitializeMappings Method
RadCoverFlowItem Class See Also Send Feedback
Initializes the mapping of the RadCoverFlowItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.InvokeMethod Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.NextSibling Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.Parent Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.PreviousSibling Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.ScrollToVisible Method
RadCoverFlowItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
RadCoverFlowItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadCoverFlowItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem Properties
RadCoverFlowItem Class See Also Send Feedback

The RadCoverFlowItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
ContentImage | Get the item image if any.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the index of the item.
IsContentValid | Gets a value indicating whether to display the error image, or not.
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsLoading | Gets a value indicating whether to display the loading animation.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlowItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


ContentImage Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.ContentImage Property
RadCoverFlowItem Class See Also Send Feedback
Get the item image if any.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Image ContentImage { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentImage As Image
Visual C++
public:
property Image^ ContentImage {
    Image^ get ();
}

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.Index Property
RadCoverFlowItem Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsContentValid Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.IsContentValid Property
RadCoverFlowItem Class See Also Send Feedback
Gets a value indicating whether to display the error image, or not.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsContentValid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsContentValid As Boolean
Visual C++
public:
property bool IsContentValid {
    bool get ();
}

Field Value

True if the error image should be displayed; otherwise, false.

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsLoading Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.IsLoading Property
RadCoverFlowItem Class See Also Send Feedback
Gets a value indicating whether to display the loading animation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsLoading { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLoading As Boolean
Visual C++
public:
property bool IsLoading {
    bool get ();
}

Field Value

True if the loading animation should be displayed; otherwise, false.

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadCoverFlowItem..::.XamlTag Property
RadCoverFlowItem Class See Also Send Feedback
Get the xaml tag of RadCoverFlowItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCoverFlowItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadDatePicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Class
Members See Also Send Feedback
Represents the DatePicker control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDatePicker : Control
Visual Basic (Declaration)
Public Class RadDatePicker _
    Inherits Control
Visual C++
public ref class RadDatePicker : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadDatePicker

See Also

RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


RadDatePicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Members
RadDatePicker Class Constructors Methods Properties See Also Send Feedback

The RadDatePicker type exposes the following members.

Constructors

Name | Description
RadDatePicker | Initializes a new instance of the RadDatePicker class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDatePicker control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDate | Simulates user clicking on the calendar button to select the date.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TypeText | Simulates user entering text into the DatePicker text box.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupToClose | Useful upon any action over the popup that closes it.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Calendar | Gets the calendar from the popup if open; returns 'null' otherwise.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Culture | Gets the Culture representation of the date picker.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HeaderVisibility | Gets whether the calendar header is visible.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the date picker calendar popup is opened. Returns 'false' also if the calendar popup cannot be found with the current control template.
IsReadOnly | Gets whether the date picker is read only.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsTodayHighlighted | Gets whether the date picker today date is highlighted.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedDate | Gets the DatePicker selected date via an automation property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the DatePicker input text box.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadDatePicker control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadDatePicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Constructor
RadDatePicker Class See Also Send Feedback
Initializes a new instance of the RadDatePicker class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDatePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDatePicker()

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadDatePicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Methods
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDatePicker control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDate | Simulates user clicking on the calendar button to select the date.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TypeText | Simulates user entering text into the DatePicker text box.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupToClose | Useful upon any action over the popup that closes it.

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.AnySibling Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.GetProperty Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.GetRectangle Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Highlight Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.InitializeMappings Method
RadDatePicker Class See Also Send Feedback
Initializes the mapping of the RadDatePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.InvokeMethod Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.MouseClick Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType) | Triggers mouse click on the text box from the given type.
MouseClick(MouseClickType, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.MouseClick Method (MouseClickType)
RadDatePicker Class See Also Send Feedback
Triggers mouse click on the text box from the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The type of the mouse click.

See Also

RadDatePicker Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.MouseClick Method (MouseClickType, Int32)
RadDatePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.

See Also

RadDatePicker Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32, Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.MouseClick Method (MouseClickType, Int32, Boolean)
RadDatePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.

See Also

RadDatePicker Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.NextSibling Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Parent Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.PreviousSibling Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.ScrollToVisible Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Xaml Namespace


SelectDate Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.SelectDate Method
RadDatePicker Class See Also Send Feedback
Simulates user clicking on the calendar button to select the date.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectDate(
    string buttonText
)
Visual Basic (Declaration)
Public Sub SelectDate ( _
    buttonText As String _
)
Visual C++
public:
void SelectDate(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text of the button to be clicked.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the calendar popup is not open.
System..::.ArgumentException | Thrown when the calendar has no buttons with the given text.

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


TogglePopup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.TogglePopup Method
RadDatePicker Class See Also Send Feedback
Simulates user clicking on the calendar image to open/close the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePopup()
Visual Basic (Declaration)
Public Sub TogglePopup
Visual C++
public:
void TogglePopup()

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


TypeText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.TypeText Method
RadDatePicker Class See Also Send Feedback
Simulates user entering text into the DatePicker text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TypeText(
    string text
)
Visual Basic (Declaration)
Public Sub TypeText ( _
    text As String _
)
Visual C++
public:
void TypeText(
    String^ text
)

Parameters

text
Type: System..::.String
The text to enter.

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


WaitPopupToClose Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.WaitPopupToClose Method
RadDatePicker Class See Also Send Feedback
Useful upon any action over the popup that closes it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitPopupToClose(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupToClose ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupToClose(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadDatePicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker Properties
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Calendar | Gets the calendar from the popup if open; returns 'null' otherwise.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Culture | Gets the Culture representation of the date picker.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HeaderVisibility | Gets whether the calendar header is visible.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the date picker calendar popup is opened. Returns 'false' also if the calendar popup cannot be found with the current control template.
IsReadOnly | Gets whether the date picker is read only.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsTodayHighlighted | Gets whether the date picker today date is highlighted.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedDate | Gets the DatePicker selected date via an automation property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the DatePicker input text box.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadDatePicker control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


Calendar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Calendar Property
RadDatePicker Class See Also Send Feedback
Gets the calendar from the popup if open; returns 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadCalendar Calendar { get; }
Visual Basic (Declaration)
Public ReadOnly Property Calendar As RadCalendar
Visual C++
public:
property RadCalendar^ Calendar {
    RadCalendar^ get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


Culture Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Culture Property
RadDatePicker Class See Also Send Feedback
Gets the Culture representation of the date picker.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Culture { get; }
Visual Basic (Declaration)
Public ReadOnly Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.HeaderVisibility Property
RadDatePicker Class See Also Send Feedback
Gets whether the calendar header is visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility HeaderVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderVisibility As Visibility
Visual C++
public:
property Visibility HeaderVisibility {
    Visibility get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.IsPopupOpen Property
RadDatePicker Class See Also Send Feedback
Get whether the date picker calendar popup is opened. Returns 'false' also if the calendar popup cannot be found with the current control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.IsReadOnly Property
RadDatePicker Class See Also Send Feedback
Gets whether the date picker is read only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsTodayHighlighted Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.IsTodayHighlighted Property
RadDatePicker Class See Also Send Feedback
Gets whether the date picker today date is highlighted.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsTodayHighlighted { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTodayHighlighted As Boolean
Visual C++
public:
property bool IsTodayHighlighted {
    bool get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedDate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.SelectedDate Property
RadDatePicker Class See Also Send Feedback
Gets the DatePicker selected date via an automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDate As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.Text Property
RadDatePicker Class See Also Send Feedback
Get the text of the DatePicker input text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDatePicker..::.XamlTag Property
RadDatePicker Class See Also Send Feedback
Get the xaml tag of RadDatePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocking Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight control wrapper. Serves as a holder for the child split containers and tool windows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDocking : ItemsControl
Visual Basic (Declaration)
Public Class RadDocking _
    Inherits ItemsControl
Visual C++
public ref class RadDocking : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadDocking

See Also

RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


RadDocking Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking Members
RadDocking Class Constructors Methods Properties See Also Send Feedback

The RadDocking type exposes the following members.

Constructors

Name | Description
RadDocking | Initializes a new instance of the RadDocking class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
AutoHidePaneHeaderPin | Simulates user clicking on the auto hide area pin button.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DockDocumentPaneInContainer | Overloaded.
DockGroupInContainer | Overloaded.
DockGroupInRoot | Dock the group into the docking panel root dock position.
DockPaneInContainer | Overloaded.
DockPaneInRoot | Dock the pane into the docking root panel.
DockWindowInContainer | Simulates user docking a tool window into a split container undocking it first from the current container.
DockWindowInRoot | Simulates user docking a tool window into the root of the docking panel.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
GroupHeaderClose | Simulates user clicking on the pane group close button. Recommended in case of update layout since an explicit Refresh() is needed.
GroupHeaderPin | Simulates user clicking on the group header pin button. Recommended in case of update layout since an explicit Refresh() is needed.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePin | Overloaded.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
UndockDocumentPane | Undock a pane from the document host split container group.
UndockGroup | Undock the group from the split container.
UndockPane | Undock the pane from the split container group.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BottomAutoHide | Get the auto hide area positioned on bottom.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DocumentHost | Get the DocumentHost if defined.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftAutoHide | Get the auto hide area positioned on the left.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightAutoHide | Get the auto hide area positioned on the right.
SplitContainers | Get the list of the root docking panel split containers. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
ToolWindows | Get the list of ToolWindow controls. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TopAutoHide | Get the auto hide area positioned on top.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
VisibleWindows | Get the list of currently visible windows.
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadDocking control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocking Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking Constructor
RadDocking Class See Also Send Feedback
Initializes a new instance of the RadDocking class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDocking()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDocking()

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocking Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking Methods
RadDocking Class See Also Send Feedback

The RadDocking type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
AutoHidePaneHeaderPin | Simulates user clicking on the auto hide area pin button.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DockDocumentPaneInContainer | Overloaded.
DockGroupInContainer | Overloaded.
DockGroupInRoot | Dock the group into the docking panel root dock position.
DockPaneInContainer | Overloaded.
DockPaneInRoot | Dock the pane into the docking root panel.
DockWindowInContainer | Simulates user docking a tool window into a split container undocking it first from the current container.
DockWindowInRoot | Simulates user docking a tool window into the root of the docking panel.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
GroupHeaderClose | Simulates user clicking on the pane group close button. Recommended in case of update layout since an explicit Refresh() is needed.
GroupHeaderPin | Simulates user clicking on the group header pin button. Recommended in case of update layout since an explicit Refresh() is needed.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePin | Overloaded.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
UndockDocumentPane | Undock a pane from the document host split container group.
UndockGroup | Undock the group from the split container.
UndockPane | Undock the pane from the split container group.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.AnySibling Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.AssignReference Method
RadDocking Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadDocking.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHidePaneHeaderPin Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.AutoHidePaneHeaderPin Method
RadDocking Class See Also Send Feedback
Simulates user clicking on the auto hide area pin button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void AutoHidePaneHeaderPin(
    AutoHideArea autoHideArea
)
Visual Basic (Declaration)
Public Sub AutoHidePaneHeaderPin ( _
    autoHideArea As AutoHideArea _
)
Visual C++
public:
void AutoHidePaneHeaderPin(
    AutoHideArea^ autoHideArea
)

Parameters

autoHideArea
Type: Telerik.WebAii.Controls.Xaml..::.AutoHideArea
The auto hide are the pane to pin back belongs.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


DockDocumentPaneInContainer Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockDocumentPaneInContainer Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
DockDocumentPaneInContainer(RadPane, RadSplitContainer, DockPosition) | Dock the document pane into container.
DockDocumentPaneInContainer(FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection) | Dock the document pane into container first undocking it from the current container.

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


DockDocumentPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockDocumentPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)
RadDocking Class See Also Send Feedback
Dock the document pane into container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockDocumentPaneInContainer(
    RadPane pane,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockDocumentPaneInContainer ( _
    pane As RadPane, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockDocumentPaneInContainer(
    RadPane^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

pane
Type: Telerik.WebAii.Controls.Xaml..::.RadPane
The document pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.

See Also

RadDocking Class
DockDocumentPaneInContainer Overload
Telerik.WebAii.Controls.Xaml Namespace


DockDocumentPaneInContainer Method (FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockDocumentPaneInContainer Method (FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection)
RadDocking Class See Also Send Feedback
Dock the document pane into container first undocking it from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockDocumentPaneInContainer(
    FrameworkElement pane,
    RadSplitContainer targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)
Visual Basic (Declaration)
Public Sub DockDocumentPaneInContainer ( _
    pane As FrameworkElement, _
    targetContainer As RadSplitContainer, _
    position As DockPosition, _
    undockDirection As DockingDragDirection _
)
Visual C++
public:
void DockDocumentPaneInContainer(
    FrameworkElement^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)

Parameters

pane
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The document pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.
undockDirection
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to undock to.

See Also

RadDocking Class
DockDocumentPaneInContainer Overload
Telerik.WebAii.Controls.Xaml Namespace


DockGroupInContainer Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockGroupInContainer Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
DockGroupInContainer(RadPaneGroup, RadSplitContainer, DockPosition) | Dock the given group into the container undocking it first from the current container.
DockGroupInContainer(RadPaneGroup, RadSplitContainer, DockPosition, DockingDragDirection) | Dock the given group into the container undocking it first from the current container.

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition)
RadDocking Class See Also Send Feedback
Dock the given group into the container undocking it first from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockGroupInContainer(
    RadPaneGroup paneGroup,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockGroupInContainer ( _
    paneGroup As RadPaneGroup, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockGroupInContainer(
    RadPaneGroup^ paneGroup,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.

See Also

RadDocking Class
DockGroupInContainer Overload
Telerik.WebAii.Controls.Xaml Namespace


DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition, DockingDragDirection)
RadDocking Class See Also Send Feedback
Dock the given group into the container undocking it first from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockGroupInContainer(
    RadPaneGroup paneGroup,
    RadSplitContainer targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)
Visual Basic (Declaration)
Public Sub DockGroupInContainer ( _
    paneGroup As RadPaneGroup, _
    targetContainer As RadSplitContainer, _
    position As DockPosition, _
    undockDirection As DockingDragDirection _
)
Visual C++
public:
void DockGroupInContainer(
    RadPaneGroup^ paneGroup,
    RadSplitContainer^ targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position to dock with.
undockDirection
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to undock the group first.

See Also

RadDocking Class
DockGroupInContainer Overload
Telerik.WebAii.Controls.Xaml Namespace


DockGroupInRoot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockGroupInRoot Method
RadDocking Class See Also Send Feedback
Dock the group into the docking panel root dock position.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockGroupInRoot(
    RadPaneGroup paneGroup,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockGroupInRoot ( _
    paneGroup As RadPaneGroup, _
    position As DockPosition _
)
Visual C++
public:
void DockGroupInRoot(
    RadPaneGroup^ paneGroup,
    DockPosition position
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be docked.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position of the docking panel root.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


DockPaneInContainer Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockPaneInContainer Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
DockPaneInContainer(RadPane, RadSplitContainer, DockPosition) | Dock the given pane into the container.
DockPaneInContainer(FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection) | Dock the given pane into the container.

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


DockPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)
RadDocking Class See Also Send Feedback
Dock the given pane into the container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockPaneInContainer(
    RadPane pane,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockPaneInContainer ( _
    pane As RadPane, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockPaneInContainer(
    RadPane^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

pane
Type: Telerik.WebAii.Controls.Xaml..::.RadPane
The pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock into.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.

See Also

RadDocking Class
DockPaneInContainer Overload
Telerik.WebAii.Controls.Xaml Namespace


DockPaneInContainer Method (FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockPaneInContainer Method (FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection)
RadDocking Class See Also Send Feedback
Dock the given pane into the container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockPaneInContainer(
    FrameworkElement pane,
    RadSplitContainer targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)
Visual Basic (Declaration)
Public Sub DockPaneInContainer ( _
    pane As FrameworkElement, _
    targetContainer As RadSplitContainer, _
    position As DockPosition, _
    undockDirection As DockingDragDirection _
)
Visual C++
public:
void DockPaneInContainer(
    FrameworkElement^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)

Parameters

pane
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.
undockDirection
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to undock to.

See Also

RadDocking Class
DockPaneInContainer Overload
Telerik.WebAii.Controls.Xaml Namespace


DockPaneInRoot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockPaneInRoot Method
RadDocking Class See Also Send Feedback
Dock the pane into the docking root panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockPaneInRoot(
    RadPane pane,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockPaneInRoot ( _
    pane As RadPane, _
    position As DockPosition _
)
Visual C++
public:
void DockPaneInRoot(
    RadPane^ pane,
    DockPosition position
)

Parameters

pane
Type: Telerik.WebAii.Controls.Xaml..::.RadPane
The pane to be docked.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position of the docking panel root.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


DockWindowInContainer Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockWindowInContainer Method
RadDocking Class See Also Send Feedback
Simulates user docking a tool window into a split container undocking it first from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockWindowInContainer(
    ToolWindow window,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockWindowInContainer ( _
    window As ToolWindow, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockWindowInContainer(
    ToolWindow^ window,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

window
Type: Telerik.WebAii.Controls.Xaml..::.ToolWindow
The window to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target split container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position to drag to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


DockWindowInRoot Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DockWindowInRoot Method
RadDocking Class See Also Send Feedback
Simulates user docking a tool window into the root of the docking panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DockWindowInRoot(
    ToolWindow window,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockWindowInRoot ( _
    window As ToolWindow, _
    position As DockPosition _
)
Visual C++
public:
void DockWindowInRoot(
    ToolWindow^ window,
    DockPosition position
)

Parameters

window
Type: Telerik.WebAii.Controls.Xaml..::.ToolWindow
The window to be docked.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The docking position to drag to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.GetProperty Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.GetRectangle Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


GroupHeaderClose Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.GroupHeaderClose Method
RadDocking Class See Also Send Feedback
Simulates user clicking on the pane group close button. Recommended in case of update layout since an explicit Refresh() is needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GroupHeaderClose(
    RadPaneGroup paneGroup
)
Visual Basic (Declaration)
Public Sub GroupHeaderClose ( _
    paneGroup As RadPaneGroup _
)
Visual C++
public:
void GroupHeaderClose(
    RadPaneGroup^ paneGroup
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The group header the close button belongs to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


GroupHeaderPin Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.GroupHeaderPin Method
RadDocking Class See Also Send Feedback
Simulates user clicking on the group header pin button. Recommended in case of update layout since an explicit Refresh() is needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GroupHeaderPin(
    RadPaneGroup paneGroup
)
Visual Basic (Declaration)
Public Sub GroupHeaderPin ( _
    paneGroup As RadPaneGroup _
)
Visual C++
public:
void GroupHeaderPin(
    RadPaneGroup^ paneGroup
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The group header the pin button belongs to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.Highlight Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.InitializeMappings Method
RadDocking Class See Also Send Feedback
Initializes the mapping of the RadDocking control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.InvokeMethod Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.NextSibling Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.Parent Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.PreviousSibling Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.ScrollToVisible Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


TogglePin Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.TogglePin Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
TogglePin(AutoHideArea) | Simulates user clicking on the pin button of the given auto hide are to pin the pane.
TogglePin(RadPaneGroup) | Simulates user clicking on the pin button of the given group pane to unpin the pane.

See Also

RadDocking Class
RadDocking Members
Telerik.WebAii.Controls.Xaml Namespace


TogglePin Method (AutoHideArea)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.TogglePin Method (AutoHideArea)
RadDocking Class See Also Send Feedback
Simulates user clicking on the pin button of the given auto hide are to pin the pane.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePin(
    AutoHideArea hideArea
)
Visual Basic (Declaration)
Public Sub TogglePin ( _
    hideArea As AutoHideArea _
)
Visual C++
public:
void TogglePin(
    AutoHideArea^ hideArea
)

Parameters

hideArea
Type: Telerik.WebAii.Controls.Xaml..::.AutoHideArea
The auto hide are control.

See Also

RadDocking Class
TogglePin Overload
Telerik.WebAii.Controls.Xaml Namespace


TogglePin Method (RadPaneGroup)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.TogglePin Method (RadPaneGroup)
RadDocking Class See Also Send Feedback
Simulates user clicking on the pin button of the given group pane to unpin the pane.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePin(
    RadPaneGroup paneGroup
)
Visual Basic (Declaration)
Public Sub TogglePin ( _
    paneGroup As RadPaneGroup _
)
Visual C++
public:
void TogglePin(
    RadPaneGroup^ paneGroup
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group control.

See Also

RadDocking Class
TogglePin Overload
Telerik.WebAii.Controls.Xaml Namespace


UndockDocumentPane Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.UndockDocumentPane Method
RadDocking Class See Also Send Feedback
Undock a pane from the document host split container group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UndockDocumentPane(
    FrameworkElement documentPane,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub UndockDocumentPane ( _
    documentPane As FrameworkElement, _
    direction As DockingDragDirection _
)
Visual C++
public:
void UndockDocumentPane(
    FrameworkElement^ documentPane,
    DockingDragDirection direction
)

Parameters

documentPane
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The document pane to be undocked.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to drag to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


UndockGroup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.UndockGroup Method
RadDocking Class See Also Send Feedback
Undock the group from the split container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UndockGroup(
    RadPaneGroup paneGroup,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub UndockGroup ( _
    paneGroup As RadPaneGroup, _
    direction As DockingDragDirection _
)
Visual C++
public:
void UndockGroup(
    RadPaneGroup^ paneGroup,
    DockingDragDirection direction
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be undocked.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to drag to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


UndockPane Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.UndockPane Method
RadDocking Class See Also Send Feedback
Undock the pane from the split container group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UndockPane(
    FrameworkElement pane,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub UndockPane ( _
    pane As FrameworkElement, _
    direction As DockingDragDirection _
)
Visual C++
public:
void UndockPane(
    FrameworkElement^ pane,
    DockingDragDirection direction
)

Parameters

pane
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The pane control to be undocked.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to drag to.

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocking Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking Properties
RadDocking Class See Also Send Feedback

The RadDocking type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BottomAutoHide | Get the auto hide area positioned on bottom.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DocumentHost | Get the DocumentHost if defined.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftAutoHide | Get the auto hide area positioned on the left.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightAutoHide | Get the auto hide area positioned on the right.
SplitContainers | Get the list of the root docking panel split containers. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
ToolWindows | Get the list of ToolWindow controls. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TopAutoHide | Get the auto hide area positioned on top.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
VisibleWindows | Get the list of currently visible windows.
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadDocking control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


BottomAutoHide Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.BottomAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on bottom.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AutoHideArea BottomAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ BottomAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentHost Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.DocumentHost Property
RadDocking Class See Also Send Feedback
Get the DocumentHost if defined.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public DocumentHost DocumentHost { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentHost As DocumentHost
Visual C++
public:
property DocumentHost^ DocumentHost {
    DocumentHost^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


LeftAutoHide Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.LeftAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on the left.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AutoHideArea LeftAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ LeftAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


RightAutoHide Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.RightAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on the right.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AutoHideArea RightAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ RightAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


SplitContainers Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.SplitContainers Property
RadDocking Class See Also Send Feedback
Get the list of the root docking panel split containers. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadSplitContainer> SplitContainers { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainers As IList(Of RadSplitContainer)
Visual C++
public:
property IList<RadSplitContainer^>^ SplitContainers {
    IList<RadSplitContainer^>^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.ToolWindows Property
RadDocking Class See Also Send Feedback
Get the list of ToolWindow controls. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ToolWindow> ToolWindows { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToolWindows As IList(Of ToolWindow)
Visual C++
public:
property IList<ToolWindow^>^ ToolWindows {
    IList<ToolWindow^>^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


TopAutoHide Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.TopAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on top.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AutoHideArea TopAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ TopAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


VisibleWindows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.VisibleWindows Property
RadDocking Class See Also Send Feedback
Get the list of currently visible windows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ToolWindow> VisibleWindows { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibleWindows As IList(Of ToolWindow)
Visual C++
public:
property IList<ToolWindow^>^ VisibleWindows {
    IList<ToolWindow^>^ get ();
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocking..::.XamlTag Property
RadDocking Class See Also Send Feedback
Get the xaml tag of the RadDocking control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDocking Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocumentPane Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadDocumentPane control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDocumentPane : RadPane
Visual Basic (Declaration)
Public Class RadDocumentPane _
    Inherits RadPane
Visual C++
public ref class RadDocumentPane : public RadPane

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadPane
Telerik.WebAii.Controls.Xaml..::.RadDocumentPane

See Also

RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


RadDocumentPane Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane Members
RadDocumentPane Class Constructors Methods Properties See Also Send Feedback

The RadDocumentPane type exposes the following members.

Constructors

Name | Description
RadDocumentPane | Initializes a new instance of the RadDocumentPane class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the pane. (Inherited from RadPane.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocumentPane control. (Overrides RadPane..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutoHideHeight | Gets the auto hide height value. (Inherited from RadPane.)
AutoHideWidth | Gets the auto hide width value. (Inherited from RadPane.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanDockInDocumentHost | Gets a value indicating whether this pane can be docked into the document host. (Inherited from RadPane.)
CanFloat | Gets a value indicating whether this pane can be floated. (Inherited from RadPane.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row. (Inherited from RadTabItem.)
IsEnabled | (Inherited from ContentControl.)
IsHidden | Gets a value indicating whether this pane is hidden. (Inherited from RadPane.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host. (Inherited from RadPane.)
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group. (Inherited from RadPane.)
IsMouseOver | Gets whether the mouse is over the control. (Inherited from RadTabItem.)
IsPinned | Gets a value indicating whether this pane is pinned. (Inherited from RadPane.)
IsSelected | Get or set whether the tab item is selected. (Inherited from RadTabItem.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index. (Inherited from RadTabItem.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document pane control. (Overrides RadPane..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocumentPane Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane Constructor
RadDocumentPane Class See Also Send Feedback
Initializes a new instance of the RadDocumentPane class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDocumentPane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDocumentPane()

See Also

RadDocumentPane Class
Telerik.WebAii.Controls.Xaml Namespace


RadDocumentPane Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane Methods
RadDocumentPane Class See Also Send Feedback

The RadDocumentPane type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the pane. (Inherited from RadPane.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocumentPane control. (Overrides RadPane..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.AnySibling Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.GetProperty Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.GetRectangle Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.Highlight Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.InitializeMappings Method
RadDocumentPane Class See Also Send Feedback
Initializes the mapping of the RadDocumentPane control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadDocumentPane Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.InvokeMethod Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.NextSibling Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.Parent Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.PreviousSibling Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.ScrollToVisible Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members
Telerik.WebAii.Controls.Xaml Namespace


RadDocumentPane Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane Properties
RadDocumentPane Class See Also Send Feedback

The RadDocumentPane type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutoHideHeight | Gets the auto hide height value. (Inherited from RadPane.)
AutoHideWidth | Gets the auto hide width value. (Inherited from RadPane.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanDockInDocumentHost | Gets a value indicating whether this pane can be docked into the document host. (Inherited from RadPane.)
CanFloat | Gets a value indicating whether this pane can be floated. (Inherited from RadPane.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row. (Inherited from RadTabItem.)
IsEnabled | (Inherited from ContentControl.)
IsHidden | Gets a value indicating whether this pane is hidden. (Inherited from RadPane.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host. (Inherited from RadPane.)
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group. (Inherited from RadPane.)
IsMouseOver | Gets whether the mouse is over the control. (Inherited from RadTabItem.)
IsPinned | Gets a value indicating whether this pane is pinned. (Inherited from RadPane.)
IsSelected | Get or set whether the tab item is selected. (Inherited from RadTabItem.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index. (Inherited from RadTabItem.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document pane control. (Overrides RadPane..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDocumentPane..::.XamlTag Property
RadDocumentPane Class See Also Send Feedback
Get the xaml tag of the document pane control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDocumentPane Class
Telerik.WebAii.Controls.Xaml Namespace


RadDropDownButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton Class
Members See Also Send Feedback
Represents the RadDropDownButton for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadDropDownButton : RadButton
Visual Basic (Declaration)
Public Class RadDropDownButton _
    Inherits RadButton
Visual C++
public ref class RadDropDownButton : public RadButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Button
Telerik.WebAii.Controls.Xaml..::.RadButton
Telerik.WebAii.Controls.Xaml..::.RadDropDownButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonDropDownButton

See Also

RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadDropDownButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton Members
RadDropDownButton Class Constructors Methods Properties See Also Send Feedback

The RadDropDownButton type exposes the following members.

Constructors

Name | Description
RadDropDownButton | Initializes a new instance of the RadDropDownButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDropDownButton control. (Overrides RadButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Opens/closes the drop down.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AutoOpenDelay | Gets or sets whether the popup opens when mouse hovers for pointed milliseconds. Value of zero means no auto open.
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles.
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDownHeight | Gets or sets the Height of the popup.
DropDownIndicatorVisibility | Gets the DropDown indicator visibility.
DropDownPopup | Get the popup of the drop down button.
DropDownWidth | Gets or sets the Width of the popup.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPopupOpen | Gets whether the drop down popup is open.
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button. (Inherited from RadButton.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadButton control. (Overrides RadButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadDropDownButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton Constructor
RadDropDownButton Class See Also Send Feedback
Initializes a new instance of the RadDropDownButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDropDownButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDropDownButton()

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadDropDownButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton Methods
RadDropDownButton Class See Also Send Feedback

The RadDropDownButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDropDownButton control. (Overrides RadButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Opens/closes the drop down.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.AnySibling Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.GetProperty Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.GetRectangle Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.Highlight Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.InitializeMappings Method
RadDropDownButton Class See Also Send Feedback
Initializes the mapping of the RadDropDownButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.InvokeMethod Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.NextSibling Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.Parent Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.PreviousSibling Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.ScrollToVisible Method
RadDropDownButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
RadDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.Toggle Method
RadDropDownButton Class See Also Send Feedback
Opens/closes the drop down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadDropDownButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton Properties
RadDropDownButton Class See Also Send Feedback

The RadDropDownButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AutoOpenDelay | Gets or sets whether the popup opens when mouse hovers for pointed milliseconds. Value of zero means no auto open.
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles.
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDownHeight | Gets or sets the Height of the popup.
DropDownIndicatorVisibility | Gets the DropDown indicator visibility.
DropDownPopup | Get the popup of the drop down button.
DropDownWidth | Gets or sets the Width of the popup.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPopupOpen | Gets whether the drop down popup is open.
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button. (Inherited from RadButton.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadButton control. (Overrides RadButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


AutoOpenDelay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.AutoOpenDelay Property
RadDropDownButton Class See Also Send Feedback
Gets or sets whether the popup opens when mouse hovers for pointed milliseconds. Value of zero means no auto open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan AutoOpenDelay { get; set; }
Visual Basic (Declaration)
Public Property AutoOpenDelay As TimeSpan
Visual C++
public:
property TimeSpan^ AutoOpenDelay {
    TimeSpan^ get ();
    void set (TimeSpan^ value);
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


CloseOnEscape Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.CloseOnEscape Property
RadDropDownButton Class See Also Send Feedback
Gets or sets whether the popup closes when the Escape key toggles.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CloseOnEscape { get; set; }
Visual Basic (Declaration)
Public Property CloseOnEscape As Boolean
Visual C++
public:
property bool CloseOnEscape {
    bool get ();
    void set (bool value);
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.DropDownHeight Property
RadDropDownButton Class See Also Send Feedback
Gets or sets the Height of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double
Visual C++
public:
property double DropDownHeight {
    double get ();
    void set (double value);
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownIndicatorVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.DropDownIndicatorVisibility Property
RadDropDownButton Class See Also Send Feedback
Gets the DropDown indicator visibility.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility DropDownIndicatorVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownIndicatorVisibility As Visibility
Visual C++
public:
property Visibility DropDownIndicatorVisibility {
    Visibility get ();
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownPopup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.DropDownPopup Property
RadDropDownButton Class See Also Send Feedback
Get the popup of the drop down button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Popup DropDownPopup { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownPopup As Popup
Visual C++
public:
property Popup^ DropDownPopup {
    Popup^ get ();
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.DropDownWidth Property
RadDropDownButton Class See Also Send Feedback
Gets or sets the Width of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double
Visual C++
public:
property double DropDownWidth {
    double get ();
    void set (double value);
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.IsPopupOpen Property
RadDropDownButton Class See Also Send Feedback
Gets whether the drop down popup is open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadDropDownButton..::.XamlTag Property
RadDropDownButton Class See Also Send Feedback
Get the xaml tag of RadButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadExpander Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander Class
Members See Also Send Feedback
Represents the RadExpander for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadExpander : ContentControl
Visual Basic (Declaration)
Public Class RadExpander _
    Inherits ContentControl
Visual C++
public ref class RadExpander : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadExpander

See Also

RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


RadExpander Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander Members
RadExpander Class Constructors Methods Properties See Also Send Feedback

The RadExpander type exposes the following members.

Constructors

Name | Description
RadExpander | Initializes a new instance of the RadExpander class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadExpander control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Simulates user clicking on the toggle button to expand/collapse the content.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the expander content presenter element.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderText | Get the header text of the expander.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsExpanded | Get the 'IsExpanded' RadExpander value via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadExpander control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


RadExpander Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander Constructor
RadExpander Class See Also Send Feedback
Initializes a new instance of the RadExpander class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadExpander()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadExpander()

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


RadExpander Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander Methods
RadExpander Class See Also Send Feedback

The RadExpander type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadExpander control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Simulates user clicking on the toggle button to expand/collapse the content.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.AnySibling Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.AssignReference Method
RadExpander Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadExpander.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.GetProperty Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.GetRectangle Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.Highlight Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.InitializeMappings Method
RadExpander Class See Also Send Feedback
Initializes the mapping of the RadExpander control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.InvokeMethod Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.NextSibling Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.Parent Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.PreviousSibling Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.ScrollToVisible Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members
Telerik.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.Toggle Method
RadExpander Class See Also Send Feedback
Simulates user clicking on the toggle button to expand/collapse the content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


RadExpander Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander Properties
RadExpander Class See Also Send Feedback

The RadExpander type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the expander content presenter element.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderText | Get the header text of the expander.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsExpanded | Get the 'IsExpanded' RadExpander value via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadExpander control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.ContentPresenterElement Property
RadExpander Class See Also Send Feedback
Get the expander content presenter element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.HeaderText Property
RadExpander Class See Also Send Feedback
Get the header text of the expander.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.IsExpanded Property
RadExpander Class See Also Send Feedback
Get the 'IsExpanded' RadExpander value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadExpander..::.XamlTag Property
RadExpander Class See Also Send Feedback
Get the xaml tag of RadExpander control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadExpander Class
Telerik.WebAii.Controls.Xaml Namespace


RadFluidContentControl Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl Class
Members See Also Send Feedback
Represents the Silverlight RadFluidContentControl wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadFluidContentControl : ContentControl
Visual Basic (Declaration)
Public Class RadFluidContentControl _
    Inherits ContentControl
Visual C++
public ref class RadFluidContentControl : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadFluidContentControl

See Also

RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


RadFluidContentControl Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl Members
RadFluidContentControl Class Constructors Methods Properties See Also Send Feedback

The RadFluidContentControl type exposes the following members.

Constructors

Name | Description
RadFluidContentControl | Initializes a new instance of the RadFluidContentControl class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TileViewItemKey control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeContentPresenter | Get the large content presenter of the fuild content control.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NormalContentPresenter | Get the normal content presenter of the fuild content control.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SmallContentPresenter | Get the small content presenter of the fuild content control.
State | Get the fluid content control state.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of FluidContentControl control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadFluidContentControl Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl Constructor
RadFluidContentControl Class See Also Send Feedback
Initializes a new instance of the RadFluidContentControl class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadFluidContentControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadFluidContentControl()

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadFluidContentControl Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl Methods
RadFluidContentControl Class See Also Send Feedback

The RadFluidContentControl type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TileViewItemKey control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.AnySibling Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.GetProperty Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.GetRectangle Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.Highlight Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.InitializeMappings Method
RadFluidContentControl Class See Also Send Feedback
Initializes the mapping of the TileViewItemKey control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.InvokeMethod Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.NextSibling Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.Parent Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.PreviousSibling Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.ScrollToVisible Method
RadFluidContentControl Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
RadFluidContentControl Members
Telerik.WebAii.Controls.Xaml Namespace


RadFluidContentControl Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl Properties
RadFluidContentControl Class See Also Send Feedback

The RadFluidContentControl type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeContentPresenter | Get the large content presenter of the fuild content control.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NormalContentPresenter | Get the normal content presenter of the fuild content control.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SmallContentPresenter | Get the small content presenter of the fuild content control.
State | Get the fluid content control state.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of FluidContentControl control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


LargeContentPresenter Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.LargeContentPresenter Property
RadFluidContentControl Class See Also Send Feedback
Get the large content presenter of the fuild content control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter LargeContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property LargeContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ LargeContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


NormalContentPresenter Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.NormalContentPresenter Property
RadFluidContentControl Class See Also Send Feedback
Get the normal content presenter of the fuild content control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter NormalContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property NormalContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ NormalContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


SmallContentPresenter Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.SmallContentPresenter Property
RadFluidContentControl Class See Also Send Feedback
Get the small content presenter of the fuild content control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter SmallContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property SmallContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ SmallContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


State Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.State Property
RadFluidContentControl Class See Also Send Feedback
Get the fluid content control state.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public FluidContentControlState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As FluidContentControlState
Visual C++
public:
property FluidContentControlState State {
    FluidContentControlState get ();
}

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadFluidContentControl..::.XamlTag Property
RadFluidContentControl Class See Also Send Feedback
Get the xaml tag of FluidContentControl control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadFluidContentControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridResizer Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadGridResizer control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadGridResizer : Control
Visual Basic (Declaration)
Public Class RadGridResizer _
    Inherits Control
Visual C++
public ref class RadGridResizer : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadGridResizer

See Also

RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


RadGridResizer Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer Members
RadGridResizer Class Constructors Methods Properties See Also Send Feedback

The RadGridResizer type exposes the following members.

Constructors

Name | Description
RadGridResizer | Initializes a new instance of the RadGridResizer class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking GridResizer control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resize | Drags the resizer with the given offset.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get the grid resizer orientation.
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ShowsPreview | Gets whether the RadGridResizer will show a "ghost" preview of its position.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the grid resizer control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridResizer Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer Constructor
RadGridResizer Class See Also Send Feedback
Initializes a new instance of the RadGridResizer class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGridResizer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadGridResizer()

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridResizer Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer Methods
RadGridResizer Class See Also Send Feedback

The RadGridResizer type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking GridResizer control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resize | Drags the resizer with the given offset.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.AnySibling Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.GetProperty Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.GetRectangle Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.Highlight Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.InitializeMappings Method
RadGridResizer Class See Also Send Feedback
Initializes the mapping of the RadDocking GridResizer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.InvokeMethod Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.NextSibling Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.Parent Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.PreviousSibling Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


Resize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.Resize Method
RadGridResizer Class See Also Send Feedback
Drags the resizer with the given offset.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resize(
    int offset
)
Visual Basic (Declaration)
Public Sub Resize ( _
    offset As Integer _
)
Visual C++
public:
void Resize(
    int offset
)

Parameters

offset
Type: System..::.Int32
The offset to drag the resizer with. Accepts either positive (up/right resize) or negative (down/left) value.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the the resizer is not visible.

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.ScrollToVisible Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members
Telerik.WebAii.Controls.Xaml Namespace


RadGridResizer Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer Properties
RadGridResizer Class See Also Send Feedback

The RadGridResizer type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get the grid resizer orientation.
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ShowsPreview | Gets whether the RadGridResizer will show a "ghost" preview of its position.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the grid resizer control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.Orientation Property
RadGridResizer Class See Also Send Feedback
Get the grid resizer orientation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
}

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


ShowsPreview Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.ShowsPreview Property
RadGridResizer Class See Also Send Feedback
Gets whether the RadGridResizer will show a "ghost" preview of its position.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ShowsPreview { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowsPreview As Boolean
Visual C++
public:
property bool ShowsPreview {
    bool get ();
}

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridResizer..::.XamlTag Property
RadGridResizer Class See Also Send Feedback
Get the xaml tag of the grid resizer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadGridResizer Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadGridView : Control
Visual Basic (Declaration)
Public Class RadGridView _
    Inherits Control
Visual C++
public ref class RadGridView : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadGridView

See Also

RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


RadGridView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView Members
RadGridView Class Constructors Methods Properties See Also Send Feedback

The RadGridView type exposes the following members.

Constructors

Name | Description
RadGridView | Initializes a new instance of the RadGridView class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AddNewRow | Insert new row and commits the edit of the new row.
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
CollapseGroupRow | Collapse the group row with the given index.
CommitNewRow | Commits the edit of the new row.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
ExpandGroupRow | Expand the group row with the given index.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
GroupBy | Group the grid dragging the header cell with the given index.
GroupPanelItemClose | Close the group panel item with the given index.
HeaderClick | Simulates user clicking on a header cell and refreshes the grid.
HideNewRow | Hides the new inserted row.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollHorizontally | Drags the horizontal scrollbar thumb to scroll with the given offset.
ScrollToVisible | Overloaded.
ScrollVertically | Scroll the gridview content using the mouse wheel.
ScrollVerticallyWithScrollThumb | Drags the vertical scrollbar thumb to scroll with the given offset.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ShowNewRow | Insert new row.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserSelect | Gets a value indicating whether the RadGridView can be edited.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CurrentItem | Gets the current item.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
FooterRow | Get the RadGridView footer row.
Foreground | (Inherited from Control.)
GroupPanel | Get the RadGridView group panel.
GroupRows | Get the list of RadGridView group rows.
HeaderRow | Get the RadGridView header row.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBar | Get the RadGridView horizontal scrollbar.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | Gets a value indicating whether the RadGridView can be edited.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NewRow | Get the RadGridView new row.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RowIndicatorVisibility | Gets or sets the row indicator visibility.
Rows | Get the list of RadGridView rows.
SelectedItem | Gets the Selected item.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBar | Get the RadGridView vertical scrollbar.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadGridView control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView Constructor
RadGridView Class See Also Send Feedback
Initializes a new instance of the RadGridView class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGridView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadGridView()

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView Methods
RadGridView Class See Also Send Feedback

The RadGridView type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AddNewRow | Insert new row and commits the edit of the new row.
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
CollapseGroupRow | Collapse the group row with the given index.
CommitNewRow | Commits the edit of the new row.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
ExpandGroupRow | Expand the group row with the given index.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
GroupBy | Group the grid dragging the header cell with the given index.
GroupPanelItemClose | Close the group panel item with the given index.
HeaderClick | Simulates user clicking on a header cell and refreshes the grid.
HideNewRow | Hides the new inserted row.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the GridView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollHorizontally | Drags the horizontal scrollbar thumb to scroll with the given offset.
ScrollToVisible | Overloaded.
ScrollVertically | Scroll the gridview content using the mouse wheel.
ScrollVerticallyWithScrollThumb | Drags the vertical scrollbar thumb to scroll with the given offset.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ShowNewRow | Insert new row.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


AddNewRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.AddNewRow Method
RadGridView Class See Also Send Feedback
Insert new row and commits the edit of the new row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void AddNewRow(
    string text
)
Visual Basic (Declaration)
Public Sub AddNewRow ( _
    text As String _
)
Visual C++
public:
void AddNewRow(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.AddNewRow(System.String)"]

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.AnySibling Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.AssignReference Method
RadGridView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


CollapseGroupRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.CollapseGroupRow Method
RadGridView Class See Also Send Feedback
Collapse the group row with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CollapseGroupRow(
    int rowIndex
)
Visual Basic (Declaration)
Public Sub CollapseGroupRow ( _
    rowIndex As Integer _
)
Visual C++
public:
void CollapseGroupRow(
    int rowIndex
)

Parameters

rowIndex
Type: System..::.Int32
Group row index.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


CommitNewRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.CommitNewRow Method
RadGridView Class See Also Send Feedback
Commits the edit of the new row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CommitNewRow(
    string text
)
Visual Basic (Declaration)
Public Sub CommitNewRow ( _
    text As String _
)
Visual C++
public:
void CommitNewRow(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.CommitNewRow(System.String)"]

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


ExpandGroupRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.ExpandGroupRow Method
RadGridView Class See Also Send Feedback
Expand the group row with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ExpandGroupRow(
    int rowIndex
)
Visual Basic (Declaration)
Public Sub ExpandGroupRow ( _
    rowIndex As Integer _
)
Visual C++
public:
void ExpandGroupRow(
    int rowIndex
)

Parameters

rowIndex
Type: System..::.Int32
Group row index.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.GetProperty Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.GetRectangle Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


GroupBy Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.GroupBy Method
RadGridView Class See Also Send Feedback
Group the grid dragging the header cell with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GroupBy(
    int headerCellIndex
)
Visual Basic (Declaration)
Public Sub GroupBy ( _
    headerCellIndex As Integer _
)
Visual C++
public:
void GroupBy(
    int headerCellIndex
)

Parameters

headerCellIndex
Type: System..::.Int32
Header cell index.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


GroupPanelItemClose Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.GroupPanelItemClose Method
RadGridView Class See Also Send Feedback
Close the group panel item with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void GroupPanelItemClose(
    int groupPanelItemIndex
)
Visual Basic (Declaration)
Public Sub GroupPanelItemClose ( _
    groupPanelItemIndex As Integer _
)
Visual C++
public:
void GroupPanelItemClose(
    int groupPanelItemIndex
)

Parameters

groupPanelItemIndex
Type: System..::.Int32
Group panel item index.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.HeaderClick Method
RadGridView Class See Also Send Feedback
Simulates user clicking on a header cell and refreshes the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HeaderClick(
    int headerCellIndex
)
Visual Basic (Declaration)
Public Sub HeaderClick ( _
    headerCellIndex As Integer _
)
Visual C++
public:
void HeaderClick(
    int headerCellIndex
)

Parameters

headerCellIndex
Type: System..::.Int32

[Missing <param name="headerCellIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.HeaderClick(System.Int32)"]

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


HideNewRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.HideNewRow Method
RadGridView Class See Also Send Feedback
Hides the new inserted row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HideNewRow()
Visual Basic (Declaration)
Public Sub HideNewRow
Visual C++
public:
void HideNewRow()

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.Highlight Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.InitializeMappings Method
RadGridView Class See Also Send Feedback
Initializes the mapping of the GridView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.InvokeMethod Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.NextSibling Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.Parent Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.PreviousSibling Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollHorizontally Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.ScrollHorizontally Method
RadGridView Class See Also Send Feedback
Drags the horizontal scrollbar thumb to scroll with the given offset.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollHorizontally(
    int offset
)
Visual Basic (Declaration)
Public Sub ScrollHorizontally ( _
    offset As Integer _
)
Visual C++
public:
void ScrollHorizontally(
    int offset
)

Parameters

offset
Type: System..::.Int32
The offset to drag the scrollbar thumb with. Accepts either positive (right scroll) or negative (left) value.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the scrollbar is not visible.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.ScrollToVisible Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollVertically Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.ScrollVertically Method
RadGridView Class See Also Send Feedback
Scroll the gridview content using the mouse wheel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollVertically(
    int offset,
    MouseWheelTurnDirection direction,
    bool clickOrNot
)
Visual Basic (Declaration)
Public Sub ScrollVertically ( _
    offset As Integer, _
    direction As MouseWheelTurnDirection, _
    clickOrNot As Boolean _
)
Visual C++
public:
void ScrollVertically(
    int offset,
    MouseWheelTurnDirection direction,
    bool clickOrNot
)

Parameters

offset
Type: System..::.Int32

[Missing <param name="offset"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ScrollVertically(System.Int32,ArtOfTest.WebAii.Core.MouseWheelTurnDirection,System.Boolean)"]

direction
Type: ArtOfTest.WebAii.Core..::.MouseWheelTurnDirection

[Missing <param name="direction"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ScrollVertically(System.Int32,ArtOfTest.WebAii.Core.MouseWheelTurnDirection,System.Boolean)"]

clickOrNot
Type: System..::.Boolean

[Missing <param name="clickOrNot"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ScrollVertically(System.Int32,ArtOfTest.WebAii.Core.MouseWheelTurnDirection,System.Boolean)"]

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollVerticallyWithScrollThumb Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.ScrollVerticallyWithScrollThumb Method
RadGridView Class See Also Send Feedback
Drags the vertical scrollbar thumb to scroll with the given offset.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollVerticallyWithScrollThumb(
    int offset
)
Visual Basic (Declaration)
Public Sub ScrollVerticallyWithScrollThumb ( _
    offset As Integer _
)
Visual C++
public:
void ScrollVerticallyWithScrollThumb(
    int offset
)

Parameters

offset
Type: System..::.Int32
The offset to drag the scrollbar thumb with. Accepts either positive (up scroll) or negative (down) value.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the scrollbar is not visible.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


ShowNewRow Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.ShowNewRow Method
RadGridView Class See Also Send Feedback
Insert new row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowNewRow(
    int rowIndex
)
Visual Basic (Declaration)
Public Sub ShowNewRow ( _
    rowIndex As Integer _
)
Visual C++
public:
void ShowNewRow(
    int rowIndex
)

Parameters

rowIndex
Type: System..::.Int32

[Missing <param name="rowIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ShowNewRow(System.Int32)"]

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


RadGridView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView Properties
RadGridView Class See Also Send Feedback

The RadGridView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserSelect | Gets a value indicating whether the RadGridView can be edited.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CurrentItem | Gets the current item.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
FooterRow | Get the RadGridView footer row.
Foreground | (Inherited from Control.)
GroupPanel | Get the RadGridView group panel.
GroupRows | Get the list of RadGridView group rows.
HeaderRow | Get the RadGridView header row.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBar | Get the RadGridView horizontal scrollbar.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | Gets a value indicating whether the RadGridView can be edited.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NewRow | Get the RadGridView new row.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RowIndicatorVisibility | Gets or sets the row indicator visibility.
Rows | Get the list of RadGridView rows.
SelectedItem | Gets the Selected item.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBar | Get the RadGridView vertical scrollbar.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadGridView control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


CanUserSelect Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.CanUserSelect Property
RadGridView Class See Also Send Feedback
Gets a value indicating whether the RadGridView can be edited.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanUserSelect { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanUserSelect As Boolean
Visual C++
public:
property bool CanUserSelect {
    bool get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


CurrentItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.CurrentItem Property
RadGridView Class See Also Send Feedback
Gets the current item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Object CurrentItem { get; set; }
Visual Basic (Declaration)
Public Property CurrentItem As Object
Visual C++
public:
property Object^ CurrentItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


FooterRow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.FooterRow Property
RadGridView Class See Also Send Feedback
Get the RadGridView footer row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewFooterRow FooterRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property FooterRow As GridViewFooterRow
Visual C++
public:
property GridViewFooterRow^ FooterRow {
    GridViewFooterRow^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


GroupPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.GroupPanel Property
RadGridView Class See Also Send Feedback
Get the RadGridView group panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewGroupPanel GroupPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupPanel As GridViewGroupPanel
Visual C++
public:
property GridViewGroupPanel^ GroupPanel {
    GridViewGroupPanel^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


GroupRows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.GroupRows Property
RadGridView Class See Also Send Feedback
Get the list of RadGridView group rows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewGroupRow> GroupRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupRows As IList(Of GridViewGroupRow)
Visual C++
public:
property IList<GridViewGroupRow^>^ GroupRows {
    IList<GridViewGroupRow^>^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderRow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.HeaderRow Property
RadGridView Class See Also Send Feedback
Get the RadGridView header row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewHeaderRow HeaderRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderRow As GridViewHeaderRow
Visual C++
public:
property GridViewHeaderRow^ HeaderRow {
    GridViewHeaderRow^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalScrollBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.HorizontalScrollBar Property
RadGridView Class See Also Send Feedback
Get the RadGridView horizontal scrollbar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ScrollBar HorizontalScrollBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalScrollBar As ScrollBar
Visual C++
public:
property ScrollBar^ HorizontalScrollBar {
    ScrollBar^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.IsReadOnly Property
RadGridView Class See Also Send Feedback
Gets a value indicating whether the RadGridView can be edited.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


NewRow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.NewRow Property
RadGridView Class See Also Send Feedback
Get the RadGridView new row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public GridViewNewRow NewRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewRow As GridViewNewRow
Visual C++
public:
property GridViewNewRow^ NewRow {
    GridViewNewRow^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


RowIndicatorVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.RowIndicatorVisibility Property
RadGridView Class See Also Send Feedback
Gets or sets the row indicator visibility.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility RowIndicatorVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowIndicatorVisibility As Visibility
Visual C++
public:
property Visibility RowIndicatorVisibility {
    Visibility get ();
}

Field Value

The row indicator visibility.

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


Rows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.Rows Property
RadGridView Class See Also Send Feedback
Get the list of RadGridView rows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<GridViewRow> Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of GridViewRow)
Visual C++
public:
property IList<GridViewRow^>^ Rows {
    IList<GridViewRow^>^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedItem Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.SelectedItem Property
RadGridView Class See Also Send Feedback
Gets the Selected item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object
Visual C++
public:
property Object^ SelectedItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalScrollBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.VerticalScrollBar Property
RadGridView Class See Also Send Feedback
Get the RadGridView vertical scrollbar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ScrollBar VerticalScrollBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalScrollBar As ScrollBar
Visual C++
public:
property ScrollBar^ VerticalScrollBar {
    ScrollBar^ get ();
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadGridView..::.XamlTag Property
RadGridView Class See Also Send Feedback
Get the xaml tag of the RadGridView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadGridView Class
Telerik.WebAii.Controls.Xaml Namespace


RadHtmlPlaceholder Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder Class
Members See Also Send Feedback
Represents the RadHtmlPlaceholder for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadHtmlPlaceholder : Panel
Visual Basic (Declaration)
Public Class RadHtmlPlaceholder _
    Inherits Panel
Visual C++
public ref class RadHtmlPlaceholder : public Panel

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Panel
Telerik.WebAii.Controls.Xaml..::.RadHtmlPlaceholder

See Also

RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


RadHtmlPlaceholder Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder Members
RadHtmlPlaceholder Class Constructors Methods Properties See Also Send Feedback

The RadHtmlPlaceholder type exposes the following members.

Constructors

Name | Description
RadHtmlPlaceholder | Initializes a new instance of the RadHtmlPlaceholder class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadHtmlPlaceholder control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
HtmlFrameBrowser | Get the Html frame browser instance holding the html content.
HtmlSource | Get the html string that will be displayed over the Silverlight content.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SourceUrl | Gets the external url of the page that will be loaded over the Silverlight content.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadHtmlPlaceholder control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


RadHtmlPlaceholder Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder Constructor
RadHtmlPlaceholder Class See Also Send Feedback
Initializes a new instance of the RadHtmlPlaceholder class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadHtmlPlaceholder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadHtmlPlaceholder()

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


RadHtmlPlaceholder Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder Methods
RadHtmlPlaceholder Class See Also Send Feedback

The RadHtmlPlaceholder type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadHtmlPlaceholder control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.AnySibling Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.GetProperty Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.GetRectangle Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.Highlight Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.InitializeMappings Method
RadHtmlPlaceholder Class See Also Send Feedback
Initializes the mapping of the RadHtmlPlaceholder control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.InvokeMethod Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.NextSibling Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.Parent Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.PreviousSibling Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.ScrollToVisible Method
RadHtmlPlaceholder Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
RadHtmlPlaceholder Members
Telerik.WebAii.Controls.Xaml Namespace


RadHtmlPlaceholder Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder Properties
RadHtmlPlaceholder Class See Also Send Feedback

The RadHtmlPlaceholder type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
HtmlFrameBrowser | Get the Html frame browser instance holding the html content.
HtmlSource | Get the html string that will be displayed over the Silverlight content.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SourceUrl | Gets the external url of the page that will be loaded over the Silverlight content.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadHtmlPlaceholder control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


HtmlFrameBrowser Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.HtmlFrameBrowser Property
RadHtmlPlaceholder Class See Also Send Feedback
Get the Html frame browser instance holding the html content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Browser HtmlFrameBrowser { get; }
Visual Basic (Declaration)
Public ReadOnly Property HtmlFrameBrowser As Browser
Visual C++
public:
property Browser^ HtmlFrameBrowser {
    Browser^ get ();
}

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


HtmlSource Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.HtmlSource Property
RadHtmlPlaceholder Class See Also Send Feedback
Get the html string that will be displayed over the Silverlight content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HtmlSource { get; }
Visual Basic (Declaration)
Public ReadOnly Property HtmlSource As String
Visual C++
public:
property String^ HtmlSource {
    String^ get ();
}

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


SourceUrl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.SourceUrl Property
RadHtmlPlaceholder Class See Also Send Feedback
Gets the external url of the page that will be loaded over the Silverlight content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string SourceUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourceUrl As String
Visual C++
public:
property String^ SourceUrl {
    String^ get ();
}

Remarks

If HtmlSource property for the placeholder is set, this property is ignored.

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadHtmlPlaceholder..::.XamlTag Property
RadHtmlPlaceholder Class See Also Send Feedback
Get the xaml tag of RadHtmlPlaceholder control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadHtmlPlaceholder Class
Telerik.WebAii.Controls.Xaml Namespace


RadMaskedTextBox Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Class
Members See Also Send Feedback
Represents the Silverlight MaskedTextBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMaskedTextBox : Control
Visual Basic (Declaration)
Public Class RadMaskedTextBox _
    Inherits Control
Visual C++
public ref class RadMaskedTextBox : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadMaskedTextBox

See Also

RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


RadMaskedTextBox Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Members
RadMaskedTextBox Class Constructors Methods Properties See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Constructors

Name | Description
RadMaskedTextBox | Initializes a new instance of the RadMaskedTextBox class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMaskedTextBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEmpty | Gets a value indicating whether the Value is empty (null). Uses an automation property, e.g. getting the value from a control property.
IsEnabled | (Inherited from Control.)
IsFocused | Gets the bool value indicating whether the control is focused or not. Uses an automation property, e.g. getting the value from a control property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | Gets a value determining if the user can change the text in the text box. Uses an automation property, e.g. getting the value from a control property.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Mask | Gets the currently set mask. Uses an automation property, e.g. getting the value from a control property.
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectionLength | Get the selection length value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
SelectionStart | Get the selection start value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the current masked text box text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the MaskedTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


RadMaskedTextBox Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Constructor
RadMaskedTextBox Class See Also Send Feedback
Initializes a new instance of the RadMaskedTextBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMaskedTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMaskedTextBox()

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


RadMaskedTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Methods
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMaskedTextBox control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.AnySibling Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.GetProperty Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.GetRectangle Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.Highlight Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.InitializeMappings Method
RadMaskedTextBox Class See Also Send Feedback
Initializes the mapping of the RadMaskedTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.InvokeMethod Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.MouseClick Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType) | Triggers mouse click on the text box from the given type.
MouseClick(MouseClickType, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.MouseClick Method (MouseClickType)
RadMaskedTextBox Class See Also Send Feedback
Triggers mouse click on the text box from the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The type of the mouse click.

See Also

RadMaskedTextBox Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.MouseClick Method (MouseClickType, Int32)
RadMaskedTextBox Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.

See Also

RadMaskedTextBox Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32, Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.MouseClick Method (MouseClickType, Int32, Boolean)
RadMaskedTextBox Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.

See Also

RadMaskedTextBox Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.NextSibling Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.Parent Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.PreviousSibling Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.ScrollToVisible Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Xaml Namespace


RadMaskedTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox Properties
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEmpty | Gets a value indicating whether the Value is empty (null). Uses an automation property, e.g. getting the value from a control property.
IsEnabled | (Inherited from Control.)
IsFocused | Gets the bool value indicating whether the control is focused or not. Uses an automation property, e.g. getting the value from a control property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsReadOnly | Gets a value determining if the user can change the text in the text box. Uses an automation property, e.g. getting the value from a control property.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Mask | Gets the currently set mask. Uses an automation property, e.g. getting the value from a control property.
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectionLength | Get the selection length value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
SelectionStart | Get the selection start value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the current masked text box text.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the MaskedTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


IsEmpty Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.IsEmpty Property
RadMaskedTextBox Class See Also Send Feedback
Gets a value indicating whether the Value is empty (null). Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


IsFocused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.IsFocused Property
RadMaskedTextBox Class See Also Send Feedback
Gets the bool value indicating whether the control is focused or not. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.IsReadOnly Property
RadMaskedTextBox Class See Also Send Feedback
Gets a value determining if the user can change the text in the text box. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


Mask Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.Mask Property
RadMaskedTextBox Class See Also Send Feedback
Gets the currently set mask. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Mask { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mask As String
Visual C++
public:
property String^ Mask {
    String^ get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


SelectionLength Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.SelectionLength Property
RadMaskedTextBox Class See Also Send Feedback
Get the selection length value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectionLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionLength As Integer
Visual C++
public:
property int SelectionLength {
    int get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


SelectionStart Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.SelectionStart Property
RadMaskedTextBox Class See Also Send Feedback
Get the selection start value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectionStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionStart As Integer
Visual C++
public:
property int SelectionStart {
    int get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.Text Property
RadMaskedTextBox Class See Also Send Feedback
Get the current masked text box text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMaskedTextBox..::.XamlTag Property
RadMaskedTextBox Class See Also Send Feedback
Get the xaml tag of the MaskedTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaChapter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter Class
Members See Also Send Feedback
Represents the Silverlight RadMediaChapter control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMediaChapter : Control
Visual Basic (Declaration)
Public Class RadMediaChapter _
    Inherits Control
Visual C++
public ref class RadMediaChapter : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadMediaChapter

See Also

RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


RadMediaChapter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter Members
RadMediaChapter Class Constructors Methods Properties See Also Send Feedback

The RadMediaChapter type exposes the following members.

Constructors

Name | Description
RadMediaChapter | Initializes a new instance of the RadMediaChapter class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMediaChapter control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the chapter image.
Index | Get the chapter index.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Position | Get the chapter position via automation property.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the chapter.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaChapter control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaChapter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter Constructor
RadMediaChapter Class See Also Send Feedback
Initializes a new instance of the RadMediaChapter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMediaChapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMediaChapter()

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaChapter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter Methods
RadMediaChapter Class See Also Send Feedback

The RadMediaChapter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMediaChapter control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.AnySibling Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.GetProperty Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.GetRectangle Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.Highlight Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.InitializeMappings Method
RadMediaChapter Class See Also Send Feedback
Initializes the mapping of the RadMediaChapter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.InvokeMethod Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.NextSibling Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.Parent Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.PreviousSibling Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.ScrollToVisible Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members
Telerik.WebAii.Controls.Xaml Namespace


RadMediaChapter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter Properties
RadMediaChapter Class See Also Send Feedback

The RadMediaChapter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the chapter image.
Index | Get the chapter index.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Position | Get the chapter position via automation property.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the chapter.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaChapter control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


Image Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.Image Property
RadMediaChapter Class See Also Send Feedback
Get the chapter image.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.Index Property
RadMediaChapter Class See Also Send Feedback
Get the chapter index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


Position Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.Position Property
RadMediaChapter Class See Also Send Feedback
Get the chapter position via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Position { get; }
Visual Basic (Declaration)
Public ReadOnly Property Position As String
Visual C++
public:
property String^ Position {
    String^ get ();
}

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.Title Property
RadMediaChapter Class See Also Send Feedback
Get the title of the chapter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaChapter..::.XamlTag Property
RadMediaChapter Class See Also Send Feedback
Get the xaml tag of RadMediaChapter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMediaChapter Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem Class
Members See Also Send Feedback
Represents the Silverlight RadMediaItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMediaItem : ItemsControl
Visual Basic (Declaration)
Public Class RadMediaItem _
    Inherits ItemsControl
Visual C++
public ref class RadMediaItem : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadMediaItem

See Also

RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadMediaItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem Members
RadMediaItem Class Constructors Methods Properties See Also Send Feedback

The RadMediaItem type exposes the following members.

Constructors

Name | Description
RadMediaItem | Initializes a new instance of the RadMediaItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMediaItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Play | Simulates user clicking on the play button of the media item to start playing it.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BufferingTime | Get the value of the buffering time via automation property. The value specifies the advance-load time (buffer) that the media item will need before starts playing.
Chapters | Get the list of all chapters defined for this media item.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Description | Get the item description.
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
ImageSource | Get the image source of the item showed in the playlist.
Index | Get the item index.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Source | Get the video file source of type Uri associated with the media item.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the item.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem Constructor
RadMediaItem Class See Also Send Feedback
Initializes a new instance of the RadMediaItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMediaItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMediaItem()

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem Methods
RadMediaItem Class See Also Send Feedback

The RadMediaItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMediaItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Play | Simulates user clicking on the play button of the media item to start playing it.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.AnySibling Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.AssignReference Method
RadMediaItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.GetProperty Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.GetRectangle Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Highlight Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.InitializeMappings Method
RadMediaItem Class See Also Send Feedback
Initializes the mapping of the RadMediaItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.InvokeMethod Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.NextSibling Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Parent Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


Play Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Play Method
RadMediaItem Class See Also Send Feedback
Simulates user clicking on the play button of the media item to start playing it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Play()
Visual Basic (Declaration)
Public Sub Play
Visual C++
public:
void Play()

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.PreviousSibling Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.ScrollToVisible Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadMediaItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem Properties
RadMediaItem Class See Also Send Feedback

The RadMediaItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BufferingTime | Get the value of the buffering time via automation property. The value specifies the advance-load time (buffer) that the media item will need before starts playing.
Chapters | Get the list of all chapters defined for this media item.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Description | Get the item description.
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
ImageSource | Get the image source of the item showed in the playlist.
Index | Get the item index.
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Source | Get the video file source of type Uri associated with the media item.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the item.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


BufferingTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.BufferingTime Property
RadMediaItem Class See Also Send Feedback
Get the value of the buffering time via automation property. The value specifies the advance-load time (buffer) that the media item will need before starts playing.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan BufferingTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property BufferingTime As TimeSpan
Visual C++
public:
property TimeSpan^ BufferingTime {
    TimeSpan^ get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


Chapters Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Chapters Property
RadMediaItem Class See Also Send Feedback
Get the list of all chapters defined for this media item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMediaChapter> Chapters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Chapters As IList(Of RadMediaChapter)
Visual C++
public:
property IList<RadMediaChapter^>^ Chapters {
    IList<RadMediaChapter^>^ get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


Description Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Description Property
RadMediaItem Class See Also Send Feedback
Get the item description.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


ImageSource Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.ImageSource Property
RadMediaItem Class See Also Send Feedback
Get the image source of the item showed in the playlist.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public BitmapImage ImageSource { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImageSource As BitmapImage
Visual C++
public:
property BitmapImage^ ImageSource {
    BitmapImage^ get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Index Property
RadMediaItem Class See Also Send Feedback
Get the item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


Source Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Source Property
RadMediaItem Class See Also Send Feedback
Get the video file source of type Uri associated with the media item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Source { get; }
Visual Basic (Declaration)
Public ReadOnly Property Source As String
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.Title Property
RadMediaItem Class See Also Send Feedback
Get the title of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaItem..::.XamlTag Property
RadMediaItem Class See Also Send Feedback
Get the xaml tag of RadMediaItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMediaItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaPlayer Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer Class
Members See Also Send Feedback
Represents the Silverlight RadMediaPlayer control wrapper. Holds the chapter controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMediaPlayer : ItemsControl
Visual Basic (Declaration)
Public Class RadMediaPlayer _
    Inherits ItemsControl
Visual C++
public ref class RadMediaPlayer : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadMediaPlayer

See Also

RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


RadMediaPlayer Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer Members
RadMediaPlayer Class Constructors Methods Properties See Also Send Feedback

The RadMediaPlayer type exposes the following members.

Constructors

Name | Description
RadMediaPlayer | Initializes a new instance of the RadMediaPlayer class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMediaPlayer control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
LoadNextChapter | Simulates user clicking on the 'next chapter' button to load the next chapter of the item.
LoadPlaylist | Simulates user clicking on the 'playlist button' to load the playlist.
LoadPreviousChapter | Simulates user clicking on the 'previous chapter' button to load the previous chapter of the item.
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Simulates user selecting item from the playlist to start playing it.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StopPlaying | Simulates user clicking on the 'stop' button to stop playing the item.
ToggleFullScreenMode | Simulates user clicking on the 'full screen' button to toggle the full screen state of RadMediaPlayer.
ToggleMute | Simulates user clicking on the 'mute' button.
TogglePlaying | Pauses/resumes playing of the item.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Chapters | Get the list of the chapters presented upon playing the item.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ControlPanel | Get the element holding the control buttons like play, stop, previous/next chapter, toggle mute, etc.
CurrentState | Get the current state of the media player.
CurrentTime | Get the current time of the currently playing item.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
FullScreenButton | Get the full screen mode button that toggles the full screen mode.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsFullScreen | Get whether the media player is displayed in full screen mode. Gets the bool value via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInPlayMode | Get whether an item is loaded in play mode.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MediaElement | Get the current media element of the player.
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PlayingItemTitle | Get the title of the currently playing item.
Playlist | Get the playlist of the media items.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeSlider | Get the time slider representing the progress in time of playing the item.
TotalTime | Get the total time of the currently playing item.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
VolumeSlider | Get the volume slider from the bottom part.
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaPlayer control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaPlayer Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer Constructor
RadMediaPlayer Class See Also Send Feedback
Initializes a new instance of the RadMediaPlayer class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMediaPlayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMediaPlayer()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaPlayer Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer Methods
RadMediaPlayer Class See Also Send Feedback

The RadMediaPlayer type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMediaPlayer control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
LoadNextChapter | Simulates user clicking on the 'next chapter' button to load the next chapter of the item.
LoadPlaylist | Simulates user clicking on the 'playlist button' to load the playlist.
LoadPreviousChapter | Simulates user clicking on the 'previous chapter' button to load the previous chapter of the item.
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Simulates user selecting item from the playlist to start playing it.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StopPlaying | Simulates user clicking on the 'stop' button to stop playing the item.
ToggleFullScreenMode | Simulates user clicking on the 'full screen' button to toggle the full screen state of RadMediaPlayer.
ToggleMute | Simulates user clicking on the 'mute' button.
TogglePlaying | Pauses/resumes playing of the item.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.AnySibling Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.AssignReference Method
RadMediaPlayer Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaPlayer.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.GetProperty Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.GetRectangle Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.Highlight Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.InitializeMappings Method
RadMediaPlayer Class See Also Send Feedback
Initializes the mapping of the RadMediaPlayer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.InvokeMethod Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


LoadNextChapter Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.LoadNextChapter Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'next chapter' button to load the next chapter of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadNextChapter()
Visual Basic (Declaration)
Public Sub LoadNextChapter
Visual C++
public:
void LoadNextChapter()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


LoadPlaylist Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.LoadPlaylist Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'playlist button' to load the playlist.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadPlaylist()
Visual Basic (Declaration)
Public Sub LoadPlaylist
Visual C++
public:
void LoadPlaylist()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


LoadPreviousChapter Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.LoadPreviousChapter Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'previous chapter' button to load the previous chapter of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void LoadPreviousChapter()
Visual Basic (Declaration)
Public Sub LoadPreviousChapter
Visual C++
public:
void LoadPreviousChapter()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.NextSibling Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.Parent Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


PlayItem Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.PlayItem Method
RadMediaPlayer Class See Also Send Feedback
Simulates user selecting item from the playlist to start playing it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void PlayItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub PlayItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void PlayItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32

[Missing <param name="itemIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaPlayer.PlayItem(System.Int32)"]

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.PreviousSibling Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.ScrollToVisible Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members
Telerik.WebAii.Controls.Xaml Namespace


StopPlaying Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.StopPlaying Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'stop' button to stop playing the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void StopPlaying()
Visual Basic (Declaration)
Public Sub StopPlaying
Visual C++
public:
void StopPlaying()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleFullScreenMode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.ToggleFullScreenMode Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'full screen' button to toggle the full screen state of RadMediaPlayer.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleFullScreenMode()
Visual Basic (Declaration)
Public Sub ToggleFullScreenMode
Visual C++
public:
void ToggleFullScreenMode()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the toggle full screen mode button is not visible.

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleMute Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.ToggleMute Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'mute' button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleMute()
Visual Basic (Declaration)
Public Sub ToggleMute
Visual C++
public:
void ToggleMute()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


TogglePlaying Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.TogglePlaying Method
RadMediaPlayer Class See Also Send Feedback
Pauses/resumes playing of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePlaying()
Visual Basic (Declaration)
Public Sub TogglePlaying
Visual C++
public:
void TogglePlaying()

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


RadMediaPlayer Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer Properties
RadMediaPlayer Class See Also Send Feedback

The RadMediaPlayer type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Chapters | Get the list of the chapters presented upon playing the item.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ControlPanel | Get the element holding the control buttons like play, stop, previous/next chapter, toggle mute, etc.
CurrentState | Get the current state of the media player.
CurrentTime | Get the current time of the currently playing item.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
FullScreenButton | Get the full screen mode button that toggles the full screen mode.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsFullScreen | Get whether the media player is displayed in full screen mode. Gets the bool value via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInPlayMode | Get whether an item is loaded in play mode.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MediaElement | Get the current media element of the player.
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PlayingItemTitle | Get the title of the currently playing item.
Playlist | Get the playlist of the media items.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeSlider | Get the time slider representing the progress in time of playing the item.
TotalTime | Get the total time of the currently playing item.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
VolumeSlider | Get the volume slider from the bottom part.
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaPlayer control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


Chapters Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.Chapters Property
RadMediaPlayer Class See Also Send Feedback
Get the list of the chapters presented upon playing the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMediaChapter> Chapters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Chapters As IList(Of RadMediaChapter)
Visual C++
public:
property IList<RadMediaChapter^>^ Chapters {
    IList<RadMediaChapter^>^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


ControlPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.ControlPanel Property
RadMediaPlayer Class See Also Send Feedback
Get the element holding the control buttons like play, stop, previous/next chapter, toggle mute, etc.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Grid ControlPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property ControlPanel As Grid
Visual C++
public:
property Grid^ ControlPanel {
    Grid^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


CurrentState Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.CurrentState Property
RadMediaPlayer Class See Also Send Feedback
Get the current state of the media player.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public MediaElementState CurrentState { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentState As MediaElementState
Visual C++
public:
property MediaElementState CurrentState {
    MediaElementState get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


CurrentTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.CurrentTime Property
RadMediaPlayer Class See Also Send Feedback
Get the current time of the currently playing item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CurrentTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentTime As String
Visual C++
public:
property String^ CurrentTime {
    String^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


FullScreenButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.FullScreenButton Property
RadMediaPlayer Class See Also Send Feedback
Get the full screen mode button that toggles the full screen mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Button FullScreenButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullScreenButton As Button
Visual C++
public:
property Button^ FullScreenButton {
    Button^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


IsFullScreen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.IsFullScreen Property
RadMediaPlayer Class See Also Send Feedback
Get whether the media player is displayed in full screen mode. Gets the bool value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFullScreen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFullScreen As Boolean
Visual C++
public:
property bool IsFullScreen {
    bool get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


IsInPlayMode Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.IsInPlayMode Property
RadMediaPlayer Class See Also Send Feedback
Get whether an item is loaded in play mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsInPlayMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInPlayMode As Boolean
Visual C++
public:
property bool IsInPlayMode {
    bool get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


MediaElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.MediaElement Property
RadMediaPlayer Class See Also Send Feedback
Get the current media element of the player.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public MediaElement MediaElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property MediaElement As MediaElement
Visual C++
public:
property MediaElement^ MediaElement {
    MediaElement^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


PlayingItemTitle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.PlayingItemTitle Property
RadMediaPlayer Class See Also Send Feedback
Get the title of the currently playing item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string PlayingItemTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlayingItemTitle As String
Visual C++
public:
property String^ PlayingItemTitle {
    String^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


Playlist Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.Playlist Property
RadMediaPlayer Class See Also Send Feedback
Get the playlist of the media items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PlaylistPresenter Playlist { get; }
Visual Basic (Declaration)
Public ReadOnly Property Playlist As PlaylistPresenter
Visual C++
public:
property PlaylistPresenter^ Playlist {
    PlaylistPresenter^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlider Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.TimeSlider Property
RadMediaPlayer Class See Also Send Feedback
Get the time slider representing the progress in time of playing the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlider TimeSlider { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlider As RadSlider
Visual C++
public:
property RadSlider^ TimeSlider {
    RadSlider^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


TotalTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.TotalTime Property
RadMediaPlayer Class See Also Send Feedback
Get the total time of the currently playing item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TotalTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalTime As String
Visual C++
public:
property String^ TotalTime {
    String^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


VolumeSlider Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.VolumeSlider Property
RadMediaPlayer Class See Also Send Feedback
Get the volume slider from the bottom part.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlider VolumeSlider { get; }
Visual Basic (Declaration)
Public ReadOnly Property VolumeSlider As RadSlider
Visual C++
public:
property RadSlider^ VolumeSlider {
    RadSlider^ get ();
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMediaPlayer..::.XamlTag Property
RadMediaPlayer Class See Also Send Feedback
Get the xaml tag of RadMediaPlayer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMediaPlayer Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenu Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Class
Members See Also Send Feedback
Represents the Silverlight RadMenu wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMenu : RadMenuBase
Visual Basic (Declaration)
Public Class RadMenu _
    Inherits RadMenuBase
Visual C++
public ref class RadMenu : public RadMenuBase

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadMenuBase
Telerik.WebAii.Controls.Xaml..::.RadMenu

See Also

RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


RadMenu Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Members
RadMenu Class Constructors Methods Properties See Also Send Feedback

The RadMenu type exposes the following members.

Constructors

Name | Description
RadMenu | Initializes a new instance of the RadMenu class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMenu control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickToOpen | Gets or sets whether the child group opens upon clicking a parent item. (Inherited from RadMenuBase.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the collection of all the root RadMenuItem elements.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Gets or sets a value that specifies the menu orientation.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenu control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenu Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Constructor
RadMenu Class See Also Send Feedback
Initializes a new instance of the RadMenu class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenu()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMenu()

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenu Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Methods
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadMenu control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.AnySibling Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.AssignReference Method
RadMenu Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMenu.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.GetProperty Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.GetRectangle Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Highlight Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.InitializeMappings Method
RadMenu Class See Also Send Feedback
Initializes the mapping of the RadMenu control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.InvokeMethod Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.NextSibling Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Parent Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.PreviousSibling Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.ScrollToVisible Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Xaml Namespace


RadMenu Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu Properties
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickToOpen | Gets or sets whether the child group opens upon clicking a parent item. (Inherited from RadMenuBase.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the collection of all the root RadMenuItem elements.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Gets or sets a value that specifies the menu orientation.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenu control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Items Property
RadMenu Class See Also Send Feedback
Gets the collection of all the root RadMenuItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ Items {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.Orientation Property
RadMenu Class See Also Send Feedback
Gets or sets a value that specifies the menu orientation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenu..::.XamlTag Property
RadMenu Class See Also Send Feedback
Get the xaml tag of RadMenu control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMenu Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuBase Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase Class
Members See Also Send Feedback
Serves as the base for the Silverlight RadMenu and RadContextMenu wrappers.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public abstract class RadMenuBase : ItemsControl
Visual Basic (Declaration)
Public MustInherit Class RadMenuBase _
    Inherits ItemsControl
Visual C++
public ref class RadMenuBase abstract : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadMenuBase
Telerik.WebAii.Controls.Xaml..::.RadContextMenu
Telerik.WebAii.Controls.Xaml..::.RadMenu

See Also

RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


RadMenuBase Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase Members
RadMenuBase Class Constructors Methods Properties See Also Send Feedback

The RadMenuBase type exposes the following members.

Constructors

Name | Description
RadMenuBase | Initializes a new instance of the RadMenuBase class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickToOpen | Gets or sets whether the child group opens upon clicking a parent item.
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuBase Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase Constructor
RadMenuBase Class See Also Send Feedback
Initializes a new instance of the RadMenuBase class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected RadMenuBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
RadMenuBase()

See Also

RadMenuBase Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuBase Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase Methods
RadMenuBase Class See Also Send Feedback

The RadMenuBase type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.AnySibling Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.GetProperty Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.GetRectangle Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.Highlight Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.InvokeMethod Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.NextSibling Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.Parent Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.PreviousSibling Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.ScrollToVisible Method
RadMenuBase Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
RadMenuBase Members
Telerik.WebAii.Controls.Xaml Namespace


RadMenuBase Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase Properties
RadMenuBase Class See Also Send Feedback

The RadMenuBase type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickToOpen | Gets or sets whether the child group opens upon clicking a parent item.
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMenuBase Class
Telerik.WebAii.Controls.Xaml Namespace


ClickToOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuBase..::.ClickToOpen Property
RadMenuBase Class See Also Send Feedback
Gets or sets whether the child group opens upon clicking a parent item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ClickToOpen { get; set; }
Visual Basic (Declaration)
Public Property ClickToOpen As Boolean
Visual C++
public:
property bool ClickToOpen {
    bool get ();
    void set (bool value);
}

See Also

RadMenuBase Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Class
Members See Also Send Feedback
Represents the Silverlight RadMenuItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadMenuItem : ItemsControl
Visual Basic (Declaration)
Public Class RadMenuItem _
    Inherits ItemsControl
Visual C++
public ref class RadMenuItem : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadMenuItem

See Also

RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadMenuItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Members
RadMenuItem Class Constructors Methods Properties See Also Send Feedback

The RadMenuItem type exposes the following members.

Constructors

Name | Description
RadMenuItem | Initializes a new instance of the RadMenuItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Clicks the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
HoverOver | Hovers over the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
InitializeMappings | Initializes the mapping of the RadMenuItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SubitemClick | Simulates user clicking a sub item. Holds the control update internally.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundBrush | Get the item background color brush.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
ForegroundBrush | Get the item foreground color brush.
HasIcon | Get whether the menu item has icon.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsCheckable | Get or set whether the menu item can be checked.
IsChecked | Get or set whether the menu item is checked.
IsEnabled | (Inherited from ItemsControl.)
IsHighlighted | Gets a value indicating whether a RadMenuItem is highlighted.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the item (i.e. its popup) is opened.
IsSubmenuOpen | Gets a value that indicates whether the submenu of the RadMenuItem is open.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
Items | Get the list of RadMenuItem sub elements of this menu item.
ItemText | Get the item text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StaysOpenOnClick | Gets or sets a value that indicates that the submenu in which this RadMenuItem is located should not close when this item is clicked.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenuItem. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Constructor
RadMenuItem Class See Also Send Feedback
Initializes a new instance of the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadMenuItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMenuItem()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Methods
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Clicks the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
HoverOver | Hovers over the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
InitializeMappings | Initializes the mapping of the RadMenuItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SubitemClick | Simulates user clicking a sub item. Holds the control update internally.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.AnySibling Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.AssignReference Method
RadMenuItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference of the element.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Click Method
RadMenuItem Class See Also Send Feedback
Clicks the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Click()
Visual Basic (Declaration)
Public Sub Click
Visual C++
public:
void Click()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.GetProperty Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.GetRectangle Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Highlight Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


HoverOver Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.HoverOver Method
RadMenuItem Class See Also Send Feedback
Hovers over the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HoverOver()
Visual Basic (Declaration)
Public Sub HoverOver
Visual C++
public:
void HoverOver()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.InitializeMappings Method
RadMenuItem Class See Also Send Feedback
Initializes the mapping of the RadMenuItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.InvokeMethod Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.NextSibling Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Parent Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.PreviousSibling Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ScrollToVisible Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Xaml Namespace


SubitemClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.SubitemClick Method
RadMenuItem Class See Also Send Feedback
Simulates user clicking a sub item. Holds the control update internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SubitemClick(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SubitemClick ( _
    itemIndex As Integer _
)
Visual C++
public:
void SubitemClick(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the clicked sub item.

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadMenuItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem Properties
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundBrush | Get the item background color brush.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
ForegroundBrush | Get the item foreground color brush.
HasIcon | Get whether the menu item has icon.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsCheckable | Get or set whether the menu item can be checked.
IsChecked | Get or set whether the menu item is checked.
IsEnabled | (Inherited from ItemsControl.)
IsHighlighted | Gets a value indicating whether a RadMenuItem is highlighted.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the item (i.e. its popup) is opened.
IsSubmenuOpen | Gets a value that indicates whether the submenu of the RadMenuItem is open.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
Items | Get the list of RadMenuItem sub elements of this menu item.
ItemText | Get the item text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StaysOpenOnClick | Gets or sets a value that indicates that the submenu in which this RadMenuItem is located should not close when this item is clicked.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenuItem. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


BackgroundBrush Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.BackgroundBrush Property
RadMenuItem Class See Also Send Feedback
Get the item background color brush.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SolidColorBrush BackgroundBrush { get; }
Visual Basic (Declaration)
Public ReadOnly Property BackgroundBrush As SolidColorBrush
Visual C++
public:
property SolidColorBrush^ BackgroundBrush {
    SolidColorBrush^ get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


ForegroundBrush Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ForegroundBrush Property
RadMenuItem Class See Also Send Feedback
Get the item foreground color brush.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SolidColorBrush ForegroundBrush { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForegroundBrush As SolidColorBrush
Visual C++
public:
property SolidColorBrush^ ForegroundBrush {
    SolidColorBrush^ get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


HasIcon Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.HasIcon Property
RadMenuItem Class See Also Send Feedback
Get whether the menu item has icon.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasIcon { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasIcon As Boolean
Visual C++
public:
property bool HasIcon {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsCheckable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.IsCheckable Property
RadMenuItem Class See Also Send Feedback
Get or set whether the menu item can be checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsCheckable { get; set; }
Visual Basic (Declaration)
Public Property IsCheckable As Boolean
Visual C++
public:
property bool IsCheckable {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsChecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.IsChecked Property
RadMenuItem Class See Also Send Feedback
Get or set whether the menu item is checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic (Declaration)
Public Property IsChecked As Boolean
Visual C++
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsHighlighted Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.IsHighlighted Property
RadMenuItem Class See Also Send Feedback
Gets a value indicating whether a RadMenuItem is highlighted.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsHighlighted { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHighlighted As Boolean
Visual C++
public:
property bool IsHighlighted {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.IsPopupOpen Property
RadMenuItem Class See Also Send Feedback
Get whether the item (i.e. its popup) is opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsSubmenuOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.IsSubmenuOpen Property
RadMenuItem Class See Also Send Feedback
Gets a value that indicates whether the submenu of the RadMenuItem is open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSubmenuOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSubmenuOpen As Boolean
Visual C++
public:
property bool IsSubmenuOpen {
    bool get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ItemIndex Property
RadMenuItem Class See Also Send Feedback
Get the item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.Items Property
RadMenuItem Class See Also Send Feedback
Get the list of RadMenuItem sub elements of this menu item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadMenuItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ Items {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.ItemText Property
RadMenuItem Class See Also Send Feedback
Get the item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


StaysOpenOnClick Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.StaysOpenOnClick Property
RadMenuItem Class See Also Send Feedback
Gets or sets a value that indicates that the submenu in which this RadMenuItem is located should not close when this item is clicked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool StaysOpenOnClick { get; set; }
Visual Basic (Declaration)
Public Property StaysOpenOnClick As Boolean
Visual C++
public:
property bool StaysOpenOnClick {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadMenuItem..::.XamlTag Property
RadMenuItem Class See Also Send Feedback
Get the xaml tag of RadMenuItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadNumericUpDown Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown Class
Members See Also Send Feedback
Represents the RadNumericUpDown for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadNumericUpDown : RangeBase
Visual Basic (Declaration)
Public Class RadNumericUpDown _
    Inherits RangeBase
Visual C++
public ref class RadNumericUpDown : public RangeBase

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.RangeBase
Telerik.WebAii.Controls.Xaml..::.RadNumericUpDown

See Also

RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


RadNumericUpDown Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown Members
RadNumericUpDown Class Constructors Methods Properties See Also Send Feedback

The RadNumericUpDown type exposes the following members.

Constructors

Name | Description
RadNumericUpDown | Initializes a new instance of the RadNumericUpDown class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
DecreaseValue | Simulates user clicking on the 'decrease' spin button.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
IncreaseValue | Simulates user clicking on the 'increase' spin button.
InitializeMappings | Initializes the mapping of the RadNumericUpDown control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TextBoxMouseWheel | Simulates turning mouse wheel for the given period and direction.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentText | Gets the current text content held by the textbox. Uses an automation property taking the value from the NumericUpDown control.
CustomUnit | Gets the custom unit applied for the NumericUpDown. Uses an automation property taking the value from the NumericUpDown control.
Delay | Gets the NumericUpDown delay value (in milliseconds). Uses an automation property taking the value from the NumericUpDown control.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEditable | Gets whether the NumericUpDown is editable. Uses an automation property taking the value from the NumericUpDown control.
IsEnabled | (Inherited from RangeBase.)
IsFocused | Gets whether the NumericUpDown is focused. Uses an automation property taking the value from the NumericUpDown control.
IsHighlighted | Gets whether the NumericUpDown is highlighted. Uses an automation property taking the value from the NumericUpDown control.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RepeatInterval | Gets the NumericUpDown repeat interval value (in milliseconds). Uses an automation property taking the value from the NumericUpDown control.
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextBox | Gets the PickerTextBox element.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadNumericTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


RadNumericUpDown Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown Constructor
RadNumericUpDown Class See Also Send Feedback
Initializes a new instance of the RadNumericUpDown class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadNumericUpDown()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadNumericUpDown()

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


RadNumericUpDown Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown Methods
RadNumericUpDown Class See Also Send Feedback

The RadNumericUpDown type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
DecreaseValue | Simulates user clicking on the 'decrease' spin button.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
IncreaseValue | Simulates user clicking on the 'increase' spin button.
InitializeMappings | Initializes the mapping of the RadNumericUpDown control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TextBoxMouseWheel | Simulates turning mouse wheel for the given period and direction.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.AnySibling Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


DecreaseValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.DecreaseValue Method
RadNumericUpDown Class See Also Send Feedback
Simulates user clicking on the 'decrease' spin button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DecreaseValue()
Visual Basic (Declaration)
Public Sub DecreaseValue
Visual C++
public:
void DecreaseValue()

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.GetProperty Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.GetRectangle Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.Highlight Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


IncreaseValue Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.IncreaseValue Method
RadNumericUpDown Class See Also Send Feedback
Simulates user clicking on the 'increase' spin button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void IncreaseValue()
Visual Basic (Declaration)
Public Sub IncreaseValue
Visual C++
public:
void IncreaseValue()

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.InitializeMappings Method
RadNumericUpDown Class See Also Send Feedback
Initializes the mapping of the RadNumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.InvokeMethod Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.NextSibling Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.Parent Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.PreviousSibling Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.ScrollToVisible Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members
Telerik.WebAii.Controls.Xaml Namespace


TextBoxMouseWheel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.TextBoxMouseWheel Method
RadNumericUpDown Class See Also Send Feedback
Simulates turning mouse wheel for the given period and direction.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TextBoxMouseWheel(
    int delta,
    MouseWheelTurnDirection direction
)
Visual Basic (Declaration)
Public Sub TextBoxMouseWheel ( _
    delta As Integer, _
    direction As MouseWheelTurnDirection _
)
Visual C++
public:
void TextBoxMouseWheel(
    int delta,
    MouseWheelTurnDirection direction
)

Parameters

delta
Type: System..::.Int32
The period to turn the mouse wheel in millis.
direction
Type: ArtOfTest.WebAii.Core..::.MouseWheelTurnDirection
Either 'forward' or 'backward' direction.

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


RadNumericUpDown Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown Properties
RadNumericUpDown Class See Also Send Feedback

The RadNumericUpDown type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentText | Gets the current text content held by the textbox. Uses an automation property taking the value from the NumericUpDown control.
CustomUnit | Gets the custom unit applied for the NumericUpDown. Uses an automation property taking the value from the NumericUpDown control.
Delay | Gets the NumericUpDown delay value (in milliseconds). Uses an automation property taking the value from the NumericUpDown control.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEditable | Gets whether the NumericUpDown is editable. Uses an automation property taking the value from the NumericUpDown control.
IsEnabled | (Inherited from RangeBase.)
IsFocused | Gets whether the NumericUpDown is focused. Uses an automation property taking the value from the NumericUpDown control.
IsHighlighted | Gets whether the NumericUpDown is highlighted. Uses an automation property taking the value from the NumericUpDown control.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RepeatInterval | Gets the NumericUpDown repeat interval value (in milliseconds). Uses an automation property taking the value from the NumericUpDown control.
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextBox | Gets the PickerTextBox element.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadNumericTextBox control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


ContentText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.ContentText Property
RadNumericUpDown Class See Also Send Feedback
Gets the current text content held by the textbox. Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ContentText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentText As String
Visual C++
public:
property String^ ContentText {
    String^ get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


CustomUnit Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.CustomUnit Property
RadNumericUpDown Class See Also Send Feedback
Gets the custom unit applied for the NumericUpDown. Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CustomUnit { get; }
Visual Basic (Declaration)
Public ReadOnly Property CustomUnit As String
Visual C++
public:
property String^ CustomUnit {
    String^ get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


Delay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.Delay Property
RadNumericUpDown Class See Also Send Feedback
Gets the NumericUpDown delay value (in milliseconds). Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Delay { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delay As Integer
Visual C++
public:
property int Delay {
    int get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


IsEditable Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.IsEditable Property
RadNumericUpDown Class See Also Send Feedback
Gets whether the NumericUpDown is editable. Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsEditable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


IsFocused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.IsFocused Property
RadNumericUpDown Class See Also Send Feedback
Gets whether the NumericUpDown is focused. Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


IsHighlighted Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.IsHighlighted Property
RadNumericUpDown Class See Also Send Feedback
Gets whether the NumericUpDown is highlighted. Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsHighlighted { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHighlighted As Boolean
Visual C++
public:
property bool IsHighlighted {
    bool get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


RepeatInterval Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.RepeatInterval Property
RadNumericUpDown Class See Also Send Feedback
Gets the NumericUpDown repeat interval value (in milliseconds). Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int RepeatInterval { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepeatInterval As Integer
Visual C++
public:
property int RepeatInterval {
    int get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


TextBox Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.TextBox Property
RadNumericUpDown Class See Also Send Feedback
Gets the PickerTextBox element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PickerTextBox TextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBox As PickerTextBox
Visual C++
public:
property PickerTextBox^ TextBox {
    PickerTextBox^ get ();
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadNumericUpDown..::.XamlTag Property
RadNumericUpDown Class See Also Send Feedback
The xaml tag of RadNumericTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadNumericUpDown Class
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar Class
Members See Also Send Feedback
Represents the Silverlight RadOutlookBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadOutlookBar : RadTabControl
Visual Basic (Declaration)
Public Class RadOutlookBar _
    Inherits RadTabControl
Visual C++
public ref class RadOutlookBar : public RadTabControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.RadOutlookBar

See Also

RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar Members
RadOutlookBar Class Constructors Methods Properties See Also Send Feedback

The RadOutlookBar type exposes the following members.

Constructors

Name | Description
RadOutlookBar | Initializes a new instance of the RadOutlookBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragHorizontalSplitter | Drag the horizontal splitter by the given vertical offset refreshing the outlook bar as well.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadOutlookBar control. (Overrides RadTabControl..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button. (Inherited from RadTabControl.)
ScrollRight | Simulates user clicking on the right scrolling repeat button. (Inherited from RadTabControl.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items. (Inherited from RadTabControl.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem. (Inherited from RadTabControl.)
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging. (Inherited from RadTabControl.)
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. (Inherited from RadTabControl.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl. (Inherited from RadTabControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButtonElement | Get the toggle button showing the remaining tab items on click. (Inherited from RadTabControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderText | Get the text at the OutlookBar header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the root RadOutlookBarItem elements.
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left. (Inherited from RadTabControl.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedOutlookBarArea | Get the minimized area control of this outlook bar.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. (Inherited from RadTabControl.)
RightScrollButton | Get the repeat button which on click scrolls the tab items on right. (Inherited from RadTabControl.)
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. (Inherited from RadTabControl.)
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements. (Inherited from RadTabControl.)
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl. (Inherited from RadTabControl.)
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadOutlookBar control. (Overrides RadTabControl..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar Constructor
RadOutlookBar Class See Also Send Feedback
Initializes a new instance of the RadOutlookBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadOutlookBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadOutlookBar()

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar Methods
RadOutlookBar Class See Also Send Feedback

The RadOutlookBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragHorizontalSplitter | Drag the horizontal splitter by the given vertical offset refreshing the outlook bar as well.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadOutlookBar control. (Overrides RadTabControl..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button. (Inherited from RadTabControl.)
ScrollRight | Simulates user clicking on the right scrolling repeat button. (Inherited from RadTabControl.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items. (Inherited from RadTabControl.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.AnySibling Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.AssignReference Method
RadOutlookBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadOutlookBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


DragHorizontalSplitter Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.DragHorizontalSplitter Method
RadOutlookBar Class See Also Send Feedback
Drag the horizontal splitter by the given vertical offset refreshing the outlook bar as well.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragHorizontalSplitter(
    int verticalOffset
)
Visual Basic (Declaration)
Public Sub DragHorizontalSplitter ( _
    verticalOffset As Integer _
)
Visual C++
public:
void DragHorizontalSplitter(
    int verticalOffset
)

Parameters

verticalOffset
Type: System..::.Int32
The offset to drag by.

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.GetProperty Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.GetRectangle Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.Highlight Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.InitializeMappings Method
RadOutlookBar Class See Also Send Feedback
Initializes the mapping of the RadOutlookBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.InvokeMethod Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.NextSibling Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.Parent Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.PreviousSibling Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.ScrollToVisible Method
RadOutlookBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
RadOutlookBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar Properties
RadOutlookBar Class See Also Send Feedback

The RadOutlookBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem. (Inherited from RadTabControl.)
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging. (Inherited from RadTabControl.)
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. (Inherited from RadTabControl.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl. (Inherited from RadTabControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButtonElement | Get the toggle button showing the remaining tab items on click. (Inherited from RadTabControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderText | Get the text at the OutlookBar header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the root RadOutlookBarItem elements.
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left. (Inherited from RadTabControl.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedOutlookBarArea | Get the minimized area control of this outlook bar.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. (Inherited from RadTabControl.)
RightScrollButton | Get the repeat button which on click scrolls the tab items on right. (Inherited from RadTabControl.)
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. (Inherited from RadTabControl.)
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements. (Inherited from RadTabControl.)
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl. (Inherited from RadTabControl.)
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadOutlookBar control. (Overrides RadTabControl..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.HeaderText Property
RadOutlookBar Class See Also Send Feedback
Get the text at the OutlookBar header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.Items Property
RadOutlookBar Class See Also Send Feedback
Gets the list of the root RadOutlookBarItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadOutlookBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadOutlookBarItem)
Visual C++
public:
property IList<RadOutlookBarItem^>^ Items {
    IList<RadOutlookBarItem^>^ get ();
}

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedOutlookBarArea Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.MinimizedOutlookBarArea Property
RadOutlookBar Class See Also Send Feedback
Get the minimized area control of this outlook bar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public MinimizedOutlookBarArea MinimizedOutlookBarArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinimizedOutlookBarArea As MinimizedOutlookBarArea
Visual C++
public:
property MinimizedOutlookBarArea^ MinimizedOutlookBarArea {
    MinimizedOutlookBarArea^ get ();
}

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBar..::.XamlTag Property
RadOutlookBar Class See Also Send Feedback
Get the xaml tag of RadOutlookBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadOutlookBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBarItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem Class
Members See Also Send Feedback
Represents the Silverlight RadOutlookBarItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadOutlookBarItem : RadTabItem
Visual Basic (Declaration)
Public Class RadOutlookBarItem _
    Inherits RadTabItem
Visual C++
public ref class RadOutlookBarItem : public RadTabItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadOutlookBarItem

See Also

RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBarItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem Members
RadOutlookBarItem Class Constructors Methods Properties See Also Send Feedback

The RadOutlookBarItem type exposes the following members.

Constructors

Name | Description
RadOutlookBarItem | Initializes a new instance of the RadOutlookBarItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the item. The method also updates the parent control. (Inherited from RadTabItem.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadOutlookBarItem control. (Overrides RadTabItem..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row. (Inherited from RadTabItem.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Gets whether the mouse is over the control. (Inherited from RadTabItem.)
IsSelected | Get or set whether the tab item is selected. (Inherited from RadTabItem.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index. (Inherited from RadTabItem.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadOutlookBarItem control. (Overrides RadTabItem..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBarItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem Constructor
RadOutlookBarItem Class See Also Send Feedback
Initializes a new instance of the RadOutlookBarItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadOutlookBarItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadOutlookBarItem()

See Also

RadOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBarItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem Methods
RadOutlookBarItem Class See Also Send Feedback

The RadOutlookBarItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the item. The method also updates the parent control. (Inherited from RadTabItem.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadOutlookBarItem control. (Overrides RadTabItem..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.AnySibling Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.GetProperty Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.GetRectangle Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.Highlight Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.InitializeMappings Method
RadOutlookBarItem Class See Also Send Feedback
Initializes the mapping of the RadOutlookBarItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.InvokeMethod Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.NextSibling Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.Parent Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.PreviousSibling Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.ScrollToVisible Method
RadOutlookBarItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
RadOutlookBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadOutlookBarItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem Properties
RadOutlookBarItem Class See Also Send Feedback

The RadOutlookBarItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row. (Inherited from RadTabItem.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Gets whether the mouse is over the control. (Inherited from RadTabItem.)
IsSelected | Get or set whether the tab item is selected. (Inherited from RadTabItem.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index. (Inherited from RadTabItem.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadOutlookBarItem control. (Overrides RadTabItem..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadOutlookBarItem..::.XamlTag Property
RadOutlookBarItem Class See Also Send Feedback
Get the xaml tag of RadOutlookBarItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadOutlookBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadPane Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadPane control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPane : RadTabItem
Visual Basic (Declaration)
Public Class RadPane _
    Inherits RadTabItem
Visual C++
public ref class RadPane : public RadTabItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadPane
Telerik.WebAii.Controls.Xaml..::.RadDocumentPane

See Also

RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


RadPane Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Members
RadPane Class Constructors Methods Properties See Also Send Feedback

The RadPane type exposes the following members.

Constructors

Name | Description
RadPane | Initializes a new instance of the RadPane class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the pane. (Overrides RadTabItem..::.Click()()().)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking Pane control. (Overrides RadTabItem..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutoHideHeight | Gets the auto hide height value.
AutoHideWidth | Gets the auto hide width value.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanDockInDocumentHost | Gets a value indicating whether this pane can be docked into the document host.
CanFloat | Gets a value indicating whether this pane can be floated.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row. (Inherited from RadTabItem.)
IsEnabled | (Inherited from ContentControl.)
IsHidden | Gets a value indicating whether this pane is hidden.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host.
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group.
IsMouseOver | Gets whether the mouse is over the control. (Inherited from RadTabItem.)
IsPinned | Gets a value indicating whether this pane is pinned.
IsSelected | Get or set whether the tab item is selected. (Inherited from RadTabItem.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index. (Inherited from RadTabItem.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadPane control. (Overrides RadTabItem..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


RadPane Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Constructor
RadPane Class See Also Send Feedback
Initializes a new instance of the RadPane class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPane()

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


RadPane Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Methods
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the pane. (Overrides RadTabItem..::.Click()()().)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking Pane control. (Overrides RadTabItem..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.AnySibling Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Click Method
RadPane Class See Also Send Feedback
Simulates user clicking on the pane.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Click()
Visual Basic (Declaration)
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.GetProperty Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.GetRectangle Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Highlight Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.InitializeMappings Method
RadPane Class See Also Send Feedback
Initializes the mapping of the RadDocking Pane control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.InvokeMethod Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.NextSibling Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.Parent Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.PreviousSibling Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.ScrollToVisible Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Xaml Namespace


RadPane Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane Properties
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutoHideHeight | Gets the auto hide height value.
AutoHideWidth | Gets the auto hide width value.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanDockInDocumentHost | Gets a value indicating whether this pane can be docked into the document host.
CanFloat | Gets a value indicating whether this pane can be floated.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row. (Inherited from RadTabItem.)
IsEnabled | (Inherited from ContentControl.)
IsHidden | Gets a value indicating whether this pane is hidden.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host.
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group.
IsMouseOver | Gets whether the mouse is over the control. (Inherited from RadTabItem.)
IsPinned | Gets a value indicating whether this pane is pinned.
IsSelected | Get or set whether the tab item is selected. (Inherited from RadTabItem.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index. (Inherited from RadTabItem.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadPane control. (Overrides RadTabItem..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.AutoHideHeight Property
RadPane Class See Also Send Feedback
Gets the auto hide height value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double AutoHideHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoHideHeight As Double
Visual C++
public:
property double AutoHideHeight {
    double get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


AutoHideWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.AutoHideWidth Property
RadPane Class See Also Send Feedback
Gets the auto hide width value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double AutoHideWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoHideWidth As Double
Visual C++
public:
property double AutoHideWidth {
    double get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


CanDockInDocumentHost Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.CanDockInDocumentHost Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane can be docked into the document host.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanDockInDocumentHost { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanDockInDocumentHost As Boolean
Visual C++
public:
property bool CanDockInDocumentHost {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


CanFloat Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.CanFloat Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane can be floated.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanFloat { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanFloat As Boolean
Visual C++
public:
property bool CanFloat {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


IsHidden Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.IsHidden Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane is hidden.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsHidden { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHidden As Boolean
Visual C++
public:
property bool IsHidden {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


IsInDocumentHost Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.IsInDocumentHost Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane resizes in the document host.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsInDocumentHost { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInDocumentHost As Boolean
Visual C++
public:
property bool IsInDocumentHost {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


IsLastInGroup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.IsLastInGroup Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane is positioned as the last item in its group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsLastInGroup { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLastInGroup As Boolean
Visual C++
public:
property bool IsLastInGroup {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


IsPinned Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.IsPinned Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane is pinned.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPinned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPinned As Boolean
Visual C++
public:
property bool IsPinned {
    bool get ();
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPane..::.XamlTag Property
RadPane Class See Also Send Feedback
Get the xaml tag of the RadPane control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPane Class
Telerik.WebAii.Controls.Xaml Namespace


RadPaneGroup Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadPaneGroup control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPaneGroup : RadTabControl
Visual Basic (Declaration)
Public Class RadPaneGroup _
    Inherits RadTabControl
Visual C++
public ref class RadPaneGroup : public RadTabControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.RadPaneGroup

See Also

RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


RadPaneGroup Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup Members
RadPaneGroup Class Constructors Methods Properties See Also Send Feedback

The RadPaneGroup type exposes the following members.

Constructors

Name | Description
RadPaneGroup | Initializes a new instance of the RadPaneGroup class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderClose | Simulates user clicking on the 'close' button in the header.
HeaderPin | Simulates user clicking on the 'pin' button in the header.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking PaneGroup control. (Overrides RadTabControl..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button. (Inherited from RadTabControl.)
ScrollRight | Simulates user clicking on the right scrolling repeat button. (Inherited from RadTabControl.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items. (Inherited from RadTabControl.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem. (Inherited from RadTabControl.)
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging. (Inherited from RadTabControl.)
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. (Inherited from RadTabControl.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl. (Inherited from RadTabControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DockResizer | Get the dock resizer of this group.
DocumentPanes | Get the list of document panes for this group.
DropDownButtonElement | Get the toggle button showing the remaining tab items on click. (Inherited from RadTabControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCommandsButton | Get the header 'Commands' toggle button.
HeaderTitle | Get the pane header title.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left. (Inherited from RadTabControl.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
PaneHeader | Get the pane header of this group.
Panes | Get the list of panes for this group.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. (Inherited from RadTabControl.)
RightScrollButton | Get the repeat button which on click scrolls the tab items on right. (Inherited from RadTabControl.)
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. (Inherited from RadTabControl.)
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements. (Inherited from RadTabControl.)
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl. (Inherited from RadTabControl.)
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane group control. (Overrides RadTabControl..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


RadPaneGroup Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup Constructor
RadPaneGroup Class See Also Send Feedback
Initializes a new instance of the RadPaneGroup class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPaneGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPaneGroup()

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


RadPaneGroup Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup Methods
RadPaneGroup Class See Also Send Feedback

The RadPaneGroup type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderClose | Simulates user clicking on the 'close' button in the header.
HeaderPin | Simulates user clicking on the 'pin' button in the header.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking PaneGroup control. (Overrides RadTabControl..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button. (Inherited from RadTabControl.)
ScrollRight | Simulates user clicking on the right scrolling repeat button. (Inherited from RadTabControl.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items. (Inherited from RadTabControl.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.AnySibling Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.AssignReference Method
RadPaneGroup Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadPaneGroup.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.GetProperty Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.GetRectangle Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


HeaderClose Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.HeaderClose Method
RadPaneGroup Class See Also Send Feedback
Simulates user clicking on the 'close' button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HeaderClose()
Visual Basic (Declaration)
Public Sub HeaderClose
Visual C++
public:
void HeaderClose()

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderPin Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.HeaderPin Method
RadPaneGroup Class See Also Send Feedback
Simulates user clicking on the 'pin' button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HeaderPin()
Visual Basic (Declaration)
Public Sub HeaderPin
Visual C++
public:
void HeaderPin()

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.Highlight Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.InitializeMappings Method
RadPaneGroup Class See Also Send Feedback
Initializes the mapping of the RadDocking PaneGroup control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.InvokeMethod Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.NextSibling Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.Parent Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.PreviousSibling Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.ScrollToVisible Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members
Telerik.WebAii.Controls.Xaml Namespace


RadPaneGroup Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup Properties
RadPaneGroup Class See Also Send Feedback

The RadPaneGroup type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem. (Inherited from RadTabControl.)
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging. (Inherited from RadTabControl.)
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. (Inherited from RadTabControl.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl. (Inherited from RadTabControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DockResizer | Get the dock resizer of this group.
DocumentPanes | Get the list of document panes for this group.
DropDownButtonElement | Get the toggle button showing the remaining tab items on click. (Inherited from RadTabControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCommandsButton | Get the header 'Commands' toggle button.
HeaderTitle | Get the pane header title.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left. (Inherited from RadTabControl.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
PaneHeader | Get the pane header of this group.
Panes | Get the list of panes for this group.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. (Inherited from RadTabControl.)
RightScrollButton | Get the repeat button which on click scrolls the tab items on right. (Inherited from RadTabControl.)
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. (Inherited from RadTabControl.)
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements. (Inherited from RadTabControl.)
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl. (Inherited from RadTabControl.)
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane group control. (Overrides RadTabControl..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


DockResizer Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.DockResizer Property
RadPaneGroup Class See Also Send Feedback
Get the dock resizer of this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGridResizer DockResizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property DockResizer As RadGridResizer
Visual C++
public:
property RadGridResizer^ DockResizer {
    RadGridResizer^ get ();
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


DocumentPanes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.DocumentPanes Property
RadPaneGroup Class See Also Send Feedback
Get the list of document panes for this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadDocumentPane> DocumentPanes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentPanes As IList(Of RadDocumentPane)
Visual C++
public:
property IList<RadDocumentPane^>^ DocumentPanes {
    IList<RadDocumentPane^>^ get ();
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderCommandsButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.HeaderCommandsButton Property
RadPaneGroup Class See Also Send Feedback
Get the header 'Commands' toggle button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToggleButton HeaderCommandsButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderCommandsButton As RadToggleButton
Visual C++
public:
property RadToggleButton^ HeaderCommandsButton {
    RadToggleButton^ get ();
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderTitle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.HeaderTitle Property
RadPaneGroup Class See Also Send Feedback
Get the pane header title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderTitle As String
Visual C++
public:
property String^ HeaderTitle {
    String^ get ();
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


PaneHeader Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.PaneHeader Property
RadPaneGroup Class See Also Send Feedback
Get the pane header of this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public PaneHeader PaneHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaneHeader As PaneHeader
Visual C++
public:
property PaneHeader^ PaneHeader {
    PaneHeader^ get ();
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


Panes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.Panes Property
RadPaneGroup Class See Also Send Feedback
Get the list of panes for this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPane> Panes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panes As IList(Of RadPane)
Visual C++
public:
property IList<RadPane^>^ Panes {
    IList<RadPane^>^ get ();
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPaneGroup..::.XamlTag Property
RadPaneGroup Class See Also Send Feedback
Get the xaml tag of the pane group control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPaneGroup Class
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Class
Members See Also Send Feedback
Represents the Silverlight RadPanelBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPanelBar : ItemsControl
Visual Basic (Declaration)
Public Class RadPanelBar _
    Inherits ItemsControl
Visual C++
public ref class RadPanelBar : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadPanelBar

See Also

RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Members
RadPanelBar Class Constructors Methods Properties See Also Send Feedback

The RadPanelBar type exposes the following members.

Constructors

Name | Description
RadPanelBar | Initializes a new instance of the RadPanelBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadPanelBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the root RadPanelBarItem elements.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the panelbar orientation.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Constructor
RadPanelBar Class See Also Send Feedback
Initializes a new instance of the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPanelBar()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Methods
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadPanelBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.AnySibling Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.AssignReference Method
RadPanelBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadPanelBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.GetProperty Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.GetRectangle Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Highlight Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.InitializeMappings Method
RadPanelBar Class See Also Send Feedback
Initializes the mapping of the RadPanelBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.InvokeMethod Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.NextSibling Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Parent Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.PreviousSibling Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.ScrollToVisible Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar Properties
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the root RadPanelBarItem elements.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the panelbar orientation.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Items Property
RadPanelBar Class See Also Send Feedback
Gets the list of the root RadPanelBarItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ Items {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.Orientation Property
RadPanelBar Class See Also Send Feedback
Get or set the panelbar orientation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBar..::.XamlTag Property
RadPanelBar Class See Also Send Feedback
Get the xaml tag of RadPanelBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBarItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Class
Members See Also Send Feedback
Represents the Silverlight RadPanelBarItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadPanelBarItem : ItemsControl
Visual Basic (Declaration)
Public Class RadPanelBarItem _
    Inherits ItemsControl
Visual C++
public ref class RadPanelBarItem : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadPanelBarItem

See Also

RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBarItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Members
RadPanelBarItem Class Constructors Methods Properties See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Constructors

Name | Description
RadPanelBarItem | Initializes a new instance of the RadPanelBarItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Clicks and refreshes the item.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
HoverOver | Hover overs the item.
InitializeMappings | Initializes the mapping of the RadPanelBarItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the item template.
HeaderText | Get the item text in the header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the panelbar item sibling index.
IsCollapsedArrowDisplayed | Get whether the collapsed arrow is displayed in the root item.
IsDisabledVisually | Get whether the disabled style is applied.
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Get or set whether the panelbar item is expanded.
IsExpandedArrowDisplayed | Get whether the expanded arrow is displayed in the root item.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Get or set whether the panelbar item is hovered over.
IsSelected | Get or set whether the panelbar item is selected.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the RadPanelBarItem sub elements.
Level | Get the panelbar item level.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBarItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBarItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Constructor
RadPanelBarItem Class See Also Send Feedback
Initializes a new instance of the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadPanelBarItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPanelBarItem()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBarItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Methods
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Clicks and refreshes the item.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
HoverOver | Hover overs the item.
InitializeMappings | Initializes the mapping of the RadPanelBarItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.AnySibling Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.AssignReference Method
RadPanelBarItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference of the element.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Click Method
RadPanelBarItem Class See Also Send Feedback
Clicks and refreshes the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Click()
Visual Basic (Declaration)
Public Sub Click
Visual C++
public:
void Click()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.GetProperty Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.GetRectangle Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Highlight Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


HoverOver Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.HoverOver Method
RadPanelBarItem Class See Also Send Feedback
Hover overs the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HoverOver()
Visual Basic (Declaration)
Public Sub HoverOver
Visual C++
public:
void HoverOver()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.InitializeMappings Method
RadPanelBarItem Class See Also Send Feedback
Initializes the mapping of the RadPanelBarItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.InvokeMethod Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.NextSibling Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Parent Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.PreviousSibling Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.ScrollToVisible Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadPanelBarItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem Properties
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the item template.
HeaderText | Get the item text in the header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Index | Get the panelbar item sibling index.
IsCollapsedArrowDisplayed | Get whether the collapsed arrow is displayed in the root item.
IsDisabledVisually | Get whether the disabled style is applied.
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Get or set whether the panelbar item is expanded.
IsExpandedArrowDisplayed | Get whether the expanded arrow is displayed in the root item.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Get or set whether the panelbar item is hovered over.
IsSelected | Get or set whether the panelbar item is selected.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the RadPanelBarItem sub elements.
Level | Get the panelbar item level.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBarItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderContentPresenter Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.HeaderContentPresenter Property
RadPanelBarItem Class See Also Send Feedback
Get the content panel in the header that can be used to find sub-controls plugged into the item template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter HeaderContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ HeaderContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.HeaderText Property
RadPanelBarItem Class See Also Send Feedback
Get the item text in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


Index Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Index Property
RadPanelBarItem Class See Also Send Feedback
Get the panelbar item sibling index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsCollapsedArrowDisplayed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.IsCollapsedArrowDisplayed Property
RadPanelBarItem Class See Also Send Feedback
Get whether the collapsed arrow is displayed in the root item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsCollapsedArrowDisplayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCollapsedArrowDisplayed As Boolean
Visual C++
public:
property bool IsCollapsedArrowDisplayed {
    bool get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when item is not panelbar root item.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsDisabledVisually Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.IsDisabledVisually Property
RadPanelBarItem Class See Also Send Feedback
Get whether the disabled style is applied.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsDisabledVisually { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDisabledVisually As Boolean
Visual C++
public:
property bool IsDisabledVisually {
    bool get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.IsExpanded Property
RadPanelBarItem Class See Also Send Feedback
Get or set whether the panelbar item is expanded.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsExpandedArrowDisplayed Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.IsExpandedArrowDisplayed Property
RadPanelBarItem Class See Also Send Feedback
Get whether the expanded arrow is displayed in the root item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpandedArrowDisplayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpandedArrowDisplayed As Boolean
Visual C++
public:
property bool IsExpandedArrowDisplayed {
    bool get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when item is not panelbar root item.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsMouseOver Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.IsMouseOver Property
RadPanelBarItem Class See Also Send Feedback
Get or set whether the panelbar item is hovered over.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMouseOver { get; set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean
Visual C++
public:
property bool IsMouseOver {
    bool get ();
    void set (bool value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.IsSelected Property
RadPanelBarItem Class See Also Send Feedback
Get or set whether the panelbar item is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Items Property
RadPanelBarItem Class See Also Send Feedback
Gets the list of the RadPanelBarItem sub elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPanelBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ Items {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


Level Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.Level Property
RadPanelBarItem Class See Also Send Feedback
Get the panelbar item level.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadPanelBarItem..::.XamlTag Property
RadPanelBarItem Class See Also Send Feedback
Get the xaml tag of RadPanelBarItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadProgressBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar Class
Members See Also Send Feedback
Represents the RadProgressBar for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadProgressBar : RangeBase
Visual Basic (Declaration)
Public Class RadProgressBar _
    Inherits RangeBase
Visual C++
public ref class RadProgressBar : public RangeBase

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.RangeBase
Telerik.WebAii.Controls.Xaml..::.RadProgressBar

See Also

RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadProgressBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar Members
RadProgressBar Class Constructors Methods Properties See Also Send Feedback

The RadProgressBar type exposes the following members.

Constructors

Name | Description
RadProgressBar | Initializes a new instance of the RadProgressBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadProgressBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsIndeterminate | Get the 'IsIndeterminate' RadProgressBar value via automation property.
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get the RadProgressBar orientation value via automation property.
Padding | (Inherited from RangeBase.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadProgressBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadProgressBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar Constructor
RadProgressBar Class See Also Send Feedback
Initializes a new instance of the RadProgressBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadProgressBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadProgressBar()

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadProgressBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar Methods
RadProgressBar Class See Also Send Feedback

The RadProgressBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadProgressBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.AnySibling Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.GetProperty Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.GetRectangle Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.Highlight Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.InitializeMappings Method
RadProgressBar Class See Also Send Feedback
Initializes the mapping of the RadProgressBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.InvokeMethod Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.NextSibling Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.Parent Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.PreviousSibling Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.ScrollToVisible Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadProgressBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar Properties
RadProgressBar Class See Also Send Feedback

The RadProgressBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsIndeterminate | Get the 'IsIndeterminate' RadProgressBar value via automation property.
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get the RadProgressBar orientation value via automation property.
Padding | (Inherited from RangeBase.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadProgressBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


IsIndeterminate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.IsIndeterminate Property
RadProgressBar Class See Also Send Feedback
Get the 'IsIndeterminate' RadProgressBar value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsIndeterminate { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsIndeterminate As Boolean
Visual C++
public:
property bool IsIndeterminate {
    bool get ();
}

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.Orientation Property
RadProgressBar Class See Also Send Feedback
Get the RadProgressBar orientation value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
}

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadProgressBar..::.XamlTag Property
RadProgressBar Class See Also Send Feedback
Get the xaml tag of RadProgressBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadProgressBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadRadioButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton Class
Members See Also Send Feedback
Represents the RadRadioButton for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRadioButton : RadioButton
Visual Basic (Declaration)
Public Class RadRadioButton _
    Inherits RadioButton
Visual C++
public ref class RadRadioButton : public RadioButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.RadioButton
Telerik.WebAii.Controls.Xaml..::.RadRadioButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonRadioButton

See Also

RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRadioButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton Members
RadRadioButton Class Constructors Methods Properties See Also Send Feedback

The RadRadioButton type exposes the following members.

Constructors

Name | Description
RadRadioButton | Initializes a new instance of the RadRadioButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RadioButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRadioButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SmartUserClick | Clicks on the check box portion of the radio button if it exists, otherwise clicks on the center of the button rectangle. (Inherited from RadioButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RadioButton.)
BorderBrush | (Inherited from RadioButton.)
BorderThickness | (Inherited from RadioButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from RadioButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from RadioButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RadioButton.)
FontSize | (Inherited from RadioButton.)
FontStretch | (Inherited from RadioButton.)
FontStyle | (Inherited from RadioButton.)
FontWeight | (Inherited from RadioButton.)
Foreground | (Inherited from RadioButton.)
GroupName | (Inherited from RadioButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RadioButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | (Inherited from RadioButton.)
IsEnabled | (Inherited from RadioButton.)
IsFocused | (Inherited from RadioButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from RadioButton.)
IsPressed | (Inherited from RadioButton.)
IsTabStop | (Inherited from RadioButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from RadioButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from RadioButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from RadioButton.)
TabNavigation | (Inherited from RadioButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RadioButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRadioButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRadioButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton Constructor
RadRadioButton Class See Also Send Feedback
Initializes a new instance of the RadRadioButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRadioButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRadioButton()

See Also

RadRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRadioButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton Methods
RadRadioButton Class See Also Send Feedback

The RadRadioButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RadioButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRadioButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SmartUserClick | Clicks on the check box portion of the radio button if it exists, otherwise clicks on the center of the button rectangle. (Inherited from RadioButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.AnySibling Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.GetProperty Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.GetRectangle Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.Highlight Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.InitializeMappings Method
RadRadioButton Class See Also Send Feedback
Initializes the mapping of the RadRadioButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.InvokeMethod Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.NextSibling Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.Parent Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.PreviousSibling Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.ScrollToVisible Method
RadRadioButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
RadRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRadioButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton Properties
RadRadioButton Class See Also Send Feedback

The RadRadioButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RadioButton.)
BorderBrush | (Inherited from RadioButton.)
BorderThickness | (Inherited from RadioButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from RadioButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from RadioButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RadioButton.)
FontSize | (Inherited from RadioButton.)
FontStretch | (Inherited from RadioButton.)
FontStyle | (Inherited from RadioButton.)
FontWeight | (Inherited from RadioButton.)
Foreground | (Inherited from RadioButton.)
GroupName | (Inherited from RadioButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RadioButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | (Inherited from RadioButton.)
IsEnabled | (Inherited from RadioButton.)
IsFocused | (Inherited from RadioButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from RadioButton.)
IsPressed | (Inherited from RadioButton.)
IsTabStop | (Inherited from RadioButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from RadioButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from RadioButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from RadioButton.)
TabNavigation | (Inherited from RadioButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RadioButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRadioButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRadioButton..::.XamlTag Property
RadRadioButton Class See Also Send Feedback
Get the xaml tag of RadRadioButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar Class
Members See Also Send Feedback
Represents the Silverlight RadRibbonBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRibbonBar : ItemsControl
Visual Basic (Declaration)
Public Class RadRibbonBar _
    Inherits ItemsControl
Visual C++
public ref class RadRibbonBar : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadRibbonBar

See Also

RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar Members
RadRibbonBar Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBar type exposes the following members.

Constructors

Name | Description
RadRibbonBar | Initializes a new instance of the RadRibbonBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTab | Selects the tab with the given index.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleApplicationMenu | Opens/closes the application menu.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
ApplicationButton | Get the drop down button opening the application menu on click.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HelpButton | Get the Ribbon help button.
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMinimized | Get whether the Ribbon is minimized.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
QuickAccessToolBar | Get the quick access tool bar (at the Ribbon top).
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RibbonGroups | Get the list of tab content ribbon groups.
TabContentHost | Gets the element hosting the tab content.
TabContentPopup | Get the tab content popup hosting the content if the ribbon tab is in minimized state.
TabControl | Get the TabControl position below the header of the RibbonBar.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
WindowTitle | Get the window title control of our RibbonBar.
XamlTag | Get the xaml tag of RadRibbonBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar Constructor
RadRibbonBar Class See Also Send Feedback
Initializes a new instance of the RadRibbonBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRibbonBar()

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar Methods
RadRibbonBar Class See Also Send Feedback

The RadRibbonBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTab | Selects the tab with the given index.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleApplicationMenu | Opens/closes the application menu.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.AnySibling Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.AssignReference Method
RadRibbonBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference to assign.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.GetProperty Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.GetRectangle Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.Highlight Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.InitializeMappings Method
RadRibbonBar Class See Also Send Feedback
Initializes the mapping of the RadRibbonBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.InvokeMethod Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.NextSibling Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.Parent Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.PreviousSibling Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.ScrollToVisible Method
RadRibbonBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Xaml Namespace


SelectTab Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.SelectTab Method
RadRibbonBar Class See Also Send Feedback
Selects the tab with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectTab(
    int index
)
Visual Basic (Declaration)
Public Sub SelectTab ( _
    index As Integer _
)
Visual C++
public:
void SelectTab(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the tab to be selected.

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleApplicationMenu Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.ToggleApplicationMenu Method
RadRibbonBar Class See Also Send Feedback
Opens/closes the application menu.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleApplicationMenu()
Visual Basic (Declaration)
Public Sub ToggleApplicationMenu
Visual C++
public:
void ToggleApplicationMenu()

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar Properties
RadRibbonBar Class See Also Send Feedback

The RadRibbonBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
ApplicationButton | Get the drop down button opening the application menu on click.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HelpButton | Get the Ribbon help button.
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMinimized | Get whether the Ribbon is minimized.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
QuickAccessToolBar | Get the quick access tool bar (at the Ribbon top).
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RibbonGroups | Get the list of tab content ribbon groups.
TabContentHost | Gets the element hosting the tab content.
TabContentPopup | Get the tab content popup hosting the content if the ribbon tab is in minimized state.
TabControl | Get the TabControl position below the header of the RibbonBar.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
WindowTitle | Get the window title control of our RibbonBar.
XamlTag | Get the xaml tag of RadRibbonBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


ApplicationButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.ApplicationButton Property
RadRibbonBar Class See Also Send Feedback
Get the drop down button opening the application menu on click.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonDropDownButton ApplicationButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationButton As RadRibbonDropDownButton
Visual C++
public:
property RadRibbonDropDownButton^ ApplicationButton {
    RadRibbonDropDownButton^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


HelpButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.HelpButton Property
RadRibbonBar Class See Also Send Feedback
Get the Ribbon help button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonButton HelpButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpButton As RadRibbonButton
Visual C++
public:
property RadRibbonButton^ HelpButton {
    RadRibbonButton^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


IsMinimized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.IsMinimized Property
RadRibbonBar Class See Also Send Feedback
Get whether the Ribbon is minimized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMinimized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMinimized As Boolean
Visual C++
public:
property bool IsMinimized {
    bool get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


QuickAccessToolBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.QuickAccessToolBar Property
RadRibbonBar Class See Also Send Feedback
Get the quick access tool bar (at the Ribbon top).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public QuickAccessToolBar QuickAccessToolBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property QuickAccessToolBar As QuickAccessToolBar
Visual C++
public:
property QuickAccessToolBar^ QuickAccessToolBar {
    QuickAccessToolBar^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonGroups Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.RibbonGroups Property
RadRibbonBar Class See Also Send Feedback
Get the list of tab content ribbon groups.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadRibbonGroup> RibbonGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property RibbonGroups As IList(Of RadRibbonGroup)
Visual C++
public:
property IList<RadRibbonGroup^>^ RibbonGroups {
    IList<RadRibbonGroup^>^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


TabContentHost Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.TabContentHost Property
RadRibbonBar Class See Also Send Feedback
Gets the element hosting the tab content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Border TabContentHost { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabContentHost As Border
Visual C++
public:
property Border^ TabContentHost {
    Border^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


TabContentPopup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.TabContentPopup Property
RadRibbonBar Class See Also Send Feedback
Get the tab content popup hosting the content if the ribbon tab is in minimized state.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Popup TabContentPopup { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabContentPopup As Popup
Visual C++
public:
property Popup^ TabContentPopup {
    Popup^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


TabControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.TabControl Property
RadRibbonBar Class See Also Send Feedback
Get the TabControl position below the header of the RibbonBar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTabControl TabControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabControl As RadTabControl
Visual C++
public:
property RadTabControl^ TabControl {
    RadTabControl^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.WindowTitle Property
RadRibbonBar Class See Also Send Feedback
Get the window title control of our RibbonBar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public WindowTitle WindowTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property WindowTitle As WindowTitle
Visual C++
public:
property WindowTitle^ WindowTitle {
    WindowTitle^ get ();
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonBar..::.XamlTag Property
RadRibbonBar Class See Also Send Feedback
Get the xaml tag of RadRibbonBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton Class
Members See Also Send Feedback
Represents the Silverlight RadRibbonBar's Button control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRibbonButton : RadButton
Visual Basic (Declaration)
Public Class RadRibbonButton _
    Inherits RadButton
Visual C++
public ref class RadRibbonButton : public RadButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Button
Telerik.WebAii.Controls.Xaml..::.RadButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonButton

See Also

RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton Members
RadRibbonButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonButton type exposes the following members.

Constructors

Name | Description
RadRibbonButton | Initializes a new instance of the RadRibbonButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonButton control. (Overrides RadButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the image of the button.
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button. (Inherited from RadButton.)
TextBlock1 | Get the text block in the first row of the ribbon button.
TextBlock2 | Get the text block in the second row of the ribbon button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonButton control. (Overrides RadButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton Constructor
RadRibbonButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRibbonButton()

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton Methods
RadRibbonButton Class See Also Send Feedback

The RadRibbonButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonButton control. (Overrides RadButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.AnySibling Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.GetProperty Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.GetRectangle Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.Highlight Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.InitializeMappings Method
RadRibbonButton Class See Also Send Feedback
Initializes the mapping of the RadRibbonButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.InvokeMethod Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.NextSibling Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.Parent Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.PreviousSibling Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.ScrollToVisible Method
RadRibbonButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
RadRibbonButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton Properties
RadRibbonButton Class See Also Send Feedback

The RadRibbonButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the image of the button.
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button. (Inherited from RadButton.)
TextBlock1 | Get the text block in the first row of the ribbon button.
TextBlock2 | Get the text block in the second row of the ribbon button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonButton control. (Overrides RadButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


Image Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.Image Property
RadRibbonButton Class See Also Send Feedback
Get the image of the button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlock1 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.TextBlock1 Property
RadRibbonButton Class See Also Send Feedback
Get the text block in the first row of the ribbon button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlock1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlock1 As TextBlock
Visual C++
public:
property TextBlock^ TextBlock1 {
    TextBlock^ get ();
}

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlock2 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.TextBlock2 Property
RadRibbonButton Class See Also Send Feedback
Get the text block in the second row of the ribbon button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlock2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlock2 As TextBlock
Visual C++
public:
property TextBlock^ TextBlock2 {
    TextBlock^ get ();
}

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonButton..::.XamlTag Property
RadRibbonButton Class See Also Send Feedback
Get the xaml tag of RadRibbonButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRibbonButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonDropDownButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton Class
Members See Also Send Feedback
Represents the Silverlight RadRibbonBar's DropDownButton control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRibbonDropDownButton : RadDropDownButton
Visual Basic (Declaration)
Public Class RadRibbonDropDownButton _
    Inherits RadDropDownButton
Visual C++
public ref class RadRibbonDropDownButton : public RadDropDownButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Button
Telerik.WebAii.Controls.Xaml..::.RadButton
Telerik.WebAii.Controls.Xaml..::.RadDropDownButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonDropDownButton

See Also

RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonDropDownButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton Members
RadRibbonDropDownButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonDropDownButton type exposes the following members.

Constructors

Name | Description
RadRibbonDropDownButton | Initializes a new instance of the RadRibbonDropDownButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonButton control. (Overrides RadDropDownButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Opens/closes the drop down. (Inherited from RadDropDownButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AutoOpenDelay | Gets or sets whether the popup opens when mouse hovers for pointed milliseconds. Value of zero means no auto open. (Inherited from RadDropDownButton.)
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles. (Inherited from RadDropDownButton.)
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDownHeight | Gets or sets the Height of the popup. (Inherited from RadDropDownButton.)
DropDownIndicatorVisibility | Gets the DropDown indicator visibility. (Inherited from RadDropDownButton.)
DropDownPopup | Get the popup of the drop down button. (Inherited from RadDropDownButton.)
DropDownWidth | Gets or sets the Width of the popup. (Inherited from RadDropDownButton.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPopupOpen | Gets whether the drop down popup is open. (Inherited from RadDropDownButton.)
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button. (Inherited from RadButton.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonDropDownButton control. (Overrides RadDropDownButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonDropDownButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton Constructor
RadRibbonDropDownButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonDropDownButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonDropDownButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRibbonDropDownButton()

See Also

RadRibbonDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonDropDownButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton Methods
RadRibbonDropDownButton Class See Also Send Feedback

The RadRibbonDropDownButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Button.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonButton control. (Overrides RadDropDownButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Opens/closes the drop down. (Inherited from RadDropDownButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.AnySibling Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.GetProperty Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.GetRectangle Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.Highlight Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.InitializeMappings Method
RadRibbonDropDownButton Class See Also Send Feedback
Initializes the mapping of the RadRibbonButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRibbonDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.InvokeMethod Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.NextSibling Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.Parent Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.PreviousSibling Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.ScrollToVisible Method
RadRibbonDropDownButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
RadRibbonDropDownButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonDropDownButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton Properties
RadRibbonDropDownButton Class See Also Send Feedback

The RadRibbonDropDownButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
AutoOpenDelay | Gets or sets whether the popup opens when mouse hovers for pointed milliseconds. Value of zero means no auto open. (Inherited from RadDropDownButton.)
Background | (Inherited from Button.)
BorderBrush | (Inherited from Button.)
BorderThickness | (Inherited from Button.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from Button.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles. (Inherited from RadDropDownButton.)
Content | (Inherited from Button.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDownHeight | Gets or sets the Height of the popup. (Inherited from RadDropDownButton.)
DropDownIndicatorVisibility | Gets the DropDown indicator visibility. (Inherited from RadDropDownButton.)
DropDownPopup | Get the popup of the drop down button. (Inherited from RadDropDownButton.)
DropDownWidth | Gets or sets the Width of the popup. (Inherited from RadDropDownButton.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Button.)
FontSize | (Inherited from Button.)
FontStretch | (Inherited from Button.)
FontStyle | (Inherited from Button.)
FontWeight | (Inherited from Button.)
Foreground | (Inherited from Button.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Button.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Button.)
IsFocused | (Inherited from Button.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from Button.)
IsPopupOpen | Gets whether the drop down popup is open. (Inherited from RadDropDownButton.)
IsPressed | (Inherited from Button.)
IsTabStop | (Inherited from Button.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Button.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Button.)
TabNavigation | (Inherited from Button.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the text of the button. (Inherited from RadButton.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Button.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonDropDownButton control. (Overrides RadDropDownButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonDropDownButton..::.XamlTag Property
RadRibbonDropDownButton Class See Also Send Feedback
Get the xaml tag of RadRibbonDropDownButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRibbonDropDownButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonGroup Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup Class
Members See Also Send Feedback
Represents the Silverlight RadRibbonGroup control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRibbonGroup : ItemsControl
Visual Basic (Declaration)
Public Class RadRibbonGroup _
    Inherits ItemsControl
Visual C++
public ref class RadRibbonGroup : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadRibbonGroup

See Also

RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonGroup Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup Members
RadRibbonGroup Class Constructors Methods Properties See Also Send Feedback

The RadRibbonGroup type exposes the following members.

Constructors

Name | Description
RadRibbonGroup | Initializes a new instance of the RadRibbonGroup class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonGroup control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DialogLauncher | Get the button at the very bottom right which shows some tips on hover over.
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StripPanel | Get the strip panel element holding the group content.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TrayText | Get the group tray text.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonGroup control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonGroup Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup Constructor
RadRibbonGroup Class See Also Send Feedback
Initializes a new instance of the RadRibbonGroup class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRibbonGroup()

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonGroup Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup Methods
RadRibbonGroup Class See Also Send Feedback

The RadRibbonGroup type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonGroup control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.AnySibling Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.GetProperty Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.GetRectangle Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.Highlight Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.InitializeMappings Method
RadRibbonGroup Class See Also Send Feedback
Initializes the mapping of the RadRibbonGroup control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.InvokeMethod Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.NextSibling Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.Parent Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.PreviousSibling Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.ScrollToVisible Method
RadRibbonGroup Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
RadRibbonGroup Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonGroup Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup Properties
RadRibbonGroup Class See Also Send Feedback

The RadRibbonGroup type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DialogLauncher | Get the button at the very bottom right which shows some tips on hover over.
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StripPanel | Get the strip panel element holding the group content.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TrayText | Get the group tray text.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonGroup control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


DialogLauncher Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.DialogLauncher Property
RadRibbonGroup Class See Also Send Feedback
Get the button at the very bottom right which shows some tips on hover over.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonButton DialogLauncher { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogLauncher As RadRibbonButton
Visual C++
public:
property RadRibbonButton^ DialogLauncher {
    RadRibbonButton^ get ();
}

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


StripPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.StripPanel Property
RadRibbonGroup Class See Also Send Feedback
Get the strip panel element holding the group content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public FrameworkElement StripPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property StripPanel As FrameworkElement
Visual C++
public:
property FrameworkElement^ StripPanel {
    FrameworkElement^ get ();
}

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


TrayText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.TrayText Property
RadRibbonGroup Class See Also Send Feedback
Get the group tray text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TrayText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrayText As String
Visual C++
public:
property String^ TrayText {
    String^ get ();
}

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonGroup..::.XamlTag Property
RadRibbonGroup Class See Also Send Feedback
Get the xaml tag of RadRibbonGroup control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRibbonGroup Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonRadioButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton Class
Members See Also Send Feedback
Represents the Silverlight RadRibbonRadioButton control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRibbonRadioButton : RadRadioButton
Visual Basic (Declaration)
Public Class RadRibbonRadioButton _
    Inherits RadRadioButton
Visual C++
public ref class RadRibbonRadioButton : public RadRadioButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.RadioButton
Telerik.WebAii.Controls.Xaml..::.RadRadioButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonRadioButton

See Also

RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonRadioButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton Members
RadRibbonRadioButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonRadioButton type exposes the following members.

Constructors

Name | Description
RadRibbonRadioButton | Initializes a new instance of the RadRibbonRadioButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RadioButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonRadioButton control. (Overrides RadRadioButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SmartUserClick | Clicks on the check box portion of the radio button if it exists, otherwise clicks on the center of the button rectangle. (Inherited from RadioButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RadioButton.)
BorderBrush | (Inherited from RadioButton.)
BorderThickness | (Inherited from RadioButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from RadioButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from RadioButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RadioButton.)
FontSize | (Inherited from RadioButton.)
FontStretch | (Inherited from RadioButton.)
FontStyle | (Inherited from RadioButton.)
FontWeight | (Inherited from RadioButton.)
Foreground | (Inherited from RadioButton.)
GroupName | (Inherited from RadioButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RadioButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the image of the button.
IsAutoSize | Get/Set the permission to resize the Image according to the RibbonBar guidance.
IsChecked | (Inherited from RadioButton.)
IsEnabled | (Inherited from RadioButton.)
IsFocused | (Inherited from RadioButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from RadioButton.)
IsPressed | (Inherited from RadioButton.)
IsTabStop | (Inherited from RadioButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from RadioButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from RadioButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from RadioButton.)
TabNavigation | (Inherited from RadioButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextBlock1 | Get the text block in the first row of the ribbon radio button.
TextBlock2 | Get the text block in the second row of the ribbon radio button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RadioButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonRadioButton control. (Overrides RadRadioButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonRadioButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton Constructor
RadRibbonRadioButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonRadioButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonRadioButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRibbonRadioButton()

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonRadioButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton Methods
RadRibbonRadioButton Class See Also Send Feedback

The RadRibbonRadioButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RadioButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonRadioButton control. (Overrides RadRadioButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SmartUserClick | Clicks on the check box portion of the radio button if it exists, otherwise clicks on the center of the button rectangle. (Inherited from RadioButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.AnySibling Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.GetProperty Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.GetRectangle Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.Highlight Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.InitializeMappings Method
RadRibbonRadioButton Class See Also Send Feedback
Initializes the mapping of the RadRibbonRadioButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.InvokeMethod Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.NextSibling Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.Parent Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.PreviousSibling Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.ScrollToVisible Method
RadRibbonRadioButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
RadRibbonRadioButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonRadioButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton Properties
RadRibbonRadioButton Class See Also Send Feedback

The RadRibbonRadioButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RadioButton.)
BorderBrush | (Inherited from RadioButton.)
BorderThickness | (Inherited from RadioButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from RadioButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from RadioButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RadioButton.)
FontSize | (Inherited from RadioButton.)
FontStretch | (Inherited from RadioButton.)
FontStyle | (Inherited from RadioButton.)
FontWeight | (Inherited from RadioButton.)
Foreground | (Inherited from RadioButton.)
GroupName | (Inherited from RadioButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RadioButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the image of the button.
IsAutoSize | Get/Set the permission to resize the Image according to the RibbonBar guidance.
IsChecked | (Inherited from RadioButton.)
IsEnabled | (Inherited from RadioButton.)
IsFocused | (Inherited from RadioButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from RadioButton.)
IsPressed | (Inherited from RadioButton.)
IsTabStop | (Inherited from RadioButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from RadioButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from RadioButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from RadioButton.)
TabNavigation | (Inherited from RadioButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextBlock1 | Get the text block in the first row of the ribbon radio button.
TextBlock2 | Get the text block in the second row of the ribbon radio button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RadioButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonRadioButton control. (Overrides RadRadioButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


Image Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.Image Property
RadRibbonRadioButton Class See Also Send Feedback
Get the image of the button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsAutoSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.IsAutoSize Property
RadRibbonRadioButton Class See Also Send Feedback
Get/Set the permission to resize the Image according to the RibbonBar guidance.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAutoSize { get; set; }
Visual Basic (Declaration)
Public Property IsAutoSize As Boolean
Visual C++
public:
property bool IsAutoSize {
    bool get ();
    void set (bool value);
}

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlock1 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.TextBlock1 Property
RadRibbonRadioButton Class See Also Send Feedback
Get the text block in the first row of the ribbon radio button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlock1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlock1 As TextBlock
Visual C++
public:
property TextBlock^ TextBlock1 {
    TextBlock^ get ();
}

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlock2 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.TextBlock2 Property
RadRibbonRadioButton Class See Also Send Feedback
Get the text block in the second row of the ribbon radio button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlock2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlock2 As TextBlock
Visual C++
public:
property TextBlock^ TextBlock2 {
    TextBlock^ get ();
}

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonRadioButton..::.XamlTag Property
RadRibbonRadioButton Class See Also Send Feedback
Get the xaml tag of RadRibbonRadioButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRibbonRadioButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonSplitButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton Class
Members See Also Send Feedback
Represents the RadRibbonSplitButton for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadRibbonSplitButton : RadSplitButton
Visual Basic (Declaration)
Public Class RadRibbonSplitButton _
    Inherits RadSplitButton
Visual C++
public ref class RadRibbonSplitButton : public RadSplitButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadSplitButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonSplitButton

See Also

RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonSplitButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton Members
RadRibbonSplitButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonSplitButton type exposes the following members.

Constructors

Name | Description
RadRibbonSplitButton | Initializes a new instance of the RadRibbonSplitButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonSplitButton control. (Overrides RadSplitButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Opens/closes the drop down of the split button refreshing the popup. (Inherited from RadSplitButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Button | Get the RadButton part of the split button. (Inherited from RadSplitButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles. (Inherited from RadSplitButton.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDown | Get the RadToggleButton part of the split button. (Inherited from RadSplitButton.)
DropDownHeight | Gets or sets the drop down height. (Inherited from RadSplitButton.)
DropDownIndicator | Get the drop down indicator of the split button. (Inherited from RadSplitButton.)
DropDownPopup | Get the drop down popup of the split button. (Inherited from RadSplitButton.)
DropDownWidth | Gets or sets the drop down width. (Inherited from RadSplitButton.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the image of the ribbon split button.
IsAutoSize | Get/Set the permission to resize the Image according to the RibbonBar guidance.
IsChecked | Gets or sets whether the button is checked. (Inherited from RadSplitButton.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsTextInMiddleButton | Get/Set the placement of the text in the Middle-sized button.
IsToggle | Gets or sets whether the popup supports toggle mode. (Inherited from RadSplitButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitText | Get whether the Text splitting for the Large-sized button is enabled.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextBlock1 | Get the text block in the first row of the ribbon button.
TextBlock2 | Get the text block in the second row of the ribbon button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonSplitButton control. (Overrides RadSplitButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonSplitButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton Constructor
RadRibbonSplitButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonSplitButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadRibbonSplitButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadRibbonSplitButton()

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonSplitButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton Methods
RadRibbonSplitButton Class See Also Send Feedback

The RadRibbonSplitButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadRibbonSplitButton control. (Overrides RadSplitButton..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Opens/closes the drop down of the split button refreshing the popup. (Inherited from RadSplitButton.)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.AnySibling Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.GetProperty Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.GetRectangle Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.Highlight Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.InitializeMappings Method
RadRibbonSplitButton Class See Also Send Feedback
Initializes the mapping of the RadRibbonSplitButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.InvokeMethod Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.NextSibling Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.Parent Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.PreviousSibling Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.ScrollToVisible Method
RadRibbonSplitButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
RadRibbonSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadRibbonSplitButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton Properties
RadRibbonSplitButton Class See Also Send Feedback

The RadRibbonSplitButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Button | Get the RadButton part of the split button. (Inherited from RadSplitButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles. (Inherited from RadSplitButton.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDown | Get the RadToggleButton part of the split button. (Inherited from RadSplitButton.)
DropDownHeight | Gets or sets the drop down height. (Inherited from RadSplitButton.)
DropDownIndicator | Get the drop down indicator of the split button. (Inherited from RadSplitButton.)
DropDownPopup | Get the drop down popup of the split button. (Inherited from RadSplitButton.)
DropDownWidth | Gets or sets the drop down width. (Inherited from RadSplitButton.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Image | Get the image of the ribbon split button.
IsAutoSize | Get/Set the permission to resize the Image according to the RibbonBar guidance.
IsChecked | Gets or sets whether the button is checked. (Inherited from RadSplitButton.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsTextInMiddleButton | Get/Set the placement of the text in the Middle-sized button.
IsToggle | Gets or sets whether the popup supports toggle mode. (Inherited from RadSplitButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitText | Get whether the Text splitting for the Large-sized button is enabled.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextBlock1 | Get the text block in the first row of the ribbon button.
TextBlock2 | Get the text block in the second row of the ribbon button.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadRibbonSplitButton control. (Overrides RadSplitButton..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


Image Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.Image Property
RadRibbonSplitButton Class See Also Send Feedback
Get the image of the ribbon split button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsAutoSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.IsAutoSize Property
RadRibbonSplitButton Class See Also Send Feedback
Get/Set the permission to resize the Image according to the RibbonBar guidance.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAutoSize { get; set; }
Visual Basic (Declaration)
Public Property IsAutoSize As Boolean
Visual C++
public:
property bool IsAutoSize {
    bool get ();
    void set (bool value);
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsTextInMiddleButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.IsTextInMiddleButton Property
RadRibbonSplitButton Class See Also Send Feedback
Get/Set the placement of the text in the Middle-sized button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsTextInMiddleButton { get; set; }
Visual Basic (Declaration)
Public Property IsTextInMiddleButton As Boolean
Visual C++
public:
property bool IsTextInMiddleButton {
    bool get ();
    void set (bool value);
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


SplitText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.SplitText Property
RadRibbonSplitButton Class See Also Send Feedback
Get whether the Text splitting for the Large-sized button is enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool SplitText { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitText As Boolean
Visual C++
public:
property bool SplitText {
    bool get ();
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlock1 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.TextBlock1 Property
RadRibbonSplitButton Class See Also Send Feedback
Get the text block in the first row of the ribbon button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlock1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlock1 As TextBlock
Visual C++
public:
property TextBlock^ TextBlock1 {
    TextBlock^ get ();
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


TextBlock2 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.TextBlock2 Property
RadRibbonSplitButton Class See Also Send Feedback
Get the text block in the second row of the ribbon button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TextBlock TextBlock2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBlock2 As TextBlock
Visual C++
public:
property TextBlock^ TextBlock2 {
    TextBlock^ get ();
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadRibbonSplitButton..::.XamlTag Property
RadRibbonSplitButton Class See Also Send Feedback
Get the xaml tag of RadRibbonSplitButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadRibbonSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadScheduler Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Class
Members See Also Send Feedback
Represents the RadScheduler control wrapper. Serves as a main entry point for the entire Scheduler API.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadScheduler : Control
Visual Basic (Declaration)
Public Class RadScheduler _
    Inherits Control
Visual C++
public ref class RadScheduler : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadScheduler

See Also

RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


RadScheduler Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Members
RadScheduler Class Constructors Methods Properties See Also Send Feedback

The RadScheduler type exposes the following members.

Constructors

Name | Description
RadScheduler | Initializes a new instance of the RadScheduler class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ChangeView | Change the view with the given type.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NavigateBack | Simulates user clicking on the 'Back' navigation button below the Scheduler header.
NavigateForward | Simulates user clicking on the 'Forward' navigation button below the Scheduler header.
NextSibling | Overloaded.
OpenMonthDay | Overloaded.
OpenMonthWeek | Open the week with the given index. Refreshes the content internally.
OpenWeekDay | Open the day with the given index from the week header. Refreshes the content internally.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CurrentView | Gets the currently opened view.
DateHeaderText | Gets the current date header text.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NavigationDatePicker | Get the navigation RadDatePicker control residing below the Scheduler header.
NavigationPanel | Get the stack panel holding the navigation buttons and date picker.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Presenter | Gets the presenter control of the Scheduler.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewButtonsPanel | Get the top StackPanel holding the change view buttons.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadScheduler control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


RadScheduler Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Constructor
RadScheduler Class See Also Send Feedback
Initializes a new instance of the RadScheduler class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadScheduler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadScheduler()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


RadScheduler Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Methods
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ChangeView | Change the view with the given type.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NavigateBack | Simulates user clicking on the 'Back' navigation button below the Scheduler header.
NavigateForward | Simulates user clicking on the 'Forward' navigation button below the Scheduler header.
NextSibling | Overloaded.
OpenMonthDay | Overloaded.
OpenMonthWeek | Open the week with the given index. Refreshes the content internally.
OpenWeekDay | Open the day with the given index from the week header. Refreshes the content internally.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.AnySibling Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


ChangeView Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ChangeView Method
RadScheduler Class See Also Send Feedback
Change the view with the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ChangeView(
    SchedulerViewType type
)
Visual Basic (Declaration)
Public Sub ChangeView ( _
    type As SchedulerViewType _
)
Visual C++
public:
void ChangeView(
    SchedulerViewType type
)

Parameters

type
Type: Telerik.WebAii.Controls.Xaml..::.SchedulerViewType
The scheduler type view to change to.

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetProperty Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.GetRectangle Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.Highlight Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InitializeMappings Method
RadScheduler Class See Also Send Feedback
Initializes the mapping of the RadScheduler control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.InvokeMethod Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


NavigateBack Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigateBack Method
RadScheduler Class See Also Send Feedback
Simulates user clicking on the 'Back' navigation button below the Scheduler header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NavigateBack()
Visual Basic (Declaration)
Public Sub NavigateBack
Visual C++
public:
void NavigateBack()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


NavigateForward Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigateForward Method
RadScheduler Class See Also Send Feedback
Simulates user clicking on the 'Forward' navigation button below the Scheduler header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void NavigateForward()
Visual Basic (Declaration)
Public Sub NavigateForward
Visual C++
public:
void NavigateForward()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NextSibling Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


OpenMonthDay Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.OpenMonthDay Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
OpenMonthDay(Int32) | Open the month day with the given value.
OpenMonthDay(Int32, Int32) | Open the month day with the given value and occurrence.

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


OpenMonthDay Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.OpenMonthDay Method (Int32)
RadScheduler Class See Also Send Feedback
Open the month day with the given value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenMonthDay(
    int day
)
Visual Basic (Declaration)
Public Sub OpenMonthDay ( _
    day As Integer _
)
Visual C++
public:
void OpenMonthDay(
    int day
)

Parameters

day
Type: System..::.Int32
The first met value of the day displayed in the view.

See Also

RadScheduler Class
OpenMonthDay Overload
Telerik.WebAii.Controls.Xaml Namespace


OpenMonthDay Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.OpenMonthDay Method (Int32, Int32)
RadScheduler Class See Also Send Feedback
Open the month day with the given value and occurrence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenMonthDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub OpenMonthDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void OpenMonthDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The value of the day displayed in the view to open.
occurrence
Type: System..::.Int32
The occurrence of that day, e.g. the last month day value might be displayed twice.

See Also

RadScheduler Class
OpenMonthDay Overload
Telerik.WebAii.Controls.Xaml Namespace


OpenMonthWeek Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.OpenMonthWeek Method
RadScheduler Class See Also Send Feedback
Open the week with the given index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenMonthWeek(
    int index
)
Visual Basic (Declaration)
Public Sub OpenMonthWeek ( _
    index As Integer _
)
Visual C++
public:
void OpenMonthWeek(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the week to open.

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


OpenWeekDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.OpenWeekDay Method
RadScheduler Class See Also Send Feedback
Open the day with the given index from the week header. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenWeekDay(
    int index
)
Visual Basic (Declaration)
Public Sub OpenWeekDay ( _
    index As Integer _
)
Visual C++
public:
void OpenWeekDay(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the day to open.

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.Parent Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.PreviousSibling Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ScrollToVisible Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Xaml Namespace


RadScheduler Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler Properties
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CurrentView | Gets the currently opened view.
DateHeaderText | Gets the current date header text.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NavigationDatePicker | Get the navigation RadDatePicker control residing below the Scheduler header.
NavigationPanel | Get the stack panel holding the navigation buttons and date picker.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Presenter | Gets the presenter control of the Scheduler.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewButtonsPanel | Get the top StackPanel holding the change view buttons.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadScheduler control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


CurrentView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.CurrentView Property
RadScheduler Class See Also Send Feedback
Gets the currently opened view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerViewType CurrentView { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentView As SchedulerViewType
Visual C++
public:
property SchedulerViewType CurrentView {
    SchedulerViewType get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


DateHeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.DateHeaderText Property
RadScheduler Class See Also Send Feedback
Gets the current date header text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DateHeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateHeaderText As String
Visual C++
public:
property String^ DateHeaderText {
    String^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


NavigationDatePicker Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigationDatePicker Property
RadScheduler Class See Also Send Feedback
Get the navigation RadDatePicker control residing below the Scheduler header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadDatePicker NavigationDatePicker { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigationDatePicker As RadDatePicker
Visual C++
public:
property RadDatePicker^ NavigationDatePicker {
    RadDatePicker^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


NavigationPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.NavigationPanel Property
RadScheduler Class See Also Send Feedback
Get the stack panel holding the navigation buttons and date picker.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackPanel NavigationPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigationPanel As StackPanel
Visual C++
public:
property StackPanel^ NavigationPanel {
    StackPanel^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


Presenter Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.Presenter Property
RadScheduler Class See Also Send Feedback
Gets the presenter control of the Scheduler.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerPresenter Presenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Presenter As SchedulerPresenter
Visual C++
public:
property SchedulerPresenter^ Presenter {
    SchedulerPresenter^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


ViewButtonsPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.ViewButtonsPanel Property
RadScheduler Class See Also Send Feedback
Get the top StackPanel holding the change view buttons.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackPanel ViewButtonsPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewButtonsPanel As StackPanel
Visual C++
public:
property StackPanel^ ViewButtonsPanel {
    StackPanel^ get ();
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadScheduler..::.XamlTag Property
RadScheduler Class See Also Send Feedback
Get the xaml tag of the RadScheduler control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadScheduler Class
Telerik.WebAii.Controls.Xaml Namespace


RadSlider Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Class
Members See Also Send Feedback
Represents the Silverlight RadSlider control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSlider : RangeBase
Visual Basic (Declaration)
Public Class RadSlider _
    Inherits RangeBase
Visual C++
public ref class RadSlider : public RangeBase

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.RangeBase
Telerik.WebAii.Controls.Xaml..::.RadSlider

See Also

RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


RadSlider Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Members
RadSlider Class Constructors Methods Properties See Also Send Feedback

The RadSlider type exposes the following members.

Constructors

Name | Description
RadSlider | Initializes a new instance of the RadSlider class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ClickOnPath | Click on the path of the RadSlider.
Decrease | Overloaded.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragBy | Draging of the thumbs. Checks orientation of slider.
DragToTick | Drag of the thumbs to a tick.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
Increase | Overloaded.
InitializeMappings | Initializes the mapping of the RadSlider control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
BottomTickBar | Get the BottomTickBar of the slider.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelectionRangeEnabled | Get the 'IsSelectionRangeEnabled' value via automation property.
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
LeftTickBar | Get the LeftTickBar of the slider.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get the Slider orientation type, either 'Horizontal' or 'Vertical'.
Padding | (Inherited from RangeBase.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightTickBar | Get the RightTickBar of the slider.
SelectionEnd | Get the 'SelectionEnd' value via automation property.
SelectionStart | Get the 'SelectionStart' value via automation property.
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TopTickBar | Get the TopTickBar of the slider.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadSlider control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


RadSlider Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Constructor
RadSlider Class See Also Send Feedback
Initializes a new instance of the RadSlider class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSlider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSlider()

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


RadSlider Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Methods
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
ClickOnPath | Click on the path of the RadSlider.
Decrease | Overloaded.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragBy | Draging of the thumbs. Checks orientation of slider.
DragToTick | Drag of the thumbs to a tick.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
Increase | Overloaded.
InitializeMappings | Initializes the mapping of the RadSlider control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.AnySibling Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


ClickOnPath Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ClickOnPath Method
RadSlider Class See Also Send Feedback
Click on the path of the RadSlider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ClickOnPath(
    int offsetFromStart
)
Visual Basic (Declaration)
Public Sub ClickOnPath ( _
    offsetFromStart As Integer _
)
Visual C++
public:
void ClickOnPath(
    int offsetFromStart
)

Parameters

offsetFromStart
Type: System..::.Int32
The offset from the start of the RadSlider.

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


Decrease Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Decrease Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Decrease()()() | Simulates clicking on decrease handle parameters.
Decrease(Int32) | Simulates clicking on decrease handle parameters.

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


Decrease Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Decrease Method
RadSlider Class See Also Send Feedback
Simulates clicking on decrease handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Decrease()
Visual Basic (Declaration)
Public Sub Decrease
Visual C++
public:
void Decrease()

See Also

RadSlider Class
Decrease Overload
Telerik.WebAii.Controls.Xaml Namespace


Decrease Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Decrease Method (Int32)
RadSlider Class See Also Send Feedback
Simulates clicking on decrease handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Decrease(
    int numberOfClicks
)
Visual Basic (Declaration)
Public Sub Decrease ( _
    numberOfClicks As Integer _
)
Visual C++
public:
void Decrease(
    int numberOfClicks
)

Parameters

numberOfClicks
Type: System..::.Int32
Number of handle clicks.

See Also

RadSlider Class
Decrease Overload
Telerik.WebAii.Controls.Xaml Namespace


DragBy Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.DragBy Method
RadSlider Class See Also Send Feedback
Draging of the thumbs. Checks orientation of slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragBy(
    ThumbName thumbName,
    int offset
)
Visual Basic (Declaration)
Public Sub DragBy ( _
    thumbName As ThumbName, _
    offset As Integer _
)
Visual C++
public:
void DragBy(
    ThumbName thumbName,
    int offset
)

Parameters

thumbName
Type: Telerik.WebAii.Controls.Xaml..::.ThumbName
Thumb(SingleThumb,StartThumb,MiddleThumb,EndThumb).
offset
Type: System..::.Int32
Offset from the thumb. Negative offset is used to move thumb left/down.

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


DragToTick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.DragToTick Method
RadSlider Class See Also Send Feedback
Drag of the thumbs to a tick.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToTick(
    ThumbName thumbName,
    int tickIndex
)
Visual Basic (Declaration)
Public Sub DragToTick ( _
    thumbName As ThumbName, _
    tickIndex As Integer _
)
Visual C++
public:
void DragToTick(
    ThumbName thumbName,
    int tickIndex
)

Parameters

thumbName
Type: Telerik.WebAii.Controls.Xaml..::.ThumbName
Thumb(SingleThumb,StartThumb,MiddleThumb,EndThumb).
tickIndex
Type: System..::.Int32
The tick index.

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.GetProperty Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.GetRectangle Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Highlight Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


Increase Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Increase Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Increase()()() | Simulates clicking on increase handle parameters.
Increase(Int32) | Simulates clicking on increase handle parameters.

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


Increase Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Increase Method
RadSlider Class See Also Send Feedback
Simulates clicking on increase handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Increase()
Visual Basic (Declaration)
Public Sub Increase
Visual C++
public:
void Increase()

See Also

RadSlider Class
Increase Overload
Telerik.WebAii.Controls.Xaml Namespace


Increase Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Increase Method (Int32)
RadSlider Class See Also Send Feedback
Simulates clicking on increase handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Increase(
    int numberOfClicks
)
Visual Basic (Declaration)
Public Sub Increase ( _
    numberOfClicks As Integer _
)
Visual C++
public:
void Increase(
    int numberOfClicks
)

Parameters

numberOfClicks
Type: System..::.Int32
Number of handle clicks.

See Also

RadSlider Class
Increase Overload
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.InitializeMappings Method
RadSlider Class See Also Send Feedback
Initializes the mapping of the RadSlider control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.InvokeMethod Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.NextSibling Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Parent Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.PreviousSibling Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.ScrollToVisible Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Xaml Namespace


RadSlider Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider Properties
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
BottomTickBar | Get the BottomTickBar of the slider.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelectionRangeEnabled | Get the 'IsSelectionRangeEnabled' value via automation property.
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
LeftTickBar | Get the LeftTickBar of the slider.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get the Slider orientation type, either 'Horizontal' or 'Vertical'.
Padding | (Inherited from RangeBase.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RightTickBar | Get the RightTickBar of the slider.
SelectionEnd | Get the 'SelectionEnd' value via automation property.
SelectionStart | Get the 'SelectionStart' value via automation property.
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TopTickBar | Get the TopTickBar of the slider.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadSlider control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


BottomTickBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.BottomTickBar Property
RadSlider Class See Also Send Feedback
Get the BottomTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTickBar BottomTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ BottomTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


IsSelectionRangeEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.IsSelectionRangeEnabled Property
RadSlider Class See Also Send Feedback
Get the 'IsSelectionRangeEnabled' value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelectionRangeEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelectionRangeEnabled As Boolean
Visual C++
public:
property bool IsSelectionRangeEnabled {
    bool get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


LeftTickBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.LeftTickBar Property
RadSlider Class See Also Send Feedback
Get the LeftTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTickBar LeftTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ LeftTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.Orientation Property
RadSlider Class See Also Send Feedback
Get the Slider orientation type, either 'Horizontal' or 'Vertical'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


RightTickBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.RightTickBar Property
RadSlider Class See Also Send Feedback
Get the RightTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTickBar RightTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ RightTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


SelectionEnd Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SelectionEnd Property
RadSlider Class See Also Send Feedback
Get the 'SelectionEnd' value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SelectionEnd { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionEnd As Double
Visual C++
public:
property double SelectionEnd {
    double get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


SelectionStart Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.SelectionStart Property
RadSlider Class See Also Send Feedback
Get the 'SelectionStart' value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SelectionStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionStart As Double
Visual C++
public:
property double SelectionStart {
    double get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


TopTickBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.TopTickBar Property
RadSlider Class See Also Send Feedback
Get the TopTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTickBar TopTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ TopTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSlider..::.XamlTag Property
RadSlider Class See Also Send Feedback
Get the xaml tag of RadSlider control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadSlider Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton Class
Members See Also Send Feedback
Represents the RadSplitButton for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSplitButton : ContentControl
Visual Basic (Declaration)
Public Class RadSplitButton _
    Inherits ContentControl
Visual C++
public ref class RadSplitButton : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadSplitButton
Telerik.WebAii.Controls.Xaml..::.RadRibbonSplitButton

See Also

RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadSplitButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton Members
RadSplitButton Class Constructors Methods Properties See Also Send Feedback

The RadSplitButton type exposes the following members.

Constructors

Name | Description
RadSplitButton | Initializes a new instance of the RadSplitButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadSplitButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Opens/closes the drop down of the split button refreshing the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Button | Get the RadButton part of the split button.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDown | Get the RadToggleButton part of the split button.
DropDownHeight | Gets or sets the drop down height.
DropDownIndicator | Get the drop down indicator of the split button.
DropDownPopup | Get the drop down popup of the split button.
DropDownWidth | Gets or sets the drop down width.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | Gets or sets whether the button is checked.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsToggle | Gets or sets whether the popup supports toggle mode.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadSplitButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton Constructor
RadSplitButton Class See Also Send Feedback
Initializes a new instance of the RadSplitButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSplitButton()

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton Methods
RadSplitButton Class See Also Send Feedback

The RadSplitButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadSplitButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Opens/closes the drop down of the split button refreshing the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.AnySibling Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.GetProperty Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.GetRectangle Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.Highlight Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.InitializeMappings Method
RadSplitButton Class See Also Send Feedback
Initializes the mapping of the RadSplitButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.InvokeMethod Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.NextSibling Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.Parent Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.PreviousSibling Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.ScrollToVisible Method
RadSplitButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
RadSplitButton Members
Telerik.WebAii.Controls.Xaml Namespace


ToggleDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.ToggleDropDown Method
RadSplitButton Class See Also Send Feedback
Opens/closes the drop down of the split button refreshing the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleDropDown()
Visual Basic (Declaration)
Public Sub ToggleDropDown
Visual C++
public:
void ToggleDropDown()

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton Properties
RadSplitButton Class See Also Send Feedback

The RadSplitButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Button | Get the RadButton part of the split button.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseOnEscape | Gets or sets whether the popup closes when the Escape key toggles.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DropDown | Get the RadToggleButton part of the split button.
DropDownHeight | Gets or sets the drop down height.
DropDownIndicator | Get the drop down indicator of the split button.
DropDownPopup | Get the drop down popup of the split button.
DropDownWidth | Gets or sets the drop down width.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | Gets or sets whether the button is checked.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsToggle | Gets or sets whether the popup supports toggle mode.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadSplitButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


Button Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.Button Property
RadSplitButton Class See Also Send Feedback
Get the RadButton part of the split button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadButton Button { get; }
Visual Basic (Declaration)
Public ReadOnly Property Button As RadButton
Visual C++
public:
property RadButton^ Button {
    RadButton^ get ();
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


CloseOnEscape Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.CloseOnEscape Property
RadSplitButton Class See Also Send Feedback
Gets or sets whether the popup closes when the Escape key toggles.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CloseOnEscape { get; set; }
Visual Basic (Declaration)
Public Property CloseOnEscape As Boolean
Visual C++
public:
property bool CloseOnEscape {
    bool get ();
    void set (bool value);
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDown Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.DropDown Property
RadSplitButton Class See Also Send Feedback
Get the RadToggleButton part of the split button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToggleButton DropDown { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDown As RadToggleButton
Visual C++
public:
property RadToggleButton^ DropDown {
    RadToggleButton^ get ();
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.DropDownHeight Property
RadSplitButton Class See Also Send Feedback
Gets or sets the drop down height.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double
Visual C++
public:
property double DropDownHeight {
    double get ();
    void set (double value);
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownIndicator Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.DropDownIndicator Property
RadSplitButton Class See Also Send Feedback
Get the drop down indicator of the split button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Path DropDownIndicator { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownIndicator As Path
Visual C++
public:
property Path^ DropDownIndicator {
    Path^ get ();
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownPopup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.DropDownPopup Property
RadSplitButton Class See Also Send Feedback
Get the drop down popup of the split button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Popup DropDownPopup { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownPopup As Popup
Visual C++
public:
property Popup^ DropDownPopup {
    Popup^ get ();
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.DropDownWidth Property
RadSplitButton Class See Also Send Feedback
Gets or sets the drop down width.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double
Visual C++
public:
property double DropDownWidth {
    double get ();
    void set (double value);
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsChecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.IsChecked Property
RadSplitButton Class See Also Send Feedback
Gets or sets whether the button is checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic (Declaration)
Public Property IsChecked As Boolean
Visual C++
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


IsToggle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.IsToggle Property
RadSplitButton Class See Also Send Feedback
Gets or sets whether the popup supports toggle mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsToggle { get; set; }
Visual Basic (Declaration)
Public Property IsToggle As Boolean
Visual C++
public:
property bool IsToggle {
    bool get ();
    void set (bool value);
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitButton..::.XamlTag Property
RadSplitButton Class See Also Send Feedback
Get the xaml tag of RadSplitButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadSplitButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitContainer Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadSplitContainer control wrapper. The instance may contain child split containers as well as pane group controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadSplitContainer : ItemsControl
Visual Basic (Declaration)
Public Class RadSplitContainer _
    Inherits ItemsControl
Visual C++
public ref class RadSplitContainer : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadSplitContainer

See Also

RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


RadSplitContainer Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer Members
RadSplitContainer Class Constructors Methods Properties See Also Send Feedback

The RadSplitContainer type exposes the following members.

Constructors

Name | Description
RadSplitContainer | Initializes a new instance of the RadSplitContainer class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking SplitContainer control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
CenterPoint | Get the center point of the split container screen rectangle.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DockResizer | Get the docking grid resizer control.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
PaneGroups | Get the list of pane groups for this split container.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitContainers | Get the list of child split containers.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the split container control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitContainer Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer Constructor
RadSplitContainer Class See Also Send Feedback
Initializes a new instance of the RadSplitContainer class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitContainer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSplitContainer()

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


RadSplitContainer Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer Methods
RadSplitContainer Class See Also Send Feedback

The RadSplitContainer type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking SplitContainer control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.AnySibling Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.AssignReference Method
RadSplitContainer Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadSplitContainer.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.GetProperty Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.GetRectangle Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.Highlight Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.InitializeMappings Method
RadSplitContainer Class See Also Send Feedback
Initializes the mapping of the RadDocking SplitContainer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.InvokeMethod Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.NextSibling Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.Parent Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.PreviousSibling Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.ScrollToVisible Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members
Telerik.WebAii.Controls.Xaml Namespace


RadSplitContainer Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer Properties
RadSplitContainer Class See Also Send Feedback

The RadSplitContainer type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
CenterPoint | Get the center point of the split container screen rectangle.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DockResizer | Get the docking grid resizer control.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
PaneGroups | Get the list of pane groups for this split container.
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitContainers | Get the list of child split containers.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the split container control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


CenterPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.CenterPoint Property
RadSplitContainer Class See Also Send Feedback
Get the center point of the split container screen rectangle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point CenterPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property CenterPoint As Point
Visual C++
public:
property Point CenterPoint {
    Point get ();
}

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


DockResizer Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.DockResizer Property
RadSplitContainer Class See Also Send Feedback
Get the docking grid resizer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadGridResizer DockResizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property DockResizer As RadGridResizer
Visual C++
public:
property RadGridResizer^ DockResizer {
    RadGridResizer^ get ();
}

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


PaneGroups Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.PaneGroups Property
RadSplitContainer Class See Also Send Feedback
Get the list of pane groups for this split container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadPaneGroup> PaneGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaneGroups As IList(Of RadPaneGroup)
Visual C++
public:
property IList<RadPaneGroup^>^ PaneGroups {
    IList<RadPaneGroup^>^ get ();
}

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


SplitContainers Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.SplitContainers Property
RadSplitContainer Class See Also Send Feedback
Get the list of child split containers.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadSplitContainer> SplitContainers { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainers As IList(Of RadSplitContainer)
Visual C++
public:
property IList<RadSplitContainer^>^ SplitContainers {
    IList<RadSplitContainer^>^ get ();
}

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadSplitContainer..::.XamlTag Property
RadSplitContainer Class See Also Send Feedback
Get the xaml tag of the split container control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadSplitContainer Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabControl Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl Class
Members See Also Send Feedback
Represents the Silverlight RadTabControl wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTabControl : ItemsControl
Visual Basic (Declaration)
Public Class RadTabControl _
    Inherits ItemsControl
Visual C++
public ref class RadTabControl : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.AutoHideArea
Telerik.WebAii.Controls.Xaml..::.RadOutlookBar
Telerik.WebAii.Controls.Xaml..::.RadPaneGroup

See Also

RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


RadTabControl Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl Members
RadTabControl Class Constructors Methods Properties See Also Send Feedback

The RadTabControl type exposes the following members.

Constructors

Name | Description
RadTabControl | Initializes a new instance of the RadTabControl class. Empty contructor [Must have].

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTabControl control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button.
ScrollRight | Simulates user clicking on the right scrolling repeat button.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem.
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging.
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButtonElement | Get the toggle button showing the remaining tab items on click.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected.
RightScrollButton | Get the repeat button which on click scrolls the tab items on right.
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected.
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements.
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl.
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison.
TabStripPanel | Get the tab strip panel holding the tab items.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabControl. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabControl Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl Constructor
RadTabControl Class See Also Send Feedback
Initializes a new instance of the RadTabControl class. Empty contructor [Must have].

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTabControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTabControl()

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabControl Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl Methods
RadTabControl Class See Also Send Feedback

The RadTabControl type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTabControl control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the left scrolling repeat button.
ScrollRight | Simulates user clicking on the right scrolling repeat button.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the toggle button which on click shows the remaining tab items.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.AnySibling Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.GetProperty Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.GetRectangle Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.Highlight Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.InitializeMappings Method
RadTabControl Class See Also Send Feedback
Initializes the mapping of the RadTabControl control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.InvokeMethod Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.NextSibling Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.Parent Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.PreviousSibling Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollLeft Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.ScrollLeft Method
RadTabControl Class See Also Send Feedback
Simulates user clicking on the left scrolling repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollLeft()
Visual Basic (Declaration)
Public Sub ScrollLeft
Visual C++
public:
void ScrollLeft()

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollRight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.ScrollRight Method
RadTabControl Class See Also Send Feedback
Simulates user clicking on the right scrolling repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollRight()
Visual Basic (Declaration)
Public Sub ScrollRight
Visual C++
public:
void ScrollRight()

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.ScrollToVisible Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members
Telerik.WebAii.Controls.Xaml Namespace


ToggleDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.ToggleDropDown Method
RadTabControl Class See Also Send Feedback
Simulates user clicking on the toggle button which on click shows the remaining tab items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleDropDown()
Visual Basic (Declaration)
Public Sub ToggleDropDown
Visual C++
public:
void ToggleDropDown()

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabControl Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl Properties
RadTabControl Class See Also Send Feedback

The RadTabControl type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllowDragOverTab | Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem.
AllowDragReorder | Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging.
AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownButtonElement | Get the toggle button showing the remaining tab items on click.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LeftScrollButton | Get the repeat button which on click scrolls the tab items on left.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected.
RightScrollButton | Get the repeat button which on click scrolls the tab items on right.
SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected.
TabIndex | (Inherited from ItemsControl.)
TabItems | Gets the list of the RadTabItem elements.
TabNavigation | (Inherited from ItemsControl.)
TabOrientation | Gets or sets the orientation of the TabItems in the TabControl.
TabPosition | Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison.
TabStripPanel | Get the tab strip panel holding the tab items.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabControl. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


AllowDragOverTab Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.AllowDragOverTab Property
RadTabControl Class See Also Send Feedback
Gets or sets a value indicating whether dragging objects over a TabItem will select this TabItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowDragOverTab { get; set; }
Visual Basic (Declaration)
Public Property AllowDragOverTab As Boolean
Visual C++
public:
property bool AllowDragOverTab {
    bool get ();
    void set (bool value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


AllowDragReorder Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.AllowDragReorder Property
RadTabControl Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to rearrange the tabs with dragging.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllowDragReorder { get; set; }
Visual Basic (Declaration)
Public Property AllowDragReorder As Boolean
Visual C++
public:
property bool AllowDragReorder {
    bool get ();
    void set (bool value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


AllTabsEqualHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.AllTabsEqualHeight Property
RadTabControl Class See Also Send Feedback
Gets or sets whether all the present tabs have equal height.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool AllTabsEqualHeight { get; set; }
Visual Basic (Declaration)
Public Property AllTabsEqualHeight As Boolean
Visual C++
public:
property bool AllTabsEqualHeight {
    bool get ();
    void set (bool value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


BackgroundVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.BackgroundVisibility Property
RadTabControl Class See Also Send Feedback
Gets or sets the visibility of the Background of the TabControl.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility BackgroundVisibility { get; set; }
Visual Basic (Declaration)
Public Property BackgroundVisibility As Visibility
Visual C++
public:
property Visibility BackgroundVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.ContentPresenterElement Property
RadTabControl Class See Also Send Feedback
Get the TabControl ContentPresenter element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownButtonElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.DropDownButtonElement Property
RadTabControl Class See Also Send Feedback
Get the toggle button showing the remaining tab items on click.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToggleButton DropDownButtonElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownButtonElement As ToggleButton
Visual C++
public:
property ToggleButton^ DropDownButtonElement {
    ToggleButton^ get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


LeftScrollButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.LeftScrollButton Property
RadTabControl Class See Also Send Feedback
Get the repeat button which on click scrolls the tab items on left.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RepeatButton LeftScrollButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftScrollButton As RepeatButton
Visual C++
public:
property RepeatButton^ LeftScrollButton {
    RepeatButton^ get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


ReorderTabRows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.ReorderTabRows Property
RadTabControl Class See Also Send Feedback
Gets or sets whether the TabItem rows would be reordered when selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool ReorderTabRows { get; set; }
Visual Basic (Declaration)
Public Property ReorderTabRows As Boolean
Visual C++
public:
property bool ReorderTabRows {
    bool get ();
    void set (bool value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


RightScrollButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.RightScrollButton Property
RadTabControl Class See Also Send Feedback
Get the repeat button which on click scrolls the tab items on right.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RepeatButton RightScrollButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightScrollButton As RepeatButton
Visual C++
public:
property RepeatButton^ RightScrollButton {
    RepeatButton^ get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.SelectedIndex Property
RadTabControl Class See Also Send Feedback
Gets or sets the index of the selected item. The default value is -1 which means that no item is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


TabItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.TabItems Property
RadTabControl Class See Also Send Feedback
Gets the list of the RadTabItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTabItem> TabItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabItems As IList(Of RadTabItem)
Visual C++
public:
property IList<RadTabItem^>^ TabItems {
    IList<RadTabItem^>^ get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


TabOrientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.TabOrientation Property
RadTabControl Class See Also Send Feedback
Gets or sets the orientation of the TabItems in the TabControl.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation TabOrientation { get; set; }
Visual Basic (Declaration)
Public Property TabOrientation As Orientation
Visual C++
public:
property Orientation TabOrientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


TabPosition Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.TabPosition Property
RadTabControl Class See Also Send Feedback
Get the TabControl position determined by element rectangles Top, Bottom, Left and Right comparison.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Position TabPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabPosition As Position
Visual C++
public:
property Position TabPosition {
    Position get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


TabStripPanel Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.TabStripPanel Property
RadTabControl Class See Also Send Feedback
Get the tab strip panel holding the tab items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected FrameworkElement TabStripPanel { get; }
Visual Basic (Declaration)
Protected ReadOnly Property TabStripPanel As FrameworkElement
Visual C++
protected:
property FrameworkElement^ TabStripPanel {
    FrameworkElement^ get ();
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabControl..::.XamlTag Property
RadTabControl Class See Also Send Feedback
Get the xaml tag of RadTabControl.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTabControl Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem Class
Members See Also Send Feedback
Represents the Silverlight RadTabItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTabItem : ContentControl
Visual Basic (Declaration)
Public Class RadTabItem _
    Inherits ContentControl
Visual C++
public ref class RadTabItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadOutlookBarItem
Telerik.WebAii.Controls.Xaml..::.RadPane

See Also

RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadTabItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem Members
RadTabItem Class Constructors Methods Properties See Also Send Feedback

The RadTabItem type exposes the following members.

Constructors

Name | Description
RadTabItem | Initializes a new instance of the RadTabItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the item. The method also updates the parent control.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTabItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Gets whether the mouse is over the control.
IsSelected | Get or set whether the tab item is selected.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
ItemText | Get the item text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem Constructor
RadTabItem Class See Also Send Feedback
Initializes a new instance of the RadTabItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTabItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTabItem()

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTabItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem Methods
RadTabItem Class See Also Send Feedback

The RadTabItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Click | Simulates user clicking on the item. The method also updates the parent control.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTabItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.AnySibling Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


Click Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.Click Method
RadTabItem Class See Also Send Feedback
Simulates user clicking on the item. The method also updates the parent control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public virtual void Click()
Visual Basic (Declaration)
Public Overridable Sub Click
Visual C++
public:
virtual void Click()

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.GetProperty Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.GetRectangle Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.Highlight Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.InitializeMappings Method
RadTabItem Class See Also Send Feedback
Initializes the mapping of the RadTabItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.InvokeMethod Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.NextSibling Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.Parent Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.PreviousSibling Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.ScrollToVisible Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadTabItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem Properties
RadTabItem Class See Also Send Feedback

The RadTabItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsBreak | Get or set whether the next tab would be displayed on the next row.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | Gets whether the mouse is over the control.
IsSelected | Get or set whether the tab item is selected.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
ItemText | Get the item text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderContentPresenter Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.HeaderContentPresenter Property
RadTabItem Class See Also Send Feedback
Get the content panel in the header that can be used to find sub-controls plugged into the control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter HeaderContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ HeaderContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsBreak Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.IsBreak Property
RadTabItem Class See Also Send Feedback
Get or set whether the next tab would be displayed on the next row.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsBreak { get; set; }
Visual Basic (Declaration)
Public Property IsBreak As Boolean
Visual C++
public:
property bool IsBreak {
    bool get ();
    void set (bool value);
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsMouseOver Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.IsMouseOver Property
RadTabItem Class See Also Send Feedback
Gets whether the mouse is over the control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMouseOver { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMouseOver As Boolean
Visual C++
public:
property bool IsMouseOver {
    bool get ();
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.IsSelected Property
RadTabItem Class See Also Send Feedback
Get or set whether the tab item is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.ItemIndex Property
RadTabItem Class See Also Send Feedback
Get the item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.ItemText Property
RadTabItem Class See Also Send Feedback
Get the item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTabItem..::.XamlTag Property
RadTabItem Class See Also Send Feedback
Get the xaml tag of RadTabItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTabItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTickBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar Class
Members See Also Send Feedback
Represents the Silverlight RadTickBar control wrapper. Holds the Slider ticks.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTickBar : Control
Visual Basic (Declaration)
Public Class RadTickBar _
    Inherits Control
Visual C++
public ref class RadTickBar : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadTickBar

See Also

RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadTickBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar Members
RadTickBar Class Constructors Methods Properties See Also Send Feedback

The RadTickBar type exposes the following members.

Constructors

Name | Description
RadTickBar | Initializes a new instance of the RadTickBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTickBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Ticks | The list of Slider ticks.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the RadTickBar control xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadTickBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar Constructor
RadTickBar Class See Also Send Feedback
Initializes a new instance of the RadTickBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTickBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTickBar()

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadTickBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar Methods
RadTickBar Class See Also Send Feedback

The RadTickBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTickBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.AnySibling Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.GetProperty Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.GetRectangle Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.Highlight Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.InitializeMappings Method
RadTickBar Class See Also Send Feedback
Initializes the mapping of the RadTickBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.InvokeMethod Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.NextSibling Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.Parent Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.PreviousSibling Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.ScrollToVisible Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadTickBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar Properties
RadTickBar Class See Also Send Feedback

The RadTickBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Ticks | The list of Slider ticks.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the RadTickBar control xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


Ticks Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.Ticks Property
RadTickBar Class See Also Send Feedback
The list of Slider ticks.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<Grid> Ticks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ticks As IList(Of Grid)
Visual C++
public:
property IList<Grid^>^ Ticks {
    IList<Grid^>^ get ();
}

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTickBar..::.XamlTag Property
RadTickBar Class See Also Send Feedback
Get the RadTickBar control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTickBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView Class
Members See Also Send Feedback
Represents the Silverlight RadTileView wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTileView : ItemsControl
Visual Basic (Declaration)
Public Class RadTileView _
    Inherits ItemsControl
Visual C++
public ref class RadTileView : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTileView

See Also

RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


RadTileView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView Members
RadTileView Class Constructors Methods Properties See Also Send Feedback

The RadTileView type exposes the following members.

Constructors

Name | Description
RadTileView | Initializes a new instance of the RadTileView class. Empty contructor [Must have].

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTileView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsItemDraggingEnabled | Gets or sets a value indicating whether the item dragging is enabled.
IsItemsAnimationEnabled | Gets or sets a value indicating whether the item animation is enabled.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxColumns | Gets or sets the max columns, 0 for no maximum. Max rows takes priority over max columns.
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxRows | Gets or sets the max rows, 0 for no maximum. Max rows takes priority over max columns.
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedColumnWidth | Gets or sets the width for the minimzed column on the right or left side.
MinimizedRowHeight | Gets or sets the height for the minimized row on the top or bottom side.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TileViewItems | Gets the list of the RadTileViewItem elements.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTileView. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView Constructor
RadTileView Class See Also Send Feedback
Initializes a new instance of the RadTileView class. Empty contructor [Must have].

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTileView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTileView()

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView Methods
RadTileView Class See Also Send Feedback

The RadTileView type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTileView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.AnySibling Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.GetProperty Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.GetRectangle Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.Highlight Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.InitializeMappings Method
RadTileView Class See Also Send Feedback
Initializes the mapping of the RadTileView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.InvokeMethod Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.NextSibling Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.Parent Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.PreviousSibling Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.ScrollToVisible Method
RadTileView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTileView Class
RadTileView Members
Telerik.WebAii.Controls.Xaml Namespace


RadTileView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView Properties
RadTileView Class See Also Send Feedback

The RadTileView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsItemDraggingEnabled | Gets or sets a value indicating whether the item dragging is enabled.
IsItemsAnimationEnabled | Gets or sets a value indicating whether the item animation is enabled.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxColumns | Gets or sets the max columns, 0 for no maximum. Max rows takes priority over max columns.
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxRows | Gets or sets the max rows, 0 for no maximum. Max rows takes priority over max columns.
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedColumnWidth | Gets or sets the width for the minimzed column on the right or left side.
MinimizedRowHeight | Gets or sets the height for the minimized row on the top or bottom side.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TileViewItems | Gets the list of the RadTileViewItem elements.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTileView. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


IsItemDraggingEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.IsItemDraggingEnabled Property
RadTileView Class See Also Send Feedback
Gets or sets a value indicating whether the item dragging is enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsItemDraggingEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsItemDraggingEnabled As Boolean
Visual C++
public:
property bool IsItemDraggingEnabled {
    bool get ();
    void set (bool value);
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


IsItemsAnimationEnabled Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.IsItemsAnimationEnabled Property
RadTileView Class See Also Send Feedback
Gets or sets a value indicating whether the item animation is enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsItemsAnimationEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsItemsAnimationEnabled As Boolean
Visual C++
public:
property bool IsItemsAnimationEnabled {
    bool get ();
    void set (bool value);
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


MaxColumns Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.MaxColumns Property
RadTileView Class See Also Send Feedback
Gets or sets the max columns, 0 for no maximum. Max rows takes priority over max columns.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MaxColumns { get; set; }
Visual Basic (Declaration)
Public Property MaxColumns As Integer
Visual C++
public:
property int MaxColumns {
    int get ();
    void set (int value);
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


MaxRows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.MaxRows Property
RadTileView Class See Also Send Feedback
Gets or sets the max rows, 0 for no maximum. Max rows takes priority over max columns.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int MaxRows { get; set; }
Visual Basic (Declaration)
Public Property MaxRows As Integer
Visual C++
public:
property int MaxRows {
    int get ();
    void set (int value);
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedColumnWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.MinimizedColumnWidth Property
RadTileView Class See Also Send Feedback
Gets or sets the width for the minimzed column on the right or left side.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double MinimizedColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property MinimizedColumnWidth As Double
Visual C++
public:
property double MinimizedColumnWidth {
    double get ();
    void set (double value);
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedRowHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.MinimizedRowHeight Property
RadTileView Class See Also Send Feedback
Gets or sets the height for the minimized row on the top or bottom side.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double MinimizedRowHeight { get; set; }
Visual Basic (Declaration)
Public Property MinimizedRowHeight As Double
Visual C++
public:
property double MinimizedRowHeight {
    double get ();
    void set (double value);
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


TileViewItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.TileViewItems Property
RadTileView Class See Also Send Feedback
Gets the list of the RadTileViewItem elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTileViewItem> TileViewItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property TileViewItems As IList(Of RadTileViewItem)
Visual C++
public:
property IList<RadTileViewItem^>^ TileViewItems {
    IList<RadTileViewItem^>^ get ();
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileView..::.XamlTag Property
RadTileView Class See Also Send Feedback
Get the xaml tag of RadTileView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTileView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileViewItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem Class
Members See Also Send Feedback
Represents the Silverlight RadTileViewItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTileViewItem : ContentControl
Visual Basic (Declaration)
Public Class RadTileViewItem _
    Inherits ContentControl
Visual C++
public ref class RadTileViewItem : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadTileViewItem

See Also

RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadTileViewItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem Members
RadTileViewItem Class Constructors Methods Properties See Also Send Feedback

The RadTileViewItem type exposes the following members.

Constructors

Name | Description
RadTileViewItem | Initializes a new instance of the RadTileViewItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TileViewItemKey control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleState | Selects the tab by clicking on it and update the parent control.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderText | Get the item text in the header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMaximized | Get whether the item is maximized.
IsMinimized | Get whether the item is minimized.
IsRestored | Get whether the item is restored.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedHeight | Gets or sets the minimized height of the item.
MinimizedWidth | Gets or sets the minimized width of the item.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
ToggleStateButton | Get the toggle button changing the state.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of TileViewItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileViewItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem Constructor
RadTileViewItem Class See Also Send Feedback
Initializes a new instance of the RadTileViewItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTileViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTileViewItem()

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileViewItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem Methods
RadTileViewItem Class See Also Send Feedback

The RadTileViewItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TileViewItemKey control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleState | Selects the tab by clicking on it and update the parent control.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.AnySibling Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.GetProperty Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.GetRectangle Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.Highlight Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.InitializeMappings Method
RadTileViewItem Class See Also Send Feedback
Initializes the mapping of the TileViewItemKey control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.InvokeMethod Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.NextSibling Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.Parent Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.PreviousSibling Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.ScrollToVisible Method
RadTileViewItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
RadTileViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


ToggleState Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.ToggleState Method
RadTileViewItem Class See Also Send Feedback
Selects the tab by clicking on it and update the parent control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleState()
Visual Basic (Declaration)
Public Sub ToggleState
Visual C++
public:
void ToggleState()

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTileViewItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem Properties
RadTileViewItem Class See Also Send Feedback

The RadTileViewItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderText | Get the item text in the header.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMaximized | Get whether the item is maximized.
IsMinimized | Get whether the item is minimized.
IsRestored | Get whether the item is restored.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the item index.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinimizedHeight | Gets or sets the minimized height of the item.
MinimizedWidth | Gets or sets the minimized width of the item.
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
ToggleStateButton | Get the toggle button changing the state.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of TileViewItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.HeaderText Property
RadTileViewItem Class See Also Send Feedback
Get the item text in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsMaximized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.IsMaximized Property
RadTileViewItem Class See Also Send Feedback
Get whether the item is maximized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMaximized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMaximized As Boolean
Visual C++
public:
property bool IsMaximized {
    bool get ();
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsMinimized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.IsMinimized Property
RadTileViewItem Class See Also Send Feedback
Get whether the item is minimized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMinimized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMinimized As Boolean
Visual C++
public:
property bool IsMinimized {
    bool get ();
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsRestored Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.IsRestored Property
RadTileViewItem Class See Also Send Feedback
Get whether the item is restored.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsRestored { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRestored As Boolean
Visual C++
public:
property bool IsRestored {
    bool get ();
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.ItemIndex Property
RadTileViewItem Class See Also Send Feedback
Get the item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.MinimizedHeight Property
RadTileViewItem Class See Also Send Feedback
Gets or sets the minimized height of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double MinimizedHeight { get; set; }
Visual Basic (Declaration)
Public Property MinimizedHeight As Double
Visual C++
public:
property double MinimizedHeight {
    double get ();
    void set (double value);
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizedWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.MinimizedWidth Property
RadTileViewItem Class See Also Send Feedback
Gets or sets the minimized width of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double MinimizedWidth { get; set; }
Visual Basic (Declaration)
Public Property MinimizedWidth As Double
Visual C++
public:
property double MinimizedWidth {
    double get ();
    void set (double value);
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleStateButton Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.ToggleStateButton Property
RadTileViewItem Class See Also Send Feedback
Get the toggle button changing the state.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToggleButton ToggleStateButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToggleStateButton As ToggleButton
Visual C++
public:
property ToggleButton^ ToggleStateButton {
    ToggleButton^ get ();
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTileViewItem..::.XamlTag Property
RadTileViewItem Class See Also Send Feedback
Get the xaml tag of TileViewItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTileViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTimePicker Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Class
Members See Also Send Feedback
Represents the RadTimePicker for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTimePicker : Control
Visual Basic (Declaration)
Public Class RadTimePicker _
    Inherits Control
Visual C++
public ref class RadTimePicker : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadTimePicker

See Also

RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


RadTimePicker Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Members
RadTimePicker Class Constructors Methods Properties See Also Send Feedback

The RadTimePicker type exposes the following members.

Constructors

Name | Description
RadTimePicker | Initializes a new instance of the RadTimePicker class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTimePicker control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the clock button to select time.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TypeText | Simulates user typing in the TimePicker input box and leaving the input control via 'Tab' key press.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Clock | Gets the clock control from the popup if open; returns 'null' otherwise.
Culture | Gets the TimePicker set culture. Obtains the value from the TimePicker control via automation property.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndTime | Gets the TimePicker end time. Obtains the value from the TimePicker control via automation property.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsFocused | Gets whether the TimePicker is focused. Obtains the value from the TimePicker control via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the time picker clock popup is opened. Returns 'false' also if the clock popup cannot be identified with the current control template.
IsReadOnly | Gets whether the TimePicker is read only. Obtains the value from the TimePicker control via automation property.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedTime | Gets the TimePicker selected time. Obtains the value from the TimePicker control via automation property.
StartTime | Gets the TimePicker start time. Obtains the value from the TimePicker control via automation property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Gets the text of the TimePicker input box.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeInterval | Gets the TimePicker time interval. Obtains the value from the TimePicker control via automation property.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTimePicker control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadTimePicker Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Constructor
RadTimePicker Class See Also Send Feedback
Initializes a new instance of the RadTimePicker class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTimePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTimePicker()

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadTimePicker Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Methods
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTimePicker control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the clock button to select time.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
TypeText | Simulates user typing in the TimePicker input box and leaving the input control via 'Tab' key press.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.AnySibling Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.GetProperty Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.GetRectangle Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Highlight Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.InitializeMappings Method
RadTimePicker Class See Also Send Feedback
Initializes the mapping of the RadTimePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.InvokeMethod Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.MouseClick Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType) | Triggers mouse click on the text box from the given type.
MouseClick(MouseClickType, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.MouseClick Method (MouseClickType)
RadTimePicker Class See Also Send Feedback
Triggers mouse click on the text box from the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The type of the mouse click.

See Also

RadTimePicker Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.MouseClick Method (MouseClickType, Int32)
RadTimePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.

See Also

RadTimePicker Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


MouseClick Method (MouseClickType, Int32, Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.MouseClick Method (MouseClickType, Int32, Boolean)
RadTimePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::.MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.

See Also

RadTimePicker Class
MouseClick Overload
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.NextSibling Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Parent Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.PreviousSibling Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.ScrollToVisible Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Xaml Namespace


SelectTime Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.SelectTime Method
RadTimePicker Class See Also Send Feedback
Simulates user clicking on the clock button to select time.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void SelectTime(
    string buttonText
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    buttonText As String _
)
Visual C++
public:
void SelectTime(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text of the button to be clicked.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the clock contains no button with the given text.
System..::.InvalidOperationException | Thrown when the clock popup is not open.

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


TogglePopup Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.TogglePopup Method
RadTimePicker Class See Also Send Feedback
Simulates user clicking on the calendar image to open/close the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TogglePopup()
Visual Basic (Declaration)
Public Sub TogglePopup
Visual C++
public:
void TogglePopup()

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


TypeText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.TypeText Method
RadTimePicker Class See Also Send Feedback
Simulates user typing in the TimePicker input box and leaving the input control via 'Tab' key press.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void TypeText(
    string newText,
    int keyPressTime
)
Visual Basic (Declaration)
Public Sub TypeText ( _
    newText As String, _
    keyPressTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ newText,
    int keyPressTime
)

Parameters

newText
Type: System..::.String
The text to be typed into the TimePicker input box.
keyPressTime
Type: System..::.Int32
The key press time in milliseconds.

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


WaitPopupAnimation Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.WaitPopupAnimation Method
RadTimePicker Class See Also Send Feedback
Useful upon any open/close action of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitPopupAnimation(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupAnimation ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupAnimation(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadTimePicker Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker Properties
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Clock | Gets the clock control from the popup if open; returns 'null' otherwise.
Culture | Gets the TimePicker set culture. Obtains the value from the TimePicker control via automation property.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndTime | Gets the TimePicker end time. Obtains the value from the TimePicker control via automation property.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsFocused | Gets whether the TimePicker is focused. Obtains the value from the TimePicker control via automation property.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the time picker clock popup is opened. Returns 'false' also if the clock popup cannot be identified with the current control template.
IsReadOnly | Gets whether the TimePicker is read only. Obtains the value from the TimePicker control via automation property.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SelectedTime | Gets the TimePicker selected time. Obtains the value from the TimePicker control via automation property.
StartTime | Gets the TimePicker start time. Obtains the value from the TimePicker control via automation property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Gets the text of the TimePicker input box.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TimeInterval | Gets the TimePicker time interval. Obtains the value from the TimePicker control via automation property.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTimePicker control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


Clock Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Clock Property
RadTimePicker Class See Also Send Feedback
Gets the clock control from the popup if open; returns 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadClock Clock { get; }
Visual Basic (Declaration)
Public ReadOnly Property Clock As RadClock
Visual C++
public:
property RadClock^ Clock {
    RadClock^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


Culture Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Culture Property
RadTimePicker Class See Also Send Feedback
Gets the TimePicker set culture. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Culture { get; }
Visual Basic (Declaration)
Public ReadOnly Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


EndTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.EndTime Property
RadTimePicker Class See Also Send Feedback
Gets the TimePicker end time. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan EndTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndTime As TimeSpan
Visual C++
public:
property TimeSpan^ EndTime {
    TimeSpan^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsFocused Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.IsFocused Property
RadTimePicker Class See Also Send Feedback
Gets whether the TimePicker is focused. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As String
Visual C++
public:
property String^ IsFocused {
    String^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.IsPopupOpen Property
RadTimePicker Class See Also Send Feedback
Get whether the time picker clock popup is opened. Returns 'false' also if the clock popup cannot be identified with the current control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.IsReadOnly Property
RadTimePicker Class See Also Send Feedback
Gets whether the TimePicker is read only. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


SelectedTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.SelectedTime Property
RadTimePicker Class See Also Send Feedback
Gets the TimePicker selected time. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan SelectedTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedTime As TimeSpan
Visual C++
public:
property TimeSpan^ SelectedTime {
    TimeSpan^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


StartTime Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.StartTime Property
RadTimePicker Class See Also Send Feedback
Gets the TimePicker start time. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan StartTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTime As TimeSpan
Visual C++
public:
property TimeSpan^ StartTime {
    TimeSpan^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.Text Property
RadTimePicker Class See Also Send Feedback
Gets the text of the TimePicker input box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


TimeInterval Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.TimeInterval Property
RadTimePicker Class See Also Send Feedback
Gets the TimePicker time interval. Obtains the value from the TimePicker control via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSpan TimeInterval { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeInterval As TimeSpan
Visual C++
public:
property TimeSpan^ TimeInterval {
    TimeSpan^ get ();
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTimePicker..::.XamlTag Property
RadTimePicker Class See Also Send Feedback
Get the xaml tag of RadTimePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Xaml Namespace


RadToggleButton Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton Class
Members See Also Send Feedback
Represents the RadToggleButton for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToggleButton : ToggleButton
Visual Basic (Declaration)
Public Class RadToggleButton _
    Inherits ToggleButton
Visual C++
public ref class RadToggleButton : public ToggleButton

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ToggleButton
Telerik.WebAii.Controls.Xaml..::.RadToggleButton

See Also

RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadToggleButton Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton Members
RadToggleButton Class Constructors Methods Properties See Also Send Feedback

The RadToggleButton type exposes the following members.

Constructors

Name | Description
RadToggleButton | Initializes a new instance of the RadToggleButton class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ToggleButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadToggleButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ToggleButton.)
BorderBrush | (Inherited from ToggleButton.)
BorderThickness | (Inherited from ToggleButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from ToggleButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ToggleButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ToggleButton.)
FontSize | (Inherited from ToggleButton.)
FontStretch | (Inherited from ToggleButton.)
FontStyle | (Inherited from ToggleButton.)
FontWeight | (Inherited from ToggleButton.)
Foreground | (Inherited from ToggleButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ToggleButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ToggleButton.)
IsFocused | (Inherited from ToggleButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from ToggleButton.)
IsPressed | (Inherited from ToggleButton.)
IsTabStop | (Inherited from ToggleButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from ToggleButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ToggleButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ToggleButton.)
TabNavigation | (Inherited from ToggleButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ToggleButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToggleButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadToggleButton Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton Constructor
RadToggleButton Class See Also Send Feedback
Initializes a new instance of the RadToggleButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToggleButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToggleButton()

See Also

RadToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadToggleButton Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton Methods
RadToggleButton Class See Also Send Feedback

The RadToggleButton type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ToggleButton.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadToggleButton control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.AnySibling Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.GetProperty Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.GetRectangle Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.Highlight Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.InitializeMappings Method
RadToggleButton Class See Also Send Feedback
Initializes the mapping of the RadToggleButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.InvokeMethod Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.NextSibling Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.Parent Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.PreviousSibling Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.ScrollToVisible Method
RadToggleButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
RadToggleButton Members
Telerik.WebAii.Controls.Xaml Namespace


RadToggleButton Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton Properties
RadToggleButton Class See Also Send Feedback

The RadToggleButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ToggleButton.)
BorderBrush | (Inherited from ToggleButton.)
BorderThickness | (Inherited from ToggleButton.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
ClickMode | (Inherited from ToggleButton.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ToggleButton.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ToggleButton.)
FontSize | (Inherited from ToggleButton.)
FontStretch | (Inherited from ToggleButton.)
FontStyle | (Inherited from ToggleButton.)
FontWeight | (Inherited from ToggleButton.)
Foreground | (Inherited from ToggleButton.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ToggleButton.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ToggleButton.)
IsFocused | (Inherited from ToggleButton.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from ToggleButton.)
IsPressed | (Inherited from ToggleButton.)
IsTabStop | (Inherited from ToggleButton.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | (Inherited from ToggleButton.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ToggleButton.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ToggleButton.)
TabNavigation | (Inherited from ToggleButton.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ToggleButton.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToggleButton control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToggleButton..::.XamlTag Property
RadToggleButton Class See Also Send Feedback
Get the xaml tag of RadToggleButton control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadToggleButton Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Class
Members See Also Send Feedback
Represents the Silverlight RadToolBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBar : ItemsControl
Visual Basic (Declaration)
Public Class RadToolBar _
    Inherits ItemsControl
Visual C++
public ref class RadToolBar : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadToolBar
Telerik.WebAii.Controls.Xaml..::.QuickAccessToolBar

See Also

RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


RadToolBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Members
RadToolBar Class Constructors Methods Properties See Also Send Feedback

The RadToolBar type exposes the following members.

Constructors

Name | Description
RadToolBar | Initializes a new instance of the RadToolBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadToolBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleOverflowDropDown | Opens/closes the overflow drop down.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
Band | Gets a value indicating on wich Tray's Band the toolbar should be positioned.
BandIndex | Gets or sets a value indicating the order in a Tray's Band via automation property.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HasOverflowItems | Gets a value indicating whether the Overflow area contains items via automation property.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsOverflowPopupOpen | Get whether the overflow popup is open.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of toolbar items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the toolbar orientation.
OverflowItems | Get the list of overflow items.
OverflowPopup | Gets the popup holding the overflow items.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Constructor
RadToolBar Class See Also Send Feedback
Initializes a new instance of the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBar()

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Methods
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadToolBar control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleOverflowDropDown | Opens/closes the overflow drop down.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.AnySibling Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.AssignReference Method
RadToolBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadToolBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.GetProperty Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.GetRectangle Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Highlight Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.InitializeMappings Method
RadToolBar Class See Also Send Feedback
Initializes the mapping of the RadToolBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.InvokeMethod Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.NextSibling Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Parent Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.PreviousSibling Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.ScrollToVisible Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Xaml Namespace


ToggleOverflowDropDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.ToggleOverflowDropDown Method
RadToolBar Class See Also Send Feedback
Opens/closes the overflow drop down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public virtual void ToggleOverflowDropDown()
Visual Basic (Declaration)
Public Overridable Sub ToggleOverflowDropDown
Visual C++
public:
virtual void ToggleOverflowDropDown()

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar Properties
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
Band | Gets a value indicating on wich Tray's Band the toolbar should be positioned.
BandIndex | Gets or sets a value indicating the order in a Tray's Band via automation property.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HasOverflowItems | Gets a value indicating whether the Overflow area contains items via automation property.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsOverflowPopupOpen | Get whether the overflow popup is open.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of toolbar items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the toolbar orientation.
OverflowItems | Get the list of overflow items.
OverflowPopup | Gets the popup holding the overflow items.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBar control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


Band Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Band Property
RadToolBar Class See Also Send Feedback
Gets a value indicating on wich Tray's Band the toolbar should be positioned.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Band { get; }
Visual Basic (Declaration)
Public ReadOnly Property Band As Integer
Visual C++
public:
property int Band {
    int get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


BandIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.BandIndex Property
RadToolBar Class See Also Send Feedback
Gets or sets a value indicating the order in a Tray's Band via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int BandIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property BandIndex As Integer
Visual C++
public:
property int BandIndex {
    int get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


HasOverflowItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.HasOverflowItems Property
RadToolBar Class See Also Send Feedback
Gets a value indicating whether the Overflow area contains items via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HasOverflowItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasOverflowItems As Boolean
Visual C++
public:
property bool HasOverflowItems {
    bool get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


IsOverflowPopupOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.IsOverflowPopupOpen Property
RadToolBar Class See Also Send Feedback
Get whether the overflow popup is open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsOverflowPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOverflowPopupOpen As Boolean
Visual C++
public:
property bool IsOverflowPopupOpen {
    bool get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Items Property
RadToolBar Class See Also Send Feedback
Get the list of toolbar items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<FrameworkElement> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of FrameworkElement)
Visual C++
public:
property IList<FrameworkElement^>^ Items {
    IList<FrameworkElement^>^ get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.Orientation Property
RadToolBar Class See Also Send Feedback
Get or set the toolbar orientation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


OverflowItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.OverflowItems Property
RadToolBar Class See Also Send Feedback
Get the list of overflow items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<FrameworkElement> OverflowItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowItems As IList(Of FrameworkElement)
Visual C++
public:
property IList<FrameworkElement^>^ OverflowItems {
    IList<FrameworkElement^>^ get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


OverflowPopup Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.OverflowPopup Property
RadToolBar Class See Also Send Feedback
Gets the popup holding the overflow items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected Popup OverflowPopup { get; }
Visual Basic (Declaration)
Protected ReadOnly Property OverflowPopup As Popup
Visual C++
protected:
property Popup^ OverflowPopup {
    Popup^ get ();
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBar..::.XamlTag Property
RadToolBar Class See Also Send Feedback
Get the xaml tag of RadToolBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadToolBar Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBarTray Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray Class
Members See Also Send Feedback
Represents the Silverlight RadToolBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadToolBarTray : ItemsControl
Visual Basic (Declaration)
Public Class RadToolBarTray _
    Inherits ItemsControl
Visual C++
public ref class RadToolBarTray : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadToolBarTray

See Also

RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


RadToolBarTray Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray Members
RadToolBarTray Class Constructors Methods Properties See Also Send Feedback

The RadToolBarTray type exposes the following members.

Constructors

Name | Description
RadToolBarTray | Initializes a new instance of the RadToolBarTray class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadToolBarTray control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsLocked | Gets whether the tray is locked via automation property.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the RadToolBar items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the toolbar tray orientation.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBarTray control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBarTray Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray Constructor
RadToolBarTray Class See Also Send Feedback
Initializes a new instance of the RadToolBarTray class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadToolBarTray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBarTray()

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


RadToolBarTray Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray Methods
RadToolBarTray Class See Also Send Feedback

The RadToolBarTray type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadToolBarTray control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.AnySibling Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.AssignReference Method
RadToolBarTray Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference of the element.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.GetProperty Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.GetRectangle Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.Highlight Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.InitializeMappings Method
RadToolBarTray Class See Also Send Feedback
Initializes the mapping of the RadToolBarTray control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.InvokeMethod Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.NextSibling Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.Parent Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.PreviousSibling Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.ScrollToVisible Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members
Telerik.WebAii.Controls.Xaml Namespace


RadToolBarTray Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray Properties
RadToolBarTray Class See Also Send Feedback

The RadToolBarTray type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsLocked | Gets whether the tray is locked via automation property.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Gets the list of the RadToolBar items.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Orientation | Get or set the toolbar tray orientation.
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBarTray control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


IsLocked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.IsLocked Property
RadToolBarTray Class See Also Send Feedback
Gets whether the tray is locked via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsLocked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
}

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.Items Property
RadToolBarTray Class See Also Send Feedback
Gets the list of the RadToolBar items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadToolBar> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadToolBar)
Visual C++
public:
property IList<RadToolBar^>^ Items {
    IList<RadToolBar^>^ get ();
}

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


Orientation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.Orientation Property
RadToolBarTray Class See Also Send Feedback
Get or set the toolbar tray orientation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadToolBarTray..::.XamlTag Property
RadToolBarTray Class See Also Send Feedback
Get the xaml tag of RadToolBarTray control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadToolBarTray Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView Class
Members See Also Send Feedback
Represents the Silverlight RadTreeListView control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTreeListView : ItemsControl
Visual Basic (Declaration)
Public Class RadTreeListView _
    Inherits ItemsControl
Visual C++
public ref class RadTreeListView : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTreeListView

See Also

RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView Members
RadTreeListView Class Constructors Methods Properties See Also Send Feedback

The RadTreeListView type exposes the following members.

Constructors

Name | Description
RadTreeListView | Initializes a new instance of the RadTreeListView class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTreeListView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the list of the root columns.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TreeListItems | Gets the list of the root RadTreeListViewItem.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTreeListView. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView Constructor
RadTreeListView Class See Also Send Feedback
Initializes a new instance of the RadTreeListView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeListView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeListView()

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView Methods
RadTreeListView Class See Also Send Feedback

The RadTreeListView type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTreeListView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.AnySibling Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.AssignReference Method
RadTreeListView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadTreeListView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.GetProperty Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.GetRectangle Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.Highlight Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.InitializeMappings Method
RadTreeListView Class See Also Send Feedback
Initializes the mapping of the RadTreeListView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.InvokeMethod Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.NextSibling Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.Parent Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.PreviousSibling Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.ScrollToVisible Method
RadTreeListView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
RadTreeListView Members
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView Properties
RadTreeListView Class See Also Send Feedback

The RadTreeListView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the list of the root columns.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TreeListItems | Gets the list of the root RadTreeListViewItem.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTreeListView. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


Columns Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.Columns Property
RadTreeListView Class See Also Send Feedback
Gets the list of the root columns.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadColumn> Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As IList(Of RadColumn)
Visual C++
public:
property IList<RadColumn^>^ Columns {
    IList<RadColumn^>^ get ();
}

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.TreeListItems Property
RadTreeListView Class See Also Send Feedback
Gets the list of the root RadTreeListViewItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeListViewItem> TreeListItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property TreeListItems As IList(Of RadTreeListViewItem)
Visual C++
public:
property IList<RadTreeListViewItem^>^ TreeListItems {
    IList<RadTreeListViewItem^>^ get ();
}

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListView..::.XamlTag Property
RadTreeListView Class See Also Send Feedback
Get the xaml tag of RadTreeListView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTreeListView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListViewItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem Class
Members See Also Send Feedback
Represents the Silverlight RadTreeViewItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTreeListViewItem : RadTreeViewItem
Visual Basic (Declaration)
Public Class RadTreeListViewItem _
    Inherits RadTreeViewItem
Visual C++
public ref class RadTreeListViewItem : public RadTreeViewItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTreeViewItem
Telerik.WebAii.Controls.Xaml..::.RadTreeListViewItem

See Also

RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListViewItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem Members
RadTreeListViewItem Class Constructors Methods Properties See Also Send Feedback

The RadTreeListViewItem type exposes the following members.

Constructors

Name | Description
RadTreeListViewItem | Initializes a new instance of the RadTreeListViewItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides RadTreeViewItem..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Check | Check the node check box or radio button if enabled. (Inherited from RadTreeViewItem.)
CheckNode | Check a sub node with the given index and get back with updated (parent) node. (Inherited from RadTreeViewItem.)
Collapse | Collapse this node. (Inherited from RadTreeViewItem.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToElement | Drag the current node to the target element. (Inherited from RadTreeViewItem.)
DragToNode | Drag the current node to the target one. (Inherited from RadTreeViewItem.)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this node. (Inherited from RadTreeViewItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderRightClick | Simulates user right-click on the item header. Useful in integration with RadContextMenu. (Inherited from RadTreeViewItem.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TreeListViewItem control. (Overrides RadTreeViewItem..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Selects the current treeview list item instance. (Overrides RadTreeViewItem..::.Select()()().)
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this item instance. (Overrides RadTreeViewItem..::.Toggle()()().)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCells | Gets the list of the header cells.
HeaderRow | Get the header Grid holding the node text and the expander toggle button. (Inherited from RadTreeViewItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsAlternate | Gets or sets a value indicating whether the item is an alternate item.
IsChecked | Get whether the node check box or radio button is checked. (Inherited from RadTreeViewItem.)
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Gets whether the TreeViewItem is expanded. (Inherited from RadTreeViewItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the TreeViewItem is selected. (Inherited from RadTreeViewItem.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!). (Inherited from RadTreeViewItem.)
ItemExpander | Gets the item expander toggle button. (Inherited from RadTreeViewItem.)
ItemIndex | Get the index of the item. (Inherited from RadTreeViewItem.)
ItemsHost | Gets the items presenter element holding the sub items. (Inherited from RadTreeViewItem.)
ItemText | Get the item text. (Inherited from RadTreeViewItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Nodes | Get the list of RadTreeViewItem children. (Inherited from RadTreeViewItem.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TreeListItems | Get the list of RadTreeListViewItem children.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the tree view item control xaml tag. (Overrides RadTreeViewItem..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListViewItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem Constructor
RadTreeListViewItem Class See Also Send Feedback
Initializes a new instance of the RadTreeListViewItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeListViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeListViewItem()

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListViewItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem Methods
RadTreeListViewItem Class See Also Send Feedback

The RadTreeListViewItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides RadTreeViewItem..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Check | Check the node check box or radio button if enabled. (Inherited from RadTreeViewItem.)
CheckNode | Check a sub node with the given index and get back with updated (parent) node. (Inherited from RadTreeViewItem.)
Collapse | Collapse this node. (Inherited from RadTreeViewItem.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToElement | Drag the current node to the target element. (Inherited from RadTreeViewItem.)
DragToNode | Drag the current node to the target one. (Inherited from RadTreeViewItem.)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this node. (Inherited from RadTreeViewItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderRightClick | Simulates user right-click on the item header. Useful in integration with RadContextMenu. (Inherited from RadTreeViewItem.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the TreeListViewItem control. (Overrides RadTreeViewItem..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Selects the current treeview list item instance. (Overrides RadTreeViewItem..::.Select()()().)
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this item instance. (Overrides RadTreeViewItem..::.Toggle()()().)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.AnySibling Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.AssignReference Method
RadTreeListViewItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference of the element.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.GetProperty Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.GetRectangle Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.Highlight Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.InitializeMappings Method
RadTreeListViewItem Class See Also Send Feedback
Initializes the mapping of the TreeListViewItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.InvokeMethod Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.NextSibling Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.Parent Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.PreviousSibling Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.ScrollToVisible Method
RadTreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
RadTreeListViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.Select Method
RadTreeListViewItem Class See Also Send Feedback
Selects the current treeview list item instance.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Select()
Visual Basic (Declaration)
Public Overrides Sub Select
Visual C++
public:
virtual void Select() override

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.Toggle Method
RadTreeListViewItem Class See Also Send Feedback
Toggles (expands/collapses) this item instance.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void Toggle()
Visual Basic (Declaration)
Public Overrides Sub Toggle
Visual C++
public:
virtual void Toggle() override

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeListViewItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem Properties
RadTreeListViewItem Class See Also Send Feedback

The RadTreeListViewItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCells | Gets the list of the header cells.
HeaderRow | Get the header Grid holding the node text and the expander toggle button. (Inherited from RadTreeViewItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsAlternate | Gets or sets a value indicating whether the item is an alternate item.
IsChecked | Get whether the node check box or radio button is checked. (Inherited from RadTreeViewItem.)
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Gets whether the TreeViewItem is expanded. (Inherited from RadTreeViewItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the TreeViewItem is selected. (Inherited from RadTreeViewItem.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!). (Inherited from RadTreeViewItem.)
ItemExpander | Gets the item expander toggle button. (Inherited from RadTreeViewItem.)
ItemIndex | Get the index of the item. (Inherited from RadTreeViewItem.)
ItemsHost | Gets the items presenter element holding the sub items. (Inherited from RadTreeViewItem.)
ItemText | Get the item text. (Inherited from RadTreeViewItem.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Nodes | Get the list of RadTreeViewItem children. (Inherited from RadTreeViewItem.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TreeListItems | Get the list of RadTreeListViewItem children.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the tree view item control xaml tag. (Overrides RadTreeViewItem..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderCells Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.HeaderCells Property
RadTreeListViewItem Class See Also Send Feedback
Gets the list of the header cells.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadCell> HeaderCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderCells As IList(Of RadCell)
Visual C++
public:
property IList<RadCell^>^ HeaderCells {
    IList<RadCell^>^ get ();
}

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsAlternate Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.IsAlternate Property
RadTreeListViewItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is an alternate item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsAlternate { get; set; }
Visual Basic (Declaration)
Public Property IsAlternate As Boolean
Visual C++
public:
property bool IsAlternate {
    bool get ();
    void set (bool value);
}

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListItems Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.TreeListItems Property
RadTreeListViewItem Class See Also Send Feedback
Get the list of RadTreeListViewItem children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeListViewItem> TreeListItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property TreeListItems As IList(Of RadTreeListViewItem)
Visual C++
public:
property IList<RadTreeListViewItem^>^ TreeListItems {
    IList<RadTreeListViewItem^>^ get ();
}

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeListViewItem..::.XamlTag Property
RadTreeListViewItem Class See Also Send Feedback
Get the tree view item control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTreeListViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeView Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Class
Members See Also Send Feedback
Represents the Silverlight RadTreeView control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTreeView : ItemsControl
Visual Basic (Declaration)
Public Class RadTreeView _
    Inherits ItemsControl
Visual C++
public ref class RadTreeView : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTreeView

See Also

RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


RadTreeView Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Members
RadTreeView Class Constructors Methods Properties See Also Send Feedback

The RadTreeView type exposes the following members.

Constructors

Name | Description
RadTreeView | Initializes a new instance of the RadTreeView class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindNode | Find a node by the given custom predicate.
FindNodeByText | Searches for a node in the tree view by given text.
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTreeView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleNode | Toggle the root node finding it by index.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllNodes | Get the list of all the treeview nodes.
AllSelectedNodes | Get the list of all the treeview selected nodes.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RootNodes | Gets the list of the RadTreeViewItem root nodes.
RootSelectedNodes | Get the list of all the root selected nodes.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTreeView. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeView Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Constructor
RadTreeView Class See Also Send Feedback
Initializes a new instance of the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeView()

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeView Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Methods
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindNode | Find a node by the given custom predicate.
FindNodeByText | Searches for a node in the tree view by given text.
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTreeView control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleNode | Toggle the root node finding it by index.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.AnySibling Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.AssignReference Method
RadTreeView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadTreeView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


FindNode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNode Method
RadTreeView Class See Also Send Feedback
Find a node by the given custom predicate.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeViewItem FindNode(
    Predicate<FrameworkElement> predicate
)
Visual Basic (Declaration)
Public Function FindNode ( _
    predicate As Predicate(Of FrameworkElement) _
) As RadTreeViewItem
Visual C++
public:
RadTreeViewItem^ FindNode(
    Predicate<FrameworkElement^>^ predicate
)

Parameters

predicate
Type: System..::.Predicate <(Of <(FrameworkElement>)>)
The predicate to search by.

Return Value

The node found by the given predicate.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


FindNodeByText Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.FindNodeByText Method
RadTreeView Class See Also Send Feedback
Searches for a node in the tree view by given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeViewItem FindNodeByText(
    string nodeText
)
Visual Basic (Declaration)
Public Function FindNodeByText ( _
    nodeText As String _
) As RadTreeViewItem
Visual C++
public:
RadTreeViewItem^ FindNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::.String
The text of the node to search for.

Return Value

The tree view item matching the given text.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.GetProperty Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.GetRectangle Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.Highlight Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.InitializeMappings Method
RadTreeView Class See Also Send Feedback
Initializes the mapping of the RadTreeView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.InvokeMethod Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.NextSibling Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.Parent Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.PreviousSibling Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.ScrollToVisible Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Xaml Namespace


ToggleNode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.ToggleNode Method
RadTreeView Class See Also Send Feedback
Toggle the root node finding it by index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ToggleNode(
    int index
)
Visual Basic (Declaration)
Public Sub ToggleNode ( _
    index As Integer _
)
Visual C++
public:
void ToggleNode(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the root node which state is going to be changed.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown if the index is out of the sub nodes count range.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeView Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView Properties
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllNodes | Get the list of all the treeview nodes.
AllSelectedNodes | Get the list of all the treeview selected nodes.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RootNodes | Gets the list of the RadTreeViewItem root nodes.
RootSelectedNodes | Get the list of all the root selected nodes.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTreeView. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


AllNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.AllNodes Property
RadTreeView Class See Also Send Feedback
Get the list of all the treeview nodes.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeViewItem> AllNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllNodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ AllNodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


AllSelectedNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.AllSelectedNodes Property
RadTreeView Class See Also Send Feedback
Get the list of all the treeview selected nodes.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeViewItem> AllSelectedNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllSelectedNodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ AllSelectedNodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


RootNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.RootNodes Property
RadTreeView Class See Also Send Feedback
Gets the list of the RadTreeViewItem root nodes.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeViewItem> RootNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootNodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ RootNodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


RootSelectedNodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.RootSelectedNodes Property
RadTreeView Class See Also Send Feedback
Get the list of all the root selected nodes.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeViewItem> RootSelectedNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootSelectedNodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ RootSelectedNodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeView..::.XamlTag Property
RadTreeView Class See Also Send Feedback
Get the xaml tag of RadTreeView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTreeView Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeViewItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem Class
Members See Also Send Feedback
Represents the Silverlight RadTreeViewItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadTreeViewItem : ItemsControl
Visual Basic (Declaration)
Public Class RadTreeViewItem _
    Inherits ItemsControl
Visual C++
public ref class RadTreeViewItem : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadTreeViewItem
Telerik.WebAii.Controls.Xaml..::.RadTreeListViewItem

See Also

RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadTreeViewItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem Members
RadTreeViewItem Class Constructors Methods Properties See Also Send Feedback

The RadTreeViewItem type exposes the following members.

Constructors

Name | Description
RadTreeViewItem | Initializes a new instance of the RadTreeViewItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Check | Check the node check box or radio button if enabled.
CheckNode | Check a sub node with the given index and get back with updated (parent) node.
Collapse | Collapse this node.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToElement | Drag the current node to the target element.
DragToNode | Drag the current node to the target one.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this node.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderRightClick | Simulates user right-click on the item header. Useful in integration with RadContextMenu.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTreeViewItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Select the current tree node.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this node.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderRow | Get the header Grid holding the node text and the expander toggle button.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | Get whether the node check box or radio button is checked.
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Gets whether the TreeViewItem is expanded.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the TreeViewItem is selected.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!).
ItemExpander | Gets the item expander toggle button.
ItemIndex | Get the index of the item.
ItemsHost | Gets the items presenter element holding the sub items.
ItemText | Get the item text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Nodes | Get the list of RadTreeViewItem children.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the tree view item control xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeViewItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem Constructor
RadTreeViewItem Class See Also Send Feedback
Initializes a new instance of the RadTreeViewItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadTreeViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeViewItem()

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeViewItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem Methods
RadTreeViewItem Class See Also Send Feedback

The RadTreeViewItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Check | Check the node check box or radio button if enabled.
CheckNode | Check a sub node with the given index and get back with updated (parent) node.
Collapse | Collapse this node.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToElement | Drag the current node to the target element.
DragToNode | Drag the current node to the target one.
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Expand | Expand this node.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeaderRightClick | Simulates user right-click on the item header. Useful in integration with RadContextMenu.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadTreeViewItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Select the current tree node.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this node.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.AnySibling Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.AssignReference Method
RadTreeViewItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference
The automation reference of the element.

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Check Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Check Method
RadTreeViewItem Class See Also Send Feedback
Check the node check box or radio button if enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Check()
Visual Basic (Declaration)
Public Sub Check
Visual C++
public:
void Check()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the TreeView is not configured with 'OptionsElements' setting.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


CheckNode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.CheckNode Method
RadTreeViewItem Class See Also Send Feedback
Check a sub node with the given index and get back with updated (parent) node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void CheckNode(
    int nodeIndex
)
Visual Basic (Declaration)
Public Sub CheckNode ( _
    nodeIndex As Integer _
)
Visual C++
public:
void CheckNode(
    int nodeIndex
)

Parameters

nodeIndex
Type: System..::.Int32
The index of the node to be checked.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Collapse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Collapse Method
RadTreeViewItem Class See Also Send Feedback
Collapse this node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the node is not in expanded state.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


DragToElement Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.DragToElement Method
RadTreeViewItem Class See Also Send Feedback
Drag the current node to the target element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToElement(
    FrameworkElement element
)
Visual Basic (Declaration)
Public Sub DragToElement ( _
    element As FrameworkElement _
)
Visual C++
public:
void DragToElement(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::.FrameworkElement
The target element to drag to.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


DragToNode Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.DragToNode Method
RadTreeViewItem Class See Also Send Feedback
Drag the current node to the target one.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void DragToNode(
    RadTreeViewItem target
)
Visual Basic (Declaration)
Public Sub DragToNode ( _
    target As RadTreeViewItem _
)
Visual C++
public:
void DragToNode(
    RadTreeViewItem^ target
)

Parameters

target
Type: Telerik.WebAii.Controls.Xaml..::.RadTreeViewItem
The target node to drag the current item to.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Expand Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Expand Method
RadTreeViewItem Class See Also Send Feedback
Expand this node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the node is not in collapsed state.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.GetProperty Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.GetRectangle Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


HeaderRightClick Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.HeaderRightClick Method
RadTreeViewItem Class See Also Send Feedback
Simulates user right-click on the item header. Useful in integration with RadContextMenu.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void HeaderRightClick()
Visual Basic (Declaration)
Public Sub HeaderRightClick
Visual C++
public:
void HeaderRightClick()

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Highlight Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.InitializeMappings Method
RadTreeViewItem Class See Also Send Feedback
Initializes the mapping of the RadTreeViewItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.InvokeMethod Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.NextSibling Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Parent Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.PreviousSibling Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.ScrollToVisible Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Select Method
RadTreeViewItem Class See Also Send Feedback
Select the current tree node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public virtual void Select()
Visual Basic (Declaration)
Public Overridable Sub Select
Visual C++
public:
virtual void Select()

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Toggle Method
RadTreeViewItem Class See Also Send Feedback
Toggles (expands/collapses) this node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public virtual void Toggle()
Visual Basic (Declaration)
Public Overridable Sub Toggle
Visual C++
public:
virtual void Toggle()

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadTreeViewItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem Properties
RadTreeViewItem Class See Also Send Feedback

The RadTreeViewItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderRow | Get the header Grid holding the node text and the expander toggle button.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsChecked | Get whether the node check box or radio button is checked.
IsEnabled | (Inherited from ItemsControl.)
IsExpanded | Gets whether the TreeViewItem is expanded.
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsSelected | Gets whether the TreeViewItem is selected.
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
IsThreeState | Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!).
ItemExpander | Gets the item expander toggle button.
ItemIndex | Get the index of the item.
ItemsHost | Gets the items presenter element holding the sub items.
ItemText | Get the item text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Nodes | Get the list of RadTreeViewItem children.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the tree view item control xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderRow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.HeaderRow Property
RadTreeViewItem Class See Also Send Feedback
Get the header Grid holding the node text and the expander toggle button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Grid HeaderRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderRow As Grid
Visual C++
public:
property Grid^ HeaderRow {
    Grid^ get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsChecked Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.IsChecked Property
RadTreeViewItem Class See Also Send Feedback
Get whether the node check box or radio button is checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Nullable<bool> IsChecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsChecked As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> IsChecked {
    Nullable<bool> get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the TreeView is not configured with 'OptionsElements' setting.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsExpanded Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.IsExpanded Property
RadTreeViewItem Class See Also Send Feedback
Gets whether the TreeViewItem is expanded.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.IsSelected Property
RadTreeViewItem Class See Also Send Feedback
Gets whether the TreeViewItem is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsThreeState Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.IsThreeState Property
RadTreeViewItem Class See Also Send Feedback
Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsThreeState { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsThreeState As Boolean
Visual C++
public:
property bool IsThreeState {
    bool get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the TreeView is not configured with 'OptionsElements' setting.

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemExpander Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.ItemExpander Property
RadTreeViewItem Class See Also Send Feedback
Gets the item expander toggle button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected ToggleButton ItemExpander { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ItemExpander As ToggleButton
Visual C++
protected:
property ToggleButton^ ItemExpander {
    ToggleButton^ get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.ItemIndex Property
RadTreeViewItem Class See Also Send Feedback
Get the index of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemsHost Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.ItemsHost Property
RadTreeViewItem Class See Also Send Feedback
Gets the items presenter element holding the sub items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
protected ItemsPresenter ItemsHost { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ItemsHost As ItemsPresenter
Visual C++
protected:
property ItemsPresenter^ ItemsHost {
    ItemsPresenter^ get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.ItemText Property
RadTreeViewItem Class See Also Send Feedback
Get the item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ItemText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


Nodes Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.Nodes Property
RadTreeViewItem Class See Also Send Feedback
Get the list of RadTreeViewItem children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadTreeViewItem> Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ Nodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadTreeViewItem..::.XamlTag Property
RadTreeViewItem Class See Also Send Feedback
Get the tree view item control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTreeViewItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadUniformGrid Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid Class
Members See Also Send Feedback
Represents the RadUniformGrid for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadUniformGrid : Panel
Visual Basic (Declaration)
Public Class RadUniformGrid _
    Inherits Panel
Visual C++
public ref class RadUniformGrid : public Panel

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Panel
Telerik.WebAii.Controls.Xaml..::.RadUniformGrid
Telerik.WebAii.Controls.Xaml..::.CalendarPanel

See Also

RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


RadUniformGrid Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid Members
RadUniformGrid Class Constructors Methods Properties See Also Send Feedback

The RadUniformGrid type exposes the following members.

Constructors

Name | Description
RadUniformGrid | Initializes a new instance of the RadUniformGrid class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadUniformGrid control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the number of columns that are in the grid.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FirstColumn | Gets the number of leading blank cells in the first row of the grid.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Rows | Gets the number of rows that are in the grid.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUniformGrid control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


RadUniformGrid Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid Constructor
RadUniformGrid Class See Also Send Feedback
Initializes a new instance of the RadUniformGrid class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUniformGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUniformGrid()

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


RadUniformGrid Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid Methods
RadUniformGrid Class See Also Send Feedback

The RadUniformGrid type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadUniformGrid control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.AnySibling Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.GetProperty Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.GetRectangle Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.Highlight Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.InitializeMappings Method
RadUniformGrid Class See Also Send Feedback
Initializes the mapping of the RadUniformGrid control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.InvokeMethod Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.NextSibling Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.Parent Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.PreviousSibling Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.ScrollToVisible Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members
Telerik.WebAii.Controls.Xaml Namespace


RadUniformGrid Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid Properties
RadUniformGrid Class See Also Send Feedback

The RadUniformGrid type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Columns | Gets the number of columns that are in the grid.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FirstColumn | Gets the number of leading blank cells in the first row of the grid.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Rows | Gets the number of rows that are in the grid.
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUniformGrid control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


Columns Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.Columns Property
RadUniformGrid Class See Also Send Feedback
Gets the number of columns that are in the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual C++
public:
property int Columns {
    int get ();
}

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


FirstColumn Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.FirstColumn Property
RadUniformGrid Class See Also Send Feedback
Gets the number of leading blank cells in the first row of the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int FirstColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstColumn As Integer
Visual C++
public:
property int FirstColumn {
    int get ();
}

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


Rows Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.Rows Property
RadUniformGrid Class See Also Send Feedback
Gets the number of rows that are in the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As Integer
Visual C++
public:
property int Rows {
    int get ();
}

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUniformGrid..::.XamlTag Property
RadUniformGrid Class See Also Send Feedback
Get the xaml tag of RadUniformGrid control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadUniformGrid Class
Telerik.WebAii.Controls.Xaml Namespace


RadUpload Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Class
Members See Also Send Feedback
Represents the RadUpload for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadUpload : ItemsControl
Visual Basic (Declaration)
Public Class RadUpload _
    Inherits ItemsControl
Visual C++
public ref class RadUpload : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml..::.RadUpload

See Also

RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


RadUpload Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Members
RadUpload Class Constructors Methods Properties See Also Send Feedback

The RadUpload type exposes the following members.

Constructors

Name | Description
RadUpload | Initializes a new instance of the RadUpload class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
Browse | Overloaded.
Cancel | Simulates the user clicking on the 'Cancel' button to cancel the file upload process.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HandleUploadDialog | Handles the Silverlight Upload dialog given a file path to enter for selection.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadUpload control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Pause | Simulates the user clicking on the 'Pause' button to pause the file upload process.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resume | Simulates the user clicking on the 'Resume' button to resume file uploading.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Upload | Simulates the user clicking on the 'Upload' button to trigger manual file upload. Can be called after a file is selected (the browse dialog is handled).
UploadFile | Overloaded.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitForUploadEnd | Overloaded.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of RadUploadItems currently displayed in the upload control.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
ProgressCaptionText | Get the progress caption text of the upload.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TotalPercentText | Get the progress area 'total percent' text.
TotalProgressBar | Get the progress area progress bar control.
TotalSizeText | Get the progress area 'total size' text.
TotalText | Get the progress area 'total' text.
UploadCompleted | Get whether the upload process has completed.
Uploading | Get whether the upload is in progress.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUpload control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


RadUpload Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Constructor
RadUpload Class See Also Send Feedback
Initializes a new instance of the RadUpload class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUpload()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUpload()

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


RadUpload Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Methods
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
Browse | Overloaded.
Cancel | Simulates the user clicking on the 'Cancel' button to cancel the file upload process.
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HandleUploadDialog | Handles the Silverlight Upload dialog given a file path to enter for selection.
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadUpload control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Pause | Simulates the user clicking on the 'Pause' button to pause the file upload process.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Resume | Simulates the user clicking on the 'Resume' button to resume file uploading.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Upload | Simulates the user clicking on the 'Upload' button to trigger manual file upload. Can be called after a file is selected (the browse dialog is handled).
UploadFile | Overloaded.
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
WaitForUploadEnd | Overloaded.

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.AnySibling Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.AssignReference Method
RadUpload Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadUpload.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


Browse Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Browse Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Browse()()() | Simulates the user clicking on the 'Browse' button opening the file browse dialog.
Browse(String) | Simulates the user clicking on the 'Browse' button to open the file browser dialog.

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


Browse Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Browse Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Browse' button opening the file browse dialog.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Browse()
Visual Basic (Declaration)
Public Sub Browse
Visual C++
public:
void Browse()

See Also

RadUpload Class
Browse Overload
Telerik.WebAii.Controls.Xaml Namespace


Browse Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Browse Method (String)
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Browse' button to open the file browser dialog.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Browse(
    string filePath
)
Visual Basic (Declaration)
Public Sub Browse ( _
    filePath As String _
)
Visual C++
public:
void Browse(
    String^ filePath
)

Parameters

filePath
Type: System..::.String

[Missing <param name="filePath"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadUpload.Browse(System.String)"]

See Also

RadUpload Class
Browse Overload
Telerik.WebAii.Controls.Xaml Namespace


Cancel Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Cancel Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Cancel' button to cancel the file upload process.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.GetProperty Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.GetRectangle Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


HandleUploadDialog Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.HandleUploadDialog Method
RadUpload Class See Also Send Feedback
Handles the Silverlight Upload dialog given a file path to enter for selection.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static void HandleUploadDialog(
    string filePath
)
Visual Basic (Declaration)
Public Shared Sub HandleUploadDialog ( _
    filePath As String _
)
Visual C++
public:
static void HandleUploadDialog(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The path of the file to select and upload.

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Highlight Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.InitializeMappings Method
RadUpload Class See Also Send Feedback
Initializes the mapping of the RadUpload control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.InvokeMethod Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.NextSibling Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Parent Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


Pause Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Pause Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Pause' button to pause the file upload process.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Pause()
Visual Basic (Declaration)
Public Sub Pause
Visual C++
public:
void Pause()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the upload has either not started or already completed.

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.PreviousSibling Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


Resume Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Resume Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Resume' button to resume file uploading.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Resume()
Visual Basic (Declaration)
Public Sub Resume
Visual C++
public:
void Resume()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the upload has either not started or already completed.

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ScrollToVisible Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


Upload Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Upload Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Upload' button to trigger manual file upload. Can be called after a file is selected (the browse dialog is handled).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Upload()
Visual Basic (Declaration)
Public Sub Upload
Visual C++
public:
void Upload()

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


UploadFile Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.UploadFile Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
UploadFile(String) | Simulates user browsing, selecting file with the given path and uploading manually (click "Upload"). Handles the Silverlight Upload dialog internally.
UploadFile(String, Boolean) | Simulates user browsing, selecting file with the given path and uploading manually (click "Upload") when isAutomaticUpload='false'. Hansles the Silverlight Upload dialog internally.
UploadFile(String, Boolean, Int32) | Simulates user browsing, selecting file with the given path and uploading manually (click "Upload") when isAutomaticUpload='false'. Hansles the Silverlight Upload dialog internally.

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


UploadFile Method (String)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.UploadFile Method (String)
RadUpload Class See Also Send Feedback
Simulates user browsing, selecting file with the given path and uploading manually (click "Upload"). Handles the Silverlight Upload dialog internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UploadFile(
    string filePath
)
Visual Basic (Declaration)
Public Sub UploadFile ( _
    filePath As String _
)
Visual C++
public:
void UploadFile(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The path of the file to be uploaded.

See Also

RadUpload Class
UploadFile Overload
Telerik.WebAii.Controls.Xaml Namespace


UploadFile Method (String, Boolean)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.UploadFile Method (String, Boolean)
RadUpload Class See Also Send Feedback
Simulates user browsing, selecting file with the given path and uploading manually (click "Upload") when isAutomaticUpload='false'. Hansles the Silverlight Upload dialog internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UploadFile(
    string filePath,
    bool isAutomaticUpload
)
Visual Basic (Declaration)
Public Sub UploadFile ( _
    filePath As String, _
    isAutomaticUpload As Boolean _
)
Visual C++
public:
void UploadFile(
    String^ filePath,
    bool isAutomaticUpload
)

Parameters

filePath
Type: System..::.String
The path of the file to be uploaded.
isAutomaticUpload
Type: System..::.Boolean
Whether the Upload control is configured to upload automatically the file on selection or not.

See Also

RadUpload Class
UploadFile Overload
Telerik.WebAii.Controls.Xaml Namespace


UploadFile Method (String, Boolean, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.UploadFile Method (String, Boolean, Int32)
RadUpload Class See Also Send Feedback
Simulates user browsing, selecting file with the given path and uploading manually (click "Upload") when isAutomaticUpload='false'. Hansles the Silverlight Upload dialog internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void UploadFile(
    string filePath,
    bool isAutomaticUpload,
    int timeout
)
Visual Basic (Declaration)
Public Sub UploadFile ( _
    filePath As String, _
    isAutomaticUpload As Boolean, _
    timeout As Integer _
)
Visual C++
public:
void UploadFile(
    String^ filePath,
    bool isAutomaticUpload,
    int timeout
)

Parameters

filePath
Type: System..::.String
The path of the file to be uploaded.
isAutomaticUpload
Type: System..::.Boolean
Whether the Upload control is configured to upload automatically the file on selection or not.
timeout
Type: System..::.Int32
The upload timeout to wait until process ends.

See Also

RadUpload Class
UploadFile Overload
Telerik.WebAii.Controls.Xaml Namespace


WaitForUploadEnd Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.WaitForUploadEnd Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
WaitForUploadEnd()()() | Waits until the upload process ends.
WaitForUploadEnd(Int32) | Waits until the upload process ends.

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Xaml Namespace


WaitForUploadEnd Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.WaitForUploadEnd Method
RadUpload Class See Also Send Feedback
Waits until the upload process ends.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitForUploadEnd()
Visual Basic (Declaration)
Public Sub WaitForUploadEnd
Visual C++
public:
void WaitForUploadEnd()

See Also

RadUpload Class
WaitForUploadEnd Overload
Telerik.WebAii.Controls.Xaml Namespace


WaitForUploadEnd Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.WaitForUploadEnd Method (Int32)
RadUpload Class See Also Send Feedback
Waits until the upload process ends.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void WaitForUploadEnd(
    int timeout
)
Visual Basic (Declaration)
Public Sub WaitForUploadEnd ( _
    timeout As Integer _
)
Visual C++
public:
void WaitForUploadEnd(
    int timeout
)

Parameters

timeout
Type: System..::.Int32
The upload timeout to wait until process ends.

See Also

RadUpload Class
WaitForUploadEnd Overload
Telerik.WebAii.Controls.Xaml Namespace


RadUpload Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload Properties
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Items | Get the list of RadUploadItems currently displayed in the upload control.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
ProgressCaptionText | Get the progress caption text of the upload.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
TotalPercentText | Get the progress area 'total percent' text.
TotalProgressBar | Get the progress area progress bar control.
TotalSizeText | Get the progress area 'total size' text.
TotalText | Get the progress area 'total' text.
UploadCompleted | Get whether the upload process has completed.
Uploading | Get whether the upload is in progress.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUpload control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


Items Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Items Property
RadUpload Class See Also Send Feedback
Get the list of RadUploadItems currently displayed in the upload control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<RadUploadItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadUploadItem)
Visual C++
public:
property IList<RadUploadItem^>^ Items {
    IList<RadUploadItem^>^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


ProgressCaptionText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.ProgressCaptionText Property
RadUpload Class See Also Send Feedback
Get the progress caption text of the upload.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ProgressCaptionText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressCaptionText As String
Visual C++
public:
property String^ ProgressCaptionText {
    String^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


TotalPercentText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.TotalPercentText Property
RadUpload Class See Also Send Feedback
Get the progress area 'total percent' text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TotalPercentText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalPercentText As String
Visual C++
public:
property String^ TotalPercentText {
    String^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


TotalProgressBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.TotalProgressBar Property
RadUpload Class See Also Send Feedback
Get the progress area progress bar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadProgressBar TotalProgressBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalProgressBar As RadProgressBar
Visual C++
public:
property RadProgressBar^ TotalProgressBar {
    RadProgressBar^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


TotalSizeText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.TotalSizeText Property
RadUpload Class See Also Send Feedback
Get the progress area 'total size' text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TotalSizeText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalSizeText As String
Visual C++
public:
property String^ TotalSizeText {
    String^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


TotalText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.TotalText Property
RadUpload Class See Also Send Feedback
Get the progress area 'total' text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string TotalText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalText As String
Visual C++
public:
property String^ TotalText {
    String^ get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


UploadCompleted Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.UploadCompleted Property
RadUpload Class See Also Send Feedback
Get whether the upload process has completed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool UploadCompleted { get; }
Visual Basic (Declaration)
Public ReadOnly Property UploadCompleted As Boolean
Visual C++
public:
property bool UploadCompleted {
    bool get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


Uploading Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.Uploading Property
RadUpload Class See Also Send Feedback
Get whether the upload is in progress.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool Uploading { get; }
Visual Basic (Declaration)
Public ReadOnly Property Uploading As Boolean
Visual C++
public:
property bool Uploading {
    bool get ();
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUpload..::.XamlTag Property
RadUpload Class See Also Send Feedback
Get the xaml tag of RadUpload control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadUpload Class
Telerik.WebAii.Controls.Xaml Namespace


RadUploadItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem Class
Members See Also Send Feedback
Represents the RadUploadItem for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadUploadItem : Control
Visual Basic (Declaration)
Public Class RadUploadItem _
    Inherits Control
Visual C++
public ref class RadUploadItem : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.RadUploadItem

See Also

RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadUploadItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem Members
RadUploadItem Class Constructors Methods Properties See Also Send Feedback

The RadUploadItem type exposes the following members.

Constructors

Name | Description
RadUploadItem | Initializes a new instance of the RadUploadItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Delete | Simulates user clicking on the delete item icon to delete the item when uploading has not started or has been paused.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadUploadItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
FileName | Get the name of the file represented by this item.
FileSize | Get the size of the file represented by this item.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the upload item index.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
ProgressBar | Get the progress bar of the upload item.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUploadItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadUploadItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem Constructor
RadUploadItem Class See Also Send Feedback
Initializes a new instance of the RadUploadItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUploadItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUploadItem()

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadUploadItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem Methods
RadUploadItem Class See Also Send Feedback

The RadUploadItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Delete | Simulates user clicking on the delete item icon to delete the item when uploading has not started or has been paused.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadUploadItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.AnySibling Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


Delete Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.Delete Method
RadUploadItem Class See Also Send Feedback
Simulates user clicking on the delete item icon to delete the item when uploading has not started or has been paused.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.GetProperty Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.GetRectangle Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.Highlight Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.InitializeMappings Method
RadUploadItem Class See Also Send Feedback
Initializes the mapping of the RadUploadItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.InvokeMethod Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.NextSibling Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.Parent Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.PreviousSibling Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.ScrollToVisible Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members
Telerik.WebAii.Controls.Xaml Namespace


RadUploadItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem Properties
RadUploadItem Class See Also Send Feedback

The RadUploadItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
FileName | Get the name of the file represented by this item.
FileSize | Get the size of the file represented by this item.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
ItemIndex | Get the upload item index.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
ProgressBar | Get the progress bar of the upload item.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUploadItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


FileName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.FileName Property
RadUploadItem Class See Also Send Feedback
Get the name of the file represented by this item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


FileSize Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.FileSize Property
RadUploadItem Class See Also Send Feedback
Get the size of the file represented by this item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string FileSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileSize As String
Visual C++
public:
property String^ FileSize {
    String^ get ();
}

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


ItemIndex Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.ItemIndex Property
RadUploadItem Class See Also Send Feedback
Get the upload item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


ProgressBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.ProgressBar Property
RadUploadItem Class See Also Send Feedback
Get the progress bar of the upload item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadProgressBar ProgressBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressBar As RadProgressBar
Visual C++
public:
property RadProgressBar^ ProgressBar {
    RadProgressBar^ get ();
}

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadUploadItem..::.XamlTag Property
RadUploadItem Class See Also Send Feedback
Get the xaml tag of RadUploadItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadUploadItem Class
Telerik.WebAii.Controls.Xaml Namespace


RadWindow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Class
Members See Also Send Feedback
Represents the Silverlight RadWindow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RadWindow : ContentControl
Visual Basic (Declaration)
Public Class RadWindow _
    Inherits ContentControl
Visual C++
public ref class RadWindow : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.RadWindow
Telerik.WebAii.Controls.Xaml..::.AppointmentItemDialog

See Also

RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


RadWindow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Members
RadWindow Class Constructors Methods Properties See Also Send Feedback

The RadWindow type exposes the following members.

Constructors

Name | Description
RadWindow | Initializes a new instance of the RadWindow class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Closes the window by a 'Close' button Click action.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeightCloseTo | Round the height of the window.
Highlight | Overloaded.
HorizontalCoordinateCloseTo | Round the horizontal coordinates of the window.
InitializeMappings | Initializes the mapping of the RadWindow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Maximize | Maximizes the window by a 'Maximize' button Click action.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes the window by a 'Minimize' button Click action.
MoveBy | Moves the window dragging its header thumb by the given pixels on X and Y coordinates.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeDown | Resizes (Down) the window with given pixels.
ResizeDownLeft | Resizes to down/left the window with given pixels.
ResizeDownRight | Resizes to down/right the window with given pixels.
ResizeLeft | Resizes (Left) the window with given pixels.
ResizeRight | Resizes (Right) the window with given pixels.
ResizeUp | Resizes (UP) the window with given pixels.
ResizeUpLeft | Resizes to up/left the window with given pixels.
ResizeUpRight | Resizes to up/right the window with given pixels.
Restore | Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
VerticalCoordinateCloseTo | Round the vertical coordinates of the window.
WidthCloseTo | Round the width of the window.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanClose | Gets a value indicating whether the current RadWindow can be closed.
CanMove | Gets a value indicating whether the current RadWindow can be moved.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the Window content presenter element.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsActiveWindow | Gets a value indicating whether this instance is active.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMaximized | Gets a value that represents whether the RadWindow is maximized.
IsMinimized | Gets a value that represents whether the RadWindow is minimized.
IsModal | Gets a value that represents whether the RadWindow is modal.
IsOpen | Gets a value representing the current RadWindow open state.
IsPinned | Gets a value indicating whether the current RadWindow is pinned.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page.
LeftOffset | Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RestoreMinimizedLocation | Gets the value determining whether the window preserves its size and location when the state is changed.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the window.
Top | Gets or sets a value that represents the distance between the top of an element and the top of the page.
TopOffset | Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadWindow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


RadWindow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Constructor
RadWindow Class See Also Send Feedback
Initializes a new instance of the RadWindow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadWindow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadWindow()

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


RadWindow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Methods
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Closes the window by a 'Close' button Click action.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
HeightCloseTo | Round the height of the window.
Highlight | Overloaded.
HorizontalCoordinateCloseTo | Round the horizontal coordinates of the window.
InitializeMappings | Initializes the mapping of the RadWindow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Maximize | Maximizes the window by a 'Maximize' button Click action.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes the window by a 'Minimize' button Click action.
MoveBy | Moves the window dragging its header thumb by the given pixels on X and Y coordinates.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ResizeDown | Resizes (Down) the window with given pixels.
ResizeDownLeft | Resizes to down/left the window with given pixels.
ResizeDownRight | Resizes to down/right the window with given pixels.
ResizeLeft | Resizes (Left) the window with given pixels.
ResizeRight | Resizes (Right) the window with given pixels.
ResizeUp | Resizes (UP) the window with given pixels.
ResizeUpLeft | Resizes to up/left the window with given pixels.
ResizeUpRight | Resizes to up/right the window with given pixels.
Restore | Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
VerticalCoordinateCloseTo | Round the vertical coordinates of the window.
WidthCloseTo | Round the width of the window.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.AnySibling Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Close Method
RadWindow Class See Also Send Feedback
Closes the window by a 'Close' button Click action.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.GetProperty Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.GetRectangle Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


HeightCloseTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.HeightCloseTo Method
RadWindow Class See Also Send Feedback
Round the height of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HeightCloseTo(
    double height
)
Visual Basic (Declaration)
Public Function HeightCloseTo ( _
    height As Double _
) As Boolean
Visual C++
public:
bool HeightCloseTo(
    double height
)

Parameters

height
Type: System..::.Double
The current height.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.HeightCloseTo(System.Double)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Highlight Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


HorizontalCoordinateCloseTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.HorizontalCoordinateCloseTo Method
RadWindow Class See Also Send Feedback
Round the horizontal coordinates of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool HorizontalCoordinateCloseTo(
    double horizontalCoordinates
)
Visual Basic (Declaration)
Public Function HorizontalCoordinateCloseTo ( _
    horizontalCoordinates As Double _
) As Boolean
Visual C++
public:
bool HorizontalCoordinateCloseTo(
    double horizontalCoordinates
)

Parameters

horizontalCoordinates
Type: System..::.Double
Passed by user horizontal coordinates.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.HorizontalCoordinateCloseTo(System.Double)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.InitializeMappings Method
RadWindow Class See Also Send Feedback
Initializes the mapping of the RadWindow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.InvokeMethod Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


Maximize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Maximize Method
RadWindow Class See Also Send Feedback
Maximizes the window by a 'Maximize' button Click action.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Maximize()
Visual Basic (Declaration)
Public Sub Maximize
Visual C++
public:
void Maximize()

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Minimize Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Minimize Method
RadWindow Class See Also Send Feedback
Minimizes the window by a 'Minimize' button Click action.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Minimize()
Visual Basic (Declaration)
Public Sub Minimize
Visual C++
public:
void Minimize()

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


MoveBy Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.MoveBy Method
RadWindow Class See Also Send Feedback
Moves the window dragging its header thumb by the given pixels on X and Y coordinates.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveBy(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub MoveBy ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void MoveBy(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
By 'X' pixels left or right.
offsetByY
Type: System..::.Int32
By 'Y' pixels up or down.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.NextSibling Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Parent Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.PreviousSibling Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


ResizeDown Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeDown Method
RadWindow Class See Also Send Feedback
Resizes (Down) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeDown(
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeDown ( _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeDown(
    int offsetByY
)

Parameters

offsetByY
Type: System..::.Int32
The pixels to add on down resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeDownLeft Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeDownLeft Method
RadWindow Class See Also Send Feedback
Resizes to down/left the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeDownLeft(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeDownLeft ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeDownLeft(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on left resizing.
offsetByY
Type: System..::.Int32
The pixels to add on down resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeDownRight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeDownRight Method
RadWindow Class See Also Send Feedback
Resizes to down/right the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeDownRight(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeDownRight ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeDownRight(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on right resizing.
offsetByY
Type: System..::.Int32
The pixels to add on down resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeLeft Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeLeft Method
RadWindow Class See Also Send Feedback
Resizes (Left) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeLeft(
    int offsetByX
)
Visual Basic (Declaration)
Public Sub ResizeLeft ( _
    offsetByX As Integer _
)
Visual C++
public:
void ResizeLeft(
    int offsetByX
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on left resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeRight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeRight Method
RadWindow Class See Also Send Feedback
Resizes (Right) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeRight(
    int offsetByX
)
Visual Basic (Declaration)
Public Sub ResizeRight ( _
    offsetByX As Integer _
)
Visual C++
public:
void ResizeRight(
    int offsetByX
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on right resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeUp Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeUp Method
RadWindow Class See Also Send Feedback
Resizes (UP) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeUp(
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeUp ( _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeUp(
    int offsetByY
)

Parameters

offsetByY
Type: System..::.Int32
The pixels to add on up resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeUpLeft Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeUpLeft Method
RadWindow Class See Also Send Feedback
Resizes to up/left the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeUpLeft(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeUpLeft ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeUpLeft(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on left resizing.
offsetByY
Type: System..::.Int32
The pixels to add on up resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeUpRight Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ResizeUpRight Method
RadWindow Class See Also Send Feedback
Resizes to up/right the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ResizeUpRight(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeUpRight ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeUpRight(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on right resizing.
offsetByY
Type: System..::.Int32
The pixels to add on up resizing.

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Restore Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Restore Method
RadWindow Class See Also Send Feedback
Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Restore()
Visual Basic (Declaration)
Public Sub Restore
Visual C++
public:
void Restore()

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ScrollToVisible Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Xaml Namespace


VerticalCoordinateCloseTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.VerticalCoordinateCloseTo Method
RadWindow Class See Also Send Feedback
Round the vertical coordinates of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool VerticalCoordinateCloseTo(
    double verticalCoordinates
)
Visual Basic (Declaration)
Public Function VerticalCoordinateCloseTo ( _
    verticalCoordinates As Double _
) As Boolean
Visual C++
public:
bool VerticalCoordinateCloseTo(
    double verticalCoordinates
)

Parameters

verticalCoordinates
Type: System..::.Double
Passed by user vertical coordinates.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.VerticalCoordinateCloseTo(System.Double)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


WidthCloseTo Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.WidthCloseTo Method
RadWindow Class See Also Send Feedback
Round the width of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool WidthCloseTo(
    double width
)
Visual Basic (Declaration)
Public Function WidthCloseTo ( _
    width As Double _
) As Boolean
Visual C++
public:
bool WidthCloseTo(
    double width
)

Parameters

width
Type: System..::.Double
The current width.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.WidthCloseTo(System.Double)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


RadWindow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow Properties
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanClose | Gets a value indicating whether the current RadWindow can be closed.
CanMove | Gets a value indicating whether the current RadWindow can be moved.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the Window content presenter element.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsActiveWindow | Gets a value indicating whether this instance is active.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMaximized | Gets a value that represents whether the RadWindow is maximized.
IsMinimized | Gets a value that represents whether the RadWindow is minimized.
IsModal | Gets a value that represents whether the RadWindow is modal.
IsOpen | Gets a value representing the current RadWindow open state.
IsPinned | Gets a value indicating whether the current RadWindow is pinned.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page.
LeftOffset | Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
RestoreMinimizedLocation | Gets the value determining whether the window preserves its size and location when the state is changed.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the title of the window.
Top | Gets or sets a value that represents the distance between the top of an element and the top of the page.
TopOffset | Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadWindow control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


CanClose Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.CanClose Property
RadWindow Class See Also Send Feedback
Gets a value indicating whether the current RadWindow can be closed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanClose { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanClose As Boolean
Visual C++
public:
property bool CanClose {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


CanMove Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.CanMove Property
RadWindow Class See Also Send Feedback
Gets a value indicating whether the current RadWindow can be moved.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool CanMove { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanMove As Boolean
Visual C++
public:
property bool CanMove {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.ContentPresenterElement Property
RadWindow Class See Also Send Feedback
Get the Window content presenter element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


IsActiveWindow Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsActiveWindow Property
RadWindow Class See Also Send Feedback
Gets a value indicating whether this instance is active.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsActiveWindow { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActiveWindow As Boolean
Visual C++
public:
property bool IsActiveWindow {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


IsMaximized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsMaximized Property
RadWindow Class See Also Send Feedback
Gets a value that represents whether the RadWindow is maximized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMaximized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMaximized As Boolean
Visual C++
public:
property bool IsMaximized {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


IsMinimized Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsMinimized Property
RadWindow Class See Also Send Feedback
Gets a value that represents whether the RadWindow is minimized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMinimized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMinimized As Boolean
Visual C++
public:
property bool IsMinimized {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


IsModal Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsModal Property
RadWindow Class See Also Send Feedback
Gets a value that represents whether the RadWindow is modal.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsModal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModal As Boolean
Visual C++
public:
property bool IsModal {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


IsOpen Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsOpen Property
RadWindow Class See Also Send Feedback
Gets a value representing the current RadWindow open state.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOpen As Boolean
Visual C++
public:
property bool IsOpen {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


IsPinned Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.IsPinned Property
RadWindow Class See Also Send Feedback
Gets a value indicating whether the current RadWindow is pinned.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsPinned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPinned As Boolean
Visual C++
public:
property bool IsPinned {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Left Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Left Property
RadWindow Class See Also Send Feedback
Gets or sets a value that represents the distance between the left side of an element and the left side of the page.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Double
Visual C++
public:
property double Left {
    double get ();
    void set (double value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


LeftOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.LeftOffset Property
RadWindow Class See Also Send Feedback
Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double LeftOffset { get; set; }
Visual Basic (Declaration)
Public Property LeftOffset As Double
Visual C++
public:
property double LeftOffset {
    double get ();
    void set (double value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


RestoreMinimizedLocation Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.RestoreMinimizedLocation Property
RadWindow Class See Also Send Feedback
Gets the value determining whether the window preserves its size and location when the state is changed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool RestoreMinimizedLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property RestoreMinimizedLocation As Boolean
Visual C++
public:
property bool RestoreMinimizedLocation {
    bool get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Title Property
RadWindow Class See Also Send Feedback
Get the title of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Top Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.Top Property
RadWindow Class See Also Send Feedback
Gets or sets a value that represents the distance between the top of an element and the top of the page.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Double
Visual C++
public:
property double Top {
    double get ();
    void set (double value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


TopOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.TopOffset Property
RadWindow Class See Also Send Feedback
Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RadWindow..::.XamlTag Property
RadWindow Class See Also Send Feedback
Get the xaml tag of RadWindow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadWindow Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonBarElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames Class
Members See Also Send Feedback
Represents the RadRibbonBar important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class RibbonBarElementNames
Visual Basic (Declaration)
Public NotInheritable Class RibbonBarElementNames
Visual C++
public ref class RibbonBarElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.RibbonBarElementNames

See Also

RibbonBarElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


RibbonBarElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames Members
RibbonBarElementNames Class Fields See Also Send Feedback

The RibbonBarElementNames type exposes the following members.

Fields

Name | Description
ApplicationDropDownButtonName | The RibbonBar application menu button name.
ButtonImageName | The RibbonButton image name.
ButtonTextRow1Name | The RibbonButton first text block name.
ButtonTextRow2Name | The RibbonButton second text block name.
GroupDialogLauncherName | The RibbonGroup dialog launcher button name.
GroupTrayName | The RibbonGroup tray element name.
HelpButtonName | The RibbonBar help button name.
TabContentHostName | The RibbonBar tab content host name.
TabContentPopupName | The RibbonBar tab content popup name.
TabControlName | The RibbonBar tab control name.
TitleAlignerName | The RibbonBar title aligner name.
WindowTitleApplicationTextName | The RibbonBar WindowTitle application name text block name.
WindowTitleDividerTextName | The RibbonBar WindowTitle divider text block name.
WindowTitleName | The RibbonBar WindowTitle element name.
WindowTitleTextName | The RibbonBar WindowTitle title text block name.

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


RibbonBarElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames Fields
RibbonBarElementNames Class See Also Send Feedback

The RibbonBarElementNames type exposes the following members.

Fields

Name | Description
ApplicationDropDownButtonName | The RibbonBar application menu button name.
ButtonImageName | The RibbonButton image name.
ButtonTextRow1Name | The RibbonButton first text block name.
ButtonTextRow2Name | The RibbonButton second text block name.
GroupDialogLauncherName | The RibbonGroup dialog launcher button name.
GroupTrayName | The RibbonGroup tray element name.
HelpButtonName | The RibbonBar help button name.
TabContentHostName | The RibbonBar tab content host name.
TabContentPopupName | The RibbonBar tab content popup name.
TabControlName | The RibbonBar tab control name.
TitleAlignerName | The RibbonBar title aligner name.
WindowTitleApplicationTextName | The RibbonBar WindowTitle application name text block name.
WindowTitleDividerTextName | The RibbonBar WindowTitle divider text block name.
WindowTitleName | The RibbonBar WindowTitle element name.
WindowTitleTextName | The RibbonBar WindowTitle title text block name.

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ApplicationDropDownButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.ApplicationDropDownButtonName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar application menu button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ApplicationDropDownButtonName
Visual Basic (Declaration)
Public Const ApplicationDropDownButtonName As String
Visual C++
public:
literal String^ ApplicationDropDownButtonName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ButtonImageName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.ButtonImageName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonButton image name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ButtonImageName
Visual Basic (Declaration)
Public Const ButtonImageName As String
Visual C++
public:
literal String^ ButtonImageName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ButtonTextRow1Name Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.ButtonTextRow1Name Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonButton first text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ButtonTextRow1Name
Visual Basic (Declaration)
Public Const ButtonTextRow1Name As String
Visual C++
public:
literal String^ ButtonTextRow1Name

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ButtonTextRow2Name Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.ButtonTextRow2Name Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonButton second text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ButtonTextRow2Name
Visual Basic (Declaration)
Public Const ButtonTextRow2Name As String
Visual C++
public:
literal String^ ButtonTextRow2Name

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


GroupDialogLauncherName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.GroupDialogLauncherName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonGroup dialog launcher button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GroupDialogLauncherName
Visual Basic (Declaration)
Public Const GroupDialogLauncherName As String
Visual C++
public:
literal String^ GroupDialogLauncherName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


GroupTrayName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.GroupTrayName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonGroup tray element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GroupTrayName
Visual Basic (Declaration)
Public Const GroupTrayName As String
Visual C++
public:
literal String^ GroupTrayName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HelpButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.HelpButtonName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar help button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HelpButtonName
Visual Basic (Declaration)
Public Const HelpButtonName As String
Visual C++
public:
literal String^ HelpButtonName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TabContentHostName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.TabContentHostName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar tab content host name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabContentHostName
Visual Basic (Declaration)
Public Const TabContentHostName As String
Visual C++
public:
literal String^ TabContentHostName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TabContentPopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.TabContentPopupName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar tab content popup name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabContentPopupName
Visual Basic (Declaration)
Public Const TabContentPopupName As String
Visual C++
public:
literal String^ TabContentPopupName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TabControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.TabControlName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar tab control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TabControlName
Visual Basic (Declaration)
Public Const TabControlName As String
Visual C++
public:
literal String^ TabControlName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TitleAlignerName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.TitleAlignerName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar title aligner name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TitleAlignerName
Visual Basic (Declaration)
Public Const TitleAlignerName As String
Visual C++
public:
literal String^ TitleAlignerName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitleApplicationTextName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.WindowTitleApplicationTextName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar WindowTitle application name text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WindowTitleApplicationTextName
Visual Basic (Declaration)
Public Const WindowTitleApplicationTextName As String
Visual C++
public:
literal String^ WindowTitleApplicationTextName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitleDividerTextName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.WindowTitleDividerTextName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar WindowTitle divider text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WindowTitleDividerTextName
Visual Basic (Declaration)
Public Const WindowTitleDividerTextName As String
Visual C++
public:
literal String^ WindowTitleDividerTextName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitleName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.WindowTitleName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar WindowTitle element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WindowTitleName
Visual Basic (Declaration)
Public Const WindowTitleName As String
Visual C++
public:
literal String^ WindowTitleName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitleTextName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RibbonBarElementNames..::.WindowTitleTextName Field
RibbonBarElementNames Class See Also Send Feedback
The RibbonBar WindowTitle title text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WindowTitleTextName
Visual Basic (Declaration)
Public Const WindowTitleTextName As String
Visual C++
public:
literal String^ WindowTitleTextName

See Also

RibbonBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerDayPresenter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter Class
Members See Also Send Feedback
The Scheduler DayView presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerDayPresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerDayPresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerDayPresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerDayPresenter

See Also

SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerDayPresenter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter Members
SchedulerDayPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerDayPresenter type exposes the following members.

Constructors

Name | Description
SchedulerDayPresenter | Initializes a new instance of the SchedulerDayPresenter class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerDayPresenter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter Constructor
SchedulerDayPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerDayPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerDayPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerDayPresenter()

See Also

SchedulerDayPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerDayPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter Methods
SchedulerDayPresenter Class See Also Send Feedback

The SchedulerDayPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.AnySibling Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.GetProperty Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.GetRectangle Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.Highlight Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.InvokeMethod Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.NextSibling Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.Parent Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.PreviousSibling Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.ScrollToVisible Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerDayPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter Properties
SchedulerDayPresenter Class See Also Send Feedback

The SchedulerDayPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.AllDayAppointmentsControl Property
SchedulerDayPresenter Class See Also Send Feedback
Get the 'all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl AllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerDayPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


NotAllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerDayPresenter..::.NotAllDayAppointmentsControl Property
SchedulerDayPresenter Class See Also Send Feedback
Get the 'not all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl NotAllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property NotAllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ NotAllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerDayPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames Class
Members See Also Send Feedback
Represents the Scheduler important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SchedulerElementNames
Visual Basic (Declaration)
Public NotInheritable Class SchedulerElementNames
Visual C++
public ref class SchedulerElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.SchedulerElementNames

See Also

SchedulerElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames Members
SchedulerElementNames Class Fields See Also Send Feedback

The SchedulerElementNames type exposes the following members.

Fields

Name | Description
AllDayAppointmentsControlName | The Scheduler all day appointments control name.
AppointmentDeleteButtonName | The Scheduler appointment item delete button name.
AppointmentDialogAllDayEventCheckBoxName | The Scheduler appointment dialog all day event check box name.
AppointmentDialogDescriptionTextBoxName | The Scheduler appointment dialog description text box name.
AppointmentDialogEndDateTimeName | The Scheduler appointment dialog end date time element name.
AppointmentDialogStartDateTimeName | The Scheduler appointment dialog start date time element name.
AppointmentRecurrenceMarkName | The Scheduler appointment item recurrence mark image name.
AppointmentResizeEndName | The Scheduler appointment item end resize rectangle name.
AppointmentResizeStartName | The Scheduler appointment item start resize rectangle name.
AppointmentsControlTimeSlotItemsControlName | The Scheduler appointments control time slot items control name.
AppointmentSubjectTextBoxName | The Scheduler appointment item subject text box name.
BackButtonName | The Scheduler back navigation button name.
DayPresenterAllDayAppointmentsControlName | The Scheduler day presenter all day appointments control name.
DayPresenterNotAllDayAppointmentsControlName | The Scheduler day presenter not all day appointments control name.
DayViewButtonName | The Scheduler header 'Day' view button name.
ForwardButtonName | The Scheduler forward navigation button name.
HeaderBorderName | The Scheduler header border name.
MonthPresenterMonthViewGridName | The Scheduler month presenter month view grid name.
MonthPresenterScrollBarName | The Scheduler month presenter scroll bar name.
MonthPresenterVerticalSmallDecreaseButtonName | The the name of the Scheduler month presenter vertical small decrease button scrolling the month view down.
MonthPresenterVerticalSmallIncreaseButtonName | The the name of the Scheduler month presenter vertical small increase button scrolling the month view down.
MonthViewButtonName | The Scheduler header 'Month' view button name.
NavigationDatePickerName | The Scheduler navigation date picker name.
PresenterName | The Scheduler presenter name.
TimelineViewButtonName | The Scheduler header 'Timeline' view button name.
TimeSlotContentHostGridName | The Scheduler time slot content host grid element name.
TimeSlotDayTextBlockName | The Scheduler time slot day name text block.
TimeSlotHeaderGridName | The Scheduler time slot header grid element name.
TimeSlotMonthTextBlockName | The Scheduler time slot month name text block name.
TimeSlotShowMoreButtonName | The Scheduler time slot show more button name.
WeekPresenterAllDayAppointmentsControlName | The Scheduler week presenter all day appointments control name.
WeekPresenterDayHeaderName | The Scheduler week presenter day header element name.
WeekPresenterNotAllDayAppointmentsControlName | The Scheduler week presenter not all day appointments control name.
WeekViewButtonName | The Scheduler header 'Week' view button name.

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames Fields
SchedulerElementNames Class See Also Send Feedback

The SchedulerElementNames type exposes the following members.

Fields

Name | Description
AllDayAppointmentsControlName | The Scheduler all day appointments control name.
AppointmentDeleteButtonName | The Scheduler appointment item delete button name.
AppointmentDialogAllDayEventCheckBoxName | The Scheduler appointment dialog all day event check box name.
AppointmentDialogDescriptionTextBoxName | The Scheduler appointment dialog description text box name.
AppointmentDialogEndDateTimeName | The Scheduler appointment dialog end date time element name.
AppointmentDialogStartDateTimeName | The Scheduler appointment dialog start date time element name.
AppointmentRecurrenceMarkName | The Scheduler appointment item recurrence mark image name.
AppointmentResizeEndName | The Scheduler appointment item end resize rectangle name.
AppointmentResizeStartName | The Scheduler appointment item start resize rectangle name.
AppointmentsControlTimeSlotItemsControlName | The Scheduler appointments control time slot items control name.
AppointmentSubjectTextBoxName | The Scheduler appointment item subject text box name.
BackButtonName | The Scheduler back navigation button name.
DayPresenterAllDayAppointmentsControlName | The Scheduler day presenter all day appointments control name.
DayPresenterNotAllDayAppointmentsControlName | The Scheduler day presenter not all day appointments control name.
DayViewButtonName | The Scheduler header 'Day' view button name.
ForwardButtonName | The Scheduler forward navigation button name.
HeaderBorderName | The Scheduler header border name.
MonthPresenterMonthViewGridName | The Scheduler month presenter month view grid name.
MonthPresenterScrollBarName | The Scheduler month presenter scroll bar name.
MonthPresenterVerticalSmallDecreaseButtonName | The the name of the Scheduler month presenter vertical small decrease button scrolling the month view down.
MonthPresenterVerticalSmallIncreaseButtonName | The the name of the Scheduler month presenter vertical small increase button scrolling the month view down.
MonthViewButtonName | The Scheduler header 'Month' view button name.
NavigationDatePickerName | The Scheduler navigation date picker name.
PresenterName | The Scheduler presenter name.
TimelineViewButtonName | The Scheduler header 'Timeline' view button name.
TimeSlotContentHostGridName | The Scheduler time slot content host grid element name.
TimeSlotDayTextBlockName | The Scheduler time slot day name text block.
TimeSlotHeaderGridName | The Scheduler time slot header grid element name.
TimeSlotMonthTextBlockName | The Scheduler time slot month name text block name.
TimeSlotShowMoreButtonName | The Scheduler time slot show more button name.
WeekPresenterAllDayAppointmentsControlName | The Scheduler week presenter all day appointments control name.
WeekPresenterDayHeaderName | The Scheduler week presenter day header element name.
WeekPresenterNotAllDayAppointmentsControlName | The Scheduler week presenter not all day appointments control name.
WeekViewButtonName | The Scheduler header 'Week' view button name.

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AllDayAppointmentsControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AllDayAppointmentsControlName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler all day appointments control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AllDayAppointmentsControlName
Visual Basic (Declaration)
Public Const AllDayAppointmentsControlName As String
Visual C++
public:
literal String^ AllDayAppointmentsControlName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentDeleteButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentDeleteButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment item delete button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentDeleteButtonName
Visual Basic (Declaration)
Public Const AppointmentDeleteButtonName As String
Visual C++
public:
literal String^ AppointmentDeleteButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentDialogAllDayEventCheckBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentDialogAllDayEventCheckBoxName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment dialog all day event check box name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentDialogAllDayEventCheckBoxName
Visual Basic (Declaration)
Public Const AppointmentDialogAllDayEventCheckBoxName As String
Visual C++
public:
literal String^ AppointmentDialogAllDayEventCheckBoxName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentDialogDescriptionTextBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentDialogDescriptionTextBoxName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment dialog description text box name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentDialogDescriptionTextBoxName
Visual Basic (Declaration)
Public Const AppointmentDialogDescriptionTextBoxName As String
Visual C++
public:
literal String^ AppointmentDialogDescriptionTextBoxName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentDialogEndDateTimeName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentDialogEndDateTimeName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment dialog end date time element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentDialogEndDateTimeName
Visual Basic (Declaration)
Public Const AppointmentDialogEndDateTimeName As String
Visual C++
public:
literal String^ AppointmentDialogEndDateTimeName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentDialogStartDateTimeName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentDialogStartDateTimeName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment dialog start date time element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentDialogStartDateTimeName
Visual Basic (Declaration)
Public Const AppointmentDialogStartDateTimeName As String
Visual C++
public:
literal String^ AppointmentDialogStartDateTimeName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentRecurrenceMarkName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentRecurrenceMarkName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment item recurrence mark image name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentRecurrenceMarkName
Visual Basic (Declaration)
Public Const AppointmentRecurrenceMarkName As String
Visual C++
public:
literal String^ AppointmentRecurrenceMarkName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentResizeEndName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentResizeEndName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment item end resize rectangle name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentResizeEndName
Visual Basic (Declaration)
Public Const AppointmentResizeEndName As String
Visual C++
public:
literal String^ AppointmentResizeEndName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentResizeStartName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentResizeStartName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment item start resize rectangle name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentResizeStartName
Visual Basic (Declaration)
Public Const AppointmentResizeStartName As String
Visual C++
public:
literal String^ AppointmentResizeStartName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControlTimeSlotItemsControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentsControlTimeSlotItemsControlName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointments control time slot items control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentsControlTimeSlotItemsControlName
Visual Basic (Declaration)
Public Const AppointmentsControlTimeSlotItemsControlName As String
Visual C++
public:
literal String^ AppointmentsControlTimeSlotItemsControlName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentSubjectTextBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.AppointmentSubjectTextBoxName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler appointment item subject text box name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string AppointmentSubjectTextBoxName
Visual Basic (Declaration)
Public Const AppointmentSubjectTextBoxName As String
Visual C++
public:
literal String^ AppointmentSubjectTextBoxName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


BackButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.BackButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler back navigation button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BackButtonName
Visual Basic (Declaration)
Public Const BackButtonName As String
Visual C++
public:
literal String^ BackButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DayPresenterAllDayAppointmentsControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.DayPresenterAllDayAppointmentsControlName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler day presenter all day appointments control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DayPresenterAllDayAppointmentsControlName
Visual Basic (Declaration)
Public Const DayPresenterAllDayAppointmentsControlName As String
Visual C++
public:
literal String^ DayPresenterAllDayAppointmentsControlName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DayPresenterNotAllDayAppointmentsControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.DayPresenterNotAllDayAppointmentsControlName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler day presenter not all day appointments control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DayPresenterNotAllDayAppointmentsControlName
Visual Basic (Declaration)
Public Const DayPresenterNotAllDayAppointmentsControlName As String
Visual C++
public:
literal String^ DayPresenterNotAllDayAppointmentsControlName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DayViewButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.DayViewButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler header 'Day' view button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DayViewButtonName
Visual Basic (Declaration)
Public Const DayViewButtonName As String
Visual C++
public:
literal String^ DayViewButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ForwardButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.ForwardButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler forward navigation button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ForwardButtonName
Visual Basic (Declaration)
Public Const ForwardButtonName As String
Visual C++
public:
literal String^ ForwardButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderBorderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.HeaderBorderName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler header border name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HeaderBorderName
Visual Basic (Declaration)
Public Const HeaderBorderName As String
Visual C++
public:
literal String^ HeaderBorderName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MonthPresenterMonthViewGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.MonthPresenterMonthViewGridName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler month presenter month view grid name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MonthPresenterMonthViewGridName
Visual Basic (Declaration)
Public Const MonthPresenterMonthViewGridName As String
Visual C++
public:
literal String^ MonthPresenterMonthViewGridName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MonthPresenterScrollBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.MonthPresenterScrollBarName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler month presenter scroll bar name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MonthPresenterScrollBarName
Visual Basic (Declaration)
Public Const MonthPresenterScrollBarName As String
Visual C++
public:
literal String^ MonthPresenterScrollBarName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MonthPresenterVerticalSmallDecreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.MonthPresenterVerticalSmallDecreaseButtonName Field
SchedulerElementNames Class See Also Send Feedback
The the name of the Scheduler month presenter vertical small decrease button scrolling the month view down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MonthPresenterVerticalSmallDecreaseButtonName
Visual Basic (Declaration)
Public Const MonthPresenterVerticalSmallDecreaseButtonName As String
Visual C++
public:
literal String^ MonthPresenterVerticalSmallDecreaseButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MonthPresenterVerticalSmallIncreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.MonthPresenterVerticalSmallIncreaseButtonName Field
SchedulerElementNames Class See Also Send Feedback
The the name of the Scheduler month presenter vertical small increase button scrolling the month view down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MonthPresenterVerticalSmallIncreaseButtonName
Visual Basic (Declaration)
Public Const MonthPresenterVerticalSmallIncreaseButtonName As String
Visual C++
public:
literal String^ MonthPresenterVerticalSmallIncreaseButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MonthViewButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.MonthViewButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler header 'Month' view button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MonthViewButtonName
Visual Basic (Declaration)
Public Const MonthViewButtonName As String
Visual C++
public:
literal String^ MonthViewButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


NavigationDatePickerName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.NavigationDatePickerName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler navigation date picker name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string NavigationDatePickerName
Visual Basic (Declaration)
Public Const NavigationDatePickerName As String
Visual C++
public:
literal String^ NavigationDatePickerName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.PresenterName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler presenter name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PresenterName
Visual Basic (Declaration)
Public Const PresenterName As String
Visual C++
public:
literal String^ PresenterName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimelineViewButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.TimelineViewButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler header 'Timeline' view button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimelineViewButtonName
Visual Basic (Declaration)
Public Const TimelineViewButtonName As String
Visual C++
public:
literal String^ TimelineViewButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotContentHostGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.TimeSlotContentHostGridName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler time slot content host grid element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSlotContentHostGridName
Visual Basic (Declaration)
Public Const TimeSlotContentHostGridName As String
Visual C++
public:
literal String^ TimeSlotContentHostGridName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotDayTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.TimeSlotDayTextBlockName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler time slot day name text block.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSlotDayTextBlockName
Visual Basic (Declaration)
Public Const TimeSlotDayTextBlockName As String
Visual C++
public:
literal String^ TimeSlotDayTextBlockName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotHeaderGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.TimeSlotHeaderGridName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler time slot header grid element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSlotHeaderGridName
Visual Basic (Declaration)
Public Const TimeSlotHeaderGridName As String
Visual C++
public:
literal String^ TimeSlotHeaderGridName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotMonthTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.TimeSlotMonthTextBlockName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler time slot month name text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSlotMonthTextBlockName
Visual Basic (Declaration)
Public Const TimeSlotMonthTextBlockName As String
Visual C++
public:
literal String^ TimeSlotMonthTextBlockName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotShowMoreButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.TimeSlotShowMoreButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler time slot show more button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TimeSlotShowMoreButtonName
Visual Basic (Declaration)
Public Const TimeSlotShowMoreButtonName As String
Visual C++
public:
literal String^ TimeSlotShowMoreButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WeekPresenterAllDayAppointmentsControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.WeekPresenterAllDayAppointmentsControlName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler week presenter all day appointments control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WeekPresenterAllDayAppointmentsControlName
Visual Basic (Declaration)
Public Const WeekPresenterAllDayAppointmentsControlName As String
Visual C++
public:
literal String^ WeekPresenterAllDayAppointmentsControlName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WeekPresenterDayHeaderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.WeekPresenterDayHeaderName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler week presenter day header element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WeekPresenterDayHeaderName
Visual Basic (Declaration)
Public Const WeekPresenterDayHeaderName As String
Visual C++
public:
literal String^ WeekPresenterDayHeaderName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WeekPresenterNotAllDayAppointmentsControlName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.WeekPresenterNotAllDayAppointmentsControlName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler week presenter not all day appointments control name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WeekPresenterNotAllDayAppointmentsControlName
Visual Basic (Declaration)
Public Const WeekPresenterNotAllDayAppointmentsControlName As String
Visual C++
public:
literal String^ WeekPresenterNotAllDayAppointmentsControlName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WeekViewButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerElementNames..::.WeekViewButtonName Field
SchedulerElementNames Class See Also Send Feedback
The Scheduler header 'Week' view button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string WeekViewButtonName
Visual Basic (Declaration)
Public Const WeekViewButtonName As String
Visual C++
public:
literal String^ WeekViewButtonName

See Also

SchedulerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerMonthPresenter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter Class
Members See Also Send Feedback
The Scheduler MonthView presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerMonthPresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerMonthPresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerMonthPresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerMonthPresenter

See Also

SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerMonthPresenter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter Members
SchedulerMonthPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerMonthPresenter type exposes the following members.

Constructors

Name | Description
SchedulerMonthPresenter | Initializes a new instance of the SchedulerMonthPresenter class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Overloaded.
OpenWeek | Simulates user clicking on the week with the given index to open the respective WeekView.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollBack | Scrolls up the month view with a click on the top repeat button.
ScrollForward | Scrolls down the month view with a click on the bottom repeat button.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AppointmentsControl | Get the Appointments control for this presenter.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DayHeaderGrid | Get the RadUniformGrid control representing the day header.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MonthScrollBar | Get the scroll bar part of the Scheduler MonthView.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
WeekHeaderGrid | Get the RadUniformGrid control representing the week header.
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerMonthPresenter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter Constructor
SchedulerMonthPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerMonthPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerMonthPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerMonthPresenter()

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerMonthPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter Methods
SchedulerMonthPresenter Class See Also Send Feedback

The SchedulerMonthPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Overloaded.
OpenWeek | Simulates user clicking on the week with the given index to open the respective WeekView.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollBack | Scrolls up the month view with a click on the top repeat button.
ScrollForward | Scrolls down the month view with a click on the bottom repeat button.
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.AnySibling Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.GetProperty Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.GetRectangle Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.Highlight Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.InvokeMethod Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.NextSibling Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


OpenDay Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.OpenDay Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
OpenDay(Int32) | Simulates user clicking on the first day with the given value to open the respective DayView.
OpenDay(Int32, Int32) | Simulates user clicking on the day with the given value and occurrence to open the respective DayView.

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


OpenDay Method (Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.OpenDay Method (Int32)
SchedulerMonthPresenter Class See Also Send Feedback
Simulates user clicking on the first day with the given value to open the respective DayView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenDay(
    int day
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    day As Integer _
)
Visual C++
public:
void OpenDay(
    int day
)

Parameters

day
Type: System..::.Int32
The value of the day to open.

See Also

SchedulerMonthPresenter Class
OpenDay Overload
Telerik.WebAii.Controls.Xaml Namespace


OpenDay Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.OpenDay Method (Int32, Int32)
SchedulerMonthPresenter Class See Also Send Feedback
Simulates user clicking on the day with the given value and occurrence to open the respective DayView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void OpenDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The value of the day to open.
occurrence
Type: System..::.Int32
The occurrence index of the day to open.

See Also

SchedulerMonthPresenter Class
OpenDay Overload
Telerik.WebAii.Controls.Xaml Namespace


OpenWeek Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.OpenWeek Method
SchedulerMonthPresenter Class See Also Send Feedback
Simulates user clicking on the week with the given index to open the respective WeekView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenWeek(
    int index
)
Visual Basic (Declaration)
Public Sub OpenWeek ( _
    index As Integer _
)
Visual C++
public:
void OpenWeek(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the week to open.

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.Parent Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.PreviousSibling Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollBack Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.ScrollBack Method
SchedulerMonthPresenter Class See Also Send Feedback
Scrolls up the month view with a click on the top repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollBack()
Visual Basic (Declaration)
Public Sub ScrollBack
Visual C++
public:
void ScrollBack()

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollForward Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.ScrollForward Method
SchedulerMonthPresenter Class See Also Send Feedback
Scrolls down the month view with a click on the bottom repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ScrollForward()
Visual Basic (Declaration)
Public Sub ScrollForward
Visual C++
public:
void ScrollForward()

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.ScrollToVisible Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerMonthPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter Properties
SchedulerMonthPresenter Class See Also Send Feedback

The SchedulerMonthPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AppointmentsControl | Get the Appointments control for this presenter.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DayHeaderGrid | Get the RadUniformGrid control representing the day header.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MonthScrollBar | Get the scroll bar part of the Scheduler MonthView.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
WeekHeaderGrid | Get the RadUniformGrid control representing the week header.
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.AppointmentsControl Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the Appointments control for this presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl AppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


DayHeaderGrid Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.DayHeaderGrid Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the RadUniformGrid control representing the day header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUniformGrid DayHeaderGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayHeaderGrid As RadUniformGrid
Visual C++
public:
property RadUniformGrid^ DayHeaderGrid {
    RadUniformGrid^ get ();
}

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


MonthScrollBar Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.MonthScrollBar Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the scroll bar part of the Scheduler MonthView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ScrollBar MonthScrollBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthScrollBar As ScrollBar
Visual C++
public:
property ScrollBar^ MonthScrollBar {
    ScrollBar^ get ();
}

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


WeekHeaderGrid Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerMonthPresenter..::.WeekHeaderGrid Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the RadUniformGrid control representing the week header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUniformGrid WeekHeaderGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property WeekHeaderGrid As RadUniformGrid
Visual C++
public:
property RadUniformGrid^ WeekHeaderGrid {
    RadUniformGrid^ get ();
}

See Also

SchedulerMonthPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerPresenter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter Class
Members See Also Send Feedback
The Scheduler View presenter base control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerPresenter : Control
Visual Basic (Declaration)
Public Class SchedulerPresenter _
    Inherits Control
Visual C++
public ref class SchedulerPresenter : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerDayPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerMonthPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerTimelinePresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerWeekPresenter

See Also

SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerPresenter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter Members
SchedulerPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerPresenter type exposes the following members.

Constructors

Name | Description
SchedulerPresenter | Initializes a new instance of the SchedulerPresenter class

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerPresenter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter Constructor
SchedulerPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerPresenter class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerPresenter()

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter Methods
SchedulerPresenter Class See Also Send Feedback

The SchedulerPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.AnySibling Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.GetProperty Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.GetRectangle Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.Highlight Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.InitializeMappings Method
SchedulerPresenter Class See Also Send Feedback
Initializes the mapping of the RadScheduler SchedulerPresenter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.InvokeMethod Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.NextSibling Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.Parent Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.PreviousSibling Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.ScrollToVisible Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter Properties
SchedulerPresenter Class See Also Send Feedback

The SchedulerPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property.
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


IsMonthView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.IsMonthView Property
SchedulerPresenter Class See Also Send Feedback
Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsMonthView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMonthView As Boolean
Visual C++
public:
property bool IsMonthView {
    bool get ();
}

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


PresenterType Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.PresenterType Property
SchedulerPresenter Class See Also Send Feedback
Get the SchedulerViewType of this presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerViewType PresenterType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PresenterType As SchedulerViewType
Visual C++
public:
property SchedulerViewType PresenterType {
    SchedulerViewType get ();
}

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerPresenter..::.XamlTag Property
SchedulerPresenter Class See Also Send Feedback
Gets the XamlTag of the SchedulerPresenter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SchedulerPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerTimelinePresenter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter Class
Members See Also Send Feedback
Represents the RadScheduler Timeline presenter control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerTimelinePresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerTimelinePresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerTimelinePresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerTimelinePresenter

See Also

SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerTimelinePresenter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter Members
SchedulerTimelinePresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerTimelinePresenter type exposes the following members.

Constructors

Name | Description
SchedulerTimelinePresenter | Initializes a new instance of the SchedulerTimelinePresenter class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenHeaderDay | Simulates user clicking on the day with the given index in the header to open the respective DayView.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AppointmentsControl | Get the Appointments control for this presenter.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DayHeaderGrid | Get the RadUniformGrid control representing the days header.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerTimelinePresenter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter Constructor
SchedulerTimelinePresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerTimelinePresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerTimelinePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerTimelinePresenter()

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerTimelinePresenter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter Methods
SchedulerTimelinePresenter Class See Also Send Feedback

The SchedulerTimelinePresenter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenHeaderDay | Simulates user clicking on the day with the given index in the header to open the respective DayView.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.AnySibling Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.GetProperty Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.GetRectangle Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.Highlight Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.InvokeMethod Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.NextSibling Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


OpenHeaderDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.OpenHeaderDay Method
SchedulerTimelinePresenter Class See Also Send Feedback
Simulates user clicking on the day with the given index in the header to open the respective DayView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenHeaderDay(
    int dayIndex
)
Visual Basic (Declaration)
Public Sub OpenHeaderDay ( _
    dayIndex As Integer _
)
Visual C++
public:
void OpenHeaderDay(
    int dayIndex
)

Parameters

dayIndex
Type: System..::.Int32
The index of the day item in the header.

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.Parent Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.PreviousSibling Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.ScrollToVisible Method
SchedulerTimelinePresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
SchedulerTimelinePresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerTimelinePresenter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter Properties
SchedulerTimelinePresenter Class See Also Send Feedback

The SchedulerTimelinePresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AppointmentsControl | Get the Appointments control for this presenter.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DayHeaderGrid | Get the RadUniformGrid control representing the days header.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentsControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.AppointmentsControl Property
SchedulerTimelinePresenter Class See Also Send Feedback
Get the Appointments control for this presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl AppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


DayHeaderGrid Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerTimelinePresenter..::.DayHeaderGrid Property
SchedulerTimelinePresenter Class See Also Send Feedback
Get the RadUniformGrid control representing the days header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUniformGrid DayHeaderGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayHeaderGrid As RadUniformGrid
Visual C++
public:
property RadUniformGrid^ DayHeaderGrid {
    RadUniformGrid^ get ();
}

See Also

SchedulerTimelinePresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerViewType Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerViewType Enumeration
See Also Send Feedback
The enumeration holding the supported Scheduler view types.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
[SerializableAttribute]
public enum SchedulerViewType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration SchedulerViewType
Visual C++
[SerializableAttribute]
public enum class SchedulerViewType

Members

Member name | Description
Day | The 'Day' Scheduler view type.
Week | The 'Week' Scheduler view type.
Month | The 'Month' Scheduler view type.
Timeline | The 'Timeline' Scheduler view type.

See Also

Telerik.WebAii.Controls.Xaml Namespace


SchedulerWeekPresenter Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter Class
Members See Also Send Feedback
Represents the Scheduler WeekView wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SchedulerWeekPresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerWeekPresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerWeekPresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerWeekPresenter

See Also

SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerWeekPresenter Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter Members
SchedulerWeekPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerWeekPresenter type exposes the following members.

Constructors

Name | Description
SchedulerWeekPresenter | Initializes a new instance of the SchedulerWeekPresenter class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Simulates user clicking on the day in the header to open the respective day view.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DayHeaderGrid | Get the day header grid holding the buttons.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerWeekPresenter Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter Constructor
SchedulerWeekPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerWeekPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SchedulerWeekPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerWeekPresenter()

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SchedulerWeekPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter Methods
SchedulerWeekPresenter Class See Also Send Feedback

The SchedulerWeekPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler SchedulerPresenter control. (Inherited from SchedulerPresenter.)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Simulates user clicking on the day in the header to open the respective day view.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.AnySibling Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.GetProperty Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.GetRectangle Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.Highlight Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.InvokeMethod Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.NextSibling Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


OpenDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.OpenDay Method
SchedulerWeekPresenter Class See Also Send Feedback
Simulates user clicking on the day in the header to open the respective day view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenDay(
    int index
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    index As Integer _
)
Visual C++
public:
void OpenDay(
    int index
)

Parameters

index
Type: System..::.Int32
The header index of the day to open.

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.Parent Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.PreviousSibling Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.ScrollToVisible Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members
Telerik.WebAii.Controls.Xaml Namespace


SchedulerWeekPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter Properties
SchedulerWeekPresenter Class See Also Send Feedback

The SchedulerWeekPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
DayHeaderGrid | Get the day header grid holding the buttons.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsMonthView | Get whether the presenter is of MonthView type. This is an optimized check compared to the .CurrentView property. (Inherited from SchedulerPresenter.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PresenterType | Get the SchedulerViewType of this presenter. (Inherited from SchedulerPresenter.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


AllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.AllDayAppointmentsControl Property
SchedulerWeekPresenter Class See Also Send Feedback
Get the 'all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl AllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


DayHeaderGrid Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.DayHeaderGrid Property
SchedulerWeekPresenter Class See Also Send Feedback
Get the day header grid holding the buttons.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadUniformGrid DayHeaderGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayHeaderGrid As RadUniformGrid
Visual C++
public:
property RadUniformGrid^ DayHeaderGrid {
    RadUniformGrid^ get ();
}

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


NotAllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SchedulerWeekPresenter..::.NotAllDayAppointmentsControl Property
SchedulerWeekPresenter Class See Also Send Feedback
Get the 'not all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AppointmentsControl NotAllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property NotAllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ NotAllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerWeekPresenter Class
Telerik.WebAii.Controls.Xaml Namespace


SliderElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames Class
Members See Also Send Feedback
Represents a list of RadSlider element names used accross the wrapper controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SliderElementNames
Visual Basic (Declaration)
Public NotInheritable Class SliderElementNames
Visual C++
public ref class SliderElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.SliderElementNames

See Also

SliderElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


SliderElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames Members
SliderElementNames Class Fields See Also Send Feedback

The SliderElementNames type exposes the following members.

Fields

Name | Description
BottomTickBarName | The name of the bottom tick bar.
HorizontalDecreaseButtonName | The name of the horizontal decrease button.
HorizontalIncreaseButtonName | The name of the horizontal increase button.
HorizontalRangeEndThumbName | The name of the horizontal range end thumb element.
HorizontalRangeMiddleThumbName | The name of the horizontal range middle thumb element.
HorizontalRangeStartThumbName | The name of the horizontal range start thumb element.
HorizontalRangeTemplateName | The name of the horizontal range template grid element.
HorizontalSingleThumbName | The name of the horizontal single thumb element.
HorizontalSingleThumbTemplateName | The name of the horizontal single thumb template grid element.
HorizontalTemplateName | The name of the horizontal template grid element.
LeftTickBarName | The name of the left tick bar.
RightTickBarName | The name of the right tick bar.
TopTickBarName | The name of the top tick bar.
VerticalDecreaseButtonName | The name of the vertical decrease button.
VerticalIncreaseButtonName | The name of the vertical increase button.
VerticalRangeEndThumbName | The name of the vertical range end thumb element.
VerticalRangeMiddleThumbName | The name of the vertical range middle thumb element.
VerticalRangeStartThumbName | The name of the vertical range start thumb element.
VerticalRangeTemplateName | The name of the vertical range template grid element.
VerticalSingleThumbName | The name of the vertical single thumb element.
VerticalSingleThumbTemplateName | The name of the vertical single thumb template grid element.

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SliderElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames Fields
SliderElementNames Class See Also Send Feedback

The SliderElementNames type exposes the following members.

Fields

Name | Description
BottomTickBarName | The name of the bottom tick bar.
HorizontalDecreaseButtonName | The name of the horizontal decrease button.
HorizontalIncreaseButtonName | The name of the horizontal increase button.
HorizontalRangeEndThumbName | The name of the horizontal range end thumb element.
HorizontalRangeMiddleThumbName | The name of the horizontal range middle thumb element.
HorizontalRangeStartThumbName | The name of the horizontal range start thumb element.
HorizontalRangeTemplateName | The name of the horizontal range template grid element.
HorizontalSingleThumbName | The name of the horizontal single thumb element.
HorizontalSingleThumbTemplateName | The name of the horizontal single thumb template grid element.
HorizontalTemplateName | The name of the horizontal template grid element.
LeftTickBarName | The name of the left tick bar.
RightTickBarName | The name of the right tick bar.
TopTickBarName | The name of the top tick bar.
VerticalDecreaseButtonName | The name of the vertical decrease button.
VerticalIncreaseButtonName | The name of the vertical increase button.
VerticalRangeEndThumbName | The name of the vertical range end thumb element.
VerticalRangeMiddleThumbName | The name of the vertical range middle thumb element.
VerticalRangeStartThumbName | The name of the vertical range start thumb element.
VerticalRangeTemplateName | The name of the vertical range template grid element.
VerticalSingleThumbName | The name of the vertical single thumb element.
VerticalSingleThumbTemplateName | The name of the vertical single thumb template grid element.

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


BottomTickBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.BottomTickBarName Field
SliderElementNames Class See Also Send Feedback
The name of the bottom tick bar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BottomTickBarName
Visual Basic (Declaration)
Public Const BottomTickBarName As String
Visual C++
public:
literal String^ BottomTickBarName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalDecreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalDecreaseButtonName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal decrease button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalDecreaseButtonName
Visual Basic (Declaration)
Public Const HorizontalDecreaseButtonName As String
Visual C++
public:
literal String^ HorizontalDecreaseButtonName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalIncreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalIncreaseButtonName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal increase button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalIncreaseButtonName
Visual Basic (Declaration)
Public Const HorizontalIncreaseButtonName As String
Visual C++
public:
literal String^ HorizontalIncreaseButtonName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalRangeEndThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalRangeEndThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal range end thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalRangeEndThumbName
Visual Basic (Declaration)
Public Const HorizontalRangeEndThumbName As String
Visual C++
public:
literal String^ HorizontalRangeEndThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalRangeMiddleThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalRangeMiddleThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal range middle thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalRangeMiddleThumbName
Visual Basic (Declaration)
Public Const HorizontalRangeMiddleThumbName As String
Visual C++
public:
literal String^ HorizontalRangeMiddleThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalRangeStartThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalRangeStartThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal range start thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalRangeStartThumbName
Visual Basic (Declaration)
Public Const HorizontalRangeStartThumbName As String
Visual C++
public:
literal String^ HorizontalRangeStartThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalRangeTemplateName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalRangeTemplateName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal range template grid element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalRangeTemplateName
Visual Basic (Declaration)
Public Const HorizontalRangeTemplateName As String
Visual C++
public:
literal String^ HorizontalRangeTemplateName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalSingleThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalSingleThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal single thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalSingleThumbName
Visual Basic (Declaration)
Public Const HorizontalSingleThumbName As String
Visual C++
public:
literal String^ HorizontalSingleThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalSingleThumbTemplateName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalSingleThumbTemplateName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal single thumb template grid element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalSingleThumbTemplateName
Visual Basic (Declaration)
Public Const HorizontalSingleThumbTemplateName As String
Visual C++
public:
literal String^ HorizontalSingleThumbTemplateName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalTemplateName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.HorizontalTemplateName Field
SliderElementNames Class See Also Send Feedback
The name of the horizontal template grid element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string HorizontalTemplateName
Visual Basic (Declaration)
Public Const HorizontalTemplateName As String
Visual C++
public:
literal String^ HorizontalTemplateName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


LeftTickBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.LeftTickBarName Field
SliderElementNames Class See Also Send Feedback
The name of the left tick bar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LeftTickBarName
Visual Basic (Declaration)
Public Const LeftTickBarName As String
Visual C++
public:
literal String^ LeftTickBarName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


RightTickBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.RightTickBarName Field
SliderElementNames Class See Also Send Feedback
The name of the right tick bar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RightTickBarName
Visual Basic (Declaration)
Public Const RightTickBarName As String
Visual C++
public:
literal String^ RightTickBarName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TopTickBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.TopTickBarName Field
SliderElementNames Class See Also Send Feedback
The name of the top tick bar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TopTickBarName
Visual Basic (Declaration)
Public Const TopTickBarName As String
Visual C++
public:
literal String^ TopTickBarName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalDecreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalDecreaseButtonName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical decrease button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalDecreaseButtonName
Visual Basic (Declaration)
Public Const VerticalDecreaseButtonName As String
Visual C++
public:
literal String^ VerticalDecreaseButtonName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalIncreaseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalIncreaseButtonName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical increase button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalIncreaseButtonName
Visual Basic (Declaration)
Public Const VerticalIncreaseButtonName As String
Visual C++
public:
literal String^ VerticalIncreaseButtonName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalRangeEndThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalRangeEndThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical range end thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalRangeEndThumbName
Visual Basic (Declaration)
Public Const VerticalRangeEndThumbName As String
Visual C++
public:
literal String^ VerticalRangeEndThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalRangeMiddleThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalRangeMiddleThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical range middle thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalRangeMiddleThumbName
Visual Basic (Declaration)
Public Const VerticalRangeMiddleThumbName As String
Visual C++
public:
literal String^ VerticalRangeMiddleThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalRangeStartThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalRangeStartThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical range start thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalRangeStartThumbName
Visual Basic (Declaration)
Public Const VerticalRangeStartThumbName As String
Visual C++
public:
literal String^ VerticalRangeStartThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalRangeTemplateName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalRangeTemplateName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical range template grid element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalRangeTemplateName
Visual Basic (Declaration)
Public Const VerticalRangeTemplateName As String
Visual C++
public:
literal String^ VerticalRangeTemplateName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalSingleThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalSingleThumbName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical single thumb element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalSingleThumbName
Visual Basic (Declaration)
Public Const VerticalSingleThumbName As String
Visual C++
public:
literal String^ VerticalSingleThumbName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalSingleThumbTemplateName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SliderElementNames..::.VerticalSingleThumbTemplateName Field
SliderElementNames Class See Also Send Feedback
The name of the vertical single thumb template grid element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string VerticalSingleThumbTemplateName
Visual Basic (Declaration)
Public Const VerticalSingleThumbTemplateName As String
Visual C++
public:
literal String^ VerticalSingleThumbTemplateName

See Also

SliderElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SplitButtonElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames Class
Members See Also Send Feedback
Represents the RadSplitButton important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class SplitButtonElementNames
Visual Basic (Declaration)
Public NotInheritable Class SplitButtonElementNames
Visual C++
public ref class SplitButtonElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.SplitButtonElementNames

See Also

SplitButtonElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


SplitButtonElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames Members
SplitButtonElementNames Class Fields See Also Send Feedback

The SplitButtonElementNames type exposes the following members.

Fields

Name | Description
ButtonPartName | The Button part element name.
DropDownIndicatorName | The drop down indicator element name.
DropDownPartName | The drop down part element name.
DropDownPopupName | The drop down popup name.

See Also

SplitButtonElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


SplitButtonElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames Fields
SplitButtonElementNames Class See Also Send Feedback

The SplitButtonElementNames type exposes the following members.

Fields

Name | Description
ButtonPartName | The Button part element name.
DropDownIndicatorName | The drop down indicator element name.
DropDownPartName | The drop down part element name.
DropDownPopupName | The drop down popup name.

See Also

SplitButtonElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ButtonPartName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames..::.ButtonPartName Field
SplitButtonElementNames Class See Also Send Feedback
The Button part element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ButtonPartName
Visual Basic (Declaration)
Public Const ButtonPartName As String
Visual C++
public:
literal String^ ButtonPartName

See Also

SplitButtonElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownIndicatorName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames..::.DropDownIndicatorName Field
SplitButtonElementNames Class See Also Send Feedback
The drop down indicator element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownIndicatorName
Visual Basic (Declaration)
Public Const DropDownIndicatorName As String
Visual C++
public:
literal String^ DropDownIndicatorName

See Also

SplitButtonElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownPartName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames..::.DropDownPartName Field
SplitButtonElementNames Class See Also Send Feedback
The drop down part element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownPartName
Visual Basic (Declaration)
Public Const DropDownPartName As String
Visual C++
public:
literal String^ DropDownPartName

See Also

SplitButtonElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownPopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplitButtonElementNames..::.DropDownPopupName Field
SplitButtonElementNames Class See Also Send Feedback
The drop down popup name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownPopupName
Visual Basic (Declaration)
Public Const DropDownPopupName As String
Visual C++
public:
literal String^ DropDownPopupName

See Also

SplitButtonElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TabControlElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames Class
Members See Also Send Feedback
Represents the TabControl/TabItem important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TabControlElementNames
Visual Basic (Declaration)
Public NotInheritable Class TabControlElementNames
Visual C++
public ref class TabControlElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.TabControlElementNames

See Also

TabControlElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


TabControlElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames Members
TabControlElementNames Class Fields See Also Send Feedback

The TabControlElementNames type exposes the following members.

Fields

Name | Description
ContentPresenterElementName | The TabControl content presenter element name.
DropDownButtonName | The TabControl drop down toggle button name.
ItemHeaderContentPresenterName | The TabItem header content presenter element name.
LeftScrollButtonName | The TabControl left scrolling repeat button name.
RightScrollButtonName | The TabControl right scrolling repeat button name.

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TabControlElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames Fields
TabControlElementNames Class See Also Send Feedback

The TabControlElementNames type exposes the following members.

Fields

Name | Description
ContentPresenterElementName | The TabControl content presenter element name.
DropDownButtonName | The TabControl drop down toggle button name.
ItemHeaderContentPresenterName | The TabItem header content presenter element name.
LeftScrollButtonName | The TabControl left scrolling repeat button name.
RightScrollButtonName | The TabControl right scrolling repeat button name.

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames..::.ContentPresenterElementName Field
TabControlElementNames Class See Also Send Feedback
The TabControl content presenter element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ContentPresenterElementName
Visual Basic (Declaration)
Public Const ContentPresenterElementName As String
Visual C++
public:
literal String^ ContentPresenterElementName

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


DropDownButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames..::.DropDownButtonName Field
TabControlElementNames Class See Also Send Feedback
The TabControl drop down toggle button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string DropDownButtonName
Visual Basic (Declaration)
Public Const DropDownButtonName As String
Visual C++
public:
literal String^ DropDownButtonName

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemHeaderContentPresenterName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames..::.ItemHeaderContentPresenterName Field
TabControlElementNames Class See Also Send Feedback
The TabItem header content presenter element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemHeaderContentPresenterName
Visual Basic (Declaration)
Public Const ItemHeaderContentPresenterName As String
Visual C++
public:
literal String^ ItemHeaderContentPresenterName

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


LeftScrollButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames..::.LeftScrollButtonName Field
TabControlElementNames Class See Also Send Feedback
The TabControl left scrolling repeat button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string LeftScrollButtonName
Visual Basic (Declaration)
Public Const LeftScrollButtonName As String
Visual C++
public:
literal String^ LeftScrollButtonName

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


RightScrollButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TabControlElementNames..::.RightScrollButtonName Field
TabControlElementNames Class See Also Send Feedback
The TabControl right scrolling repeat button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RightScrollButtonName
Visual Basic (Declaration)
Public Const RightScrollButtonName As String
Visual C++
public:
literal String^ RightScrollButtonName

See Also

TabControlElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ThumbName Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ThumbName Enumeration
See Also Send Feedback
Enumerates the Slider control thumbs user interacts with.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum ThumbName
Visual Basic (Declaration)
Public Enumeration ThumbName
Visual C++
public enum class ThumbName

Members

Member name | Description
SingleThumb | When single thumb.
StartThumb | When range slider -start thumb.
MiddleThumb | When range slider -middle thumb(the space between thumbs).
EndThumb | When range slider -end thumb.

See Also

Telerik.WebAii.Controls.Xaml Namespace


TileViewElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TileViewElementNames Class
Members See Also Send Feedback
Represents the TileView important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TileViewElementNames
Visual Basic (Declaration)
Public NotInheritable Class TileViewElementNames
Visual C++
public ref class TileViewElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.TileViewElementNames

See Also

TileViewElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


TileViewElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TileViewElementNames Members
TileViewElementNames Class Fields See Also Send Feedback

The TileViewElementNames type exposes the following members.

Fields

Name | Description
GripBarElementName | The TileViewItem header border name.

See Also

TileViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TileViewElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TileViewElementNames Fields
TileViewElementNames Class See Also Send Feedback

The TileViewElementNames type exposes the following members.

Fields

Name | Description
GripBarElementName | The TileViewItem header border name.

See Also

TileViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


GripBarElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TileViewElementNames..::.GripBarElementName Field
TileViewElementNames Class See Also Send Feedback
The TileViewItem header border name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string GripBarElementName
Visual Basic (Declaration)
Public Const GripBarElementName As String
Visual C++
public:
literal String^ GripBarElementName

See Also

TileViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimePickerElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimePickerElementNames Class
Members See Also Send Feedback
Holds the list of the important TimePicker element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TimePickerElementNames
Visual Basic (Declaration)
Public NotInheritable Class TimePickerElementNames
Visual C++
public ref class TimePickerElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.TimePickerElementNames

See Also

TimePickerElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


TimePickerElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimePickerElementNames Members
TimePickerElementNames Class Fields See Also Send Feedback

The TimePickerElementNames type exposes the following members.

Fields

Name | Description
InputBoxName | The name of the TimePicker input box element.
PopupName | The name of the TimePicker popup element.
ToggleButtonName | The name of the TimePicker toggle button element.

See Also

TimePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimePickerElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimePickerElementNames Fields
TimePickerElementNames Class See Also Send Feedback

The TimePickerElementNames type exposes the following members.

Fields

Name | Description
InputBoxName | The name of the TimePicker input box element.
PopupName | The name of the TimePicker popup element.
ToggleButtonName | The name of the TimePicker toggle button element.

See Also

TimePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


InputBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimePickerElementNames..::.InputBoxName Field
TimePickerElementNames Class See Also Send Feedback
The name of the TimePicker input box element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string InputBoxName
Visual Basic (Declaration)
Public Const InputBoxName As String
Visual C++
public:
literal String^ InputBoxName

See Also

TimePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimePickerElementNames..::.PopupName Field
TimePickerElementNames Class See Also Send Feedback
The name of the TimePicker popup element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PopupName
Visual Basic (Declaration)
Public Const PopupName As String
Visual C++
public:
literal String^ PopupName

See Also

TimePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToggleButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimePickerElementNames..::.ToggleButtonName Field
TimePickerElementNames Class See Also Send Feedback
The name of the TimePicker toggle button element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ToggleButtonName
Visual Basic (Declaration)
Public Const ToggleButtonName As String
Visual C++
public:
literal String^ ToggleButtonName

See Also

TimePickerElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotItem Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem Class
Members See Also Send Feedback
Represents the TimeSlotItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class TimeSlotItem : ListBoxItem
Visual Basic (Declaration)
Public Class TimeSlotItem _
    Inherits ListBoxItem
Visual C++
public ref class TimeSlotItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ListBoxItem
Telerik.WebAii.Controls.Xaml..::.TimeSlotItem

See Also

TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotItem Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem Members
TimeSlotItem Class Constructors Methods Properties See Also Send Feedback

The TimeSlotItem type exposes the following members.

Constructors

Name | Description
TimeSlotItem | Initializes a new instance of the TimeSlotItem class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler TimeSlotItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | In Month view simulates user clicking on the time slot header to open the respective day.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user selecting the time slot.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ShowAllAppointments | In Month or Timeline view simulates user clicking on the ShowMoreButton.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
DayName | In Month view gets the displayed day name of this time slot.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInMonthView | Get whether the time slot item belongs to a month view scheduler presenter.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MonthDay | In Month view combines the month and day names of this time slot.
MonthName | In Month view gets the displayed month name of this time slot.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ShowMoreButtonVisibility | In Month or Timeline view gets the Visibility of the 'show more' button.
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the TimeSlotItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotItem Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem Constructor
TimeSlotItem Class See Also Send Feedback
Initializes a new instance of the TimeSlotItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public TimeSlotItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeSlotItem()

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotItem Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem Methods
TimeSlotItem Class See Also Send Feedback

The TimeSlotItem type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadScheduler TimeSlotItem control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | In Month view simulates user clicking on the time slot header to open the respective day.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user selecting the time slot.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ShowAllAppointments | In Month or Timeline view simulates user clicking on the ShowMoreButton.
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.AnySibling Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.GetProperty Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.GetRectangle Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.Highlight Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.InitializeMappings Method
TimeSlotItem Class See Also Send Feedback
Initializes the mapping of the RadScheduler TimeSlotItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.InvokeMethod Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.NextSibling Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


OpenDay Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.OpenDay Method
TimeSlotItem Class See Also Send Feedback
In Month view simulates user clicking on the time slot header to open the respective day.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void OpenDay()
Visual Basic (Declaration)
Public Sub OpenDay
Visual C++
public:
void OpenDay()

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.Parent Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.PreviousSibling Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.ScrollToVisible Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.Select Method
TimeSlotItem Class See Also Send Feedback
Simulates user selecting the time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


ShowAllAppointments Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.ShowAllAppointments Method
TimeSlotItem Class See Also Send Feedback
In Month or Timeline view simulates user clicking on the ShowMoreButton.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void ShowAllAppointments()
Visual Basic (Declaration)
Public Sub ShowAllAppointments
Visual C++
public:
void ShowAllAppointments()

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


TimeSlotItem Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem Properties
TimeSlotItem Class See Also Send Feedback

The TimeSlotItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
DayName | In Month view gets the displayed day name of this time slot.
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsInMonthView | Get whether the time slot item belongs to a month view scheduler presenter.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
MonthDay | In Month view combines the month and day names of this time slot.
MonthName | In Month view gets the displayed month name of this time slot.
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
ShowMoreButtonVisibility | In Month or Timeline view gets the Visibility of the 'show more' button.
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the TimeSlotItem control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


DayName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.DayName Property
TimeSlotItem Class See Also Send Feedback
In Month view gets the displayed day name of this time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayName As String
Visual C++
public:
property String^ DayName {
    String^ get ();
}

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


IsInMonthView Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.IsInMonthView Property
TimeSlotItem Class See Also Send Feedback
Get whether the time slot item belongs to a month view scheduler presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public bool IsInMonthView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInMonthView As Boolean
Visual C++
public:
property bool IsInMonthView {
    bool get ();
}

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


MonthDay Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.MonthDay Property
TimeSlotItem Class See Also Send Feedback
In Month view combines the month and day names of this time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string MonthDay { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthDay As String
Visual C++
public:
property String^ MonthDay {
    String^ get ();
}

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


MonthName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.MonthName Property
TimeSlotItem Class See Also Send Feedback
In Month view gets the displayed month name of this time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string MonthName { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthName As String
Visual C++
public:
property String^ MonthName {
    String^ get ();
}

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


ShowMoreButtonVisibility Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.ShowMoreButtonVisibility Property
TimeSlotItem Class See Also Send Feedback
In Month or Timeline view gets the Visibility of the 'show more' button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Visibility ShowMoreButtonVisibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowMoreButtonVisibility As Visibility
Visual C++
public:
property Visibility ShowMoreButtonVisibility {
    Visibility get ();
}

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TimeSlotItem..::.XamlTag Property
TimeSlotItem Class See Also Send Feedback
Get the xaml tag of the TimeSlotItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

TimeSlotItem Class
Telerik.WebAii.Controls.Xaml Namespace


ToolBarElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames Class
Members See Also Send Feedback
Represents the ToolBar/ToolBarTray important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class ToolBarElementNames
Visual Basic (Declaration)
Public NotInheritable Class ToolBarElementNames
Visual C++
public ref class ToolBarElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.ToolBarElementNames

See Also

ToolBarElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


ToolBarElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames Members
ToolBarElementNames Class Fields See Also Send Feedback

The ToolBarElementNames type exposes the following members.

Fields

Name | Description
ItemsStipPanelName | The ToolBar items panel holder element name.
OverflowDropDownButtonName | The ToolBar overflow items dropdown button element name.
OverflowPanelName | The ToolBar overflow popup panel name.
OverflowPopupName | The ToolBar overflow popup element name.
TrayBandPanelName | The ToolBarTray band panel element name.

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToolBarElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames Fields
ToolBarElementNames Class See Also Send Feedback

The ToolBarElementNames type exposes the following members.

Fields

Name | Description
ItemsStipPanelName | The ToolBar items panel holder element name.
OverflowDropDownButtonName | The ToolBar overflow items dropdown button element name.
OverflowPanelName | The ToolBar overflow popup panel name.
OverflowPopupName | The ToolBar overflow popup element name.
TrayBandPanelName | The ToolBarTray band panel element name.

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemsStipPanelName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames..::.ItemsStipPanelName Field
ToolBarElementNames Class See Also Send Feedback
The ToolBar items panel holder element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemsStipPanelName
Visual Basic (Declaration)
Public Const ItemsStipPanelName As String
Visual C++
public:
literal String^ ItemsStipPanelName

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


OverflowDropDownButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames..::.OverflowDropDownButtonName Field
ToolBarElementNames Class See Also Send Feedback
The ToolBar overflow items dropdown button element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string OverflowDropDownButtonName
Visual Basic (Declaration)
Public Const OverflowDropDownButtonName As String
Visual C++
public:
literal String^ OverflowDropDownButtonName

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


OverflowPanelName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames..::.OverflowPanelName Field
ToolBarElementNames Class See Also Send Feedback
The ToolBar overflow popup panel name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string OverflowPanelName
Visual Basic (Declaration)
Public Const OverflowPanelName As String
Visual C++
public:
literal String^ OverflowPanelName

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


OverflowPopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames..::.OverflowPopupName Field
ToolBarElementNames Class See Also Send Feedback
The ToolBar overflow popup element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string OverflowPopupName
Visual Basic (Declaration)
Public Const OverflowPopupName As String
Visual C++
public:
literal String^ OverflowPopupName

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TrayBandPanelName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolBarElementNames..::.TrayBandPanelName Field
ToolBarElementNames Class See Also Send Feedback
The ToolBarTray band panel element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TrayBandPanelName
Visual Basic (Declaration)
Public Const TrayBandPanelName As String
Visual C++
public:
literal String^ TrayBandPanelName

See Also

ToolBarElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindow Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight ToolWindow control wrapper. The tool window always contains a single SplitContainer instance that may hold other containers or pane groups.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ToolWindow : ContentControl
Visual Basic (Declaration)
Public Class ToolWindow _
    Inherits ContentControl
Visual C++
public ref class ToolWindow : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml..::.ToolWindow

See Also

ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


ToolWindow Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow Members
ToolWindow Class Constructors Methods Properties See Also Send Feedback

The ToolWindow type exposes the following members.

Constructors

Name | Description
ToolWindow | Initializes a new instance of the ToolWindow class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button to close the tool window.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking ToolWindow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveAwayFromContainerCenter | Overloaded.
MoveBy | Moves the ToolWindow by the given offset values.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderElement | Get the tool window header element.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalOffset | Get the value providing the horizontal offset of the window via automation property.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the tool window title.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalOffset | Get the value providing the vertical offset of the window via automation property.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
VisibleRectangle | Get the visible screen rectangle of the tool window.
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the tool window control xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindow Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow Constructor
ToolWindow Class See Also Send Feedback
Initializes a new instance of the ToolWindow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ToolWindow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolWindow()

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


ToolWindow Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow Methods
ToolWindow Class See Also Send Feedback

The ToolWindow type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button to close the tool window.
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the RadDocking ToolWindow control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveAwayFromContainerCenter | Overloaded.
MoveBy | Moves the ToolWindow by the given offset values.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.AnySibling Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


Close Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.Close Method
ToolWindow Class See Also Send Feedback
Simulates user clicking on the close button to close the tool window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.GetProperty Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.GetRectangle Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.Highlight Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.InitializeMappings Method
ToolWindow Class See Also Send Feedback
Initializes the mapping of the RadDocking ToolWindow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.InvokeMethod Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


MoveAwayFromContainerCenter Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.MoveAwayFromContainerCenter Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
MoveAwayFromContainerCenter(RadSplitContainer) | Moves the window away from the container it covers so that one can dock controls into that container.
MoveAwayFromContainerCenter(RadSplitContainer, DockingDragDirection) | Moves the window away from the container it covers so that one can dock controls into that container.
MoveAwayFromContainerCenter(RadSplitContainer, DockingDragDirection, Int32) | Moves the window away from the container it covers so that one can dock controls into that container.

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


MoveAwayFromContainerCenter Method (RadSplitContainer)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.MoveAwayFromContainerCenter Method (RadSplitContainer)
ToolWindow Class See Also Send Feedback
Moves the window away from the container it covers so that one can dock controls into that container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveAwayFromContainerCenter(
    RadSplitContainer container
)
Visual Basic (Declaration)
Public Sub MoveAwayFromContainerCenter ( _
    container As RadSplitContainer _
)
Visual C++
public:
void MoveAwayFromContainerCenter(
    RadSplitContainer^ container
)

Parameters

container
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container.

See Also

ToolWindow Class
MoveAwayFromContainerCenter Overload
Telerik.WebAii.Controls.Xaml Namespace


MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection)
ToolWindow Class See Also Send Feedback
Moves the window away from the container it covers so that one can dock controls into that container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveAwayFromContainerCenter(
    RadSplitContainer container,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub MoveAwayFromContainerCenter ( _
    container As RadSplitContainer, _
    direction As DockingDragDirection _
)
Visual C++
public:
void MoveAwayFromContainerCenter(
    RadSplitContainer^ container,
    DockingDragDirection direction
)

Parameters

container
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target split container.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The docking drag direction to move the tool window on.

See Also

ToolWindow Class
MoveAwayFromContainerCenter Overload
Telerik.WebAii.Controls.Xaml Namespace


MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection, Int32)

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection, Int32)
ToolWindow Class See Also Send Feedback
Moves the window away from the container it covers so that one can dock controls into that container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveAwayFromContainerCenter(
    RadSplitContainer container,
    DockingDragDirection direction,
    int offset
)
Visual Basic (Declaration)
Public Sub MoveAwayFromContainerCenter ( _
    container As RadSplitContainer, _
    direction As DockingDragDirection, _
    offset As Integer _
)
Visual C++
public:
void MoveAwayFromContainerCenter(
    RadSplitContainer^ container,
    DockingDragDirection direction,
    int offset
)

Parameters

container
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target split container.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The docking drag direction to move the tool window on.
offset
Type: System..::.Int32
The offset in pixels to move the tool window with.

See Also

ToolWindow Class
MoveAwayFromContainerCenter Overload
Telerik.WebAii.Controls.Xaml Namespace


MoveBy Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.MoveBy Method
ToolWindow Class See Also Send Feedback
Moves the ToolWindow by the given offset values.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public void MoveBy(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub MoveBy ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void MoveBy(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The offset to move by X.
offsetByY
Type: System..::.Int32
The offset to move by Y.

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.NextSibling Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.Parent Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.PreviousSibling Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.ScrollToVisible Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members
Telerik.WebAii.Controls.Xaml Namespace


ToolWindow Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow Properties
ToolWindow Class See Also Send Feedback

The ToolWindow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderElement | Get the tool window header element.
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalOffset | Get the value providing the horizontal offset of the window via automation property.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the tool window title.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalOffset | Get the value providing the vertical offset of the window via automation property.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
VisibleRectangle | Get the visible screen rectangle of the tool window.
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the tool window control xaml tag. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


HeaderElement Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.HeaderElement Property
ToolWindow Class See Also Send Feedback
Get the tool window header element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Border HeaderElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderElement As Border
Visual C++
public:
property Border^ HeaderElement {
    Border^ get ();
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


HorizontalOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.HorizontalOffset Property
ToolWindow Class See Also Send Feedback
Get the value providing the horizontal offset of the window via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double HorizontalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalOffset As Double
Visual C++
public:
property double HorizontalOffset {
    double get ();
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


SplitContainer Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.SplitContainer Property
ToolWindow Class See Also Send Feedback
Get the split container element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RadSplitContainer SplitContainer { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainer As RadSplitContainer
Visual C++
public:
property RadSplitContainer^ SplitContainer {
    RadSplitContainer^ get ();
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.Title Property
ToolWindow Class See Also Send Feedback
Get the tool window title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


VerticalOffset Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.VerticalOffset Property
ToolWindow Class See Also Send Feedback
Get the value providing the vertical offset of the window via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double VerticalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalOffset As Double
Visual C++
public:
property double VerticalOffset {
    double get ();
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


VisibleRectangle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.VisibleRectangle Property
ToolWindow Class See Also Send Feedback
Get the visible screen rectangle of the tool window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Rectangle VisibleRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibleRectangle As Rectangle
Visual C++
public:
property Rectangle VisibleRectangle {
    Rectangle get ();
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ToolWindow..::.XamlTag Property
ToolWindow Class See Also Send Feedback
Get the tool window control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ToolWindow Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames Class
Members See Also Send Feedback
Represents the TreeListView important element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TreeListViewElementNames
Visual Basic (Declaration)
Public NotInheritable Class TreeListViewElementNames
Visual C++
public ref class TreeListViewElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.TreeListViewElementNames

See Also

TreeListViewElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames Members
TreeListViewElementNames Class Fields See Also Send Feedback

The TreeListViewElementNames type exposes the following members.

Fields

Name | Description
CellEditPopupName | The TreeListView RadCell edit popup name.
ColumnHeaderElementName | The TreeListView RadColumn header element name.
ColumnResizeElementName | The TreeListView RadColumn resize element name.
ColumnViewElementName | The TreeListView ColumnView element name.

See Also

TreeListViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TreeListViewElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames Fields
TreeListViewElementNames Class See Also Send Feedback

The TreeListViewElementNames type exposes the following members.

Fields

Name | Description
CellEditPopupName | The TreeListView RadCell edit popup name.
ColumnHeaderElementName | The TreeListView RadColumn header element name.
ColumnResizeElementName | The TreeListView RadColumn resize element name.
ColumnViewElementName | The TreeListView ColumnView element name.

See Also

TreeListViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CellEditPopupName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames..::.CellEditPopupName Field
TreeListViewElementNames Class See Also Send Feedback
The TreeListView RadCell edit popup name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CellEditPopupName
Visual Basic (Declaration)
Public Const CellEditPopupName As String
Visual C++
public:
literal String^ CellEditPopupName

See Also

TreeListViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ColumnHeaderElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames..::.ColumnHeaderElementName Field
TreeListViewElementNames Class See Also Send Feedback
The TreeListView RadColumn header element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColumnHeaderElementName
Visual Basic (Declaration)
Public Const ColumnHeaderElementName As String
Visual C++
public:
literal String^ ColumnHeaderElementName

See Also

TreeListViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ColumnResizeElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames..::.ColumnResizeElementName Field
TreeListViewElementNames Class See Also Send Feedback
The TreeListView RadColumn resize element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColumnResizeElementName
Visual Basic (Declaration)
Public Const ColumnResizeElementName As String
Visual C++
public:
literal String^ ColumnResizeElementName

See Also

TreeListViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ColumnViewElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeListViewElementNames..::.ColumnViewElementName Field
TreeListViewElementNames Class See Also Send Feedback
The TreeListView ColumnView element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ColumnViewElementName
Visual Basic (Declaration)
Public Const ColumnViewElementName As String
Visual C++
public:
literal String^ ColumnViewElementName

See Also

TreeListViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TreeViewElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames Class
Members See Also Send Feedback
Represents the TreeView and TreeViewItem important sub element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class TreeViewElementNames
Visual Basic (Declaration)
Public NotInheritable Class TreeViewElementNames
Visual C++
public ref class TreeViewElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.TreeViewElementNames

See Also

TreeViewElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


TreeViewElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames Members
TreeViewElementNames Class Fields See Also Send Feedback

The TreeViewElementNames type exposes the following members.

Fields

Name | Description
CheckBoxName | The TreeViewItem check box element name.
ItemExpanderName | The TreeViewItem expander button name.
ItemHeaderName | The TreeViewItem header element name.
ItemHeaderRowName | The TreeViewItem header row name.
ItemHostName | The TreeViewItem item host name.
RadioButtonName | The TreeViewItem radio button element name.

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TreeViewElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames Fields
TreeViewElementNames Class See Also Send Feedback

The TreeViewElementNames type exposes the following members.

Fields

Name | Description
CheckBoxName | The TreeViewItem check box element name.
ItemExpanderName | The TreeViewItem expander button name.
ItemHeaderName | The TreeViewItem header element name.
ItemHeaderRowName | The TreeViewItem header row name.
ItemHostName | The TreeViewItem item host name.
RadioButtonName | The TreeViewItem radio button element name.

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CheckBoxName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames..::.CheckBoxName Field
TreeViewElementNames Class See Also Send Feedback
The TreeViewItem check box element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CheckBoxName
Visual Basic (Declaration)
Public Const CheckBoxName As String
Visual C++
public:
literal String^ CheckBoxName

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemExpanderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames..::.ItemExpanderName Field
TreeViewElementNames Class See Also Send Feedback
The TreeViewItem expander button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemExpanderName
Visual Basic (Declaration)
Public Const ItemExpanderName As String
Visual C++
public:
literal String^ ItemExpanderName

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemHeaderName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames..::.ItemHeaderName Field
TreeViewElementNames Class See Also Send Feedback
The TreeViewItem header element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemHeaderName
Visual Basic (Declaration)
Public Const ItemHeaderName As String
Visual C++
public:
literal String^ ItemHeaderName

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemHeaderRowName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames..::.ItemHeaderRowName Field
TreeViewElementNames Class See Also Send Feedback
The TreeViewItem header row name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemHeaderRowName
Visual Basic (Declaration)
Public Const ItemHeaderRowName As String
Visual C++
public:
literal String^ ItemHeaderRowName

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemHostName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames..::.ItemHostName Field
TreeViewElementNames Class See Also Send Feedback
The TreeViewItem item host name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemHostName
Visual Basic (Declaration)
Public Const ItemHostName As String
Visual C++
public:
literal String^ ItemHostName

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


RadioButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TreeViewElementNames..::.RadioButtonName Field
TreeViewElementNames Class See Also Send Feedback
The TreeViewItem radio button element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RadioButtonName
Visual Basic (Declaration)
Public Const RadioButtonName As String
Visual C++
public:
literal String^ RadioButtonName

See Also

TreeViewElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TurnPagePosition Enumeration

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
TurnPagePosition Enumeration
See Also Send Feedback
Represents the RadBook enumeration for the possible corner positions to turn a page from.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public enum TurnPagePosition
Visual Basic (Declaration)
Public Enumeration TurnPagePosition
Visual C++
public enum class TurnPagePosition

Members

Member name | Description
LeftTop | The 'LeftTop' position.
LeftBottom | The 'LeftBottom' position.
RightTop | The 'RightTop' position.
RightBottom | The 'RightBottom' position.

See Also

Telerik.WebAii.Controls.Xaml Namespace


UploadElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames Class
Members See Also Send Feedback
Holds the list of important RadUpload element names.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class UploadElementNames
Visual Basic (Declaration)
Public NotInheritable Class UploadElementNames
Visual C++
public ref class UploadElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.UploadElementNames

See Also

UploadElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


UploadElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames Members
UploadElementNames Class Fields See Also Send Feedback

The UploadElementNames type exposes the following members.

Fields

Name | Description
BrowseButtonName | The Upload browse button name.
CancelButtonName | The Upload cancel button name.
ItemDeleteIconName | The UploadItem delete icon name.
ItemFileProgressBarName | The UploadItem progress bar name.
PauseButtonName | The Upload pause button name.
ProgressCaptionTextBlockName | The Upload progress caption text block name.
TotalPercentTextBlockName | The Upload total percent text block name.
TotalProgressAreaGridName | The Upload total progress area grid name.
TotalProgressBarName | The Upload total progress bar name.
TotalSizeTextBlockName | The Upload total size text block name.
TotalTextBlockName | The Upload total text block name.
UploadButtonName | The Upload upload button name.

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


UploadElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames Fields
UploadElementNames Class See Also Send Feedback

The UploadElementNames type exposes the following members.

Fields

Name | Description
BrowseButtonName | The Upload browse button name.
CancelButtonName | The Upload cancel button name.
ItemDeleteIconName | The UploadItem delete icon name.
ItemFileProgressBarName | The UploadItem progress bar name.
PauseButtonName | The Upload pause button name.
ProgressCaptionTextBlockName | The Upload progress caption text block name.
TotalPercentTextBlockName | The Upload total percent text block name.
TotalProgressAreaGridName | The Upload total progress area grid name.
TotalProgressBarName | The Upload total progress bar name.
TotalSizeTextBlockName | The Upload total size text block name.
TotalTextBlockName | The Upload total text block name.
UploadButtonName | The Upload upload button name.

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


BrowseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.BrowseButtonName Field
UploadElementNames Class See Also Send Feedback
The Upload browse button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string BrowseButtonName
Visual Basic (Declaration)
Public Const BrowseButtonName As String
Visual C++
public:
literal String^ BrowseButtonName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CancelButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.CancelButtonName Field
UploadElementNames Class See Also Send Feedback
The Upload cancel button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CancelButtonName
Visual Basic (Declaration)
Public Const CancelButtonName As String
Visual C++
public:
literal String^ CancelButtonName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemDeleteIconName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.ItemDeleteIconName Field
UploadElementNames Class See Also Send Feedback
The UploadItem delete icon name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemDeleteIconName
Visual Basic (Declaration)
Public Const ItemDeleteIconName As String
Visual C++
public:
literal String^ ItemDeleteIconName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ItemFileProgressBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.ItemFileProgressBarName Field
UploadElementNames Class See Also Send Feedback
The UploadItem progress bar name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ItemFileProgressBarName
Visual Basic (Declaration)
Public Const ItemFileProgressBarName As String
Visual C++
public:
literal String^ ItemFileProgressBarName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


PauseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.PauseButtonName Field
UploadElementNames Class See Also Send Feedback
The Upload pause button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string PauseButtonName
Visual Basic (Declaration)
Public Const PauseButtonName As String
Visual C++
public:
literal String^ PauseButtonName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ProgressCaptionTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.ProgressCaptionTextBlockName Field
UploadElementNames Class See Also Send Feedback
The Upload progress caption text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ProgressCaptionTextBlockName
Visual Basic (Declaration)
Public Const ProgressCaptionTextBlockName As String
Visual C++
public:
literal String^ ProgressCaptionTextBlockName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TotalPercentTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.TotalPercentTextBlockName Field
UploadElementNames Class See Also Send Feedback
The Upload total percent text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TotalPercentTextBlockName
Visual Basic (Declaration)
Public Const TotalPercentTextBlockName As String
Visual C++
public:
literal String^ TotalPercentTextBlockName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TotalProgressAreaGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.TotalProgressAreaGridName Field
UploadElementNames Class See Also Send Feedback
The Upload total progress area grid name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TotalProgressAreaGridName
Visual Basic (Declaration)
Public Const TotalProgressAreaGridName As String
Visual C++
public:
literal String^ TotalProgressAreaGridName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TotalProgressBarName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.TotalProgressBarName Field
UploadElementNames Class See Also Send Feedback
The Upload total progress bar name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TotalProgressBarName
Visual Basic (Declaration)
Public Const TotalProgressBarName As String
Visual C++
public:
literal String^ TotalProgressBarName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TotalSizeTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.TotalSizeTextBlockName Field
UploadElementNames Class See Also Send Feedback
The Upload total size text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TotalSizeTextBlockName
Visual Basic (Declaration)
Public Const TotalSizeTextBlockName As String
Visual C++
public:
literal String^ TotalSizeTextBlockName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TotalTextBlockName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.TotalTextBlockName Field
UploadElementNames Class See Also Send Feedback
The Upload total text block name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TotalTextBlockName
Visual Basic (Declaration)
Public Const TotalTextBlockName As String
Visual C++
public:
literal String^ TotalTextBlockName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


UploadButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
UploadElementNames..::.UploadButtonName Field
UploadElementNames Class See Also Send Feedback
The Upload upload button name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string UploadButtonName
Visual Basic (Declaration)
Public Const UploadButtonName As String
Visual C++
public:
literal String^ UploadButtonName

See Also

UploadElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowElementNames Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames Class
Members See Also Send Feedback
Represents a list of RadWindow element names used accross the wrappers.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public static class WindowElementNames
Visual Basic (Declaration)
Public NotInheritable Class WindowElementNames
Visual C++
public ref class WindowElementNames abstract sealed

Inheritance Hierarchy

System..::.Object
Telerik.WebAii.Controls.Xaml..::.WindowElementNames

See Also

WindowElementNames Members
Telerik.WebAii.Controls.Xaml Namespace


WindowElementNames Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames Members
WindowElementNames Class Fields See Also Send Feedback

The WindowElementNames type exposes the following members.

Fields

Name | Description
CloseButtonName | The Window 'Close' button element name.
ContentPresenterElementName | The Window ContentPresent element name.
MaximizeButtonName | The Window 'Maximize' button element name.
MinimizeButtonName | The Window 'Minimize' button element name.
ResizeDownLeftThumbName | The Window resizing 'DownLeft' thumb element name.
ResizeDownRightThumbName | The Window resizing 'DownRight' thumb element name.
ResizeDownThumbName | The Window resizing 'Down' thumb element name.
ResizeLeftThumbName | The Window resizing 'Left' thumb element name.
ResizeRightThumbName | The Window resizing 'Right' thumb element name.
ResizeUpLeftThumbName | The Window resizing 'UpLeft' thumb element name.
ResizeUpRightThumbName | The Window resizing 'UpRight' thumb element name.
ResizeUpThumbName | The Window resizing 'Up' thumb element name.
RestoreButtonName | The Window 'Restore' button element name.
TitlePresenterGridName | The Window title presenter grid name.
TitleThumbName | The Window title thumb element name.

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowElementNames Fields

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames Fields
WindowElementNames Class See Also Send Feedback

The WindowElementNames type exposes the following members.

Fields

Name | Description
CloseButtonName | The Window 'Close' button element name.
ContentPresenterElementName | The Window ContentPresent element name.
MaximizeButtonName | The Window 'Maximize' button element name.
MinimizeButtonName | The Window 'Minimize' button element name.
ResizeDownLeftThumbName | The Window resizing 'DownLeft' thumb element name.
ResizeDownRightThumbName | The Window resizing 'DownRight' thumb element name.
ResizeDownThumbName | The Window resizing 'Down' thumb element name.
ResizeLeftThumbName | The Window resizing 'Left' thumb element name.
ResizeRightThumbName | The Window resizing 'Right' thumb element name.
ResizeUpLeftThumbName | The Window resizing 'UpLeft' thumb element name.
ResizeUpRightThumbName | The Window resizing 'UpRight' thumb element name.
ResizeUpThumbName | The Window resizing 'Up' thumb element name.
RestoreButtonName | The Window 'Restore' button element name.
TitlePresenterGridName | The Window title presenter grid name.
TitleThumbName | The Window title thumb element name.

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


CloseButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.CloseButtonName Field
WindowElementNames Class See Also Send Feedback
The Window 'Close' button element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string CloseButtonName
Visual Basic (Declaration)
Public Const CloseButtonName As String
Visual C++
public:
literal String^ CloseButtonName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ContentPresenterElementName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ContentPresenterElementName Field
WindowElementNames Class See Also Send Feedback
The Window ContentPresent element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ContentPresenterElementName
Visual Basic (Declaration)
Public Const ContentPresenterElementName As String
Visual C++
public:
literal String^ ContentPresenterElementName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MaximizeButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.MaximizeButtonName Field
WindowElementNames Class See Also Send Feedback
The Window 'Maximize' button element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MaximizeButtonName
Visual Basic (Declaration)
Public Const MaximizeButtonName As String
Visual C++
public:
literal String^ MaximizeButtonName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


MinimizeButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.MinimizeButtonName Field
WindowElementNames Class See Also Send Feedback
The Window 'Minimize' button element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string MinimizeButtonName
Visual Basic (Declaration)
Public Const MinimizeButtonName As String
Visual C++
public:
literal String^ MinimizeButtonName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeDownLeftThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeDownLeftThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'DownLeft' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeDownLeftThumbName
Visual Basic (Declaration)
Public Const ResizeDownLeftThumbName As String
Visual C++
public:
literal String^ ResizeDownLeftThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeDownRightThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeDownRightThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'DownRight' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeDownRightThumbName
Visual Basic (Declaration)
Public Const ResizeDownRightThumbName As String
Visual C++
public:
literal String^ ResizeDownRightThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeDownThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeDownThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'Down' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeDownThumbName
Visual Basic (Declaration)
Public Const ResizeDownThumbName As String
Visual C++
public:
literal String^ ResizeDownThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeLeftThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeLeftThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'Left' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeLeftThumbName
Visual Basic (Declaration)
Public Const ResizeLeftThumbName As String
Visual C++
public:
literal String^ ResizeLeftThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeRightThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeRightThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'Right' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeRightThumbName
Visual Basic (Declaration)
Public Const ResizeRightThumbName As String
Visual C++
public:
literal String^ ResizeRightThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeUpLeftThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeUpLeftThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'UpLeft' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeUpLeftThumbName
Visual Basic (Declaration)
Public Const ResizeUpLeftThumbName As String
Visual C++
public:
literal String^ ResizeUpLeftThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeUpRightThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeUpRightThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'UpRight' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeUpRightThumbName
Visual Basic (Declaration)
Public Const ResizeUpRightThumbName As String
Visual C++
public:
literal String^ ResizeUpRightThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


ResizeUpThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.ResizeUpThumbName Field
WindowElementNames Class See Also Send Feedback
The Window resizing 'Up' thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string ResizeUpThumbName
Visual Basic (Declaration)
Public Const ResizeUpThumbName As String
Visual C++
public:
literal String^ ResizeUpThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


RestoreButtonName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.RestoreButtonName Field
WindowElementNames Class See Also Send Feedback
The Window 'Restore' button element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string RestoreButtonName
Visual Basic (Declaration)
Public Const RestoreButtonName As String
Visual C++
public:
literal String^ RestoreButtonName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TitlePresenterGridName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.TitlePresenterGridName Field
WindowElementNames Class See Also Send Feedback
The Window title presenter grid name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TitlePresenterGridName
Visual Basic (Declaration)
Public Const TitlePresenterGridName As String
Visual C++
public:
literal String^ TitlePresenterGridName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


TitleThumbName Field

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowElementNames..::.TitleThumbName Field
WindowElementNames Class See Also Send Feedback
The Window title thumb element name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public const string TitleThumbName
Visual Basic (Declaration)
Public Const TitleThumbName As String
Visual C++
public:
literal String^ TitleThumbName

See Also

WindowElementNames Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitle Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle Class
Members See Also Send Feedback
Represents the Silverlight WindowTitle control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class WindowTitle : Control
Visual Basic (Declaration)
Public Class WindowTitle _
    Inherits Control
Visual C++
public ref class WindowTitle : public Control

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.Control
Telerik.WebAii.Controls.Xaml..::.WindowTitle

See Also

WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


WindowTitle Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle Members
WindowTitle Class Constructors Methods Properties See Also Send Feedback

The WindowTitle type exposes the following members.

Constructors

Name | Description
WindowTitle | Initializes a new instance of the WindowTitle class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the WindowTitle control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
ApplicationName | Get the WindowTitle application name text.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Divider | Get the WindowTitle divider text.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the complete text of the window title.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the WindowTitle title text.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of WindowTitle control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitle Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle Constructor
WindowTitle Class See Also Send Feedback
Initializes a new instance of the WindowTitle class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public WindowTitle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WindowTitle()

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


WindowTitle Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle Methods
WindowTitle Class See Also Send Feedback

The WindowTitle type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of the WindowTitle control. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.AnySibling Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.GetProperty Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.GetRectangle Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.Highlight Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.InitializeMappings Method
WindowTitle Class See Also Send Feedback
Initializes the mapping of the WindowTitle control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.InvokeMethod Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.NextSibling Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.Parent Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.PreviousSibling Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.ScrollToVisible Method
WindowTitle Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

WindowTitle Class
WindowTitle Members
Telerik.WebAii.Controls.Xaml Namespace


WindowTitle Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle Properties
WindowTitle Class See Also Send Feedback

The WindowTitle type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
ApplicationName | Get the WindowTitle application name text.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Divider | Get the WindowTitle divider text.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Text | Get the complete text of the window title.
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
Title | Get the WindowTitle title text.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of WindowTitle control. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


ApplicationName Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.ApplicationName Property
WindowTitle Class See Also Send Feedback
Get the WindowTitle application name text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string ApplicationName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationName As String
Visual C++
public:
property String^ ApplicationName {
    String^ get ();
}

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


Divider Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.Divider Property
WindowTitle Class See Also Send Feedback
Get the WindowTitle divider text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Divider { get; }
Visual Basic (Declaration)
Public ReadOnly Property Divider As String
Visual C++
public:
property String^ Divider {
    String^ get ();
}

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


Text Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.Text Property
WindowTitle Class See Also Send Feedback
Get the complete text of the window title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


Title Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.Title Property
WindowTitle Class See Also Send Feedback
Get the WindowTitle title text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
WindowTitle..::.XamlTag Property
WindowTitle Class See Also Send Feedback
Get the xaml tag of WindowTitle control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

WindowTitle Class
Telerik.WebAii.Controls.Xaml Namespace


Telerik.WebAii.Controls.Xaml.Charting.Series Namespace

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace
Send Feedback
Contains the WebAii Charting Series Controls for Silverlight.

Classes

Class | Description
AreaChartSeriesList | The holder of the area series.
ChartSeries | The holder of the bar, line, etc. series.
ChartSeriesArea | Represents the RadChart for Silverlight ChartSeriesArea control wrapper.
ChartSeriesBar | Represents the RadChart for Silverlight ChartSeriesBar control wrapper.
ChartSeriesBubble | Represents the RadChart for Silverlight ChartSeriesBubble control wrapper.
ChartSeriesCandleStick | Represents the RadChart for Silverlight ChartSeriesCandleStick control wrapper.
ChartSeriesDoughnut | Represents the RadChart for Silverlight ChartSeriesDoughnut control wrapper.
ChartSeriesHorizontalBar | Represents the RadChart for Silverlight ChartSeriesHorizontalBar control wrapper.
ChartSeriesHorizontalStackedBar | Represents the RadChart for Silverlight ChartSeriesHorizontalStackedBar control wrapper.
ChartSeriesHorizontalStackedBar100 | Represents the RadChart for Silverlight ChartSeriesHorizontalStackedBar100 control wrapper.
ChartSeriesLine | Represents the RadChart for Silverlight ChartSeriesLine control wrapper.
ChartSeriesPie | Represents the RadChart for Silverlight ChartSeriesPie control wrapper.
ChartSeriesRange | Represents the RadChart for Silverlight ChartSeriesRange control wrapper.
ChartSeriesSpline | Represents the RadChart for Silverlight ChartSeriesSpline control wrapper.
ChartSeriesSplineArea | Represents the RadChart for Silverlight ChartSeriesSplineArea control wrapper.
ChartSeriesSplineRange | Represents the RadChart for Silverlight ChartSeriesSplineRange control wrapper.
ChartSeriesStackedArea | Represents the RadChart for Silverlight ChartSeriesStackedArea control wrapper.
ChartSeriesStackedArea100 | Represents the RadChart for Silverlight ChartSeriesStackedArea100 control wrapper.
ChartSeriesStackedBar | Represents the RadChart for Silverlight ChartSeriesStackedBar control wrapper.
ChartSeriesStackedBar100 | Represents the RadChart for Silverlight ChartSeriesStackedBar100 control wrapper.
ChartSeriesStackedLine | Represents the RadChart for Silverlight ChartSeriesStackedLine control wrapper.
ChartSeriesStackedSpline | Represents the RadChart for Silverlight ChartSeriesStackedSpline control wrapper.
ChartSeriesStackedSplineArea | Represents the RadChart for Silverlight ChartSeriesStackedSplineArea control wrapper.
ChartSeriesStackedSplineArea100 | Represents the RadChart for Silverlight ChartSeriesStackedSplineArea100 control wrapper.
ChartSeriesStick | Represents the RadChart for Silverlight ChartSeriesStick control wrapper.
LineChartSeriesList | The holder of the line series.
ParametricLine | Represents the RadChart for Silverlight ParametricLine control wrapper.
RangeChartSeriesList | The holder of the Range series.
SplineAreaChartSeriesList | The holder of the SplineArea series.
SplineChartSeriesList | The holder of the Spline series.
SplineRangeChartSeriesList | The holder of the SplineRange series.
StackedArea100ChartSeriesList | The holder of the StackedArea100 series.
StackedAreaChartSeriesList | The holder of the StackedArea series.
StackedLineChartSeriesList | The holder of the stacked line series.
StackedSplineArea100ChartSeriesList | The holder of the Stacked Spline Area 100 series.
StackedSplineAreaChartSeriesList | The holder of the Stacked Spline Area series.
StackedSplineChartSeriesList | The holder of the Stacked Spline series.


AreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList Class
Members See Also Send Feedback
The holder of the area series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class AreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class AreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class AreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.AreaChartSeriesList

See Also

AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList Members
AreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The AreaChartSeriesList type exposes the following members.

Constructors

Name | Description
AreaChartSeriesList | Initializes a new instance of the AreaChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaList | Get the list of Chart area series.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList Constructor
AreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the AreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public AreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaChartSeriesList()

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList Methods
AreaChartSeriesList Class See Also Send Feedback

The AreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of AreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.AnySibling Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.GetProperty Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.GetRectangle Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.Highlight Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.InitializeMappings Method
AreaChartSeriesList Class See Also Send Feedback
Initializes the mapping of AreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.InvokeMethod Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.NextSibling Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.Parent Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.PreviousSibling Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.ScrollToVisible Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList Properties
AreaChartSeriesList Class See Also Send Feedback

The AreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaList | Get the list of Chart area series.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of AreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.AreaList Property
AreaChartSeriesList Class See Also Send Feedback
Get the list of Chart area series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesArea> AreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaList As IList(Of ChartSeriesArea)
Visual C++
public:
property IList<ChartSeriesArea^>^ AreaList {
    IList<ChartSeriesArea^>^ get ();
}

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
AreaChartSeriesList..::.XamlTag Property
AreaChartSeriesList Class See Also Send Feedback
Get the xaml tag of AreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries Class
Members See Also Send Feedback
The holder of the bar, line, etc. series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeries : ItemsControl
Visual Basic (Declaration)
Public Class ChartSeries _
    Inherits ItemsControl
Visual C++
public ref class ChartSeries : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeries

See Also

ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries Members
ChartSeries Class Constructors Methods Properties See Also Send Feedback

The ChartSeries type exposes the following members.

Constructors

Name | Description
ChartSeries | Initializes a new instance of the ChartSeries class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Series. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BarList | Get the list of Chart bar series.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BubbleList | Get the list of Chart bubble series.
CandleStickList | Get the list of Chart candle stick series.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DoughnutList | Get the list of Chart doughnut series.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarList | Get the list of Chart horizontal bar series.
HorizontalContentAlignment | (Inherited from ItemsControl.)
HorizontalStackedBar100List | Get the list of Chart Horizontal stackedBar100 series.
HorizontalStackedBarList | Get the list of Chart horizontalStackedBar series.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PieList | Get the list of Chart pie series.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedBar100List | Get the list of Chart stackedBar100 series.
StackedBarList | Get the list of Chart stackedBar series.
StickList | Get the list of Chart stick series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Series. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries Constructor
ChartSeries Class See Also Send Feedback
Initializes a new instance of the ChartSeries class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeries()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeries()

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries Methods
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Series. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.AnySibling Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.AssignReference Method
ChartSeries Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeries.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.GetProperty Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.GetRectangle Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.Highlight Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.InitializeMappings Method
ChartSeries Class See Also Send Feedback
Initializes the mapping of Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.InvokeMethod Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.NextSibling Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.Parent Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.PreviousSibling Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.ScrollToVisible Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries Properties
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BarList | Get the list of Chart bar series.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BubbleList | Get the list of Chart bubble series.
CandleStickList | Get the list of Chart candle stick series.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DoughnutList | Get the list of Chart doughnut series.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarList | Get the list of Chart horizontal bar series.
HorizontalContentAlignment | (Inherited from ItemsControl.)
HorizontalStackedBar100List | Get the list of Chart Horizontal stackedBar100 series.
HorizontalStackedBarList | Get the list of Chart horizontalStackedBar series.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PieList | Get the list of Chart pie series.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedBar100List | Get the list of Chart stackedBar100 series.
StackedBarList | Get the list of Chart stackedBar series.
StickList | Get the list of Chart stick series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Series. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.BarList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart bar series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesBar> BarList { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarList As IList(Of ChartSeriesBar)
Visual C++
public:
property IList<ChartSeriesBar^>^ BarList {
    IList<ChartSeriesBar^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BubbleList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.BubbleList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart bubble series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesBubble> BubbleList { get; }
Visual Basic (Declaration)
Public ReadOnly Property BubbleList As IList(Of ChartSeriesBubble)
Visual C++
public:
property IList<ChartSeriesBubble^>^ BubbleList {
    IList<ChartSeriesBubble^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CandleStickList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.CandleStickList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart candle stick series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesCandleStick> CandleStickList { get; }
Visual Basic (Declaration)
Public ReadOnly Property CandleStickList As IList(Of ChartSeriesCandleStick)
Visual C++
public:
property IList<ChartSeriesCandleStick^>^ CandleStickList {
    IList<ChartSeriesCandleStick^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.DoughnutList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart doughnut series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesDoughnut> DoughnutList { get; }
Visual Basic (Declaration)
Public ReadOnly Property DoughnutList As IList(Of ChartSeriesDoughnut)
Visual C++
public:
property IList<ChartSeriesDoughnut^>^ DoughnutList {
    IList<ChartSeriesDoughnut^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


HorizontalBarList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.HorizontalBarList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart horizontal bar series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesHorizontalBar> HorizontalBarList { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalBarList As IList(Of ChartSeriesHorizontalBar)
Visual C++
public:
property IList<ChartSeriesHorizontalBar^>^ HorizontalBarList {
    IList<ChartSeriesHorizontalBar^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


HorizontalStackedBar100List Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.HorizontalStackedBar100List Property
ChartSeries Class See Also Send Feedback
Get the list of Chart Horizontal stackedBar100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesHorizontalStackedBar100> HorizontalStackedBar100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalStackedBar100List As IList(Of ChartSeriesHorizontalStackedBar100)
Visual C++
public:
property IList<ChartSeriesHorizontalStackedBar100^>^ HorizontalStackedBar100List {
    IList<ChartSeriesHorizontalStackedBar100^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


HorizontalStackedBarList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.HorizontalStackedBarList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart horizontalStackedBar series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesHorizontalStackedBar> HorizontalStackedBarList { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalStackedBarList As IList(Of ChartSeriesHorizontalStackedBar)
Visual C++
public:
property IList<ChartSeriesHorizontalStackedBar^>^ HorizontalStackedBarList {
    IList<ChartSeriesHorizontalStackedBar^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.PieList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart pie series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesPie> PieList { get; }
Visual Basic (Declaration)
Public ReadOnly Property PieList As IList(Of ChartSeriesPie)
Visual C++
public:
property IList<ChartSeriesPie^>^ PieList {
    IList<ChartSeriesPie^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedBar100List Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.StackedBar100List Property
ChartSeries Class See Also Send Feedback
Get the list of Chart stackedBar100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedBar100> StackedBar100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedBar100List As IList(Of ChartSeriesStackedBar100)
Visual C++
public:
property IList<ChartSeriesStackedBar100^>^ StackedBar100List {
    IList<ChartSeriesStackedBar100^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedBarList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.StackedBarList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart stackedBar series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedBar> StackedBarList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedBarList As IList(Of ChartSeriesStackedBar)
Visual C++
public:
property IList<ChartSeriesStackedBar^>^ StackedBarList {
    IList<ChartSeriesStackedBar^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StickList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.StickList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart stick series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStick> StickList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StickList As IList(Of ChartSeriesStick)
Visual C++
public:
property IList<ChartSeriesStick^>^ StickList {
    IList<ChartSeriesStick^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeries..::.XamlTag Property
ChartSeries Class See Also Send Feedback
Get the xaml tag of Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesArea : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesArea _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesArea : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedArea100

See Also

ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea Members
ChartSeriesArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesArea type exposes the following members.

Constructors

Name | Description
ChartSeriesArea | Initializes a new instance of the ChartSeriesArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Area. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point.
EndPointX | Get the area end point x.
EndPointY | Get the area end point y.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point.
StartPointX | Get the area start point x.
StartPointY | Get the area start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Area. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea Constructor
ChartSeriesArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesArea()

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea Methods
ChartSeriesArea Class See Also Send Feedback

The ChartSeriesArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Area. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.AnySibling Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.AssignReference Method
ChartSeriesArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.GetProperty Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.GetRectangle Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.Highlight Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.InitializeMappings Method
ChartSeriesArea Class See Also Send Feedback
Initializes the mapping of Area.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.InvokeMethod Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.NextSibling Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.Parent Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.PreviousSibling Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.ScrollToVisible Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea Properties
ChartSeriesArea Class See Also Send Feedback

The ChartSeriesArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point.
EndPointX | Get the area end point x.
EndPointY | Get the area end point y.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point.
StartPointX | Get the area start point x.
StartPointY | Get the area start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Area. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.AreaSeriesColorValue Property
ChartSeriesArea Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string AreaSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaSeriesColorValue As String
Visual C++
public:
property String^ AreaSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.Color Property
ChartSeriesArea Class See Also Send Feedback
Get the area color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.EndPoint Property
ChartSeriesArea Class See Also Send Feedback
Get the area end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.EndPointX Property
ChartSeriesArea Class See Also Send Feedback
Get the area end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.EndPointY Property
ChartSeriesArea Class See Also Send Feedback
Get the area end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.LabelText Property
ChartSeriesArea Class See Also Send Feedback
Get the area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public virtual string LabelText { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LabelText As String
Visual C++
public:
virtual property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.StartPoint Property
ChartSeriesArea Class See Also Send Feedback
Get the area start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.StartPointX Property
ChartSeriesArea Class See Also Send Feedback
Get the area start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.StartPointY Property
ChartSeriesArea Class See Also Send Feedback
Get the area start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesArea..::.XamlTag Property
ChartSeriesArea Class See Also Send Feedback
Get the xaml tag of Area.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesBar : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesBar _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesBar : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedBar100

See Also

ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar Members
ChartSeriesBar Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesBar type exposes the following members.

Constructors

Name | Description
ChartSeriesBar | Initializes a new instance of the ChartSeriesBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Bar. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the bar height.
BarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
BarWidth | Get the bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Bar. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar Constructor
ChartSeriesBar Class See Also Send Feedback
Initializes a new instance of the ChartSeriesBar class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesBar()

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar Methods
ChartSeriesBar Class See Also Send Feedback

The ChartSeriesBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Bar. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.AnySibling Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.AssignReference Method
ChartSeriesBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.GetProperty Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.GetRectangle Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.Highlight Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.InitializeMappings Method
ChartSeriesBar Class See Also Send Feedback
Initializes the mapping of Bar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.InvokeMethod Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.NextSibling Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.Parent Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.PreviousSibling Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.ScrollToVisible Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar Properties
ChartSeriesBar Class See Also Send Feedback

The ChartSeriesBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the bar height.
BarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
BarWidth | Get the bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Bar. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.BarHeight Property
ChartSeriesBar Class See Also Send Feedback
Get the bar height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.BarSeriesColorValue Property
ChartSeriesBar Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string BarSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarSeriesColorValue As String
Visual C++
public:
property String^ BarSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.BarWidth Property
ChartSeriesBar Class See Also Send Feedback
Get the bar width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.Color Property
ChartSeriesBar Class See Also Send Feedback
Get the bar color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.LabelText Property
ChartSeriesBar Class See Also Send Feedback
Get the bar label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBar..::.XamlTag Property
ChartSeriesBar Class See Also Send Feedback
Get the xaml tag of Bar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesBubble control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesBubble : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesBubble _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesBubble : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesBubble

See Also

ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble Members
ChartSeriesBubble Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesBubble type exposes the following members.

Constructors

Name | Description
ChartSeriesBubble | Initializes a new instance of the ChartSeriesBubble class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Bubble. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BubbleRadius | Get the bubble radius.
BubbleSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Center | Get the bubble center point.
CenterPoint | Get the center point property.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the bubble color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Radius | Get the bubble radius.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Bubble. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble Constructor
ChartSeriesBubble Class See Also Send Feedback
Initializes a new instance of the ChartSeriesBubble class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesBubble()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesBubble()

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble Methods
ChartSeriesBubble Class See Also Send Feedback

The ChartSeriesBubble type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Bubble. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.AnySibling Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.AssignReference Method
ChartSeriesBubble Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesBubble.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.GetProperty Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.GetRectangle Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.Highlight Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.InitializeMappings Method
ChartSeriesBubble Class See Also Send Feedback
Initializes the mapping of Bubble.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.InvokeMethod Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.NextSibling Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.Parent Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.PreviousSibling Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.ScrollToVisible Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble Properties
ChartSeriesBubble Class See Also Send Feedback

The ChartSeriesBubble type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BubbleRadius | Get the bubble radius.
BubbleSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Center | Get the bubble center point.
CenterPoint | Get the center point property.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the bubble color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Radius | Get the bubble radius.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Bubble. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BubbleRadius Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.BubbleRadius Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble radius.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BubbleRadius { get; set; }
Visual Basic (Declaration)
Public Property BubbleRadius As Double
Visual C++
public:
property double BubbleRadius {
    double get ();
    void set (double value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BubbleSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.BubbleSeriesColorValue Property
ChartSeriesBubble Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string BubbleSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property BubbleSeriesColorValue As String
Visual C++
public:
property String^ BubbleSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Center Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.Center Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble center point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Point
Visual C++
public:
property Point^ Center {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CenterPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.CenterPoint Property
ChartSeriesBubble Class See Also Send Feedback
Get the center point property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point CenterPoint { get; set; }
Visual Basic (Declaration)
Public Property CenterPoint As Point
Visual C++
public:
property Point^ CenterPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.Color Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Radius Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.Radius Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble radius.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesBubble..::.XamlTag Property
ChartSeriesBubble Class See Also Send Feedback
Get the xaml tag of Bubble.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesCandleStick control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesCandleStick : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesCandleStick _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesCandleStick : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesCandleStick

See Also

ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick Members
ChartSeriesCandleStick Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesCandleStick type exposes the following members.

Constructors

Name | Description
ChartSeriesCandleStick | Initializes a new instance of the ChartSeriesCandleStick class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of CandleStick. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CandleStickSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the candle stick color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LowerLine | Get the parametric lower line.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RectangleHeight | Get the rectangle height.
RectangleWidth | Get the rectange width.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UpperLine | Get the parametric upper line.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of CandleStick. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick Constructor
ChartSeriesCandleStick Class See Also Send Feedback
Initializes a new instance of the ChartSeriesCandleStick class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesCandleStick()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesCandleStick()

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick Methods
ChartSeriesCandleStick Class See Also Send Feedback

The ChartSeriesCandleStick type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of CandleStick. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.AnySibling Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.AssignReference Method
ChartSeriesCandleStick Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesCandleStick.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.GetProperty Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.GetRectangle Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.Highlight Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.InitializeMappings Method
ChartSeriesCandleStick Class See Also Send Feedback
Initializes the mapping of CandleStick.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.InvokeMethod Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.NextSibling Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.Parent Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.PreviousSibling Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.ScrollToVisible Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick Properties
ChartSeriesCandleStick Class See Also Send Feedback

The ChartSeriesCandleStick type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CandleStickSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the candle stick color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LowerLine | Get the parametric lower line.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RectangleHeight | Get the rectangle height.
RectangleWidth | Get the rectange width.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UpperLine | Get the parametric upper line.
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of CandleStick. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CandleStickSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.CandleStickSeriesColorValue Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string CandleStickSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property CandleStickSeriesColorValue As String
Visual C++
public:
property String^ CandleStickSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.Color Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the candle stick color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LowerLine Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.LowerLine Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the parametric lower line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ParametricLine LowerLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property LowerLine As ParametricLine
Visual C++
public:
property ParametricLine^ LowerLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RectangleHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.RectangleHeight Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the rectangle height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double RectangleHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property RectangleHeight As Double
Visual C++
public:
property double RectangleHeight {
    double get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RectangleWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.RectangleWidth Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the rectange width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double RectangleWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property RectangleWidth As Double
Visual C++
public:
property double RectangleWidth {
    double get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


UpperLine Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.UpperLine Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the parametric upper line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ParametricLine UpperLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpperLine As ParametricLine
Visual C++
public:
property ParametricLine^ UpperLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesCandleStick..::.XamlTag Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the xaml tag of CandleStick.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesDoughnut control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesDoughnut : ChartSeriesPie
Visual Basic (Declaration)
Public Class ChartSeriesDoughnut _
    Inherits ChartSeriesPie
Visual C++
public ref class ChartSeriesDoughnut : public ChartSeriesPie

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesPie
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesDoughnut

See Also

ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut Members
ChartSeriesDoughnut Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesDoughnut type exposes the following members.

Constructors

Name | Description
ChartSeriesDoughnut | Initializes a new instance of the ChartSeriesDoughnut class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesPie..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Doughnut. (Overrides ChartSeriesPie..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the doughnut color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DoughnutSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
DoughnutStartAngle | Get the doughnut start angle.
DoughnutSweepAngle | Get the doughnut sweep angle.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the doughnut label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PieSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesPie.)
PieStartAngle | Get the pie start angle. (Inherited from ChartSeriesPie.)
PieSweepAngle | Get the pie sweep angle. (Inherited from ChartSeriesPie.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartAngle | Start angle property. (Inherited from ChartSeriesPie.)
SweepAngle | Sweep angle property. (Inherited from ChartSeriesPie.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Doughnut. (Overrides ChartSeriesPie..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut Constructor
ChartSeriesDoughnut Class See Also Send Feedback
Initializes a new instance of the ChartSeriesDoughnut class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesDoughnut()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesDoughnut()

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut Methods
ChartSeriesDoughnut Class See Also Send Feedback

The ChartSeriesDoughnut type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesPie..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Doughnut. (Overrides ChartSeriesPie..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.AnySibling Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.AssignReference Method
ChartSeriesDoughnut Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesDoughnut.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.GetProperty Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.GetRectangle Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.Highlight Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.InitializeMappings Method
ChartSeriesDoughnut Class See Also Send Feedback
Initializes the mapping of Doughnut.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.InvokeMethod Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.NextSibling Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.Parent Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.PreviousSibling Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.ScrollToVisible Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut Properties
ChartSeriesDoughnut Class See Also Send Feedback

The ChartSeriesDoughnut type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the doughnut color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DoughnutSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
DoughnutStartAngle | Get the doughnut start angle.
DoughnutSweepAngle | Get the doughnut sweep angle.
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the doughnut label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PieSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesPie.)
PieStartAngle | Get the pie start angle. (Inherited from ChartSeriesPie.)
PieSweepAngle | Get the pie sweep angle. (Inherited from ChartSeriesPie.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartAngle | Start angle property. (Inherited from ChartSeriesPie.)
SweepAngle | Sweep angle property. (Inherited from ChartSeriesPie.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Doughnut. (Overrides ChartSeriesPie..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.Color Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.DoughnutSeriesColorValue Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string DoughnutSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DoughnutSeriesColorValue As String
Visual C++
public:
property String^ DoughnutSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutStartAngle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.DoughnutStartAngle Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut start angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DoughnutStartAngle { get; set; }
Visual Basic (Declaration)
Public Property DoughnutStartAngle As Double
Visual C++
public:
property double DoughnutStartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutSweepAngle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.DoughnutSweepAngle Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut sweep angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double DoughnutSweepAngle { get; set; }
Visual Basic (Declaration)
Public Property DoughnutSweepAngle As Double
Visual C++
public:
property double DoughnutSweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.LabelText Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesDoughnut..::.XamlTag Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the xaml tag of Doughnut.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesHorizontalBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesHorizontalBar : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesHorizontalBar _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesHorizontalBar : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalStackedBar

See Also

ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar Members
ChartSeriesHorizontalBar Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesHorizontalBar type exposes the following members.

Constructors

Name | Description
ChartSeriesHorizontalBar | Initializes a new instance of the ChartSeriesHorizontalBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Horizontal Bar. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the horizontal bar height.
BarWidth | Get the horizontal bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the horizontal bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the horizontal bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Horizontal Bar. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar Constructor
ChartSeriesHorizontalBar Class See Also Send Feedback
Initializes a new instance of the ChartSeriesHorizontalBar class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesHorizontalBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesHorizontalBar()

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar Methods
ChartSeriesHorizontalBar Class See Also Send Feedback

The ChartSeriesHorizontalBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Horizontal Bar. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.AnySibling Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.AssignReference Method
ChartSeriesHorizontalBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesHorizontalBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.GetProperty Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.GetRectangle Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.Highlight Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.InitializeMappings Method
ChartSeriesHorizontalBar Class See Also Send Feedback
Initializes the mapping of Horizontal Bar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.InvokeMethod Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.NextSibling Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.Parent Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.PreviousSibling Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.ScrollToVisible Method
ChartSeriesHorizontalBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
ChartSeriesHorizontalBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar Properties
ChartSeriesHorizontalBar Class See Also Send Feedback

The ChartSeriesHorizontalBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the horizontal bar height.
BarWidth | Get the horizontal bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the horizontal bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the horizontal bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Horizontal Bar. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.BarHeight Property
ChartSeriesHorizontalBar Class See Also Send Feedback
Get the horizontal bar height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.BarWidth Property
ChartSeriesHorizontalBar Class See Also Send Feedback
Get the horizontal bar width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.Color Property
ChartSeriesHorizontalBar Class See Also Send Feedback
Get the horizontal bar color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


HorizontalBarSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.HorizontalBarSeriesColorValue Property
ChartSeriesHorizontalBar Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HorizontalBarSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalBarSeriesColorValue As String
Visual C++
public:
property String^ HorizontalBarSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.LabelText Property
ChartSeriesHorizontalBar Class See Also Send Feedback
Get the horizontal bar label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalBar..::.XamlTag Property
ChartSeriesHorizontalBar Class See Also Send Feedback
Get the xaml tag of Horizontal Bar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesHorizontalBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesHorizontalStackedBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesHorizontalStackedBar : ChartSeriesHorizontalBar
Visual Basic (Declaration)
Public Class ChartSeriesHorizontalStackedBar _
    Inherits ChartSeriesHorizontalBar
Visual C++
public ref class ChartSeriesHorizontalStackedBar : public ChartSeriesHorizontalBar

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalStackedBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalStackedBar100

See Also

ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar Members
ChartSeriesHorizontalStackedBar Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesHorizontalStackedBar type exposes the following members.

Constructors

Name | Description
ChartSeriesHorizontalStackedBar | Initializes a new instance of the ChartSeriesHorizontalStackedBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesHorizontalBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of HorizontalStackedBar. (Overrides ChartSeriesHorizontalBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the horizontal stacked bar height.
BarWidth | Get the horizontal stacked bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the horizontal stacked bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesHorizontalBar.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalStackedBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the horizontal stacked bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of HorizontalStackedBar. (Overrides ChartSeriesHorizontalBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar Constructor
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Initializes a new instance of the ChartSeriesHorizontalStackedBar class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesHorizontalStackedBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesHorizontalStackedBar()

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar Methods
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

The ChartSeriesHorizontalStackedBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesHorizontalBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of HorizontalStackedBar. (Overrides ChartSeriesHorizontalBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.AnySibling Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.AssignReference Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesHorizontalStackedBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.GetProperty Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.GetRectangle Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.Highlight Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.InitializeMappings Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Initializes the mapping of HorizontalStackedBar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.InvokeMethod Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.NextSibling Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.Parent Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.PreviousSibling Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.ScrollToVisible Method
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
ChartSeriesHorizontalStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar Properties
ChartSeriesHorizontalStackedBar Class See Also Send Feedback

The ChartSeriesHorizontalStackedBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the horizontal stacked bar height.
BarWidth | Get the horizontal stacked bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the horizontal stacked bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesHorizontalBar.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalStackedBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the horizontal stacked bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of HorizontalStackedBar. (Overrides ChartSeriesHorizontalBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.BarHeight Property
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Get the horizontal stacked bar height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.BarWidth Property
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Get the horizontal stacked bar width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.Color Property
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Get the horizontal stacked bar color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


HorizontalStackedBarSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.HorizontalStackedBarSeriesColorValue Property
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HorizontalStackedBarSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalStackedBarSeriesColorValue As String
Visual C++
public:
property String^ HorizontalStackedBarSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.LabelText Property
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Get the horizontal stacked bar label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar..::.XamlTag Property
ChartSeriesHorizontalStackedBar Class See Also Send Feedback
Get the xaml tag of HorizontalStackedBar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesHorizontalStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar100 Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100 Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesHorizontalStackedBar100 control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesHorizontalStackedBar100 : ChartSeriesHorizontalStackedBar
Visual Basic (Declaration)
Public Class ChartSeriesHorizontalStackedBar100 _
    Inherits ChartSeriesHorizontalStackedBar
Visual C++
public ref class ChartSeriesHorizontalStackedBar100 : public ChartSeriesHorizontalStackedBar

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalStackedBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesHorizontalStackedBar100

See Also

ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar100 Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100 Members
ChartSeriesHorizontalStackedBar100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesHorizontalStackedBar100 type exposes the following members.

Constructors

Name | Description
ChartSeriesHorizontalStackedBar100 | Initializes a new instance of the ChartSeriesHorizontalStackedBar100 class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesHorizontalStackedBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of HorizontalStackedBar100. (Overrides ChartSeriesHorizontalStackedBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the Horizontal stackedbar100 height.
BarWidth | Get the Horizontal stackedbar100 width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the Horizontal stackedbar100 color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesHorizontalBar.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalStackedBar100SeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
HorizontalStackedBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesHorizontalStackedBar.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the Horizontal stackedbar100 label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of HorizontalStackedBar100. (Overrides ChartSeriesHorizontalStackedBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar100 Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100 Constructor
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesHorizontalStackedBar100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesHorizontalStackedBar100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesHorizontalStackedBar100()

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar100 Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100 Methods
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

The ChartSeriesHorizontalStackedBar100 type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesHorizontalStackedBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of HorizontalStackedBar100. (Overrides ChartSeriesHorizontalStackedBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.AnySibling Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.AssignReference Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesHorizontalStackedBar100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.GetProperty Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.GetRectangle Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.Highlight Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.InitializeMappings Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Initializes the mapping of HorizontalStackedBar100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.InvokeMethod Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.NextSibling Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.Parent Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.PreviousSibling Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.ScrollToVisible Method
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
ChartSeriesHorizontalStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesHorizontalStackedBar100 Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100 Properties
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback

The ChartSeriesHorizontalStackedBar100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the Horizontal stackedbar100 height.
BarWidth | Get the Horizontal stackedbar100 width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the Horizontal stackedbar100 color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesHorizontalBar.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalStackedBar100SeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
HorizontalStackedBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesHorizontalStackedBar.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the Horizontal stackedbar100 label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of HorizontalStackedBar100. (Overrides ChartSeriesHorizontalStackedBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.BarHeight Property
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Get the Horizontal stackedbar100 height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.BarWidth Property
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Get the Horizontal stackedbar100 width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.Color Property
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Get the Horizontal stackedbar100 color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


HorizontalStackedBar100SeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.HorizontalStackedBar100SeriesColorValue Property
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string HorizontalStackedBar100SeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalStackedBar100SeriesColorValue As String
Visual C++
public:
property String^ HorizontalStackedBar100SeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.LabelText Property
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Get the Horizontal stackedbar100 label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesHorizontalStackedBar100..::.XamlTag Property
ChartSeriesHorizontalStackedBar100 Class See Also Send Feedback
Get the xaml tag of HorizontalStackedBar100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesHorizontalStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesLine control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesLine : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesLine _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesLine : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesLine
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedLine

See Also

ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine Members
ChartSeriesLine Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesLine type exposes the following members.

Constructors

Name | Description
ChartSeriesLine | Initializes a new instance of the ChartSeriesLine class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Line. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the line color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the line end point.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the line label text.
LineSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Line. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine Constructor
ChartSeriesLine Class See Also Send Feedback
Initializes a new instance of the ChartSeriesLine class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesLine()

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine Methods
ChartSeriesLine Class See Also Send Feedback

The ChartSeriesLine type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Line. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.AnySibling Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.AssignReference Method
ChartSeriesLine Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesLine.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.GetProperty Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.GetRectangle Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.Highlight Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.InitializeMappings Method
ChartSeriesLine Class See Also Send Feedback
Initializes the mapping of Line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.InvokeMethod Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.NextSibling Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.Parent Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.PreviousSibling Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.ScrollToVisible Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine Properties
ChartSeriesLine Class See Also Send Feedback

The ChartSeriesLine type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the line color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the line end point.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the line label text.
LineSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Line. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.Color Property
ChartSeriesLine Class See Also Send Feedback
Get the line color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.EndPoint Property
ChartSeriesLine Class See Also Send Feedback
Get the line end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.LabelText Property
ChartSeriesLine Class See Also Send Feedback
Get the line label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.LineSeriesColorValue Property
ChartSeriesLine Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LineSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineSeriesColorValue As String
Visual C++
public:
property String^ LineSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.StartPoint Property
ChartSeriesLine Class See Also Send Feedback
Get the line start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesLine..::.XamlTag Property
ChartSeriesLine Class See Also Send Feedback
Get the xaml tag of Line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesPie control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesPie : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesPie _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesPie : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesPie
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesDoughnut

See Also

ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie Members
ChartSeriesPie Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesPie type exposes the following members.

Constructors

Name | Description
ChartSeriesPie | Initializes a new instance of the ChartSeriesPie class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Pie. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the pie color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the pie label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PieSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
PieStartAngle | Get the pie start angle.
PieSweepAngle | Get the pie sweep angle.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartAngle | Start angle property.
SweepAngle | Sweep angle property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Pie. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie Constructor
ChartSeriesPie Class See Also Send Feedback
Initializes a new instance of the ChartSeriesPie class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesPie()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesPie()

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie Methods
ChartSeriesPie Class See Also Send Feedback

The ChartSeriesPie type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Pie. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.AnySibling Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.AssignReference Method
ChartSeriesPie Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesPie.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.GetProperty Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.GetRectangle Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.Highlight Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.InitializeMappings Method
ChartSeriesPie Class See Also Send Feedback
Initializes the mapping of Pie.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.InvokeMethod Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.NextSibling Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.Parent Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.PreviousSibling Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.ScrollToVisible Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie Properties
ChartSeriesPie Class See Also Send Feedback

The ChartSeriesPie type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the pie color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the pie label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PieSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
PieStartAngle | Get the pie start angle.
PieSweepAngle | Get the pie sweep angle.
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartAngle | Start angle property.
SweepAngle | Sweep angle property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Pie. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.Color Property
ChartSeriesPie Class See Also Send Feedback
Get the pie color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.LabelText Property
ChartSeriesPie Class See Also Send Feedback
Get the pie label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.PieSeriesColorValue Property
ChartSeriesPie Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string PieSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property PieSeriesColorValue As String
Visual C++
public:
property String^ PieSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieStartAngle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.PieStartAngle Property
ChartSeriesPie Class See Also Send Feedback
Get the pie start angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double PieStartAngle { get; set; }
Visual Basic (Declaration)
Public Property PieStartAngle As Double
Visual C++
public:
property double PieStartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieSweepAngle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.PieSweepAngle Property
ChartSeriesPie Class See Also Send Feedback
Get the pie sweep angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double PieSweepAngle { get; set; }
Visual Basic (Declaration)
Public Property PieSweepAngle As Double
Visual C++
public:
property double PieSweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartAngle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.StartAngle Property
ChartSeriesPie Class See Also Send Feedback
Start angle property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SweepAngle Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.SweepAngle Property
ChartSeriesPie Class See Also Send Feedback
Sweep angle property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SweepAngle { get; set; }
Visual Basic (Declaration)
Public Property SweepAngle As Double
Visual C++
public:
property double SweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesPie..::.XamlTag Property
ChartSeriesPie Class See Also Send Feedback
Get the xaml tag of Pie.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesRange control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesRange : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesRange _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesRange : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesRange
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineRange

See Also

ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange Members
ChartSeriesRange Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesRange type exposes the following members.

Constructors

Name | Description
ChartSeriesRange | Initializes a new instance of the ChartSeriesRange class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Range. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the range end point.
EndPointX | Get the range end point x.
EndPointY | Get the range end point y.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the range width.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SideEndPoint | Get the range side end point.
SideEndPointX | Get the range side end point x.
SideEndPointY | Get the range side end point y.
SideStartPoint | Get the range side start point.
SideStartPointX | Get the range side start point x.
SideStartPointY | Get the range side start point y.
StartPoint | Get the range start point.
StartPointX | Get the range start point x.
StartPointY | Get the range start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Range. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XValue | Get the range X value property.
Y1Value | Get the range Y1 value property.
Y2Value | Get the range Y2 value property.

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange Constructor
ChartSeriesRange Class See Also Send Feedback
Initializes a new instance of the ChartSeriesRange class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesRange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesRange()

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange Methods
ChartSeriesRange Class See Also Send Feedback

The ChartSeriesRange type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Range. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.AnySibling Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.AssignReference Method
ChartSeriesRange Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesRange.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.GetProperty Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.GetRectangle Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.Highlight Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.InitializeMappings Method
ChartSeriesRange Class See Also Send Feedback
Initializes the mapping of Range.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.InvokeMethod Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.NextSibling Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.Parent Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.PreviousSibling Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.ScrollToVisible Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange Properties
ChartSeriesRange Class See Also Send Feedback

The ChartSeriesRange type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the range end point.
EndPointX | Get the range end point x.
EndPointY | Get the range end point y.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the range width.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SideEndPoint | Get the range side end point.
SideEndPointX | Get the range side end point x.
SideEndPointY | Get the range side end point y.
SideStartPoint | Get the range side start point.
SideStartPointX | Get the range side start point x.
SideStartPointY | Get the range side start point y.
StartPoint | Get the range start point.
StartPointX | Get the range start point x.
StartPointY | Get the range start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Range. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XValue | Get the range X value property.
Y1Value | Get the range Y1 value property.
Y2Value | Get the range Y2 value property.

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.EndPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.EndPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.EndPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.RangeWidth Property
ChartSeriesRange Class See Also Send Feedback
Get the range width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double RangeWidth { get; set; }
Visual Basic (Declaration)
Public Property RangeWidth As Double
Visual C++
public:
property double RangeWidth {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.SideEndPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range side end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point SideEndPoint { get; set; }
Visual Basic (Declaration)
Public Property SideEndPoint As Point
Visual C++
public:
property Point^ SideEndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.SideEndPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range side end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SideEndPointX { get; set; }
Visual Basic (Declaration)
Public Property SideEndPointX As Double
Visual C++
public:
property double SideEndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.SideEndPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range side end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SideEndPointY { get; set; }
Visual Basic (Declaration)
Public Property SideEndPointY As Double
Visual C++
public:
property double SideEndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.SideStartPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range side start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point SideStartPoint { get; set; }
Visual Basic (Declaration)
Public Property SideStartPoint As Point
Visual C++
public:
property Point^ SideStartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.SideStartPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range side start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SideStartPointX { get; set; }
Visual Basic (Declaration)
Public Property SideStartPointX As Double
Visual C++
public:
property double SideStartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.SideStartPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range side start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double SideStartPointY { get; set; }
Visual Basic (Declaration)
Public Property SideStartPointY As Double
Visual C++
public:
property double SideStartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.StartPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.StartPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.StartPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.XamlTag Property
ChartSeriesRange Class See Also Send Feedback
Get the xaml tag of Range.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.XValue Property
ChartSeriesRange Class See Also Send Feedback
Get the range X value property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double XValue { get; set; }
Visual Basic (Declaration)
Public Property XValue As Double
Visual C++
public:
property double XValue {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y1Value Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.Y1Value Property
ChartSeriesRange Class See Also Send Feedback
Get the range Y1 value property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Y1Value { get; set; }
Visual Basic (Declaration)
Public Property Y1Value As Double
Visual C++
public:
property double Y1Value {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y2Value Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesRange..::.Y2Value Property
ChartSeriesRange Class See Also Send Feedback
Get the range Y2 value property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Y2Value { get; set; }
Visual Basic (Declaration)
Public Property Y2Value As Double
Visual C++
public:
property double Y2Value {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesSpline control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesSpline : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesSpline _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesSpline : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSpline
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSpline

See Also

ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline Members
ChartSeriesSpline Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesSpline type exposes the following members.

Constructors

Name | Description
ChartSeriesSpline | Initializes a new instance of the ChartSeriesSpline class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Spline. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the spline end point.
EndPointX | Get the spline end point x.
EndPointY | Get the spline end point y.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the spline label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the spline start point.
StartPointX | Get the spline start point x.
StartPointY | Get the spline start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Spline. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline Constructor
ChartSeriesSpline Class See Also Send Feedback
Initializes a new instance of the ChartSeriesSpline class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesSpline()

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline Methods
ChartSeriesSpline Class See Also Send Feedback

The ChartSeriesSpline type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Spline. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.AnySibling Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.AssignReference Method
ChartSeriesSpline Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSpline.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.GetProperty Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.GetRectangle Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.Highlight Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.InitializeMappings Method
ChartSeriesSpline Class See Also Send Feedback
Initializes the mapping of Spline.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.InvokeMethod Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.NextSibling Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.Parent Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.PreviousSibling Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.ScrollToVisible Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline Properties
ChartSeriesSpline Class See Also Send Feedback

The ChartSeriesSpline type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the spline end point.
EndPointX | Get the spline end point x.
EndPointY | Get the spline end point y.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the spline label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the spline start point.
StartPointX | Get the spline start point x.
StartPointY | Get the spline start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Spline. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.EndPoint Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.EndPointX Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.EndPointY Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.LabelText Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.StartPoint Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.StartPointX Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.StartPointY Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSpline..::.XamlTag Property
ChartSeriesSpline Class See Also Send Feedback
Get the xaml tag of Spline.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesSplineArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesSplineArea : ChartSeriesArea
Visual Basic (Declaration)
Public Class ChartSeriesSplineArea _
    Inherits ChartSeriesArea
Visual C++
public ref class ChartSeriesSplineArea : public ChartSeriesArea

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSplineArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSplineArea100

See Also

ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea Members
ChartSeriesSplineArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesSplineArea type exposes the following members.

Constructors

Name | Description
ChartSeriesSplineArea | Initializes a new instance of the ChartSeriesSplineArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineArea. (Overrides ChartSeriesArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the spline area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineArea. (Overrides ChartSeriesArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea Constructor
ChartSeriesSplineArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesSplineArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesSplineArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesSplineArea()

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea Methods
ChartSeriesSplineArea Class See Also Send Feedback

The ChartSeriesSplineArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineArea. (Overrides ChartSeriesArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.AnySibling Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.AssignReference Method
ChartSeriesSplineArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSplineArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.GetProperty Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.GetRectangle Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.Highlight Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.InitializeMappings Method
ChartSeriesSplineArea Class See Also Send Feedback
Initializes the mapping of SplineArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.InvokeMethod Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.NextSibling Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.Parent Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.PreviousSibling Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.ScrollToVisible Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea Properties
ChartSeriesSplineArea Class See Also Send Feedback

The ChartSeriesSplineArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the spline area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineArea. (Overrides ChartSeriesArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.LabelText Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineArea..::.XamlTag Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the xaml tag of SplineArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesSplineRange control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesSplineRange : ChartSeriesRange
Visual Basic (Declaration)
Public Class ChartSeriesSplineRange _
    Inherits ChartSeriesRange
Visual C++
public ref class ChartSeriesSplineRange : public ChartSeriesRange

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesRange
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineRange

See Also

ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange Members
ChartSeriesSplineRange Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesSplineRange type exposes the following members.

Constructors

Name | Description
ChartSeriesSplineRange | Initializes a new instance of the ChartSeriesSplineRange class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesRange..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineRange. (Overrides ChartSeriesRange..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the range end point. (Inherited from ChartSeriesRange.)
EndPointX | Get the range end point x. (Inherited from ChartSeriesRange.)
EndPointY | Get the range end point y. (Inherited from ChartSeriesRange.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the range width. (Inherited from ChartSeriesRange.)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SideEndPoint | Get the range side end point. (Inherited from ChartSeriesRange.)
SideEndPointX | Get the range side end point x. (Inherited from ChartSeriesRange.)
SideEndPointY | Get the range side end point y. (Inherited from ChartSeriesRange.)
SideStartPoint | Get the range side start point. (Inherited from ChartSeriesRange.)
SideStartPointX | Get the range side start point x. (Inherited from ChartSeriesRange.)
SideStartPointY | Get the range side start point y. (Inherited from ChartSeriesRange.)
StartPoint | Get the range start point. (Inherited from ChartSeriesRange.)
StartPointX | Get the range start point x. (Inherited from ChartSeriesRange.)
StartPointY | Get the range start point y. (Inherited from ChartSeriesRange.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineRange. (Overrides ChartSeriesRange..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XValue | Get the range X value property. (Inherited from ChartSeriesRange.)
Y1Value | Get the range Y1 value property. (Inherited from ChartSeriesRange.)
Y2Value | Get the range Y2 value property. (Inherited from ChartSeriesRange.)

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange Constructor
ChartSeriesSplineRange Class See Also Send Feedback
Initializes a new instance of the ChartSeriesSplineRange class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesSplineRange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesSplineRange()

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange Methods
ChartSeriesSplineRange Class See Also Send Feedback

The ChartSeriesSplineRange type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesRange..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineRange. (Overrides ChartSeriesRange..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.AnySibling Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.AssignReference Method
ChartSeriesSplineRange Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSplineRange.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.GetProperty Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.GetRectangle Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.Highlight Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.InitializeMappings Method
ChartSeriesSplineRange Class See Also Send Feedback
Initializes the mapping of SplineRange.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.InvokeMethod Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.NextSibling Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.Parent Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.PreviousSibling Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.ScrollToVisible Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange Properties
ChartSeriesSplineRange Class See Also Send Feedback

The ChartSeriesSplineRange type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the range end point. (Inherited from ChartSeriesRange.)
EndPointX | Get the range end point x. (Inherited from ChartSeriesRange.)
EndPointY | Get the range end point y. (Inherited from ChartSeriesRange.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the range width. (Inherited from ChartSeriesRange.)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SideEndPoint | Get the range side end point. (Inherited from ChartSeriesRange.)
SideEndPointX | Get the range side end point x. (Inherited from ChartSeriesRange.)
SideEndPointY | Get the range side end point y. (Inherited from ChartSeriesRange.)
SideStartPoint | Get the range side start point. (Inherited from ChartSeriesRange.)
SideStartPointX | Get the range side start point x. (Inherited from ChartSeriesRange.)
SideStartPointY | Get the range side start point y. (Inherited from ChartSeriesRange.)
StartPoint | Get the range start point. (Inherited from ChartSeriesRange.)
StartPointX | Get the range start point x. (Inherited from ChartSeriesRange.)
StartPointY | Get the range start point y. (Inherited from ChartSeriesRange.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineRange. (Overrides ChartSeriesRange..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
XValue | Get the range X value property. (Inherited from ChartSeriesRange.)
Y1Value | Get the range Y1 value property. (Inherited from ChartSeriesRange.)
Y2Value | Get the range Y2 value property. (Inherited from ChartSeriesRange.)

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesSplineRange..::.XamlTag Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the xaml tag of SplineRange.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedArea : ChartSeriesArea
Visual Basic (Declaration)
Public Class ChartSeriesStackedArea _
    Inherits ChartSeriesArea
Visual C++
public ref class ChartSeriesStackedArea : public ChartSeriesArea

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedArea

See Also

ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea Members
ChartSeriesStackedArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedArea type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedArea | Initializes a new instance of the ChartSeriesStackedArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedArea. (Overrides ChartSeriesArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedAreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedArea. (Overrides ChartSeriesArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea Constructor
ChartSeriesStackedArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedArea()

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea Methods
ChartSeriesStackedArea Class See Also Send Feedback

The ChartSeriesStackedArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedArea. (Overrides ChartSeriesArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.AnySibling Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.AssignReference Method
ChartSeriesStackedArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.GetProperty Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.GetRectangle Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.Highlight Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.InitializeMappings Method
ChartSeriesStackedArea Class See Also Send Feedback
Initializes the mapping of StackedArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.InvokeMethod Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.NextSibling Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.Parent Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.PreviousSibling Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.ScrollToVisible Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea Properties
ChartSeriesStackedArea Class See Also Send Feedback

The ChartSeriesStackedArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedAreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedArea. (Overrides ChartSeriesArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.LabelText Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.StackedAreaSeriesColorValue Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StackedAreaSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedAreaSeriesColorValue As String
Visual C++
public:
property String^ StackedAreaSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea..::.XamlTag Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the xaml tag of StackedArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100 Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedArea100 control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedArea100 : ChartSeriesArea
Visual Basic (Declaration)
Public Class ChartSeriesStackedArea100 _
    Inherits ChartSeriesArea
Visual C++
public ref class ChartSeriesStackedArea100 : public ChartSeriesArea

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedArea100

See Also

ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100 Members
ChartSeriesStackedArea100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedArea100 type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedArea100 | Initializes a new instance of the ChartSeriesStackedArea100 class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedArea100. (Overrides ChartSeriesArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedArea100SeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedArea100. (Overrides ChartSeriesArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100 Constructor
ChartSeriesStackedArea100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedArea100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedArea100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedArea100()

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100 Methods
ChartSeriesStackedArea100 Class See Also Send Feedback

The ChartSeriesStackedArea100 type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedArea100. (Overrides ChartSeriesArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.AnySibling Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.AssignReference Method
ChartSeriesStackedArea100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedArea100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.GetProperty Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.GetRectangle Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.Highlight Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.InitializeMappings Method
ChartSeriesStackedArea100 Class See Also Send Feedback
Initializes the mapping of StackedArea100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.InvokeMethod Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.NextSibling Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.Parent Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.PreviousSibling Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.ScrollToVisible Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100 Properties
ChartSeriesStackedArea100 Class See Also Send Feedback

The ChartSeriesStackedArea100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedArea100SeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedArea100. (Overrides ChartSeriesArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.LabelText Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100SeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.StackedArea100SeriesColorValue Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StackedArea100SeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedArea100SeriesColorValue As String
Visual C++
public:
property String^ StackedArea100SeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedArea100..::.XamlTag Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the xaml tag of StackedArea100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedBar : ChartSeriesBar
Visual Basic (Declaration)
Public Class ChartSeriesStackedBar _
    Inherits ChartSeriesBar
Visual C++
public ref class ChartSeriesStackedBar : public ChartSeriesBar

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedBar

See Also

ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar Members
ChartSeriesStackedBar Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedBar type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedBar | Initializes a new instance of the ChartSeriesStackedBar class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedBar. (Overrides ChartSeriesBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stacked bar height.
BarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesBar.)
BarWidth | Get the stacked bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the stacked bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedBar. (Overrides ChartSeriesBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar Constructor
ChartSeriesStackedBar Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedBar class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedBar()

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar Methods
ChartSeriesStackedBar Class See Also Send Feedback

The ChartSeriesStackedBar type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedBar. (Overrides ChartSeriesBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.AnySibling Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.AssignReference Method
ChartSeriesStackedBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.GetProperty Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.GetRectangle Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.Highlight Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.InitializeMappings Method
ChartSeriesStackedBar Class See Also Send Feedback
Initializes the mapping of StackedBar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.InvokeMethod Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.NextSibling Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.Parent Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.PreviousSibling Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.ScrollToVisible Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar Properties
ChartSeriesStackedBar Class See Also Send Feedback

The ChartSeriesStackedBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stacked bar height.
BarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesBar.)
BarWidth | Get the stacked bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the stacked bar color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked bar label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedBarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedBar. (Overrides ChartSeriesBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.BarHeight Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.BarWidth Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.Color Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.LabelText Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedBarSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.StackedBarSeriesColorValue Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StackedBarSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedBarSeriesColorValue As String
Visual C++
public:
property String^ StackedBarSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar..::.XamlTag Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the xaml tag of StackedBar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100 Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedBar100 control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedBar100 : ChartSeriesBar
Visual Basic (Declaration)
Public Class ChartSeriesStackedBar100 _
    Inherits ChartSeriesBar
Visual C++
public ref class ChartSeriesStackedBar100 : public ChartSeriesBar

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesBar
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedBar100

See Also

ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100 Members
ChartSeriesStackedBar100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedBar100 type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedBar100 | Initializes a new instance of the ChartSeriesStackedBar100 class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedBar100. (Overrides ChartSeriesBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stackedbar100 height.
BarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesBar.)
BarWidth | Get the stackedbar100 width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the stackedbar100 color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedbar100 label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedBar100SeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedBar100. (Overrides ChartSeriesBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100 Constructor
ChartSeriesStackedBar100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedBar100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedBar100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedBar100()

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100 Methods
ChartSeriesStackedBar100 Class See Also Send Feedback

The ChartSeriesStackedBar100 type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesBar..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedBar100. (Overrides ChartSeriesBar..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.AnySibling Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.AssignReference Method
ChartSeriesStackedBar100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedBar100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.GetProperty Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.GetRectangle Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.Highlight Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.InitializeMappings Method
ChartSeriesStackedBar100 Class See Also Send Feedback
Initializes the mapping of StackedBar100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.InvokeMethod Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.NextSibling Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.Parent Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.PreviousSibling Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.ScrollToVisible Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100 Properties
ChartSeriesStackedBar100 Class See Also Send Feedback

The ChartSeriesStackedBar100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stackedbar100 height.
BarSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesBar.)
BarWidth | Get the stackedbar100 width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the stackedbar100 color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedbar100 label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedBar100SeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedBar100. (Overrides ChartSeriesBar..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.BarHeight Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.BarWidth Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.Color Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.LabelText Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedBar100SeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.StackedBar100SeriesColorValue Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StackedBar100SeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedBar100SeriesColorValue As String
Visual C++
public:
property String^ StackedBar100SeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedBar100..::.XamlTag Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the xaml tag of StackedBar100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedLine control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedLine : ChartSeriesLine
Visual Basic (Declaration)
Public Class ChartSeriesStackedLine _
    Inherits ChartSeriesLine
Visual C++
public ref class ChartSeriesStackedLine : public ChartSeriesLine

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesLine
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedLine

See Also

ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine Members
ChartSeriesStackedLine Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedLine type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedLine | Initializes a new instance of the ChartSeriesStackedLine class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesLine..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedLine. (Overrides ChartSeriesLine..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the stacked line color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the stacked line end point.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked line label text.
LineSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesLine.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedLineSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
StartPoint | Get the stacked line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedLine. (Overrides ChartSeriesLine..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine Constructor
ChartSeriesStackedLine Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedLine class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedLine()

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine Methods
ChartSeriesStackedLine Class See Also Send Feedback

The ChartSeriesStackedLine type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesLine..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedLine. (Overrides ChartSeriesLine..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.AnySibling Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.AssignReference Method
ChartSeriesStackedLine Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedLine.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.GetProperty Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.GetRectangle Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.Highlight Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.InitializeMappings Method
ChartSeriesStackedLine Class See Also Send Feedback
Initializes the mapping of StackedLine.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.InvokeMethod Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.NextSibling Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.Parent Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.PreviousSibling Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.ScrollToVisible Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine Properties
ChartSeriesStackedLine Class See Also Send Feedback

The ChartSeriesStackedLine type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the stacked line color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the stacked line end point.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stacked line label text.
LineSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesLine.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedLineSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
StartPoint | Get the stacked line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedLine. (Overrides ChartSeriesLine..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.Color Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.EndPoint Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.LabelText Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.StackedLineSeriesColorValue Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StackedLineSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedLineSeriesColorValue As String
Visual C++
public:
property String^ StackedLineSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.StartPoint Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedLine..::.XamlTag Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the xaml tag of StackedLine.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedSpline control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedSpline : ChartSeriesSpline
Visual Basic (Declaration)
Public Class ChartSeriesStackedSpline _
    Inherits ChartSeriesSpline
Visual C++
public ref class ChartSeriesStackedSpline : public ChartSeriesSpline

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSpline
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSpline

See Also

ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline Members
ChartSeriesStackedSpline Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedSpline type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedSpline | Initializes a new instance of the ChartSeriesStackedSpline class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesSpline..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSpline. (Overrides ChartSeriesSpline..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the spline end point. (Inherited from ChartSeriesSpline.)
EndPointX | Get the spline end point x. (Inherited from ChartSeriesSpline.)
EndPointY | Get the spline end point y. (Inherited from ChartSeriesSpline.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedspline label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the spline start point. (Inherited from ChartSeriesSpline.)
StartPointX | Get the spline start point x. (Inherited from ChartSeriesSpline.)
StartPointY | Get the spline start point y. (Inherited from ChartSeriesSpline.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSpline. (Overrides ChartSeriesSpline..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline Constructor
ChartSeriesStackedSpline Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedSpline class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedSpline()

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline Methods
ChartSeriesStackedSpline Class See Also Send Feedback

The ChartSeriesStackedSpline type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesSpline..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSpline. (Overrides ChartSeriesSpline..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.AnySibling Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.AssignReference Method
ChartSeriesStackedSpline Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSpline.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.GetProperty Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.GetRectangle Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.Highlight Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.InitializeMappings Method
ChartSeriesStackedSpline Class See Also Send Feedback
Initializes the mapping of StackedSpline.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.InvokeMethod Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.NextSibling Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.Parent Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.PreviousSibling Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.ScrollToVisible Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline Properties
ChartSeriesStackedSpline Class See Also Send Feedback

The ChartSeriesStackedSpline type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the spline end point. (Inherited from ChartSeriesSpline.)
EndPointX | Get the spline end point x. (Inherited from ChartSeriesSpline.)
EndPointY | Get the spline end point y. (Inherited from ChartSeriesSpline.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedspline label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the spline start point. (Inherited from ChartSeriesSpline.)
StartPointX | Get the spline start point x. (Inherited from ChartSeriesSpline.)
StartPointY | Get the spline start point y. (Inherited from ChartSeriesSpline.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSpline. (Overrides ChartSeriesSpline..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.LabelText Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSpline..::.XamlTag Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the xaml tag of StackedSpline.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedSplineArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedSplineArea : ChartSeriesSplineArea
Visual Basic (Declaration)
Public Class ChartSeriesStackedSplineArea _
    Inherits ChartSeriesSplineArea
Visual C++
public ref class ChartSeriesStackedSplineArea : public ChartSeriesSplineArea

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSplineArea

See Also

ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea Members
ChartSeriesStackedSplineArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedSplineArea type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedSplineArea | Initializes a new instance of the ChartSeriesStackedSplineArea class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesSplineArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineArea. (Overrides ChartSeriesSplineArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineArea. (Overrides ChartSeriesSplineArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea Constructor
ChartSeriesStackedSplineArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedSplineArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedSplineArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedSplineArea()

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea Methods
ChartSeriesStackedSplineArea Class See Also Send Feedback

The ChartSeriesStackedSplineArea type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesSplineArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineArea. (Overrides ChartSeriesSplineArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.AnySibling Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.AssignReference Method
ChartSeriesStackedSplineArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSplineArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.GetProperty Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.GetRectangle Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.Highlight Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.InitializeMappings Method
ChartSeriesStackedSplineArea Class See Also Send Feedback
Initializes the mapping of StackedSplineArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.InvokeMethod Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.NextSibling Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.Parent Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.PreviousSibling Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.ScrollToVisible Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea Properties
ChartSeriesStackedSplineArea Class See Also Send Feedback

The ChartSeriesStackedSplineArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineArea. (Overrides ChartSeriesSplineArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.LabelText Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea..::.XamlTag Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the xaml tag of StackedSplineArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100 Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStackedSplineArea100 control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStackedSplineArea100 : ChartSeriesSplineArea
Visual Basic (Declaration)
Public Class ChartSeriesStackedSplineArea100 _
    Inherits ChartSeriesSplineArea
Visual C++
public ref class ChartSeriesStackedSplineArea100 : public ChartSeriesSplineArea

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineArea
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSplineArea100

See Also

ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100 Members
ChartSeriesStackedSplineArea100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedSplineArea100 type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedSplineArea100 | Initializes a new instance of the ChartSeriesStackedSplineArea100 class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesSplineArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineArea100. (Overrides ChartSeriesSplineArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea100 label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineArea100. (Overrides ChartSeriesSplineArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100 Constructor
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedSplineArea100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStackedSplineArea100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedSplineArea100()

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100 Methods
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

The ChartSeriesStackedSplineArea100 type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides ChartSeriesSplineArea..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineArea100. (Overrides ChartSeriesSplineArea..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.AnySibling Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.AssignReference Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSplineArea100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.GetProperty Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.GetRectangle Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.Highlight Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.InitializeMappings Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Initializes the mapping of StackedSplineArea100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.InvokeMethod Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.NextSibling Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.Parent Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.PreviousSibling Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.ScrollToVisible Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100 Properties
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

The ChartSeriesStackedSplineArea100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AreaSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ChartSeriesArea.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Color | Get the area color. (Inherited from ChartSeriesArea.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the area end point. (Inherited from ChartSeriesArea.)
EndPointX | Get the area end point x. (Inherited from ChartSeriesArea.)
EndPointY | Get the area end point y. (Inherited from ChartSeriesArea.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea100 label text.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the area start point. (Inherited from ChartSeriesArea.)
StartPointX | Get the area start point x. (Inherited from ChartSeriesArea.)
StartPointY | Get the area start point y. (Inherited from ChartSeriesArea.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineArea100. (Overrides ChartSeriesSplineArea..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.LabelText Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStackedSplineArea100..::.XamlTag Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the xaml tag of StackedSplineArea100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ChartSeriesStick control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ChartSeriesStick : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStick _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStick : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStick

See Also

ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick Members
ChartSeriesStick Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStick type exposes the following members.

Constructors

Name | Description
ChartSeriesStick | Initializes a new instance of the ChartSeriesStick class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Stick. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseLine | Get the parametric close line.
Color | Get the stick color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the stick end point.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
OpenLine | Get the parametric open line.
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the stick start point.
StickSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalLine | Get the parametric vertical line.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Stick. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick Constructor
ChartSeriesStick Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStick class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ChartSeriesStick()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStick()

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick Methods
ChartSeriesStick Class See Also Send Feedback

The ChartSeriesStick type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of Stick. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.AnySibling Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.AssignReference Method
ChartSeriesStick Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStick.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.GetProperty Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.GetRectangle Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.Highlight Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.InitializeMappings Method
ChartSeriesStick Class See Also Send Feedback
Initializes the mapping of Stick.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.InvokeMethod Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.NextSibling Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.Parent Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.PreviousSibling Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.ScrollToVisible Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick Properties
ChartSeriesStick Class See Also Send Feedback

The ChartSeriesStick type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
CloseLine | Get the parametric close line.
Color | Get the stick color.
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
EndPoint | Get the stick end point.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
OpenLine | Get the parametric open line.
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StartPoint | Get the stick start point.
StickSeriesColorValue | Get the selected color RGB representation. Example: '255:0:0'.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalLine | Get the parametric vertical line.
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of Stick. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CloseLine Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.CloseLine Property
ChartSeriesStick Class See Also Send Feedback
Get the parametric close line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ParametricLine CloseLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property CloseLine As ParametricLine
Visual C++
public:
property ParametricLine^ CloseLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.Color Property
ChartSeriesStick Class See Also Send Feedback
Get the stick color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.EndPoint Property
ChartSeriesStick Class See Also Send Feedback
Get the stick end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


OpenLine Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.OpenLine Property
ChartSeriesStick Class See Also Send Feedback
Get the parametric open line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ParametricLine OpenLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property OpenLine As ParametricLine
Visual C++
public:
property ParametricLine^ OpenLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.StartPoint Property
ChartSeriesStick Class See Also Send Feedback
Get the stick start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StickSeriesColorValue Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.StickSeriesColorValue Property
ChartSeriesStick Class See Also Send Feedback
Get the selected color RGB representation. Example: '255:0:0'.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public string StickSeriesColorValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StickSeriesColorValue As String
Visual C++
public:
property String^ StickSeriesColorValue {
    String^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


VerticalLine Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.VerticalLine Property
ChartSeriesStick Class See Also Send Feedback
Get the parametric vertical line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ParametricLine VerticalLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalLine As ParametricLine
Visual C++
public:
property ParametricLine^ VerticalLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ChartSeriesStick..::.XamlTag Property
ChartSeriesStick Class See Also Send Feedback
Get the xaml tag of Stick.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList Class
Members See Also Send Feedback
The holder of the line series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class LineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class LineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class LineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.LineChartSeriesList

See Also

LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList Members
LineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The LineChartSeriesList type exposes the following members.

Constructors

Name | Description
LineChartSeriesList | Initializes a new instance of the LineChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of LineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LineList | Get the list of Chart line series.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of LineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList Constructor
LineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the LineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public LineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineChartSeriesList()

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList Methods
LineChartSeriesList Class See Also Send Feedback

The LineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of LineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.AnySibling Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.GetProperty Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.GetRectangle Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.Highlight Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.InitializeMappings Method
LineChartSeriesList Class See Also Send Feedback
Initializes the mapping of LineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.InvokeMethod Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.NextSibling Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.Parent Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.PreviousSibling Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.ScrollToVisible Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList Properties
LineChartSeriesList Class See Also Send Feedback

The LineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
LineList | Get the list of Chart line series.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of LineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.LineList Property
LineChartSeriesList Class See Also Send Feedback
Get the list of Chart line series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesLine> LineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineList As IList(Of ChartSeriesLine)
Visual C++
public:
property IList<ChartSeriesLine^>^ LineList {
    IList<ChartSeriesLine^>^ get ();
}

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
LineChartSeriesList..::.XamlTag Property
LineChartSeriesList Class See Also Send Feedback
Get the xaml tag of LineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine Class
Members See Also Send Feedback
Represents the RadChart for Silverlight ParametricLine control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class ParametricLine : ContentControl
Visual Basic (Declaration)
Public Class ParametricLine _
    Inherits ContentControl
Visual C++
public ref class ParametricLine : public ContentControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ParametricLine

See Also

ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine Members
ParametricLine Class Constructors Methods Properties See Also Send Feedback

The ParametricLine type exposes the following members.

Constructors

Name | Description
ParametricLine | Initializes a new instance of the ParametricLine class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ParametricLine. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Fill | Get the Fill property.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Line | Get the line.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
X1 | Get the line start point x.
X2 | Get the line end point x.
XamlTag | Get the xaml tag of ParametricLine. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Y1 | Get the line start point y.
Y2 | Get the line end point y.

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine Constructor
ParametricLine Class See Also Send Feedback
Initializes a new instance of the ParametricLine class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public ParametricLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParametricLine()

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine Methods
ParametricLine Class See Also Send Feedback

The ParametricLine type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::.AssignReference(AutomationReference).)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of ParametricLine. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.AnySibling Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.AssignReference Method
ParametricLine Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::.AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ParametricLine.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeer..::.AssignReference(AutomationReference)

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.GetProperty Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.GetRectangle Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.Highlight Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.InitializeMappings Method
ParametricLine Class See Also Send Feedback
Initializes the mapping of ParametricLine.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.InvokeMethod Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.NextSibling Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.Parent Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.PreviousSibling Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.ScrollToVisible Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine Properties
ParametricLine Class See Also Send Feedback

The ParametricLine type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Fill | Get the Fill property.
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Line | Get the line.
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
X1 | Get the line start point x.
X2 | Get the line end point x.
XamlTag | Get the xaml tag of ParametricLine. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Y1 | Get the line start point y.
Y2 | Get the line end point y.

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Fill Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.Fill Property
ParametricLine Class See Also Send Feedback
Get the Fill property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SolidColorBrush Fill { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fill As SolidColorBrush
Visual C++
public:
property SolidColorBrush^ Fill {
    SolidColorBrush^ get ();
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Line Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.Line Property
ParametricLine Class See Also Send Feedback
Get the line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public Line Line { get; }
Visual Basic (Declaration)
Public ReadOnly Property Line As Line
Visual C++
public:
property Line^ Line {
    Line^ get ();
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


X1 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.X1 Property
ParametricLine Class See Also Send Feedback
Get the line start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double X1 { get; set; }
Visual Basic (Declaration)
Public Property X1 As Double
Visual C++
public:
property double X1 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


X2 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.X2 Property
ParametricLine Class See Also Send Feedback
Get the line end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double X2 { get; set; }
Visual Basic (Declaration)
Public Property X2 As Double
Visual C++
public:
property double X2 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.XamlTag Property
ParametricLine Class See Also Send Feedback
Get the xaml tag of ParametricLine.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y1 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.Y1 Property
ParametricLine Class See Also Send Feedback
Get the line start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Y1 { get; set; }
Visual Basic (Declaration)
Public Property Y1 As Double
Visual C++
public:
property double Y1 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y2 Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
ParametricLine..::.Y2 Property
ParametricLine Class See Also Send Feedback
Get the line end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public double Y2 { get; set; }
Visual Basic (Declaration)
Public Property Y2 As Double
Visual C++
public:
property double Y2 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList Class
Members See Also Send Feedback
The holder of the Range series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class RangeChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class RangeChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class RangeChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.RangeChartSeriesList

See Also

RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList Members
RangeChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The RangeChartSeriesList type exposes the following members.

Constructors

Name | Description
RangeChartSeriesList | Initializes a new instance of the RangeChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of RangeSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeList | Get the list of Chart range series.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RangeSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList Constructor
RangeChartSeriesList Class See Also Send Feedback
Initializes a new instance of the RangeChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public RangeChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RangeChartSeriesList()

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList Methods
RangeChartSeriesList Class See Also Send Feedback

The RangeChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of RangeSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.AnySibling Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.GetProperty Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.GetRectangle Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.Highlight Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.InitializeMappings Method
RangeChartSeriesList Class See Also Send Feedback
Initializes the mapping of RangeSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.InvokeMethod Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.NextSibling Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.Parent Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.PreviousSibling Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.ScrollToVisible Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList Properties
RangeChartSeriesList Class See Also Send Feedback

The RangeChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeList | Get the list of Chart range series.
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RangeSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.RangeList Property
RangeChartSeriesList Class See Also Send Feedback
Get the list of Chart range series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesRange> RangeList { get; }
Visual Basic (Declaration)
Public ReadOnly Property RangeList As IList(Of ChartSeriesRange)
Visual C++
public:
property IList<ChartSeriesRange^>^ RangeList {
    IList<ChartSeriesRange^>^ get ();
}

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
RangeChartSeriesList..::.XamlTag Property
RangeChartSeriesList Class See Also Send Feedback
Get the xaml tag of RangeSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList Class
Members See Also Send Feedback
The holder of the SplineArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SplineAreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class SplineAreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class SplineAreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.SplineAreaChartSeriesList

See Also

SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList Members
SplineAreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The SplineAreaChartSeriesList type exposes the following members.

Constructors

Name | Description
SplineAreaChartSeriesList | Initializes a new instance of the SplineAreaChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineAreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplineAreaList | Get the list of Chart splineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineAreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList Constructor
SplineAreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the SplineAreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SplineAreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineAreaChartSeriesList()

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList Methods
SplineAreaChartSeriesList Class See Also Send Feedback

The SplineAreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineAreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.AnySibling Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.GetProperty Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.GetRectangle Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.Highlight Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.InitializeMappings Method
SplineAreaChartSeriesList Class See Also Send Feedback
Initializes the mapping of SplineAreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.InvokeMethod Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.NextSibling Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.Parent Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.PreviousSibling Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.ScrollToVisible Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList Properties
SplineAreaChartSeriesList Class See Also Send Feedback

The SplineAreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplineAreaList | Get the list of Chart splineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineAreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.SplineAreaList Property
SplineAreaChartSeriesList Class See Also Send Feedback
Get the list of Chart splineArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesSplineArea> SplineAreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineAreaList As IList(Of ChartSeriesSplineArea)
Visual C++
public:
property IList<ChartSeriesSplineArea^>^ SplineAreaList {
    IList<ChartSeriesSplineArea^>^ get ();
}

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineAreaChartSeriesList..::.XamlTag Property
SplineAreaChartSeriesList Class See Also Send Feedback
Get the xaml tag of SplineAreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList Class
Members See Also Send Feedback
The holder of the Spline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SplineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class SplineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class SplineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.SplineChartSeriesList

See Also

SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList Members
SplineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The SplineChartSeriesList type exposes the following members.

Constructors

Name | Description
SplineChartSeriesList | Initializes a new instance of the SplineChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplineList | Get the list of Chart spline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList Constructor
SplineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the SplineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SplineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineChartSeriesList()

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList Methods
SplineChartSeriesList Class See Also Send Feedback

The SplineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.AnySibling Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.GetProperty Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.GetRectangle Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.Highlight Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.InitializeMappings Method
SplineChartSeriesList Class See Also Send Feedback
Initializes the mapping of SplineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.InvokeMethod Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.NextSibling Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.Parent Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.PreviousSibling Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.ScrollToVisible Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList Properties
SplineChartSeriesList Class See Also Send Feedback

The SplineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplineList | Get the list of Chart spline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.SplineList Property
SplineChartSeriesList Class See Also Send Feedback
Get the list of Chart spline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesSpline> SplineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineList As IList(Of ChartSeriesSpline)
Visual C++
public:
property IList<ChartSeriesSpline^>^ SplineList {
    IList<ChartSeriesSpline^>^ get ();
}

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineChartSeriesList..::.XamlTag Property
SplineChartSeriesList Class See Also Send Feedback
Get the xaml tag of SplineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList Class
Members See Also Send Feedback
The holder of the SplineRange series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class SplineRangeChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class SplineRangeChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class SplineRangeChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.SplineRangeChartSeriesList

See Also

SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList Members
SplineRangeChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The SplineRangeChartSeriesList type exposes the following members.

Constructors

Name | Description
SplineRangeChartSeriesList | Initializes a new instance of the SplineRangeChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineRangeSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplineRangeList | Get the list of Chart splineRange series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineRangeSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList Constructor
SplineRangeChartSeriesList Class See Also Send Feedback
Initializes a new instance of the SplineRangeChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public SplineRangeChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineRangeChartSeriesList()

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList Methods
SplineRangeChartSeriesList Class See Also Send Feedback

The SplineRangeChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of SplineRangeSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.AnySibling Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.GetProperty Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.GetRectangle Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.Highlight Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.InitializeMappings Method
SplineRangeChartSeriesList Class See Also Send Feedback
Initializes the mapping of SplineRangeSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.InvokeMethod Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.NextSibling Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.Parent Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.PreviousSibling Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.ScrollToVisible Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList Properties
SplineRangeChartSeriesList Class See Also Send Feedback

The SplineRangeChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
SplineRangeList | Get the list of Chart splineRange series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of SplineRangeSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.SplineRangeList Property
SplineRangeChartSeriesList Class See Also Send Feedback
Get the list of Chart splineRange series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesSplineRange> SplineRangeList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineRangeList As IList(Of ChartSeriesSplineRange)
Visual C++
public:
property IList<ChartSeriesSplineRange^>^ SplineRangeList {
    IList<ChartSeriesSplineRange^>^ get ();
}

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
SplineRangeChartSeriesList..::.XamlTag Property
SplineRangeChartSeriesList Class See Also Send Feedback
Get the xaml tag of SplineRangeSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList Class
Members See Also Send Feedback
The holder of the StackedArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class StackedArea100ChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedArea100ChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedArea100ChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedArea100ChartSeriesList

See Also

StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList Members
StackedArea100ChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedArea100ChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedArea100ChartSeriesList | Initializes a new instance of the StackedArea100ChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedArea100Series. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedArea100List | Get the list of Chart stackedArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedArea100Series. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList Constructor
StackedArea100ChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedArea100ChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackedArea100ChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedArea100ChartSeriesList()

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList Methods
StackedArea100ChartSeriesList Class See Also Send Feedback

The StackedArea100ChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedArea100Series. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.AnySibling Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.GetProperty Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.GetRectangle Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.Highlight Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.InitializeMappings Method
StackedArea100ChartSeriesList Class See Also Send Feedback
Initializes the mapping of StackedArea100Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.InvokeMethod Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.NextSibling Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.Parent Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.PreviousSibling Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.ScrollToVisible Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList Properties
StackedArea100ChartSeriesList Class See Also Send Feedback

The StackedArea100ChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedArea100List | Get the list of Chart stackedArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedArea100Series. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100List Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.StackedArea100List Property
StackedArea100ChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedArea100> StackedArea100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedArea100List As IList(Of ChartSeriesStackedArea100)
Visual C++
public:
property IList<ChartSeriesStackedArea100^>^ StackedArea100List {
    IList<ChartSeriesStackedArea100^>^ get ();
}

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedArea100ChartSeriesList..::.XamlTag Property
StackedArea100ChartSeriesList Class See Also Send Feedback
Get the xaml tag of StackedArea100Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList Class
Members See Also Send Feedback
The holder of the StackedArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class StackedAreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedAreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedAreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedAreaChartSeriesList

See Also

StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList Members
StackedAreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedAreaChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedAreaChartSeriesList | Initializes a new instance of the StackedAreaChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedAreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedAreaList | Get the list of Chart stackedArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedAreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList Constructor
StackedAreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedAreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackedAreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedAreaChartSeriesList()

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList Methods
StackedAreaChartSeriesList Class See Also Send Feedback

The StackedAreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedAreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.AnySibling Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.GetProperty Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.GetRectangle Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.Highlight Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.InitializeMappings Method
StackedAreaChartSeriesList Class See Also Send Feedback
Initializes the mapping of StackedAreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.InvokeMethod Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.NextSibling Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.Parent Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.PreviousSibling Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.ScrollToVisible Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList Properties
StackedAreaChartSeriesList Class See Also Send Feedback

The StackedAreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedAreaList | Get the list of Chart stackedArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedAreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.StackedAreaList Property
StackedAreaChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedArea> StackedAreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedAreaList As IList(Of ChartSeriesStackedArea)
Visual C++
public:
property IList<ChartSeriesStackedArea^>^ StackedAreaList {
    IList<ChartSeriesStackedArea^>^ get ();
}

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedAreaChartSeriesList..::.XamlTag Property
StackedAreaChartSeriesList Class See Also Send Feedback
Get the xaml tag of StackedAreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList Class
Members See Also Send Feedback
The holder of the stacked line series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class StackedLineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedLineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedLineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedLineChartSeriesList

See Also

StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList Members
StackedLineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedLineChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedLineChartSeriesList | Initializes a new instance of the StackedLineChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedLineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedLineList | Get the list of Chart stackedLine series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedLineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList Constructor
StackedLineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedLineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackedLineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedLineChartSeriesList()

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList Methods
StackedLineChartSeriesList Class See Also Send Feedback

The StackedLineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedLineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.AnySibling Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.GetProperty Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.GetRectangle Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.Highlight Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.InitializeMappings Method
StackedLineChartSeriesList Class See Also Send Feedback
Initializes the mapping of StackedLineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.InvokeMethod Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.NextSibling Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.Parent Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.PreviousSibling Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.ScrollToVisible Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList Properties
StackedLineChartSeriesList Class See Also Send Feedback

The StackedLineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedLineList | Get the list of Chart stackedLine series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedLineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.StackedLineList Property
StackedLineChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedLine series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedLine> StackedLineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedLineList As IList(Of ChartSeriesStackedLine)
Visual C++
public:
property IList<ChartSeriesStackedLine^>^ StackedLineList {
    IList<ChartSeriesStackedLine^>^ get ();
}

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedLineChartSeriesList..::.XamlTag Property
StackedLineChartSeriesList Class See Also Send Feedback
Get the xaml tag of StackedLineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList Class
Members See Also Send Feedback
The holder of the Stacked Spline Area 100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class StackedSplineArea100ChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedSplineArea100ChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedSplineArea100ChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedSplineArea100ChartSeriesList

See Also

StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList Members
StackedSplineArea100ChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedSplineArea100ChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedSplineArea100ChartSeriesList | Initializes a new instance of the StackedSplineArea100ChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineArea100Series. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedSplineArea100List | Get the list of Chart stackedSplineArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineArea100Series. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList Constructor
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedSplineArea100ChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackedSplineArea100ChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedSplineArea100ChartSeriesList()

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList Methods
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

The StackedSplineArea100ChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineArea100Series. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.AnySibling Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.GetProperty Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.GetRectangle Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.Highlight Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.InitializeMappings Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
Initializes the mapping of StackedSplineArea100Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.InvokeMethod Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.NextSibling Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.Parent Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.PreviousSibling Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.ScrollToVisible Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList Properties
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

The StackedSplineArea100ChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedSplineArea100List | Get the list of Chart stackedSplineArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineArea100Series. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100List Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.StackedSplineArea100List Property
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedSplineArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedSplineArea100> StackedSplineArea100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineArea100List As IList(Of ChartSeriesStackedSplineArea100)
Visual C++
public:
property IList<ChartSeriesStackedSplineArea100^>^ StackedSplineArea100List {
    IList<ChartSeriesStackedSplineArea100^>^ get ();
}

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineArea100ChartSeriesList..::.XamlTag Property
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
Get the xaml tag of StackedSplineArea100Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList Class
Members See Also Send Feedback
The holder of the Stacked Spline Area series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class StackedSplineAreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedSplineAreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedSplineAreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedSplineAreaChartSeriesList

See Also

StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList Members
StackedSplineAreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedSplineAreaChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedSplineAreaChartSeriesList | Initializes a new instance of the StackedSplineAreaChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineAreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedSplineAreaList | Get the list of Chart stackedSplineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineAreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList Constructor
StackedSplineAreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedSplineAreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackedSplineAreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedSplineAreaChartSeriesList()

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList Methods
StackedSplineAreaChartSeriesList Class See Also Send Feedback

The StackedSplineAreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineAreaSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.AnySibling Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.GetProperty Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.GetRectangle Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.Highlight Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.InitializeMappings Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback
Initializes the mapping of StackedSplineAreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.InvokeMethod Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.NextSibling Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.Parent Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.PreviousSibling Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.ScrollToVisible Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList Properties
StackedSplineAreaChartSeriesList Class See Also Send Feedback

The StackedSplineAreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedSplineAreaList | Get the list of Chart stackedSplineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineAreaSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.StackedSplineAreaList Property
StackedSplineAreaChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedSplineArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedSplineArea> StackedSplineAreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineAreaList As IList(Of ChartSeriesStackedSplineArea)
Visual C++
public:
property IList<ChartSeriesStackedSplineArea^>^ StackedSplineAreaList {
    IList<ChartSeriesStackedSplineArea^>^ get ();
}

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineAreaChartSeriesList..::.XamlTag Property
StackedSplineAreaChartSeriesList Class See Also Send Feedback
Get the xaml tag of StackedSplineAreaSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList Class
Members See Also Send Feedback
The holder of the Stacked Spline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public class StackedSplineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedSplineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedSplineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
ArtOfTest.WebAii.Silverlight..::.AutomationObject<(Of <(FrameworkElement>)>)
ArtOfTest.WebAii.Silverlight..::.FrameworkElement
ArtOfTest.WebAii.Silverlight.UI..::.ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedSplineChartSeriesList

See Also

StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList Members
StackedSplineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedSplineChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedSplineChartSeriesList | Initializes a new instance of the StackedSplineChartSeriesList class.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedSplineList | Get the list of Chart stackedSpline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList Constructor
StackedSplineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedSplineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public StackedSplineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedSplineChartSeriesList()

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList Methods
StackedSplineChartSeriesList Class See Also Send Feedback

The StackedSplineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As<(Of <(T>)>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
CastAs<(Of <(T>)>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Highlight | Overloaded.
InitializeMappings | Initializes the mapping of StackedSplineSeries. (Overrides FrameworkElement..::.InitializeMappings(MappingsCollection).)
Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.AnySibling Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling<(Of <(T>)>)()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.GetProperty Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.GetRectangle Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.Highlight Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | Highlight this element. (Inherited from FrameworkElement.)
Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InitializeMappings Method

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.InitializeMappings Method
StackedSplineChartSeriesList Class See Also Send Feedback
Initializes the mapping of StackedSplineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic (Declaration)
Public Overrides Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
) override

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::.MappingsCollection
The framework mappings collection.

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.InvokeMethod Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.NextSibling Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling<(Of <(T>)>)()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.Parent Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | Get the parent framework element (Inherited from FrameworkElement.)
Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.PreviousSibling Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling<(Of <(T>)>)()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.ScrollToVisible Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList Properties
StackedSplineChartSeriesList Class See Also Send Feedback

The StackedSplineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
StackedSplineList | Get the list of Chart stackedSpline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
TextContent | Gets the text content of this framework element if any. (Inherited from FrameworkElement.)
UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from FrameworkElement.)
User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of StackedSplineSeries. (Overrides FrameworkElement..::.XamlTag.)
XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineList Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.StackedSplineList Property
StackedSplineChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedSpline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public IList<ChartSeriesStackedSpline> StackedSplineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineList As IList(Of ChartSeriesStackedSpline)
Visual C++
public:
property IList<ChartSeriesStackedSpline^>^ StackedSplineList {
    IList<ChartSeriesStackedSpline^>^ get ();
}

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls (ASP.NET AJAX and Silverlight)
StackedSplineChartSeriesList..::.XamlTag Property
StackedSplineChartSeriesList Class See Also Send Feedback
Get the xaml tag of StackedSplineSeries.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.3.1208.20 (2009.3.1208.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace